Wwise Unity Integration Documentation: Wwise Unity 통합

Wwise Unity Integration Documentation
Wwise Unity 통합

Wwise Unity 통합은 Unity 게임에서 Wwise Sound Engine을 사용하도록 해주는 다양한 리소스를 모아놓은 것입니다. 이 문서의 다른 부분에서는 'Integration(통합)'이라고 불립니다. 이 통합은 Unity 플러그인 라이브러리, C::에서의 Wwise SDK API 바인딩, 그리고 여러 가지 유용한 컴포넌트와 Editor 창으로 구성되어 있습니다. Wwise SDK의 기본 기능을 이해하려면 온라인이나 Wwise 설치와 함께 제공되는 CHM을 통해 설명서를 참조하세요.

이 Integration 설명서는 Unity-Wwise 통합과 Wwise API에 대한 정보를 제공합니다. Wwise 저작 애플리케이션 (사운드 디자이너용)에 대한 정보는 온라인이나 로컬 컴퓨터에 설치된 문서 (보통 C:\Program Files(x86)\Audiokinetic\Wwise [version] \Authoring\Help 에 있습니다)를 참조하세요.

  • 릴리즈 노트 - Wwise Unity 통합 2023.1.1.8417.3007
  • 이전 버전 릴리즈 노트
  • Unity 프로젝트에서 통합 설치/업그레이드하기
  • Wwise Integration Package 제거하기
  • Unity Editor Settings 조정하기
  • Wwise Initialization Settings 조정하기
  • SoundBank 관리하기
  • Wwise Unity 통합 사용하기
    • Wwise Picker
    • WAAPI 유틸리티
  • 원하는 플랫폼으로 Unity 게임 빌드하기
  • Wwise와 Unity에서 DLC 만들기
  • 소스 코드에서 네이티브 Integration 플러그인 빌드하기
  • Enter Play Mode 작동 방식
  • API 변경 및 제한 사항
  • 플랫폼별 정보
  • 데모 게임
  • Unity에서의 Spatial Audio
  • Unity용 Wwise Addressables Package
    • Wwise Unity Addressables 패키지 설치하기
    • Packaging DLC 기본 튜토리얼
    • Wwise Addressable Samples
  • 문제 해결

연락처

이 통합에 대해 궁금한 내용이 있으시면 Q&A 커뮤니티 포럼에 글을 작성해주세요. 지원 패키지를 구매하셨을 경우 고객 지원팀에 연락해주세요.

참고
  • Audiokinetic 런처: Unity 프로젝트에 Wwise 통합하기
  • Wwise-301: Wwise Unity 통합


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2023.1.1.8417.3007

릴리즈 노트 - Wwise Unity 통합 2023.1.1.8417.3007

이 배포는 Wwise 2023.1.1 을(를) 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2023.1.1
  • Unity: 이 통합은 Unity 2023.2.3f1로 테스트되었습니다. 최소 지원 버전은 2020.3이며 최고 지원 버전은 2023.2입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 성능 개선 사항
  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

성능 개선 사항

  • WG-69395 WG-68992에서 도입된 Memory Span Count 설정에 대한 지원이 Advanced Settings에 추가되었습니다. 이는 전체 CPU 성능에 대한 적은 비용으로 Wwise가 예약하는 메모리 양을 크게 줄이는 데 사용됩니다.

기타 수정 사항

  • WG-68202 Reverb Zone의 Transition Region의 기본값을 0이 아닌 값으로 변경했습니다.

버그 수정

  • WG-68461 수정됨: (Spatial Audio) Reverb Zone에서 Transition Region을 활성화하려면 AKSurfaceReflector 구성 요소가 필요함.
  • WG-68629 수정됨: Unity에서 사운드 엔진 오류가 출력될 때 크래시 발생.
  • WG-68716 수정됨: (Spatial Audio) 형제 Reverb Zone을 연결하는 Portal이 유효하지 않음에도 불구하고 빨간색으로 표시되지 않음.
  • WG-68980 수정됨: (Spatial Audio) 동일한 앞 Room과 뒤 Room을 유지한 채 이동해도 Portal이 업데이트되지 않음.

커뮤니티에 보고된 버그 수정

  • WG-69036 Fixed: InvalidOperationException in Unity when the debugger is attached.
  • WG-69340 수정됨: 편집기를 시작할 때 가끔 ProjectData 생성이 실패함.
  • WG-69422 수정됨: (Spatial Audio) Unity Portal이 초기 상태에서 닫혀 있으면 열리지 않음.


Wwise Unity Integration Documentation: 이전 버전 릴리즈 노트

이전 버전 릴리즈 노트

다음 페이지에서는 이전 릴리즈에서 만들어진 통합의 변경 사항에 대한 정보를 제공합니다.

  • 릴리즈 노트 - Wwise Unity 통합 2023.1.0.8367.2953
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.9.8365.2941
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.8.8316.2888
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.7.8290.2858
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.6.8263.2826
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.5.8242.2798
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.4.8200.2750
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.3.8179.2728
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.2.8150.2694
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.1.8100.2644
  • 릴리즈 노트 - Wwise Unity 통합 2022.1.0.8070.2611
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.14.8108.2676
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.13.8036.2602
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.12.7973.2529
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.11.7933.2488
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.10.7883.2429
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.9.7847.2389
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.8.7831.2373
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.7.7796.2335
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.6.7774.2308
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.5.7749.2277
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.4.7707.2232
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.3.7665.2179
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.2.7629.2141
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.1.7601.2102
  • 릴리즈 노트 - Wwise Unity 통합 2021.1.0.7575.2069
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.15.7667.2215
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.14.7616.2152
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.13.7577.2104
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.12.7544.2058
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.11.7512.2017
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.10.7490.1989
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.9.7459.1949
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.8.7432.1919
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.7.7402.1888
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.6.7381.1867
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.5.7349.1831
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.4.7329.1806
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.3.7304.1778
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.2.7275.1749
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.1.7250.1718
  • 릴리즈 노트 - Wwise Unity 통합 2019.2.0.7216.1681
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.11.7296.1786
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.10.7250.1738
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.9.7221.1704
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.8.7173.1654
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.7.7135.1611
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.6.7110.1585
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.5.7093.1568
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.4.7065.1538
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.3.7048.1516
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1481
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1480
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.1.6977.1430
  • 릴리즈 노트 - Wwise Unity 통합 2019.1.0.6947.1394
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.6.6858.1313
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.5.6835.1288
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.4.6807.1258
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.3.6784.1233
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.2.6762.1211
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.1.6727.1172
  • 릴리즈 노트 - Wwise Unity 통합 2018.1.0.6714.1154
    • 새로운 기능 2018.1
  • Release Notes - Wwise Unity Integration 2017.2.9.6726.1210
  • Release Notes - Wwise Unity Integration 2017.2.8.6698.1171
  • Release Notes - Wwise Unity Integration 2017.2.7.6661.1133
  • Release Notes - Wwise Unity Integration 2017.2.6.6636.1107
  • Release Notes - Wwise Unity Integration 2017.2.5.6619.1090
  • Release Notes - Wwise Unity Integration 2017.2.4.6590.1064
  • Release Notes - Wwise Unity Integration 2017.2.4.6590.1054
  • Release Notes - Wwise Unity Integration 2017.2.3.6575.1037
  • Release Notes - Wwise Unity Integration 2017.2.2.6553.1015
  • Release Notes - Wwise Unity Integration 2017.2.1.6524.980
  • 릴리즈 노트 - Wwise Unity 통합 2017.2.0.6500.947
    • 새로운 기능 2017.2
    • 중요한 마이그레이션 참고 사항 2017.2
  • Release Notes - Wwise Unity Integration 2017.1.9.6501.947
  • Release Notes - Wwise Unity Integration 2017.1.8.6488.933
  • Release Notes - Wwise Unity Integration 2017.1.7.6467.910
  • Release Notes - Wwise Unity Integration 2017.1.6.6446.890
  • Release Notes - Wwise Unity Integration 2017.1.5.6429.870
  • Release Notes - Wwise Unity Integration 2017.1.4.6407.845
  • Release Notes - Wwise Unity Integration 2017.1.3.6377.812
  • Release Notes - Wwise Unity Integration 2017.1.2.6361.791
  • Release Notes - Wwise Unity Integration 2017.1.1.6340.770
  • Release Notes - Wwise Unity Integration 2017.1.0.6302.726
    • New Features 2017.1
    • Important Migration Notes 2017.1
  • Release Notes - Wwise Unity Integration 2016.2.6.6153.595
  • Release Notes - Wwise Unity Integration 2016.2.5.6121.560
  • Release Notes - Wwise Unity Integration 2016.2.4.6098.531
  • Release Notes - Wwise Unity Integration 2016.2.3.6077.504
  • Release Notes - Wwise Unity Integration 2016.2.2.6022.430
  • Release Notes - Wwise Unity Integration 2016.2.1.5995.409
  • Release Notes - Wwise Unity Integration 2016.2.1
  • Release Notes - Wwise Unity Integration 2016.2.0
  • Release Notes - Wwise Unity Integration 2016.1.6
  • Release Notes - Wwise Unity Integration 2016.1.5
  • Release Notes - Wwise Unity Integration 2016.1.4
  • Release Notes - Wwise Unity Integration 2016.1.3
  • Release Notes - Wwise Unity Integration 2016.1.2
  • Release Notes - Wwise Unity Integration 2016.1.1
  • Release Notes - Wwise Unity Integration 2016.1
  • Release Notes - Wwise Unity Integration 2015.1.9
  • Release Notes - Wwise Unity Integration 2015.1.8
  • Release Notes - Wwise Unity Integration 2015.1.7
  • Release Notes - Wwise Unity Integration 2015.1.6
  • Release Notes - Wwise Unity Integration 2015.1.5
  • Release Notes - Wwise Unity Integration 2015.1.4
  • Release Notes - Wwise Unity Integration 2015.1.3
  • Release Notes - Wwise Unity Integration 2015.1.2
  • Release Notes - Wwise Unity Integration 2015.1.1
  • Release Notes - Wwise Unity Integration 2015.1
  • Release Notes - Wwise Unity Integration 2014.1.6
  • Release Notes - Wwise Unity Integration 2014.1.5
  • Release Notes - Wwise Unity Integration 2014.1.4
  • Release Notes - Wwise Unity Integration 2014.1.3
  • Release Notes - Wwise Unity Integration 2014.1.2
  • Release Notes - Wwise Unity Integration 2014.1.1
  • Release Notes - Wwise Unity Integration 2014.1
  • Release Notes - Wwise Unity Integration 2013.2.10
  • Release Notes - Wwise Unity Integration 2013.2.9
  • Release Notes - Wwise Unity Integration 2013.2.8
  • Release Notes - Wwise Unity Integration 2013.2.5
  • Release Notes - Wwise Unity Integration 2013.2.4
  • Release Notes - Wwise Unity Integration 2013.2.1
  • Release Notes - Wwise Unity Integration 2013.1.1
  • Release Notes - Wwise Unity Integration 2013.1


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2023.1.0.8367.2953

릴리즈 노트 - Wwise Unity 통합 2023.1.0.8367.2953

이 릴리즈는 Wwise 2023.1.0을 위한 Wwise SDK 업데이트를 제공합니다.

  • 중요한 마이그레이션 참고 사항 2023.1

호환성:

  • Wwise SDK: 2023.1.0
  • Unity: 이 통합은 Unity 2022.3.2f1로 테스트되었습니다. 최소 지원 버전은 2020.3이며 최고 지원 버전은 2023.2입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • API 개선 사항
  • 작동 방식 변경 사항
  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-51085 Enter Play Mode 지원을 추가함.
  • WG-53593 게임이 포커스를 잃을 때 오디오를 일시 중지하지 않는 옵션을 추가함.
  • WG-65226 3D 뷰어에서 전환 구역을 표시하는 옵션을 추가함.

API 개선 사항

  • WG-64048 (Spatial Audio) 단일 이미터에서 발생할 수 있는 게임에서 정의한 보조 센드의 최대 개수를 제한하는 AkSpatialAudioInitSettings::uMaxEmitterRoomAuxSends를 추가함.
  • WG-65130 (Spatial Audio) AkGeometryParams::EnableTriangles를 제거하고 AkGeometryInstanceParams::UseForReflectionAndDiffraction으로 교체함.
  • WG-66244 (Spatial Audio) AkGeometryInstanceParams::RoomID 사용이 이제 추후 버전에서는 사용이 중단되며 해당 매개 변수가 추후 버전에서 제거됨. RoomID를 사용하지 말고 기본값(-1)으로 남겨두세요.

작동 방식 변경 사항

  • WG-65242 Wwise Initialization Settings 사용자 경험을 개선함.

기타 수정 사항

  • WG-66693 Wwise Unity 통합 사용시 Audiokinetic 런처 2023.1.1 또는 그 이상 버전 필요.

버그 수정

  • WG-66259 수정됨: 'Load Sound Engine in Edit Mode'가 비활성화된 채로 Play Session을 중단할 경우 'Failed load Init.bnk with result: AK_Fail' 오류가 뜸.
  • WG-68085 수정됨: Play 모드에 들어가면 Wwise Picker가 비어 있음.

커뮤니티에 보고된 버그 수정

  • WG-56018 수정됨: AkRoom이 원치 않는 물리적 상호 작용을 발생시킴.
  • WG-61124 수정됨: 사운드에서 스트리밍이 비활성화되있을 경우 Addressables Group이 올바르게 업데이트되지 않음.


Wwise Unity Integration Documentation: 중요한 마이그레이션 참고 사항 2023.1

중요한 마이그레이션 참고 사항 2023.1

Spatial Audio

연속적 레이 캐스팅

Spatial Audio는 레이트레이싱 엔진을 사용하여 리플렉션과 회절 경로를 평가합니다. 이전 Wwise 버전에서는 이미터나 리스너의 움직임이 미리 정의된 한계점(Movement Threshold Spatial Audio Setting 참고)을 초과했을 경우 캐스팅되는 광선의 개수와 리플렉션 및 회절 경로가 다시 계산됩니다. 이 레이 캐스트와 재계산이 조합되어 프레임에서의 로드가 증가해서 CPU 피크가 발생했습니다. Wwise 2023.1에서는 재계산이 트리거될 때까지 각 프레임에서 광선이 계속해서 캐스팅됩니다. 이렇게 하면 레이 캐스팅의 로드를 여러 프레임에 걸쳐 분산시켜서 CPU 피크를 방지합니다.

이러한 이유로Number Of Primary Rays Spatial Audio Setting의 default value(기본값)이 100에서 35로 감소했습니다. 마이그레이션 후 프로젝트에서 주요 광선의 선호 개수를 다시 검토하세요.

방수 지오메트리

23.1에서 전환 구역의 봉쇄와 접근성을 계산하기 위해 Room의 Geometry가 방수되도록 하는 새로운 Spatial Audio 기능이 소개되었습니다. 즉 Geometry에 구멍이 하나도 없으며 모든 모서리가 정확히 두 삼각형을 연결합니다. Room이 Spatial Audio로 전송될 때 Room의 Geometry는 경계 모서리를 검색합니다. 경계 모서리를 찾으면 Geometry가 방수되지 않기 때문에 오류 메시지가 뜹니다.

Room에 Reverb Zone이 있으면 해당 Geometry는 반드시 방수되어야 합니다. 오류 메시지가 뜰 경우 구멍이나 경계 모서리가 있는지 확인하여 Geometry를 수정하세요. 구멍은 Transmission Loss 값이 0인 표면으로 덮을 수 있습니다. 구멍이 보이지 않는다면 서로 겹치는 모서리나 표면으로 인한 경계 모서리가 있는지 찾아보세요.

또한 Spatial Audio를 사용하여 공간 봉쇄를 할 경우에도 방수 Geometry를 가지는 것이 중요합니다. 하지만 Unity 통합은 이 기능을 기본적으로 사용하지 않습니다. 다른 상황에서는 이 오류 메시지를 무시하셔도 됩니다.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.9.8365.2941

릴리즈 노트 - Wwise Unity 통합 2022.1.9.8365.2941

이 릴리즈는 Wwise 2022.1.9를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.9
  • Unity: 이 통합은 Unity 2022.2.2f1와 2022.3.2f1로 테스트되었습니다. 최소 지원 버전은 2020.3이며 최고 지원 버전은 2023.2입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • 버그 수정

새로운 기능

  • WG-53593 게임이 포커스를 잃을 때 오디오를 일시 중지하지 않는 옵션을 추가함.

버그 수정

  • WG-68085 수정됨: Play 모드에 들어가면 Wwise Picker가 비어 있음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.8.8316.2888

릴리즈 노트 - Wwise Unity 통합 2022.1.8.8316.2888

이 릴리즈는 Wwise 2022.1.8을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.8
  • Unity: 이 통합은 Unity 2022.2.2f1와 2022.3.2f1로 테스트되었습니다. 최소 지원 버전은 2020.3이며 최고 지원 버전은 2023.2입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-67267 수정됨: XMLErrorTranslator의 s_reader가 초기화되지 않는 경우가 있음.

커뮤니티에 보고된 버그 수정

  • WG-64307 수정됨: 표현식이나 파일 이름에서 일정 문자 수를 초과하면 AkUnityAssertHook()가 assert를 일으킴.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.7.8290.2858

릴리즈 노트 - Wwise Unity 통합 2022.1.7.8290.2858

이 릴리즈는 Wwise 2022.1.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.7
  • Unity: 이 통합은 Unity 2022.2.2f1와 2022.3.2f1로 테스트되었습니다. 최소 지원 버전은 2020.3이며 최고 지원 버전은 2023.2입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 커뮤니티에 보고된 버그 수정
  • 문서 개선 사항

커뮤니티에 보고된 버그 수정

  • WG-62495 수정됨: Wwise Unity Addressables 뱅크 관리자가 AK_BankAlreadyLoaded 결과를 올바르게 처리하지 않음.
  • WG-63623 수정됨: AVAudioSession.Playback 이 지원되지 않음.
  • WG-66686 수정됨: Wwise 프로젝트를 찾을 수 없는 경우 에셋 불러오기에 실패함.

문서 개선 사항

  • WG-66192 Addressables 패키지의 새로운 사용자 인터페이스와 일치하도록 Packaging DLC 기본 튜토리얼 을 업데이트.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.6.8263.2826

릴리즈 노트 - Wwise Unity 통합 2022.1.6.8263.2826

이 릴리즈는 Wwise 2022.1.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.6
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2022.1.6

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-66643 Unity Wwise 통합 사용시 Audiokinetic 런처 2023.1.1 또는 그 이상 버전 필요.

버그 수정

  • WG-66276 수정됨: Waapi Picker 콘텍스트 메뉴가 State와 Switch에서 열리지 않음.

커뮤니티에 보고된 버그 수정

  • WG-56968 수정됨: Triggers Game Sync가 Unity Wwise Picker에 표시되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.5.8242.2798

릴리즈 노트 - Wwise Unity 통합 2022.1.5.8242.2798

이 릴리즈는 Wwise 2022.1.5를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.5
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63104 수정됨: AkRoom 컴포넌트와 상호작용할 때 Cube가 예기치 않게 스폰됨.
  • WG-63120 수정됨: Unity Editor에서 Spatial Audio 컴포넌트 토글 후 Geometry Set 삭제 오류.
  • WG-63187 수정됨: (Spatial Audio) Geometry가 필요한 곳에서 업데이트되지 않음.
  • WG-65420 수정됨: 유효하지 않은 Portal 배치 메시지가 Warning이 아니라 Error로 보고됨.

커뮤니티에 보고된 버그 수정

  • WG-63156 수정됨: SoundbanksInfo.xml이 Unity 캐시로 저장되거나 파싱되지 않음.
  • WG-64381 수정됨:상태 전환(state transition)이 활성화돼있는 Switch Container가 포함된 SoundBank를 언로드할 때 Debug 구성에서 잘못된 assert 발생.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.4.8200.2750

릴리즈 노트 - Wwise Unity 통합 2022.1.4.8200.2750

이 릴리즈는 Wwise 2022.1.4를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.4
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-64673 수정됨: 디버그 빌드에 모든 사운드 엔진 디버그 심볼이 포함돼있지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.3.8179.2728

릴리즈 노트 - Wwise Unity 통합 2022.1.3.8179.2728

이 릴리즈는 Wwise 2022.1.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.3
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-63931 통합 C# 코드 파일에 누락되었던 Audiokinetic 저작권 정보 추가.

버그 수정

  • WG-63983 수정됨: RoomAwareObject를 활성화한 후 RoomAwareManager에서 NullReferenceException이 발생함.

커뮤니티에 보고된 버그 수정

  • WG-54630 수정됨: Wwise Unity Addressable이 있는 iOS 플랫폼에서 불필요한 SetBasePath 호출하면 오류 메시지를 로그함.
  • WG-63727 수정됨: Unity AkEmitterObstructionOcclusion 컴포넌트가 사운드를 즉시 차단하지 않음.
  • WG-64433 수정됨: FileSystemWatcher로 인하여 과도한 IO 호출이 발생함.
  • WG-64493 수정됨: Wwise Component Picker가 잘못된 화면 위치에서 놓임.
  • WG-64498 수정됨: 도메인을 다시 로드할 때 "Unable to load Wwise Data: UnityEngine.UnityException: LoadAssetAtPath can only be called from the main thread."의 오류가 발생함.
  • WG-64499 수정됨: Asset Import 프로세스의 성능 문제.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.2.8150.2694

릴리즈 노트 - Wwise Unity 통합 2022.1.2.8150.2694

이 릴리즈는 Wwise 2022.1.2를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.2
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2022.1.2

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63482 수정됨: Inspector에서 Event 재생 후, 다른 씬이 열린 다음 소리가 남.

커뮤니티에 보고된 버그 수정

  • WG-63469 수정됨: AkGameObj 컴포넌트를 프리팹에서 Environment Aware 속성으로 변경하는 내용이 저장되지 않음.
  • WG-64036 Wwise 2019.1 이상을 사용하는 프로젝트의 마이그레이션 속도 개선됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.1.8100.2644

릴리즈 노트 - Wwise Unity 통합 2022.1.1.8100.2644

이 릴리즈는 Wwise 2022.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.1
  • Unity: 이 통합은 Unity 2020.3, 2021.3 및 2022.1에 대해 컴파일됩니다. 2021.3.16f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2022.1.1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-62355 모범 사례에 따라 Unity Spatial Audio 코드 개선.

버그 수정

  • WG-62061 수정됨: (Spatial Audio) 재생 도중 공간을 움직이면 발생하는 Game Object 3D Viewer의 중복 공간 시각화
  • WG-62388 수정됨: (Spatial Audio) 이전에 AkGeometry 와 연관돼있던 공간이 제대로 업데이트되지 않음.
  • WG-62411 수정됨: (Spatial Audio) AkRoom 의 상위 GameObject 를 변환한 후 AkRoom 의 크기가 올바르게 변경되지 않음.
  • WG-62690 수정됨: 마이그레이션 후 Unity 콘솔에서 다음과 같은 오류가 나타남.
    • WwiseUnity: The platform SoundBank subfolder within the Wwise project could not be found.
    • WwiseUnity: <Assets> 플랫폼의 소스 폴더를 찾을 수 없음. Did you remember to generate your banks?
    • NullReferenceException: Object reference not set to an instance of an object
    • Asset import failed, "Assets/WwiseData/Banks/iOS/Subtitles.bnk" > NullReferenceException: Object reference not set to an instance of an object
  • WG-63116 수정됨: (Spatial Audio) 포털과 겹치는 지오메트리 세트를 업데이트하면 발생하는 교착 상태(deadlock).
  • WG-63119 수정됨: AkAmbient 를 중지시키면 발생하는 오류.

커뮤니티에 보고된 버그 수정

  • WG-62051 수정됨: AkGameObj 위치 오프셋의 수정 내용이 프리팹에 올바르게 저장되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2022.1.0.8070.2611

릴리즈 노트 - Wwise Unity 통합 2022.1.0.8070.2611

이 릴리즈는 Wwise 2022.1.0을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2022.1.0
  • Unity: 이 통합은 Unity 2020.3, 2021.3 및 2022.1에 대해 컴파일됩니다. 2021.2.17f1과 2022.1.8f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • API 개선 사항
  • 작동 방식 변경 사항
  • 기타 수정 사항
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-54310 자동 정의 SoundBank 옵션이 추가됨. 이를 활성화하면 Wwise가 가능한 경우 각 Event 및 Aux Bus에 대해 SoundBank를 자동으로 정의합니다. 자세한 내용은 SoundBank 자동 정의하기를 참고해 주세요.

자동 정의 SoundBank는 SoundBank Settings을 통해 활성화됩니다. 자세한 내용은 SoundBank Settings를 참고해 주세요.

  • WG-54685 사운드 엔진 처리 작업의 더 유연한 동시 실행을 위해 Task Scheduler API가 새로운 Job Manager로 대체됨.
  • WG-59193 새로운 오류 메시지 변환기와 관련하여 XML 및 WAAPI의 시간 초과 값을 조정하기 위해 두 개의 새로운 Wwise Editor Project Settings가 추가됨. 이 설정은 Wwise Error Message Translator라는 새로운 섹션에서 찾을 수 있습니다.

API 개선 사항

  • WG-55811 Wwise Demo Game에서 사용되는 WwiseSimpleExternalSourceManager라는 WwiseExternalSourceManager의 최소 구현을 추가함.
  • WG-56860 SetPosition과 SetMultiplePositions에 동일한 게임 오브젝트에 대해 이미터와 리스너 위치를 독립적으로 설정할 수 있는 새로운 in_eFlags 매개 변수가 추가됨.

작동 방식 변경 사항

  • WG-60908 모든 플랫폼에서 AkCommonUserSettings::m_SamplesPerFrame의 기본값을 512로 변경함. 이로 인해 Wwise의 기본 CPU 사용량이 약간 증가하지만 사운드 엔진의 총 오디오 레이턴시는 크게 줄어듭니다. 게임의 총 오디오 레이턴시와 사용 가능한 컴퓨팅 리소스의 균형을 맞추기 위해 'Samples Per Frame'과 'Number of Refills In Voice'를 조정하는 것이 좋습니다.

기타 수정 사항

  • WG-57028 숫자 유형이 이제 모든 플랫폼에서 stdint.h에 의해 제공됨.

커뮤니티에 보고된 버그 수정

  • WG-61295 수정됨: 기본 설정으로 서버 빌드에서 Unity 통합이 비활성화돼있음.
  • WG-61373 수정됨: (Wwise Unity Addressables) Init WwiseAddressableSoundBank가 삭제되고 재생성될 경우 열리지 않은 씬에서 Init 뱅크에 대한 참조가 무효화됨.
  • WG-62390 수정됨: WwiseAddressableSoundBank RefCount가 LoadCount >0로 병렬화될 수 있음. 해당 값은 더 이상 병렬화가 필요하지 않습니다.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.14.8108.2676

릴리즈 노트 - Wwise Unity 통합 2021.1.14.8108.2676

이 릴리즈는 Wwise 2021.1.14를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.14
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • 기타 수정 사항
  • 버그 수정

새로운 기능

  • WG-53593 게임이 포커스를 잃을 때 오디오를 일시 중지하지 않는 옵션을 추가함.

기타 수정 사항

  • WG-66693 Wwise Unity 통합 사용시 Audiokinetic 런처 2023.1.1 또는 그 이상 버전 필요.

버그 수정

  • WG-68085 수정됨: Play 모드에 들어가면 Wwise Picker가 비어 있음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.13.8036.2602

릴리즈 노트 - Wwise Unity 통합 2021.1.13.8036.2602

이 릴리즈는 Wwise 2021.1.13을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.13
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63983 수정됨: RoomAwareObject를 활성화한 후 RoomAwareManager에서 NullReferenceException이 발생함.

커뮤니티에 보고된 버그 수정

  • WG-54630 수정됨: Wwise Unity Addressable이 있는 iOS 플랫폼에서 불필요한 SetBasePath 호출하면 오류 메시지를 로그함.
  • WG-63727 수정됨: Unity AkEmitterObstructionOcclusion 컴포넌트가 사운드를 즉시 차단하지 않음.
  • WG-64036 수정됨: 마이그레이션에 오랜 시간이 걸림.
  • WG-64493 수정됨: Wwise Component Picker가 잘못된 화면 위치에서 놓임.
  • WG-64498 수정됨: 도메인을 다시 로드할 때 "Unable to load Wwise Data: UnityEngine.UnityException: LoadAssetAtPath can only be called from the main thread."의 오류가 발생함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.12.7973.2529

릴리즈 노트 - Wwise Unity 통합 2021.1.12.7973.2529

이 릴리즈는 Wwise 2021.1.12를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.12
  • Unity: 이 통합은 Unity 2020.3, 2021.3, 2022.1 및 2022.2에 대해 컴파일됩니다. 2022.2.2f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2021.1.12

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63119 수정됨: AkAmbient 를 중지시키면 발생하는 오류.

커뮤니티에 보고된 버그 수정

  • WG-62051 수정됨: AkGameObj 위치 오프셋의 수정 내용이 프리팹에 올바르게 저장되지 않음.
  • WG-63469 수정됨: AkGameObj 컴포넌트를 프리팹에서 Environment Aware 속성으로 변경하는 내용이 저장되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.11.7933.2488

릴리즈 노트 - Wwise Unity 통합 2021.1.11.7933.2488

이 릴리즈는 Wwise 2021.1.11을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.11
  • Unity: 이 통합은 Unity 2020.3, 2021.3 및 2022.1에 대해 컴파일됩니다. 2021.3.14f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2021.1.11

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 커뮤니티에 보고된 버그 수정

커뮤니티에 보고된 버그 수정

  • WG-61295 수정됨: 기본 설정으로 서버 빌드에서 Unity 통합이 비활성화돼있음.
  • WG-61373 수정됨: (Wwise Unity Addressables) Init WwiseAddressableSoundBank가 삭제되고 재생성될 경우 열리지 않은 씬에서 Init 뱅크에 대한 참조가 무효화됨.
  • WG-62390 수정됨: WwiseAddressableSoundBank RefCount가 LoadCount >0로 병렬화될 수 있음. 해당 값은 더 이상 병렬화가 필요하지 않습니다.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.10.7883.2429

릴리즈 노트 - Wwise Unity 통합 2021.1.10.7883.2429

이 릴리즈는 Wwise 2021.1.10을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.10
  • Unity: 이 통합은 Unity 2019.4, 2020.3 및 2021.3에 대해 컴파일됩니다. 2021.3.8f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-60348 수정됨: SetGameObjectRadius API 호출이 해당 Game Object ID를 리턴하지 않음.

커뮤니티에 보고된 버그 수정

  • WG-57736 수정됨: 명령줄을 사용하여 AkAmbient.cs가 필요한 에셋을 마이그레이션할 때 오류가 발생함.
  • WG-61133 수정됨: Wwise Project를 찾을 수 없는 경우 Unity 통합이 메모리를 누수시킬 수 있음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.9.7847.2389

릴리즈 노트 - Wwise Unity 통합 2021.1.9.7847.2389

이 릴리즈는 Wwise 2021.1.9를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.9
  • Unity: 이 통합은 Unity 2019.4, 2020.3 및 2021.2에 대해 컴파일됩니다. 2021.2.17f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-59609 수정됨: 특정 플랫폼에 대해 GenerateApiBinding.py를 호출할 때 잘못된 플랫폼을 요청하는 오류 메시지.
  • WG-60097 수정됨: Unity Editor에서 플레이할 때 SetGameObjectRadius가 모든 프레임에 호출됨.
  • WG-60099 수정됨: Unity 및 Unity Demo Game에서 Spatial Audio Initialization Setting Movement Threshold 기본값이 너무 높음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.8.7831.2373

릴리즈 노트 - Wwise Unity 통합 2021.1.8.7831.2373

이 릴리즈는 Wwise 2021.1.8을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.8
  • Unity: 이 통합은 Unity 2019.4, 2020.3 및 2021.2에 대해 컴파일됩니다. 2021.2.17f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2021.1.8

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-53953 Wwise 초기화 오류는 Local Output의 초기에 보고됨.

버그 수정

  • WG-59456 수정됨: Unity 2020에서 Default Room "Outdoors"에 설정된 게임 오브젝트가 잘못된 ID를 사용함.
  • WG-59563 수정됨: Unity Editor에서 SoundBank를 찾을 수 없는 경우 사운드 엔진 초기화 시 경고가 나오지 않음.
  • WG-59812 수정됨: AkRoom 톤이 OnDisable 내에서 재생될 때 Unity Editor가 충돌함.

커뮤니티에 보고된 버그 수정

  • WG-58413 수정됨: Unity에서 플레이하는 동안 공간을 비활성화할 때 'Unknown game object ID' 오류 메시지가 표시됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.7.7796.2335

릴리즈 노트 - Wwise Unity 통합 2021.1.7.7796.2335

이 릴리즈는 Wwise 2021.1.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.7
  • Unity: Unity 2019.4.22f1, 2020.3.1f1 (Personal 혹은 Pro).
    참고: 이 통합은 Unity 4를 지원하지 않습니다. 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac (에디터와 런타임) Windows (에디터와 런타임) Linux (런타임만) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-58565 Wwise 에셋에 대한 Addressables Metadata의 직렬화(serialization) 및 복원(restoration)을 수행하는 샘플 스크립트를 Addressables Package에 추가했습니다.

커뮤니티에 보고된 버그 수정

  • WG-54625 수정됨: Windows가 아닌 플랫폼에서 AkAddressableBankManager가 AK.Wwise.Unity.API.WwiseTypes 어셈블리 로드에 실패함.
  • WG-54627 수정됨: Addressables Wwise Build 스크립트가 에디터 플랫폼 에셋 번들에서만 빌드되며 WwiseAddressableSoundBank가 항상 대상 빌드 플랫폼이 아닌 Editor platform AssetReferences를 일련화함.
  • WG-58396 수정됨: Wwise Work Unit 구문 분석의 드문 경우 로깅이 제대로 되지 않음. Auto-Delete WwiseObjectReferences 설정을 추가하여 사용자가 Work Unit Parser에서 수행하는 에셋 삭제 작업을 비활성화할 수 있습니다.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.6.7774.2308

릴리즈 노트 - Wwise Unity 통합 2021.1.6.7774.2308

이 릴리즈는 Wwise 2021.1.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.6
  • Unity: Unity 2019.4.22f1, 2020.3.1f1 (Personal 혹은 Pro).
    참고: 이 통합은 Unity 4를 지원하지 않습니다. 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac (에디터와 런타임) Windows (에디터와 런타임) Linux (런타임만) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항

기타 수정 사항

  • WG-57492 MemoryAllocationSizeLimit(메모리 사용량 제한)과 MemoryDebugLevel(메모리 문제 디버깅)이라는 두 개의 초기화 설정이 표시됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.5.7749.2277

릴리즈 노트 - Wwise Unity 통합 2021.1.5.7749.2277

이 릴리즈는 Wwise 2021.1.5을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.5
  • Unity: Unity 2019.4.22f1, 2020.3.1f1 (Personal 혹은 Pro).
    참고: 이 통합은 Unity 4를 지원하지 않습니다. 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac (에디터와 런타임) Windows (에디터와 런타임) Linux (런타임만) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-56969 수정됨: 게임 시간의 두 번째 프레임 전까지 오프라인 렌더링을 시작할 수 없음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.4.7707.2232

릴리즈 노트 - Wwise Unity 통합 2021.1.4.7707.2232

이 릴리즈는 Wwise 2021.1.4을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.4
  • Unity: Unity 2019.4.22f1, 2020.3.1f1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2021.1.4

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • 성능 개선 사항
  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-29814 오프라인 렌더릳 지원을 추가함.

성능 개선 사항

  • WG-55340 큰 프로젝트 계층 구조를 파싱하거나 페치할 때 두 Wwise Picker 모드의 성능을 모두 개선함.

기타 수정 사항

  • WG-55912 Unity C# 바인딩이 이제 SWIG 4.0.2로부터 생성됩니다.
  • WG-56370 커뮤니티에서 보고됨: 오래된 버전에서 Wwise 2021.1.1 이상으로 마이그레이션할 때 JsonSerialize Unity 패키지가 필요함.

버그 수정

  • WG-55639 수정됨: (Spatial Audio) 공간이 비활성화된 후 다시 활성화될 때 누락됨.

커뮤니티에 보고된 버그 수정

  • WG-55076 수정됨: 빌드된 게임에서 WwiseType의 어셈블리 로드가 Windows 플랫폼에서만 작동함.
  • WG-55077 수정됨: SoundBank가 로드에 실패할 때 SoundBank에서 Event의 목록을 접근하려고 할 때 NullReferenceExceptions 오류가 생김.
  • WG-55078 수정됨: SoundBank가 비동기적으로 로드를 끝내기 전에 언로드되는 드문 문제.
  • WG-55704 수정됨: Unity 프로젝트에 파일 경로 중 'Runtime/Plugins'가 담긴 플러그인이 있을 경우 이 프로젝트에 Wwise를 통합할 수 없음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.3.7665.2179

릴리즈 노트 - Wwise Unity 통합 2021.1.3.7665.2179

이 릴리즈는 Wwise 2021.1.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.3
  • Unity: Unity 2019.4.22f1, 2020.3.1f1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-47576 통합 스크립트를 Python 2에서 Python 3로 업그레이드함.

버그 수정

  • WG-55388 수정됨: Unity WwiseDemoScene이 AkSpatialAudioListener 오류를 보고함.

커뮤니티에 보고된 버그 수정

  • WG-54782 수정됨: AssetDatabase V2를 사용할 경우 에디터에서 AkWwiseProjectData 에셋을 생성할 때 AkWwiseProjectInfo에서의 잘못된 정의로 인해 문제가 일어남.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.2.7629.2141

릴리즈 노트 - Wwise Unity 통합 2021.1.2.7629.2141

이 릴리즈는 Wwise 2021.1.2를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-52653 수정됨: 게임 오브젝트에 비활성화된 AkSurfaceReflector가 있을 경우 AkRoom 컴포넌트 Wet Transmission 경고 메시지가 표시되지 않음.
  • WG-53624 수정됨: Playable의 Time 속성을 조정할 때 오디오가 빠른이동하지 않음.

커뮤니티에 보고된 버그 수정

  • WG-54127 수정됨: Wwise Scriptable Object가 지속적으로 변경되었다고 표시됨.
  • WG-54619 수정됨: 로컬 컴퓨터의 로케일이 마침표를 소수점 구분자로 사용하지 않을 경우 SoundbankInfo.xml을 파싱할 수 없음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.1.7601.2102

릴리즈 노트 - Wwise Unity 통합 2021.1.1.7601.2102

이 릴리즈는 Wwise 2021.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2021.1.1
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-53257 수정됨: 통합에서 CPU Limit 값이 고정되지 않음

커뮤니티에 보고된 버그 수정

  • WG-50723 수정됨: AkTriggerEnable이 Awake()에서 단 한 번 트리거되며 재활성화될 경우에는 트리거되지 않음.
  • WG-53320 수정됨: 이미 Unity 통합의 일부가 아닌 동적 라이브러리가 DSP 폴더 안으로 복사됨.
  • WG-53410 수정됨: 배치모드(batchmode)에서 AkAmbient가 초기화되지 않은 AkSoundEngine과 상호작용하려고 함.
  • WG-53722 수정됨: 'Wwise Authoring(와이즈 저작)' 모드에서 Game Parameter가 Wwise Picker에 표시되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2021.1.0.7575.2069

릴리즈 노트 - Wwise Unity 통합 2021.1.0.7575.2069

이 릴리즈는 Wwise 2021.1.0을 위한 Wwise SDK 업데이트를 제공합니다.

  • 중요한 마이그레이션 참고 사항 2021.1

호환성:

  • Wwise SDK: 2021.1.0
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2021.1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • API 개선 사항
  • 작동 방식 변경 사항
  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-34342 Wwise Picker 창이 이제 사용 가능할 경우 WAAPI를 사용함.
  • WG-43009 Wwise Addressables 패키지를 추가하여 Unity Addressables 시스템이 있는 Wwise 에셋 로드 지원.
  • WG-48935 Editor 뷰에서 표시되는 감쇠 구의 색깔 변경 기능 추가.
  • WG-49016 Wwise Picker가 Unity TreeView 백엔드를 사용하도록 업데이트함.

API 개선 사항

  • WG-48127 버스 미터링 콜백 함수 AkBusMeteringCallbackFunc가 새로운 기능을 가지며 AkBusMeteringCallbackInfo 구조를 수신함. 이 구조는 AK::SoundEngine::RegisterBusMeteringCallback을 통해 게임이 전달할 수 있는 선택적 쿠키를 운반합니다. 마찬가지로 AK::SoundEngine::RegisterBusVolumeCallback()도 이제 AkSpeakerVolumeMatrixCallbackInfo 구조에 의해 AkBusCallbackFunc로 올바르게 전달되는 쿠키를 수락합니다.
  • WG-50742 Spatial Audio에서 'occlusion'을 언급하는 매개 변수가 대신 'transmission loss'를 사용하도록 매개 변수 이름을 변경함.

작동 방식 변경 사항

  • WG-47929 미래 Unity 패키지 안으로 통합을 보다 잘 분할할 수 있도록 소스의 레이아웃이 변경됨.
  • WG-48326 콜백 데이터 구조 메모리를 이제 Authoring 도구에서 모니터링할 수 있음.
  • WG-52040 이제 맞춤 플랫폼 이름을 사용하려면 델리게이트로 등록해야 함. 더 많은 정보는 Unity에서 Wwise 커스텀 플랫폼 사용하기 를 참고하세요.

기타 수정 사항

  • WG-52025 AkGameObj 컴포넌트가 있는 게임 오브젝트에서 AkRoomAwareObject 컴포넌트를 추가할 수 있는 버튼을 추가함.
  • WG-52182 기본 모니터 대기열 풀 크기를 증가시킴.

버그 수정

  • WG-48587 수정됨: 비어 있는 Work Unit의 계층 구조가 Wwise Picker에서 올바르게 표시되지 않음.
  • WG-48929 수정됨: 에디터 뷰에서 감쇠 구의 가시성이 좋지 않음.

커뮤니티에 보고된 버그 수정

  • WG-52936 수정됨: Timeline에서 스크러빙할 때 재생 오류가 일어남.


Wwise Unity Integration Documentation: 중요한 마이그레이션 참고 사항 2021.1

중요한 마이그레이션 참고 사항 2021.1

Spatial Audio

Spatial Audio에서 방해(obstruction)와 차단(occlusion) 대신 회절과 전달이라는 용어를 사용합니다.

  • AkRoom 컴포넌트에서 Wall Occlusion이 Transmission Loss으로 변경되었습니다.
  • AkSurfaceReflector 컴포넌트에서 Occlusion Values가 Transmission Loss Values로 변경되었습니다.

Spatial Audio Initialization Settings가 업데이트 및 개선되었습니다. 프로젝트를 2021.1로 업데이트할 경우 Spatial Audio Initialization Settings를 확인하여 원하는대로 모두 설정되었는지 확인해주세요. AkSpatialAudioInitSettings 구조체 참조를 참고해주세요.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.15.7667.2215

릴리즈 노트 - Wwise Unity 통합 2019.2.15.7667.2215

이 릴리즈는 Wwise 2019.2.15을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.15
  • Unity: 이 통합은 Unity 2019.4, 2020.3 및 2021.2에 대해 컴파일됩니다. 2021.2.17f1에서 테스트되었습니다. 앞서 언급한 버전보다 최신인 Unity 버전은 현재 지원되지 않지만 후속 패치 릴리스에 포함될 예정입니다.

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-50265 수정됨: Unity SpatialAudioTutorial의 Mobile Main Camera 오브젝트에 공간 음향 리스너(spatial audio listener)가 없음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.14.7616.2152

릴리즈 노트 - Wwise Unity 통합 2019.2.14.7616.2152

이 릴리즈는 Wwise 2019.2.14를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.14
  • Unity: Unity 2018.4.31f1, 2019.4.21f1, 2020.3.0f1 (Personal 혹은 Pro).
    참고: 중요 참고 사항: 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항

기타 수정 사항

  • WG-55912 Unity C# 바인딩이 이제 SWIG 4.0.2로부터 생성됩니다.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.13.7577.2104

릴리즈 노트 - Wwise Unity 통합 2019.2.13.7577.2104

이 릴리즈는 Wwise 2019.2.13을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.13
  • Unity: Unity 2018.4.31f1, 2019.4.21f1, 2020.3.0f1 (Personal 혹은 Pro).
    참고: 중요 참고 사항: 다음 목록은 호환성 시험을 철저히 거친 Unity 버전입니다. 대부분의 다른 Unity 버전과도 호환된다고 예상할 수 있지만 완벽히 보장되지는 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • API 개선 사항
  • 버그 수정

API 개선 사항

  • WG-56084 AkUtilities.GetWwiseSoundBankDestinationFolder 함수 서명이 업데이트됨.

버그 수정

  • WG-52943 수정됨: Unity Editor에서 플레이 모드를 시작할 때 Decode Compressed Data 경로가 제거됨.
  • WG-55388 수정됨: Unity의 WwiseDemoScene이 AkSpatialAudioListener 오류를 보고함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.12.7544.2058

릴리즈 노트 - Wwise Unity 통합 2019.2.12.7544.2058

이 릴리즈는 Wwise 2019.2.12를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.12
  • Unity: Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3, 2021.1 (Personal 혹은 Pro).
    참고: 주의 사항: 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 기타 수정 사항
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-47576 통합 스크립트를 Python 2에서 Python 3로 업그레이드함.

버그 수정

  • WG-53624 수정됨: Playable의 Time 속성을 조정할 때 오디오가 빠른이동하지 않음.

커뮤니티에 보고된 버그 수정

  • WG-53980 수정됨: Unity 통합 코드에서 .NET 3.5와의 불호환성.
  • WG-54619 수정됨: 로컬 컴퓨터의 로케일이 마침표를 소수점 구분자로 사용하지 않을 경우 SoundbankInfo.xml을 파싱할 수 없음.
  • WG-54782 수정됨: AssetDatabase V2를 사용할 경우 에디터에서 AkWwiseProjectData 에셋을 생성할 때 AkWwiseProjectInfo에서의 잘못된 정의로 인해 문제가 일어남.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.11.7512.2017

릴리즈 노트 - Wwise Unity 통합 2019.2.11.7512.2017

이 릴리즈는 Wwise 2019.2.11을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.11
  • Unity: Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3 (Personal 혹은 Pro).
    참고: 주의 사항: 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 커뮤니티에 보고된 버그 수정

커뮤니티에 보고된 버그 수정

  • WG-53320 수정됨: 이미 Unity 통합의 일부인 라이브러리가 DSP 폴더로 복사됨.
  • WG-54308 수정됨: Playable의 시간을 코드에서 직접 변경할 경우 활성화된 이벤트를 탐색하지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.10.7490.1989

릴리즈 노트 - Wwise Unity 통합 2019.2.10.7490.1989

이 릴리즈는 Wwise 2019.1.10을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.10
  • Unity: Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3 (Personal 혹은 Pro).
    참고: 주의 사항: 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2019.2.10

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-53615 수정됨: AkPluginActivator가 먼저 잘못된 경로에서 plugin xml 파일을 찾음.

커뮤니티에 보고된 버그 수정

  • WG-50723 수정됨: AkTriggerEnable이 Awake()에서 단 한 번 트리거되며 재활성화될 경우에는 트리거되지 않음.
  • WG-52936 수정됨: Timeline에서 스크러빙할 때 재생 오류가 일어남.
  • WG-53410 수정됨: 배치모드(batchmode)에서 AkAmbient가 초기화되지 않은 AkSoundEngine과 상호작용하려고 함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.9.7459.1949

릴리즈 노트 - Wwise Unity 통합 2019.2.9.7459.1949

이 릴리즈는 Wwise 2019.2.9을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-47326 수정됨: Spatial Audio 튜토리얼에서 대사음의 거리 감쇠에 적용되는 저대역 통과 필터가 너무 지나침.
  • WG-51287 수정됨: Unity에서 프로젝트를 열 때 Wwise Picker가 구성되는 데에 시간이 오래 걸림.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.8.7432.1919

릴리즈 노트 - Wwise Unity 통합 2019.2.8.7432.1919

이 릴리즈는 Wwise 2019.2.8을 위한 Wwise SDK 업데이트를 제공합니다.

  • 중요한 마이그레이션 참고 사항 2019.2.8

호환성:

  • Wwise SDK: 2019.2.8
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.


Wwise Unity Integration Documentation: 중요한 마이그레이션 참고 사항 2019.2.8

중요한 마이그레이션 참고 사항 2019.2.8

iOS에서 Bitcode 사용하기

2019.2.8 버전부터 iOS용 Wwise SDK는 XCode 12를 사용하여 제작되었습니다. 여전히 XCode 11을 사용할 경우 생성된 XCode 프로젝트에서 Bitcode를 반드시 비활성화해야 합니다. Unity 빌드 처리가 완료되면 생성된 XCode 프로젝트를 여세요. Xcode Project의 Build Settings으로 간 다음 "Build Options" 섹션에 있는 'Enable Bitcode'를 'No'로 설정하세요.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.7.7402.1888

릴리즈 노트 - Wwise Unity 통합 2019.2.7.7402.1888

이 릴리즈는 Wwise 2019.2.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.7
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-50610 수정됨: 유효하지 않은 범위의 공간 ID를 사용할 경우 정의되지 않은 작동 방식이 생김. 공간과 포털 통합 데모에서는 권장하지만 AkRoomID::OutdoorsGameObjID는 유효한 공간 ID가 아닙니다. AK::SpatialAudio::kOutdoorRoomID (-1)가 사용되어야 합니다.

커뮤니티에 보고된 버그 수정

  • WG-51147 수정됨: Unity 에디터에서 재생 모드를 시작할 때 XmlWatcher.EnableRaisingEvents에 관하여 대기 시간이 김.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.6.7381.1867

릴리즈 노트 - Wwise Unity 통합 2019.2.6.7381.1867

이 릴리즈는 Wwise 2019.2.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.6
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정

버그 수정

  • WG-47325 수정됨: Spatial Audio 튜토리얼에서 사용되는 리버브에 Early Reflections가 활성화되어 있음.
  • WG-47374 수정됨: Spatial Audio Room이 제거될 때 공간음이 연결되지 않게 됨.
  • WG-49936 수정됨: 튜토리얼에서 Spatial Audio 메쉬가 Spatial Audio Geometry로서 사용될 때 오류가 표시됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.5.7349.1831

릴리즈 노트 - Wwise Unity 통합 2019.2.5.7349.1831

이 릴리즈는 Wwise 2019.2.5을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.5
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 새로운 기능
  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

새로운 기능

  • WG-48674 씬을 재생할 때 포털이 닫히면 포털 기즈모가 변경됨.

버그 수정

  • WG-47470 수정됨: AkSpatialAudioListener가 올바르게 마이그레이션되지 않음.
  • WG-48672 수정됨: AkRoomPortal이 depth(Z)로 조정되어 있을 경우 앞/뒤 공간을 잘못 지정함.

커뮤니티에 보고된 버그 수정

  • WG-49902 수정됨: 네스팅된 Work Unit에 관련된 Wwise Picker 오류.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.4.7329.1806

릴리즈 노트 - Wwise Unity 통합 2019.2.4.7329.1806

이 릴리즈는 Wwise 2019.2.4을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.4
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.4.0f1

버그 수정

  • WG-45583 수정됨: Wwise SDK 폴더가 특정 위치에 있지 않을 경우 Unity 통합을 빌드할 수 없음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.3.7304.1778

릴리즈 노트 - Wwise Unity 통합 2019.2.3.7304.1778

이 릴리즈는 Wwise 2019.2.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.3
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

커뮤니티에서 보고한 버그 수정

  • WG-49370 수정됨: AkBank가 Awake에서 뱅크를 로드하도록 설정한 경우 Awake일 때 뱅크를 언로드함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.2.7275.1749

릴리즈 노트 - Wwise Unity 통합 2019.2.2.7275.1749

이 릴리즈는 Wwise 2019.2.2을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.2
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

해결된 문제:

  • WG-46080 수정됨: AkTriggerEnable이 첫 번째 트리거를 감지하지 못함.
  • WG-47578 수정됨: 명령줄로부터 Unity를 시작할 때 일어나는 중단 문제.
  • WG-48293 수정됨: 계층 구조가 빈 가상 폴더를 담고 있을 경우 Wwise Picker에서 Wwise Project Explorer Hierarchy가 올바르게 표시되지 않음.
  • WG-48525 수정됨: AkWwiseXMLWatcher 업데이트 함수의 성능 문제.
  • WG-48709 수정됨: Asset Pipeline 버전 2를 사용하여 Unity 프로젝트로 Wwise를 통합할 경우 일어나는 중단 문제.
  • WG-48831 수정됨: Wwise 플러그인이 빌드된 게임에서 등록되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.1.7250.1718

릴리즈 노트 - Wwise Unity 통합 2019.2.1.7250.1718

이 릴리즈는 Wwise 2019.2.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.2.1
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f6

해결된 문제:

  • WG-47287 Nintendo Switch와 iOS에서의 Unity 통합에서 Krotos Igniter를 지원함.
  • WG-47349 수정됨: Unity 2019.3에서 Wwise Picker의 색깔이 Unity 2019.2에서의 색깔과 이제 동일함.
  • WG-47491 수정됨: (Stadia) Stadia에서 Unity를 사용할 때 Dynamic 플러그인이 로드되지 않음.
  • WG-47537 수정됨 (Stadia): 통합 라이브러리가 더 이상 std::atomic에 의존하지 않음.
  • WG-47621 .NET 3.5 스크립팅 벡엔드를 사용할 경우 일어나는 종합 오류 해결.
  • WG-48108 수정됨: 대량의 콜백을 생성할 때 잠재적인 데드락 방지.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.2.0.7216.1681

릴리즈 노트 - Wwise Unity 통합 2019.2.0.7216.1681

이 릴리즈는 Wwise 2019.2.0을 위한 Wwise SDK 업데이트를 제공합니다.

  • 중요한 마이그레이션 참고 사항 2019.2

호환성:

  • Wwise SDK: 2019.2.0
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows | Unity 2019.3.0f6
Android iOS Linux Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

해결된 문제:

  • WG-39507 AkVector 와 AkVertex 사용을 UnityEngine.Vector3 으로 교체함.
  • WG-42160 Wwise Editor 설정과 Wwise Initialization 설정을 SettingsProviders로 등록함.
  • WG-42486 수정됨: Back과 Front Room으로의 Portal Assignment가 Spatial Audio에서 Undo/Redo에 반응하지 않음.
  • WG-42487 수정됨: (Spatial Audio) AkRoom Component를 비활성화할 경우 리스너나 이미터가 올바른 공간에 배치되지 않음.
  • WG-43185 뮤텍스 대신 C# 락(lock)을 사용해서 락 선능을 향상시킴.
  • WG-43252 이제 Wwise 장치 열거법이 표시됨.
  • WG-43255 "Wwise\Resources" 폴더의 이름이 "Wwise\ScriptableObjects"로 바뀜.
  • WG-43329 AK::SoundEngine::ResourceMonitor 기능을 Unity에 노출시킴.
  • WG-44044 메모리 과부하에서 LoadBank의 이름이 LoadBankMemoryCopy와 LoadBankMemoryView로 변경됨.
  • WG-44311 (Spatial Audio) AkEnvironmentPortal에 실행 취소/다시 실행 지원 추가.
  • WG-44366 수정됨: AkRoom Component 비활성화가 올바르게 작동하지 않음.
  • WG-44450 AkArray, AkHashList, AkKeyArray의 모든 변형이 이제 각자 'Grow Policy' 규칙을 제공하여 각 선언에서 적용되는 규칙을 최적화할 수 있는 옵션을 가짐.
  • WG-44742 Unreal과 Unity에서 Spatial Audio 설정의 범위 제한을 업데이트함.
  • WG-44768 UnityEngine.Application.persistentDataPath를 지원하는 플랫폼에서 UnityEngine.Application.persistentDataPath로부터 뱅크를 로드할 수 있는 기능을 추가함.
  • WG-45089 Unity의 Timeline에서 AkEventPlayable을 다룰 때 나타날 수 있는 경고를 제거함.
  • WG-45586 Spatial Audio에 bEnableDirectPathDiffraction 매개 변수를 추가하여 전역적으로 회절을 활성화/비활성화할 수 있게 함.
  • WG-45782 수정함: (Spatial Audio) AkRoom을 비활성화한 후 AkSurfaceReflector 컴포넌트가 무시됨.
  • WG-46045 2019.2에 마이그레이션 단계가 추가됨: AkSpatialAudioEmitter가 AkRoomAwareObject롤 교체됨.
  • WG-46158 WwiseDemoScene에 씬을 전환하거나 애플리케이션을 종료할 수 있는 메뉴를 추가함.
  • WG-46919 수정됨: WAAPI Client에 있는 DllNotFoundException이 Library 폴더를 삭제한 후에 일어날 수 없음.
  • WG-46991 수정됨: 백그라운드 뱅크 언로드가 더 이상 일어나지 않음.
  • WG-47182 AkRoomPortal 의 앞/뒤 공간을 변경할 수 있는 가능성이 제거됨. 이제 AkRoomPortal의 앞/뒤 위치와 겹치는 활성화된 공간이 자동으로 가장 높은 우선 순위를 가짐. 결과적으로 SpatialAudioTutorial Unity 씬의 AkRoomPortal Component Baker가 제거됨.


Wwise Unity Integration Documentation: 중요한 마이그레이션 참고 사항 2019.2

중요한 마이그레이션 참고 사항 2019.2

Spatial Audio

AkSpatialAudioEmitter 컴포넌트는 추후 버전에서 더 이상 사용되지 않습니다. 2019.2부터 공간 음향 매개 변수는 저작 도구에서 각 사운드마다 적용할 수 있습니다. 이미터를 더 이상 공간 음향 이미터로 태그하지 않아도 됩니다.

  • 초기 반사
    • Reflect Aux Bus: 2019.2부터 저작 도구 내의 Sound SFX Property Editor의 General Settings 탭에서 초기 반사 보조 버스를 선택할 수 있습니다. 여전히 AK::SpatialAudio::SetEarlyReflectionsAuxSend()를 호출하여 게임 오브젝트에 ER 보조 버스를 연결할 수 있습니다. 하지만 저작 도구에서 지정된 초기 반사 보조 버스가 우선시 됩니다. 더 자세한 내용은 새로운 AkEarlyReflections 컴포넌트를 참고해 주세요. 현재 이 컴포넌트는 해당 매개 변수를 통해 지정된 보조 버스로 AK::SpatialAudio::SetEarlyReflectionsAuxSend()를 호출합니다.
    • Reflection Max Path Length: 2019.2부터 Reflection Max Path Length는 Authoring 도구에서 사운드의 Attenuation Max Distance 값에 의해 설정됩니다.
    • Reflection Aux Bus Gain: 2019.2부터 저작 도구 내의 Sound SFX Property Editor의 General Settings 탭에서 초기 반사 볼륨을 설정할 수 있습니다. 여전히 AK:SpatialAudio::SetEarlyReflectionsVolume()을 호출하여 게임 오브젝트마다 초기 반사 볼륨을 설정할 수 있습니다. 이 볼륨은 저작 도구에서 사운드마다 정의된 볼륨에 추가적으로 적용됩니다. 더 자세한 내용은 새로운 AkEarlyReflections 컴포넌트를 참고해 주세요. 현재 이 컴포넌트는 해당 매개 변수를 통해 지정된 볼륨으로 AK:SpatialAudio::SetEarlyReflectionsVolume()을 호출합니다.
    • Reflections Order: 2019.2부터 Reflection Order는 Spatial Audio Initialization Settings에서 설정됩니다.
  • Room
    • Room Reverb Aux Bus Gain: 2019.2부터 Room Reverb Aux Bus Gain이 Authoring 도구 내의 Property Editor의 Game-Defined Auxiliary Sends Volume에 의해 설정됩니다.
  • Geometric Diffraction
    • Diffraction Max Edges: 2019.2부터 회절은 Authoring 도구의 Sound Property Editor에서 활성화됩니다.
    • Diffraction Max Paths: 2019.2부터 회절은 Authoring 도구의 Sound Property Editor에서 활성화됩니다.
    • Diffraction Max Path Length: 2019.2부터 회절은 Authoring 도구의 Sound Property Editor에서 활성화됩니다.
  • Debug Draw: 디버깅용 출력 표시는 새로운 AkSpatialAudioDebugDraw 컴포넌트로 옮겨졌습니다.

AkSurfaceReflector 컴포넌트는 새로운 매개 변수를 가집니다.

  • Mesh: AkSurfaceReflector 컴포넌트에 더 이상 MeshFilter 컴포넌트가 필요하지 않습니다. 대신 Spatial Audio로 전송되는 표면 반사기를 나타내는 메쉬가 해당 매개 변수를 통해 지정됩니다. 아무 것도 선택되지 않을 경우 이 컴포넌트는 해당 Unity Game Object에 Mesh Filter 컴포넌트가 있는지 확인하고 이 메쉬를 AkSurfaceReflector 메쉬로 사용합니다.
  • Acoustic Textures: 예전의 AkSurfaceReflector 컴포넌트에서는 전체 표면 반사기 메쉬에 대해 단 하나의 AkAcousticTexture만 선택할 수 있었습니다. 2019.2부터 이전 매개 변수에서 제공되는 메쉬의 각 하위 메쉬에 서로 다른 AkAcousticTexture를 지정할 수 있습니다. 하나의 Acoustic Texture 매개 변수로 전달되는 기존의 값은 모든 하위 메쉬에 적용됩니다.

AkRoomAwareObject라는 새로운 컴포넌트가 Spatial Audio에 추가됨. 이 컴포넌트는 AkRoomPortal가 항상 게임 오브젝트가 위치한 공간을 알려주는 AK::SpatialAudio::SetGameObjectInRoom()을 호출함. 이 컴포넌트는 모든 Spatial Audio 이미터와 리스너에 추가되어야 함.

  • 마이그레이션은 이전에 AkSpatialAudioEmitter를 가졌던 GameObject에 AkRoomAwareObject 컴포넌트를 자동으로 추가합니다. 마이그레이션은 AkSpatialAudioListener 게임 오브젝트에는 이 컴포넌트를 추가하지 않습니다. 이 작업은 사용자가 직접 해야 합니다.
  • AkRoomAwareObject 컴포넌트에 대한 더 자세한 정보는 인스펙터에서 AkRoomAwareObject 사용하기 를 참고해 주세요.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.11.7296.1786

릴리즈 노트 - Wwise Unity 통합 2019.1.11.7296.1786

이 릴리즈는 Wwise 2019.1.11을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.11
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

특정 플랫폼에 국한된 정보는 여기에서 확인할 수 있습니다.

Android 2019.1.11

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.10.7250.1738

릴리즈 노트 - Wwise Unity 통합 2019.1.10.7250.1738

이 릴리즈는 Wwise 2019.1.10을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.10
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

이전 버전의 경우 이전 버전 릴리즈 노트 를 참고해 주세요.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-45583 수정됨: Wwise SDK 폴더가 특정 위치에 있지 않을 경우 Unity 통합을 빌드할 수 없음.

커뮤니티에 보고된 버그 수정

  • WG-48525 수정됨: AkWwiseXMLWatcher 업데이트 함수의 성능 문제.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.9.7221.1704

릴리즈 노트 - Wwise Unity 통합 2019.1.9.7221.1704

이 배포는 Wwise 2019.1.9에 대한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f10

해결된 문제:

  • WG-47349 수정됨: Unity 2019.3에서 Wwise Picker 색깔이 Unity 2019.2에서의 색깔과 동일하지 않음.
  • WG-47578 수정됨: 명령줄로부터 Unity를 시작할 때 일어나는 중단 문제.
  • WG-48108 수정됨: 대량의 콜백을 생성할 때 일어날 수 있는 중단 문제.
  • WG-48709 수정됨: Asset Pipeline 버전 2를 사용하여 Unity 프로젝트로 Wwise를 통합할 경우 일어나는 중단 문제.
  • WG-48831 수정됨: Wwise 플러그인이 빌드된 게임에서 등록되지 않음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.8.7173.1654

릴리즈 노트 - Wwise Unity 통합 2019.1.8.7173.1654

이 배포는 Wwise 2019.1.8에 대한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.8
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f6
Stadia | Unity 2019.3.0f5

해결된 문제:

  • WG-46771 수정: (Android) 알림이나 소프트웨어 키보드를 보여줄 때 Sound Engine이 중지됨.
  • WG-46919 수정됨: WAAPI Client에 있는 DllNotFoundException이 Library 폴더를 삭제한 후에 일어날 수 없음.
  • WG-46984 설명서와 더 대응하도록 Unity에서의 Timeline 통합을 간소화함.
  • WG-47287 Nintendo Switch와 iOS에서의 Unity 통합에서 Krotos가 지원됨.
  • WG-47418 수정: Spatial Audio 고정적 실외 게임 오브젝트가 원점에 배치됨.
  • WG-47491 수정됨: (Stadia) Stadia에서 Unity를 사용할 때 Dynamic 플러그인이 로드되지 않음.
  • WG-47687 수정: Wwise Unity 통합 소스 패키지에 AkSoundEngineLumin.make를 추가함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.7.7135.1611

릴리즈 노트 - Wwise Unity 통합 2019.1.7.7135.1611

이 릴리즈는 Wwise 2019.1.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.7
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

해결된 문제:

  • WG-44250 EventCallbackPackage에서 레거시 Finalizer를 제거함.
  • WG-46282 수정됨: 경로 이름에 'Deployment'가 들어갈 경우 빌드된 게임에 'Plug-in not found' 오류가 표시됨.
  • WG-46360 수정됨: AkGameObj 가 움직이지 않을 경우 이제 위치를 한 번만 설정하며, AkAmbientInspector 가 다위치로 설정되어 있으며 대상 UnityEngine.GameObjects 가 고정적이지 않을 경우 AkAmbientInspector 가 경고 메시지를 표시함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.6.7110.1585

릴리즈 노트 - Wwise Unity 통합 2019.1.6.7110.1585

이 릴리즈는 Wwise 2019.1.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.6
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.10f1
Stadia | Unity 2019.3.0b8

해결된 문제:

  • WG-45582 AkEnvironmentPortal에 의해 전송되는 보조 센드 값을 [0, 1]로 고정함.
  • WG-45671 Wwise Advanced Settings에서 저수준(low-level) I/O의 Async Open을 표시함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.5.7093.1568

릴리즈 노트 - Wwise Unity 통합 2019.1.5.7093.1568

이 릴리즈는 Wwise 2019.1.5를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.5
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.6f1
Stadia | Unity 2019.3.0b8

해결된 문제:

  • WG-45084 AkEventPlayable 안으로 스크러빙한 후 AkEventPlayable 재생 수정.
  • WG-45708 (Switch) 스트리밍 사운드를 사용할 경우 중단되는 문제 수정.
  • WG-45806 'Fixing clip durations of AkEventPlayables' 팝업 뒤의 처리 최적화.
  • WG-45902 (Stadia) 초기화시 충돌 수정.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.4.7065.1538

릴리즈 노트 - Wwise Unity 통합 2019.1.4.7065.1538

이 릴리즈는 Wwise 2019.1.4를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.4
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

해결된 문제:

  • WG-44854 XboxOne에서 SoundBank 기본 경로 생성에 오타를 수정함.
  • WG-44905 해당하는 GroupObjectReference가 변경될 경우 WwiseGroupValueObjectReference가 dirty로 표시됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.3.7048.1516

릴리즈 노트 - Wwise Unity 통합 2019.1.3.7048.1516

이 릴리즈는 Wwise 2019.1.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.3
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

해결된 문제:

  • WG-43179 Stadia 예비 지원 추가.
  • WG-43705 Unity에서 차단 수정.
  • WG-43966 Google resonance Mixer 플러그인이 기본 Mixer 플러그인 연결 매개 변수로 출력하지 않는 문제 해결.
  • WG-44142 이제 에디터와 빌드된 게임의 로그에서 Wwise 버전과 저작권 정보가 표시됩니다.
  • WG-44205 해당하는 데이터가 변경될 경우에만 {{WwiseObjectReference}} 에셋 파일이 변경됨.
  • WG-44393 게임 빌드시 일어나는 종합 오류 제거.
  • WG-44581 (iOS, Switch) 플랫폼 전용 'PluginInfo.xml' 파일을 찾지 못했을 경우 일어나는 {{KeyNotFoundException}} 오류로부터 빌드를 보호함.
  • WG-44205 해당하는 데이터가 변경된 경우에만 WwiseObjectReference 에셋 파일이 변경됨.
  • WG-44393 게임 빌드시 일어나는 종합 오류 제거.
  • WG-44581 플랫폼 전용 'PluginInfo.xml' 파일을 찾지 못했을 경우 일어나는 {{KeyNotFoundException}} 오류로부터 Switch와 iOS 빌드를 보호함.
  • WG-44627 GetWindowsDeviceCount()를 추가하고 GetWindowsDeviceName()을 수정하여 이제 AkAudioDeviceState 인자를 수락할 수 있음.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1481

릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1481

이 릴리즈는 Wwise 2019.1.2를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1 with ML SDK 0.21.0

해결된 문제:

  • WG-44216 Bug Reporter를 사용하여 보고됨: .NET 3.5 스크립팅 백엔드를 사용할 경우 일어나는 종합 오류 해결.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1480

릴리즈 노트 - Wwise Unity 통합 2019.1.2.7018.1480

이 릴리즈는 Wwise 2019.1.2를 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1 with ML SDK 0.21.0

해결된 문제:

  • WG-42831 Unity 콜백에서 중지되어 있을 경우 사운드 엔진의 렌더링 여부를 결정하는 설정이 추가됨.
  • WG-43182 열려있는 모든 씬을 닫음으로써 씬이 많은 Unity 프로젝트의 마이그레이션을 수정함.
  • WG-43292 Spatial Audio Portal을 올바르게 배치했을 경우 일어나는 오류 수정.
  • WG-43347 (Switch) Community 플러그인을 사용할 경우 일어나는 배포 문제 해결.
  • WG-43358 (iOS) Community 플러그인을 사용할 경우 일어나는 배포 문제 해결.
  • WG-43676 UWP: VS 2017로 업데이트, ARM64 지원 추가.
  • WG-44134 Launcher 2019.5.905를 사용하여 Wwise를 통합한 이후 AkSoundEngine.a에서 일어나는 Unity 프로젝트 빌드 실패 해결.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.1.6977.1430

릴리즈 노트 - Wwise Unity 통합 2019.1.1.6977.1430

이 릴리즈는 Wwise 2019.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.1
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.0f2
Magic Leap (Lumin OS) | Unity 2019.1.0f2 with ML SDK 0.19.0

해결된 문제:

  • WG-40425 SoundBank가 새로운 정보로 재생성될 경우 AkEvent의 변경된 이름과 시간을 반영하여 Timeline에 있는 AkEvent가 업데이트되도록 함.
  • WG-41071 전체 지속 길이를 알 수 없을 경우 Timeline에서 AkEvent 클립이 올바른 최소 길이로 생성되도록 함.
  • WG-41383 연관된 클립이 끝날 경우 AkEventPlayable 오브젝트를 중단할지의 여부를 지정하는 기능을 추가함.
  • WG-41684 수정됨: Mac 에디터에서 Windows 실행 파일을 빌드할 수 없음.
  • WG-41721 AkRoomPortal 컴포넌트가 초기 상태를 선택할 수 있는 옵션을 가지도록 변경함.
  • WG-42001 수정됨: AkExternalSourceInfo.szFile을 설정할 때 발생하는 충돌.
  • WG-42612 (Switch) 이제 폴더 위치 요구 사항 없이 소스 솔루션을 빌드할 수 있음.
  • WG-42625 구조 배열을 전달받기 위한 API가 알맞게 표시됨.
  • WG-42841 AkAmbient가 연결된 GameObject를 선택할 경우 일어나는 NullReferenceException 수정.
  • WG-42870 Motion 플러그인 DLL을 Unity 통합으로 패키징함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2019.1.0.6947.1394

릴리즈 노트 - Wwise Unity 통합 2019.1.0.6947.1394

이 배포는 Wwise 2019.1.0을 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2019.1.0
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Mac PS4 Switch Windows Xbox One | Unity 2018.3.7f1
Linux tvOS UWP (Universal Windows Platform) | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6와 ML SDK 0.16.0)

해결된 문제:

  • WG-26971 Unity 프로젝트에서 전반적으로 Wwise 오브젝트의 이름 변경이 알맞게 전달되도록 함.
  • WG-36815 수정됨: Advanced Profiler의 Listeners 탭이 Game Object나 Listener의 이름을 새로 고치지 않음.
  • WG-38842 업데이트된 SoundBank가 Unity 에디터에 알맞게 다시 로드되지 않음.
  • WG-39769 AkSurfaceReflector 컴포넌트가 이제 AkRoom 컴포넌트와 연결되도록 변경됨.
  • WG-40552 AkAmbient 가 Large_Mode 위치 지정 유형에 대해 불편했던 에디터를 더 이상 사용하지 않음. 대신 AkAmbientLargeModePositioner 컴포넌트를 담은 하위 오브젝트를 복수 위치 지정을 위한 위치 음원으로 사용함.
  • WG-41010 Wwise Picker에서 Acoustic Texture와 Game Parameter에 알맞은 아이콘을 추가함.
  • WG-41282 AkSurfaceReflector 를 Acoustic Texture의 드래그 대상으로 추가함.
  • WG-42073 모든 Python 빌드 스크립트가 Python 3와 호환하도록 만듬.
  • WG-42081 (Linux) 32비트 지원 제거.
  • WG-42133 (Switch) 사용 가능한 모든 플러그인을 이 플랫폼에서 사용할 수 있게 함.
  • WG-42208 수정됨: (tvOS) DSP 플러그인에 잘못된 경로.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.6.6858.1313

릴리즈 노트 - Wwise Unity 통합 2018.1.6.6858.1313

이 배포는 Wwise 2018.1.6을 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.6
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Mac Xbox One | Unity 2018.2.16f1
Linux PS4 tvOS UWP (Universal Windows Platform) Windows | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 2018.2.16f1과 NintendoSDK 6.4.0

해결된 문제:

  • WG-36343 수정됨: 포털 방해가 유효하지 않은 포털에 설정되어 오류 로그에 메시지가 지나치게 많이 출력됨.
  • WG-37644 수정됨: "AkInitializer.cs Awake() was not executed yet" 라는 몇몇 잘못된 보고가 표준 출력에 출력됨.
  • WG-39629 수정됨: Wwise Unity 통합을 통합할 때 일부 씬에서 AkAudioListener가 카메라에 추가되지 않음.
  • WG-39793 이제 에디터에서 게임이 일시 중지되었을 때 Wwise Profiler에 연결할 수 있음.
  • WG-40103 수정됨: WwiseTypes 마이그레이션이 Prefab을 저장하지 않음.
  • WG-40988 수정됨: 사운드를 재생할 때 AkAmbient Play 버튼이 제대로 새로 고침되지 않음.
  • WG-41012 수정됨: Wwise Picker에서 Game Object Inspector 뷰로 아이템을 드래그하여 놓을 때 가끔 스크립트가 생성되지 않음.
  • WG-41018 수정됨: Wwise Picker에서 Component를 생성할 때 드래그 취소/재실행 작업이 가끔 작동하지 않음.
  • WG-41107 (iOS, Switch, tvOS) 수정됨: 누락된 플러그인을 참조하는 게임을 빌드할 때 오류 메시지가 뜨지 않음.
  • WG-41185 수정됨: 재생 모드에서 Wwise Picker 창에 'Root Item'을 표시함.
  • WG-41248 (PS4) 수정됨: ACP Batch 버퍼가 없어서 ATRAC9 디코딩이 실패함.
  • WG-41479 수정됨: Timeline Demo Event와 RTPC 트랙이 마이그레이션되지 않음.
  • WG-41514 수정됨: Wwise Picker에 아이템을 드래그하여 놓을 경우 가끔 알맞은 아이템을 참조하지 않음.
  • WG-41815 수정됨: Wwise 컴포넌트가 2018.1.3에서 2018.1.6버전까지의 Wwise에서 알맞게 마이그레이션되지 않음.
  • WG-41920 AkEvents 에서의 콜백이 Prefab 인스턴스에서 사용되었을 때 알맞게 저장되도록 함.
  • WG-42016 (Switch) 패키지에 AkMotionSourceSource를 추가함.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.5.6835.1288

릴리즈 노트 - Wwise Unity 통합 2018.1.5.6835.1288

이 배포는 Wwise 2018.1.5를 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.5
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 2018.2.16f1과 NintendoSDK 6.4.0

해결된 문제:

  • WG-36753 Unity 통합이 이제 SDK에서 premake5를 사용하여 C++ 프로젝트를 생성함.
  • WG-39264 수정됨: Wwise 컴포넌트를 담은 오브젝트를 실행 취소할 때 콘솔에 너무 많이 출력.
  • WG-39429 수정됨: UI에 표시되는 고급 플랫폼 전용 설정을 찾을 수 없음.
  • WG-39543 이제 SoundBank가 생성되면 Timeline에 있는 Sound Event가 새로운 이름을 표시함.
  • WG-39990 Android ARM64 지원 추가.
  • WG-40006 플러그인 설정 변경을 확인하는 메시지 추가.
  • WG-40565 수정됨: Wwise Unity 초기화 설정이 Spatial Audio 회절 설정에 유효하지 않은 기본값을 가짐. 기본 설정이 업데이트되었으며 기존 프로젝트에 대한 기본 설정의 유효성을 검사해서 해당 범위 안에 들어가도록 함.
  • WG-40674 수정됨: 2017.3보다 오래된 Unity 버전의 컴파일 오류.
  • WG-40992 Unity 데이터에 복제된 Wwise Project Info가 이제 알맞은 시간에 저장됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.4.6807.1258

릴리즈 노트 - Wwise Unity 통합 2018.1.4.6807.1258

이 배포는 Wwise 2018.1.4를 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.4
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 2018.2.16f1과 NintendoSDK 6.4.0

해결된 문제:

  • WG-39412 HiDPI 디스플레이에서 AkAmbient 툴바가 보이지 않는 문제 수정.
  • WG-39444 AkExternalSourceInfo 파일 이름의 문자열 인코딩 수정.
  • WG-39639 AkEventPlayable Timeline 클립이 새로운 SoundBank 정보에 반응하지 않는 문제 수정.
  • WG-39849 문자열 배열로 AkSoundEngine.PrepareEvent()나 AksoundEngine.PrepareGameSync()를 호출할 경우 힙 손상 문제 수정.
  • WG-40051 Switch 플랫폼에서 Development Build 문제 수정.
  • WG-40095 에셋이 변경되는 도중 프로젝트를 열 경우 중단되는 문제 수정.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.3.6784.1233

릴리즈 노트 - Wwise Unity 통합 2018.1.3.6784.1233

이 배포는 Wwise 2018.1.3을 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.3
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2018.1.4f1과 NintendoSDK 5.4.0)

해결된 문제:

  • WG-38413 수정됨: 에디터 일시 정지 후 재생 모드로 들어갈 때 Unity가 중단됨.
  • WG-39235 사운드 엔진이 이미 초기화된 경우에 대한 로그 메시지 추가.
  • WG-39416 수정됨: Prepare Pool Size를 0이 아닌 다른 값으로 설정할 경우 Unity가 강제 종료됨.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.2.6762.1211

릴리즈 노트 - Wwise Unity 통합 2018.1.2.6762.1211

이 배포는 Wwise 2018.1.2를 위한 Wwise SDK를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.2
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2018.1.4f1과 NintendoSDK 5.4.0)

해결된 문제:

  • WG-26971 Wwise 오브젝트의 이름 재지정이 이제 Unity 프로젝트를 통해 전달됩니다.
  • WG-39195 수정됨: 에디터의 리스너 위치와 방향의 값이 일정할 경우 계속해서 알림
  • WG-39235 사운드 엔진이 이미 초기화된 경우에 대한 로그 메시지 추가.
  • WG-39307 감쇠 구를 90% 투명하게 표시.
  • WG-39331 변경 사항이 있을 경우 플랫폼 설정에 AkWwiseInitializationSettings {{ScriptableObject}}를 함께 저장.
  • WG-39362 Unity 통합에 Opus 코덱 추가.
  • WG-39577 수정됨: (Xbox One) 초기화 문제.
  • WG-39608 패키지에 WAAPI C# API 파일 추가.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.1.6727.1172

릴리즈 노트 - Wwise Unity 통합 2018.1.1.6727.1172

이 배포는 Wwise 2018.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2018.1.1
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux PS4 tvOS UWP (Universal Windows Platform) Xbox One | Unity 2018.1.5
Mac Windows | Unity 2018.2.2f1
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity-2018.1.0f2-MLTP6과 ML SDK 0.16.0)
Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2017.4.0f1과 NintendoSDK 4.5.0)

해결된 문제:

  • WG-35762: 수정됨: 선택된 여러 개의 AkEvent 재생이 단 하나의 Event ID만 재생
  • WG-39012: AkWwisePostImportCallbackSetup.ClearConsole() 제거


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2018.1.0.6714.1154

릴리즈 노트 - Wwise Unity 통합 2018.1.0.6714.1154

이 배포는 Wwise 2018.1.0을 위한 Wwise SDK 업데이트를 제공합니다.

  • 새로운 기능 2018.1

호환성:

  • Wwise SDK: 2018.1.0
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
플랫폼: | Wwise Unity 통합을 테스트한 Unity 버전:
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.1.0f2
Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity 2018.1.0b12-MLTP5와 ML SDK 0.14.0)
Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2017.4.0f1과 NintendoSDK 4.5.0)

해결된 문제:

  • WG-30965: COMM의 초기화 설정을 C# 바인딩에 노출.
  • WG-32316: Xbox One APU 메모리 힙 크기 노출.
  • WG-36375: 모든 초기화 설정을 Unity UI에 노출.
  • WG-36993: 배열 안에서 WwiseTypes 설정을 수정.
  • WG-37127: Room 톤의 새로운 Spatial Audio Room API에 지원 추가.
  • WG-37514: Unity에 WAAPI 지원 추가.


Wwise Unity Integration Documentation: 새로운 기능 2018.1

새로운 기능 2018.1

Wwise 2018.1과 해당 Unity 통합에는 중요한 새 기능이 여러 가지 있습니다. 다음과 같은 기능을 포함합니다.

  • 프로파일러가 사용하는 커뮤니케이션 설정이 이제 Unity Editor에 노출되었습니다.
  • APU 힙 크기를 이제 Unity 통합에서 설정할 수 있습니다.
  • 새로 추가된 C# WAAPI Client 클래스로 인해 이제 사용자가 WAAAPI를 통해서 Wwise Authoring 도구와 의사소통하는 스크립트를 직접 작성할 수 있습니다.
  • 여러 가지 메모리 풀의 크기를 정의하는 Wwise 초기화 설정을 이제 Unity Editor에서 각 플랫폼용으로 정의할 수 있습니다.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.9.6726.1210

Release Notes - Wwise Unity Integration 2017.2.9.6726.1210

이 릴리즈는 Wwise 2017.2.9을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.9
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
Platforms: | Wwise Unity Integration tested on:
iOS Mac tvOS Windows | Unity 2018.3.0f2
Android Linux PS4 UWP (Universal Windows Platform) Xbox One | Unity 2018.2.16f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.9f1-MLTP9.6 with ML SDK 0.18.0)
Switch | Unity for Nintendo Switch 2018.2.16f1 with NintendoSDK 6.4.0

Resolved Issues:

  • WG-39412 Fixed issue where AkAmbient toolbar would not be visible on Hi DPI displays.
  • WG-39444 Fixed string encoding for AkExternalSourceInfo file name.
  • WG-39849 문자열 배열로 AkSoundEngine.PrepareEvent()나 AksoundEngine.PrepareGameSync()를 호출할 경우 힙 손상 문제 수정.
  • WG-39990 Android ARM64 지원 추가.
  • WG-40006 플러그인 설정 변경을 확인하는 메시지 추가.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.8.6698.1171

Release Notes - Wwise Unity Integration 2017.2.8.6698.1171

이 릴리즈는 Wwise 2017.2.8을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.8
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, 2018.1, and 2018.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One
    Mac
    Windows     		Unity 2018.2.5f1
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 with ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)

해결된 문제:

  • WG-38413 수정됨: 에디터 일시 정지 후 재생 모드로 들어갈 때 Unity가 중단됨.
  • WG-39195 수정됨: 에디터의 리스너 위치와 방향의 값이 일정할 경우 계속해서 알림
  • WG-39201 Removed error message when adding an AkBank component from the Add Component button.
  • WG-39235 사운드 엔진이 이미 초기화된 경우에 대한 로그 메시지 추가.
  • WG-39307 감쇠 구를 90% 투명하게 표시.
  • WG-39388 Fixed: Ak Initializer settings are not persisted on project reload


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.7.6661.1133

Release Notes - Wwise Unity Integration 2017.2.7.6661.1133

이 릴리즈는 Wwise 2017.2.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.7
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, 2018.1, and 2018.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4를 지원하지 않습니다. 위에 열거하지 않은 Unity 버전으로의 호환이 보장되지 않습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 2018.1.5
    Mac
    Windows     		Unity 2018.2.2f1
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 with ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)

해결된 문제:

  • WG-35762: Fixed: Playback of multiple selected Ak Objects only plays one Event ID.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.6.6636.1107

Release Notes - Wwise Unity Integration 2017.2.6.6636.1107

이 릴리즈는 Wwise 2017.2.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.6
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, and 2018.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity 2018.1.0b12-MLTP5와 ML SDK 0.14.0)
    Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2017.4.0f1과 NintendoSDK 4.5.0)

해결된 문제:

  • WG-36351: Fixed: The SpatialAudioTutorial Unity scene's AkRoomPortal component Baker window throws errors.
  • WG-38246: Fixed: Using a list of WwiseTypes in the Inspector Window now properly sets the correct entry in the list.
  • WG-38247: Fixed: Displaying a WwiseType in a non-Inspector window no longer throws an exception.
  • WG-38312: Fixed: The Save Decoded Bank feature no longer overwrites the original SoundBank.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.5.6619.1090

Release Notes - Wwise Unity Integration 2017.2.5.6619.1090

이 릴리즈는 Wwise 2017.2.5을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.5
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, and 2018.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Magic Leap Technical Preview용 Unity (Unity 2018.1.0b12-MLTP5와 ML SDK 0.14.0)
    Switch | Nintendo Switch용 Unity 4.1.0 (Unity 2017.4.0f1과 NintendoSDK 4.5.0)

해결된 문제:

  • WG-37187: Fixed the reactivation of the sound engine when deleting the WwiseGlobal object in the editor.
  • WG-37767: Fixed the pause/resume state of the sound enginge via OnApllicationPause() and OnApplicationFocus() callbacks in built games.
  • WG-37836: Ensured Xbox One PDB filename matches DLL filename.
  • WG-38027: Fixed inspectors for Wwise types and components in Unity 2018.1.
  • WG-38191: Added experimental support for Magic Leap platform.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.4.6590.1064

Release Notes - Wwise Unity Integration 2017.2.4.6590.1064

This release delivers compatibility with Unity 2018.1.

호환성:

  • Wwise SDK: 2017.2.4
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, and 2018.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.4.6590.1054

Release Notes - Wwise Unity Integration 2017.2.4.6590.1054

이 릴리즈는 Wwise 2017.2.4을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.4
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3, and 2017.4 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.3.6575.1037

Release Notes - Wwise Unity Integration 2017.2.3.6575.1037

이 릴리즈는 Wwise 2017.2.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.3
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 with NintendoSDK 3.5.2)

해결된 문제:

  • WG-36615: Fixed game object names appearing as IDs when connected to Editor.
  • WG-36636: Fixed AkInitializer issues in Editor and game.
  • WG-36817: Fixed default listener game object registration issues when playing/stopping scene in Editor.
  • WG-36829: Fixed scene not marked as dirty by AkWwisePostImportCallbackSetup.cs.
  • WG-36867: Fixed the circular dependency between AkGameObj and AkAudioListener initialization.
  • WG-36952: Fixed MSSpatial plug-in activation.
  • WG-37021: Fixed loading SoundBanks from StreamingAssets folder in Editor.
  • WG-37061: Fixed failure when deploying to Switch, iOS and tvOS for the first time.
  • WG-37065: Fixed possible crash in Wwise's AK::SoundEngine::Term, which could result in Unity Editor crash when stopping game.
  • WG-37122: Fixed updating of aux sends when moving within a single AkEnvironmentPortal.
  • WG-37171: Fixed compilation error in AkAmbientInspector.cs in Unity 5.5.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.2.6553.1015

Release Notes - Wwise Unity Integration 2017.2.2.6553.1015

이 릴리즈는 Wwise 2017.2.2을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.2.2
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 with NintendoSDK 3.5.2)

해결된 문제:

  • WG-26533: Project is set to dirty only when necessary when saving expanded items in the Wwise picker.
  • WG-33976: Added menu item to enable Wwise communication on UWP. 더 많은 정보는 pg_WindowsInfo 를 참고하세요.
  • WG-36296: Using the AkSoundEngine.AddListener and AkSoundEngine.AddDefaultListener functionality.
  • WG-36434: Fully qualified the names of all types used within the integration.
  • WG-36499: Fixed Unity installation issues when AkSoundEngine.dll has not yet been loaded.
  • WG-36584: Added documentation for AkSoundEngine and fixed documentation for various classes within folders API/Handwritten and Components.
  • WG-36827: Fixed AkInitializer re-initialization and unloading of SoundBanks.
  • WG-36848: Fixed AkRoomPortals won't detect overlapping AkRoom components with trigger colliders.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.2.1.6524.980

Release Notes - Wwise Unity Integration 2017.2.1.6524.980

이 릴리즈는 Wwise 2017.2.1을 위한 Wwise SDK 업데이트를 제공합니다. The Wwise Unity integration documentation is also now available in Chinese.

호환성:

  • Wwise SDK: 2017.2.1
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 with NintendoSDK 3.5.2)

해결된 문제:

  • WG-34267: Placed the members of Wwise_IDs.cs within the AK namespace and prefixed class names with "Ak".
  • WG-35301: Changed Event selector to automatically display in inspector when AkEventSection is added to Timeline track.
  • WG-35609: Made AkRoomPortal inspector update the front and back rooms in real time.
  • WG-36086: Added public functions to AkRoomPortal to update the front and back rooms.
  • WG-36099: Fixed NullReferenceException when migrating from 2016.2.4.
  • WG-36125: Fixed compatibility with Unity 5.5.
  • WG-36144: Fully specified System.IO.Path in Wwise C# script to avoid potential conflicts.
  • WG-36219: Fixed drag and drop from the Wwise Picker under Unity 2017.3.
  • WG-36356: Exposed monitoring pool size and queue size in AkInitializer inspector.
  • WG-36413: Fixed crash when having more than one portal from one room to the other.


Wwise Unity Integration Documentation: 릴리즈 노트 - Wwise Unity 통합 2017.2.0.6500.947

릴리즈 노트 - Wwise Unity 통합 2017.2.0.6500.947

이 릴리즈는 Wwise 2017.2.0에 대한 Wwise SDK 업데이트 및 Unity 2017.3과의 호환성을 제공합니다.

  • 새로운 기능 2017.2
  • 중요한 마이그레이션 참고 사항 2017.2

호환성:

  • Wwise SDK: 2017.2.0
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Mac
    Windows
            Unity 2017.3.0f3
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 2017.2.0f3
    Switch Nintendo Switch용 Unity 3.1.2 (Unity 5.6.4와 NintendoSDK 3.5.2)

새로운 기능:

  • 새로운 기능 2017.2 페이지에 설명한대로 몇 가지 새로운 기능 추가.

마이그레이션 참고 사항:

  • 다른 소프트웨어 패키지와 이름이 충돌하는 것을 방지하기 위해서 중단되는 사항 변경. 이 부분은 중요한 마이그레이션 참고 사항 2017.2 페이지에서 자세하게 설명되어 있습니다.

해결된 문제:

  • WG-25994: C# 스크립팅을 통해 오디오 입력 음원 플러그인을 접근할 수 있게 됨. 더 많은 정보는 Unity에서 오디오 입력 음원 플러그인 사용하기 를 참고하세요.
  • WG-27337: 사운드 엔진에 MIDI 이벤트를 전송하는 기능 추가. 더 많은 정보는 Wwise에 MIDI 전송하기 를 참고하세요.
  • WG-28541: Ak가 앞에 붙지 않은 모든 열거형(enum)에 네임스페이스 추가. 생성된 모든 클래스의 이름 앞에 Ak를 붙였습니다.
  • WG-33501: 자동 SoundBank 관리 추가.
  • WG-34446: AkCallbackManager에서 메모리 할댱량 감소.


Wwise Unity Integration Documentation: 새로운 기능 2017.2

새로운 기능 2017.2

Wwise 2017.2와 해당 Unity 통합에는 중요한 새 기능이 여러 가지 있습니다. 다음과 같은 기능을 포함합니다.

  • Edit Mode Support
    • Edit 모드에서 뱅크 로드/언로드하기
  • WwiseGlobal 게임 오브젝트에 추가된 내용
  • Wwise Audio Input 플러그인
  • MIDI Event
  • 자동 SoundBank 관리

Edit Mode Support

이제 Unity가 Edit 모드인 상태에서 Wwise 사운드 엔진을 초기화할 수 있습니다. 다시 말해 Play 모드로 전환하지 않은 채로 에디터에서 Wwise Event를 트리거할 수 있습니다. 이 부분을 보여주기 위해서 AkEvent (그리고 AkAmbient )의 인스펙터가 업데이트되었습니다. 이제 에디터에서 직접 Event를 재생하고 중단하는 데 사용할 수 있는 새로운 버튼이 인스펙터에 추가되었습니다. Play/Stop 버튼은 각 Event를 재생하고 중단합니다. AkEvent가 있는 여러 오브젝트가 선택되었을 경우 Play Multiple과 Stop Multiple 버튼을 사용하면 선택된 모든 Event를 재생하거나 중단할 수 있습니다. Stop All 버튼은 현재 재생 중인 모든 Event를 중단합니다.

Edit 모드에서 뱅크 로드/언로드하기

편집 모드 기능이 올바르게 작동하려면 해당 AkBank 컴포넌트의 Load On: 속성이 Awake로 설정되고 Unload On: 속성이 Never로 설정되어야 합니다.

WwiseGlobal 게임 오브젝트에 추가된 내용

이제 WwiseGlobal 게임 오브젝트에 AkEditorEventPlayer 컴포넌트가 있습니다. 이 컴포넌트는 에디터에서만 사용할 수 있으며 Edit 모드에서 AkEvent 컴포넌트에 연결된 WwiseEvent를 재생하는 데 사용됩니다. 이제 WwiseGlobal 오브젝트에 Rigidbody, AkGameObj, AkAudioListener 컴포넌트가 있습니다. 이 컴포넌트는 Edit 모드에서 AkEnvironment, AkGameObj, AkRoom 컴포넌트 간의 상호작용을 위해 사용됩니다. Unity 프로젝트의 변경 사항 를 참고하세요.

Wwise Audio Input 플러그인

이제 C# 스크립팅을 통해 Wwise Audio Input Source 플러그인에 접근할 수 있습니다. 더 많은 정보는 Unity에서 오디오 입력 음원 플러그인 사용하기 를 참고하세요.

MIDI Event

이제 C# 스크립팅을 통해 MIDI 이벤트를 Wwise에 전송할 수 있습니다. 더 많은 정보는 Wwise에 MIDI 전송하기 를 참고하세요.

자동 SoundBank 관리

자동 SoundBank 관리가 추가되었습니다. 더 많은 정보는 단일 플랫폼 프로젝트에서 SoundBank 배포하기 와 멀티 플랫폼 프로젝트에서 SoundBank 배포하기 를 참고하세요.

공간 음향 통합

Unity 통합에 공간 음향 API가 추가되었습니다. 튜토리얼은 Unity에서의 Spatial Audio 를 참고하세요.


Wwise Unity Integration Documentation: 중요한 마이그레이션 참고 사항 2017.2

중요한 마이그레이션 참고 사항 2017.2

다음 열거형의 이름이 변경되었습니다:

2017.2 이전: | 새로운 2017.2:
ErrorCode | AK.Monitor.ErrorCode
ErrorLevel | AK.Monitor.ErrorLevel
DynamicSequenceType | AK.SoundEngine.DynamicSequence.DynamicSequenceType
MultiPositionType | AK.SoundEngine.MultiPositionType
PreparationType | AK.SoundEngine.PreparationType
RTPCValue_type | AK.SoundEngine.Query.RTPCValue_type

다음 클래스의 이름이 변경되었습니다:

2017.2 이전: | 새로운 2017.2:
Iterator | AkIterator
Playlist | AkPlaylist
PlaylistItem | AkPlaylistItem


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.9.6501.947

Release Notes - Wwise Unity Integration 2017.1.9.6501.947

이 릴리즈는 Wwise 2017.1.9을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.1.9
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3, 2017.4, and 2018.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.8.6488.933

Release Notes - Wwise Unity Integration 2017.1.8.6488.933

이 릴리즈는 Wwise 2017.1.8을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.1.8
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3, 2017.4, and 2018.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)

해결된 문제:

  • WG-37836: Ensured Xbox One PDB filename matches DLL filename.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.7.6467.910

Release Notes - Wwise Unity Integration 2017.1.7.6467.910

이 릴리즈는 Wwise 2017.1.7을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.1.7
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3, and 2017.4 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.6.6446.890

Release Notes - Wwise Unity Integration 2017.1.6.6446.890

이 릴리즈는 Wwise 2017.1.6을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.1.6
  • Unity: Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 (Personal 혹은 Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 with NintendoSDK 3.5.2)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.5.6429.870

Release Notes - Wwise Unity Integration 2017.1.5.6429.870

호환성:

  • Wwise SDK: 2017.1.5
  • Unity: Unity 5.5, 5.6, 2017.1 and 2017.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 with NintendoSDK 3.5.2)

해결된 문제:

  • WG-33289: Updated SWIG to 3.0.12.
  • WG-36079: Brought back AddSecondaryOutput.
  • WG-36219: Fixed drag and drop from the Wwise Picker under Unity 2017.3.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.4.6407.845

Release Notes - Wwise Unity Integration 2017.1.4.6407.845

호환성:

  • Wwise SDK: 2017.1.4
  • Unity: Unity 5.5, 5.6, 2017.1 and 2017.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.2.0f3
    Switch Nintendo Switch용 Unity 3.1.2 (Unity 5.6.4와 NintendoSDK 3.5.2)

해결된 문제:

  • WG-35168: Fixed crash when loading SoundBanks on Switch.
  • WG-35383: Fixed update of IDs associated with WwiseTypes when used as properties within custom inspectors.
  • WG-35384: AkAudioListener, AkInitializer, and AkTerminator now implement OnEnable() instead of Awake(), so they are disabled when unchecked in the Editor.
  • WG-35513: Added full custom positioning for AkGameObj.
  • WG-35958: Unity 2017.3 support added. Note the integration has not been thoroughly tested in Unity 2017.3, but it should be compatible.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.3.6377.812

Release Notes - Wwise Unity Integration 2017.1.3.6377.812

This release delivers the Wwise SDK update for Wwise 2017.1.3, and compatibility with Unity 2017.1.

호환성:

  • Wwise SDK: 2017.1.3
  • Unity: Unity 5.5, 5.6, 2017.1 and 2017.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.2.0f3
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 with Nintendo SDK 1.4.0)

해결된 문제:

  • WG-34855: Added AkSoundEngine.GetCurrentLanguage().
  • WG-35075: Fixed: Added support for Unity 2017.2 integration in the Audiokinetic Launcher.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.2.6361.791

Release Notes - Wwise Unity Integration 2017.1.2.6361.791

이 릴리즈는 Wwise 2017.1.2을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2017.1.2
  • Unity: Unity 2017.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.1.1f1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 with Nintendo SDK 1.4.0)


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.1.6340.770

Release Notes - Wwise Unity Integration 2017.1.1.6340.770

This release delivers the Wwise SDK update for Wwise 2017.1.1, and compatibility with Unity 2017.1.

호환성:

  • Wwise SDK: 2017.1.1
  • Unity: Unity 2017.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 with Nintendo SDK 1.4.0)

해결된 문제:

  • WG-33018: Fixed: No localization folder is created when using the Decode Banks feature.
  • WG-33818: Fixed bank decoding on iOS and Android.
  • WG-34090: Fixed TLS Allocator Error spamming for WSA Unity Plugin.
  • WG-34188: Fully qualified name of System.EventHandler to avoid name clashes.
  • WG-34205: Fully qualified name of UnityEditor.Menu and UnityEditor.MenuItem to avoid name clashes.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2017.1.0.6302.726

Release Notes - Wwise Unity Integration 2017.1.0.6302.726

This release delivers the Wwise SDK update for Wwise 2017.1.0, and compatibility with Unity 2017.1.

  • New Features 2017.1
  • Important Migration Notes 2017.1

호환성:

  • Wwise SDK: 2017.1.0
  • Unity: Unity 2017.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 with Nintendo SDK 1.4.0)

새로운 기능:

  • Added several new features, as detailed in the New Features 2017.1 page.

마이그레이션 참고 사항:

  • The Wii U platform is no longer supported.
  • The functionality encompassing the auto-registration of GameObject's has been moved to the Unity Integration Extensions. 이 변경 내용에 대한 더 자세한 정보는 Wwise 설치 및 마이그레이션 안내서를 참고하세요.
  • There are a number of breaking changes made to the AkCallbackManager, which are detailed in the Important Migration Notes 2017.1 page.

해결된 문제:

  • WG-27479: Made callback buffer size configurable via AkInitializer.
  • WG-30791: Added WwiseTypes. See Wwise 타입 for more information.
  • WG-31155: Fixed AkMemSettings and AkChannelConfig so that their methods do not check for SoundEngine initialization.
  • WG-31735: Added hooks enabling users to easily extend or remove auto-registration of GameObjects. See Unity 통합 확장 for more information.
  • WG-32348: Fixed XML parsing of SoundBanksInfo file.
  • WG-32657: Reduced memory allocations when using callback classes, and removed foreach statements.
  • WG-33303: Added support for AK_MusicPlaylistSelect.
  • WG-34003: Installation procedure will not deactivate other native plugins in the project anymore.


Wwise Unity Integration Documentation: New Features 2017.1

New Features 2017.1

There are a number of important new features in Wwise 2017.1 and its Unity Integration. 다음과 같은 기능을 포함합니다.

  • Required Components
  • WwiseTypes
  • Unity Integration Extensions
  • 3D Busses

Required Components

[RequireComponent(typeof(AkGameObj))] has been added to AkEvent.

AkEnvironment and AkEnvironmentPortal no longer specify Rigidbody as a required component, and the members of Rigidbody are no longer modified. If an AkEnvironment or an AkEnvironmentPortal does not have a Rigidbody attached to its game object or an AkGameObj is set to "Environment aware" and does not have a Rigidbody attached to its game object, the following warning will be displayed in the Editor: AkGameObj-AkEnvironment interactions require a Rigidbody component on the object or the environment.

All instances of the above warning can be removed by unchecking the Show Warning for Missing RigidBody option within the Wwise Settings window.

WwiseTypes

New "WwiseTypes" have been added that provide users with finer control over features represented by Wwise objects such as Events, game parameters, Switches, and States. These new classes each come with their own property drawers that bring up a Wwise picker when clicked, allowing for rapid prototyping of game audio systems.

Below is a brief example use case:

public class Footsteps : MonoBehaviour
{
[Header("Wwise Types")]
public AK.Wwise.Event FootStepEvent = null;
public AK.Wwise.RTPC SpeedRTPC = null;
public AK.Wwise.Switch UnderFootMaterialSwitch = null;
public AK.Wwise.Bank FootStepBank = null;
void InitializeSound() { FootStepBank.Load(); }
void FinalizeSound() { FootStepBank.Unload(); }
void PlayFootStepSound(float speed)
{
SpeedRTPC.SetValue(gameObject, speed);
UnderFootMaterialSwitch.SetValue(gameObject);
FootStepEvent.Post(gameObject);
}
}

Unity Integration Extensions

AkSoundEngine is now a partial class. Hooks have been added to allow users to extend the auto-registration of game objects or remove this functionality all together. 확장을 권장하지만 Unity 프로젝트에 Wwise 통합하기 중에 제외시킬 수도 있습니다.

3D Busses

To complement the addition of the 3D busses feature in Wwise, the following modifications have been made. There is no longer a restriction on the number of listeners, and the concept of default listeners has been added to represent the listeners that all game objects are initially set up to be listened by. AkGameObj has been modified to hold a list of AkAudioListeners. By default, an AkGameObj will emit its sound to the default listeners, and an AkAudioListener is a default listener.

AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29


Wwise Unity Integration Documentation: Important Migration Notes 2017.1

Important Migration Notes 2017.1

The following breaking changes have been made to the AkCallbackManager.

  • AkCallbackManager.AudioInterruptionCallback() has a new signature:
    public delegate AKRESULT AudioInterruptionCallback(bool in_bEnterInterruption, object in_Cookie);

  • AkCallbackManager.BGMCallback() has a new signature:
    public delegate AKRESULT BGMCallback(bool in_bOtherAudioPlaying, object in_Cookie);

  • AkCallbackManager.EventCallback() has a new signature:
    public delegate void EventCallback(object in_cookie, AkCallbackType in_type, AkCallbackInfo in_info);

  • The callback classes are no longer nested within AkCallbackManager and have a hierarchy with many inheriting from AkCallbackInfo. Wherever possible, the associations and members of these classes mimic the syntax of their C++ counterparts.
  • The gameObjID member of the callback classes is now of type ulong instead of IntPtr.
  • The class AkCallbackManager.AkMidiEventCallbackInfo is now AkMIDIEventCallbackInfo. (Please note the capitalization of "MIDI".)
  • The class AkCallbackManager.AkMusicSyncCallbackInfoBase has been removed. Use AkMusicSyncCallbackInfo instead.
  • All of the members of AkCallbackManager.AkMusicSyncCallbackInfo.segmentInfo have been exposed as members of AkMusicSyncCallbackInfo.segmentInfo_*.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.6.6153.595

Release Notes - Wwise Unity Integration 2016.2.6.6153.595

이 릴리즈는 Wwise 2016.2.6을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.2.6
  • Unity: Unity 2017.2 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 2017.2.0f3
    Switch | Unity for Switch 3.1.2 (Unity 5.6.4p1 with NintendoSDK 3.5.2)
    Wii U | Unity 5.4.2f2
    Resolved Issues:
  • WG-35075: Fixed: Added support for Unity 2017.2 integration in the Audiokinetic Launcher.
  • WG-35168: Fixed crash when loading SoundBanks on Switch.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.5.6121.560

Release Notes - Wwise Unity Integration 2016.2.5.6121.560

이 릴리즈는 Wwise 2016.2.5을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.2.5
  • Unity: Unity 2017.1 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 2017.1.0f3
    Switch | Unity for Switch 1.0.1 (Unity 5.5.0p1 with NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    Resolved Issues:
  • WG-33687: Added headers for missing internal plug-ins on Nintendo Switch.
  • WG-34003: Installation procedure will not deactivate other native plug-ins in the project anymore.
  • WG-34090: Fixed TLS Allocator Error spamming for WSA Unity Plugin.
  • WG-34216: Fixed compilation issues regarding updating to Unity 2017.1.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.4.6098.531

Release Notes - Wwise Unity Integration 2016.2.4.6098.531

이 릴리즈는 Wwise 2016.2.4을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.2.4
  • Unity: Unity 5.6 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch | Unity for Switch 1.0.1 (Unity 5.5.0p1 with NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    Resolved Issues:
  • WG-33395: Added namespace around potentially conflicting class names


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.3.6077.504

Release Notes - Wwise Unity Integration 2016.2.3.6077.504

이 릴리즈는 Wwise 2016.2.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.2.3
  • Unity: Unity 5.6 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.6.0f3
    Switch | Unity for Switch 0.6.1
    Wii U | Unity 5.4.2f2

해결된 문제:

  • WG-32536: Added Nintendo Switch support.
  • WG-32623: Fixed Android music custom cue crash.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.2.6022.430

Release Notes - Wwise Unity Integration 2016.2.2.6022.430

이 릴리즈는 Wwise 2016.2.2을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.2.2
  • Unity: Unity 5.5 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0p4
    Wii U Unity 5.4.2f2

해결된 문제:

  • WG-31862: Removed enum values that are not associated with event callbacks from event callback list.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.1.5995.409

Release Notes - Wwise Unity Integration 2016.2.1.5995.409

이 릴리즈는 Wwise 2016.2.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

해결된 문제:

  • WG-32006: Fixed "Unknown Game Object ID" error when setting a GameObject's position.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.1

Release Notes - Wwise Unity Integration 2016.2.1

이 릴리즈는 Wwise 2016.2.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

해결된 문제:

  • WG-27085: Reduced the allocations due to AuxSends
  • WG-31127: Fixed the returned user cue name for AK_MusicSyncUserCue.
  • WG-31650: Fixed NullReferenceException in AkGameObj when the SoundEngine was not initialized.
  • WG-31651: Avoid the automatic creation of AkGameObj when calling SetObjectPosition.
  • WG-31862: Removed enum values that are not associated with event callbacks from event callback list.

Known Issues

  • Unity case #861189: Installation from the Launcher fails if the Unity Windows Store playback engine is installed.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.2.0

Release Notes - Wwise Unity Integration 2016.2.0

이 릴리즈는 Wwise 2016.2.0을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.2.0
  • Unity: Unity 5.4 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.4.1p2
    Wii U Unity 5.2.4f1

Migration Notes

  • Windows Phone 8.1, and Windows Store 8.0 and 8.1 platforms have been deprecated. The only supported Windows Store platform is now Universal Windows Platform (UWP).
  • The Xbox 360 platform is no longer supported.
  • The PS3 platform is no longer supported.

해결된 문제:

  • WG-30571: Rebuilding the Library folder will no longer trigger an error message saying the Wwise Unity integration is not installed for a platform.
  • WG-30960: Applying a position offset to an AkGameObj is now reflected in Unity's dirty system.
  • WG-31507: Add MediaID and bStreaming to duration callback.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.6

Release Notes - Wwise Unity Integration 2016.1.6

이 릴리즈는 Wwise 2016.1.6을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.1.6
  • Unity: Unity 5.5 (Personal or Pro).
    참고: Important note: We no longer officially support the Integration for Unity 4. While it may work, we will not test this or future versions of the Wwise Integration for Unity on Unity 4.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0p4
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-32006: Fixed "Unknown Game Object ID" error when setting a GameObject's position.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.5

Release Notes - Wwise Unity Integration 2016.1.5

이 릴리즈는 Wwise 2016.1.5을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.1.5
  • Unity: Unity 5.5 (Personal or Pro).
    참고: Important note: We no longer officially support the Integration for Unity 4. While it may work, we will not test this or future versions of the Wwise Integration for Unity on Unity 4.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0f3
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.4

Release Notes - Wwise Unity Integration 2016.1.4

이 릴리즈는 Wwise 2016.1.4을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.1.4
  • Unity: Unity 5.4 (Personal or Pro).
    참고: Important note: We no longer officially support the Integration for Unity 4. While it may work, we will not test this or future versions of the Wwise Integration for Unity on Unity 4.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-31507: Added MediaID and bStreaming to duration callback.
  • WG-31650: Fixed NullReferenceException in AkGameObj when the sound engine was not initialized.
  • WG-31651: Bypassed the automatic creation of AkGameObj when calling SetObjectPosition().


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.3

Release Notes - Wwise Unity Integration 2016.1.3

이 릴리즈는 Wwise 2016.1.3을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2016.1.3
  • Unity: Unity 5.4 (Personal or Pro).
    참고: Important note: We no longer officially support the Integration for Unity 4. While it may work, we will not test this or future versions of the Wwise Integration for Unity on Unity 4.
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.2

Release Notes - Wwise Unity Integration 2016.1.2

이 릴리즈는 Wwise 2016.1.2을 위한 Wwise SDK 업데이트를 제공합니다. The Wwise Unity integration documentation is also now available in Japanese.

호환성:

  • Wwise SDK: 2016.1.2
  • Unity: Unity 5.4 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-30567 Fixed: Crash when using WAV markers having an empty label.

마이그레이션 참고 사항:

  • SWIG sources are not distributed with the source ZIP files anymore. The provided ZIP sources contain the necessary files and pre-generated SWIG interfaces required to build the integration package without the need for SWIG.
  • Projects still using Wwise 2014.1.4 and less are not directly upgradeable to 2016.1. Please first update your project to 2015.1.6, and then to 2016.1.
  • If you wish to update your Unity project to Unity 5.4, please perform the Wwise migration to 2016.1.2 first. Some changes in Unity 5.4 broke the older integrations, and updating to the Wwise 2016.1.2 integration first resolves these issues.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1.1

Release Notes - Wwise Unity Integration 2016.1.1

이 릴리즈는 Wwise 2016.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.1.1
  • Unity: Unity 5.3 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-30021: Use the last modified date of a decoded SoundBank to decide if it needs to be re-decoded.
  • WG-30228: It is now possible to rebuild the Linux integration from source.
  • WG-30231: It is now possible to rebuild the tvOS integration from source.
  • WG-30259: Fix AkGameObj registration behavior when calling GC.Collect.

Known issues:

  • WG-30128: It is not possible to save decoded SoundBanks to disk on the Vita platform.
  • WG-30139: It is not possible to save decoded SoundBanks to disk on the Wii U platform.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2016.1

Release Notes - Wwise Unity Integration 2016.1

이 릴리즈는 Wwise 2016.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2016.1
  • Unity: Unity 5.3 (Personal or Pro).
    참고: 주의 사항: 이 통합은 Unity 4에서 테스트 되지 않았습니다.
    플랫폼: Wwise Unity 통합을 테스트한 Unity 버전:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p3
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-25675 Fixed: Added a "Generate SoundBanks" button in the Wwise Picker to generate the SoundBanks for all platforms of the Wwise project.
  • WG-27583 Fixed: Now automatically managing the SoundBank folders in the Unity assets, pointing to the right SoundBank for the current Unity target platform.
  • WG-28175 Fixed: WwiseGlobal is not always automatically created when creating a new scene.
  • WG-26011 Fixed: Enabling back Ak Audio Listener after creating a new Scene doesn't properly destroy Default Unity Audio Listener.

마이그레이션 참고 사항:

  • SWIG sources are not distributed with the source ZIP files anymore. The provided ZIP sources contain the necessary files and pre-generated SWIG interfaces required to build the integration package without the need for SWIG.
  • Projects still using Wwise 2014.1.4 and less are not directly upgradable to 2016.1. Please first update your project to 2015.1.6, and then to 2016.1.

Known issues:

  • WG-30021: The DecodeBanks feature is deactivated when previewing a scene in the Editor.
  • WG-30021: The DecodeBanks feature does not automatically delete the decoded SoundBanks. If SoundBanks are updated, the DecodedBanks folder should be removed from the target devices.
  • WG-30128: It is not possible to save decoded SoundBanks to disk on the Vita platform
  • WG-30139: It is not possible to save decoded SoundBanks to disk on the WiiU platform


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.9

Release Notes - Wwise Unity Integration 2015.1.9

이 릴리즈는 Wwise 2015.1.9을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.9
  • Unity: Unity 4.6 Pro or Unity 5.3 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.8

Release Notes - Wwise Unity Integration 2015.1.8

이 릴리즈는 Wwise 2015.1.8을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.8
  • Unity: Unity 4.6 Pro or Unity 5.3 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

해결된 문제:

  • WG-30259 Fixed: Fix AkGameObj registration behaviour when calling GC.Collect
  • WG-30422 Fixed: Audio is no longer lost when connecting an iOS app to an Apple TV.
  • WG-30567 Fixed: Fix a crash when using WAV markers having an empty label


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.7

Release Notes - Wwise Unity Integration 2015.1.7

이 릴리즈는 Wwise 2015.1.7을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.7
  • Unity: Unity 4.6 Pro or Unity 5.3 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p5
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

해결된 문제:

  • WG-29521 Fixed: (iOS) Deadlock when coming back from a missed FaceTime call.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.6

Release Notes - Wwise Unity Integration 2015.1.6

이 릴리즈는 Wwise 2015.1.6을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.6
  • Unity: Unity 4.6 Pro or Unity 5.3 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.3p1
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

New Features

  • WG-23513 (Android) Added a low-level I/O that can read OBB files used by Unity.

해결된 문제:

  • WG-29405 Fixed: Ensured AkEnvironment Effect does not persist outside spawning zone environment.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.5

Release Notes - Wwise Unity Integration 2015.1.5

이 릴리즈는 Wwise 2015.1.5을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.5
  • Unity: Unity 4.6 Pro or Unity 5.3 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.1p3
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.3p3 with Wii U add-on 3.0.1
    Xbox 360 | Unity 5.2.1f1

New Features

  • The Wii U integration is now compatible with Unity 5.2.3p3.

해결된 문제:

  • WG-27300 Fixed: Exposed the Prepare Pool to allow use of PrepareEvent() and PrepareBank().
  • WG-28716 Fixed: Made the source package compatible with Python 3.4+.
  • WG-28917 Fixed: Disabled automatic removal of an AkAudioListener manually added to a GameObject other than the Main Camera.
  • WG-28957 Fixed: Removed cause of NullReferenceExceptions when getting the Wwise project data.
  • WG-28975 Fixed: Resolved a race condition between LoadBank() and UnLoadBank().

Known Issues:

  • It is not possible to connect the Profiler to a game on the Windows Store Apps platform.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.4

Release Notes - Wwise Unity Integration 2015.1.4

이 릴리즈는 Wwise 2015.1.4을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2015.1.4
  • Unity: Unity 4.6 Pro or Unity 5.2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1 with Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

New Features

  • Added support for Windows 10 Universal Apps
  • Added support for Windows Store Apps SDK 8.1

Migration Notes

  • Removed support for Windows Phone 8.0
  • Removed support for Windows Store Apps SDK 8.0

해결된 문제:

  • WG-28412 Fixed: AkGameObj position offset can now be saved in a prefab.
  • WG-28723 Fixed: It is now possible to build the game as a PS4 package.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.3

Release Notes - Wwise Unity Integration 2015.1.3

This release delivers the Wwise SDK update for Wwise 2015.1.3, and the Universal Windows Platform.

호환성:

  • Wwise SDK: 2015.1.3
  • Unity: Unity 4.6 Pro or Unity 5.2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store Apps
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1 with Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

새로운 기능:

  • Added support for the Universal Windows Platform under the Windows Store Apps package.
  • Added support for Windows Store Apps SDK 8.1.
  • Removed support for Windows Phone 8.0.
  • Removed support for Windows Store Apps SDK 8.0.

해결된 문제:

  • WG-25945 Fixed: Wwise errors were always redirected to the Unity console. Added a menu item in the WwiseGlobal settings to enable/disable the Wwise engine output in the Unity console.
  • WG-26011 Fixed: Enabling back Ak Audio Listener after creating a new Scene didn't properly destroy Default Unity Audio Listener.
  • WG-28108 Fixed: Sound kept playing when pausing editor. Sound is now stopped when pausing in the editor and starts playing again when unpausing. Sound keeps playing (as before) when switching windows.
  • WG-28175 Fixed: WwiseGlobal was not always automatically created when creating a new scene.
  • WG-28479 Fixed: Setup attempted to add unchecked option. Setup now succeeds when installing the integration in a project without a Main Camera.
  • WG-28526 Fixed: Potential Unity Editor crash. Made sure the SoundEngine is initialized before registering and unregistering GameObjects.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.2

Release Notes - Wwise Unity Integration 2015.1.2

이 릴리즈는 Wwise 2015.1.2을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2015.1.2
  • Unity: Unity 4.6.5 Pro or Unity 5.1.2p2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.2.0f3
    Wii U | Unity 4.3.7f1 with Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-27029 Fixed: Fix rare occurence where a deactivated Unity GameObject might result in the associated AkGameObj being unregistered.
  • WG-28200 Fixed: Default active listener set to Everything affected 3D positioning of GameObjects close to (0, 0, 0). Resolved by setting default listener mask to L0.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1.1

Release Notes - Wwise Unity Integration 2015.1.1

이 릴리즈는 Wwise 2015.1.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2015.1.1
  • Unity: Unity 4.6.5 Pro or Unity 5.1.2p2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    Wii U | Unity 4.3.7f1 with Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-27977 Fixed: Unity crash when terminating, if the script order is wrong.
  • WG-28030 Fixed: Wii U/Unity: Release RPL is not tagged NDEBUG as required by the TRC.
  • WG-28042 Fixed: Unity: Not possible to run game if the Wwise project is not accessible.
  • WG-28044 Fixed: Unity: Performance issue, Wwise project is re-parsed endlessly.
  • WG-28046 Fixed: Remove mandatory dependency on an AkInitializer instance.
  • WG-28048 Fixed: Properly display the GameObject names in the Wwise profiler.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2015.1

Release Notes - Wwise Unity Integration 2015.1

이 릴리즈는 Wwise 2015.1을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2015.1

Known Issues:

  • WG-25669: Auto Populate of the Wwise Picker doesn't work in the Mac Editor.

해결된 문제:

  • WG-27079 Fixed: Properly set the encoding of the WwiseSettings.xml files for non-English locales.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.6

Release Notes - Wwise Unity Integration 2014.1.6

이 릴리즈는 Wwise 2014.1.6을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2014.1.6
  • Unity: Unity 4.6.5 Pro, or Unity 5.0.2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    WiiU | Unity 4.3.7f1 with WiiU add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

해결된 문제:

  • WG-27585 Fixed: Properly display the Wwise project hierarchy in the Wwise Picker window.
  • WG-27624 Fixed: (PS3) SetListenerPostion doesn't work on PS3
  • WG-27749 Fixed: Calling Wwise API while objects are destroying prints lots of errors.
  • WG-27977 Fixed: Unity crash when terminating, if the script order is wrong.
  • WG-28030 Fixed: WiiU/Unity: Release RPL is not tagged NDEBUG as required by the TRC

Known Unity Issues:

  • Xbox One: SoundEngine initialization fails even if Unity audio is disabled. See 문제 해결 for a workaround.
  • Windows Store Apps in Unity 4: The built game throws a DllNotFoundException. See 문제 해결 for a workaround.

해결된 문제:

  • WG-27585 Fixed: Properly display the Wwise project hierarchy in the Wwise Picker window.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.5

Release Notes - Wwise Unity Integration 2014.1.5

이 릴리즈는 Wwise 2014.1.5을 위한 Wwise SDK 업데이트를 제공합니다. 호환성:

  • Wwise SDK: 2014.1.5
  • Unity: Unity 4.6.5 Pro, or Unity 5.0.2 (Personal or Pro)
    Platforms: Wwise Unity Integration tested on:
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone     		Unity 5.0.2p3
    Xbox 360 | Unity 5.0.1f1
    Xbox One | Unity 5.0.2p4

Known Issues:

  • WG-25669 Fixed: Auto Populate of the Wwise Picker now works in the Mac Editor.

Known Unity Issues:

  • Xbox One: SoundEngine initialization fails even if Unity audio is disabled. See 문제 해결 for a workaround.
  • Windows Store Apps in Unity 4: The built game throws a DllNotFoundException. See 문제 해결 for a workaround.

새로운 기능:

  • Added support for Android x86.
  • Removed the need for Scripting Define Symbols for the Windows Store Apps platform.

해결된 문제:

  • WG-25733 Fixed: It is now possible to build iOS/Mac games using the Windows editor and vice-versa.
  • WG-26655 iOS: Fixed: Audio now restores after phone Interruption on iOS 8 under AmbientSound category.
  • WG-26875 Fixed: The AkMemBankLoader component now allocates aligned memory, preventing failures on certain platforms.
  • WG-27108 Fixed: Now there are no Unity error messages when posting events during the Destroy phase.
  • WG-27461 Fixed: AkGameObj set on the same object as AkEnvironment now gets the environment.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.4

Release Notes - Wwise Unity Integration 2014.1.4

This release delivers the Wwise SDK update for Wwise 2014.1.4, and compatibility with Unity 5.

호환성:

  • Wwise SDK: 2014.1.4
  • Unity: Unity 4 Pro, or Unity 5 (Personal or Pro)

해결된 문제:

  • WG-26780 Fixed: Not having the Wwise project present on the machine will no longer generate errors in the Unity console window.
  • WG-26837 Fixed: Fix the SoundBank reference counting in the AkBankManager to prevent premature unloading.

Known Issues:

  • WG-25669: Auto Populate of the Wwise Picker doesn't work in the Mac Editor.
  • WG-25733: Cannot build iOS/Mac games using the Windows editor and vice-versa.

새로운 기능:

  • Added support for the Windows Phone 8.1 platform (accessible via the Metro platform in the build settings).
  • Now fully compatible with Unity 5. The Wwise Unity Integration now uses the new Plugin Importer API to activate its plug-ins. The <UNITY_PROJECT_ROOT>/Assets/Plugins folder will no longer be used by the integration.

Migration notes: The recommended procedure to upgrade your Unity 4 project to Unity 5 is:

  1. Make sure you have a backup of your project
  2. Open your Unity 4 project in Unity 5. This will trigger the Unity upgrade assistant.
  3. Once the upgrade to Unity 5 is done, import the 2014.1.4 Unity integration
  4. A migration window will appear, click "Start"
  5. Once the migration window closes, the migration is done
  6. You are now ready to use the Wwise Unity Integration in Unity 5!


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.3

Release Notes - Wwise Unity Integration 2014.1.3

이 릴리즈는 Wwise 2014.1.3을 위한 Wwise SDK 업데이트를 제공합니다.

호환성:

  • Wwise SDK: 2014.1.3

Known Issues:

  • WG-25669: Auto Populate of the Wwise Picker doesn't work in the Mac Editor.
  • WG-25733: Cannot build iOS/Mac games using the Windows editor and vice-versa.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.2

Release Notes - Wwise Unity Integration 2014.1.2

This release delivers the Wwise SDK update for Wwise 2014.1.2 and bug fixes.

호환성:

  • Wwise SDK: 2014.1.2
  • This version is unavailable for the Xbox One platform due to XDK incompatibilities between the Unity Editor (October XDK) and the Wwise SDK (November XDK).

해결된 문제:

  • WG-26305 Fixed: Using null GameObject reports an unregistered GameObject on 64-bit builds.
  • WG-26337 Fixed: Added compatibility to the Mac 64-bit platform.
  • WG-26385 Fixed: Wwise takes CPU in Unity when in background on Android.
  • WG-26395 Fixed: Fixed build failure when building Windows Phone 8 project from the command line using MSBUILD.
  • WG-26430 Fixed: Fixed crash when calling SetBasePath() on iOS.

Known Issues:

  • WG-25669: Auto Populate of the Wwise Picker doesn't work in the Mac Editor.
  • WG-25733: Cannot build iOS/Mac games using the Windows editor and vice-versa.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1.1

Release Notes - Wwise Unity Integration 2014.1.1

This release delivers the Wwise SDK update for Wwise 2014.1.1, final documentation, and bug fixes.

호환성:

  • Wwise SDK: 2014.1.1
  • Unity: 4.x (5.0 not supported yet)

새로운 기능:

  • Added the support for the Wii U platform.
  • Added Plug-in Registration documentation.
  • Exposed the Wwise Sound Engine version in the Unity "Wwise Settings" dialog.
  • Updated documentation with more accurate information about the GeneratedSoundBanks and Populate button.

해결된 문제:

  • WG-26201: Explicitly call the scope of C# System calls


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2014.1

Release Notes - Wwise Unity Integration 2014.1

This release delivers the Wwise SDK update for Wwise 2014.1, bug fixes, a new Demonstration scene, and a migration process for projects created with the Wwise Unity Integration 2013.2.

Notable features:

  • Stability fixes
  • Added a demonstration scene
  • Added a migration process for projects created with the 2013.2 Wwise Unity Integration

호환성:

  • Wwise SDK: 2014.1
  • Unity: 4.x

Supported Platforms:

  • Android
  • iOS
  • Linux
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 and above)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

새로운 기능:

  • Added a demonstration scene, available in a separate package. See Wwise Demo 씬 for more information.
  • Added a migration process for projects created with the 2013.2 Wwise Unity Integration.
  • Wwise Components are now referenced by UUID within the Wwise Unity Integration. This allows renaming them in the Wwise Project without breaking the link with the Unity project.
  • Added some customizable triggers for posting events and loading banks. See Wwise 이벤트에 새로운 트리거 추가하기 for more information.
  • Added some customizable callbacks for Wwise events. See 인스펙터에서 AkAmbient 사용하기 for more information.
  • Reduced the AkSoundEngine plug-in size.
  • Added an option to create (or destroy) the WwiseGlobal object and the AkListener.

해결된 문제:

  • WG-25783: Fix a memory leak in the Callback Manager
  • WG-25677: Fix path issues on Mac

Known Issues:

  • WG-25669: Auto Populate of the Wwise Picker doesn't work in the Mac Editor.
  • WG-25733: Cannot build iOS/Mac games using the Windows editor and vice-versa.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.10

Release Notes - Wwise Unity Integration 2013.2.10

This release delivers the Wwise SDK update for Wwise 2013.2.10 and bug fixes.

Notable features:

  • WG-25783 Fixed: Fixed a memory leak when cancelling callbacks

호환성:

  • Wwise SDK: 2013.2.10
  • Unity: 4.x

Supported Platforms:

  • Android
  • iOS
  • Linux*
    • 32비트
    • 64비트
  • Mac OS X (10.6 and above)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32비트
    • 64비트
  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows Phone 8.0
  • Xbox360
  • Xbox One


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.9

Release Notes - Wwise Unity Integration 2013.2.9

This release delivers the Wwise SDK update for Wwise 2013.2.9, final documentation, and bug fixes.

Notable features:

  • Final version of the documentation
  • Stability fixes

호환성:

  • Wwise SDK: 2013.2.9
  • Unity: 4.x

Supported Platforms:

  • Android
  • iOS
  • Linux
    • 32-bit
    • 64=bit
  • Mac OS X (10.6 and above)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

새로운 기능:

  • Added the support for the Windows Phone 8.0 platform.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.8

Release Notes - Wwise Unity Integration 2013.2.8

This release delivers the Wwise SDK update for Wwise 2013.2.8, new Wwise-Unity integration tools, additional documentation, and bug fixes.

Notable features:

  • A simpler setup flow for new projects (see Unity 프로젝트에서 통합 설치/업그레이드하기)
  • Easier Wwise project access with the Wwise Picker (see Wwise Picker)
  • New and improved Unity components to wrap common audio tasks (see Wwise Unity 통합 사용하기)
  • Wwise-Unity Integration documentation merged and cross-referenced with Wwise SDK documentation (this file!)

호환성:

  • Wwise SDK: 2013.2.8
  • Unity: 4.x

Supported Platforms:

  • Android
  • iOS
  • Linux*
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 and above)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

새로운 기능:

  • Added the support for the Xbox One platform.
  • Added the support for the PS4 platform.
  • Added the support for the Linux platform.
    * Unity Integration for Linux is supported in Wwise 2013.2.8 Linux BETA.
  • Added the support for the Windows Phone 8.0 platform.

Migrations:

  • Multi-architecture Windows and Metro plug-ins are now installed into their designated folders and no longer need to be switched using Unity's Scripting Define Symbol feature.
  • Removed the feature for rebuilding the Integration from Unity Editor menu for simplicity.
  • Separated the ready-to-use Integration from the source code.
  • Upgraded Windows IDE solution from Visual Studio 2008 to 2010.
  • Updated the designated platform folders for Windows and Metro.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.5

Release Notes - Wwise Unity Integration 2013.2.5

This release delivers the Wwise SDK update for Wwise 2013.2.5, the support of new platforms, and bug fixes.

호환성:

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

Supported Platforms:

  • Android
  • iOS
  • Mac OS X (10.6 and above)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Xbox 360
  • Xbox One

새로운 기능:

  • Added the support for the new platform: PS4.
  • Added the support for the new platform: PS Vita.
  • Added the support for the new platform: Xbox One.
  • Android: Added a new API AddBasePath() to allow specifying a POSIX file system path for I/O.

해결된 문제:

  • WG-24351: iOS: Remote control interruption is not handled.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.4

Release Notes - Wwise Unity Integration 2013.2.4

This release delivers Wwise SDK update for Wwise 2013.2.4, bug fixes, and improvements.

호환성:

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

Supported Platforms:

  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 and above)
  • iOS
  • Android
  • Xbox360
  • PS3

새로운 기능:

  • New menu item Wwise > Help for opening the Integration documentation in the default web browser.
  • Added Version.txt metadata file to all distributions to indicate the base Wwse SDK info.

해결된 문제:

  • WG-24080: Compiler errors after switching to Android with both Windows and Mac APIs present.

Migrations:

  • Removed Android armeabi plug-ins.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.2.1

Release Notes - Wwise Unity Integration 2013.2.1

This release delivers the Wwise SDK update for Wwise 2013.2.1, new features including an overhauled distribution, installation and build experience, and bug fixes.

호환성:

  • Wwise SDK: 2013.2, 2013.2.1
  • Unity: 4.x (3.x is no longer supported)

Supported Platforms:

  • Windows 8 (Metro)
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 and above)
  • iOS
  • Android
  • Xbox360
  • PS3

새로운 기능:

  • Unity Integration is now distributed as a Unity asset bundle that contains the target platform version and the desktop version. It can be imported directly into a Unity project, and function in both the Editor and on target devices.
  • A new Wwise menu was added in the Unity Editor UI for the following tasks:
    • Installing the plug-in.
    • Rebuilding the Integration.
    • Converting a SoundBank ID C++ header into its C# version.
  • Build and run applications for multi-architecture platforms (for example, Windows) with Unity 4's Custom scripting symbols feature.
  • A build script for rebuilding the Integration for any supported platform through the command line.
  • A simplified positioning demo added to the IntegrationDemo.
  • Android: SoundBanks can now be saved in and loaded from the Android Expansion Files (OBB).

해결된 문제:

  • WG-23781: Bank callback does not work.
  • WG-23734: Marker callback receives garbled strings on Windows platforms.
  • WG-23345: Compiler errors when switching to unsupported platforms in Unity Editor.
  • WG-23436: Unity: listener positioning error due to wrong index type cast.
  • WG-23423: Performance issue with GameObjects in Unity related to component access.
  • WG-22533: Unity: Some API binding functions shouldn't have exception handlers.

Improvements:

  • Simplified iOS plug-in installation and deployment.
  • Updated documentation with more accurate prerequisites and other instructions.

Migrations:

  • The installed file and folder structure is updated for the new distribution method. 자세한 내용은 Unity 프로젝트에서 통합 설치/업그레이드하기 을 참고하세요.
  • The plug-ins for multi-architecture platforms are renamed. See BUILD THE APPLICATION FOR A MULTI-ARCHITECTURE PLATFORM for details.
  • On iOS, there is no longer a need to configure Xcode project to find the plug-in library. But a new native API call is needed. 자세한 내용은 pg_iOSInfo 를 참고하세요.
  • The previous multi-architecture platform build UI script examples are removed.
  • The old build script for the Apple platforms is removed.
  • SWIG is upgraded to 2.0.11.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.1.1

Release Notes - Wwise Unity Integration 2013.1.1

This release includes the Wwise SDK update for Wwise 2013.1.1. No other changes were made in the Integration.


Wwise Unity Integration Documentation: Release Notes - Wwise Unity Integration 2013.1

Release Notes - Wwise Unity Integration 2013.1

This release includes the Wwise SDK update for Wwise 2013.1, Android-related new features, and general bug fixes.

호환성:

  • Wwise SDK: 2012.2.x, 2013.1
  • Unity: 3.4.x, 3.5.x, 4.x

Supported Platforms:

  • Windows 8
    • Desktop
    • Windows Store App on Intel devices and ARM tablets
  • Windows (32비트)
  • Windows (64비트)
  • Mac OS X (10.6 and above)
  • iOS
  • Android
  • Xbox360
  • PS3

새로운 기능:

  • Android: SoundBanks can now be saved in Android application packages (apk) and are accessible transparently using LoadBank() APIs.
  • Support for Windows 64bit.
  • Support for Windows 8.

해결된 문제:

  • WG-22948: Positioning error due to listener index assignment error on PS3.
  • WG-22938: Positioning data passed by Unity Integration on Mac OSX is invalid.
  • WG-22334: Music userCue names are incorrectly reported to Unity as empty strings.
  • WG-22329: Cannot PostEvent() to global scope with Unity Integration.
  • WG-22255: Unity Android: Sound persists after switching app to background.
  • WG-22165: 3D positioning does not work properly under iOS and Android.
  • WG-21933: AkCallbackManager.cs handles deserialization of floats incorrectly. UserCue names broken.
  • WG-21365: Unity iOS: Cannot hear sounds after iOS audio interruption events come and go.
  • WG-22533: Some API binding functions shouldn't have exception handlers.

Improvements:

  • Windows and Mac distributions can coexist in the same Unity project.
  • Improved documentation readability and accuracy and added 플랫폼별 정보 section for easily reading the info about platforms of interest.
  • Build logs now support quiet and verbose modes for readability.
  • Build pipeline now checks user Python version and warns if it is outdated.
  • Deployment script can now be used directly to copy the Integration to Unity projects.

Migrations:

  • Visual Studio 2010 is now required to build the Integration for PS3.
  • Build scripts no longer support Python 2.6 and older versions. Python 2.7.x or 3.x is required.
  • The environment variable UNITY_PROJECT_ROOT is no longer required for building the Integration yourself. By default, the Integration is no longer automatically deployed to the folder specified by UNITY_PROJECT_ROOT. 자세한 내용은 소스 코드에서 네이티브 Integration 플러그인 빌드하기 를 참고하세요.
  • Android build scripts no longer deploy PostprocessBuildPlayer scripts to Unity projects.
  • IntegrationDemo project is upgraded to Unity4 format.


Wwise Unity Integration Documentation: Unity 프로젝트에서 통합 설치/업그레이드하기

Unity 프로젝트에서 통합 설치/업그레이드하기

Wwise Unity 통합은 Wwise가 Unity 프로젝트에서 작동하도록 해주는 Unity 컴포넌트, Editor 도구, 설명서를 담고 있습니다.

필요에 따라 다양한 설치와 업그레이드 절차에 대한 정보는 다음 페이지를 참조하세요.

  • 선행 조건
  • Wwise 통합 패키지 최초 설치
  • Unity 프로젝트의 변경 사항
  • 게임에 사운드 통합하기
  • SoundBank 위치 설정하기
  • 플러그인 추가하기
  • Wwise의 최신 버전 사용을 위해 통합 업그레이드하기


Wwise Unity Integration Documentation: 선행 조건

선행 조건

플랫폼별 정보 에서 각 플랫폼의 Wwise 요구 사항을 확인하세요.

참고: 이 통합은 Unity Cloud Build 서비스를 지원하지 않습니다.

Unity로의 통합은 다음 소프트웨어를 필요로 합니다.

Platform | Required components
iOS | Xcode 7.2 or above with compatible iOS SDK
Windows | DirectX End-User runtime x64 Visual Studio 2013 재배포 가능 패키지
Windows 32비트 디버그 | x86 Visual Studio 2013 재배포 가능 패키지


Wwise Unity Integration Documentation: Wwise 통합 패키지 최초 설치

Wwise 통합 패키지 최초 설치

Audiokinetic 런처를 이용해 Wwise Integration 패키지를 설치할 수 있습니다. 더 자세한 정보는 Unity 프로젝트에 Wwise 통합하기(Integrating Wwise into a Unity Project) 를 참고해 주세요.

경고: 작업 실행 전 주의 사항:
  • Unity 프로젝트를 백업하세요. 소스 컨트롤 시스템을 사용하거나 Audiokinetic 런처를 사용할 수도 있습니다. 런처를 통해 프로젝트를 백업하려면 반드시 프로젝트 통합 페이지에서 Install files into a copy of the Unity project directory, then apply changes if successful이 선택되어 있는지 확인하세요.
  • Wwise 통합을 설치하기 전에 먼저 Unity 프로젝트가 오류 없이 성공적으로 컴파일할 수 있는 상태인지 확인하세요. (경고 메시지는 괜찮습니다.)
  • Unity 프로젝트가 소스 컨트롤 안에 있을 경우 통합을 시작하기 전에 전체 Unity 프로젝트를 체크 아웃하세요. 그렇지 않으면 파일을 변경할 수가 없어 통합이 실패하게 됩니다.
  • 기존 Wwise 프로젝트를 Unity 프로젝트에 통합하려는 경우 Wwise Project Settings 대화 상자에서 Enable Auto-Defined SoundBanks 옵션이 선택 해제되어 있는지 확인하세요.

Unity 통합 확장

사용자가 게임 오브젝트를 자동으로 등록하거나 이 기능을 모두 제거할 수 있도록 사용자 후크가 partial 메소드의 형태로 추가되었습니다. 기본 설정된 확장자를 권장하지만 Unity 프로젝트에 Wwise 통합하기 중 이를 제외하도록 선택할 수 있습니다.


Wwise Unity Integration Documentation: Unity 프로젝트의 변경 사항

Unity 프로젝트의 변경 사항

Wwise Integration 설치 과정이 Unity 프로젝트를 다음과 같은 방식으로 변경합니다.

  • Edit > Project Settings… > Audio에서 Disable Audio 옵션이 활성화됩니다. 이 옵션은 내장 오디오 시스템을 비활성화합니다.
  • Create WwiseGlobal GameObject Wwise Setting을 활성화했을 경우 'Wwise Global'이라는 게임 오브젝트가 현재 씬에 생성됩니다. 또한 WwiseGlobal 오브젝트에는 편집 모드에서 AkEvent 오브젝트 미리 보기에 사용되는 AkEditorEventPlayer, AkAudioListener, AkGameObj 스크립트가 있습니다. AkEnvironment, AkRoom, AkGameObj 간의 상호 작용을 미리 볼 수 있도록 Rigidbody 컴포넌트가 추가되었습니다.
참고: WwiseGlobal 오브젝트는 Wwise Sound Engine의 Initializing과 Terminating 스크립트를 담은 GameObject 입니다. Editor 작업 과정에서 이 오브젝트는 모든 씬에 추가되어 Editor에서 알맞게 미리볼 수 있습니다. 빌드에서는 첫 번째 장면에서 단일 인스턴스가 생성되고 게임 내내 지속됩니다. 초기화 스크립트에는 커스터마이징할 수 있는 옵션이 몇 가지 있습니다. - Wwise SDK 문서에서 사운드 엔진 모듈 초기화하기를 참고하세요.
  • 중요한 Wwise 스크립트 (AkInitializer와 AkGameObj, AkAudioListener, AkBank)에 Script Execution Order가 활성화됩니다.
  • Add Ak Listener to Main Camera 체크 상자를 활성화했을 경우 Main Camera 오브젝트에서 Audio Listener 컴포넌트를 제거하고 기본 AkAudioListener.cs 스크립트가 Main Camera 오브젝트에 설정됩니다.
  • Edit > Project Settings > Player > Resolution and Presentation에서 Run in Background 옵션을 활성화하여 Wwise Profiler에 연결할 수 있습니다.


Wwise Unity Integration Documentation: 게임에 사운드 통합하기

게임에 사운드 통합하기

이제 게임에서 Wwise 사운드를 재생할 수 있습니다. Wwise 프로젝트에 사운드, Event, SoundBank가 이미 준비되지 않았다면 Wwise를 시작하고 다음을 실행하세요.

  1. WAV 파일을 가져오세요. File Explorer 창에서 Project Explorer의 Audio 탭으로 파일을 드래그하세요. 그러면 Sound가 생성됩니다.
  2. Event를 만드세요. 사운드를 우클릭하고 New Event를 선택하세요. 알맞은 이름을 지정하세요.
  3. SoundBank를 만드세요. SoundBanks 레이아웃으로 전환하세요 (F7). SoundBank Manager에서 New…를 클릭하세요.
  4. SoundBank에 Event를 넣으세요. Project Explorer에서 SoundBank로 Event를 드래그하여 넣을 수 있습니다.
  5. Generate Selected를 클릭하세요. 이제 재생할 사운드가 생겼습니다.
경고: Unity 통합은 Auto-Defined SoundBank를 지원하지 않습니다. Wwise Project Settings에서 이 기능이 비활성화되어 있는지 확인하세요.

그럼 이제 Unity 프로젝트에 사운드를 통합해봅시다.

  1. Wwise Picker 창 (Window > Wwise Picker)을 여세요. 만들어둔 Event와 SoundBank가 보입니다.
  2. SoundBank를 씬 안에 있는 오브젝트로 드래그하세요.
  3. 씬 안에 있는 오브젝트로 Event를 드래그하세요.
  4. 게임을 실행해보세요! 게임이 시작되자마자 사운드가 들려야 합니다.

아무 소리도 들리지 않으신가요? 문제 해결 페이지를 읽어주세요.

더 많은 사운드 통합하기

현재 Unity로 통합된 Wwise는 일반적으로 사용되는 몇 가지 Unity 컴포넌트를 제공합니다.

  • AkAmbient 를 사용해서 씬에 고정된 사운드 이미터를 배치하세요.
  • AkBank 를 사용해서 SoundBank를 로드하세요.
  • AkEnvironment 를 콜라이더에 연결하여 특정 구역에 리버브를 설정하세요.
  • 다른 컴포넌트에 대해 더 알아보세요.

하지만 게임에 필요한 보다 복잡한 작동 방식을 구현하려면 프로그래머의 도움으로 스크립트를 작성해야 합니다. Wwise API에 관한 더 많은 정보는 여기 두 섹션을 참고하세요.

  • 게임에 Wwise 요소 통합하기
  • AK::SoundEngine 네임스페이스 레퍼런스


Wwise Unity Integration Documentation: SoundBank 위치 설정하기

SoundBank 위치 설정하기

Unity Editor에서 프로젝트를 실행할 때 프로토타입 속도를 높일 수 있도록 Wwise 프로젝트의 GeneratedSoundBanks 폴더에서 직접 SoundBank를 가져오게 됩니다. 기본 폴더 위치는 …\<UnityProjectName>\Assets\StreamingAssets\Audio\GeneratedSoundBanks 입니다.

SoundBank의 위치를 변경하려면 Edit > Project Settings > Wwise Editor로 이동해서 SoundBank Path를 업데이트하세요.

Unity는 프로젝트를 패키징할 때 대상 플랫폼에 따라 애셋을 선택적으로 패키징하지 않습니다. 대신 지정된 SoundBanks 폴더에 있는 모든 SoundBank를 패키징합니다. Unity가 필요한 플랫폼용으로만 SoundBank를 빌드하고 패키징하도록 하려면 Wwise Editor 페이지에서 Copy SoundBanks at pre-Build step을 선택하세요.

혹은 고급 Unity 개발자의 경우 BuildPlayerPipeline 스크립트를 사용할 수 있습니다.

만약 Unity Addressables를사용하고 있다면 SoundBank 옵션이 약간 다릅니다. 더 자세한 내용은 Addressables를 위해 생성된 SoundBank 위치 설정하기 를 참고하세요.

참고
  • 원하는 플랫폼으로 Unity 게임 빌드하기

Addressables를 위해 생성된 SoundBank 위치 설정하기

프로젝트에서 Unity Addressables를 사용하는 경우, Unity가 SoundBank를 제대로 가져올 수 있도록 하기 위해서 생성된 SoundBank가 담긴 폴더가 프로젝트 내에 있어야 합니다.

생성된 SoundBanks 경로를 설정하려면 Edit > Project Settings > Wwise Editor로 이동해서 Generated SoundBanks Path를 업데이트 하세요. 이 폴더의 위치는 반드시 Assets 폴더 내에 있어야 합니다.

참고
  • Wwise Unity Addressables 패키지 설치하기


Wwise Unity Integration Documentation: 플러그인 추가하기

플러그인 추가하기

내장된 모든 Wwise 음원 및 Effect 플러그인은 통합에서 기본적으로 사용할 수 있습니다.

Effect 플러그인은 동적 라이브러리로 사용할 수 있습니다. 라이브러리는 Wwise 프로젝트에서 플러그인의 사용 여부에 따라 Unity 프로젝트에 자동으로 들어갑니다. 프로젝트가 사용하는 Effect 플러그인의 목록은 SoundBank를 생성할 때 컴파일됩니다.

이전에 사용하지 않던 플러그인을 프로젝트에 추가하려면 다음 단계를 실행하세요.

  1. Wwise 프로젝트에서 해당 Effect 플러그인을 사용하세요.
  2. 작업 중인 플랫폼의 SoundBank를 생성하세요.
  3. Unity 프로젝트로 전환하세요.
  4. 새로운 SoundBank를 StreamingAssets 폴더에 복사하세요. (Play in Editor(에디터에서 재생) 할 경우 복사할 필요가 없습니다.)
  5. 게임을 컴파일하세요 (혹은 Play in Editor).

런처를 사용하여 이미 Wwise에 설치한 플러그인은 Wwise를 Unity 프로젝트에 통합하면 자동으로 사용할 수 있습니다. 그러나 Wwise 프로젝트를 Unity 프로젝트에 통합한 후에 플러그인을 설치하는 경우 통합에서 플러그인을 사용하려면 Unity와 Unreal 통합에 플러그인 추가하기 에 설명된 단계를 따라야 합니다.

라이선스된 플러그인은 기본 Wwise 라이선스(McDSP, iZotope, Auro, SoundSeed, Crankcase REV, Convolution Reverb, Motion)안에 들어가지 않습니다. 그렇기 때문에 저작 애플리케이션에서는 사용해볼 수 있지만 게임에서는 사용할 수 없습니다. 유효한 라이선스가 없을 경우 저희에게 연락 해주세요. 평가판 라이선스는 항상 무료입니다.

새로운 Wwise Effect 플러그인을 만들고 싶은 경우 (그런 다음 Unity로 추가) 새로운 플러그인 제작하기 섹션을 읽어주세요. iOS, tvOS, Nintendo Switch의 경우 플러그인이 반드시 정적 라이브러리로서 제공되어야 합니다. 플러그인 정적 등록을 참고하세요. 통합에 들어 있지 않은 플러그인은 AkPluginActivator.StaticPluginRegistration 클래스 안에서 생성된 해당 CPP 파일 안에 자동으로 등록됩니다. 새로운 플러그인을 등록하려면 다음과 유사한 CPP 파일을 만들어야 합니다.

namespace AK { class PluginRegistration; };
#define AK_STATIC_LINK_PLUGIN(_pluginName_) extern AK::PluginRegistration _pluginName_##Registration; void *_pluginName_##_fp = (void*)&_pluginName_##Registration;
#include "MyNewPluginFactory.h"
AK
Definition: AkWwiseAcousticTexture.cs:21


Wwise Unity Integration Documentation: Wwise의 최신 버전 사용을 위해 통합 업그레이드하기

Wwise의 최신 버전 사용을 위해 통합 업그레이드하기

Wwise의 새로운 메이저 버전과 마이너 버전이 출시되면 새 버전의 Wwise를 사용하도록 통합 패키지를 업데이트할 수 있습니다.

다음 업그레이드 절차에서는 다음을 가정합니다:

  • 이전 버전의 Wwise용 Wwise 통합 패키지가 포함된 Unity 프로젝트가 이미 있습니다.
  • Wwise SDK와 기존 통합에서 지원하는 모든 배포 플랫폼을 포함하여 새 버전의 Wwise를 이미 설치했습니다.
경고: 권장 사항
  • 업그레이드 작업은 되돌릴 수 없습니다. 작업을 진행하기 전에 Unity 프로젝트를 백업하세요.
  • Unity 프로젝트가 소스 컨트롤 안에 있을 경우 업그레이드를 시작하기 전에 Unity 프로젝트 전체를 체크 아웃하세요. 그렇지 않으면 파일을 성공적으로 변경할 수 없기 때문에 업그레이드에 실패하게 됩니다.
  • Wwise 통합을 업그레이드하기 전에 먼저 Unity 프로젝트가 오류 없이 성공적으로 컴파일할 수 있는 상태인지 확인하세요. (경고 메시지는 괜찮습니다.)
  • C++ AkSoundEngine 플러그인 소스 코드의 C++ Wwise SDK를 수정했다면 플러그인의 C++ 코드를 변경한 경우 Wwise Integration 패키지를 새로운 버전으로 업데이트/업그레이드 하기 에 열거된 지시에 따라주세요.
  • Unity용 Wwise Addressables Package 를 사용하는 경우 Wwise Unity Addressables 패키지 업데이트하기 를 참고해 주세요.

다른 Unity 플러그인과는 달리 Wwise Integration 패키지를 새로운 버전으로 업데이트하려면 이전의 패키지 버전을 설치한 채로 놔두어야 합니다.

경고: 새 통합으로 업그레이드하기 전에 기존 Wwise 통합을 삭제하지 마세요. 그러면 게임의 모든 Wwise 오디오가 손실됩니다.

업그레이드는 두 부분으로 진행됩니다. 먼저 Wwise 프로젝트를 사용하고자 하는 새로운 버전으로 업데이트하세요 그런 다음 Unity 프로젝트도 마찬가지로 업그레이드하세요.

  1. Wwise 프로젝트 업데이트:
    1. 런처에서 Wwise 페이지를 선택하세요.
    2. 새로 설치된 Wwise 버전을 시작합니다.
    3. 기존 Wwise 프로젝트를 여세요.
    4. Wwise 프로젝트를 새로운 버전으로 업데이트하라는 메시지가 뜨면 Update를 클릭하세요.
    5. 업데이트가 완료되면 Wwise SoundBank를 생성합니다.
    6. Wwise 프로젝트를 저장하세요.
  2. Unity 프로젝트 업데이트:
    1. Wwise의 새로운 버전에 대한 Unity 프로젝트 업데이트는 런처를 사용하여 수행됩니다. 자세한 내용은 런처 문서의 통합 패키지 업데이트 및 변경하기를 참고해 주세요.

Wwise 2021.1.1 이전 버전에서 업그레이드하기

Wwise 2021.1.1이나 Wwise 2021.1.1 이전의 후반 버전으로 업그래이드할 경우 Unity 프로젝트에서 JsonSerialize 패키지가 반드시 활성화되어야 합니다. 그렇지 않으면 업그레이드에 실패하게 됩니다. 이 패키지는 다음 두 가지 방법으로 활성화할 수 있습니다.

  1. Unity 패키지 매니저에서 패키지 활성화하기.
    • 이 패키지는 Built-in packages 목록 아래 있습니다.
  2. Packages/Manifest.json에 있는 의존성 목록에 "com.unity.modules.jsonserialize": "1.0.0"을 추가하기.
    • 변경한 후에는 Unity 프로젝트를 열고 닫아서 패키가 올바르게 프로젝트에 추가되도록 해주세요.


Wwise Unity Integration Documentation: Wwise Integration Package 제거하기

Wwise Integration Package 제거하기

Wwise Integration Package를 제거하려면 Unity 프로젝트에서 Assets/Wwise 폴더를 직접 삭제해야 합니다. 그렇게 하더라도 Wwise 컴포넌트가 게임 오브젝트에서 제거되거나 그 외 설정이 변경되지도 않습니다.

또한 Wwise Addressables 패키지를 사용하려는 경우 Unity의 Package Manager를 사용하거나 [Unity Project]/Packages/manifest.json에서 해당 입력란을 삭제해서 패키지를 제거해야 합니다.


Wwise Unity Integration Documentation: Unity Editor Settings 조정하기

Unity Editor Settings 조정하기

Wwise Editor Settings는 Wwise Editor 섹션 아래 Project Settings Window (Edit > Project Settings)에서 확인할 수 있습니다.

Wwise Sound Engine 초기화에서 사용되는 프로젝트 설정의 경우 Wwise Initialization Settings 조정하기 페이지를 참고해 주세요.

Wwise Project Settings

Wwise Project Path: 해당 게임과 연결된 Wwise 프로젝트의 위치. Unity Project 루트 폴더 안에 있으며 Assets 폴더 밖에 있도록 배치하는 것이 좋습니다.

Wwise Application Path: Wwise 애플리케이션의 위치. 이 위치는 Unity 안에서 SoundBank를 생성하기 위해 꼭 필요합니다.

Editor 작동 방식 설정

SoundBank 옵션은 Unity Addressables 사용 여부에 따라 달라집니다. Addressables에 대한 자세한 내용은 Unity용 Wwise Addressables Package 를 참고해 주세요.

SoundBanks Path: StreamingAssets 폴더에 대한 (혹은 그 안에서의) SoundBank의 위치. 이 위치는 게임을 빌드할 때 생성된 사운드뱅크를 프로젝트로 복사하는 데에 사용됩니다. 프로젝트에 Unity Addressables 패키지가 설치되어 있으면 이 옵션은 나타나지 않습니다. 대신 Generated SoundBanks Path를 지정해야 합니다.

Generated SoundBanks Path: 프로젝트에서 생성된 SoundBank의 위치. 이 옵션은 Addressables 패키지가 프로젝트에 설치된 경우에만 나타납니다. SoundBank를 제대로 가져오려면 경로가 프로젝트의 Assets 폴더 아래에 있는지 확인하세요.

Copy SoundBanks at pre-Build step: 이 옵션을 선택하면 빌드 및 배포 중에 SoundBank가 SoundBank Path에 지정된 위치로 복사됩니다. 이 옵션을 선택하는 것이 좋습니다. 프로젝트에 Unity Addressables 패키지가 설치되어 있으면 이 옵션은 나타나지 않습니다.

Generate SoundBanks at pre-Build step: 빌드 사전 단계 도중 SoundBank를 복사하기 전에 먼저 SoundBank를 생성합니다. SoundBank가 특정 빌드 머신에서 생성되는 경우 이 옵션을 선택하지 않는 것이 좋습니다. 프로젝트에 Unity Addressables 패키지가 설치되어 있으면 이 옵션은 나타나지 않습니다.

Create WwiseGlobal GameObject: WwiseGlobal 오브젝트는 Wwise Sound Engine의 Initializing 및 Terminating 스크립트를 담고 있는 GameObject입니다. Editor 작업 과정에서 이 오브젝트는 모든 씬에 추가되어 Editor에서 알맞게 미리볼 수 있습니다. 게임에서는 첫 번째 씬에서 단 하나의 인스턴스가 생성되며 게임 내내 유지됩니다. 이 체크 상자는 활성화한 상태로 두는 것이 좋습니다.

Add Listener to Main Camera: 위치 지정이 작동하려면 AkAudioListener 스크립트가 모든 씬에서 메인 카메라에 연결되어야 합니다. 리스너가 다른 GameObject와 연결되어야 할 경우 이 상자를 비활성화하세요.

Auto-delete WwiseObjectReferences: Event, Bank, Buss와 같은 Wwise 오브젝트는 Wwise/ScriptableObjects 폴더 안에 있는 WwiseObjectReference 에셋을 사용하여 이러한 참조를 추적합니다. 이 옵션이 활성화되었으며 Wwise Object가 Wwise Project에서 제거될 경우 Wwise 프로젝트 구조를 파싱하면 Wwise/ScriptableObjects 폴더에 있는 해당 에셋이 삭제됩니다.

Load Sound Engine in Edit Mode: Edit Mode에서 Sound Engine을 로드합니다. Sound Engine이 게임 내에서 제대로 초기화되었는지 확인하려면 이 설정을 비활성화하세요. 이 설정을 비활성화하면 Inspector, Timeline 등과 같은 기능에서 소리가 재생되지 않습니다. 소리를 들을 수 있는 유일한 방법은 Editor에서 Play를 클릭하는 것입니다. 이 설정은 Enter Play Mode 작동 방식 에 영향을 줍니다.

Show Spatial Audio Warnings: Spatial Audio가 올바르게 작동하도록 구성되지 않은 Wwise 컴포넌트에 대해 경고 메시지가 표시됩니다. 이 체크 상자는 활성화한 상태로 두는 것이 좋습니다.

WAAPI 설정

Connect to Wwise: 이 옵션을 활성화할 경우 에디터는 Wwise Authoring 인스턴스를 사용하여 WAAPI 연결을 확립하려고 주기적으로 시도하게 됩니다.

WAAPI Port: 연결할 포트를 말합니다. Wwise Authoring 의 (Project > User Settings) 에서 검토할 수 있습니다. 기본값은 8080입니다.

WAAPI IP address: Wwise 저작 도구를 실행하는 장치의 IP 주소를 말합니다. 같은 장치에서 실행할 경우 127.0.0.1을 사용하세요.

Wwise 오류 메시지 번역기 설정

Error Translators는 오류 메시지의 숫자 ID의 정보를 사람이 읽을 수 있는 이름으로 변환하도록 해줍니다. 오류 메시지를 번역하는 방법은 SoundBanksInfo.xml을 통한 방법과 WAAPI를 통한 방법 두 가지가 있습니다.

SoundBanksInfo.xml 파일이 사운드뱅크 파일과 함께 위치해 있는 경우(선택 사항) XML 방식을 사용하는 것이 더 빠릅니다.

WAAPI는 Wwise 인스턴스에서 직접 최신 정보를 읽을 수 있다는 장점이 있습니다. 그러나 네트워크 통신은 매우 느릴 수 있습니다. 이 때문에 이 옵션은 기본적으로 비활성화되어 있습니다.

XML Translator Timeout XML 파일 리더의 ID를 검색하는 데 할당된 최대 시간(밀리초). 비활성화하려면 0으로 설정하세요.

WAAPI Translator Timeout WAAPI 연결을 통해 ID를 검색하는 데 할당된 최대 시간(밀리초). 비활성화하려면 0으로 설정하세요.


Wwise Unity Integration Documentation: Wwise Initialization Settings 조정하기

Wwise Initialization Settings 조정하기

Wwise Initialization Settings(와이즈 초기화 설정)은 Wwise 사운드 엔진의 C/C++ SDK 안에 있는 다음 구조체의 구성 요소에 해당합니다.

  • AkCommSettings
  • AkDeviceSettings
  • AkInitSettings
  • AkMemSettings
  • AkMusicSettings
  • AkPlatformInitSettings
  • AkSpatialAudioInitSettings
  • AkStreamMgrSettings

이 설정에는 경로, 언어, 샘플 레이트, 대기열 크기, 메모리 스레숄드, 풀 크기 등 엄청난 범위의 내용이 있기 때문에 어렵게 느껴질 수 있습니다. 하지만 대부분의 경우 기본 설정으로 유지하면 됩니다. 하지만 프로젝트의 상황에 따라 Wwise Initialization Settings에 접근하여 조정해야 할 수도 있습니다.

Wwise Initialization Settings에 접근하기

Wwise Initialization Settings은 이제 Unity Editor에 노출되어 있습니다. 그렇기 때문에 변경하기 위해 스크립트를 사용할 필요가 없습니다.

이 설정은 Wwise Initialization 섹션 아래 Project Settings Window (Edit > Project Settings...)에서 확인할 수 있습니다.

Wwise Initialization Settings (Wwise 초기화 설정)

Project Settings 창에서 Wwise Initialization Settings은 네 가지 직관적인 그룹인 Common User Settings(공통 사용자 설정), Common Advanced Settings(공통 고급 설정), Wwise Communication Settings(와이즈 통신 설정), Platform Specific Advanced Settings (플랫폼 고급 설정) (Platform 은 사용자가 작업 중인 플랫폼)으로 구성되어 있습니다. 각 설정은 인터페이스의 입력란, 체크 상자, 슬라이더를 통해 직접 편집할 수 있습니다. 또한 사용자의 편의를 돕기 위해 매개 변수 자체에 대한 추가 정보나 가능한 값을 제공하는 툴팁이 모든 설정에 제공됩니다.

편리한 툴팁을 보여주는 Common User Settings

Platform-Specific Settings

Common User Settings, Common Advanced Settings, Wwise Communication Settings에서는 각 플랫폼의 설정값을 쉽게 접근할 수 있게 묶여서 제공됩니다. 체크 상자가 활성화된 모든 플랫폼에 값을 전역적으로 적용할 수 있습니다. 또한 체크 상자를 비활성화하면 플랫폼 별로 값을 설정할 수 있습니다.

Platform 구체적인 Advanced Settings는 Wwise 커스텀 플랫폼 별로 표시되어 사용자가 각 플랫폼에 맞게 설정할 수 있게 해줍니다.

플랫폼 별로 값이 다르게 설정되어 있는 Common Advanced Settings
참고:
Initialization Settings에서 변경된 내용은 사운드 엔진을 재생하고 중단하기 전까지 아무 효과를 주지 않습니다.


Wwise Unity Integration Documentation: SoundBank 관리하기

SoundBank 관리하기

Wwise Unity 통합은 SoundBank 관리에 관한 여러 옵션을 제공하며 몇 가지 고유한 요구 사항이 있습니다. 통합을 사용하는 경우 다음 사항에 주의하세요.

  • 권장되는 SoundBank 위치는 Unity Addressables 사용 여부에 따라 달라집니다(Unity용 Wwise Addressables Package). Addressables를 사용하는 경우 SoundBank를 제대로 가져올 수 있도록 SoundBank가 프로젝트의 Assets 폴더 내에 있어야 합니다. 그러나 Addressables를 사용하지 않는 경우 SoundBank를 프로젝트 외부에 배치할 수 있습니다. 자세한 내용은 SoundBank 위치 설정하기 및 Wwise Unity Addressables 패키지 설치하기 를 참고해 주세요.
  • Unity에서 Wwise Picker를 통해 SoundBank를 생성할 수 있습니다. 더 자세한 내용은 Wwise Picker 를 참고하세요.
  • Unity 개발자는 AkBank 클래스 를 사용하여 로드, 언로드, 디코딩과 같은 다양한 SoundBank 작업을 수행할 수 있습니다.
  • 자동 정의 SoundBank는 지원되지 않기 때문에 Wwise 프로젝트에서 이와 관련된 옵션이 비활성화되어 있는지 확인해야 합니다. Wwise Authoring에서 Project > Project Settings > SoundBanks로 이동해서 Enable Audo Defined SoundBanks선택이 해제되어 있는지 확인하세요. SoundBanks 탭을 참고해 주세요.


Wwise Unity Integration Documentation: Wwise Unity 통합 사용하기

Wwise Unity 통합 사용하기

Unity 통합은 Unity Scene GameObject에서 직접 사용할 수 있는 Wwise 전용 컴포넌트를 제공합니다. 이 컴포넌트는 대부분의 사운드 디자인 상황에 필요한 필요를 채워줍니다. 해당 컴포넌트는 커스텀 C# 스크립트를 사용하지만, 코드 작업 없이 퍼블릭 속성을 편집할 수 있습니다.

Wwise 컴포넌트 추가하기

Unity GameObject에 Wwise 컴포넌트를 추가하는 방법:

  • 씬에서 선택한 GameObject와 함께 로드된 Unity Inspector 창(Ctrl+3)으로 가세요.
  • Add Component를 클릭해서 Component 목록을 여세요.
  • Wwise를 선택해서 하위 목록을 열고 원하는 Wwise 컴포넌트 를 선택하세요.
    도움말: 컴포넌트 검색란에 'ak'를 입력하면 모든 Wwise 컴포넌트를 담은 목록에 빠르게 접근할 수 있습니다.

Wwise Picker에서 Wwise 컴포넌트 추가하기

Wwise Picker에서 Inspector나 로드된 씬의 Hierarchy에 열거된 게임 오브젝트로 Wwise 오브젝트를 드래그하면 게임에 컴포넌트를 직접 추가할 수 있습니다.

참고
  • Wwise 컴포넌트
  • Wwise Picker

The WwiseGlobal 오브젝트

WwiseGlobal 오브젝트는 Wwise Sound Engine의 Initializing과 Terminating 스크립트를 담은 GameObject 입니다. Editor 작업 과정에서 이 오브젝트는 모든 씬에 추가되어 Editor에서 알맞게 미리볼 수 있습니다. 게임에서는 첫 번째 씬에서 단 하나의 인스턴스가 생성되며 게임 내내 유지됩니다. 초기화 스크립트에는 커스터마이징할 수 있는 옵션이 몇 가지 있습니다.

이 작동 방식을 비활성화하려면 Edit > Project Settings > Wwise Editor를 사용하여 Create WwiseGlobal GameObject를 비활성화하세요. 이 경우 게임에서 지속적으로 유지될 오브젝트에 초기화 스크립트를 여러분이 직접 추가하셔야 합니다.

Main Camera에서의 리스너

위치 지정이 작동하려면 모든 씬에서 Ak Audio Listener 스크립트가 메인 카메라에 연결되어야 합니다. 기본적으로 리스너는 메인 카메라에 자동으로 추가됩니다. 이 작동 방식을 비활성화하려면 Edit > Project Settings > Wwise Editor를 사용하여 Automatically add Listener to Main Camera를 비활성화하세요.

참고
  • 3인칭 게임에서 Distance Probe를 사용하는 법에 대한 더 많은 정보는 Ak Listener Distance Probe 를 사용하여 3인칭 게임에서 리스너 사용자 지정하기 를 참고해 주세요.

Wwise 타입

Unity 통합은 코드를 최소화하여 사용할 수 있도록 가장 흔한 클래스들도 제공합니다.

  • AK.Wwise.AuxBus
    This type represents an auxiliary send in the Master-Mixer Hierarchy.
  • AK.Wwise.Bank
    This type can be used to load/unload SoundBanks.
  • AK.Wwise.CallbackFlags
    This type represents the values of the flags used when posting an Event with a callback.
  • AK.Wwise.Event
    This type can be used to post Events to the sound engine.
  • AK.Wwise.RTPC
    This type can be used to set game parameter values to the sound engine.
  • AK.Wwise.State
    This type can be used to set Wwise States.
  • AK.Wwise.Switch
    This type can be used to set Switch values on gameobjects.
  • AK.Wwise.Trigger
    This type can be used to post triggers to the sound engine.
  • AK.Wwise.AcousticTexture
    This type represents an Acoustic Texture.
참고
  • Wwise Type

Wwise Authoring API (와이즈 저작 API, WAAPI) 클라이언트

C# API로 네이티브 WAAPI 클라이언트를 사용하면 Unity 안에서 WAAPI에 연결할 수 있습니다. 현재 Windows와 macOS에서 사용할 수 있습니다. Wwise Authoring API(와이즈 저작 API)는 JSON 객체를 통해 메시지를 전송합니다. Unity에서 클라이언트는 문자열을 사용하여 구현되었습니다. 자신이 선호하는 방법으로 유효한 JSON 문자열을 생성한 후 WAAPI 클라이언트에 제공할 수 있습니다.

참고
  • WAAPI 유틸리티

Game Object에 Wwise 사운드 추가하기

다음 네 가지 방법을 통해 게임에 사운드를 추가할 수 있습니다.

  • Wwise Picker 사용하기. 오브젝트에 사운드를 추가하는 가장 간단한 방법입니다. Wwise Picker(와이즈 피커) 창에서 Event를 Unity Viewer(유니티 뷰어)나 Inspector(인스펙터)의 오브젝트로 드래그하세요. 대상 게임 오브젝트에 AkAmbient 컴포넌트가 자동으로 생성됩니다.
  • Add Component 메뉴 사용하기. Unity 게임 오브젝트에 AkAmbient나 AkEvent 컴포넌트를 추가하세요.
  • Wwise Type 사용하기. C# 스크립트에서 AK.Wwise.Event.Post() 를 호출하세요.
  • 스크립트 사용하기. C# 스크립트에서 AkSoundEngine.PostEvent() 를 호출하세요.
참고
  • C# 코드를 사용하여 사운드 엔진 제어하기

Unity Timeline에서 Wwise 사용하기

Unity Timeline 기능을 위한 Wwise 이벤트를 트리거하고 Wwise RTPC 값을 설정하는 맞춤 Wwise 트랙이 있습니다.

Wwise 사운드 오브젝트가 Unity 오디오 타임라인의 일부인 경우 이러한 사운드에 Initial Delay를 적용하면 문제가 발생할 수 있습니다. 예를 들어 탐색(seek)을 사용하는 경우 사운드 자체가 아닌 Initial Delay를 생성할 때, 생성된 무음에서 이 탐색이 수행되므로 해당 사운드는 지정된 타임스탬프가 아닌 파일의 처음부터 시작됩니다. 딜레이 후 사운드를 시작하려면 Wwise Initial Delay 대신 Unity Timeline을 사용하세요. Timeline에서 원하는 타임스탬프로 클립을 이동시키면 됩니다.

참고
  • Wwise Timeline 통합


Wwise Unity Integration Documentation: Wwise 컴포넌트

Wwise 컴포넌트

일반 컴포넌트

AkAmbient
이 컴포넌트를 사용하여 씬에 있는 오브젝트에 Wwise Event를 연결하세요. 선택한 Unity 트리거에 따라 다양한 시점에서 사운드를 시작할 수 있습니다. 이 컴포넌트는 환경음(씬과 결합한 오브젝트에 관련된 사운드)에 더 유용하게 사용할 수 있지만 다른 목적에도 사용할 수 있습니다. AkAmbient의 기본 클래스로 AkEvent가 있기 때문에 연관된 Wwise 이벤트를 미리 들어볼 수 있는 재생/중단, 다중 재생, 다중 중단, 전체 중단 버튼이 제공됩니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkAmbient 사용하기 를 참고하세요.

AkAudioListener
리스너 게임 오브젝트에 이 스크립트를 추가하세요. 이 컴포넌트는 보통 Camera 오브젝트나 Player 오브젝트에 추가되지만 3D 버스를 구현할 경우 원하는 게임 오브젝트에 추가할 수 있습니다. isDefaultListener 는 게임 오브젝트가 기본 리스너로 간주될지의 여부를 결정합니다. 기본 리스너는 AkGameObjListenerList에 연결된 리스너가 없는 모든 게임 오브젝트에 대해서 자동으로 들을 수 있는 역할을 해줍니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkAudioListener 사용하기 를 참고하세요.

AkBank
특정 시점에서 SoundBank를 로드/언로드합니다. Decode Compressed Data 옵션을 사용하면 특정 시점에서 Vorbis 사운드를 압축 해제할 수 있습니다. 이 경우 SoundBank가 준비됩니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkBank 사용하기 를 참고하세요.
SDK 문서: 뱅크 로딩도 참고하세요.

AkEmitterObstructionOcclusion
현재 게임 오브젝트와 리스너 사이에 적어도 한 오브젝트가 있을 경우 현재 게임 오브젝트의 이미터를 리스너로부터 완전히 방해/차단합니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkEmitterObstructionOcclusion 사용하기 을 참고하세요.

AkEnvironment
이 컴포넌트를 사용하여 리버브 구역을 정의하세요. 이 컴포넌트가 올바르게 작동하려면 콜라이더 오브젝트에 추가되어야 합니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기 을 참고하세요.

AkEnvironmentPortal
이 컴포넌트를 사용하여 서로 다른 두 AkEnvironment 구역이 겹치는 영역을 정의하세요.
해당 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기 을 참고하세요.

AkEvent
Wwise Event와 이를 Unity에서 트리거해야 할 시기를 인지하는 헬퍼 클래스입니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkEvent 사용하기 를 참고하세요.

AkGameObj
이 컴포넌트는 씬에서 해당 오브젝트의 위치와 Switch, RTPC, 환경값 등의 게임 싱크를 추적하는 사운드 오브젝트를 나타냅니다. 소리를 방사하는 오브젝트에 이 컴포넌트를 추가할 수 있으며 AkAudioListener가 연결된 모든 오브젝트에 추가됩니다. 이 컴포넌트가 없을 경우 Wwise로 전달되는 Unity Game Object에 이 컴포넌트를 기본값으로 자동 추가합니다.
해당 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkGameObj 사용하기 를 참고하세요.

AkInitializer
이 컴포넌트는 Wwise 오디오 엔진의 초기화와 프레임 업데이트를 담당합니다. DontDestroyOnLoad 로 표시되기 때문에 한 씬이 아닌 게임 전체 실행 시간동안 활성화된 채로 유지됩니다. 이 스크립트를 수정해 사운드 엔진의 초기화 매개 변수를 변경할 수 있습니다. 몇 가지 매개 변수는 속성 인스펙터에 이미 표시되어 있습니다. 게임을 시작할 때 오디오를 올바르게 초기화하려면 이 오브젝트가 한 Game Object에 반드시 있어야 합니다. AkSoundEngine 을 사용하는 MonoBehavior가 동작하기 전에 반드시 실행되어야 합니다.

  • Wwise Initialization Settings 조정하기
  • Wwise SDK 문서: 사운드 엔진의 다양한 모듈 초기화하기
  • AK::SoundEngine::Init()
  • AK::SoundEngine::Term()
  • AkCallbackInfo

AkListenerDistanceProbe
이 컴포넌트는 Game Object를 특정한 리스너 Game Object에 대한 Distance Probe로 할당합니다. 3인칭 게임에서 Distance Probe는 주로 리스너의 위치가 아닌 다른 위치를 기준으로 사운드에 감쇠를 적용합니다.
퍼블릭 속성에 대한 설명은 Ak Listener Distance Probe 를 사용하여 3인칭 게임에서 리스너 사용자 지정하기 를 참고해 주세요.

AkState
이 컴포넌트는 선택된 Unity 이벤트가 트리거될 때마다 ak.soundengine.setState()를 호출합니다. 예를 들어 이 컴포넌트를 Unity 콜라이더에 설정하여 오브젝트가 콜라이더 안으로 들어갈 때 트리거할 수 있습니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkState 사용하기 를 참고하세요.

AkSwitch
이 컴포넌트는 선택된 Unity 이벤트가 트리거될 때마다 ak.soundengine.setSwitch()를 호출합니다. 예를 들어 이 컴포넌트를 Unity 콜라이더에 설정하여 오브젝트가 콜라이더 안으로 들어갈 때 트리거할 수 있습니다.
해당 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkSwitch 사용하기 를 참고하세요.

Spatial Audio 컴포넌트

AkEarlyReflections
이미터를 나타내는 게임 오브젝트에 이 스크립트를 추가하세요. 해당 게임 오브젝트가 방사하는 사운드는 근처에 있는 AkSurfaceReflector에서 초기 반사음을 생성합니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkEarlyReflections 사용하기 을 참고하세요.

AkRadialEmitter
이미터를 나타내는 게임 오브젝트에 이 스크립트를 추가하세요. 해당 게임 오브젝트가 방사하는 사운드는 게임 오브젝트의 위치를 중앙으로 내/외부 반경에 따른 확산을 가지게 됩니다.
이 컴포넌트의 퍼블릭 속성에 대한 속성은 Inspector에서의 AkRadialEmitter 를 참고하세요.

AkReverbZone
두 개의 Room을 함께 연결하려면 게임 오브젝트에 이 스크립트를 추가하세요. 하나는 Reverb Zone으로, 다른 하나는 상위 항목으로 사용됩니다. AkRoom 구성 요소가 있는 게임 오브젝트에 스크립트를 추가하여 해당 Room을 Reverb Zone으로 설정하세요.
공용 속성에 대한 설명은 Inspector에서 AkReverbZone 사용하기 를 참고하세요.

AkRoom
AkRoom은 AkRoomPortal이 있는 야외/다른 공간과의 통신만을 위한 전용 환경입니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkRoom 사용하기 을 참고하세요.

AkRoomAwareObject
AkRoom 컴포넌트를 인지하는 게임 오브젝트를 말합니다. Spatial Audio Listener와 공간 음향 사운드를 방사하는 GameObject에 추가하기 위한 것입니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkRoomAwareObject 사용하기 를 참고하세요.

AkRoomPortal
AkRoomPortal 은 두 AkRoom 컴포넌트를 서로 연결하고 이 둘 사이에 소리를 전달할 수 있습니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkRoomPortal 과 AkRoomPortalObstruction 사용하기 을 참고하세요.

AkRoomPortalObstruction
현재 게임 오브젝트와 공간 음향 리스너 사이에 적어도 한 오브젝트가 있을 경우 현재 게임 오브젝트의 공간 음향 포털에서 나오는 사운드를 완전히 방해합니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkRoomPortal 과 AkRoomPortalObstruction 사용하기 을 참고하세요.

AkSpatialAudioDebugDraw
공간 음향을 사용하는 사운드를 방사할 게임 오브젝트에 이 스크립트를 추가하세요. 해당 스크립트는 디버깅을 위해 현재 게임 오브젝트에서 공간 음향 리스너로의 초기 반사 혹은 회절 경로를 표시할 수 있습니다.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkSpatialAudioDebugDraw 사용하기 를 참고하세요.

AkSpatialAudioListener
리스너를 나타내는 게임 오브젝트에 이 스크립트를 추가하세요.
이 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkSpatialAudioListener 사용하기 를 참고하세요.

AkSurfaceReflector
이 컴포넌트는 GameObject 지오메트리의 삼각형을 소리를 반사하는 표면으로 변환합니다.
해당 컴포넌트의 퍼블릭 속성에 대한 설명은 인스펙터에서 AkSurfaceReflector 사용하기 를 참고하세요.

참고
  • Wwise 이벤트에 새로운 트리거 추가하기

컴포넌트 코드

Wwise 컴포넌트의 코드에 대해 알아보려면 해당 컴포넌트의 설정 버튼을 사용해 올바른 C# 스크립트를 열 수 있습니다.

Wwise Unity 통합 프로젝트에 커스텀 스크립트를 작성하고자 할 경우 Wwise Type 를 사용할 것을 권장해드립니다.

참고
  • Wwise 컴포넌트 추가하기


Wwise Unity Integration Documentation: 인스펙터에서 AkAmbient 사용하기

인스펙터에서 AkAmbient 사용하기
참고: AkAmbient는 AkEvent에 다중 위치 지정을 허용한 것입니다.
  • Trigger On: Wwise Event를 트리거할 수 있는 Unity 이벤트 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 목록에서 제시하지 않은 이벤트도 사용할 수 있습니다. 코드에서 AkSoundEngine.PostEvent 를 호출하면 이벤트를 트리거할 수 있습니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
  • Action On Event: Wwise에서 정의된 몇 가지 Event 매개 변수를 사용자가 Unity에서 직접 덮어 쓸 수 있게 해줍니다.. 이렇게 하면 새로운 Event를 만들지 않고 기존의 Event를 재사용할 수 있습니다.
    선택하지 않을 경우 Event를 직접 전달해야 합니다. Action On Event를 활성화할 경우 Use Callback을 활성화할 수 없습니다. AK::SoundEngine::ExecuteActionOnEvent 에 대한 SDK 설명서의 입력값도 참고하세요.
    • Action On Event Type: 해당 Event의 Action 타입을 덮어 씁니다.
    • Curve Interpolation: 보간 곡선을 덮어 씁니다.
    • Fade Time: 사운드의 페이드 시간을 덮어 씁니다.
  • Use Callback: 게임 오브젝트가 이벤트 콜백에 반응하도록 하는 쉬운 방법을 제공합니다. Action On Event를 활성화할 경우 Use Callback을 활성화할 수 없습니다.
    • Game Object: 콜백을 수신할 게임 오브젝트를 말합니다. 게임 오브젝트를 선택하려면 계층 구조에서 게임 오브젝트 입력란으로 게임 오브젝트를 드래그하세요.
    • Callback Function: 콜백이 발생하면 Game Object로 호출되는 함수입니다. 함수를 선택하려면 Callback Function 입력란에 함수 이름을 입력하세요. 이 함수가 작동하려면 Game Object는 반드시 컴포넌트에 Callback Function을 정의해야 합니다. 이 함수는 적어도 한 개의 AkEventCallbackMsg 인자를 받아야 합니다.
    • Callback Flags: Callback Function이 호출되는 시기를 지정하는 플래그를 선택합니다. 동시에 한 개 이상의 플래그를 선택할 수 있습니다. 각 플래그에 대한 더 자세한 정보는 Wwise SDK 설명서의 AkCallbackType 목록을 참고하세요.
    • Add: 새로운 콜백을 생성합니다.
  • Play / Stop: Edit 모드에서 Wwise Event를 미리 보는 데 사용할 수 있습니다.
  • Stop All: 재생 중인 모든 Wwise Event를 중단합니다.
  • Position Type: Event의 위치를 오디오 엔진에 전송하는 방법을 정의합니다.
    • Simple_Mode: Event 위치가 이벤트가 연결된 게임 오브젝트와 동일하게 됩니다.
    • Large_Mode: Event가 여러 개의 점으로 정의한 다양한 위치를 가질 수 있습니다. 인스펙터에서 Add Large Mode position 오브젝트를 클릭하면 점을 추가할 수 있습니다. AkAmbient 게임 오브젝트에 하위 게임 오브젝트가 추가되며 일반 트랜스폼 도구를 사용해서 옮길 수 있습니다. 또한 AkAmbientLargeModePositioner 컴포넌트를 직접 추가하고 인스펙터에서 Pick existing position 오브젝트를 클릭해서 기존의 게임 오브젝트를 사용할 수도 있습니다. 이 모드는 동시에 사운드가 여러 위치에서 들릴 경우 유용합니다. 한 가지 좋은 예로 바다 한 가운데서 들려오는 물 소리가 있습니다.
    • MultiPosition_Mode: 이 모드는 동일한 Event를 사용하는 AkAmbient 의 모든 인스턴스가 단 하나의 사운드 인스턴스만 가지도록 하여 메모리를 절약할 수 있게 해줍니다. 이 모드를 사용하는 모든 AkAmbient 인스턴스와 동일한 이벤트를 가지는 모든 AKAmbient 인스턴스를 자동으로 감지되며, 같은 사운드를 여러 번 로드하는 대신 동일한 사운드 인스턴스를 사용하게 됩니다.
      참고: 이 모드를 사용하며 동일한 이벤트를 가진 모든 AkAmbient 인스턴스는 동일한 트리거를 가집니다 (AkEvent에서 Trigger On을 참고하세요). 그렇기 때문에 한 AkAmbient의 트리거를 변경하면 동일한 이벤트를 사용하는 모든 AkAmbient의 트리거가 자동으로 변경됩니다.
  • Show Attenuation Sphere: 이벤트가 재생하는 사운드가 들리는 공간을 정의하는 영역을 보여줍니다. 하지만 Editor에서 Play할 경우 볼 수 없습니다.
    이 기능이 작동하려면 Wwise 프로젝트의 SoundBank 설정에서 Max Attenuation을 활성화해야 합니다. (Project > Project Settings > Soundbanks > Max attenuation)
    • Dont_Show: 감쇠 영역을 표시하지 않습니다.
    • Current_Event_Only: 현재 모드에서 AkSoundEngine.PostEvent 로의 호출 후 재생될 모든 사운드의 감쇠 영역을 보여줍니다.
      • Simple_Mode의 경우 게임 오브젝트에서 들리는 사운드의 감쇠 영역만 보여줍니다.
      • Large_Mode의 경우 각 지점의 감쇠 영역만 보여줍니다.
      • MultiPosition_Mode일 경우 MultiPosition_Mode에서 동일한 이벤트를 가지는 서로 다른 AkAmbient 마다 한 개씩 감쇠 영역을 보여줍니다.
    • All_Events: 해당 씬에 있는 모든 AkAmbient 인스턴스의 감쇠 영역을 보여줍니다.
  • Name: 클릭하여 WwiseProject > Events에서 정의한 Event 중에서 선택하세요. 새로운 Event를 추가하려면 Wwise Project Explorer의 Events 탭 안에 있는 Create new 'Event' 버튼을 클릭하세요.
참고: Large_Mode와 MultiPosition_Mode 위치 타입의 경우 고려해야 할 몇 가지 제한 사항이 있습니다. AkSoundEngine.SetMultiplePositions 의 호출이 나중에 발생하기 때문에 사운드를 Awake 에서 트리거하지 말아야 합니다. 이 두 개의 다중 위치 지정 모드는 비유동적인 오브젝트에 적합합니다. 해당 모드를 사용하는 UnityEngine.GameObjects 는 반드시 정적으로 설정하는 것이 좋습니다.
참고
  • Wwise SDK 문서: 통합 세부사항 - 3D 위치 지정
  • AK::SoundEngine::SetMultiplePositions
  • AK::SoundEngine::SetPosition
  • Wwise 도움말: Event 관리하기


Wwise Unity Integration Documentation: 인스펙터에서 AkAudioListener 사용하기

인스펙터에서 AkAudioListener 사용하기
  • Is Default Listener: 또 다른 리스너로 호출하여 덮어 쓸 때까지 선택한 GameObject를 다른 GameObject의 리스너로 설정합니다. 보통 카메라와 같이 중심이 되는 오브젝트에 Default Listener를 적용합니다.
참고
  • Wwise SDK 문서: Wwise에서 리스너 통합하기
  • Wwise-301: 오디오 리스너


Wwise Unity Integration Documentation: 인스펙터에서 AkBank 사용하기

인스펙터에서 AkBank 사용하기
  • Load On: 게임이 SoundBank를 로드해야 하는 시점을 말합니다. 클릭하여 다음 중 한 개 이상의 옵션을 선택하세요.
    • Start: 씬이 로드될 때 로드합니다. 기본으로 설정되며 SoundBank를 로드하는 일반적인 방법입니다.
    • Nothing: Unity 기본 옵션이며 사용하지 말아야 합니다.
    • Everything: Unity 기본 옵션이며 사용하지 말아야 합니다.
    • Awake: 현재 게임 오브젝트가 활성화될 때 로드합니다.
    • Destroy: 씬이 종료될 때 로드합니다. SoundBank 로드가 아닌 언로드에 사용하도록 제작되었습니다.
    • AkTrigger 옵션: 여러 가지 AkTrigger 옵션이 제공됩니다. 예를 들어 AkTriggerEnter를 적용하면 플레이어가 공간 안으로 들어갈 때 SoundBank가 로드됩니다. 공간 사운드가 필요할 경우 SoundBank가 로드되어야 하기 때문에 랙이 일어날 수 있다는 점을 유의하세요. Trigger를 사용하여 SoundBank 로드하기에 대한 더 자세한 개요는 Wwise 301의 Loading SoundBanks using Triggers를 참고해주세요.
  • Unload On: 게임이 SoundBank를 언로드해야 하는 시점을 말합니다. 클릭하여 다음 중 한 개 이상의 옵션을 선택하세요.
    • Start: 씬이 로드될 때 언로드합니다. SoundBank 언로드가 아닌 로드에 사용하도록 제작되었습니다.
    • Nothing: Unity의 기본 옵션이며 사용하지 말아야 합니다.
    • Everything: Unity 기본 옵션이며 사용하지 말아야 합니다.
    • Awake: 현재 게임 오브젝트가 활성화될 때 로드합니다. SoundBank 언로드가 아닌 로드에 사용하도록 제작되었습니다.
    • Destroy: 씬이 종료될 때 로드합니다. 기본으로 설정되며 SoundBank를 언로드하는 일반적인 방법입니다.
    • AkTrigger 옵션: 여러 가지 AkTrigger 옵션이 제공됩니다. 예를 들어 AkTriggerExit을 적용하면 플레이어가 공간 밖으로 나갈 때 SoundBank를 언로드할 수 있습니다.
  • Override Load Setting: Wwise 초기화 설정(Edit > Project Settings > Wwise Initialization)에서 Load Bank Asynchronously 설정을 오버라이드합니다. 활성화되면 Load Bank Asynchronously 설정이 표시되며, 이 설정을 선택하여 해당 뱅크를 비동기적으로 로드할 수 있습니다.
  • Load Bank Asynchronously: 로드 요청이 성공적으로 큐에 추가되었는지 여부를 나타내는 LoadBank 함수 호출을 즉시 반환하고, 실제 로드가 백그라운드에서 계속되는 동안 다른 작업이 수행될 수 있도록 합니다. 동기화 버전은 로드가 완료되기를 기다리도록 주요 처리 스레드를 차단합니다. 비동기화 호출은 즉시 로드할 필요가 없는 대규모 SoundBank에 적합합니다.
    참고
    • LoadBank 의 동기화 버전에 대한 SDK 레퍼런스 문서
  • Decode compressed data: 모든 SoundBank의 Vorbis와 Opus 압축 파일을 압축 해제합니다.
    참고
    • Wwise Help: 오디오 포맷에 대해
    • Wwise SDK 문서: 뱅크 준비
    • AK::SoundEngine::PrepareBank
  • Save decoded bank: 압축 해제된 파일을 디스크에 저장하여 SoundBank가 언로드된 후 이 파일을 빠르게 로드할 수 있게 해줍니다.
  • Name: 클릭하여 이미 WwiseProject > Banks에서 정의된 SoundBank 중에서 선택하세요. 새로운 SoundBank를 추가하려면 Wwise Project Explorer의 SoundBanks 탭 안에서 Create new 'SoundBank' 버튼을 클릭하세요.
참고
  • Wwise 도움말:SoundBank 관리하기
    • SoundBank 만들기
  • Wwise-301: Unity에서 SoundBank관리하기


Wwise Unity Integration Documentation: 인스펙터에서 AkEmitterObstructionOcclusion 사용하기

인스펙터에서 AkEmitterObstructionOcclusion 사용하기

GameObjectdp AkEmitterObstructionComponent를 추가하면 리스너와 오브젝트의 경로 사이에 또 다른 오브젝트가 있을 경우 방해/차단할 수 있습니다.

이미터가 방해되거나 차단되면 AkEmitterObstructionOcclusion 컴포넌트가 1의 값으로 SetObjectObstructionAndOcclusion()을 호출합니다. Wwise Project Settings에서 방해 (Obstruction Volume, Obstruction LPF, Obstruction HPF)와 차단 곡선 (Occlusion Volume, Occlusion LPF, Occlusion HPF)을 정의하세요.

맵이 공간 음향을 사용하지 않을 경우 (AkRoom 컴포넌트가 없을 경우) AkEmitterObstructionOcclusion 컴포넌트가 Wwise에서 정의한 차단 곡선만 사용합니다. 반대로 맵이 공간 음향을 사용할 경우 GameObject가 Wwise에서 정의한 방해 곡선만 사용합니다.

  • Fade Time: 페이드 인/아웃의 길이 (초 단위)를 말합니다.
  • Layer Mask: 어떤 레이어가 방해/차단 레이어로 작용하는지를 표시합니다.
  • Max Distance: 방해/차단 검사를 수행하는 최대 거리를 말합니다. 음수값의 경우 무한대 거리로 간주됩니다.
  • Refresh Interval: 방해/차단 확인 격차를 초 단위로 표시합니다. 0일 경우 방해/차단을 쉬지 않고 확인합니다.
참고: 공간 음향 회절을 사용할 경우 AkEmitterObstructionOcclusion을 사용하지 마세요.
참고
  • A. 이미터 방해/차단
  • AK::SoundEngine::SetObjectObstructionAndOcclusion


Wwise Unity Integration Documentation: 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기

인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기

Unity 통합에서 AkEnvironment 및 AkEnvironmentPortal 구성 요소를 게임 오브젝트에 적용할 수 있습니다. 그런 다음 이러한 구성 요소를 Wwise Effect가 있는 Auxiliary Bus와 연결하여 사운드의 환경 효과를 시뮬레이션할 수 있습니다. 여기서는 이러한 구성 요소를 사용하여 리버브 효과를 시뮬레이션하는 방법에 대해 설명합니다. 동일한 원리를 사용하여 다른 유형의 효과를 적용할 수도 있습니다.

도움말: 리버브를 구현하는 또 다른 방법은 Spatial Audio를 사용하는 것입니다. 자세한 내용은 다음 항목을 참조하세요.
  • 인스펙터에서 AkRoom 사용하기
  • AkReverbZone
  • Unity에서의 Spatial Audio

이 주제의 예제는 Audioynamic Launcher를 통해 Wwise Demo 씬 에서 다운로드할 수 있습니다 (Unity 참고).

사전 준비

Unity 씬에 환경 및 환경 포털 구성 요소를 추가하려면 먼저 Wwise Authoring에서 Auxiliary Bus를 생성하고 여기에 효과를 적용한 후 SoundBank를 생성해야 합니다.

버스에 대한 자세한 정보는 Master-Mixer Hierarchy에 버스 추가하기 및 버스에 효과 적용하기를 참고하세요.

리버브 효과의 경우 리버브 플러그인 중 하나를 버스에 적용할 수 있습니다.

  • Matrix Reverb
  • AK Convolution Reverb
  • RoomVerb

AkEnvironment 구성 요소 추가하기

AkEnvironment 구성 요소는 아주 간단한 환경 구역을 나타냅니다. AkEnvironment 구성 요소는 모든 타입의 콜라이더에 연결할 수 있습니다.

씬에 AkEnvironment 구성 요소를 추가하는 방법에는, Wwise Picker , Add Component 메뉴 또는 C# 스크립트를 사용하는 세 가지 방법이 있습니다.

Wwise Picker에서 AkEnvironment 구성 요소를 추가할 경우:

  1. Wwise Picker에서, 사용하려는 리버브 효과가 있는 Auxiliary Bus를 찾으세요.
  2. Unity에서 씬에서 오브젝트를 선택합니다. 오브젝트 속성이 Inspector에 표시됩니다.

  3. Auxiliary 버스를 Wwise Picker에서 Inspector로 드래그하세요.

    Auxiliary 버스의 이름을 딴 AkEnvironment 구성 요소가 오브젝트에 추가됩니다.

메뉴에서 AkEnvironment 구성 요소를 추가할 경우:

  1. 씬에서 오브젝트를 선택합니다. 오브젝트 속성이 Inspector에 표시됩니다.
  2. Inspector 하단에서 Add Component > Wwise > AkEnvironment를 클릭하세요. AkEnvironment 구성 요소가 오브젝트에 추가됩니다.
  3. 다른 Auxiliary Bus를 선택하려면 Name을 클릭하여 Auxiliary Bus 창을 엽니다. 그런 다음 버스를 선택하고 OK를 클릭하거나 원하는 버스를 더블 클릭하세요. 또는 Wwise Picker에서 Auxiliary Bus를 현재 Auxiliary Bus의 이름으로 드래그할 수도 있습니다.

C# 스크립트를 사용하여 AkEnvironment 구성 요소를 추가할 경우:

  • 어느 단계든 상관 없이 AkSoundEngine.SetGameObjectAuxSendValues() 를 호출하면 됩니다.

AkEnvironment 구성 요소 속성

하나의 씬이나 AkGameObj 에 대해 동시에 활성화할 수 있는 AkEnvironment 구성 요소는 4개입니다.

AkEnvironment 구성 요소에는 Inspector에서 접근할 수 있는 다음 속성이 있습니다.

  • Priority: 환경의 우선 순위를 정의합니다. 가장 작은 숫자(0)가 가장 높은 우선순위를 나타냅니다.
    게임 오브젝트가 4개 이상의 환경 내에 있는 경우 우선 순위가 가장 높은 4개의 환경만 활성화됩니다 (Default 및 Exclude Others 플래그가 설정되지 않은 경우).
  • Default: 기본 환경은 게임 오브젝트를 포함하는 유일한 환경인 경우에만 활성화됩니다.
    게임 오브젝트가 둘 이상의 기본 환경 내에 있는 경우 우선 순위가 가장 높은 오브젝트만 활성화됩니다.
  • Exclude Others: 이 플래그가 있는 환경은 다른 환경과 겹칠 수 없습니다.
    게임 오브젝트가 Exclude Others 플래그가 있는 환경 내에 있는 경우 다른 모든 환경은 삭제됩니다.
    게임 오브젝트가 Exclude Others 플래그가 있는 둘 이상의 환경 내에 있는 경우 우선 순위가 가장 높은 항목만 활성화됩니다.
  • Name: 연결된 Auxiliary Bus의 이름입니다.

AkEnvironmentPortal 구성 요소 추가하기

포털을 사용하여 두 환경의 효과를 결합할 수 있습니다. 두 환경 각각의 기여도는 게임 오브젝트와의 거리에 따라 결정됩니다. 이는 게임 오브젝트가 두 Room 사이에 있거나 두 환경을 연결하는 터널에 있는 경우 유용합니다.

프로젝트에 환경 포털을 추가하려면:

  1. Unity 메뉴 바에서 GameObject > Wwise > Environment Portal을 클릭하세요. 환경 포털 오브젝트가 프로젝트 계층 구조에 추가됩니다.

AkEnvironmentPortal 구성 요소 속성

두 환경 사이에 환경 포털을 배치하면 게임 오브젝트가 포털 안에 있을 경우 효과를 조합할 수 있습니다. 포털은 두 환경 모두와 교차해야 합니다. 각 환경의 기여도는 게임 오브젝트와의 거리에 따라 결정됩니다. 게임 오브젝트가 환경에 가까울수록 해당 환경이 최종 효과에 더 많이 기여하게 됩니다.

AkEnvironmentPortal 구성 요소에는 Inspector에서 접근할 수 있는 다음 속성이 있습니다.

  • Environment #1: 포털은 포털을 교차하는 모든 환경을 자동으로 감지합니다. 포털의 반대쪽(선택한 축 방향의 반대)의 환경은 이 드롭다운 메뉴에 있습니다.
  • 환경 #2: 포털의 바른쪽(선택한 축과 동일한 방향)의 환경은 이 드롭다운 메뉴에 있습니다.
  • 축: 축은 각 환경의 상대적 기여도를 결정합니다. 예를 들어 Z축을 선택한 경우 X를 따라 이동해도 두 환경의 상대적 기여도는 변경되지 않습니다. Z축의 움직임만 기여도에 영향을 미칩니다.
    참고: 축은 오브젝트 공간 안에 있습니다. 따라서 포털을 회전하면 축도 함께 회전됩니다.

환경 및 환경 포털 사용

환경과 환경 포털을 사용하려면 환경을 인지하는 AkGameObj 컴포넌트를 가진 게임 오브젝트가 필요합니다. AkEnvironmentPortal 오브젝트는 겹쳐지는 AkEnvironment 오브젝트를 자동으로 감지합니다. 겹치는 환경은 포털의 인스펙터에서 두 개의 선택 목록에 표시됩니다.

포털에 너무 많은 환경이 겹칠 경우 포털이 조합할 환경을 직접 선택할 수 있습니다. 하나의 게임 오브젝트에 대해 동시에 4개의 AkEnvironment 만 활성화할 수 있습니다. 환경 포털의 경우 4개의 AkEnvironment가 다음과 같이 선택됩니다.

  • 포털에 연결되어 있으며 우선 순위가 가장 높은 환경은 네 가지 환경이 선택될 때까지, 혹은 포털에 연결된 환경이 없을 때까지 선택됩니다.
  • 연결된 환경이 4개 미만인 경우 씬에서 연결되지 않은 환경은 다음 기준에 따라 연결됩니다.
    • 4개 제한에 도달할 때까지 우선순위가 가장 높은 환경이 선택됩니다 (Default 및 Exclude Others 플래그가 설정되지 않은 경우).
    • Default 환경은 선택된 환경이 없을 경우에만 선택됩니다.
    • 게임 오브젝트가 Exclude Others 플래그가 설정된 환경 안에 있을 경우 이 환경이 선택되며 다른 모든 환경이 제거됩니다.
참고
  • Wwise SDK 문서: 환경과 Game-defined Auxiliary Send 통합하기
  • AK::SoundEngine::SetGameObjectAuxSendValues


Wwise Unity Integration Documentation: 인스펙터에서 AkEvent 사용하기

인스펙터에서 AkEvent 사용하기
참고: AkAmbient는 AkEvent에 다중 위치 지정을 허용한 것입니다.
  • Trigger On: 이 Wwise Event를 설정할 수 있는 Unity 이벤트의 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 목록에서 제시하지 않은 이벤트도 사용할 수 있습니다. 코드에서 AkSoundEngine.PostEvent 를 호출하면 언제든지 Event를 설정할 수 있습니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
    • Action On Event: Wwise에서 정의된 몇 가지 Event 매개 변수를 사용자가 Unity에서 직접 덮어 쓸 수 있게 해줍니다.. 이렇게 하면 새로운 Event를 만들지 않고 기존의 Event를 재사용할 수 있습니다.
      선택하지 않을 경우 Event를 직접 전달해야 합니다. Action On Event를 활성화할 경우 Use Callback을 활성화할 수 없습니다. AK::SoundEngine::ExecuteActionOnEvent 에 대한 SDK 설명서의 입력값도 참고하세요.
      • Action On Event Type: 해당 Event의 Action 타입을 덮어 씁니다.
      • Curve Interpolation: 보간 곡선을 덮어 씁니다.
      • Fade Time: 사운드의 페이드 시간을 덮어 씁니다.
    • Use Callback: 게임 오브젝트가 이벤트 콜백에 반응하도록 하는 쉬운 방법을 제공합니다. Action On Event를 활성화할 경우 Use Callback을 활성화할 수 없습니다.
      • Game Object: 콜백을 수신할 게임 오브젝트를 말합니다. 게임 오브젝트를 선택하려면 계층 구조에서 게임 오브젝트 입력란으로 게임 오브젝트를 드래그하세요.
      • Callback Function: 콜백이 발생하면 Game Object로 호출되는 함수입니다. 함수를 선택하려면 Callback Function 입력란에 함수 이름을 입력하세요. 이 함수가 작동하려면 Game Object는 반드시 컴포넌트에 Callback Function을 정의해야 합니다. 이 함수는 적어도 한 개의 AkEventCallbackMsg 인자를 받아야 합니다.
      • Callback Flags: Callback Function이 호출되는 시기를 지정하는 플래그를 선택합니다. 동시에 한 개 이상의 플래그를 선택할 수 있습니다. 각 플래그에 대한 더 자세한 정보는 Wwise SDK 설명서의 AkCallbackType 목록을 참고하세요.
      • Add: 새로운 콜백을 생성합니다.
  • Play / Stop: Edit 모드에서 Wwise Event를 미리 보는 데 사용할 수 있습니다.
  • Stop All: 재생 중인 모든 Wwise Event를 중단합니다.
  • Name: 클릭하여 이미 Wwise Picker 의 WwiseProject > States에서 정의된 Event 중에서 선택하세요. 새로운 Event를 추가하려면 Wwise Project Explorer의 Events 탭 안에 있는 Create new 'Event' 버튼을 클릭하세요.
참고
  • AK::SoundEngine::SetPosition
  • Wwise 도움말: Event 관리하기


Wwise Unity Integration Documentation: 인스펙터에서 AkGameObj 사용하기

인스펙터에서 AkGameObj 사용하기
  • Apply Position Offset: 게임 오브젝트에 두 번째 Transform을 적용하여 게임 오브젝트의 실제 위치와 다른 오디오 계산 위치를 지정합니다.
    • Position Offset 게임 오브젝트의 두 번째 Transform 위치를 각 X (좌우), Y (위아래), Z (앞뒤) 입력란에 있는 게임에서 쓰는 단위에 따라 이동합니다.
    • Hide Main Transform 뷰에서 원본 Transform을 제거하여 상쇄값만 보이도록 합니다.
  • Envrionment Aware: 이 게임 오브젝트의 오디오가 환경, 공간, 포털에 의해 영향을 받도록 설정합니다. 이 옵션을 설정할 경우 AkGameObj에 반드시 Rigidbody가 있어야 합니다.
    참고: 이 옵션은 씬을 재생하기 전에 선택되어 있을 경우에만 실행됩니다.
    • Add Rigidbody GameObject에 Rigidbody 컴포넌트를 생성합니다.
  • Use Default Listeners: 보통 Default Listener는 카메라와 같이 중심이 되는 게임 오브젝트에 적용됩니다. 그리고 이 리스너는 모든 것을 듣습니다.
    • Add Listener 또 다른 리스너 항목을 지정합니다. 선택 버튼을 클릭하여 Select AkAudioListener 대화창을 열어 AkAudioListener가 있는 게임 오브젝트를 선택하세요.
      참고: 반드시 리스너가 있어야 합니다. 기본 리스너가 없거나 다른 리스너를 지정하지 않을 경우 일반적으로 Wwise Settings 대화창 (Edit > Project Settings > Wwise Editor)에서 기본 "Automatically add Listener to Main Camera(리스너를 메인 카메라에 자동 추가" Asset Management 설정으로 저장합니다.
참고
  • 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
  • SDK 문서: Wwise에서 리스너 통합하기


Wwise Unity Integration Documentation: Ak Listener Distance Probe 를 사용하여 3인칭 게임에서 리스너 사용자 지정하기

Ak Listener Distance Probe 를 사용하여 3인칭 게임에서 리스너 사용자 지정하기
참고: 이 예시를 진행하기 전에 3인칭 게임에서 리스너 작업하기(Working with Listeners in Third-Person Perspective Games)를 통해 Wwise에서 Distance Probe 사용하기에 대한 개요를 참고해 주세요.

다음 예시에서는 3인칭 게임용으로 만들어진 Unity 프로젝트가 있다는 가정 하에 진행됩니다. 먼저 리스너로 사용할 카메라 GameObject와 Distance Probe로 지정할 플레이어 캐릭터나 다른 GameObject가 있어야 합니다. Ak Audio Listener 컴포넌트는 기본적으로 메인 카메라에 자동으로 추가됩니다.

  1. Distance Probe로 지정할 GameObject로 이동하세요. 대부분의 경우 플레이어 캐릭터의 GameObject가 Distance Probe로 지정됩니다.
    1. Ak Game Obj 컴포넌트가 GameObject에 연결되어 있는지 확인하세요. Inspector에서 Add Component를 클릭하고 Ak Game Obj를 선택하면 컴포넌트를 추가할 수 있습니다.

  2. 리스너로 사용되는 카메라 GameObject로 이동하세요.

    1. Inspector에서 Add Component를 클릭하세요. Ak Listener Distance Probe를 선택하세요. 만약 Ak Audio Listener와 Ak Game Obj 스크립트가 이미 존재하지 않을 경우 GameObject에 자동으로 추가됩니다.
    2. Inspector에서 Ak Listener Distance Probe 컴포넌트로 이동하세요. Distance Probe 입력란을 클릭해서 Distance Probe로 사용하려는 Ak Game Obj를 지정하세요.
      • 만약 선택 메뉴에서 GameObject를 사용할 수 없는 경우 Ak Game Obj 컴포넌트가 지정되지 않은 것입니다. 1단계를 참고하세요.

이제 Wwise Authoring 도구를 사용해서 게임에 연결하고 Distance Probe가 올바르게 설정되었는지 확인할 수 있습니다. 자세한 내용은 (Distance Probe 프로파일링하기)Profiling the Distance Probe 를 참고해 주세요.


Wwise Unity Integration Documentation: 인스펙터에서 AkState 사용하기

인스펙터에서 AkState 사용하기
  • Trigger On: State를 트리거할 수 있는 Unity 이벤트 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 목록에서 제시하지 않은 이벤트도 사용할 수 있습니다. 코드에서 AkSoundEngine.SetState 를 호출하면 State를 트리거할 수 있습니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
  • Name: 클릭하여 이미 Wwise Picker 의 WwiseProject > States에서 정의된 State 중에서 선택하세요. 새로운 State를 추가하려면 Wwise Project Explorer의 Game Syncs 탭 안에 있는 Create new 'State' 버튼을 클릭하세요.
참고
  • Wwise 도움말: State 사용하기
    • State 새로 만들기
  • Wwise SDK 문서: 통합 세부사항 - State (상태)
  • AkSoundEngine.SetState()


Wwise Unity Integration Documentation: 인스펙터에서 AkSwitch 사용하기

인스펙터에서 AkSwitch 사용하기
  • Trigger On: Switch를 트리거할 수 있는 Unity 이벤트 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 목록에서 제시하지 않은 이벤트도 사용할 수 있습니다. 코드에서 AkSoundEngine.SetSwitch 를 호출하면 Switch를 트리거할 수 있습니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
  • Use Other Object: 이 속성은 콜라이더와 함께 사용할 경우에만 유용합니다. 이 속성을 활성화하면 Action의 대상이 콜라이드하는 또 다른 오브젝트가 됩니다. 비활성화할 경우 그 대상이 현재 오브젝트가 됩니다.
  • Name: 클릭하여 이미 Wwise Picker 의 WwiseProject > Switches에서 선택한 Switch 중에서 선택하세요. 새로운 Switch를 추가하려면 Wwise Project Explorer의 SoundBanks 탭 안에 있는 Create new 'Switch' 버튼을 클릭하세요.
참고
  • Footsteps demo(발자국 소리 데모)
  • Wwise 도움말: Switch 사용하기
    • Switch 만들기
  • Wwise SDK 문서: 통합 세부사항 - Switch
  • AkSoundEngine.SetSwitch()


Wwise Unity Integration Documentation: 인스펙터에서 AkEarlyReflections 사용하기

인스펙터에서 AkEarlyReflections 사용하기

AkEarlyReflections는 선택적 컴포넌트입니다. 이 컴포넌트는 게임 오브젝트에 의해 방사되는 모든 사운드에 초기 반사음을 활성화합니다. 이 컴포넌트는 SetEarlyReflectionsAuxSend()와 SetEarlyReflectionsVolume()를 호출합니다.

또한 Authoring 애플리케이션의 Sound Property Editor에서 사운드별로 초기 반사음을 활성화할 수도 있습니다. Authoring 애플리케이션에서 사운드에 적용된 Reflect Auxiliary Bus는 AkEarlyReflections 컴포넌트를 통해 정의된 초기 반사음보다 항상 우선시됩니다.

  • Reflections Aux Bus 현재 게임 오브젝트의 초기 반사 보조 버스를 설정합니다. 이 컴포넌트는 선택된 보조 버스와 함께 AK::SpatialAudio::SetEarlyReflectionsAuxSend()를 호출하게 됩니다. 해당 보조 버스 매개 변수는 저작 도구에서 초기 반사 보조 버스를 지정하지 않은 게임 오브젝트를 재생하는 사운드에 적용됩니다. 각 사운드에 지정된 초기 반사 보조 버스는 여기로 전달된 값보다 우선 순위가 높습니다.
  • Reflections Volume 현재 게임 오브젝트의 초기 반사 전송 볼륨을 설정합니다. 초기 반사 전송의 볼륨을 제어하는 데에 사용됩니다. 이 컴포넌트는 입력된 볼륨값과 함께 AK:SpatialAudio::SetEarlyReflectionsVolume()을 호출합니다. 이 값은 저작 도구에서 명시한 초기 반사 볼륨과 합쳐지며 해당 게임 오브젝트에서 재생되는 모든 사운드에 적용됩니다. 유효한 값은 [0, 1]입니다. 볼륨을 0으로 설정할 경우 이 게임 오브젝트에서의 모든 반사 처리를 비활성화합니다.

이 컴포넌트는 반사적 표면도 필요로 합니다. 더 자세한 내용은 AkSurfaceReflector 와 인스펙터에서 AkSurfaceReflector 사용하기 를 참고해 주세요.


Wwise Unity Integration Documentation: Inspector에서의 AkRadialEmitter

Inspector에서의 AkRadialEmitter

이 컴포넌트는 게임 오브젝트에 내/외부 반경을 추가하여 방사형 이미터를 시뮬레이션합니다. 사운드의 확산은 내/외부 반경과 이미터와 리스너 간의 거리에 의해 자동으로 계산됩니다. 감쇠 곡선을 적용하는 데에 사용되는 거리는 리스너와 내부 반경 구형에서의 가장 근접한 지점 간의 거리로 간주됩니다.

이 컴포넌트는 매개 변수에서 지정된 외/내부 반경값과 함께 AK:SpatialAudio::SetGameObjectRadius()를 호출합니다.

참고: 이 기능은 Spatial Audio와만 작동하기 때문에 씬에 AkSpatialAudioListener가 반드시 있어야 합니다.
  • Outer Radius: 해당 입력란을 원하는 외부 반경 크기로 설정하세요. 설정되는 숫자는 변환되지 않고 그대로 공간 음향 호출로 전송됩니다. 기즈모가 활성화되어 있으며 현재 게임 오브젝트가 선택되어있을 경우, 게임 오브젝트의 위치 주변에 노란색 구를 표시하여 입력된 크기를 시각화해 줍니다.
  • Inner Radius: 해당 입력란을 원하는 내부 반경 크기로 설정하세요. 이 크기는 외부 반경 크기보다 더 클 수 없습니다. 설정된 숫자는 변환되지 않고 그대로 공간 음향 호출로 전송됩니다. 기즈모가 활성화되어 있으며 현재 게임 오브젝트가 선택되어있을 경우, 게임 오브젝트의 위치 주변에 노란색 구를 표시하여 입력된 크기를 시각화해 줍니다.

AkRadialEmitter가 있는 게임 오브젝트가 AkAmbient 컴포넌트의 Large_Mode 위치 타입과 사용될 경우, 반경이 모든 위치에 추가됩니다. 또한 AkRadialEmitter는 다위치 지정에서도 사용할 수 있습니다.


Wwise Unity Integration Documentation: Inspector에서 AkReverbZone 사용하기

Inspector에서 AkReverbZone 사용하기

연결 Portal의 필요 없이 동일한 Room인 것처럼 Reverb Zone과 해당 상위 Room 사이에 소리가 전달됩니다.

  • Reverb Zone: Reverb Zone으로 설정할 AkRoom 구성 요소를 선택하려면 클릭하세요. AkRoom 구성 요소가 있는 게임 오브젝트에 AkReverbZone 구성 요소가 추가되면 이 속성은 해당 AkRoom 구성 요소로 자동으로 채워집니다.
  • Parent Room: Reverb Zone의 상위 항목으로 설정할 AkRoom 구성 요소를 선택하려면 클릭하세요. 상위 계층 Room은 여러 개의 Reverb Zone을 가질 수 있지만 Reverb Zone은 하나의 Parent만 가질 수 있습니다. Room은 자신의 상위 항목이 될 수 없습니다. Reverb Zone을 자동으로 생성된 'Outdoors' Room에 연결하려면 이 속성을 None으로 설정된 상태로 둡니다.
  • Transition Zone Width: Reverb Zone과 상위 Room 사이의 원하는 전환 영역 폭 값으로 슬라이더를 설정합니다. 전환 영역(transition zone)은 Reverb Zone 지오메트리를 중심으로 합니다. 이 너비는 삼각형 전달 손실(triangle transmission loss)이 0으로 설정된 경우에만 적용됩니다.
참고
  • AkRoom
  • AkRoomPortal


Wwise Unity Integration Documentation: 인스펙터에서 AkRoom 사용하기

인스펙터에서 AkRoom 사용하기

공간(room)은 Spatial Audio의 핵심 부분이며 모든 Spatial Audio Concept(공간 음향 개념)에서 중요한 역할을 합니다.

  • Reverb Aux Bus: 클릭하여 Wwise Picker 의 WwiseProject > AuxiliaryBusses에서 이미 정의된 Auxiliary Bus 중에서 선택하세요. 새로운 Auxiliary Bus를 추가하려면 Master-Mixer Hierarchy에서 Audio Bus를 선택한 후 Wwise Project Explorer의 Audio 탭 안에 있는 Create new 'Auxiliary Bus'를 클릭하세요.
  • Reverb Level: 슬라이더나 입력란을 Auxiliary Bus의 Auxliary Send Volume의 승수로 직접 설정합니다 (0일 경우 보조 센드가 없음 ~ 1일 경우 최대 7개의 소수점 위치). 예를 들어 큰 공간이나 작은 공간에 Auxiliary Bus를 설정했을 경우 작은 공간의 리버브는 보다 덜 드러나기 때문에 레벨을 감소해야 합니다.
  • Transmission Loss: 슬라이더나 입력란(0~1)을 이 공간과 연결하고자 하는 전달 손실값으로 설정하세요. 전달 손실(transmission loss)은 소리가 장애물을 통과하면서 에너지가 손실되는 것을 시뮬레이션하는 데에 사용됩니다. 전달이 차단 (\ref pg_initialization_settings "Spatial Audio Initialization Settings" 참고)을 사용할 경우 차단 손실값은 Wwise Project Settings에 있는 Occlusion 곡선 (Occlusion Volume, Occlusion LPF, Occlusion HPF)을 사용하여 사운드를 필터링합니다. 예를 들어 Transmission Loss가 0.75일 경우 해당 Wwise Occlusion 그래프 Occlusion 축의 75% 지점에 해당하여 아래 이미지에서 -12.0dB와 같습니다.
    보통 얇은 벽일수록 낮은 전달 손실값이 어울리며, 더 두껍고 단단한 벽일수록 높은 전달 손실값이 어울립니다.
  • Priority: 게임 오브젝트가 두 개 이상의 공간에 있을 경우 AK::SpatialAudio::SetGameObjectInRoom()에서 선택할 공간의 우선 순위 숫자를 설정합니다. 숫자가 클수록 우선 순위가 높은 것으로 간주됩니다. 예를 들어 Priority가 2인 공간이 Priority가 l인 공간을 제치고 사용됩니다.

Room Tone

  • Trigger On: Wwise Event를 트리거할 수 있는 Unity 이벤트 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 목록에서 제시하지 않은 이벤트도 사용할 수 있습니다. 코드에서 AkSoundEngine.PostEvent 를 호출하면 Event를 트리거할 수 있습니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
  • Room Tone Event: 클릭하여 이미 Wwise Picker 의 WwiseProject > Events에서 정의된 Event 중에서 선택하세요. 새로운 Event를 추가하려면 Wwise Project Explorer의 Events 탭 안에 있는 Create new 'Event' 버튼을 클릭하세요. 선택한 Event가 해당 공간 게임 오브젝트에 적용됩니다.
  • Room Tone Aux Send: 슬라이더나 입력란을 해당 공간 게임 오브젝트에 전달된 사운드의 전송 레벨로 직접 설정합니다. 값이 0일 경우 보조 센드를 비활성화하며 값이 1일 경우 전체 값으로 설정됩니다.

공간의 경계선은 AkRoom 컴포넌트와 동일한 게임 오브젝트에서 있는 콜라이더에 의해 결정됩니다. 이 콜라이더가 있는 Trigger는 해당 공간에 있는 다른 게임 오브젝트를 AK::SpatialAudio::SetGameObjectInRoom()으로 설정합니다.

또한 공간도 벽을 통해 변조된 사운드를 전달할 수 있습니다. 공간의 모양은 해당 포털 주변에 있는 경계 상자에 의해 정의됩니다. 공간의 모양을 지정하는 또 다른 방식은 공간을 지오메트리와 연결하는 것입니다. Unity에서 지오메트리는 콜라이더의 모양이나 동일한 게임 오브젝트에 있는 AkSurfaceReflector 컴포넌트에 따라 공간과 자동 연결될 수 있습니다.

이 작동 방식은 다음과 같습니다.

  • AkSurfaceReflector 컴포넌트가 없으며 콜라이더가 메쉬, 상자, 구형, 캡슐일 경우 AkRoom 컴포넌트가 공간의 범위 및 시각화의 목적만을 위해 콜라이더의 모양으로부터 Spatial Audio로 전송할 지오메트리를 생성합니다. 캡슐의 경우 상자 모양의 메쉬가 전송됩니다. 이 지오메트리는 Game Object 3D Viewer에서 확인할 수 있습니다. 이 지오메트리는 다른 지오메트리처럼 표시되지만 공간이라는 것을 표시하는 특정 색깔로 표시됩니다.
  • 활성화된 AkSurfaceReflector 컴포넌트가 있을 경우 해당 ID가 AkRoomParams에 직접 추가되어 해당 지오메트리를 공간과 연결합니다.
    참고: AkSurfaceReflector 컴포넌트의 메쉬가 공간의 콜라이더와 비슷한 것이 좋습니다. 공간의 콜라이더는 공간에서 게임 오브젝트를 설정하는 데에 사용됩니다. 두 볼륨이 다를 경우 격리와 공간 전달 간에 불일치가 발생할 수 있습니다. Game Object 3D Viewer에서 공간 주변에 표시되는 지오메트리는 게임 오브젝트가 공간 안에 있음으로 간주될 경우의 볼륨과 다릅니다.
  • 두 조건이 성사하지 않을 경우 Inspector에 경고 메시지가 뜹니다.

결과적으로 Wwise에서는 연관된 지오메트리의 꼭짓점으로 구성된 경계 상자가 생깁니다. 이 볼륨은 확산에 영향을 끼칩니다. 이 볼륨 밖에서는 공간의 변조 신호 전달 확산이 0~180도가 됩니다. 이 볼륨 안에서는 100가 됩니다. 이 볼륨은 공간의 범위라고 불립니다. 이 범위는 Game Object 3D Viewer Settings에서 Room Extent를 활성화하여 Game Object 3D Viewer에서 확인할 수 있습니다.

참고
  • Unity에서의 Spatial Audio
    • Room과 Portal 튜토리얼
      • B. Room (공간)
  • AkRoom
  • AkRoomParams
  • 공간과 포털 설명서
  • Wwise 도움말: 프로젝트의 방해와 차단 곡선 정의하기
  • 전달(Transmission)
  • 공간 전달


Wwise Unity Integration Documentation: 인스펙터에서 AkRoomAwareObject 사용하기

인스펙터에서 AkRoomAwareObject 사용하기

Rigidbody

  • AkRoomAwareObject 컴포넌트가 있는 GameObject와 AkRoom 컴포넌트가 있는 GameObject 간의 상호작용을 위해서는 적어도 한 GameObject에 Rigidbody 컴포넌트가 있어야 합니다. Add Rigidbody 버튼을 클릭해서 추가하세요.

Collider

  • AkRoomAwareObject 컴포넌트가 있는 GameObject에는 콜라이더 컴포넌트가 필요합니다. GameObject가 들어있는 공간(room)을 확인해 이 정보를 AK::SpatialAudio::SetGameObjectInRoom() 함수 호출로 Spatial Audio에 보내야 합니다. GameObject의 콜라이더가 AkRoom 컴포넌트의 콜라이더와 겹치면 곧바로 이 GameObject가 공간 안에 놓이게 됩니다 (현재 GameObject가 들어있는 공간보다 해당 공간이 더 높은 우선 순위일 경우). GameObject의 콜라이더를 적절하게 조절하세요. 권장하는 값은 0입니다.
참고
  • Unity에서의 Spatial Audio
    • Room과 Portal 튜토리얼


Wwise Unity Integration Documentation: 인스펙터에서 AkRoomPortal 과 AkRoomPortalObstruction 사용하기

인스펙터에서 AkRoomPortal 과 AkRoomPortalObstruction 사용하기

포털은 Spatial Audio에서 중요한 역할을 합니다. Unity 통합에서는 AkRoomPortal 과 부수적으로 AkRoomPortalObstruction (필수 아님)이라는 두 가지 Wwise 컴포넌트를 제공합니다.

AkRoomPortal

  • Initial State: 포털을 닫히거나 열린 상태로 시작하도록 설정합니다.
    • Open On: 포털을 열 Unity 이벤트의 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요.
    • Close On: 포털을 닫을 Unity 이벤트의 목록을 제공합니다. 여러 Unity 이벤트를 선택할 수 있으며 이 경우 입력란이 'Mixed…'로 표시됩니다. 또한 직접 만든 트리거 코드를 작성하여 자신의 동료들이 목록에서 볼 수 있게 할 수도 있습니다. Wwise 이벤트에 새로운 트리거 추가하기 를 참고하세요. 또한 SDK doc: 공간과 포털 사용하기를 참고하세요.
  • Back Room AkRoomPortal 이 두 개의 AkRoom '공간'을 연결합니다. Back Room은 우선 순위가 가장 높으며 포털의 음수 쪽 (포털 내부 Z 축의 반대 방향)에 배치된 활성화된 공간입니다. 비활성화된 공간은 런타임 때 선택되지 않습니다.
  • Front Room AkRoomPortal 은 두 개의 AkRoom '공간'을 연결합니다. Front Room은 우선 순위가 가장 높으며 포털의 양수 쪽 (포털 내부 Z 축의 방향)에 배치된 활성화된 공간입니다. 비활성화된 공간은 런타임 때 선택되지 않습니다.

AkRoomPortalObstruction

이 선택적 컴포넌트는 오브젝트가 포털과 리스너 사이의 경로를 막고 있을 경우 포털에서 전해오는 사운드에 방해를 적용합니다. 회절이 활성화된 AkSurfaceReflector를 추가할 수 있을 경우 (혹은 원하는 경우) 회절 필터링을 더욱 정확하게 성취할 수 있습니다. 인스펙터에서 AkSurfaceReflector 사용하기 를 참고해 주세요.

현재 게임 오브젝트와 공간 음향 리스너 사이에 적어도 한 오브젝트가 있을 경우 SetPortalObstructionAndOcclusion()로의 호출을 통해 현재 GameObject의 공간 음향 포털을 공간 오디오 리스너로부터 방해합니다. 현재 GameObject와 공간 음향 리스너 사이에 오브젝트가 있을 경우 해당 스크립트는 차단 값을 1로 SetObjectObstructionAndOcclusion()을 호출합니다.

이미 AkRoomPortal 컴포넌트가 있는 GameObject에만 AkRoomPortalObstruction을 추가할 수 있습니다. 또한 등록된 공간 음향 리스너가 없을 경우 방해가 일어나지 않습니다.

  • Fade Time: 페이드 인/아웃의 길이 (초 단위)를 말합니다.
  • Layer Mask: 방해 레이어의 역할을 할 레이어를 표시합니다.
  • Max Distance: 방해를 실행할 최대 거리를 말합니다. 음수값의 경우 무한대 거리로 간주됩니다.
  • Refresh Interval: 방해 확인 격차를 초 단위로 표시합니다. 0일 경우 방해를 쉬지 않고 확인합니다.
참고: 공간 음향 회절을 사용할 경우 AkRoomPortalObstruction을 사용하지 마세요.
참고
  • A. 이미터 방해/차단
  • Unity에서의 Spatial Audio
    • Room과 Portal 튜토리얼
      • C. Portal (포털)
  • Wwise 도움말: User-Defined Auxiliary Send 사용하기
  • Wwise 도움말: Game-defined Auxiliary Send 사용하기
  • SDK doc: 방해와 차단 vs. 포털의 전달과 회절
  • AkPortalParams
  • SetPortalObstructionAndOcclusion()


Wwise Unity Integration Documentation: 인스펙터에서 AkSpatialAudioDebugDraw 사용하기

인스펙터에서 AkSpatialAudioDebugDraw 사용하기
  • Draw First Order Reflections 한 표면에 부딪혀서 일어나는 리플렉션의 선을 표시합니다.
  • Draw Second Order Reflections 리스너에게 도달할 때까지 두 표면에 부딪혀서 일어나는 리플렉션의 선을 표시합니다.
  • Draw Higher Order Reflections 리스너에게 도달할 때까지 세 표면에 부딪혀서 일어나는 리플렉션의 선을 표시합니다.
    경고: 생성되는 리플렉션의 개수는 각 차순마다 기하급수적으로 늘어납니다.
  • Draw Diffraction Paths 활성화된 지오메트릭 회절을 나타내는 선을 표시합니다.
참고
  • 지오메트리 API를 사용하여 회절 시뮬레이션하기
  • AK::SpatialAudio::SetReflectionsOrder
  • AkSpatialAudioInitSettings


Wwise Unity Integration Documentation: 인스펙터에서 AkSpatialAudioListener 사용하기

인스펙터에서 AkSpatialAudioListener 사용하기

Spatial Audio 리스너를 추가하여 게임에서 Spatial Audio 사용하기. Unity 통합에서는 AkSpatialAudioListener가 AkAudioListener를 필요로 하기 때문에 AkAudioListener가 없을 경우 해당 오브젝트에 이를 자동으로 추가합니다.

이 AkAudioListner는 보통 Camera 오브젝트나 Player 오브젝트에 추가되지만 아무 게임 오브젝트에나 추가할 수 있습니다.

스크린샷에서 보이듯이 Spatial Audio가 단 하나의 활성화된 AkSpatialAudioListener만 지원한다는 것을 Unity 통합이 경고해줍니다. 적용할 곳을 주의 깊게 정하세요.

참고
  • Unity에서의 Spatial Audio
    • 3. Unity 프로젝트 준비


Wwise Unity Integration Documentation: 인스펙터에서 AkSurfaceReflector 사용하기

인스펙터에서 AkSurfaceReflector 사용하기

이 컴포넌트는 지오메트리를 Spatial Audio로 전송합니다. 이 컴포넌트는 소리 전달의 회절과 전달에 사용할 수 있으며, Wwise Reflect 플러그인이 있을 경우 초기 반사음을 시뮬레이션하는 데에도 사용할 수 있습니다.

  • Mesh 사운드의 초기 리플렉션, 회절, 혹은 전달에 사용될 메쉬를 말합니다. None으로 남겨둘 경우 가능하면 GameObject의 MeshFilter 컴포넌트에 있는 메쉬를 사용하게 됩니다.
  • Acoustic Textures Wwise Picker 의 WwiseProject > VirtualAcoustics에서 이미 정의한 Acoustic Texture를 사용하여 각 하위 메쉬의 Acoustic Texture를 선택하세요. 새로운 Acoustic Texture를 추가하려면 Virtual Acoustics 안에서 워크 유닛이나 폴더를 선택한 후 'Acoustic Texture' 버튼을 클릭하세요. 필터링되지 않은 초기 리플렉션을 사용하려면 None으로 남겨두세요.
  • Transmission Loss Values 각 하위 메쉬의 전달 손실값(0~1)을 선택하세요. 보통 값이 1.0일 경우 완전히 손실됨을 의미하며 0.0일 경우 소리가 필터링 없이 지오메트리를 통과하여 전달될 수 있음을 의미합니다.
  • Enable Diffraction 메쉬의 모서리에 지오메트리 회절을 설정합니다.
  • Enable Diffraction On Boundary Edges 경계 모서리에 지오메트리 회절을 설정합니다. 경계 모서리는 한 삼각형에만 연결된 모서리를 말합니다.
  • Associated Room(추후 사용 중단) 이 AkSurfaceReflector 구성 요소를 Room과 연결합니다. 이 속성은 더 이상 사용되지 않으며 향후 버전에서 제거될 예정입니다. None으로 설정하여 사용하지 않는 것이 좋습니다. AkSurfaceReflector 를 특정 Room과 연결하면 지오메트리에 접근할 수 있는 범위가 제한됩니다. 지오메트리를 공간과 연결하면 리플렉션과 회절 계산에 의해 실행되는 레이캐스트의 검색 공간을 줄여줍니다. 이 속성을 None으로 설정하면 해당 지오메트리는 전역적 범위를 가집니다. 하나 이상의 지오메트리가 Room과 연관되어 있는 경우 해당 Room은 더 이상 전역 범위에 있는 지오메트리에 접근할 수 없습니다.
참고
  • Unity에서의 Spatial Audio
    • 표면 리플렉터 튜토리얼
    • A. 표면 리플렉터와 포털
  • Wwise 도움말: Wwise Reflect - Acoustic Textures
  • Wwise 도움말: Wwise Reflect - 회절 작업하기
  • Wwise SDK doc: 공간 음향 - 회절
  • AK::SpatialAudio::SetGeometry


Wwise Unity Integration Documentation: Wwise 이벤트에 새로운 트리거 추가하기

Wwise 이벤트에 새로운 트리거 추가하기

Unity에서 대부분의 Wwise 컴포넌트에는 'Trigger On' 속성이 있습니다. 이 속성에서는 Wwise 컴포넌트(Event, Switch, State 등)를 트리거할 Unity 알림/이벤트를 선택할 수 있습니다. 이 목록은 Unity에서 사용 가능한 부분만 담고 있습니다. 하지만 트리거 시스템은 통합 코드 자체를 변경하지 않은 채 확장할 수 있습니다.

새로운 트리거를 추가하려면 AkTriggerBase 에서 파생되는 C# 클래스를 작성하세요. AkTriggerBase 에서 파생되는 모든 클래스는 리플렉션(reflection)을 통해 찾을 수 있으며 'Trigger On' 드롭 목록에 추가됩니다. 이 클래스 안에는 델리게이트(delegate)인 triggerDelegate(GameObject in_target)이 있으며 트리거가 실행될 조건이 일어날 경우 반드시 호출해야 합니다. 'target' 오브젝트는 선택적이며 현재 Collider(콜라이더)와 함께 사용될 경우 충돌 오브젝트를 제공하기 위해 사용됩니다. 이렇게 하면 Wwise 컴포넌트가 Collider 대신 '충돌하는 오브젝트'에서 Event를 게시할 수 있습니다.

필요할 경우 이 시스템을 사용하여 오디오 컴포넌트를 게임 코드에서 트리거할 수 있습니다. 코드에서 트리거가 실행될 상황이 일어날 경우 (혹은 커스텀 함수가 있을 경우) GetComponent<YourTriggerClass>().triggerDelegate(GameObject in_target) 를 호출하세요.

참고: 현재 AkTriggerBase 의 파생 클래스의 최대 개수는 32개 입니다.

다음은 커스텀 함수의 예시입니다.

public class TriggerOnGunHit : AkTriggerBase
{
void Hit()
{
if(triggerDelegate != null)
{
triggerDelegate(null);
}
}
}

게임 코드에 이 코드를 넣을 수 있습니다.

if (playerIsShot)
{
GetComponent<TriggerOnGunHit>().Hit();
}

그러면 TriggerOnGunHit 트리거에 연결된 Wwise 컴포넌트가 이 작업을 실행할 수 있습니다. 대부분의 단순한 상황에서 이 작업은 완전히 불필요합니다. 또한 AkSoundEngine.PostEvent("GunHit", gameObject) 로 기본 Wwise SDK를 호출하고 사운드 디자이너가 Wwise에서 이 Event의 효과를 처리하도록 할 수도 있습니다.

AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23


Wwise Unity Integration Documentation: Wwise Picker

Wwise Picker

Wwise Picker(와이즈 피커) 창은 Wwise 프로젝트에서 사용 가능한 오브젝트 (예: Event와 Switch)를 Wwise와 동일한 구조로 보여줍니다. Wwise Picker에 표시되는 프로젝트는 Wwise Settings 창 (menu Edit > Project Settings > Wwise Editor)에 입력된 프로젝트와 동일합니다. 보통 이 프로젝트는 Wwise 플러그인이 Unity 안에 설치되었을 때에 지정됩니다.

  • 기능
    • Picker로 오디오를 씬으로 추가하기
    • 검색 및 이동
    • Generating SoundBanks
    • Finding References in Scene
    • Auto Populate
    • Select in Wwise Picker
  • WAAPI 기능
    • 동기화된 선택
    • Event 재생
    • Renaming Wwise Objects
    • Open Containing Folder
    • Open SoundBank Folder
    • 프로젝트 새로 고치기
    • 연결 상태

2021.1 버전부터 Wwise Picker는 File System과 Wwise Authoring이라는 두 가지 모드를 가집니다. 이 모드는 피커 창의 상단 좌측 모서리에 있는 메뉴를 사용하여 변경할 수 있습니다.

File System 모드에서는 Wwise 프로젝트가 저장될 때 Wwise Picker 뷰에 있는 사용 가능한 오브젝트가 업데이트됩니다. 생성한 오브젝트가 보이지 않을 경우, 프로젝트가 저장되지 않았을 가능성이 높습니다. Refresh Project를 클릭하면 Wwise Picker 뷰를 새로 고칠 수 있습니다. 이때 SoundBank를 생성할 때 생기는 XML 메타데이터 파일에 있는 데이터를 포함한 Wwise에 관련된 모든 데이터도 새로 고침 됩니다.

참고: AkWwiseProjectData.asset은 버전 컨트롤에 넣지 마세요! 이 파일은 Wwise Picker가 계속해서 Work Unit 파일을 파싱하지 않도록 하는 Wwise 프로젝트 데이터의 임시 캐시 파일입니다. 이 파일을 버전 컨트롤에 추가할 경우 문제가 일어날 수 있습니다.
참고:
Wwise Settings 대화창에서 Wwise Windows Installation Path(와이즈 윈도우 설치 경로) (혹은 Mac의 경우 Wwise Application(와이즈 애플리케이션))를 반드시 지정해야 합니다. Unity에서 Generate SoundBanks를 클릭할 때 Unity가 Wwise 경로를 사용해야 합니다.

Wwise Authoring 모드에서 피커는 WAAPI를 사용하여 Wwise에서 열린 프로젝트와 통신합니다. File System 모드에서 제공되는 기능과 더불어, 이 모드는 다음의 기능을 제공합니다:

  • Wwise Authoring에서 오브젝트가 변경될 경우 사용 가능한 오브젝트를 즉시 업데이트함
  • Picker 안에서 사운드 Event 재생
  • Unity와 Wwise 간에 동기화된 선택
  • Unity 안에서 Wwise 오브젝트 이름 변경 및 삭제.
주의: 이 모드가 올바르게 작동하려면 Wwise 프로젝트가 Wwise Authoring 안에서 반드시 열려있어야 하며 WAAPI 설정이 올바르게 설정되어 있어야 합니다. 프로젝트의 WAAPI 설정하기에 대한 더 많은 정보는 WAAPI 유틸리티 페이지를 참조해 주세요.

기능

다음 섹션에서 설명된 기능은 File System과 Wwise Authoring 모드에서 모두 사용할 수 있습니다.

Picker로 오디오를 씬으로 추가하기

Wwise Picker에서 씬으로 오브젝트를 추가하려면 게임 오브젝트나 인스펙터 창으로 게임 오브젝트를 드래그하세요. 컴포넌트의 더 자세한 내용은 각 컴포넌트의 설명서를 참조하세요.

  • Event를 드래그하면 AkAmbient 가 생성됩니다.
  • SoundBank를 드래그하면 AkBank 가 생성됩니다.
  • Switch Value를 드래그하면 AkSwitch 가 생성됩니다.
  • State Value를 드래그하면 AkState 가 생깁니다.
  • Aux Bus 를 드래그하면 AkEnvironment 가 생깁니다.

검색 및 이동

Wwise Picker의 윗쪽에 있는 필터 박스를 사용해서 특정 아이템을 찾으세요. 찾고자 하는 아이템의 이름을 입력하면 Picker가 자동으로 검색어에 대응하지 않는 아이템을 걸러냅니다.

+와 - 버튼을 클릭하거나 아이템의 이름을 더블 클릭하면 아이템을 펼치거나 닫을 수 있습니다. 또한 키보드의 화살표 키를 사용해서 아이템을 선택하고 펼칠 수 있습니다.

찾고자 하는 아이템의 상위 계층이 닫혀 있는 경우 몇몇 아이템을 펼쳐야 할 수 있습니다.

Generating SoundBanks

Generate SoundBanks를 클릭하면 모든 플랫폼과 언어용 SoundBank가 생성됩니다. 생성된 SoundBank는 Wwise Picker의 SoundBanks 폴더 아래 Wwise 안에서 생성된 것과 동일하게 표시됩니다. 그리고 Unity 상태 막대가 다음 중 한 메시지를 표시하게 됩니다:

  • WwiseUnity: SoundBanks generation successful: 오류나 경고 메시지가 없을 경우
  • WwiseUnity: SoundBanks generation has warning(s): 경고 메시지가 있을 경우
  • WwiseUnity: SoundBanks generation error: 오류 메시지가 있을 경우 메시지를 클릭하면 SoundBank 생성 과정 정보를 보여주는 Console 탭으로 포커스가 옮겨집니다.

Finding References in Scene

픽커에서 Wwise 오브젝트를 우클릭하면 씬에서 해당 오브젝트로의 참조를 찾는 옵션을 선택할 수 있습니다. 이 옵션을 선택하면 Hierarchy 창이 해당 Wwise 오브젝트로의 참조를 담은 GameObject만 표시하게 됩니다. 또한 아이템을 선택하고 Shift + R을 눌러서 같은 작업을 실행할 수 있습니다.

Auto Populate

이 옵션은 File System 모드에서만 나타납니다. 이 옵션이 활성화되면 Wwise 프로젝트 파일에서 변경이 감지될 때마다 (보통 프로젝트를 저장하면 감지됨) 피커가 내용을 업데이트하게 됩니다. 이 옵션을 비활성화하면 Refresh Project 버튼을 눌러서 피커 내용을 업데이트해야 합니다.

Select in Wwise Picker

이제 Wwise Object 오브젝트를 참조하는 Wwise 컴포넌트를 우클릭하면 피커에서 해당 오브젝트를 선택할 수 있는 메뉴 옵션이 제공됩니다. 이 옵션을 사용하면 피커 윈도에서 참조된 오브젝트가 강조 표시됩니다.

WAAPI 기능

Wwise Authoring 모드를 사용할 경우 Wwise 프로젝트에서의 변경 내용이 피커 창에 즉시 반영됩니다. Wwise Project Explorer에서 오브젝트를 복사, 이름 변경, 삭제, 이동할 경우 Picker 창의 내용이 항상 대응하게 됩니다. 또한 피커 창에서 아이템을 우클릭하면 제공되는 수많은 추가 기능을 확인할 수 있습니다:

동기화된 선택

Autosync selection 옵션을 사용하면 Unity와 Wwise 저작 간에 선택 사항을 동기화할지의 여부를 결정할 수 있습니다. 이 옵션은 마지막으로 선택한 아이템을 같게 해서 두 프로그램 간을 쉽게 전환할 수 있게 해줍니다.

Event 재생

WAAPi Picker에서 이벤트를 우클릭해서 들어보기를 선택할 수 있습니다. 또한 동일한 옵션을 사용해서 재생이 시작되어 진행 중인 Event를 중단할 수도 있습니다.

빠른 실행: Space bar 혹은 빠른 더블 클릭.

어떤 이벤트를 재생 중인지 잊어버릴 경우, 피커에서 아무 아이템이나 우클릭해서 Stop All을 선택할 수 있습니다.

Renaming Wwise Objects

바로가기 메뉴에서 이 옵션을 선택하면 피커 창 안에서 Wwise 오브젝트의 이름을 변경할 수 있습니다.

빠른 실행: F2나 느린 더블 클릭.

참고: Work Unit이나 Physical Folder의 이름은 변경할 수 없습니다.

Open Containing Folder

바로가기 메뉴의 Open Containing Folder 옵션은 Wwise 오브젝트의 Work Unit이 담긴 폴더를 파일 탐색기에서 열어줍니다.

빠른 실행: Ctrl + O

Open SoundBank Folder

선택한 아이템이 SoundBank일 경우, SoundBank 폴더를 열 수 있는 추가 옵션이 제공됩니다. 이 옵션은 Wwise Authoring에서 현재 활성화된 플랫폼의 Generated SoundBanks 폴더를 파일 탐색기에서 열어줍니다.

참고: SoundBank를 아직 생성하지 않았을 경우 아마도 OS의 최상위 계층 폴더가 열릴 것입니다.

프로젝트 새로 고치기

Wwise Authoring 모드에서 Refresh 버튼을 클릭하면 피커 창을 비우고 WAAPI를 사용하여 프로젝트의 내용을 다시 페치하게 됩니다.

연결 상태

연결 상태와 실패한 WAAPI 요청에 의한 오류 메시지는 Wwise Picker Window의 상단 우측 모서리에 표시됩니다.

프로젝트에 WAAPI 설정하기에 대한 더 많은 정보는 WAAPI 유틸리티 페이지를 참고해 주세요. WAAPI가 활성화되었지만 Unity 프로젝트가 웹소켓 연결을 성공적으로 열지 못할 경우, Wwise Picker 창에서 특정 오류 메시지가 표시됩니다.

연결 오류 메시지:

  • Connection refused
    • 프로젝트가 열려 있지 않은 경우
    • Unity나 Wwise WAAPI 설정에서 잘못된 포트/IP 주소가 지정된 경우
    • Wwise Authoring User 사용자 환경에서 WAAPI가 비활성화되었을 경우
  • The wrong project is open in Wwise
    • 올바른 프로젝트가 열려 있는지 확인하세요
  • No project is open in Wwise yet
    • 프로젝트가 열려있는지 확인하세요

기타 오류 메시지:

  • Cannot execute call because Wwise has an exclusive lock
    • Wwise Authoring에서 모달이나 설정 창이 열려있을 경우.

연결에 실패할 때마다 Unity 통합이 2^N초 후에 재연결을 시도합니다 (N은 실패한 연결 시도 횟수를 말함). 이 대기 시간은 32초를 초과하지 않습니다.


Wwise Unity Integration Documentation: Wwise Type

Wwise Type

Wwise Type은 SoundBank, Event, Game Parameters, State, Switch와 같은 주요 오브젝트를 나타내는 클래스의 모음을 말합니다. 각 클래스에는 필요한 오브젝트를 쉽게 선택할 수 있는 속성 창이 있습니다. 또한 Wwise Type에는 Event를 게시할 때 사운드 엔진에 전송할 수 있는 콜백 플래그를 나타내는 지원 클래스가 있습니다.

다음은 몇 가지 Wwise Type을 사용하는 스크립트의 예시입니다.

public class WwiseTypesExample : UnityEngine.MonoBehaviour
{
public AK.Wwise.Bank MyBank = null;
public AK.Wwise.Event MyEvent = null;
public AK.Wwise.RTPC MyRTPC = null;
public void Awake()
{
MyBank.Load();
}
public void Start()
{
MyEvent.Post(gameObject);
}
private float CalculateMyValue()
{
return (float)System.Math.Sin(System.Math.PI * UnityEngine.Time.timeSinceLevelLoad);
}
public void Update()
{
MyRTPC.SetValue(gameObject, CalculateMyValue());
}
}

위의 스크립트는 다음 인스펙터를 자동으로 생성합니다.

WwiseTypesExample 클래스를 다음과 같이 변경하면 마커 콜백을 사용할 수 있습니다.

public AK.Wwise.CallbackFlags MyCallbackFlags = null;
public void Start()
{
MyEvent.Post(gameObject, MyCallbackFlags, EventCallback);
}
private void EventCallback(object cookie, AkCallbackType type, AkCallbackInfo info)
{
if (type == AkCallbackType.AK_Marker)
{
var markerInfo = info as AkMarkerCallbackInfo;
if (markerInfo != null)
{
// ...
}
}
}
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25


Wwise Unity Integration Documentation: C# 코드를 사용하여 사운드 엔진 제어하기

C# 코드를 사용하여 사운드 엔진 제어하기

대부분의 Wwise SDK 함수는 AkSoundEngine 클래스를 통해 Unity에서 사용할 수 있습니다. C++의 네임스페이스 AK::SoundEngine, AK::MusicEngine 등을 대체한다고 생각하면 됩니다. 원본 SDK와 비교하여 API 바인딩에서 변경한 내용은 API 변경 및 제한 사항 를 참고하세요. 더욱 복잡한 상황의 경우 코드에서 Wwise 함수를 호출해야 합니다. API에서 모든 함수 안에 있는 GameObjectID 는 Unity GameObject 개념으로 대체됩니다. AkGameObj 컴포넌트를 수동으로 추가지 않은 경우 런타임에서 자동으로 해당 GameObject에 추가됩니다.

Event와 Bank에 문자열이 아닌 숫자 ID 사용하기

네이티브 Wwise API에서는 문자열이나 ID를 사용하여 Wwise 프로젝트에서 이벤트나 명명된 오브젝트를 트리거할 수 있습니다. Wwise_IDs.h 파일을 Wwise_IDs.cs 로 변경하면 C::에서도 그렇게 할 수 있습니다. Assets > Wwise > Convert Wwise SoundBank IDs를 클릭하세요. 이 작업을 위해서는 Python(파이썬)이 설치되어 있어야 합니다.

Wwise에 MIDI 전송하기

AkMIDIPostArray 클래스의 AkMIDIPost 멤버를 채워 넣거나 다음 메소드를 호출하면 Wwise에 MIDI를 전송할 수 있습니다.

  • AkMIDIPostArray.PostOnEvent()
  • AkSoundEngine.PostMIDIOnEvent()
  • AK.Wwise.Event.PostMIDI()

다음은 사운드 엔진에 MIDI 메시지를 전송하는 기본 스크립트입니다.

public class MyMIDIBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event SynthEvent;
private void Start()
{
AkMIDIPostArray MIDIPostArrayBuffer = new AkMIDIPostArray(6);
AkMIDIPost midiEvent = new AkMIDIPost();
midiEvent.byType = AkMIDIEventTypes.NOTE_ON;
midiEvent.byChan = 0;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 127;
midiEvent.uOffset = 0;
MIDIPostArrayBuffer[0] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[1] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[2] = midiEvent;
midiEvent.byType = AkMIDIEventTypes.NOTE_OFF;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 0;
midiEvent.uOffset = 48000 * 8;
MIDIPostArrayBuffer[3] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[4] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[5] = midiEvent;
SynthEvent.PostMIDI(gameObject, MIDIPostArrayBuffer);
}
}

Unity에서 오프라인 렌더링하기

Unity 통합은 Wwise SDK 안에서 오프라인 렌더링하기 기능을 제공하여 오디오 샘플을 가져올 수 있는 방법을 간소화해줍니다.

주의: 오프라인 렌더링이 활성화된 경우 비동기적 AkSoundEngine.LoadBank 와 AkSoundEngine.UnloadBank API만 메인 스레드에서 사용되도록 주의해야 합니다. 더 자세한 설명은 오디오 렌더링 커스텀 예약을 참고해 주세요.

AkSoundEngine.StartDeviceCapture 는 캡처를 위해 특정 출력 오디오 장치를 설정하여 AkSoundEngine.UpdateCaptureSampleCount 를 호출해서 사용 가능한 샘플의 개수를 결정하고 AkSoundEngine.GetCaptureSamples 를 사용하여 오디오 샘플을 가져올 수 있도록 해줍니다.

다음 예시는 Unity의 스크린 캡처 기능과 함께 Unity 통합을 사용하여 오프라인 오디오 렌더링을 실행하는 방법을 설명해줍니다. 이 기능이 구현됨으로써 다중 조작 후반 처리 단계를 쉽게 실행하여 캡처된 오디오 샘플과 비디오 프레임을 동영상으로 조합할 수 있게 되었습니다.

public abstract class WwiseOfflineRenderer : UnityEngine.MonoBehaviour
{
public bool IsOfflineRendering { get; set; }
public bool StartWithOfflineRenderingEnabled = false;
private bool IsCurrentlyOfflineRendering = false;
public float FrameRate = 25.0f;
protected ulong OutputDeviceId = 0;
public abstract string GetUniqueScreenshotFileName(int frameCount);
public abstract void ProcessAudioSamples(float[] buffer);
protected void Start()
{
OutputDeviceId = AkSoundEngine.GetOutputID(AkSoundEngine.AK_INVALID_UNIQUE_ID, 0);
if (StartWithOfflineRenderingEnabled)
{
IsOfflineRendering = true;
Update();
}
}
private void LogAudioFormatInfo()
{
var sampleRate = AkSoundEngine.GetSampleRate();
var channelConfig = new AkChannelConfig();
var audioSinkCapabilities = new Ak3DAudioSinkCapabilities();
AkSoundEngine.GetOutputDeviceConfiguration(OutputDeviceId, channelConfig, audioSinkCapabilities);
UnityEngine.Debug.LogFormat("Sample Rate: {0}, Channels: {1}", sampleRate, channelConfig.uNumChannels);
}
protected void Update()
{
if (IsOfflineRendering != IsCurrentlyOfflineRendering)
{
IsCurrentlyOfflineRendering = IsOfflineRendering;
if (IsOfflineRendering)
{
#if UNITY_EDITOR
// 에디터 업데이트가 AkSoundEngine.RenderAudio()를 호출하지 않도록 확인하세요.
AkSoundEngineController.Instance.DisableEditorLateUpdate();
#endif
LogAudioFormatInfo();
AkSoundEngine.ClearCaptureData();
AkSoundEngine.StartDeviceCapture(OutputDeviceId);
}
else
{
AkSoundEngine.StopDeviceCapture(OutputDeviceId);
#if UNITY_EDITOR
// 에디터 업데이트 호출을 AkSoundEngine.RenderAudio()로 다시 가져옵니다.
AkSoundEngineController.Instance.EnableEditorLateUpdate();
#endif
}
}
var frameTime = IsOfflineRendering && FrameRate != 0.0f ? 1.0f / FrameRate : 0.0f;
UnityEngine.Time.captureDeltaTime = frameTime;
AkSoundEngine.SetOfflineRenderingFrameTime(frameTime);
AkSoundEngine.SetOfflineRendering(IsOfflineRendering);
if (!IsOfflineRendering)
return;
UnityEngine.ScreenCapture.CaptureScreenshot(GetUniqueScreenshotFileName(UnityEngine.Time.frameCount));
var sampleCount = AkSoundEngine.UpdateCaptureSampleCount(OutputDeviceId);
if (sampleCount <= 0)
return;
var buffer = new float[sampleCount];
var count = AkSoundEngine.GetCaptureSamples(OutputDeviceId, buffer, (uint)buffer.Length);
if (count <= 0)
return;
ProcessAudioSamples(buffer);
}
}

Unity에서 오디오 입력 음원 플러그인 사용하기

오디오 입력 음원 플러그인은 C# 스크립트를 통해 사용할 수 있습니다. Wwise SDK 설명서에서 오디오 입력 음원 플러그인을 참고하세요.

다음은 오디오 입력 음원 플러그인에 시험음을 전송하는 기본 스크립트입니다.

public class MyAudioInputBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event AudioInputEvent;
public uint SampleRate = 48000;
public uint NumberOfChannels = 1;
public uint SampleIndex = 0;
public uint Frequency = 880;
private bool IsPlaying = true;
// 오디오 샘플을 채워 넣는 콜백 - 이 함수는 모든 채널에 대해서 각 프레임마다 호출됩니다.
bool AudioSamplesDelegate(uint playingID, uint channelIndex, float[] samples)
{
for (uint i = 0; i < samples.Length; ++i)
samples[i] = UnityEngine.Mathf.Sin(Frequency * 2 * UnityEngine.Mathf.PI * (i + SampleIndex) / SampleRate);
if (channelIndex == NumberOfChannels - 1)
SampleIndex = (uint)(SampleIndex + samples.Length) % SampleRate;
// false를 반환하여 제공할 데이터가 없음을 표시합니다. 이 경우 연결된 이벤트도 중단됩니다.
return IsPlaying;
}
// 오디오 형식을 설정하는 콜백 - 이 함수는 샘플이 요청되기 전에 한 번 호출됩니다.
void AudioFormatDelegate(uint playingID, AkAudioFormat audioFormat)
{
// 설정해야 하는 주요 매개 변수는 채널 구성과 샘플 레이트입니다.
audioFormat.channelConfig.uNumChannels = NumberOfChannels;
audioFormat.uSampleRate = SampleRate;
}
private void Start()
{
// Audio Input 플러그인을 사용하도록 Wwise 안에서 설정된 AudioInputEvent 이벤트는 gameObject에 전달됩니다.
// AudioFormatDelegate는 한 번 호출되며 AudioSamplesDelegate는 false를 리턴할 때까지 각 프레임마다 한 번 호출됩니다.
AkAudioInputManager.PostAudioInputEvent(AudioInputEvent, gameObject, AudioSamplesDelegate, AudioFormatDelegate);
}
// 이 메소드를 다른 스크립트에서 호출하여 콜백을 중단할 수 있습니다
public void StopSound()
{
IsPlaying = false;
}
private void OnDestroy()
{
AudioInputEvent.Stop(gameObject);
}
}

Unity에서 맞춤 위치 지정 적용하기

기본적으로 AkGameObj 컴포넌트는 특정한 Unity gameObject 에 연결되어 있으며 트랜스폼(transform) (필요시 상쇄값도 포함)을 사용하여 전체 위치 지정을 설정합니다. 이 방법은 보통 1인칭 슈팅 게임과 같은 수많은 게임에 적합합니다. 하지만 3인칭 게임과 같이 맞춤 카메라 각도가 있는 게임의 경우, Unity의 메인 카메라와 같이 한 게임 오브젝트에 오디오 리스너(audio listener)를 연결해서는 위치 지정의 두 방면 (거리 감쇠와 공간화)를 다루기가 어렵습니다. 게임에 따라 플레이어가 맞춤화된 다른 위치 지정을 경험하도록 하고자 할 수 있습니다.

이런 경우를 위해 AkGameObj 컴포넌트 클래스는 Unity 사용자가 위치 지정을 오버라이드할 수 있게 해줍니다. Unity에서는 세 가지 가상 메소드인 GetPosition(), GetForward(), GetUpward() 를 통해 AkGameObj 로부터 하위 클래스를 만들고, 이 하위 클래스 컴포넌트를 사용해서 Unity gameObjects 의 위치 지정을 맞춤화할 수 있습니다.

다음은 커스텀 컴포넌트를 사용하여 기본 AkAudioListener 작동 방식을 덮어쓰는 방법을 보여주는 간단한 예시입니다. Wwise를 사용하여 통합된 3인칭 프로젝트의 경우 기존의 AkAudioListener 와 연관된 AkGameObj 를 제거하세요. 그리고 다음 스크립트를 MainCamera 오브젝트에 연결하고 AkAudioListener 를 연결하세요. 마지막으로 오디오 리스너의 위치가 따를 대상 Unity gameObject (예를 들어 플레이어 아바타와 같이)를 지정하세요. 이렇게 하면 모든 이미터의 거리 감쇠가 선택된 Unity gameObject 의 위치를 리스너의 위치 (화면 안의 거리 리스너)로 사용하며, 모든 이미터의 거리는 여전히 메인 카메라의 방향을 리스너의 방향 (화면 밖의 방향 리스너)으로 설정합니다.

#if ! (UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
//
// Copyright (c) 2017 Audiokinetic Inc. / All Rights Reserved
//
using UnityEngine;
using System;
using System.Collections.Generic;
[AddComponentMenu ("Wwise/AkGameObj3rdPersonCam")]
[ExecuteInEditMode] //isStaticObject의 알맞은 상태를 유지하는 데 필요한 ExecuteInEditMode입니다.
public class AkGameObj3rdPersonCam : AkGameObj
{
public Transform target; // 해당 카메라가 따라갈 위치를 말합니다. 인스펙터에서 사용자가 이 부분을 플레이어 캐릭터의 Unity gameObject로 지정할 수 있습니다.
// 카메라의 위치를 플레이어의 위치로 설정하여 거리 감쇠를 처리합니다.
public override Vector3 GetPosition ()
{
return target.GetComponent<AkGameObj> ().GetPosition ();
}
}
#endif // #if ! (UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:278


Wwise Unity Integration Documentation: Wwise Timeline 통합

Wwise Timeline 통합

Unity의 Timeline(타임라인)은 시네마틱 편집 도구입니다. 게임플레이 시퀀스, 오디오 시퀀스 그외 시네마틱 콘텐츠를 만드는 데에 사용할 수 있습니다.

Timeline에 대한 더 많은 정보는 Unity의 Timeline 설명서를 참고해 주세요.

Timeline Asset(타임라인 에셋)과 Timeline 인스턴스를 만드는 법에 대한 설명은 타임라인 사용하기를 참조하세요.

참고: Unity 2019.3부터 Timeline이제 Unity Package Manager를 통해 제공됩니다. Timeline 패키지 설치를 삭제하려는 경우 모든 플랫폼의 Player Settings에 AK_DISABLE_TIMELINE Scripting Define Symbol을 추가하세요.

Wwise Timeline 트랙

Wwise Unity 통합은 AkTimelineEventTrack 과 AkTimelineRtpcTrack 이라는 두 개의 새로운 Timeline 트랙과 AkEventTrack 과 AkRTPCTrack 이라는 추후 버전에서는 지원되지 않는 두 개의 Timeline 트랙을 추가합니다.

AkTimelineEventTrack 은 Wwise Event를 게시하는 데에 사용되며 AkTimelineRtpcTrack 은 Game Parameter 값을 설정하는 데에 사용됩니다. 두 타입의 트랙은 모두 'Add' 드롭다운 버튼을 사용하거나 Timeline 창의 트랙 헤더 섹션을 우클릭하여 Timeline에 추가할 수 있습니다.

AK 트랙을 Timeline에 추가하기
참고: AkEventTrack 과 AkRTPCTrack 트랙과 연관된 플레이어블은 이전 버전과의 호환성을 제공하기 위해 포함되었으며 더 이상 사용하지 말아야 합니다.
추후 버전에서는 지원되지 않는 AkEventTrack

Ak 트랙 오브젝트 바인딩

AkTimelineEventTrack 과 AkTimelineRtpcTrack 은 Game Object에 설정할 수 있는 오브젝트 바인딩을 가지고 있습니다. 명시적으로 설정된 트랙 바인딩은 대상 Game Object를 지정합니다. 트랙 바인딩이 설정되지 않았을 경우 (None으로 설정될 경우) 해당 트랙은 Timeline을 소유하는 Game Object (PlayableDirector 컴포넌트를 가지고 있으며 Timeline을 트리거하는 데에 사용되는 Game Object) 를 대상으로 하게 됩니다. Event가 게시되며 RTPC가 이 대상 GameObject를 변경하게 됩니다.

참고: 런타임 때 할당을 감소하려면 이벤트를 게시하거나 RTPC가 변경될 모든 GameObject 에 AkGameObj 를 추가하세요.

Wwise 타임라인 Playable 클립

AkTimelineEventTrack 트랙은 AkTimelineEventPlayable 클립을, AkTimelineRtpcTrack 은 AkTimelineRtpcPlayable 클립을 가집니다. 이 클립은 트랙의 메뉴를 사용하거나 트랙을 우클릭하여 추가할 수 있습니다.

AK 클립을 AK 트랙에 추가하기

Timeline 클립 속성

Timeline에 있는 모든 클립에는 타이밍 속성이 있으며 인스펙터의 윗 부분에 표시됩니다. 이 속성에 대한 더 많은 정보는 클립 속성을 참고하세요.

AkTimelineEventPlayable 클립 속성

다음 속성은 AkTimelineEventPlayable 클립의 인스펙터에서 접근할 수 있습니다:

AkTimelineEventPlayable 클립 속성
  • Event: 해당 클립에 의해 트리거될 Wwise Event 입니다.
  • Blend In Curve: Event를 게시할 때 사용되는 AkCurveInterpolation 값입니다. 이 값은 클립의 Ease In Duration가 0보다 클 경우에만 작동합니다.
  • Blend Out Curve: Event를 중단할 때 사용되는 AkCurveInterpolation 값입니다. 이 값은 클립의 Ease Out Duration이 0보다 클 경우에만 작동합니다.
  • Use Wwise Event Duration: 이 속성을 선택할 경우 Event가 클립의 전체 지속 시간동안 트리거되며 API 호출로 인해 명시적으로 중단되지 않습니다. 그리고 다음의 두 매개 변수를 사용할 수 없게 됩니다.
  • Stop Event At End Of Clip: 이 속성을 선택할 경우 클립이 끝날 때 Blend Out Curve가 작동할 수 있는 알맞은 시간에 중단 API 함수가 실행되며 Event가 중단됩니다. 선택하지 않을 경우 Blend Out Curve가 작동하지 않으며 Event가 지속 경과 시간까지 계속해서 재생됩니다.
  • Loop: 이 속성을 선택했으며 클립의 지속 시간이 Event의 지속 시간보다 길 경우 클립이 끝날 때까지 해당 Event가 끝날 때마다 다시 트리거됩니다.

AkTimelineRtpcPlayable 클립 속성

다음 속성은 AkTimelineRtpcPlayable 클립의 인스펙터에서 접근할 수 있습니다:

AkTimelineRtpcPlayable 클립 속성
  • RTPC: 해당 트랙과 연관된 GameObject에 설정될 Wwise Game Parameter를 말합니다.
  • Set Globally: 이 속성을 선택할 경우 RTPC가 모든 오브젝트에서 전역적으로 설정됩니다.
  • Animated Value: Value 해당 클립에 의해 애니메이트될 값을 말합니다.

AkTimelineRtpcPlayable 클립 곡선

트랙 대상으로 전송된 RTPC의 값을 애니메이트하기 위해서는 다음 단계를 실행해야 합니다.

  1. 알맞은 시점에서 알맞은 지속 시간의 클립을 만드세요.
  2. 트랙을 녹화 준비 시키세요.
  3. Timeline Playhead를 클립 영역 안에 배치하세요.
  4. 해당 클립의 Inspector에서 Value를 우클릭하면 Key를 추가, 제거, 변경할 수 있는 콘텍스트 메뉴가 뜹니다.
  5. 첫 번째 키를 추가한 후에 해당 클립을 더블 클릭하면 곡선과 키를 더욱 정밀하게 편집할 수 있는 Animation Window가 열립니다.
참고: Timeline에서 애니메이션 곡선 변경하기에 대한 더 많은 정보는 Infinite 클립으로 기본 애니메이션 녹화하기를 참고해 주세요.
녹화 준비 및 디스플레이 곡선 버튼
녹화 준비되었으며 곡선이 표시된 AkTimelineRtpcPlayable

자주 겪는 문제 & 제한 사항

스크러빙은 현재 Unity Editor의 Edit 모드와 Play 모드에서 지원됩니다. 하지만 어셈블리 다시 로드하기에서는 재생을 사용할 수 없습니다.

Wwise 프로젝트 설정하기

Event 길이가 AkTimelineEventTracks 에서 알맞게 표시되도록 하려면 Wwise 프로젝트가 오디오 Event의 길이를 예측하도록 구성되어야 하며 XML 메타데이터가 반드시 생성되어야 합니다. 이 프로젝트 범위의 설정을 활성화하려면 Project Settings의 SoundBanks 탭으로 이동하세요. 아래와 같이 Metadata Options 그룹 상자에서 Estimated duration 체크 상자를 활성화하고 SoundBank Settings 그룹 상자에서 Generate XML Metadata를 활성화하세요.

AkTimelineEventTracks에 필요한 Project Settings


Wwise Unity Integration Documentation: 원하는 플랫폼으로 Unity 게임 빌드하기

원하는 플랫폼으로 Unity 게임 빌드하기

원하는 플랫폼으로 Unity 게임을 빌드하는 작업이 Unity의 표준 파이프라인이나 빌드 스크립트로 애플리케이션을 제작하는 것만큼 간단해졌습니다. SoundBank를 생성, 복사, 삭제하는 빌드 전/후 단계는 Edit > Project Settings > Wwise Editor 안에서 활성화/비활성화할 수 있습니다.

Wwise 플러그인 배포

Unity 빌드 시스템은 Wwise 플러그인을 게임에 자동으로 패키징합니다. 기본적으로 플러그인의 Profile 환경 설정이 사용됩니다. 이 설정은 Wwise를 게임에 연결하여 프로파일링할 수 있게 해주기 때문에 가장 실용적인 설정이라고 할 수 있습니다. 하지만 게임을 배포할 준비가 되었을 경우 Assets > Wwise > Activate Plugins 메뉴로 가서 Wwise 플러그인 구성을 Release 옵션으로 변경해야 합니다.

참고: Debug 는 사운드 엔진에 관한 문제를 디버깅하는 데 사용되며 보통 Audiokinetic 지원팀의 협력과 함께 문제를 해결하게 됩니다.
참고
  • 플랫폼별 정보

StreamingAssets 폴더

Unity는 보통 <UNITY_PROJECT_ROOT>\Assets\StreamingAssets와 같이 Unity 프로젝트의 Assets 폴더에 StreamingAssets 폴더를 만듭니다 (Unity 프로젝트에 없을 경우 직접 만드세요). Unity는 이 폴더의 콘텐츠를 대상 장치에 자동으로 배포합니다. 자세한 내용은 Unity의 StreamingAssets 기능을 참고하세요.

기본 SoundBanks 경로인 Audio\GeneratedSoundBanks는 StreamingAssets 폴더 아래 있습니다. Unity는 이 최종 경로에 현재 플랫폼의 폴더를 추가하며, 폴더의 이름은 Wwise 프로젝트의 Platform Manager에서 설정한 것과 같습니다. 이렇게 <UNITY_PROJECT_ROOT>\Assets\StreamingAssets\Audio\GeneratedSoundBanks\<해당플랫폼>이라는 전체 경로가 형성됩니다.

필요한 경우 Common User Settings에서 Base Path를 변경할 수 있습니다.

Unity 에디터를 실행할 때 SoundBanks 경로는 항상 Wwise 프로젝트의 Project Settings 대화창에서 정의된 GeneratedSoundBank 경로를 가리키도록 설정되어 있습니다. 이렇게 하면 Windows나 Mac에서 사운드를 통합할 때 뱅크 배포 오류를 방지할 수 있습니다.

단일 플랫폼 프로젝트에서 SoundBank 배포하기

SoundBank 파일을 실제로 StreamingAssets 폴더로 옮기는 대신 단일 플랫폼 게임을 작업할 경우 Wwise 프로젝트에서 SoundBank의 출력 경로를 StreamingAssets 폴더 아래 원하는 폴더로 설정하면 원하는 위치에 SoundBank가 바로 생성되도록 할 수 있습니다. 이 방법을 사용할 경우 Wwise Settings 창에서 SoundBank 생성과 복사에 관련된 빌드 전 단계를 비활성화해야 합니다.

멀티 플랫폼 프로젝트에서 SoundBank 배포하기

여러 플랫폼에서 출시되는 제품의 경우 빌드 전 단계를 사용하여 바이너리가 생성되기 전에 SoundBank를 생성하고 StreamingAssets 폴더로 복사할 수 있습니다. 그런 다음 빌드 후 단계를 사용하여 SoundBank를 삭제해서 대상 플랫폼의 SoundBank만 배포되도록 할 수 있습니다.

최종 구현은 더 정교한 관리에 필요한 잠재적인 필요를 수용하기 위해서 게임 개발자가 결정해야 합니다.

참조 플랫폼에 대한 여러 가지 커스텀 플랫폼 다루기

Wwise 프로젝트에서 아이패드나 아이폰 플랫폼 대상 iOS와 같이 동일한 참조 플랫폼의 여러 가지 버전을 정의했을 경우 추가적인 스크립팅 작업이 필요합니다. 더 많은 정보는 Unity에서 Wwise 커스텀 플랫폼 사용하기 를 참고하세요.

SoundBank 메타데이터 제외하기

Wwise는 TXT나 XML같은 SoundBank 메타데이터 파일을 생성합니다. 이 파일들은 항상 SoundbanksInfo 라는 이름으로 돼있습니다. 이 파일은 다른 파이프라인 도구에 의해 사용되는 SoundBank에 대한 정보를 담고 있지만, 게임에 필요하지 않습니다. 이 파일은 최종 StreamingAssets 폴더에 복사할 필요가 없습니다.


Wwise Unity Integration Documentation: Wwise와 Unity에서 DLC 만들기

Wwise와 Unity에서 DLC 만들기

Wwise 파일 패키지 사용하기

Wwise에서 DLC를 지원하는 기본적인 방법은 파일 패키지를 사용하는 것입니다. 이 방법은 저작 설명서의 Wwise > 도움말 > 프로젝트 완료하기 > 파일 패키지 관리하기 > 다운로드용 콘텐츠 개요에서 설명되어 있습니다. 요약하여 설명하자면, 이 패키지는 BNK와 WEM의 대체 혹은 추가 파일을 담을 수 있으며 DLC를 활성화하거나 비활성화하도록 자유롭게 로드(load)하고 언로드(unload) 할 수 있습니다. 이 패키지 형식은 선택적이지만 현재 Wwise/Unity 플러그인에 내장되어 있습니다. 직접 패키지 형식을 작성하고자 할 경우 새로운 Low-Level IO를 작성하여 기본 형식을 대체해야 합니다.

Unity에서 패키지를 사용하려면 AkInitializer의 속성에서 정의한대로 뱅크가 있는 경로인 Base Path에 패키지를 배치하세요. 그런 다음 AkSoundEngine.LoadFilePackage() 를 호출하세요. Wwise는 항상 파일 패키지를 통해 파일을 역순서로 로드합니다 (가장 마지막으로 추가된 파일이 가장 먼저 검색됨).

이 방법은 게임을 출시한 후 디스크 상에서 Base Path에 작성할 수 있는 모든 플랫폼에서 작동합니다. 하지만 iOS나 Android의 경우 사용할 수 없습니다.

Android와 iOS의 경우 모든 데이터가 읽기 전용 시스템으로 묶여지기 때문에 패키지를 다른 폴더에 배치해야 합니다. 이 작업은 AkSoundEngine.LoadFilePackage()에 앞서 AkSoundEngine.AddBasePath()를 호출함으로써 완료됩니다. 여러 개의 경로를 추가할 수 있으며 가장 마지막으로 추가된 경로가 가장 먼저 검색됩니다. 제한 사항은 해당 운영 체제의 설명서를 참고하세요. 아래 코드는 파일을 저장할 경로를 선택하는 코드의 예시입니다.

#if UNITY_IPHONE
string fileNameBase = Application.dataPath.Substring(0, Application.dataPath.LastIndexOf('/'));
fileName = fileNameBase.Substring(0, fileNameBase.LastIndexOf('/')) + "/Documents/" + FILE_NAME;
#elif UNITY_ANDROID
fileName = Application.persistentDataPath + "/" + FILE_NAME ;
#else
fileName = Application.dataPath + "/" + FILE_NAME;
#endif

Android에서는 SD 카드나 유사한 저장 장치와 같이 작성 가능한 여러 가지 경로가 있습니다.

참고
  • OBB 파일 사용하기

Addressables 사용하기

Unity Addressables 시스템은 SoundBank와 스트리밍 미디어 파일을 패키징하고 배포하는 데에 사용할 수 있습니다. 더 자세한 정보는 Unity용 Wwise Addressables Package 페이지를 참고해 주세요.

UnityWebRequest를 사용하여 뱅크 스트리밍 하기

Unity에서 UnityWebRequest를 클래스를 사용하여 DLC 오디오 파일을 가져오고 직접 로드할 수도 있습니다. 이 작업은 AkMemBankLoader.cs에서 설명한 것처럼 메모리 안에서의 뱅크 로딩을 통해 실행됩니다. 오래된 버전의 Unity의 경우 AkMemBankLoader가 WWW 클래스로 뱅크도 로드합니다 (현재는 사용되지 않음). 기존의 뱅크를 새로운 뱅크로 교체할 경우 반드시 이전 뱅크를 언로드 해야 합니다. Wwise IO 시스템은 해당 코드를 알지 못하기 때문에 동일한 뱅크를 실수로 다시 로드하려는 것인지 혹은 교체하려는 것인지를 알아채지 못합니다.


Wwise Unity Integration Documentation: 소스 코드에서 네이티브 Integration 플러그인 빌드하기

소스 코드에서 네이티브 Integration 플러그인 빌드하기

Wwise-Unity 통합은 네이티브 Wwise API를 호출하는 얇은 C# 레이어라고 할 수 있습니다. 그리고 모든 플랫폼용으로 미리 생성되어 제공됩니다. 대부분의 경우 이 Integration 플러그인을 다시 생성할 필요가 없습니다. 하지만 소스 코드가 있을 경우, 이 소스 코드를 변경해서 커스터마이징한 변경 사항을 네이티브 사운드 엔진에 통합하거나 사운드 엔진과 연결하는 C++ 코드를 변경하고자 할 수 있습니다. 이 작업은 C++ 지식을 어느 정도 알고 있는 프로그래머가 처리해야 합니다.

작업 단계

  1. Audiokinetic 런처를 사용하여 빌드하고자 하는 플랫폼의 Wwise SDK를 설치하세요. 로그오프한 후 다시 로그인하세요.
  2. 사용 중인 운영 체제 (Windows나 Mac)의 소스 압축 파일을 찾으세요. 이 파일은 Launcher에서 Wwise 통합을 Unity에 추가할 때 함께 설치됩니다. (압축 파일의 이름이 _Src.zip로 수정되어 있습니다).
  3. 빌드하고자 하는 플랫폼의 소스 압축 코드를 찾으세요 (Windows나 Mac이 아닌 다른 플랫폼).
  4. 이 Integration을 빌드하는 데 필요한 선행 조건을 확인하세요. 자세한 내용은 선행 조건 을 참고하세요.
  5. 모든 소스 압축 파일을 동일한 폴더 안으로 압축 해제하세요. 자세한 내용은 Unity 프로젝트에서 통합 설치/업그레이드하기 을 참고하세요.
  6. 콘솔 유틸리티를 사용하여 빌드하기 혹은 통합 개발 환경 (Integrated Development Environment, IDE)를 사용하여 빌드하기 이 두 가지 방법 중 하나를 사용하여 빌드 과정을 시작하세요.
  7. 빌드가 완료될 때까지 기다리세요. 빌드 작업이 성공적으로 완료되면 API/Runtime/Plugin 폴더 아래 있는 플러그인과 API 바인딩이 업데이트되거나 이전에 없었을 경우 새로 만들어집니다.

참고 사항

  • 빌드 작업 동안 Build Log 에 있는 로그 메시지를 확인하면 경고, 오류, 중요한 메시지를 모니터링할 수 있습니다.

Integration 을 직접 빌드하는 데 필요한 내용:

플랫폼 | 필요한 컴포넌트
모든 플랫폼
  • Unity. 최신 Unity 버전은 Unity QA - Long Term Support (장기적인 지원) 을 참고해 주세요.
  • 대상 플랫폼과 호환하는 Wwise SDK. 릴리즈 노트 - Wwise Unity 통합 2023.1.1.8417.3007 참고.
  • 대상 플랫폼과 호환하는 플랫폼 SDK. Wwise SDK 도움말 (참고 자료 > 플랫폼 필수 조건 섹션) 참조.
  • Python(파이썬) 3.9.x와 사용자 시스템 실행 경로 안에 Python 실행 폴더.
Android
  • Android SDK: 32비트의 경우 최소 API 14, 64비트의 경우 최소 API 21.
  • Android NDK r17c.
  • Apache(아파치) Ant 1.8.4.

  • Wwise SDK로의 경로에 띄어쓰기가 없어야 합니다.

  • Unity 프로젝트로의 경로에 띄어쓰기가 없어야 합니다.

  • 환경 변수:
    • ANDROID_HOME 은 Android SDK 루트 폴더를 가리켜야 합니다.
    • ANDROID_NDK_HOME 은 Android NDK 루트 폴더를 가리켜야 합니다.
    • NDKROOT 은 Android NDK 루트 폴더를 가리켜야 합니다.
    • ANT_HOME 은 Apache Ant 루트 폴더를 가리켜야 합니다.
iOS
  • Xcode 11 버전 이상.
  • iOS용 Wwise SDK와 이를 가리키는 WWISESDK 환경 변수
Linux
  • Build-essential (sudo apt-get install build-essential)
  • The Wwise SDK for Linux, and a WWISESDK environment variable pointing to it
Mac
  • Xcode 11 or above.
  • Mac용 Wwise SDK와 이를 가리키는 WWISESDK 환경 변수
PS4 | Visual Studio 2017 버전 이상.
Windows | Visual Studio 2017 버전 이상.
Windows Store | Visual Studio 2017 버전 이상.
Xbox One | Visual Studio 2017 버전 이상.

소스 패키지 설치 방법

소스 패키지를 압축 해제하세요. 그런 다음 대상 플랫폼의 소스 패키지와 Wwise SDK 설치만으로 Integration 콘텐츠를 다시 빌드하고 생성하세요. 경우에 따라 Wwise 폴더 안에 있는 압축 해제된 콘텐츠를 Unity 프로젝트의 Asset 폴더 안에 있는 Integration 유니티 패키지와 합칠 수도 있습니다. 하지만 이 경우 Assets 폴더 안에 원치 않는 중간 파일이 생길 수 있습니다. 이 중간 파일은 직접 제거해야 합니다.

설치된 Integration 패키지의 폴더 구조

  • StreamingAssets: 자동 SoundBank 배포에 사용되는 폴더
  • Wwise: 최상위 계층 폴더.
    • API: 애플리케이션에서 사용되는 주요 Integration 파일.
      • Runtime: C++에서 C::로의 바인딩 파일. 이 파일은 네이티브 Wwise SDK의 번역본입니다.
      • Editor: API의 에디터 부분.
      • Plug-ins: 다양한 구성과 디버그 심볼 데이터 베이스가 담긴 Unity 플러그인 라이브러리
        • Platform
          • Architecture: 멀티 아키텍처 플랫폼의 아키텍처에 의해 공유되는 파일.
            • Debug: 플러그인 바이너리의 Debug 버전. 자세한 내용은 Wwise 플러그인 배포 을 참고하세요.
            • Profile: 플러그인 바이너리의 Profile 버전. 자세한 내용은 Wwise 플러그인 배포 을 참고하세요.
            • Release: 플러그인 바이너리의 Release 버전. 자세한 내용은 Wwise 플러그인 배포 을 참고하세요.
            • DSP: Wwise 플러그인 Effect.
    • MonoBehaviour: 커스텀 컴포넌트의 예시이며 직접 사용할 수 있는 Unity 컴포넌트 스크립트.
    • Documentation: Integration에 대한 전체 문서.

설치된 소스 패키지의 폴더 구조.

  • Wwise: 최상위 계층 폴더.
    • AkSoundEngine: Integration을 빌드하는 데 필요한 소스 코드와 IDE 프로젝트. 플랫폼 별로 구성되어 있습니다.
      • Common: 지원하는 모든 플랫폼에 의해 사용되는 소스 코드와 빌드 스크립트.
      • Platform: 대상 플랫폼의 IDE 솔루션 혹은 프로젝트, 소스 코드, 플랫폼 별 빌드 스크립트.
    • Integration/Assets/Wwise/API: 애플리케이션에 의해 사용되는 주요 Integration 파일.
      • Runtime: API 바인딩의 최상위 계층 폴더.
        • Generated: SWIG 바인딩 단계 동안 생성된 API 바인딩 파일.
        • Handwritten: 직접 제작한 API 바인딩 파일.
    • MonoBehaviour: 커스텀 컴포넌트의 예시이며 직접 사용할 수 있는 기본 Unity 컴포넌트 스크립트.

콘솔 유틸리티를 사용하여 빌드하기

Wwise\AkSoundEngine\Common\BuildWwiseUnityIntegration.py 에 있는 빌드 스크립트를 사용하면 명령줄에서 Integration을 빌드할 수 있습니다. 이 기능은 지속적 통합에 유용합니다. 사용자의 현재 작업 중인 파일이 스크립트의 상위 폴더라는 가정 하에 사용법과 예시를 확인하려면 컴퓨터에서 명령 콘솔을 입력하세요.

python BuildWwiseUnityIntegration.py -h

통합 개발 환경 (Integrated Development Environment, IDE)를 사용하여 빌드하기

Wwise Unity 통합 소스 패키지의 다음 부분에 있습니다.

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\YourPlatform

이 솔루션 (혹은 Xcode 프로젝트)는 지원되는 IDE에서 대상 플랫폼의 Integration을 빌드할 수 있게 해줍니다.

Xcode를 사용하여 Mac이나 iOS용으로 빌드하기

명령줄에서 Wwise 통합을 빌드할 경우 WWISESDK 경로가 Xcode에 자동으로 제공됩니다. 이 경로는 환경 변수인 $WWISESDK 에서 설정된 경로나 -w 옵션을 사용하여 빌드 스크립트에 제공된 경로에 따라 결정됩니다. 하지만 Xcode IDE를 사용할 경우 WWISESDK 경로를 반드시 직접 설정해합니다. 수동으로 경로를 설정하려면 Mac이나 iOS용 Xcode 프로젝트를 열고 프로젝트 탐색기에서 AkSoundEngine{platform} 프로젝트를 선택하세요. Build Settings 페이지를 선택하세요. 페이지의 하단에 User-Defined 섹션과 WWISESDK 설정 키가 있습니다. 설정 값을 WWISESDK 경로로 설정해서 Wwise 통합을 빌드하세요 (예: /Users/myUser/Wwise/SDK).

Linux 플랫폼용으로 빌드하기

premake5가 생성한 makefile이 들어 있습니다. 소스에서 Linux 플러그인을 빌드하려면 다음 명령을 터미널에 입력하세요.

  • cd <Integration source location>/AkSoundEngine/Linux

  • make config=<config>

    <config> 가 debug_x64나 profile_x64, release_x64일 경우. 빌드된 플러그인은 <Integration source location>/API/Runtime/Plugins/Linux 안에 배치됩니다.

새로운 라이브러리에 배포하기

생성되는 바이너리는 Wwise\API\Runtime\Plugins\[플랫폼]에서 찾을 수 있습니다. Assets\Wwise 폴더에서 소스를 압축 해제하지 않은 경우 그 폴더에서 프로젝트의 Assets 폴더 안의 상응하는 폴더로 새로운 바이너리를 복사해넣으세요.

내부 정보

통합 코드를 빌드하기 위해 소스를 패키징하기 전에, SWIG를 사용해서 Unity에서 Wwise SDK에 필요한 API 바인딩을 생성합니다. 대부분의 사용자는 Unity에서 Wwise를 사용할 때 SWIG가 전혀 필요하지 않습니다. 변환된 API가 담긴 통합 코드를 빌드하는 Unity 소스를 위한 Wwise에 접근할 수 있는 고급 사용자이더라도 SWIG를 설치하거나 사용할 필요가 없습니다. 유일한 예외 사항으로 사운드 엔진의 변경 사항을 통합하거나 사운드 엔진과 연결하는 C++ 코드를 변경할 경우에는 SWIG가 필요합니다. 이렇게 드문 경우에는 작업을 진행하기 전에 먼저 저희 지원팀에게 연락을 취해주세요.

빌드 과정은 다음 작업을 수행합니다.

  1. Wwise SDK 라이브러리가 Unity 플러그인으로서 하나의 라이브러리로 싸여집니다. 이 라이브러리는 Windows에서는 동적 라이브러리 (.dll)로, Mac에서는 로드 가능한 번들 (.bundle)로, iOS에서는 정적 라이브러리 (.a)로, Android에서는 공유 라이브러리 (.so)로 생성됩니다. 이 라이브러리는 Deployment 폴더 안으로 직접 생성됩니다. 폴더 구조는 Unity 프로젝트에서 통합 설치/업그레이드하기 을 참고하세요.
참고
  • 플랫폼별 정보
  • Build Log
  • 플러그인의 C++ 코드를 변경한 경우 Wwise Integration 패키지를 새로운 버전으로 업데이트/업그레이드 하기


Wwise Unity Integration Documentation: Build Log

Build Log

경고 및 오류 메시지는 Unity Editor 콘솔과 Build Log(빌드 로그)에 표시됩니다. Build Log 파일에는 Integration(통합) 빌드 중 생성된 더 자세한 메시지가 들어 있습니다. Build Log는 다음 위치에 저장됩니다.

UNITY_PROJECT_ROOT\Assets\Wwise\Logs\BuildWwiseUnityIntegration.log

로그 메시지는 다음과 같은 형식으로 표시됩니다.

Time: Message type: Source Code File name (Module name): Line number: Message body

예시:

2013-09-26 09:29:56,490: INFO: BuildWwiseUnityIntegration.py (WindowsBuilder): 91: Building: Windows (Win32, Debug) ...

로그 파일은 누적되며 한 시간 후 새로운 파일로 교체됩니다. 교체 처리 방식을 변경하려면 Wwise Unity 통합 소스 패키지의 다음 파일에서 BuildUtil.CreateLogger() 함수 설정을 변경하세요.

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\Common\AkSoundEngine\Common\BuildUtil.py

더 자세한 정보는 Python logging.handlers module을 참고하세요.

특정 플랫폼에서는 Visual Studio(비주얼 스튜디오)와 같은 IDE에 의해 로그 파일이 추가적으로 생성될 수 있습니다. 추가 파일은 동일한 폴더에서 파일 이름 안에 IDE 라는 키워드를 가질 수 있습니다.


Wwise Unity Integration Documentation: 플러그인의 C++ 코드를 변경한 경우 Wwise Integration 패키지를 새로운 버전으로 업데이트/업그레이드 하기

플러그인의 C++ 코드를 변경한 경우 Wwise Integration 패키지를 새로운 버전으로 업데이트/업그레이드 하기
경고: 권장 사항
  • Unity 마이그레이션 작업은 되돌릴 수 없습니다. 작업을 진행하기 전에 Unity 프로젝트를 백업하세요.
  • Unity 프로젝트가 소스 컨트롤 안에 있을 경우 마이그레이션을 시작하기 전에 Unity 프로젝트 전체를 체크 아웃하세요. 그렇지 않으면 파일을 성공적으로 변경할 수 없기 때문에 마이그레이션이 실패하게 됩니다.
  • Wwise 통합을 설치하기 전에 먼저 Unity 프로젝트가 오류 없이 성공적으로 컴파일할 수 있는 상태인지 확인하세요. (경고 메시지는 괜찮습니다.)

설치 과정은 Unity 프로젝트가 이전의 Wwise Integration 패키지를 이미 담고 있다고 가정합니다. 새로운 설치의 경우 Wwise 통합 패키지 최초 설치 페이지를 참조하세요. 다른 Unity 플러그인과는 달리 Wwise Integration 패키지를 새로운 버전으로 업데이트하려면 이전의 패키지 버전을 설치한 채로 놔두어야 합니다. Launcher가 새로운 기능과 버그 수정 사항을 설치한 후 이전의 Wwise Integration을 새로운 버전으로 마이그레이션합니다.

경고: 새로운 Wwise Integration을 설치하기 전에 이전 버전을 삭제하지 마세요. 삭제할 경우 Wwise 오디오를 게임에 통합해온 모든 작업을 잃게 됩니다.

업그레이드는 세 단계로 실행됩니다. 먼저 Wwise 프로젝트를 사용하고자 하는 새로운 버전으로 업데이트하세요 그런 다음 Unity 프로젝트도 마찬가지로 업그레이드하세요.

Unity 프로젝트를 새로운 Wwise 버전으로 업데이트하기

Audiokinetic 런처를 사용하여 Unity 프로젝트를 새로운 Wwise 버전으로 업데이트하세요.

Wwise 프로젝트를 새로운 버전으로 업데이트하기

  1. Unity에서 사용하고자 하는 새로운 Wwise Integration 버전과 대응하는 Wwise 버전을 실행하세요.
  2. Wwise 프로젝트를 여세요.
  3. Wwise 프로젝트를 새로운 버전으로 업데이트하라는 메시지가 뜨면 'Yes'라고 답하세요.
  4. 업데이트가 끝나면 Unity 프로젝트를 새로운 Wwise 버전으로 업데이트한 후에 사용할 수 있게 Wwise SoundBank를 재생성하세요.
  5. 생성된 SoundBank를 Unity 프로젝트의 StreamingAssets 폴더로 복사하세요.

C++ 코드 변경 사항 업데이트하기

  1. 업데이트된 Wwise SDK를 원하는 모든 플랫폼 용으로 작업 컴퓨터에 설치하세요.
  2. Unity 프로젝트에 복사된 원하는 모든 플랫폼에 대한 Unity Integration Source Code (유니티 통합 소스 코드) 압축 파일을 찾으세요.
  3. 다운로드된 모든 Unity Integration Source Code 패키지를 동일한 폴더로 압축 해제하세요.
  4. Unity Integration Source Code에 만든 변경 사항을 업데이트된 위치로 병합하세요.
  5. 업데이트되고 병합된 통합 소스 코드를 컴파일하세요.


Wwise Unity Integration Documentation: Enter Play Mode 작동 방식

Enter Play Mode 작동 방식

Enter Play Mode Settings를 사용할 때 Sound Engine 초기화 작동 방식이 변경됩니다. 관련 설정은 'Reload Domain' 및 Unity Editor Settings 조정하기 'Load Sound Engine in Edit Mode'입니다.

Sound Engine 초기화
 | Reload Domain 켜짐 | Reload Domain 꺼짐
Load Sound Engine in Edit Mode 켜짐 | Sound Engine이 Edit Mode와 Play Mode에 들어가면 초기화되고 Edit Mode와 Play MOde를 종료하면 종료됩니다. | Sound Engine이 Edit Mode 또는 Play Mode에 들어갈 때 초기화되며 종료되지 않습니다.
Load Sound Engine in Edit Mode 꺼짐 | Sound Engine이 Play Mode에 진입하면 초기화되고 Play Mode를 종료하면 종료됩니다. | Sound Engine이 Play Mode에 진입하면 초기화되고 Play Mode를 종료하면 종료됩니다.

모든 AkGameObj 는 Sound Engine이 비활성화되면 등록이 취소되고 필요할 때 등록됩니다.

참고:
  • Play Mode를 여러 번 시작하고 종료하는 Authoring에서 Profiling Session을 지속시키려면 Reload Domain이 꺼져 있어야 하고 Load Sound Engine in Edit Mode가 켜져 있어야 합니다.
  • 씬 재로딩을 건너뛰고 AkType 에서 'Awake' 트리거를 사용하면 편집기와 빌드된 게임 간에 불일치가 발생합니다. Reload Scene이 꺼져 있을 때는 'Start' 트리거를 사용하는 것이 좋습니다.

자세한 내용은 설정 가능한 Enter Play Mode를 참고하세요.


Wwise Unity Integration Documentation: API 변경 및 제한 사항

API 변경 및 제한 사항

네이티브 Wwise SDK에서 다음 기능과 함수는 지원하지 않거나 Integration에서 작동 방식이 변경되었습니다 (최근 변경 사항부터 먼저 설명).

  • UnloadBank() 가 더 이상 단일 인자의 오버로드된 버전을 사용하지 않습니다. 메모리 위치 포인터가 두 번째 인자로 제공되어야 합니다.
  • Windows(윈도우즈) 버전의 GetGameObjectFromPlayingID() 는 Windows 32비트와 64비트에서 모두 32비트의 GameObject ID를 반환합니다 (잘라내기).
  • PostEvent() 와 GameObject에 관련된 API가 이제 전역적으로 영향을 미치는 GameObject 입력 인자로 null 을 받습니다.
  • PostEvent() 콜백이 병렬화되었으며 오디오 스레드에서 호출되는 대신 다음 게임 프레임이 시작될 떄 호출됩니다. 그렇기 때문에 동기화 메커니즘이 필요 없습니다.
  • AK::Monitoring::SetLocalOutput() 가 AkCallbackManager.SetMonitoringCallback() 으로 교체되었습니다.
  • AK::SoundEngine::SetPosition() 이 AkSoundEngine.SetObjectPosition() 으로 교체되었습니다.
  • 디스크에서 레벨 데이터를 로드하는 동시에 사운드 스트리밍을 처리해서는 안됩니다.
  • 일부 AK::SoundEngine::DynamicSequence API 함수가 Unity API 바인딩을 통해 더욱 명확한 이름으로 변경되었습니다. 이 부분은 SWIG에 의해 네임스페이스가 균일화되는 부작용을 보완하기 위한 해결책입니다. 예를 들어 이전에는 API 생성으로 AK::SoundEngine::DynamicSequence::Open() 이 AkSoundEngine.Open() 으로 되었습니다. 이제 API 바인딩으로 AkSoundEngine.DynamicSequenceOpen() 이라는 이름으로 변경되었습니다.
  • C++ 연산자 오버로드는 Unity 스크립팅 언어에서 함수로 이름이 재지정되었습니다. 예를 들어 AkArray::operator[] 는 AkPlaylistArray.ItemAtIndex(uint uiIndex) 가 됩니다. 이 작업은 SWIG가 C++ 연산자 오버로드를 처리하도록 설계된 방식을 따라 처리됩니다.
  • 지원하지 않는 API와 컴포넌트:
    • iOS 오디오 입력 콜백 API
    • AkSpeakerVolumeMatrixCallbackInfo
    • AkSpeakerVolumeMatrixBusCallbackInfo
    • AkBusCallbackFunc
    • AK::SoundEngine::RegisterBusVolumeCallback
    • AK::SoundEngine::RegisterCodec
    • AK::SoundEngine::RegisterGlobalCallback
    • AK::SoundEngine::RegisterPlugin
    • AK::SoundEngine::Query::AkGameObjectsList
    • AK::SoundEngine::Query::GetActiveGameObjects()
    • AK::SoundEngine::Query::GameObjDst
    • AK::SoundEngine::Query::AkRadiusList
    • AK::SoundEngine::Query::GetMaxRadius(AkRadiusList& io_RadiusList)
    • 콜백이나 이벤트 이름을 받는 AK::SoundEngine::DynamicDialogue::ResolveDialogueEvent 의 모든 변형
참고
  • 플랫폼별 정보.


Wwise Unity Integration Documentation: 플랫폼별 정보

플랫폼별 정보

다음 페이지는 각 플랫폼별 정보를 제공합니다.

Android

  • Android 전용 정보

커스텀 플랫폼

  • Unity에서 Wwise 커스텀 플랫폼 사용하기


Wwise Unity Integration Documentation: Android 전용 정보

Android 전용 정보

Android용으로 빌드하기

Android(안드로이드)용 SoundBank는 APK 파일 안에 들어 있으며 LoadBank() API를 통해 직접 접근할 수 있습니다. StreamingAssets 폴더 아래 배치된 SoundBank는 Unity 프로젝트를 빌드할 때 APK의 Assets 폴더 안에 들어갑니다. Low-Level IO는 APK에서 SoundBank에 확실하게 접근합니다.

또한 Low-Level IO는 SD 카드와 같이 Android 파일 시스템에 있는 SoundBank 파일에 접근할 수 있습니다. 원본 파일 시스템에 접근하고자 할 경우 AkSoundEngine.AddBasePath(YourPath) 를 호출해야 합니다. 이 새로운 경로는 기본 APK 파일보다 우선시됩니다. 파일이 외부 경로와 똑같은 이름을 가지며 APK 안에 있을 경우 외부 경로가 사용됩니다. APK가 빌드된 후 오디오 콘텐츠에 DLC나 패치를 추가할 경우 외부 파일로 접근하는 것이 유용할 수 있습니다.

백그라운드 모드

앱이 백그라운드로 전환될 경우 AkSoundEngine.Suspend() 를 호출할 것을 권장합니다. 앱이 포그라운드로 돌아올 경우 AkSoundEngine.WakeupFromSuspend() 를 통해 사운드를 복구하세요. 현재 이 기능은 AkInitializer 에 구현되어 있지만 필요에 따라 게임에서 알맞은 부분으로 옮길 수 있습니다.

배경 음악 뮤트하기

Wwise Authoring에는 Audio Bus에서 배경 음악을 뮤트할 수 있는 옵션이 있습니다. 이 기능을 사용하면 플레이어 음악이 시작될 때 게임 음악을 뮤트할 수 있습니다 (플레이어가 소유한 음악으로 교체하기 참고). 그러나 Android에서 이 옵션을 활성화한 채 Unity Audio를 활성화하면 버스를 통과하는 음악이 항상 뮤트됩니다.

이 두 설정을 조합하면 호환이 되지 않으므로 Wwise 설정을 이용해 배경 음악을 뮤트할 것인지 아니면 Unity Audio를 활성화할 것인지를 결정해야 합니다.

OBB 파일 사용하기

OBB와 Wwise IO 개요

Android(안드로이드) 플랫폼의 경우 Unity 옵션 Player Settings > Publishing Settings > Split Application Binary가 설정되어 있을 때 APK Expansion Files(확장 파일) 은 프로젝트 에셋을 번들로 묶습니다. 이렇게 하면 SoundBank를 포함한 StreamingAssets 폴더가 담긴 zip 파일이 .obb 확장자로 생성됩니다. 기본 Android SoundBank 로딩 지원은 SoundBank가 APK 파일이나 OBB 파일에 있다고 가정합니다.

OBB 파일을 자체적으로 외부에서 생성할 경우 AkSoundEngine.SetBasePath에 주어지는 내부 경로가 반드시 OBB에 있는 경로와 같아야 합니다. 기본 I/O 시스템이 작동하려면 반드시 OBB 파일을 압축하거나 암호화하지 않아야 합니다. 그렇지 않으면 영구 데이터 경로에서 OBB를 압축 해제해야 합니다. 즉시 압축을 해제하기에는 CPU 비용이 너무 큽니다.

메모리에서 뱅크 로드하기

대신 메모리 내부 뱅크 로딩을 사용할 수 있습니다. AkMemBankLoader.cs에 예시가 제공되어 있습니다. 이 스크립트는 씬이 시작될 때 지정된 SoundBank 로딩을 시도하며 씬이 파괴될 때 언로딩을 시도합니다. 이 예시를 사용하려면 다음 사항을 변경해야 합니다.

  1. SoundBank를 로드해야 하는 모든 게임 오브젝트에 이 스크립트를 컴포넌트로 추가하세요.
  2. Inspector(인스펙터)에서 SoundBank의 파일 이름을 스크립트 컴포넌트의 Bank Name 입력란에 입력하세요.
  3. SoundBank가 현지화되는 경우 Inspector에서 Is Localized Bank 옵션을 선택하세요. AkInitializer.cs 에서 정의한 전역 언어를 사용합니다.
  4. 다른 모든 SoundBank 로딩 메소드를 비활성화하고 씬을 저장하세요.

AkMemBankLoader.LoadNonLocalizedBank() 와 AkMemBankLoader LoadLocalizedBank() 이 두 가지 메소드는 현지화되지 않거나 현지화 된 SoundBank의 경우 코드에서 직접 호출할 수 있습니다.

제한 사항

  • 내부 메모리 관련 메소드는 스트리밍되는 SoundBank를 로드할 수 없습니다. 더 낫지만 어려운 방법으로, 저수준 IO 후크를 구현하여 zip 파일을 압축하면 스트리밍되는 SoundBank와 그렇지 않은 SoundBank를 모두 지원할 수 있습니다. 여기에 대한 예시는 후에 제공하도록 하겠습니다. 사용자는 이러한 후크를 자유롭게 구현하고 Integration을 다시 빌드할 수 있습니다.
  • 간편함을 위해 이 예시 스크립트는 스크립트 컴포넌트 당 하나의 SoundBank만 로드하지만, SoundBank의 목록을 일괄적으로 로드하도록 모듬 기반 버전으로 스크립트를 확장할 수 있습니다.
  • 이 예시는 가장 간단한 내부 메모리 SoundBank 로딩 API만 래핑합니다. 필요할 경우 쉽게 추가할 수 있는 또다른 콜백 기반 버전이 있습니다. API 바인딩은 이미 Integration에서 사용할 수 있습니다.
참고
  • Wwise와 Unity에서 DLC 만들기
  • Android 릴리즈 노트


Wwise Unity Integration Documentation: Android 릴리즈 노트

Android 릴리즈 노트

다음 페이지는 Android에 관련된 Wwise 변경 사항에 대한 정보를 제공합니다. 다음 목록에 표시되지 않은 Wwise 버전은 해당 버전에서 Android에 관련하여 변경된 내용이 없습니다.

Android 2022.1.6
Android 2022.1.2
Android 2022.1.1
Android 2021.1.12
Android 2021.1.11
Android 2021.1.8
Android 2021.1.4
Android 2021.1
Android 2019.2.10
Android 2019.1.11


Wwise Unity Integration Documentation: Android 2022.1.6

Android 2022.1.6

다음 섹션 목록은 Wwise 2022.1.6에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 버그 수정

버그 수정

  • WG-53168 수정됨: Android의 Unity에 libstdc++.so에 대한 런타임 의존성이 있음.


Wwise Unity Integration Documentation: Android 2022.1.2

Android 2022.1.2

다음 섹션 목록은 Wwise 2022.1.2에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63447 수정됨: Event 콜백 정보 구조체에 32 비트 Android 플랫폼에서 유효하지 않은 정보가 포함돼있음.

커뮤니티에 보고된 버그 수정

  • WG-62961 수정됨: 일부 장치의 스피커에서 Wwise에서 나오는 사운드가 다른 사운드보다 작게 들림. 이 기기들에서 낮은 레이턴시 오디오 재생을 비활성화하는 새로운 플랫폼 옵션이 추가되었습니다.


Wwise Unity Integration Documentation: Android 2022.1.1

Android 2022.1.1

다음 섹션 목록은 Wwise 2022.1.1에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 커뮤니티에 보고된 버그 수정

커뮤니티에 보고된 버그 수정

  • WG-54798 수정됨: Motion 플러그인을 사용할 때 발생하는 크래시.


Wwise Unity Integration Documentation: Android 2021.1.12

Android 2021.1.12

다음 섹션 목록은 Wwise 2021.1.12에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-63447 수정됨: Event 콜백 정보 구조체에 32 비트 Android 플랫폼에서 유효하지 않은 정보가 포함돼있음.

커뮤니티에 보고된 버그 수정

  • WG-62961 수정됨: 일부 장치의 스피커에서 Wwise에서 나오는 사운드가 다른 사운드보다 작게 들림. 이 기기들에서 낮은 레이턴시 오디오 재생을 비활성화하는 새로운 플랫폼 옵션이 추가되었습니다.


Wwise Unity Integration Documentation: Android 2021.1.11

Android 2021.1.11

다음 섹션 목록은 Wwise 2021.1.11에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 커뮤니티에 보고된 버그 수정

커뮤니티에 보고된 버그 수정

  • WG-54798 수정됨: Motion 플러그인을 사용할 때 발생하는 크래시.


Wwise Unity Integration Documentation: Android 2021.1.8

Android 2021.1.8

다음 섹션 목록은 Wwise 2021.1.8에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 버그 수정
  • 커뮤니티에 보고된 버그 수정

버그 수정

  • WG-55735 수정됨: Unity Demo Game의 모바일 카메라에서 Spatial Audio Listener가 누락

커뮤니티에 보고된 버그 수정

  • WG-59378 수정됨: Spatial Audio 포털이 작동하지 않음


Wwise Unity Integration Documentation: Android 2021.1.4

Android 2021.1.4

다음 섹션 목록은 Wwise 2021.1.4에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 커뮤니티에 보고된 버그 수정

커뮤니티에 보고된 버그 수정

  • WG-55799 수정됨: 로드 작업이 실패되었는지 확인하기 위해 AsyncHandle 상태가 확인되지 않음.


Wwise Unity Integration Documentation: Android 2021.1

Android 2021.1

다음 섹션 목록은 Wwise 2021.1에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 버그 수정

버그 수정

  • WG-51601 Timeline에서 StopEventAtTheEndOfClip 옵션에 관련된 재생 오류가 일어남.
  • WG-52936 Timeline에서 스크러빙할 때 재생 오류가 일어남.


Wwise Unity Integration Documentation: Android 2019.2.10

Android 2019.2.10

다음 섹션 목록은 Wwise 2019.2.10에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 기타 수정 사항
  • 커뮤니티에 보고된 버그 수정

기타 수정 사항

  • WG-53109 libstdc++에서 Android 공유 라이브러리로부터의 런타임 의존성을 제거함.

커뮤니티에 보고된 버그 수정

  • WG-51601 수정됨: Timeline에서 StopEventAtTheEndOfClip 옵션에 관련된 재생 오류가 일어남.


Wwise Unity Integration Documentation: Android 2019.1.11

Android 2019.1.11

다음 섹션 목록은 Wwise 2019.1.11에서 Android에 관한 변경 사항을 열거 및 설명합니다.

  • 기타 수정 사항

기타 수정 사항

  • WG-53109 stdlibc++에서 Android 공유 라이브러리로부터의 런타임 의존성을 제거함.


Wwise Unity Integration Documentation: Unity에서 Wwise 커스텀 플랫폼 사용하기

Unity에서 Wwise 커스텀 플랫폼 사용하기

기본적으로 Wwise Unity 통합은 연결된 Wwise 프로젝트에서 정의한 플랫폼이 모두 기본 이름을 가졌다고 가정합니다. 플랫폼에 새로운 이름을 지정하거나 기반 플랫폼의 여러 가지 커스텀 플랫폼을 정의하려면 C# 스크립트가 필요합니다.

참고: 이 페이지는 SoundBank가 생성되는 하위 폴더의 이름이 플랫폼의 이름과 같다고 가정합니다. 폴더의 이름이 다를 경우 GetPlatformName 메소드가 반환하는 문자열을 게임의 SoundBank 하위 폴더의 이름으로 사용하게 됩니다.

플랫폼 정의하기

기본 플랫폼을 결정하는 스크립트는 <UNITY_PROJECT_ROOT>/Assets/Wwise/API/Runtime/Handwritten/Common/AkBasePathGetter.cs 파일 안에 있습니다. GetPlatformName() 메소드에서 볼 수 있듯이 모든 플랫폼의 기본 이름은 이 함수에 의해 반환됩니다. 사용자가 지정한 플랫폼 이름을 사용하려면 GetCustomPlatformName 델리게이트에 메소드를 등록해야 합니다. 델리게이트를 등록하기 위해서 RuntimeInitializeOnLoadMethod 속성을 사용하여 고정적 메소드를 사용할 것을 권장합니다.

예시

이 예시는 iOS 플랫폼의 경우만 다룹니다. 예를 들어 iOS 기반 플랫폼인 아이팟, 아이폰, 아이패드용으로 세 가지 커스텀 플랫폼을 정의하려 한다고 가정합시다.

  1. 먼저 Wwise 프로젝트의 Platform Manager에서 'iPod', 'iPhone', 'iPad' 이 세 가지 플랫폼을 추가하세요. (Wwise의 Platform Manager에 대한 더 많은 정보는 Wwise 설명서에서 Wwise 도움말 > 프로젝트 시작하기 > 플랫폼 관리하기 섹션을 참고하세요.
  2. 그런 다음 Unity에서 GetCustomPlatformName 델리게이트에 등록하는 C# 스크립트를 생성하세요. 이 파일의 내용은 다음과 같아야 합니다:
    public partial class MyCustomBasePathGetter
    {
    [UnityEngine.RuntimeInitializeOnLoadMethod(UnityEngine.RuntimeInitializeLoadType.BeforeSceneLoad)]
    static void RegisterCustomPlatformName()
    {
    AkBasePathGetter.GetCustomPlatformName = GetCustomPlatformName;
    }
    static partial void GetCustomPlatformName(ref string platformName)
    {
    #if UNTIY_IOS
    switch(UnityEngine.iOS.Device.generation)
    {
    case UnityEngine.iOS.DeviceGeneration.iPodTouch1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch5Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouchUnknown:
    platformName = "iPod";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPad1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir1:
    case UnityEngine.iOS.DeviceGeneration.iPadMini2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir2:
    case UnityEngine.iOS.DeviceGeneration.iPadUnknown:
    platformName = "iPad";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPhone:
    case UnityEngine.iOS.DeviceGeneration.iPhone3G:
    case UnityEngine.iOS.DeviceGeneration.iPhone3GS:
    case UnityEngine.iOS.DeviceGeneration.iPhone4:
    case UnityEngine.iOS.DeviceGeneration.iPhone4S:
    case UnityEngine.iOS.DeviceGeneration.iPhone5:
    case UnityEngine.iOS.DeviceGeneration.iPhone5C:
    case UnityEngine.iOS.DeviceGeneration.iPhone5S:
    case UnityEngine.iOS.DeviceGeneration.iPhone6:
    case UnityEngine.iOS.DeviceGeneration.iPhone6Plus:
    case UnityEngine.iOS.DeviceGeneration.iPhoneUnknown:
    default:
    platformName = "iPhone";
    break;
    }
    #endif
    }
    }
    참고: platformName을 그대로 놔둘 경우 현재 Unity에서 활성화된 플랫폼의 기본 플랫폼 이름이 사용됩니다.
  3. (a) AkBuildPreprocessor를 확장하는 C# 스크립트를 만들거나 (b) AkBuildPreprocessor 안에 있는 기능을 사용하는 C# 스크립트를 만드세요. 이 파일의 내용은 다음과 같습니다.
    public class WwiseIOSBuildPreprocessor : IPreprocessBuild, IPostprocessBuild
    {
    public int callbackOrder { get { return 0; } }
    string iPodDestinationSoundBankFolder = string.Empty;
    string iPadDestinationSoundBankFolder = string.Empty;
    string iPhoneDestinationSoundBankFolder = string.Empty;
    public void OnPreprocessBuild(BuildTarget target, string path)
    {
    if (target == BuildTarget.iOS)
    {
    AkBuildPreprocessor.CopySoundbanks(true, "iPod", iPodDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPad", iPadDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPhone", iPhoneDestinationSoundBankFolder);
    }
    }
    public void OnPostprocessBuild(BuildTarget target, string path)
    {
    DeleteSoundbanks(iPodDestinationSoundBankFolder);
    DeleteSoundbanks(iPadDestinationSoundBankFolder);
    DeleteSoundbanks(iPhoneDestinationSoundBankFolder);
    }
    }
  4. 또는 Wwise에서 'iPhone", 'iPod', 'iPad' 이 세 가지 플랫폼의 SoundBank를 모두 생성한 후 폴더를 UNITY_PROJECT_ROOT/Assets/StreamingAssets/Audio/GeneratedSoundBanks로 복사하세요.
  5. Unity에서 iOS 플랫폼용으로 게임을 빌드하세요.
  6. 이제 장치 유형에 따라 서로 다른 SoundBank가 사용됩니다.


Wwise Unity Integration Documentation: 데모 게임

데모 게임

Wwise Unity 통합이 담긴 데모 씬은 Audiokinetic 런처 Unity 페이지에서 문맥형 메뉴의 'Recent Unity Projects'라는 제목에서 다운로드할 수 있습니다. Unity의 표준 에셋만을 사용하여 만든 이 간단한 씬들은 Integration의 몇몇 기본 기능에 대한 사용 방법을 보여줍니다.

설치

Wwise Demo Game은 독립형 프로젝트입니다. Audiokinetic 런처에서 다운로드하실 수 있습니다. 이 프로젝트를 게임에서 기본으로 사용해서는 안됩니다. Wwise를 게임에 사용하려면 Audiokinetic 런처를 사용해서 새로운 Unity 프로젝트에 Wwise를 통합하세요.

참고:
  • 생성된 SoundBank가 패키지 안에 들어 있습니다.
  • 씬에 관련된 Wwise Project는 <DEMO_SCENE_ROOT>/WwiseProject 아래에서 찾을 수 있습니다. Wwise 프로젝트를 게임의 Assets 폴더 안에 놔두지 않는 것이 좋습니다. 하지만 이 Demo의 경우 패키징을 위해 그대로 놔두어야 합니다.

배포

Wwise Demo Game은 Unity Editor에서 Wwise Unity 통합을 미리 살펴보며 사용 방법을 보여주기 위해 제작되었습니다.

Wwise Demo Game의 씬을 게임 콘솔이나 모바일 장치에 배포하려면 다음 단계를 따라합니다.

  1. Launcher의 Unity 탭 안에서 Wwise Demo Game Unity Project에 Modify Wwise in Project... 옵션을 선택하세요.
    1. Launcher의 Unity 통합 페이지가 열립니다.
  2. 원하는 Deployment Platform(배포 플랫폼)을 추가하고 Modify(변경)를 클릭하세요.
  3. 업데이트된 버전의 프로젝트를 Unity에서 열어봅니다.
  4. 해당 플랫폼용 SoundBank를 생성하세요.
  5. Generated SoundBank(생성된 사운드뱅크) 폴더를 StreamingAssets/Audio 폴더로 복사하세요.
  6. Unity에서 원하는 플랫폼으로 씬을 빌드한 후 장치에 배포하세요.

Unity Demo Game에는 두 개의 튜토리얼이 있습니다.

  • Wwise Demo 씬
  • Unity에서의 Spatial Audio


Wwise Unity Integration Documentation: Wwise Demo 씬

Wwise Demo 씬

이 1인칭 3D 맵은 경로를 따라 '스테이션(station)'을 포함합니다. 각 스테이션마다 옆에 작은 설명이 적혀 있습니다. 스테이션의 에셋이 씬 계층 구조 안에 들어가 있어서 참조 하기가 쉽습니다.

Footsteps demo(발자국 소리 데모)

첫 번째 스테이션과 길(footpath)은 스크립트 사용과 볼륨 트리거를 통해 발자국 소리 시스템의 제작 방법을 보여줍니다.

Wwise Project에서 발자국 소리와 관련해서 권장하는 방법인, 각 표면 유형에 따른 Random 컨테이너를 Switch Container 안에 넣어서 구현되었습니다. 발자국 소리는 Footstep 이벤트를 사용하여 보낼 수 있으며 표면 머터리얼은 'Footstep_material' Switch Group을 통해 제어됩니다.

씬의 지형은 잔디, 자갈, 나무, 흙 이렇게 네 가지의 다른 텍스처로 칠해져있습니다. 여러 다른 표면 유형 위로 걸어다니면 발자국 소리가 알맞게 바뀝니다.

이 작업을 위해서 각 구역에 Box Collider가 배치되었습니다. Footstep_Material 스위치는 Wwise Picker Window에서 Box Collider로 Switch Value를 드래그하여 쉽게 설정할 수 있습니다. 콜라이더 안으로 들어갈 때 First Person Controller에 스위치를 설정하려면 'AkTriggerEnter' 트리거에 Ak Switch 스크립트를 트리거해야 하며 'Use Other Object' 체크 상자가 활성화되어야 합니다 (Inspector창에서 보이는대로).

플레이어가 이동하면 0.3초마다 Footstep 이벤트를 보내는 아주 기초적인 발자국 소리 스크립트가 구현되어 있습니다. 이 스크립트는 First Person Controller에 연결되어 있습니다. 이는 스크립트를 통해 Wwise SoundEngine에 이벤트를 보내는 방법을 보여줍니다.

Subtitle demo (자막 데모)

이 스테이션은 Unity에서 커스텀 이벤트 트리거를 만드는 방법과 이벤트 콜백을 사용하는 방법을 설명합니다.

간단한 버튼 스크립트는 플레이어가 버튼에 충분히 가까울 때 실행되는 대리자(delegate)가 포함되어 있으며 키보드나 컨트롤러로 키를 누를 수 있습니다. 또 다른 스크립트인 AkTriggerButtonPress 는 스스로 이 대리자에 등록하며 상위 클래스인 AkTriggerBase 에서 triggerDelegate 를 호출합니다. AkTriggerBase 로부터 상속받으면 커스텀 트리거가 Wwise Component Inspector 창의 'trigger' 목록에 표시됩니다 (예를 들어 버튼에 연결된 Ak Ambient). 커스텀 트리거에 대한 더 많은 정보는 Wwise 이벤트에 새로운 트리거 추가하기 를 참조하세요.

해당 이벤트는 WAV 마커를 담은 사운드 파일을 재생합니다. 이벤트에 연결된 마커 콜백을 등록하면 패널에서 자막을 업데이트할 수 있습니다. 그렇게 하기 위해서 Ak Ambient의 인스펙터에서 'Use Callback' 옵션이 선택되어 있습니다. 그런 다음 스크립트 ( SubtitleDemo.cs ) 를 담은 GameObject ( SubtitleSign ) 가 'Game Object' 상자로 드래그되었습니다. 콜백이 트리거될 때 실행하기 위해서 Callback Function (MarkerCallback) 의 이름을 입력했으며 'Marker'가 Callback Flags로 선택되었습니다. SubtitleDemo 의 코드를 보면 Callback 함수가 MarkerCallback 의 uIdentifier 입력란을 인덱스로 사용하여 미리 정의된 문자열 배열에서 자막을 읽는 것을 볼 수 있습니다. 콜백에 대한 더 많은 정보는 인스펙터에서 AkAmbient 사용하기 를 참조하세요.

Environment demo(환경 데모)

이 스테이션은 씬의 구역 안에서 효과를 적용하는 방법을 보여줍니다. 두 개의 동굴은 AuxBus가 추가된 (Wwise Picker 창에서 드래그됨) EnvironmentZone (여기서도 Box Collider가 트리거의 역할을 합니다)을 담고 있습니다.

Wwise에서 두 개의 Auxiliary Bus가 생성되었으며 각 버스가 서로 다른 효과를 담고 있습니다. 그리고 발자국 소리와 Little Sequence에 'Use game-defined Auxiliary sends'가 선택되어 있습니다.

EnvironmentZone 안에서 Wwise 이벤트를 전송하면 사운드가 구역에 연결된 AuxBus로 라우팅됩니다.

또한 이 스테이션은 Environment Portal(환경 포털) 컴포넌트를 보여줍니다. 이 포털은 두 환경 간에 공간을 전환하도록 해줍니다. 이 예시에서는 세 개의 버튼을 사용하여 Environment Portal이 Auxiliary Bus의 믹싱을 변경하는 방법을 시연합니다.

환경 포털을 만들려면 먼저 한 축에서 두 개의 Ak Environment와 접촉하는 Box Collider를 만드세요 (이 예시에서 포털은 'z' 축에서 Red 구역과 Blue 구역이 접촉합니다). 그런 다음 Ak Environment Portal 컴포넌트를 추가하고 알맞은 축을 선택하세요. 조합될 두 가지 환경이 자동으로 채워집니다.

Environment와 Environment Portal에 대한 더 많은 정보는 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기 을 참고하세요.

Timeline Demo(타임라인 데모)

이 스테이션은 Unity의 Timeline에서 AkEventTrack과 AkRTPCTrack의 사용을 보여줍니다. 여기에는 두 개의 큐브가 있으며 버튼을 누르면 서로를 향해 애니메이션해서 부딪힌 후 중단됩니다.

Timeline을 살펴보려면 Window->Timeline을 선택하세요. 그런 다음 Hierarchy에서 TimelineDemo 오브젝트를 펼친 후 Timeline Demo Button 오브젝트를 펼치세요. Button 오브젝트를 선택하세요. Timeline 에디터가 큐브의 애니메이션과 Wwise Event를 제어하는 Timeline을 보여줍니다. Timeline은 Button 오브젝트의 Playable Director 컴포넌트에 의해 제어됩니다.

Timeline에는 각 큐브 당 하나씩 총 두 개의 애니메이션 트랙이 있습니다. 이 트랙은 시간에 따라 각 큐브의 z 위치를 애니메이션하는 데 사용됩니다. 또한 Timeline에는 각각 흰색과 빨간색 탭으로 표시된 AkEventTrack과 AkRTPCTrack이 있습니다. AkEventTrack에는 두 가지 AkEventPlayable 클립이 있습니다. 첫 번째 클립은 PlayCubeMovement Wwise Event를 트리거하며 두 번째 트리거는 PlayImpact Wwise Event를 트리거합니다. 이 Wwise Event의 이름은 클립 안에 표시됩니다. 이름이 올바르게 표시되도록 하려면 Timeline 에디터 뷰의 크기를 늘이거나 줌 인해야 할 수도 있습니다. PlayCubeMovement Wwise Event는 사인파(sine wave) 음원을 재생하며 RTPC로 피치가 변경됩니다. 이 RTPC의 이름은 CubeAcceleration입니다. AkRTPCTrack은 큐브가 서로를 향해 이동하면서 시간에 따라 이 RTPC의 값을 늘립니다. 이렇게 RTPC의 값이 증가하면 사인파(sine wave)의 피치가 올라가서 각 큐브가 서로를 향해 움직이는 가속도를 표시하는 간단한 효과음이 생성됩니다.

또한 이 스테이션은 Motion(모션) 기능을 보여줍니다. 플레이어 계층 구조에 'Motion listener'라는 게임 오브젝트가 있습니다. 이 게임 오브젝트는 지원 플랫폼에서 Motion 장치의 출력을 설정합니다. 출력은 데이터를 수신하기 위해서 리스너가 필요합니다. 그렇기 때문에 Motion 리스너에는 Ak Game Object와 Ak Audio Listener도 있습니다. 큐브 충돌에서 Motion 효과를 활성화하려면 두 가지 중요한 작업이 실행되어야 합니다. 먼저 충돌음이 Wwise 프로젝트의 Wwise Motion ShareSet를 통해 출력 버스로 라우팅되어야 합니다. 두 번째로 Motion 출력에 사용되는 리스너가 충돌 이벤트를 전송하는 이미터의 리스너로 추가되어야 합니다. 출력을 추가하는 방법에 대한 예제로 AkMotionListener 스크립트를 확인하세요.

참고: 안드로이드에서 Motion 기능을 지원하려면 애플리케이션의 매니페스트(manifest)에 진동 퍼미션이 들어있어야 합니다. Unity는 애플리케이션의 내용물에 따라 매니페스트를 자동으로 생성합니다. Handheld.Vibrate() 의 호출을 추가하면 매니페스트에 원하는 퍼미션이 추가됩니다.

Timeline 통합에 대한 더 많은 정보는 Wwise Timeline 통합 을 참고하세요.


Wwise Unity Integration Documentation: Unity에서의 Spatial Audio

Unity에서의 Spatial Audio

이 단원은 Unity 통합에서 Spatial Audio 기능의 사용에 대한 개요를 제공합니다. 다음과 같이 나누어져 있습니다.

  • 이 튜토리얼을 시작하기 전에 따라야 할 준비 페이지:
    • Spatial Audio 튜토리얼 준비
  • 두 가지 튜토리얼:
    • 표면 리플렉터 튜토리얼
    • Room과 Portal 튜토리얼
  • 그리고 기타 공간 음향 기능을 다루는 추가 페이지:
    • Spatial Audio 추가 기능들
    • 방해와 차단
참고: Wwise Reflect 플러그인을 사용하여 섹션을 완료하려면 알맞은 라이선스가 필요합니다.
참고
  • 공간 음향 컴포넌트
  • 공간 음향 SDK 설명서


Wwise Unity Integration Documentation: Spatial Audio 튜토리얼 준비

Spatial Audio 튜토리얼 준비

Spatial Audio 튜토리얼을 성공적으로 완료하려면 그전에 먼저 다음 단계를 반드시 따라해 주셔야 합니다:

  • 1. Unity 프로젝트 만들기
  • 2. Wwise 프로젝트 준비
  • 3. Unity 프로젝트 준비
  • 4. 셋업 검토하기
참고: 처음부터 새로운 프로젝트를 시작하지 않고 싶으시다면 Audiokinetic 런처에서 데모 게임 Unity Demo Game을 다운로드할 수 있습니다. 이 데모 씬에는 SpatialAudioTutorial이라는 씬과 튜토리얼의 모든 단계가 들어 있습니다.

1. Unity 프로젝트 만들기

최신 버전의 Wwise와 Unity를 사용하여 아래 있는 단계를 실행해서 작업 환경을 구축하세요.

  1. Unity를 시작하고 새로운 프로젝트를 만드세요.
  2. Unity를 닫으세요.
  3. Audiokinetic 런처를 시작하고 Wwise를 Unity 프로젝트에 통합하세요.

2. Wwise 프로젝트 준비

튜토리얼에서는 Sound SFX, 이를 재생할 Event, 그리고 SoundBank가 필요합니다.

  1. Launcher를 통해 Wwise에서 프로젝트를 여세요.
  2. Actor Mixer Hierarchy의 Default Work Unit에 Sound SFX를 추가하세요.
    1. 여기에 사운드를 가져오세요.
    2. Sound Property Editor의
      1. General Settings 탭에서 Use game-defined auxiliary sends를 활성화하세요.

        Sound Property Editor General Settings tab
      2. Positioning 탭에서 Listener Relative Routing을 활성화하고 3D Spatialization에서 Position + Orientation을 선택하세요. 알맞은 Max Distance로 Attenuation을 추가하세요.

        Sound Property Editor Positioning tab
  3. Actor-Mixer Hierarchy 안에서 Sound SFX를 우클릭한 후 New Event > Play 를 선택하세요.

    Event Editor
  4. SoundBank 레이아웃으로 전환하고 (단축키 F7) 새로운 SoundBank를 추가하세요. 새로운 SoundBank로 Event를 드래그하세요.
  5. 프로젝트를 저장하세요.

3. Unity 프로젝트 준비

이 섹션에서는 게임 영역을 생성하고 그 안에 오브젝트를 만들어봅니다. 리스너, 이미터, 그리고 두 개의 공간(room)이 필요합니다.

Launcher를 통해 Unity에서 프로젝트를 여세요. Wwise Picker (Windows > Wwise Picker)를 열고, Refresh Project(프로젝트 새로 고침)와 Generate SoundBanks(사운드뱅크 생성)을 클릭하세요.

Wwise Picker
  1. 원하는 방법으로 캐릭터를 생성하세요.
    1. Unity Audio Source를 모두 제거하세요.
    2. 리스너의 역할을 하는 GameObject에 AkSpatialAudioListener 컴포넌트를 추가하세요.
      AkSpatialAudioListener component
    3. AkSpatialAudioListener 컴포넌트를 추가하면 AkAudioListener, AkRoomAwareObject, AkGameObj 컴포넌트가 자동으로 생깁니다.
      AkAudioListener 컴포넌트
      AkGameObj component
      AkRoomAwareObject 컴포넌트
      1. AkGameObj 컴포넌트에서
        1. Environment Aware 체크 상자를 선택 해제하세요.
        2. Use Default Listener 옵션을 활성화하세요.
      2. AkRoomAwareObject 컴포넌트에 최대 두 개의 경고 메시지가 뜰 수 있습니다. 아직 AkRoom 컴포넌트를 사용하지 않기 때문에 지금은 이 메시지를 무시하셔도 됩니다. Room과 Portal 튜토리얼 에서 해당 메시지를 다시 확인하도록 하겠습니다. 게임에서 AkRoom 컴포넌트를 전혀 사용하지 않을 경우 해당 컴포넌트를 비활성화해도 됩니다.
  2. 원하는 방법으로 바닥과 건물을 만들고, 건물 안에 두 공간과 건물 밖에 장애물을 만드세요.
    SpatialAudioTutorial 씬에서 저희는 건물에 메쉬를 사용하고 바닥과 장애물에 큐브를 사용했습니다 ( GameObject > 3D Object > Cube ).

    SpatialAudioTutorial 씬
  3. 원하는 방법으로 이미터를 만드세요. Wwise Unity Demo Scene에서는 원기둥을 사용하여 버튼을 만들었습니다 ( GameObject > 3D Object > Cylinder ). 각 공간의 안팎에 버튼을 추가했습니다.

    다음과 같이 각 이미터를 만드세요.
    1. AkAmbient 컴포넌트를 추가하세요.
      1. Trigger On에서 선호하는 사운드 시작 방법을 선택하세요.
      2. Name에서 Event를 선택하세요.
        AkAmbient component
    2. AkGameObj 컴포넌트 (AkAmbient 컴포넌트를 추가하면 자동으로 추가됨)에서 다음과 같이 처리하세요.
      1. Use Default Listener 옵션을 활성화하세요.
        AkGameObj component
    3. AkBank 컴포넌트를 추가하세요.
      1. 이전 섹션에서 생성된 SoundBank를 Name에 추가하세요.
        AkBank 컴포넌트

4. 셋업 검토하기

  1. 게임을 시작하고 Wwise에 연결하세요,
    1. Profiler 레이아웃 (단축키 F6)을 여세요.
      1. 버튼으로 사운드를 재생하세요. Wwise 프로젝트에 가져온 사운드가 들려야 합니다.
      2. Voices Graph 탭에서 다음 그래프가 보여야 합니다.
        Button Outside Voice Graph with no Effect
      3. Advanced Profiler 뷰의 오른쪽 위의 모서리에 있는 톱니 바퀴 모양 아이콘을 통해 Profiler 설정창을 열고 Spatial Audio를 선택하여 Game Object 3D Viewer에서 Spatial Audio이 보이도록(다음 단계) 하세요.
        Profiler Settings
    2. Game Object Profiler 레이아웃을 여세요 (단축키 F12)
      1. Game Object 3D Viewer에서 다음 게임 오브젝트를 확인할 수 있습니다. 방사되지 않은 게임 오브젝트는 이 뷰어에 나타나지 않습니다.
        Game Object 3D Viewer
  2. 편리한 곳에 씬을 저장하세요.


Wwise Unity Integration Documentation: 표면 리플렉터 튜토리얼

표면 리플렉터 튜토리얼

다음 단계에서 이 튜토리얼은 Unity에서 Spatial Audio와 함께 Reflect 플러그인을 사용하는 법을 보여줍니다. 사운드뱅크를 생성하려면 Reflect 플러그인 라이선스가 필요하지만 여전히 Wwise Authoring에 연결하여 사용해볼 수 있습니다.

  • A. Wwise 프로젝트
  • B. Unity 프로젝트
  • C. 셋업 검토하기
참고: 이 튜토리얼은 Spatial Audio 튜토리얼 준비 를 완료했다는 가정 하에 진행됩니다.

A. Wwise 프로젝트

Reflect 플러그인과 Acoustic Textures(음향 텍스처)가 있는 Auxiliary Bus를 만들어서 Wwise 프로젝트를 갱신해야 합니다.

  1. Auxiliary Bus 프리셋과 기본 Acoustic Texture에 접근할 수 있도록 기본 에셋을 가져오세요.
    1. Project > Import Factory Assets...로 이동하세요
    2. Reflect and Acoustic Textures를 선택하고 OK를 누르세요.
  2. Acoustic Texture는 Project Explorer 뷰의 ShareSets 탭에 있는 Virtual Acoustics 폴더 안에 있습니다.
    Factory Reflect Acoustic Textures in the Project Explorer ShareSets tab
    1. (선택 사항) Default Work Unit 아래 있는 Virtual Acoustics 폴더에 커스텀 Acoustic Texture를 추가할 수 있습니다.
  3. 초기 반사에 사용할 Auxiliary Bus를 추가하세요.
    1. Master Audio Bus를 우클릭하고 New Child > Presets로 가서 Early Reflection Auxiliary Bus를 선택하세요.
  4. Spatial Audio 튜토리얼 준비 에 추가된 사운드를 변경하세요
    1. General Settings 탭에서 Reflect가 있는 새로 만든 Auxiliary Bus를 Early Reflections 상자에 추가하세요.
      Sound Property Editor의 General Settings 탭에서 Reflect Auxiliary Bus를 지정하세요
  5. 프로젝트를 저장하세요.

B. Unity 프로젝트

AkSurfaceReflector 컴포넌트를 사용하여 표면 상에서의 초기 리플렉션을 시뮬레이션할 수 있습니다. 한 가지 방법으로 표면 리플렉터 컴포넌트를 게임에서 기존의 메쉬에 추가할 수 있습니다. 모양이 너무 복잡할 경우 너무 많은 삼각형이 Spatial Audio API에 전달되어 게임이 느려질 수 있습니다. 이 경우 AkSurfaceReflector 컴포넌트 자체에 충돌 메쉬 등의 다른 메쉬를 추가할 수 있습니다. 반사적 표면을 추가하는 또 다른 방법은 바로 새로운 GameObject를 추가하는 것입니다. Wwise Unity Demo Scene에서 제공하는 씬에서는 새로운 오브젝트를 표면 리플렉터로 사용했습니다. 공간이 큐브 모양이기 때문에 메쉬 렌더러가 없는 큐브를 사용했습니다.

  1. 큐브를 생성하세요 (GameObject > 3D Object > Cube)
    1. Mesh Renderer 컴포넌트를 제거하세요
    2. Box Collider 컴포넌트에서 Is Trigger를 선택하세요
    3. AkSurfaceReflector 컴포넌트를 추가하세요.
      1. MeshFilter 컴포넌트에서의 메쉬를 사용할 경우 메쉬 매개 변수를 None으로 남겨둬도 됩니다. 그렇지 않을 경우 여기에 원하는 메쉬를 추가하세요.
      2. Acoustic Textures 배열에서 각 하위 메쉬 (이 큐브는 하위 메쉬가 단 하나임)의 음향 텍스처를 선택하거나 None으로 남겨두어 필터링되지 않은 리플렉션을 사용하도록 하세요.
      3. Transmission Loss Values 배열에서 각 하위 메쉬 표면의 전달 손실값을 설정할 수 있습니다. 이 값은 메쉬를 통과하는 사운드를 필터링하는 데에 사용됩니다. 더 자세한 내용은 D. Transmission (전달) 섹션을 참조하세요.
      4. Enable Diffraction 체크 상자를 선택하면 회절을 활성화할 수 있습니다. 더 자세한 내용은 E. 공간을 Surface Reflector와 연결 (추후 버전에는 사용 중단) 을 참고하세요.
      5. 마지막으로 Associated Room을 None으로 설정해 둡니다. 더 자세한 내용은 E. 공간을 Surface Reflector와 연결 (추후 버전에는 사용 중단) 섹션을 참고해 주세요.
        AkSurfaceReflector component
  2. 반사의 순서는 Spatial Audio Settings 아래 AkWwiseInitializationSettings에서 설정됩니다
    1. 기본적으로 반사 Order는 1로 설정되어 있습니다. 최대 4까지 설정할 수 있습니다.
      Spatial Audio Init Settings
  3. 씬에서 반사 경로를 확인하려면 이미터에 AkSpatialAudioDebugDraw 컴포넌트를 추가하세요.
    1. 표시하고자 하는 반사 순서를 클릭하세요.
      AkSpatialAudioDebugDraw 컴포넌트

C. 셋업 검토하기

  1. Wwise Picker (Windows > Wwise Picker)에서 다음을 실행하세요.
    1. SoundBank를 생성하세요
      Wwise Picker
  2. 게임을 시작하고 이미터 하나를 재생하세요.
    1. Wwise에서 게임에 연결하고 Profiler 레이아웃으로 전환하세요. 다음과 비슷한 그래프가 보일 것입니다.
      Voice Graph with Reflect Effect
    2. 그래프의 Auxiliary Bus 노드 아래 강조 표시된 Wwise Reflect를 더블 클릭해서 Reflect Effect Editor를 여세요. 사운드를 재생하면 그래프와 목록에서 현재 리플렉션이 보여야 합니다. Texture(s) 열에 두 가지 텍스처가 있을 경우 이 리플렉션은 2차 리플렉션입니다.
      1. 여기에서 리플렉션의 감쇠 곡선을 변경할 수 있습니다.
      2. 리플렉션이 보이지 않을 경우 이미터와 리스너 간의 리플렉션 거리와 비교하여 Max Distance가 충분히 큰지 확인하세요.
        Reflect Effect Editor View
    3. Game Object Profiler Layout으로 전환하세요 (단축키 F12)
      1. Game Object 3D Viewer Settings에서 Reflection Paths와 Reflection Image Sources가 활성화되었는지 확인하세요.
        Game Object 3D Viewer Settings for Reflect
      2. Game Object 3D Viewer에서 재생 중인 이미터와 공간 음향 리스너 간에 표면 리플렉터와 리플렉션 경로가 보여야 합니다.
        Game Object 3D Viewer
참고: Game Object 3D 뷰어에서 지오메트리가 보이지 않을 경우 Initialization Settings에서 Monitor Queue Pool Size를 늘려야 합니다. 다음 페이지 Wwise Initialization Settings 조정하기 를 참고하세요.
참고: 건물 주위에 있는 큐브 모양의 표면 리플렉터를 통해서는 심지어 이미터가 재생 중이더라도 리스너가 밖에 있을 경우 건물 안에 있는 이미터에서 리플렉션 경로를 얻을 수 없습니다. 마찬가지로 리스너가 안에 있을 경우 건물 밖에 있는 이미터에서 리플렉션 경로를 얻을 수 없습니다. 그 이유는 빌딩의 열린 부분이 반사적 표면의 일부이기 때문입니다. 이 문제를 해결하려면 건물의 메쉬를 표면 반사기로 사용하거나 열린 부분 주위에 포털을 배치해야 합니다. 포털에 대한 더 많은 내용은 Room과 Portal 튜토리얼 을 참고하세요.
참고
  • 공간 음향 컴포넌트
  • Reflect 설명서
  • 지오메트리 API를 사용하여 초기 반사음 시뮬레이션하기


Wwise Unity Integration Documentation: Room과 Portal 튜토리얼

Room과 Portal 튜토리얼

이 튜토리얼은 Spatial Audio에서 Room(공간)과 Portal(포털)을 사용하는 법을 보여줍니다. 다음 섹션은 튜토리얼의 각 단계를 자세하게 보여줍니다.

  • A. Wwise 프로젝트
  • B. Room (공간)
  • C. Portal (포털)
  • D. 셋업 검토
  • E. 포털과 리버브
참고: 이 튜토리얼은 Spatial Audio 튜토리얼 준비 를 완료했다는 가정 하에 진행됩니다. 하지만 표면 리플렉터 튜토리얼 을 완료했다고 가정하지는 않습니다. 이 두 튜토리얼은 서로 별개입니다. 표면 리플렉터 튜토리얼 을 완료했으며 이 튜토리얼로 계속 진행하는 경우 씬을 변경하지 않은 채 작업할 수 있습니다. 새로 시작하고 싶지만 표면 리플렉터 튜토리얼 을 완료한 경우 여전히 동일한 씬을 유지할 수 있습니다.

A. Wwise 프로젝트

이 튜토리얼에서는 이미터를 볼 수 없을 때 포털을 통해 회절이 들리도록 Reverb Effect를 추가하고 Obstruction 곡선을 변경해야 합니다.

  1. 공간 프리셋을 사용하여 두 개의 Auxiliary Bus를 추가하세요.
    1. Master Audio Bus를 우클릭하고 New Child > Presets으로 가서 Room Auxiliary Bus를 선택하세요
    2. Effects 탭 아래에서 각 공간에 대해 효과를 각각 선택하세요. 예: 작은 공간에는 Rooms/Room_Medium, 큰 공간에는 Cathedrals/Medium 사용.
      공간에 대한 Auxiliary Bus Property Editor Effects 탭
  2. Spatial Audio 튜토리얼 준비 에 추가된 사운드를 변경하세요
    1. Positioning 탭에서 회절과 전달이 활성화되어 있는지 확인하세요.
      Sound Property Editor의 Positioning 탭에서 Diffraction과 Transmission을 활성화하세요
  3. 기본적으로 회절은 방해에 의해 필터링되며 전달 손실은 차단에 의해 필터링됩니다. Project > Project Settings > Obstruction/Occlusion으로 이동하세요
    1. Obstruction Volume과 Obstruction LPF 곡선을 선호에 맞게 변경하세요. 이 예시에서는 Wwise Unity Demo 씬 프로젝트에서 다음과 같이 사용했습니다:
      Curve | Point 1 | Point 2 | Curve Type
      X | Y | X | Y
      Obstruction Volume | 0 | 0 | 100 | -3 | Linear
      Obstruction LPF | 0 | 0 | 100 | 60 | Linear
      Occlusion Volume | 0 | 0 | 100 | -12 | Sine (Constant Power Fade In)
      Occlusion LPF | 0 | 0 | 100 | 75 | Sine (Constant Power Fade Out)
    2. Obstruction Volume 곡선이 다음과 같이 변경되어야 합니다.
      Wwise Project Settings의 Obstruction/Occlusion 곡선
  4. 프로젝트를 저장하세요.
  5. Unity 프로젝트에서 Wwise Picker: Windows > Wwise Picker 안에 있는 뱅크를 새로 고침하세요
    1. SoundBank를 생성하세요
      Wwise Picker

B. Room (공간)

씬에서 공간의 위치를 지정해야 합니다. 그렇게 하려면 AkRoom 컴포넌트를 사용해야 합니다.

  1. Wwise Unity Demo Scene의 튜토리얼 씬에서는 큐브 메쉬를 추가하여 건물 안에 있는 각 공간의 실내를 표시했습니다. 표면 리플렉터 튜토리얼 을 끝내고 이 튜토리얼을 진행할 경우 AkSurfaceReflector 컴포넌트가 있는 GameObject를 사용할 수 있습니다.
    1. GameObject > 3D Object > Cube를 통해 큐브를 추가하세요.
    2. Mesh Renderer 컴포넌트를 제거하세요.
    3. Box Collider 컴포넌트에서 Is Trigger를 선택하세요.
    4. AkRoom 컴포넌트를 추가하세요.
      1. Reverb Aux Bus에 사용할 해당 Auxiliary Bus를 선택하세요.
      2. 공간에 Rigidbody 컴포넌트를 추가하라는 경고 메시지가 뜹니다. AkRoom 컴포넌트와 AkRoomAwareObject 컴포넌트 사이에 상호작용이 활성화된 것이 보입니다. 다음 단계는 이러한 컴포넌트를 추가하도록 도와줍니다.
        AkRoom 컴포넌트
  2. 공간을 사용하기 때문에 AkRoomAwareObject 컴포넌트를 추가하여 모든 리스너와 이미터에 'Room Aware'가 작동되도록 해야 합니다.
    1. AkRoomAwareObject 컴포넌트는 이미 Spatial Audio 리스너에 자동으로 추가되어 있습니다. 이 컴포넌트가 활성화되었는지 확인하세요.
      AkRoomAwareObject 컴포넌트
    2. 위의 이미지에서 보이는 것처럼 두 경고 메시지가 뜹니다.
      1. 첫 번째 메시지는 Rigidbody 컴포넌트를 공간이나 현재 오브젝트에 배치해야 한다고 말합니다. Ridgidbody를 공간에 아직 추가하지 않았다면 Add Rigidbody를 클릭하세요.
      2. 두 번째 경고 메시지는 콜라이더에 관한 것입니다. 모든 AkRoomAwareObject는 AkRoom 컴포넌트와 상호작용하기 위해 콜라이더를 필요로 합니다.

C. Portal (포털)

리스너가 이미터와 다른 공간에 있을 경우 '공간의 벽'에 의해 소리가 막힙니다. 이 벽에 전달 손실값을 설정할 수 있습니다 (/ref pg_obs_occ 참고). 그렇지 않을 경우 포털을 추가해서 원하는 열린 공간에서 소리가 직접 전달되도록 해야 합니다. SpatialAudioTutorial 씬에는 포털을 배치할 수 있는 두 곳의 열린 공간이 있습니다. 한 곳은 실외 영역과 작은 Room 사이이며 다른 한 곳은 두 Room 사이입니다.

  1. 두 개의 AkRoomPortal 컴포넌트를 생성하세요 (GameObject > Wwise > Room Portal). 그리고 이 컴포넌트를 열린 부분의 주변에 배치하세요.
  2. Scene 창에서 Portal은 노란색 끈으로 둘러져 표현되며 크기와 배치되어야 할 방향을 표시합니다. 빨간선은 Portal의 앞뒤 사이의 구별을 보여줍니다. 앞면은 Portal의 z 축과 같은 방향입니다.
    Scene 창에서 AkRoomPortal
  3. AkRoomPortal 컴포넌트에서
    1. Open On을 Start로 지정하고
    2. Close On을 Nothing으로 지정하세요.
    3. Back Room과 Front Room이 알맞은 AkRoom 컴포넌트를 표시하는지 확인하세요.
  4. 작은 공간과 실외 사이에 있는 포털의 AkRoomPortal 컴포넌트가 다음과 같이 표시되어야 합니다.
    AkRoomPortal 컴포넌트

D. 셋업 검토

  1. 씬에 그려진 소리 전달 경로를 확인하려면 이미터에 AkSpatialAudioDebugDraw 컴포넌트를 추가하세요.
    1. Draw Diffraction Paths 옵션을 선택하세요.
      AkSpatialAudioDebugDraw 컴포넌트
  2. 게임을 시작하고 Wwise에 연결하세요.
    1. 두 공간 중 하나에서 버튼을 눌러 리버브를 들어보세요.
      1. 보이스 그래프가 다음과 같이 보여야 합니다:
        Voice Graph와 Room
    2. 공간 밖으로 나가서 다른 공간에 있는 재생 중인 이미터의 시야 안팎으로 움직이면서 사운드에 적용되는 회절을 들어보세요. 리스너와 포털 간의 각도에 따라 회절의 정도가 달라지는 것이 들릴 것입니다.
      1. Unity Scene 창에서 포털에서 오는 사운드를 나타내는 경로가 보입니다. 사운드에 적용되는 회절의 백분율은 회절 지점에 표시됩니다.
        포털을 통한 회절 경로의 Top 뷰
    3. Authoring의 Game Object Profiler 레이아웃을 여세요 (단축키 F12)
      1. Game Object 3D Viewer Settings에서 Diffraction Paths가 활성화되었는지 확인하세요.
        Portal 회절 경로에 대한 Game Object 3D Viewer Settings
    4. Game Object 3D Viewer에서 다음 내용을 확인할 수 있습니다:
      1. 공간과 포털의 시각화.
      2. 포털을 통과하여 이미터에서 리스너까지 가는 회절 경로. 회절률은 각 모서리에 표시됩니다. 가상 근원지의 흔적이 초록색으로 표시되어 실제로 사운드가 들려오는 곳을 보여줍니다.
      3. 전달 손실률과 함께 공간의 벽을 통과하는 전달 경로.
      4. 공간의 변조된 사운드를 표시하는 집 모양의 아이콘. 이 이미지에서는 포털으로부터 나오는 사운드를 나타내는 한 아이콘과 공간의 벽을 통과하는 사운드를 나타내는 한 아이콘이 있습니다.
      5. 각 이미터/리스너는 이름 아래 해당 공간을 표시해 줍니다. 리스너가 공간 안에 있지 않기 때문에 기본적으로 'Outdoors' 공간에 배치되었습니다.
        1. 해당 리스너를 공간으로 옮기고 Game Object 3D Viewer에서 리스너 게임 오브젝트 아래의 공간 이름이 변경되는 것을 보세요.
          Game Object 3D Viewer에서 포털을 통한 회절 경로
참고: 공간 밖에 리버브를 추가하려면 전체 영역에 걸쳐서 Room을 추가하세요. 이 Room의 우선 순위가 씬에 있는 다른 AkRoom 컴포넌트보다 낮은지 확인하세요.

E. 포털과 리버브

Portal을 통해 방사되는 사운드도 리스너가 있는 Room에서의 리버브를 사용할 수 있습니다. 저희는 이것을 Room Coupling이라고 부릅니다.

  1. 공간의 Auxiliary Bus Property Editor를 열고 General Settings 탭에서 Use game-defined auxiliary sends가 선택되어 있는지 확인하세요. 이 옵션은 공간의 리버브를 씬의 다른 리버브로 전송합니다.
  2. 작은 공간 이미터를 재생하고 큰 공간으로 이동하면 작은 공간의 리버브가 큰 공간의 리버브로 전달되는 것을 볼 수 있습니다.
    Voice Graph에 표시된 Room Coupling
참고:

Wwise Unity Demo Scene은 표면 리플렉터 튜토리얼 과 Room과 Portal 튜토리얼 뿐만 아니라 회절을 구현합니다. 더 많은 정보는 Spatial Audio 추가 기능들 을 참고하세요.

참고
  • Room Coupling

F. 공간음

경우에 따라 에어컨 작동음과 같이 공간에 특정한 환경음이 있습니다. 이 소리를 재현하기 위해서 Spatial Audio Room 게임 오브젝트에서 이벤트를 전송할 수 있습니다. 리스너가 공간 안에 있을 경우 사운드가 리스너의 위치로 배치됩니다. 리스너가 다른 공간에 있을 경우 리스너의 위치와 연결되는 포털로부터 공간음을 듣게 됩니다.

  1. Wwise 프로젝트에서 다음을 실행하세요.
    1. 공간음에 사용할 새로운 Sound SFX를 만드세요.
      1. 공간음을 공간 리버브에 전송할 수 있도록 게임에서 정의한 보조 전송을 반드시 활성화하세요.
    2. Sound SFX를 우클릭한 후 New Event > Play를 선택해서 공간음이 있는 이벤트를 재생하세요.
    3. 프로젝트를 저장하세요.
  2. Unity에서 다음을 실행하세요.
    1. 해당 이벤트를 한 공간의 AkRoom 컴포넌트의 Room Tone Event 매개 변수에 추가하세요.
      1. Aux Send Level을 조정하여 소리의 일부를 공간의 리버브로 보내세요.
      2. 이벤트가 트리거되는 방식을 선택할 수 있습니다.
        활성화된 Room으로 Spatial Audio Volume의 AkEvent 섹션.
  3. SoundBank를 생성하세요.
  4. 씬을 시작하고 Wwise Authoring에 연결하세요.
  5. 공간음이 들리는지 확인하세요.
    1. Advanced Profiler 뷰에서 이벤트가 재생되는 것이 보입니다.
      리스너가 공간음이 있는 공간에 있을 경우의 Advanced Profiler 뷰
    2. 3D Game Object Viewer에서 리스너가 움직임에 따라 공간 게임 오브젝트를 확인할 수 있습니다.
      1. 리스너가 공간 안에 있을 경우 해당 공간이 리스너의 위치에서 공간음을 방사합니다. 공간 게임 오브젝트가 리스너 게임 오브젝트를 따라 이동하는 것을 볼 수 있습니다.
      2. 리스너가 다른 공간에 있을 경우 공간 게임 오브젝트가 포털에 배치되며 공간 게임 오브젝트와 리스너 게임 오브젝트 사이의 경로가 표시됩니다.
        Game Object 3D Viewer에서 공간 게임 오브젝트를 보세요
참고
  • 공간 음향 컴포넌트
  • Spatial Audio 공간과 포털 설명서


Wwise Unity Integration Documentation: Spatial Audio 추가 기능들

Spatial Audio 추가 기능들
  • A. 표면 리플렉터와 포털
  • B. 표면 리플렉터와 리버브
  • C. 회절
  • D. Transmission (전달)
  • E. 공간을 Surface Reflector와 연결 (추후 버전에는 사용 중단)
참고: 이 페이지는 Spatial Audio 튜토리얼 준비 , 표면 리플렉터 튜토리얼 , Room과 Portal 튜토리얼 을 이미 완료했다는 가정 하에 진행됩니다.

A. 표면 리플렉터와 포털

포털이 공간 영역을 열어 소리가 전달되도록 하듯이 표면 리플렉터는 반사적인 표면을 통해 소리가 전달되도록 합니다. 표면 리플렉터 튜토리얼 의 끝부분에서 간단한 큐브를 표면 리플렉터로 사용할 경우 리플렉션이 메쉬의 열린 부분에서 일어나는 것을 볼 수 있었습니다. 이 문제를 해결하기 위해서 Spatial Audio Portal은 리플렉션 경로를 인식하며 통과시킵니다. 심지어 리플렉션 경로는 포털의 경계선에서 회절합니다.

  1. 설정 방법은 간단합니다. 공간으로의 포털을 설치하면 표면 리플렉터가 작동합니다.
    Game Object 3D Viewer에서 포털을 통한 리플렉션 경로

B. 표면 리플렉터와 리버브

늦은 리버브가 있는 Room의 경우 리버브에 초기 리플렉션을 추가하여 지오메트리를 더욱 인식하도록 할 수 있습니다.

  1. Wwise 프로젝트에서 Reflect Effect가 적용된 Auxiliary Bus를 여세요.
    1. General Settings 탭에서 Use game-defined auxiliary sends가 선택되었는지 확인하세요.
      초기 리플렉션를 공간 리버브로 전달하는 Auxiliary Bus Property Editor General Settings 탭
  2. 씬을 재생하고 작은 Room에서 버튼을 누르세요. 플레이어가 작은 Room에 있을 때 Voice Graph가 다음과 같이 표시됩니다.
    Voices Graph에서 작은 공간의 초기 리플렉션은 작은 공간의 리버브로 전달됩니다.

C. 회절

오브젝트가 이미터와 리스너 사이에 나타날 경우 Spatial Audio는 오브젝트를 피해 지나갈 회절 경로를 생설할 수 있습니다. 모서리 주위의 경로 각도에 따라 사운드가 감쇠되어 방해를 시뮬레이션합니다. 회절은 Sound마다 그리고 Surface Reflector마다 활성화할 수 있습니다. 회절이 활성화된 사운드를 방사하는 이미터는 회절이 활성화된 반사적 표면에서만 회절합니다.

  1. Sound에서 회절 활성화하기:
    1. Positioning 탭에서 Enable Diffraction 체크 상자가 활성화되었는지 확인하세요.
      Sound에서 회절 활성화하기
  2. AkSurfaceReflector 컴포넌트에서 회절 활성화하기
    1. Enable Diffraction을 선택하세요. 그러면 Wwise Spatial Audio에 전송된 지오메트리에서 회절 모서리가 생성됩니다. 회절 모서리는 Wwise가 게임에 연결되었을 경우 게임 오브젝트 뷰어에서 확인할 수 있습니다.
    2. Enable Diffraction On Boundary Edges도 확인하세요. 이 체크 상자는 이전의 체크 상자가 체크되었을 때 나타납니다. 경계 모서리는 한 삼각형에만 연결된 모서리를 말합니다. 예를 들어 Unity Quad 3D Object의 모서리가 경계 모서리로 간주됩니다.
      Diffraction enabled AkSurfaceReflector
  3. Wwise Unity Demo 씬에서는 실외 이미터, 건물의 경계선과 외부에 회절이 활성화되어 있습니다. 회절 경로는 보라색으로 표시됩니다. 각 회절 경로는 사운드가 들려올 곳인 가상 근원지를 생성합니다.
    Game Object 3D Viewer에서 회절 경로
    참고
    • 공간 음향 회절
    • 지오메트리 API를 사용하여 회절 시뮬레이션하기

D. Transmission (전달)

이미터와 리스너 간에 오브젝트가 나타날 경우 사운드가 이 오브젝트도 통과할 수 있습니다. Spatial Audio는 사운드의 직접 경로를 필터링하여 이 현상을 모델링합니다. 이미터가 공간(room) 안에 있을 경우 이 공간의 벽이 사운드를 막는 오브젝트의 역할을 합니다. 이 경우 사운드의 직접 경로와 변조 경로가 필터링 되어 소리 전달을 모델링합니다. 0~1 사이의 전달 손실값이 AkSurfaceReflector와 AkRoom 컴포넌트에 적용될 수 있습니다. 기본적으로 소리 전달은 프로젝트의 차단 볼륨, 저대역과 고대역 통과 곡선을 사용하게 됩니다. 보통 값이 1.0일 경우 소리가 완전히 손실됨을 의미하며, 값이 0.0일 경우 소리가 필터링 없이 지오메트리를 통과하여 전달될 수 있음을 의미합니다.

  1. 공간 음향 설정에서 Use Occlusion을 활성화하세요. 이렇게 하면 전달 손실값이 Wwise 프로젝트의 차단 곡선과 연결됩니다.
    Spatial Audio Init Settings
  2. 사운드를 필터링할 최종 전달 손실값은 이미터에서 리스너까지의 직접 경로에서 소리가 직면할 AkSurfaceReflector이나 AkRoom 컴포넌트에서 전달되는 모든 표면의 최대 전달 손실값이 됩니다.
    1. AkSurfaceReflector 컴포넌트에서 Transmission Loss Values 배열을 구성하여 표면 리플렉터 메쉬의 각 하위 메쉬의 전달 손실값을 연결하세요.
      AkSurfaceReflector 컴포넌트의 Transmission Loss Values 배열
    2. AkRoom 컴포넌트에서 Transmission Loss 매개 변수의 전달 손실값을 변경하세요.
      AkRoom 컴포넌트의 Transmission Loss 매개 변수
  3. 전달에 차단을 사용할 경우 Project Settings의 Obstruction/Occlusion 탭에 있는 Wwise Authoring에서 차단 곡선을 조절하세요.
    Wwise Project Settings의 Occlusion 곡선
    참고
    • 공간 음향 전달
    • 공간과 포털 전달

E. 공간을 Surface Reflector와 연결 (추후 버전에는 사용 중단)

경고: AkSurfaceReflector 요소의 Associated Room 속성은 더 이상 사용되지 않으며 향후 버전에서 제거될 예정입니다. None으로 설정하여 사용하지 않는 것이 좋습니다.

Spatial Audio에 추가된 각 표면 리플렉터는 회절각과 가시성에 대해 분석됩니다. 이 단계를 최적화하기 위해서 각 공간이 연결된 표면 리플렉터의 그룹을 가질 수 있습니다. 공간에 연결된 Surface Reflector(표면 리플렉터)는 다른 공간에서 볼 수가 없습니다. Surface Reflector가 공간에 완전히 둘러싸여 있으며 이 공간이 다른 공간과 표면 리플렉터를 공유하지 않을 경우에만 공간에 연결되어야 합니다. 공간을 표면 리플렉터와 연결하는 것은 완전히 선택적입니다. 공간을 선택하지 않으면 표면 리플렉터가 표면 리플렉터의 전역 그룹으로 추가됩니다. 표면 리플렉터를 공간에 연결하면 리플렉션과 회절 계산에 의해 실행되는 레이 캐스팅에 대한 검색 공간이 줄어듭니다.

  1. 공간을 연결하려면 AkSurfaceReflector 컴포넌트의 Associated Room에서 Room을 선택하세요.
    AkSurfaceReflector와 Associated Room
AkEvent
Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017....
Definition: AkEvent.cs:48
AkSurfaceReflector.RemoveGeometryInstance
void RemoveGeometryInstance()
Remove this component's geometry instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:401
AkEnvironmentPortal.axis
UnityEngine.Vector3 axis
The axis used to find the contribution of each environment
Definition: AkEnvironmentPortal.cs:27
TransportState
Used to deserialize transport-state information receieved from the transport.stateChanged topic.
Definition: AkWaapiHelper.cs:187
AkSpatialAudioEmitter
(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb c...
Definition: AkSpatialAudioEmitter.cs:26
AkWaapiUtilities.Disconnecting
static System.Action< bool > Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket conn...
Definition: AkWaapiUtilities.cs:42
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AkWwiseTreeWAAPIDataSource
This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object h...
Definition: AkWwiseTreeWAAPIDataSource.cs:31
AkListenerDistanceProbe
Add this script on a listener game object to assign another game object as a distance probe....
Definition: AkListenerDistanceProbe.cs:28
AkRadialEmitter
A radial emitter is for sounds that are not point sources, but instead originate from a region of spa...
Definition: AkRadialEmitter.cs:26
AK.Wwise.AcousticTexture
This type represents an Acoustic Texture.
Definition: AkWwiseAcousticTexture.cs:25
ak.wwise.core
Definition: Uri.cs:103
ArgsObject
WAAPI arguments containing an object identfier.
Definition: AkWaapiHelper.cs:57
AkBank.decodeBank
bool decodeBank
Decode this SoundBank upon load
Definition: AkBank.cs:31
AK
Definition: AkWwiseAcousticTexture.cs:21
AkSurfaceReflector.AcousticTextures
AK.Wwise.AcousticTexture[] AcousticTextures
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry....
Definition: AkSurfaceReflector.cs:36
AkSurfaceReflector.TransmissionLossValues
float[] TransmissionLossValues
The transmission loss value per submesh. The transmission loss value is a control value used to adjus...
Definition: AkSurfaceReflector.cs:41
AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >
static void QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response.
Definition: AkWaapiUtilities.cs:564
ak.wwise
Definition: Uri.cs:73
AkReverbZone.SetReverbZone
static void SetReverbZone(AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and it...
Definition: AkReverbZone.cs:60
AkBank.loadAsynchronous
bool loadAsynchronous
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the Sound...
Definition: AkBank.cs:36
AK.Wwise.Event.StopMIDI
void StopMIDI()
Stops all MIDI Events on this Event.
Definition: AkWwiseEvent.cs:232
AkWaapiUtilities.GetWwiseObject< T >
static void GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options.
Definition: AkWaapiUtilities.cs:582
ak.wwise.core.undo
Definition: Uri.cs:193
ak.wwise.error
Definition: Uri.cs:75
Wamp.ErrorException
Exception thrown during WAMP operations.
Definition: Wamp.cs:44
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:213
AkSpatialAudioDebugDraw.drawDiffractionPaths
bool drawDiffractionPaths
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the ...
Definition: AkSpatialAudioDebugDraw.cs:35
AkRoomPortal.ClosePortal
void ClosePortal(UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event
Definition: AkRoomPortal.cs:221
AkRoomPortal.GetID
ulong GetID()
Access the portal's ID
Definition: AkRoomPortal.cs:181
AkReverbZone.TransitionRegionWidth
float TransitionRegionWidth
Width of the transition region between the Reverb Zone and its parent. The transition zone is centere...
Definition: AkReverbZone.cs:43
AkRoom.reverbLevel
float reverbLevel
The reverb control value for the send to the reverb aux bus.
Definition: AkRoom.cs:47
AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
Definition: AkEnvironment.cs:86
AkWaapiUtilities.SelectObjectInAuthoring
static void SelectObjectInAuthoring(System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to Selec...
Definition: AkWaapiUtilities.cs:728
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:201
AkWaapiUtilities.Search< T >
static void Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command....
Definition: AkWaapiUtilities.cs:665
AkEnvironment.AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities.
Definition: AkEnvironment.cs:72
AkEvent.transitionDuration
float transitionDuration
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:84
AkSpatialAudioEmitter.reflectionsAuxBusGain
float reflectionsAuxBusGain
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:37
AkSurfaceReflector.GeometryData
The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
Definition: AkSurfaceReflector.cs:112
AkGameObj.GetUpward
virtual UnityEngine.Vector3 GetUpward()
Definition: AkGameObj.cs:298
AkSurfaceReflector.GetGeometryDataFromMesh
static void GetGeometryDataFromMesh(UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkS...
Definition: AkSurfaceReflector.cs:186
AkSurfaceReflector
This component converts the provided mesh into Spatial Audio Geometry.
Definition: AkSurfaceReflector.cs:27
JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:27
AkSpatialAudioEmitter.roomReverbAuxBusGain
float roomReverbAuxBusGain
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Vo...
Definition: AkSpatialAudioEmitter.cs:45
AkSpatialAudioEmitter.diffractionMaxPathLength
uint diffractionMaxPathLength
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:56
AkWaapiUtilities.GetChildren< T >
static void GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object.
Definition: AkWaapiUtilities.cs:686
AkSpatialAudioListener.SpatialAudioListeners
static SpatialAudioListenerList SpatialAudioListeners
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.
Definition: AkSpatialAudioListener.cs:47
AK.Wwise.BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and S...
Definition: AkWwiseBaseGroupType.cs:25
AkSpatialAudioEmitter.drawDiffractionPaths
bool drawDiffractionPaths
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:72
AkSpatialAudioListener.SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio l...
Definition: AkSpatialAudioListener.cs:71
AkMemBankLoader.isLocalizedBank
bool isLocalizedBank
Is the bank localized (situated in the language-specific folders)
Definition: AkMemBankLoader.cs:31
ArgsPlay
WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.
Definition: AkWaapiHelper.cs:119
AkSurfaceReflector.UpdateGeometry
void UpdateGeometry()
Update this component's geometry instance
Definition: AkSurfaceReflector.cs:382
ak.wwise.ui.commands
Definition: Uri.cs:297
AkWaapiUtilities.TogglePlayEvent
static void TogglePlayEvent(WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to...
Definition: AkWaapiUtilities.cs:876
AkSpatialAudioEmitter.drawSecondOrderReflections
bool drawSecondOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:66
ak.wwise.core.transport
Definition: Uri.cs:230
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkMemBankLoader.LoadNonLocalizedBank
void LoadNonLocalizedBank(string in_bankFilename)
Load a SoundBank from WWW object
Definition: AkMemBankLoader.cs:56
WwiseRenameInfo
Used to deserialize information published on the ak.wwise.core.@object.nameChanged topic.
Definition: AkWaapiHelper.cs:246
AkSpatialAudioEmitter.reflectAuxBus
AK.Wwise.AuxBus reflectAuxBus
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:30
AkWaapiUtilities.IsPlayable
static bool IsPlayable(WwiseObjectType type)
Checks if Wwise object is playable.
Definition: AkWaapiUtilities.cs:865
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:61
AkWaapiUtilities.GetWwiseObjects< T >
static void GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options.
Definition: AkWaapiUtilities.cs:594
AkRadialEmitter.outerRadius
float outerRadius
Definition: AkRadialEmitter.cs:38
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AkAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkAudioListener.cs:27
AkSurfaceReflector.EnableDiffractionOnBoundaryEdges
bool EnableDiffractionOnBoundaryEdges
Switch to enable or disable geometric diffraction on boundary edges for this mesh....
Definition: AkSurfaceReflector.cs:49
AkWaapiUtilities.WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by ...
Definition: AkWaapiUtilities.cs:102
AkWaapiUtilities.Unsubscribe
static void Unsubscribe(uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to ...
Definition: AkWaapiUtilities.cs:1041
AkSurfaceReflector.SetGeometry
void SetGeometry()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.
Definition: AkSurfaceReflector.cs:343
SelectedWwiseObjects
Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiHelper.cs:237
Wamp.WampNotConnectedException
Definition: Wamp.cs:35
AkSpatialAudioEmitter.diffractionMaxPaths
uint diffractionMaxPaths
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:53
AK.Wwise.TypeMigration
Definition: AkWwiseTypeMigration.cs:31
AkSpatialAudioEmitter.drawFirstOrderReflections
bool drawFirstOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:63
ErrorMessage
Used to deserialize WAAPI error messages.
Definition: AkWaapiHelper.cs:199
AkRoomAwareObject.ExitedRoom
void ExitedRoom(AkRoom room)
Called when exiting a room.
Definition: AkRoomAwareObject.cs:101
AK.Wwise.Event.StopMIDI
void StopMIDI(UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:223
AkBank.UnloadBank
void UnloadBank(UnityEngine.GameObject in_gameObject)
Unloads a SoundBank
Definition: AkBank.cs:124
AkTriggerBase.Trigger
delegate void Trigger(UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers.
Wamp.PublishHandler
delegate void PublishHandler(string json)
Publish events are delegates registered with Subscribe.
AkReverbZone.SetReverbZone
void SetReverbZone()
Calls AkReverbZone::SetReverbZone() with this component's properties
Definition: AkReverbZone.cs:94
AkEnvironmentPortal.EnvListWrapper
This enables us to detect intersections between portals and environments in the editor
Definition: AkEnvironmentPortal.cs:90
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkSpatialAudioListener.SpatialAudioListenerList.Remove
bool Remove(AkSpatialAudioListener listener)
Removes listeners from the list
Definition: AkSpatialAudioListener.cs:107
AkRoom.reverbAuxBus
AK.Wwise.AuxBus reverbAuxBus
The reverb auxiliary bus.
Definition: AkRoom.cs:43
AkWaapiUtilities.GetResultDelegate< T >
delegate void GetResultDelegate< T >(T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI...
AkMemBankLoader.LoadLocalizedBank
void LoadLocalizedBank(string in_bankFilename)
Load a language-specific bank from WWW object
Definition: AkMemBankLoader.cs:63
AkBank.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Loads the SoundBank
Definition: AkBank.cs:101
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
Wamp.TimeoutException
Exception thrown during WAMP operations when the timeout is reached.
Definition: Wamp.cs:27
AkSwitch
This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered....
Definition: AkSwitch.cs:29
AkSpatialAudioDebugDraw.drawSecondOrderReflections
bool drawSecondOrderReflections
This allows you to visualize second order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:29
AK.Wwise.Trigger
This type can be used to post triggers to the sound engine.
Definition: AkWwiseTrigger.cs:25
AkGameObj.m_positionOffsetData
AkGameObjPositionOffsetData m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Positio...
Definition: AkGameObj.cs:49
AkSurfaceReflector.SetGeometryInstance
void SetGeometryInstance()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.
Definition: AkSurfaceReflector.cs:369
AkWaapiUtilities.ParseRenameObject
static WwiseRenameInfo ParseRenameObject(string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic.
Definition: AkWaapiUtilities.cs:1078
AkGameObj.GetForward
virtual UnityEngine.Vector3 GetForward()
Definition: AkGameObj.cs:291
AkEventCallbackMsg.sender
UnityEngine.GameObject sender
GameObject from whom the callback function was called
Definition: AkEvent.cs:29
ArgsDisplayName
WAAPI arguments containing an object identfier and name used when deleting an object.
Definition: AkWaapiHelper.cs:88
ArgsRename
WAAPI arguments containing an object identfier and new value used when renaming an object.
Definition: AkWaapiHelper.cs:72
TransportOptions
WAAPI options used to specify the transport ID when subscribing.
Definition: AkWaapiHelper.cs:164
AkRoom
An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoom...
Definition: AkRoom.cs:25
AkWaapiUtilities.ParseObjectInfo
static List< WwiseObjectInfo > ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects...
Definition: AkWaapiUtilities.cs:713
AkSurfaceReflector.SetGeometryFromMesh
static void SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and t...
Definition: AkSurfaceReflector.cs:138
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AkWaapiUtilities.Disconnected
static void Disconnected()
Invoked after the client has disconnected from Wwise authoring.
Definition: AkWaapiUtilities.cs:442
ArgsTransport
WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.
Definition: AkWaapiHelper.cs:131
AkWaapiUtilities.QueueConsumed
static System.Action QueueConsumed
Fired when all commands in the queue have been executed.
Definition: AkWaapiUtilities.cs:52
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25
AkWaapiUtilities.ParseSelectedObjects
static List< WwiseObjectInfo > ParseSelectedObjects(string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiUtilities.cs:1062
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:278
AkEarlyReflections.reflectionsAuxBus
AK.Wwise.AuxBus reflectionsAuxBus
Definition: AkEarlyReflections.cs:32
AkSpatialAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkSpatialAudioListener.cs:30
ak.wwise.ui
Definition: Uri.cs:286
AkReverbZone
This component establishes a parent-child relationship between two Rooms and allows for sound propaga...
Definition: AkReverbZone.cs:27
AkRoomAwareObject.EnteredRoom
void EnteredRoom(AkRoom room)
Called when entering a room.
Definition: AkRoomAwareObject.cs:92
AkWaapiUtilities.OpenWorkUnitInExplorer
static void OpenWorkUnitInExplorer(System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:751
AK.Wwise.State
This type can be used to set Wwise States.
Definition: AkWwiseState.cs:25
AkWaapiUtilities.Delete
static void Delete(System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiComm...
Definition: AkWaapiUtilities.cs:838
AkBank.unloadTriggerList
System.Collections.Generic.List< int > unloadTriggerList
Reserved.
Definition: AkBank.cs:42
AkSpatialAudioEmitter.reflectionsOrder
uint reflectionsOrder
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.
Definition: AkSpatialAudioEmitter.cs:40
ReturnTransport
Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transpo...
Definition: AkWaapiHelper.cs:178
AkWwiseTreeWAAPIDataSource.SubscribeTopics
void SubscribeTopics()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to ke...
Definition: AkWwiseTreeWAAPIDataSource.cs:391
AkWaapiUtilities.QueueCommandWithReturnType< T >
static void QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will des...
Definition: AkWaapiUtilities.cs:548
WaapiKeywords.WwiseObjectTypeStrings
static ReadOnlyDictionary< WwiseObjectType, string > WwiseObjectTypeStrings
Maps WwiseObjectType to strings.
Definition: AkWaapiHelper.cs:464
AkRoomAwareManager
This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.
Definition: AkRoomAwareManager.cs:22
AkRoom.SetReverbZone
void SetReverbZone(AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a ...
Definition: AkRoom.cs:591
WwiseObjectInfoParent
Contains the GUID of the returned object's parent.
Definition: AkWaapiHelper.cs:328
AkEventCallbackMsg
Event callback information. Event callback functions can receive this structure as a parameter
Definition: AkEvent.cs:24
AkEventCallbackMsg.info
AkCallbackInfo info
For more information about the event callback, see the classes derived from AkCallbackInfo.
Definition: AkEvent.cs:26
AkState
This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered....
Definition: AkState.cs:29
AkRoom.PriorityList
Definition: AkRoom.cs:620
AkSurfaceReflector.Mesh
UnityEngine.Mesh Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.
Definition: AkSurfaceReflector.cs:32
AkMemBankLoader.bankName
string bankName
Name of the bank to load
Definition: AkMemBankLoader.cs:28
AkEnvironmentPortal.environments
AkEnvironment[] environments
Definition: AkEnvironmentPortal.cs:32
AkSpatialAudioDebugDraw.drawHigherOrderReflections
bool drawHigherOrderReflections
This allows you to visualize third or higher order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:32
WaapiHelper
Contains a helper function GetWwiseObjectTypeFromString.
Definition: AkWaapiHelper.cs:354
AkRoom.GetID
ulong GetID()
Access the room's ID
Definition: AkRoom.cs:195
AkSurfaceReflector.RemoveGeometry
void RemoveGeometry()
Remove this component's geometry and corresponding instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:390
AkSurfaceReflector.SetGeometryInstance
static void SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction)
Add or update an instance of the geometry by sending the transform of this component to Wwise....
Definition: AkSurfaceReflector.cs:297
AkRoomPortal.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event
Definition: AkRoomPortal.cs:215
AkSurfaceReflector.AssociatedRoom
AkRoom AssociatedRoom
Definition: AkSurfaceReflector.cs:57
AkRoom.roomToneEvent
AK.Wwise.Event roomToneEvent
Wwise Event to be posted on the room game object.
Definition: AkRoom.cs:54
AkMemBankLoader
This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory....
Definition: AkMemBankLoader.cs:22
AkRoom.transmissionLoss
float transmissionLoss
Loss value modeling transmission through walls.
Definition: AkRoom.cs:51
Args
Abstract base class for WAAPI command arguments.
Definition: AkWaapiHelper.cs:36
WaapiKeywords.FolderDisplaynames
static ReadOnlyDictionary< string, string > FolderDisplaynames
Maps root folder names to displayed strings.
Definition: AkWaapiHelper.cs:487
AkReverbZone.ReverbZone
AkRoom ReverbZone
Definition: AkReverbZone.cs:33
AkRoom.priority
int priority
Definition: AkRoom.cs:40
AkSpatialAudioDebugDraw.drawFirstOrderReflections
bool drawFirstOrderReflections
This allows you to visualize first order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:26
AkEnvironment
Use this component to define a reverb zone. This needs to be added to a collider object to work prope...
Definition: AkEnvironment.cs:34
Wamp
WAMP protocol implementation using only strings and regular expressions. This implements only a subse...
Definition: Wamp.cs:24
AkEventCallbackMsg.type
AkCallbackType type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callback...
Definition: AkEvent.cs:32
AkEvent.enableActionOnEvent
bool enableActionOnEvent
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop eve...
Definition: AkEvent.cs:56
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23
AkRoom.RemoveReverbZone
void RemoveReverbZone()
Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and...
Definition: AkRoom.cs:613
AkWaapiUtilities.Subscribe
static void Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their optio...
Definition: AkWaapiUtilities.cs:1015
AkEvent.curveInterpolation
AkCurveInterpolation curveInterpolation
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:53
AkWaapiUtilities.Rename
static void Rename(System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to Rename...
Definition: AkWaapiUtilities.cs:813
AkGameObj.isEnvironmentAware
bool isEnvironmentAware
Is this object affected by Environment changes? Set to false if not affected in order to save some us...
Definition: AkGameObj.cs:36
ReturnWwiseObjects
Generic class to deserialize a WAAPI response containing Wwise objects with custom return options.
Definition: AkWaapiHelper.cs:228
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:150
AkWaapiUtilities.Connected
static System.Action Connected
Fired when the connection is established, should be used by external classes to subscribe to topics t...
Definition: AkWaapiUtilities.cs:47
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34
AkSpatialAudioEmitter.reflectionMaxPathLength
float reflectionMaxPathLength
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Dista...
Definition: AkSpatialAudioEmitter.cs:33
AkInitializer
This script deals with initialization, and frame updates of the Wwise audio engine....
Definition: AkInitializer.cs:38
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:88
AkSpatialAudioListener.SpatialAudioListenerList.Add
bool Add(AkSpatialAudioListener listener)
Uniquely adds listeners to the list
Definition: AkSpatialAudioListener.cs:85
AkWwiseTrigger
This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered....
Definition: AkWwiseTrigger.cs:28
AkEmitterObstructionOcclusion
Completely obstructs/occludes the emitter of the current game object from its listeners if at least o...
Definition: AkEmitterObstructionOcclusion.cs:23
AkSpatialAudioEmitter.diffractionMaxEdges
uint diffractionMaxEdges
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:50
AkSpatialAudioEmitter.drawHigherOrderReflections
bool drawHigherOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:69
AkWaapiUtilities.GetWwiseObjectAndDescendants< T >
static void GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to ...
Definition: AkWaapiUtilities.cs:628
AkRoom.roomToneAuxSend
float roomToneAuxSend
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones...
Definition: AkRoom.cs:59
AkEvent.soundEmitterObject
UnityEngine.GameObject soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same obj...
Definition: AkEvent.cs:81
WwiseObjectInfo
Class containing the information returned by a WAAPI request for an object.
Definition: AkWaapiHelper.cs:338
AkEarlyReflections.reflectionsVolume
float reflectionsVolume
Definition: AkEarlyReflections.cs:39
AkRoomPortal.MAX_ROOMS_PER_PORTAL
const int MAX_ROOMS_PER_PORTAL
AkRoomPortals can only connect a maximum of 2 rooms.
Definition: AkRoomPortal.cs:26
AkAmbientLargeModePositioner
Use this component to add a Large Mode position to any AkAmbient in a Scene.
Definition: AkAmbientLargeModePositioner.cs:24
AkRoomManager
This manager tracks AkRoomPortals and the rooms that they connect (front and back room).
Definition: AkRoomManager.cs:22
AkReverbZone.RemoveReverbZone
static void RemoveReverbZone(AkRoom reverbZone)
Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms,...
Definition: AkReverbZone.cs:79
WaapiKeywords.typeStringDict
static ReadOnlyDictionary< string, WwiseObjectType > typeStringDict
Maps strings to WwiseObjectType.
Definition: AkWaapiHelper.cs:501
AkWaapiUtilities.IsConnected
static bool IsConnected()
Check whether the client is currently connected.
Definition: AkWaapiUtilities.cs:179
AkWaapiUtilities.GetProject< T >
static void GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project.
Definition: AkWaapiUtilities.cs:701
AkSpatialAudioDebugDraw
Add this script on a GameObject to print Spatial Audio paths.
Definition: AkSpatialAudioDebugDraw.cs:23
AkRoomPortalObstruction
Completely obstructs the spatial audio portal of the current game object from the spatial audio liste...
Definition: AkRoomPortalObstruction.cs:24
AkWaapiUtilities.QueueCommand
static void QueueCommand(string uri, string args, string options)
Use this function to enqueue a command with no expected return object.
Definition: AkWaapiUtilities.cs:533
AK.Wwise.IMigratable
Definition: AkWwiseTypeMigration.cs:25
AkWaapiUtilities.GetWwiseObjectAndAncestors< T >
static void GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy....
Definition: AkWaapiUtilities.cs:613
AkRoomPortal
An AkRoomPortal can connect two AkRoom components together.
Definition: AkRoomPortal.cs:24
AkReverbZone.ParentRoom
AkRoom ParentRoom
Definition: AkReverbZone.cs:39
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:117
Options
Abstract base class for WAAPI command options.
Definition: AkWaapiHelper.cs:141
AkEnvironmentPortal.envList
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class
Definition: AkEnvironmentPortal.cs:95
AkEnvironmentPortal
Use this component to define an area that straddles two different AkEnvironment's zones and allow mix...
Definition: AkEnvironmentPortal.cs:23
AK.Wwise.BaseType
This type represents the base for all Wwise Types that require a GUID.
Definition: AkWwiseBaseType.cs:25
AkReverbZone.RemoveReverbZone
void RemoveReverbZone()
Calls AkReverbZone::RemoveReverbZone() with this component's properties
Definition: AkReverbZone.cs:103
ErrorDetails
Used to deserialize details in WAAPI error messages.
Definition: AkWaapiHelper.cs:209
WaqlArgs
WAAPI arguments containing a WAQL string.
Definition: AkWaapiHelper.cs:44
AkRoomAwareObject
This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms,...
Definition: AkRoomAwareObject.cs:28
AkWaapiUtilities.StopAllTransports
static void StopAllTransports()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransp...
Definition: AkWaapiUtilities.cs:989
AkWaapiUtilities.SubscriptionInfo
Class used to store information about a specific subscription.
Definition: AkWaapiUtilities.cs:118
AkRadialEmitter.innerRadius
float innerRadius
Definition: AkRadialEmitter.cs:44
AkWaapiUtilities.GetResultListDelegate< T >
delegate void GetResultListDelegate< T >(List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAA...
ak
URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK docume...
Definition: Uri.cs:20
AK.Wwise.AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy.
Definition: AkWwiseAuxBus.cs:25
AK.Wwise.Event.Post
uint Post(ulong gameObjectId)
Posts this Event on a GameObject ID.
Definition: AkWwiseEvent.cs:143
AkSpatialAudioListener.TheSpatialAudioListener
static AkAudioListener? TheSpatialAudioListener
Returns the "single" spatial audio listener.
Definition: AkSpatialAudioListener.cs:39
WwiseChildModifiedInfo
Used to deserialize information published on the ak.wwise.core.@object.childAdded and ak....
Definition: AkWaapiHelper.cs:264
WaapiKeywords
Contains fields for specific WAAPI keywords.
Definition: AkWaapiHelper.cs:377
AkBank
Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified...
Definition: AkBank.cs:27
WwiseObjectInfoJsonObject
Used to deserialize information from a request for a Wwise object. Implements an implicit cast to Wwi...
Definition: AkWaapiHelper.cs:284
AkAmbient
Use this component to attach a Wwise Event to any object in a scene. The sound can be started at vari...
Definition: AkAmbient.cs:47
AkEarlyReflections
Set an early reflections auxiliary bus and send volume for a particular game object.
Definition: AkEarlyReflections.cs:25
AkWaapiUtilities.GetStatusString
static string GetStatusString()
Returns a rich text string representing the current WAAPI connection status.
Definition: AkWaapiUtilities.cs:481
AkBank.saveDecodedBank
bool saveDecodedBank
Save the decoded SoundBank to disk for faster loads in the future
Definition: AkBank.cs:39
AkWaapiUtilities.OpenSoundBankInExplorer
static void OpenSoundBankInExplorer(System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:762
ArgsCommand
WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities....
Definition: AkWaapiHelper.cs:103
AkEvent.actionOnEventType
AkActionOnEventType actionOnEventType
Replacement action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:50
AkWaapiUtilities.ParseChildAddedOrRemoved
static WwiseChildModifiedInfo ParseChildAddedOrRemoved(string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise....
Definition: AkWaapiUtilities.cs:1090
AkSurfaceReflector.EnableDiffraction
bool EnableDiffraction
Switch to enable or disable geometric diffraction for this mesh.
Definition: AkSurfaceReflector.cs:45
AK.Wwise.Event.ExecuteAction
void ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject.
Definition: AkWwiseEvent.cs:175


Wwise Unity Integration Documentation: 방해와 차단

방해와 차단

Unity에서는 사운드를 방해하거나 차단할 수 있습니다. 다음 중 하나를 사용할 수 있습니다.

  • Spatial Audio Diffraction(공간 음향 회절).
    • Spatial Audio 추가 기능들 섹션의 C. 회절 을 참고하세요
  • 다음 섹션에서 다루는 간단한 방해 차단 컴포넌트:
    • A. 이미터 방해/차단
    • B. 포털 방해

A. 이미터 방해/차단

Unity에서 GameObject에 AkEmitterObstructionOcclusion 컴포넌트를 추가하면 이미터를 방해하거나 차단할 수 있습니다. 이미터와 리스너 사이의 경로에 오브젝트가 있을 경우 해당 컴포넌트가 방해/차단 값을 1로 SetObjectObstructionAndOcclusion()을 호출합니다. 맵이 공간 음향을 사용하지 않을 경우 (AkRoom 컴포넌트가 없을 경우) AkEmitterObstructionOcclusion 컴포넌트가 차단을 사용하게 됩니다. 공간 음향 씬에서는 이와 동일한 컴포넌트가 공간 음향 리스너에만 방해를 사용합니다. 이 공간 음향 리스너는 AkSpatialAudioListener 컴포넌트를 가진 GameObject를 말합니다. 이미터 방해는 공간 음향 리스너와 동일한 공간에 있는 이미터에 적용됩니다.

AkEmitterObstructionOcclusion component

방해나 차단이 원하는 오브젝트에 실행되도록 하려면 레이어 마스크를 사용하세요. 예를 들어 플레이어 오브젝트에 레이어를 지정하고 AkEmitterObstructionOcclusion 컴포넌트에서 제외시키면 리스너로 소리를 방해하거나 차단하지 않습니다.

Layer Mask options for the Ak Emitter Obstruction Occlusion component

B. 포털 방해

포털을 통해 방사되는 사운드도 방해할 수 있습니다. Spatial Audio Diffraction을 사용하지 않을 경우 AkRoomPortalObstruction 컴포넌트를 AkRoomPortal이 있는 GameObject에 사용할 수 있습니다. 포털과 공간 음향 리스너 사이의 경로에 오브젝트가 있을 경우 해당 컴포넌트가 방해 값을 1로 SetObjectObstructionAndOcclusion()을 호출합니다.

AkRoomPortalObstruction component

Portal이 연결되는 Room의 메시에 AkRoomPortalObstruction 컴포넌트가 있을 경우 방해가 일어납니다. Surface Reflector를 사용할 경우 이 리플렉터도 포털의 열린 부분을 방해할 수 있습니다. 그렇기 때문에 이 메시와 Surface Reflector를 서로 다른 레이어에 배치하여 AkRoomPortalObstruction 컴포넌트의 Layer Mask에서 제외시켜야 합니다.

Layer Mask options for the Ak Room Portal Obstruction component


Wwise Unity Integration Documentation: Unity용 Wwise Addressables Package

Unity용 Wwise Addressables Package

Unity Addressables에 관하여

Unity Addressables는 플레이어와는 별도로 에셋을 패키징하기 위해서 AssetBundles를 중심으로 구축된 시스템입니다. 이 시스템은 외부 서버에 외부 에셋이 저장되는 DLC 맥락에서 특히 유용합니다.

이제 막 Addressables를 사용하기 시작한 분들의 경우 공식 설명서와
교육 자료를 통해 이에 대해 익힐 것을 권장합니다.

여기에서 Wwise Unity Addressables 패키지를 설정을 시작해보세요:

  • Wwise Unity Addressables 패키지 설치하기
  • Packaging DLC 기본 튜토리얼

다음 섹션에서는 Wwise Addressables 패키지가 어떻게 작동하는지 설명합니다:

  1. Addressables 시스템의 특징
  2. 자주 겪는 문제 & 제한 사항
  3. Wwise Addressable 샘플
  4. Wwise Addressable Assets 설명
    1. SoundBank와 AddressableSoundBank
    2. Addressable Bank Manager
    3. WwiseBankReference
    4. Wwise Asset Importer (Wwise 에셋 임포터)
    5. 스트리밍 미디어
주의: 이 패키지는 실험적으로 간주해 주세요. Addressables 지원은 Unity 통합의 새로운 기능이며 변경될 수 있습니다.
주의: Unity 2018은 지원되지 않습니다. Unity 2018에서 외부 패키지를 사용할 경우 문제가 발생할 수 있기 때문에 2019년보다 오래된 Unity 버전에서 이 패키지가 올바르게 작동할 것 이라고 보장할 수 없습니다.

Addressables 시스템의 특징

Addressables 시스템은 고려해야 할 다음 특징을 가지고 있습니다:

  • Addressables을 사용한 에셋 로드하기는 본질적으로 비동기적입니다: 이 부분은 SoundBank 로드하기와이벤트 게시하기가 동일한 트리거에 연결되어 있을 경우에 문제를 일으킬 수 있습니다. 그렇기 때문에 정확한 이벤트 타이밍이 특히 중요할 경우 연관된 Event가 트리거될 수 있기 전에 SoundBank를 먼저 로드하는 것이 좋습니다. Init Soundbank는 씬에 있는 모든 다른 SoundBank 이전에 로드되어야 하기 때문에 특정 사례입니다. Init SoundBank 에셋이 원격으로 업데이트될 경우 Addressables를 사용하여 웹 서버로부터 새로운 Init SoundBank가 반드시 먼저 페치되어야 하기 때문에, 씬이 시작될 때 다른 SoundBanks를 로드하는 데에 약간의 추가 딜레이가 있을 수 있습니다.
  • Addressable 에셋은 씬 안에서 직접 참조되지 않아야 합니다: Addressable 에셋은 Addressables 시스템을 사용하여 씬에서 동적으로 로드되도록 고안되었습니다. 씬에서 직접 참조되는 에셋은 씬의 AssetBundle로 빌드 되며 Addressables를 통해 로드되지 않습니다. 씬에 직접 에셋을 배치하고 또한 이 에셋을 Addressables를 사용하여 패키징할 경우, 해당 씬의 AssetBundle과 Addressable 그룹의 AssetBundle에 각 하나씩 두 개의 다른 에셋 복사본이 존재하게 됩니다.

자주 겪는 문제 & 제한 사항

  • 프로젝트의 모든 플랫폼은 반드시 동일한 루트 Generated SoundBanks Path를 공유해야 합니다.
  • Unity 프로젝트에서 Generated SoundBank Path를 설정할 경우 External Source의 출력 경로가 자동으로 변경되지 않습니다.
  • Decoded SoundBank(디코딩된 사운드뱅크) 저장 및 로드하기가 아직 지원되지 않습니다.
  • Prepared Event(준비된 이벤트)가 지원되지 않습니다.
  • External Source(외부 음원)이 지원되지 않습니다.

Wwise Addressable 샘플

Wwise Addressable Samples 페이지는 Wwise Addressable Asset을 관리하는 데 도움이 되는 코드 샘플에 대한 추가 정보를 제공합니다.

Wwise Addressable Assets 설명

Wwise Asset Importer (Wwise 에셋 임포터)

생성 시 .bnk와 .wem 파일이 WwiseBankImporter와 WwiseStreamingAssetImporter 클래스에 의해 처리됩니다. 이 스크립트는 파일의 이진 파일을 담은 에셋을 생성합니다. 그런 다음 저희 커스텀 에셋인 포스트프로세서 WwiseBankPostProcess가 새로운 에셋을 해당 플랫폼의 Addressables 그룹으로 추가합니다. 각 플랫폼의 Init SoundBank는 자체적인 Addressables 그룹에 추가됩니다. Init Bank가 별도의 장소에 추가되는 이유는 출시 후에 프로젝트가 변경될 경우 (예: 새로운 오디오 버스 추가) 이 뱅크가 다시 반드시 업데이트되어야 하기 때문입니다. Init SoundBank를 자체적인 어드레서블 AssetBundle 안에 패키징하면, 호스팅 서비스로부터 이 에셋의 새로운 버전을 페치하는 데에 걸리는 시간을 최소화할 수 있습니다. 에셋이 추가되는 addressable group과 에셋에 적용되는 레이블을 사용자 지정하려면 Wwise Addressable Samples 페이지를 참조하세요.

SoundBank와 AddressableSoundBank

또한 에셋 포스트프로세서는 프로젝트의 각 SoundBank에 대해 WwiseAddressableSoundBank를 생성합니다. 이 에셋은 플랫폼의 이름을 해당 SoundBank와 스트리밍 미디어 에셋으로 매핑하는 사전(dictionary)을 담고 있습니다.

  • WwiseAddressableSoundBank는 Generated SoundBanks 폴더의 최상위 계층 폴더에 있습니다.
  • WwiseAddressableSoundBank 클래스는 AssetReferenceT를 사용하여 SoundBank와 미디어 파일을 가리킵니다.
  • 프로젝트를 빌드할 때 WwiseAddressableSoundBank의 Current Platfrom Assets 입력란이 대상 빌드 플랫폼으로 설정됩니다.
주의: WwiseAddressableSoundBank에서 참조되는 SoundBank와 스트리밍 미디어는 소프트 참조입니다. 이 SoundBank와 스트리밍 미디어는 Addressables를 사용하여 로드되며 반드시 Addressables 그룹 안으로 패키징되어야 합니다.
주의: 실수로 WwiseAddressableSoundBank를 삭제할 경우, 연관된 SoundBank를 삭제하고 재생성해야 새로운 WwiseAddressableSoundBank를 만들고 올바르게 참조를 구성할 수 있습니다.

Init Bank Holder

Init SoundBank용 WwiseAddressableSoundBank가 생성되면 씬에 있는 WwiseGlobal 게임 오브젝트에 InitBankHolder 컴포넌트가 추가됩니다. 이 컴포넌트는 AddressableBankManager가 쉽게 찾을 수 있도록 WwiseAddressableSoundBank를 저장하는 역할을 합니다.

Addressable Bank Manager

Wwise Addressables를 사용할 경우 사운드뱅크를 메모리로 로드/언로드하는 작업이 AkAddressableBankManager에 의해 처리됩니다. 이 클래스는 로딩되고 있고 로드된 AddressableSoundBank로의 참조를 저장하여 Init SoundBank가 항상 먼저 로드될 수 있게 해줍니다. 해당 SoundBank가 다 로드되기 전에 AkEvent가 트리거될 경우, 이 클래스는 트리거된 호출의 매개 변수를 저장하고 SoundBank가 로드된 후에 이벤트를 다시 트리거합니다.

SoundBank가 로드되면 현재 플랫폼에 해당하는 SoundBank 에셋이 Addressables를 사용하여 로드됩니다. SoundBank가 로드되면 사운드뱅크 데이터가 고정되며 AkSoundEngine.LoadBankMemoryCopy()를 사용하여 메모리의 복사본이 사운드 엔진으로 로드됩니다.

에디터에서 재생 모드에 있을 경우 어드레서블즈 대신 AssetDatabase를 사용하여 SounBanks가 동기적으로 로드됩니다. 비동기적 로딩은 빌드된 게임에서만 시험할 수 있습니다.

WwiseBankReference

WwiseBankReference 클래스는 Ak.Wwise.Bank 컴포넌트에 대한 저희의 커스텀 인스펙터에서 사용됩니다. WwiseBankReference 는 WwiseAddressableSoundBank 로의 하드 참조를 담습니다. 이 참조는 AkAssetUtilities.AddressableBankUpdated 델리게이트를 통해 WwiseAddressableSoundBank Asset이 생성되었을 때에 업데이트됩니다. WwiseBankReference 가 WwiseAddressableSoundBank 다음에 생성되면 SoundBanks 폴더에서 Bank 이름과 일치하는 WwiseAddressableSoundBank 에셋을 검색합니다. 일련화된 WwiseBankReference는 Assets\Wwise\ScriptableObjects\SoundBank 안에 저장됩니다.

참고: 게임 오브젝트에 의해 직접 참조되는 에셋은 게임 오브젝트와 함께 패키징됩니다. AkBank Component는 WwiseBankReference로의 하드 참조를 담고 있으며, WwiseBankReference는 해당 WwiseAddressableSoundBank로의 하드 참조를 담고 있습니다. AkBank 컴포넌트가 있는 GameObject를 Addressables 그룹 안에 넣을 경우 WwiseBankReference와 WwiseAddressableSoundBank가 이와 함께 패키징됩니다 (명시적으로 이를 그룹에 추가할 필요 없이).

스트리밍 미디어

또한 스트리밍 미디어 (.wem 파일)도 WwiseBankImporter 스크립트에 의해 처리됩니다. WwiseAddressableSoundBank는 해당 뱅크와 연관된 플랫폼 전용 스트리밍 미디어 에셋으로의 참조 목록을 담고 있습니다. 뱅크가 로드되면 Addressables를 통해 미디어 에셋이 로드되며 Application.persistentDataPath 폴더로 복사됩니다. 동일한 이름을 가진 파일이 이미 폴더에 있을 경우 해쉬가 비교됩니다. 파일이 다를 경우 AssetBundle에서의 파일로 덮어쓰게 됩니다.


Wwise Unity Integration Documentation: Wwise Unity Addressables 패키지 설치하기

Wwise Unity Addressables 패키지 설치하기

목차

  • Unity Package Manager와 GitHub에서 Wwise Addressables Package 설치하기
    • Wwise Unity Addressables 패키지 업데이트하기
    • Unity Addressables Package와의 호환성
    • Unity 2018 추가 단계
  • Wwise Addressables 패키지 구성 및 빌드
  • 프로젝트 빌드하기
  • Wwise Addressables 패키지 제거하기

Unity Package Manager와 GitHub에서 Wwise Addressables Package 설치하기

Wwise Addressables Package의 공식 저장소는 https://github.com/audiokinetic/WwiseUnityAddressables입니다.

  • Unity Package Manager를 열어서 '+' 아이콘을 클릭하고 Add package from git URL...을 선택하세요.
  • 텍스트 입력란에 https://github.com/audiokinetic/WwiseUnityAddressables.git을 복사해 넣고 Add를 클릭하세요.

Git 저장소에 호스트 된 패키지 사용하기에 관한 더 많은 정보는 Unity documentation에서 찾을 수 있습니다.

참고: "No 'git' executable was found(git 실행 파일을 찾을 수 없었음)"라는 메시지가 담긴 오류가 생길 경우, 시스템 환경에 git.exe를 포함하는 폴더를 추가해야 하며 변경 사항을 적용하기 위해 시스템을 다시 시작해야 할 수 있습니다.
참고: 또한 Wwise 어드레서블스 함수가 올바르게 작동하려면 Unity Addressables Package가 반드시 프로젝트에 추가되어야 합니다. 패키지는 Wwise Addressables Package의 종속으로 열거되며 자동으로 설치되어야 합니다.

Wwise Unity Addressables 패키지 업데이트하기

새로운 Wwise 버전으로 업데이트할 때, Wwise Unity Addressables 패키지 업데이트에 앞서 Unity Integration을 업데이트하길 권장합니다.

Wwise Unity Addressables Package 업데이트는 Wwise의 마이너 또는 메이저가 출시될 때 함께 출시되지만, 반드시 동일한 빈도로 출시되지는 않습니다. 각 업데이트는 함께 출시되는(그리고 테스트된) Wwise의 버전이 태그돼있습니다. 중요한 변경 사항이 없는 한, 새로운 Unity Integration 버전과 기존 Wwise Unity Addressable 패키지 버전이 호환될 수 있도록 유지하고 있습니다. 예를 들어 Wwise Unity 통합 버전 2021.1.7 및 그 이상의 새로운 버전은 21.1.7 태그 이전의 Wwise Unity Addressable 패키지 버전과 호환되지 않는 방식입니다 (또는 그 반대). 각 GitHub 태그에는 변경 사항 및 호환 버전 정보를 설명하는 저장소 릴리즈 페이지의 해당 항목이 있습니다.

Unity Addressables Package와의 호환성

Wwise Unity Addressables Package는 Unity Addressables 패키지의 최신 버전과 호환됩니다. 이전 버전과도 호환되지만, 1.16.0 이전 버전에서는 테스트를 거치지 않았습니다. 기본적으로 Wwise Unity Addressables Package는 Unity Integration에서 지원하는 최소 Unity 버전에 대해 Addressables 패키지의 가장 최근 "확인된" 버전을 사용합니다. 지원 되는 Unity 버전 목록은 릴리즈 노트 - Wwise Unity 통합 2023.1.1.8417.3007 를 참고하세요.

Unity 2018 추가 단계

Unity 2018.x를 사용할 경우 Project Settings > Player > Other Settings에 있는 Scripting Define Symbols에 AK_WWISE_ADDRESSABLES와 UNITY_ADDRESSABLES를 추가하세요.

경고: 이 패키지는 Unity 2018에서 공식적으로 지원되지 않습니다. 여러분의 책임 하에 사용하세요.

Wwise Addressables 패키지 구성 및 빌드

1 단계: Project Settings > Wwise Editor > Generated SoundBanks Path에서 생성된 SoundBank의 대상 폴더를 설정하세요.

주의: SoundBank가 올바르게 가져와지려면 이 폴더가 반드시 Assets 폴더 안에 있어야 합니다.
  • 이 예시에서는 대상 폴더를 Assets\WwiseData\Banks로 지정했습니다.
  • 이 경로를 변경하면 Wwise에서 출력 대상 폴더가 자동으로 변경됩니다.
    • Wwise Authoring이 열린 채로 이 부분을 변경할 경우 프로젝트를 다시 로드하라는 대화창이 뜹니다.

2 단계: Wwise Authoring 안에서나 Wwise Picker를 사용하여 SoundBank를 생성하세요.

  • 이 시점에서 .bnk 와 .wem 파일의 커스텀 에셋 임포터(custom asset importer)는 생성된 SoundBank와 스트리밍 미디어 파일에 대한 Unity 에셋을 생성합니다.
  • 메타데이터 파일과 플랫폼 전용 그룹은 AddressableAssetsData 폴더에서 자동으로 생성됩니다.
  • Generated SoundBanks Path에서 파일을 확인하여 에셋이 올바르게 가져와졌는지 확인할 수 있습니다.
  • 더 자세한 설명은 Wwise Addressable Assets 설명 을 참고하세요.

3 단계: Window > Asset Management > Addressables > Groups를 클릭하세요. Wwise Addressables Groups 창이 열립니다.

기본적으로, 플랫폼 전용 SoundBank 에셋이 담긴 각 배포 플랫폼마다 한 그룹이 생성됩니다. 각 배포 플랫폼의 Init SoundBank의 경우 이를 담은 별도의 그룹이 생성됩니다

씬에서 WwiseGlobal 오브젝트를 확인하면 Init Bank Holder 컴포넌트가 추가된 것을 확인할 수 있습니다.

4 단계: Addressables에 대한 Wwise Build 스크립트를 생성하세요.

  • 이 스크립트는 기본 빌드 스크립트와 함께 AddressableAssetsData/DataBuilders 안에 배치할 것을 권장해드립니다.
  • 브라우저 안을 우클릭하고 Create > Addressables > Content Builders > Wwise Build Script를 선택하세요.
  • 그러면 BuildScriptWwisePacked 라는 에셋이 생성됩니다.

5 단계: Addressables 설정을 확인하세요.

  • 기본적으로 이 설정은 AddressableAssetsData/AddressableAssetSettings 안에서 찾을 수 있습니다
  • Groups 창에서: Tools > Inspect System Settings
  • 에디터에서: Window > AssetManagement > Addressables> Settings

6 단계: BuildScriptWwisePacked를 Addressables 빌드 스크립트에 추가하세요. AddressableAssetSettings의 인스펙터에서, 4 단계에서 만든 BuildScriptWwisePacked를 Build and Play Mode 스크립트에 추가하세요.

프로젝트 빌드하기

Wwise Build Script를 사용하여 Groups 창에서 Addressable 에셋 번들을 빌드하세요. 이렇게 하면 모든 일반 에셋 번들(예: Default Local Group) 뿐만 아니라 플랫폼 전용 에셋 번들이 Library\com.unity.Addressables\StreamingAssetsCopy\aa\<플랫폼 이름> 안에 생성됩니다.

주의: Wwise Build Script는 WwiseData 그룹 스키마의 Include in Build 속성을 변경합니다. 그룹의 이름에 WwiseData가 들어 있을 경우, 해당 이름에도 대상 빌드 플랫폼 이름이 담겨 있을 경우에만 포함됩니다. 이 작동 방식은 BuildScriptWwisePacked.cs 스크립트에서 변경할 수 있습니다. Include in Build 속성에 어떤 그룹이 포함될지를 직접 제어하려면, 기본 빌드 스크립트를 사용하면 됩니다.

어드레서블 에셋이 빌드되면, 프로젝트를 평소대로 빌드할 수 있습니다.

주의: 프로젝트에 새로운 SoundBank를 변경하거나 추가할 경우에 Addressable 그룹을 다시 빌드해야 합니다. 또한 플랫폼을 전환한 후에 Addressable 그룹을 다시 빌드해야 한다는 것을 기억하세요.

빌드 폴더에서:

  • Addressable 에셋 번들이 StreamingAssets\aa\ 로 복사됩니다.

Wwise Addressables 패키지 제거하기

이 패키지를 제거할 경우 Wwise 통합이 올바르게 작동하도록 하기 위해 몇 가지 추가 단계가 필요합니다.

  • Unity assets 폴더에서 생성된 SoundBank를 담은 폴더를 삭제하세요.
  • Unity 패키지 매니저를 사용하거나 <UnityProject>\Packages\manifest.json 파일에서 해당 줄을 삭제하여 패키지를 삭제하세요.
  • Wwise Project Settings에서 SoundBank Paths를 Assets 폴더 밖의 경로로 설정하세요.
  • SoundBank를 재생성하세요.
  • Unity Addressables 패키지를 여전히 사용할 경우, Addressables 그룹을 반드시 비워주세요.
참고: Unity 2018을 사용할 경우 Project Settings > Player > Other Settings에서 AK_WWISE_ADDRESSABLES와 UNITY_ADDRESSABLES Scripting Define Symbols를 반드시 제거하세요.


Wwise Unity Integration Documentation: Wwise Addressable Samples

Wwise Addressable Samples

목차

  • The Wwise 어드레서블 에셋 메타데이터 Preserver
    • 작동 원리
    • 예제 코드

The Wwise 어드레서블 에셋 메타데이터 Preserver

어드레서블 Wwise 에셋으로 작업할 때 WwiseAddressableBank 에셋을 최신 상태로 유지하는 가장 쉬운 방법은 생성된 Soundbank 폴더를 삭제하고 Soundbank를 재생성하는 것입니다. 어드레서블 에셋을 삭제하면 에셋이 삭제될 때 어드레서블 그룹의 내용이 지워지므로 에셋을 다시 가져올 때 상위 그룹과 레이블이 손실됩니다. Wwise Unity Addressables 패키지에 포함된 이 샘플 스크립트는 상위 그룹 및 레이블과 같은 어드레서블 에셋 메타데이터를 보존하는 기능을 제공합니다.

작동 원리

손실된 그룹 및 레이블을 복원하는 데 도움이 되도록 활성화할 수 있는 설정을 추가했습니다. Unity Project Setting-Wwise Addressables에서 찾을 수 있습니다.. 활성화되면 메타데이터의 대상 폴더를 지정할 수 있습니다. 이 폴더는 Unity 프로젝트의 에셋 폴더 내에 있어야 합니다.

WwiseAssetMetadataPreserver 스크립트는 Assets/Wwise/Addressables 아래에 메뉴 트리거를 추가하여 프로젝트에 있는 모든 Wwise 어드레서블 에셋의 메타데이터를 저장합니다. 트리거되면 어드레서블 각 Wwise 에셋에 대해 AddressableMetadata 자산이 생성되어 상위 그룹 및 레이블의 이름을 직렬화(serializing)합니다. 스크립트는 또한 WwiseBankPostProcess.GetAssetMetadataDelegate 함수에 자체 등록합니다. 이 델리게이트는 WwiseBankPostProcess 커스텀 임포터(Unity 프로젝트에 추가될 때 .bnk 및 .wem 파일 임포트)로 임포트할 때 애셋의 필드를 설정하는 데 사용한 메타데이터 구조를 외부 코드에서 채울 수 있도록 합니다.

이 두 가지 메커니즘을 통해 에셋 메타데이터는 정리를 수행하기 전에 직렬화(serialized)할 수 있으며 사운드뱅크를 생성한 후 에셋을 다시 가져올 때 에셋에 다시 적용됩니다.

참고:

이 스크립트는 이 작업을 수행할 수 있는 방법의 예시입니다. 프로덕션 요구 사항에 더 잘 맞는 고유한 메타데이터 필러(metadata filler)를 구현하는 것이 더 관련성이 있음을 알 수 있습니다.

예제 코드

#if AK_WWISE_ADDRESSABLES && UNITY_ADDRESSABLES
using UnityEditor.AddressableAssets;
using UnityEditor.AddressableAssets.Settings;
using System.Collections.Generic;
using UnityEditor;
using UnityEngine;
using System.IO;
namespace AK.Wwise.Unity.WwiseAddressables
{
/*
이 클래스는 Wwise 어드레서블 에셋 그룹과 레이블 메타데이터를 보존하고 복원하는 기능을 제공합니다.
이 정보는 에셋이 삭제되면 손실되며 Wwise 어드레서블 에셋 폴더를 지우는 것은 문제가 발생한 WwiseAddressableSounbanks를 복구하는 가장 간단한 방법입니다.
이 클래스는 완전한 솔루션이 아니라 이 기능을 구현하는 방법에 대한 예시입니다.
*/
[InitializeOnLoad]
class WwiseAddressableAssetMetadataPreserver
{
static WwiseAddressableAssetMetadataPreserver()
{
if (AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver)
{
BindMetadataDelegate();
}
}
//Sets the GetAssetMetadataDelegate on the WwiseBankPostProcess AssetPostProcessor (.bnk 및 .wem 파일 가져오기를 처리합니다.)
public static void BindMetadataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate += GetMetadata;
}
//Unset the delegate (기능이 비활성화된 경우)
public static void UnbindMetaDataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate -= GetMetadata;
}
//그룹과 레이블을 추적하는 각 어드레서블 wwise 에셋에 대해 AddressableMetadata 에셋을 만듭니다.
//메타데이터 에셋은 wwise 에셋과 일치하는 계층 구조의 자체 폴더에 생성됩니다.
//폴더 계층 및 에셋 이름은 가져올 에셋을 일치시키는 데 사용됩니다.
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Serialize addressable asset metadata")]
public static void PreserveAllWwiseAssetMetadata()
{
AddressableAssetSettings addressableSettings = AddressableAssetSettingsDefaultObject.Settings;
foreach (AddressableAssetGroup group in addressableSettings.groups)
{
foreach (AddressableAssetEntry assetEntry in group.entries)
{
if (assetEntry.MainAsset)
{
if (assetEntry.MainAsset.GetType().IsSubclassOf(typeof(WwiseAsset)))
{
CreateMetadataAsset(assetEntry.AssetPath, assetEntry.labels, group.name);
}
}
}
}
}
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Preserve addressable asset metadata", true)]
public static bool ValidatePreserveAllWwiseAssetMetadata()
{
return AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver;
}
//필요한 하위 폴더와 메타데이터 자산 생성
public static void CreateMetadataAsset(string assetPath, HashSet<string> assetLabels, string groupName)
{
string soundbankPath = assetPath.Replace(AkAssetUtilities.GetSoundbanksPath(), "");
var splitBankPath = soundbankPath.Split('/');
AddressableMetadata metaDataAsset = ScriptableObject.CreateInstance<AddressableMetadata>();
metaDataAsset.labels = new List<string>(assetLabels);
metaDataAsset.groupName = groupName;
var rootPath = AkAddressablesEditorSettings.Instance.MetadataPath;
if (!Directory.Exists(Path.Combine(Application.dataPath, rootPath)))
{
UnityEditor.AssetDatabase.CreateFolder("Assets", rootPath);
}
for (int i = 1; i < splitBankPath.Length - 1; i++)
{
if (!Directory.Exists(Path.Combine(Application.dataPath, Path.Combine(rootPath, splitBankPath[i]))))
{
AssetDatabase.CreateFolder(Path.Combine("Assets", rootPath), splitBankPath[i]);
}
rootPath = Path.Combine(rootPath, splitBankPath[i]);
}
string assetMetadataPath = Path.Combine("Assets", rootPath, Path.GetFileNameWithoutExtension(assetPath) + ".asset");
AddressableMetadata oldAsset = AssetDatabase.LoadAssetAtPath<AddressableMetadata>(assetMetadataPath);
if (oldAsset)
{
if (!metaDataAsset.IsDifferent(oldAsset))
{
return;
}
}
UnityEditor.AssetDatabase.CreateAsset(metaDataAsset, assetMetadataPath);
}
//플랫폼과 언어를 기반으로 메타데이터 에셋이 어디에 위치해야 하는지 알고 있습니다.
public static AddressableMetadata FindMetadataAsset(string assetName, string platformName, string languageName)
{
string MetadataAssetPath;
if (languageName !="SFX")
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, languageName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
else
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
return AssetDatabase.LoadAssetAtPath<AddressableMetadata>(MetadataAssetPath);
}
// .bnk 및 .wem 파일을 가져올 때 호출됩니다. 프로젝트에서 기존 메타데이터 오브젝트를 찾아 로드하려고 시도합니다.
public static bool GetMetadata(string assetName, string platformName, string languageName, ref AddressableMetadata metaData )
{
AddressableMetadata asset = FindMetadataAsset(assetName, platformName, languageName);
if ( asset )
{
metaData = asset;
return true;
}
return false;
}
}
}
#endif


Wwise Unity Integration Documentation: 문제 해결

문제 해결
  • Wwise Component/Type(컴포넌트/유형)이 오래되거나 모순된 데이터를 표시함
  • 설치 후 컴파일링 오류
  • Unity 콘솔에 있는 DllNotFoundException
  • 사운드 누락
  • Wwise Profiler에 연결할 수 없음
  • Unity 콘솔에서 Error during installation - Access to the path is denied 출력
  • Mac에서 Wwise의 SoundBank 생성 중 오류 - Cannot write to Wwise_IDs.h
  • Error: Plugin Not Registered
  • Mac에서 Unity Console에 'Multiple plugins with the same name'
  • Google Play Services가 설치된 프로젝트에 Wwise를 통합하거나 마이그레이션할 수 없음

Wwise Component/Type(컴포넌트/유형)이 오래되거나 모순된 데이터를 표시함

AkAmbient나 AkState와 같은 Wwise Component가 Wwise 오브젝트로의 참조를 잃어버렸을 경우 버전 컨트롤에 AkWwiseProjectData.asset이 추가되었을 수 있습니다. AkWwiseProjectData.asset이 잠기면 (버전 컨트롤에 추가되어 있는 경우 종종 발생) AkWwiseProjectData##.asset 형식으로 새로운 파일이 생성됩니다. 이 경우 이 파일들을 모두 삭제하고 Wwise Picker 에서 Auto populate(자동 구성)을 클릭하여 파일을 재생성하세요.

참고: AkWwiseProjectData.asset은 버전 컨트롤에 넣지 마세요! 이 파일은 Wwise Picker가 계속해서 Work Unit 파일을 파싱하지 않도록 하는 Wwise 프로젝트 데이터의 임시 캐시 파일입니다.

설치 후 컴파일링 오류

Wwise를 이전 버전에서 방금 업데이트한 경우 스크립트가 중복되었을 수 있습니다. 2013.2.8 버전에서 UNITY_PROJECT_ROOT\Assets\Wwise\Deployment\Examples 폴더의 이름이 Components 로 변경되었습니다. Examples 폴더에 있는 스크립트를 변경하지 않으셨다면 이 폴더를 삭제하세요.

또한 여러 플랫폼에서 개발할 경우 각 개발 플랫폼의 UnityPackage를 설치했는지 반드시 확인하세요. 일부 스크립트는 특정 플랫폼에서만 사용됩니다.

Unity 콘솔에 있는 DllNotFoundException

Windows에서 Unity 콘솔에 AkSoundEngine에 대한 DllNotFoundException 메시지가 보일 경우 두 가지 사항이 누락되었을 수 있습니다.

  • 작업 컴퓨터에 DirectX가 설치되었는지 확인하세요.
  • Wwise Unity 통합의 Debug 구성을 사용할 경우 Microsoft Visual Studio 2010 Debug Redistributables(마이크로소프트 비주얼 스튜디오 2010 디버그 재배포 가능 파일)도 설치해야 합니다. 보통 Profile 환경 설정은 기본적으로 설치되기 때문에 Debug 설정을 직접 설치한 경우를 제외하고는 이 문제가 일어나지 않아야 합니다.

사운드 누락

게임에서 아무 사운드도 들리지 않는다면 다음 내용을 확인하세요.

  • 독립 실행형(standalone)으로 게임을 실행할 때 사운드가 들리지 않을 경우 Windows나 Mac의 Editor에서 게임을 실행해보세요. 먼저 에디터에서 문제를 해결하는 것이 더 쉽습니다.
  • SoundBank가 알맞게 생성되었으며 Unity가 SoundBank를 찾을 수 있는지 확인하세요. 에디터에서 게임을 실행할 경우 Wwise 통합은 Wwise 프로젝트의 Generated SoundBanks 경로에서 SoundBank를 탐색합니다. 여기에 아무 것도 없을 경우 StreamingAssets 폴더를 확인합니다. Wwise에서 프로젝트 SoundBank를 덮어 쓰면 Wwise 통합이 SoundBank를 자동으로 로드하지 못합니다. 이 문제에 대한 더 많은 정보는 원하는 플랫폼으로 Unity 게임 빌드하기 를 참고하세요
  • 오디오 호출이 실행되기 전에 Sound Engine이 알맞게 초기화되었는지, 모든 엔진 호출이 완료된 후 Sound Engine이 제거되었는지 확인하세요. AkInitializer에 Script Execution Order(스크립트 실행 순서) (메뉴 Edit > Project Settings > Script Execution Order)가 알맞게 설정되었는지 확인해야 합니다.
  • Wwise Project Settings 대화 상자에서 Enable Auto-Defined SoundBanks 옵션이 해제되었는지 확인하세요.
  • Unity 콘솔에 보고된 오류가 없는지 확인하세요.
  • 게임을 실행하는 도중 Wwise Profiler (Wwise에서 F7)를 연결하면 Capture Log에 보고되는 오류가 있습니까?
  • Wwise Profiler의 SoundBank 탭에 뱅크가 로드된 것이 보이십니까? 탭이 보이지 않을 경우 Profiling Settings (Alt-G)를 열고 SoundBank를 활성화하세요. SoundBank가 로드되지 않았을 경우 언제 어떻게 로드되는지 확인해야 합니다. AkBank 컴포넌트와 AkSoundEngine.LoadBank 호출을 찾으세요.
  • Wwise Profiler의 Capture Log에서 알맞은 Event가 전송된 것이 보이나요? 그렇지 않을 경우 알맞은 Event가 SoundBank 안에 담겼으며 알맞게 로드되었는지 (이전 내용 참고) 확인해야 합니다. 뱅크가 로드되었을 경우 게임 스크립트에서 AkEvent, AkAmbient 컴포넌트와 AkSoundEngine.PostEvent 호출을 확인하세요.

Wwise Profiler에 연결할 수 없음

Windows에서 게임을 실행할 경우 다음 내용을 확인하세요.

  • Unity에서 Run in background 설정이 활성화되었는지 확인하세요 (메뉴 File > Build Settings > Player Settings).
  • 작업 컴퓨터의 방화벽이 포트 24024를 허용하며 Wwise가 예외 사항으로 설정되어 있는지 확인하세요. 방화벽이 비활성화되었을 경우 이 부분이 문제가 되지 않습니다.
  • Wwise-Unity Plug-in의 어떤 환경 설정을 실행하고 계십니까? Debug 와 Profile 만 통신(communication) 코드가 활성화되어 있습니다.
  • Task Manager를 열고 'adb.exe'라고 된 모든 프로세스를 제거하세요. 이 프로세스는 Android 드라이버이며 TCP 포트를 잠급니다. Android에서 개발하지 않거나 Android 장치가 연결되지 않더라도 마찬가지입니다. (이 부분은 Google 측의 문제입니다.)

다른 컴퓨터나 콘솔에서 게임을 실행할 경우 다음 내용을 확인하세요.

  • Wwise 컴퓨터와 게임 콘솔이 동일한 서브넷(subnet)에 있습니까? 그렇지 않을 경우 Remote Connection 대화창에 게임이 표시되지 않습니다. Connect To IP 버튼을 통해 IP를 직접 입력하세요.
  • 네트워크가 포트 24024이나 동적 포트 할당을 허용합니까?

Unity 콘솔에서 Error during installation - Access to the path is denied 출력

Unity 콘솔에서 Wwise: Error during installation: Access to the path is denied 메시지가 뜰 경우 다음 내용을 확인하세요.

  • 다음 작업 후에 바로 Assets > Wwise > Install Plugins 메뉴에서 새로운 Plug-in 환경 설정 (Debug, Profile, Release )을 설치했나요?
    • Wwise Setup 창에서 새로운 Unity 통합 설치 후
    • Unity Editor에서 Scene을 미리보기한 후
  • Unity 프로젝트를 다시 열고 새로운 Plug-in 환경 설정 (Debug, Profile, Release )을 즉시 설치하세요.

Mac에서 Wwise의 SoundBank 생성 중 오류 - Cannot write to Wwise_IDs.h

Mac에서 Wwise를 사용할 때 SoundBank 생성 중 Wwise_IDs.h를 작성하지 못했다는 오류가 보이면 다음 내용을 확인하세요.

  • Wwise 프로젝트를 여세요.
  • Project Settings에서 SoundBanks 탭으로 가세요.
  • 헤더 파일 경로를 SoundBank가 생성되는 곳으로 설정하세요.

Error: Plugin Not Registered

Wwise 프로젝트가 AkSoundEngine 동적 라이브러리에 들어가지 못한 라이센스된 플러그인을 여전히 사용합니다. 플러그인 추가하기 를 참조하세요.

Mac에서 Unity Console에 'Multiple plugins with the same name'

Mac에서 Unity를 사용하여 Integration을 가져올 경우 Unity Console이 다음과 같은 오류를 표시할 수 있습니다.

Multiple plug-ins with the same name 'aksoundengine' (found at 'Assets/Wwise/API/Runtime/Plugins/Mac/Release/AkSoundEngine.bundle' and 'Assets/Wwise/API/Runtime/Plugins/Mac/Debug/AkSoundEngine.bundle'). That means one or more plug-ins are set to be compatible with Editor. Only one plug-in at a time can be used by Editor.

설치 과정이 알맞은 플러그인을 활성화하기 때문에 이 오류는 무시해도 안전합니다.

Google Play Services가 설치된 프로젝트에 Wwise를 통합하거나 마이그레이션할 수 없음

Audiokinetic 런처는 Google Play Services가 설치된 Unity 프로젝트에 빌드 대상이 Android로 설정되었을 경우 Wwise를 통합하거나 마이그레이션할 수 없습니다. 이 제한 사항을 피하려면 Unity 프로젝트를 열어서 빌드 대상을 Android가 아닌 플랫폼으로 변경한 후 Unity를 닫고 런처를 통해 통합이나 마이그레이션을 다시 시작하세요.


Wwise Unity Integration Documentation: WAAPI 유틸리티

WAAPI 유틸리티

2018.1 버전부터 Wwise Authoring API (WAAPI) 지원이 Unity 통합 안에 내장됩니다 (더 자세한 설명은 Wwise Authoring API (WAAPI) 사용하기를 참조하세요). 2021.1 버전에서 Wwise Authoring API (WAAPI)는 Wwise Picker와의 더 나은 통합과 전반적인 사용을 쉽게 할 수 있도록 재설계되었습니다. Wwise Picker와 함께 WAAPI 사용하기에 대한 더 많은 정보는 해당 설명서 페이지인 Wwise Picker 에서 확인하실 수 있습니다.

  1. WAAPI 설정
    1. 문제 해결
  2. Unity에서 WAAPI 사용하기
    1. Waapi를 사용하여 Wwise Object 페치하기
    2. 토픽 구독하기
    3. 연결 해제
    4. Other WAAPI 명령어

WAAPI 설정

WAAPI 설정은 Project Settings > Wwise Editor > Wwise Authoring API 에서 찾을 수 있습니다.

Connect to Wwise 체크 상자가 선택되지 않았을 경우 WAAPI 기능이 비활성화됩니다. 기본적으로 WAAPI 클라이언트는 localhost (127.0.0.1)에서 포트 8080에 연결됩니다. WAAPI가 연결되어 있을 때에 이 설정을 변경할 경우 현재 연결이 닫히며 새로운 대상 주소로 연결을 시도합니다.

문제 해결

프로젝트에 연결하는 데에 문제가 있을 경우 다음의 잠재적 해결 방법을 참고해보세요:

  • Wwise Authoring에서 올바른 프로젝트가 열려 있는지 확인하세요.
  • Project Settings > Wwise Editor > Wwise Project에 있는 Wwise Project Path가 올바른지 확인하세요.
  • 여러 Wwise Authoring 인스턴스가 열려 있을 경우 그중 하나가 다른 하나의 WAAPI 포트를 막고 있을 수 있습니다.
  • Wwise Authoring에서 WAAPI가 활성화되어있으며 허용된 연결과 포트가 올바른지 확인하세요.
    • WAAPI 설정은 User Preferences에서 찾을 수 있습니다.

Unity에서 WAAPI 사용하기

AKWaapiClient 클래스는 웹소켓 연결을 사용하여 Wwise Authoring과 메시지를 주고받습니다. WAAPI 메시지는 JSON 오브젝트입니다. WAAPI 호출은 비동기적이며 WAAPI로의 호출이 GUI 스레드와 같은 스레드에서 올 수 있기 때문에 스레드에서의 응답을 기다릴 수가 없습니다. 또한 웹소켓 구현은 한 번에 한 반응만 기다릴 수 있기 때문에 WAAPI 클라이언트가 AkWaapiUtilities 클래스에 의해 래핑됩니다. 이 클래스는 WAAPI 요청을 생성하며 대기열에 더한 후 업데이트 루프를 사용하여 순차적으로 호출할 수 있는 기능을 제공합니다. WAAPI 요청은 비동기 함수 포인터 페이로드를 포함하는 WaapiCommand 안에 캡슐화됩니다. 명령어가 소비되면 페이로드가 실행됩니다.

AkWaapiUtilities에서 제공되는 함수가 여러분이 대부분 필요로 하는 것들을 충족시켜주어야 하지만, 제공되지 않은 특정한 방법으로 WAAPI를 사용하려고 할 경우 여전히 직접 구현할 수 있습니다. 더 자세한 내용은 Other WAAPI 명령어 를 참고하세요.

주의: 제공되는 대부분의 WAAPI 호출은 Wwise Authoring Query Language (Wwise 저작 대기열 언어, WAQL)를 사용합니다. WAQL에 대한 더 많은 정보는 WAQL 소개와 참조 페이지를 참고해 주세요.

Waapi를 사용하여 Wwise Object 페치하기

AkWaapiUtilities는 이미 Wwise 오브젝트를 페치할 수 있는 WAAPI 호출을 기본적으로 담고 있습니다.

  • AkWaapiUtilities.GetWwiseObject<T>
  • AkWaapiUtilities.GetWwiseObjectAndDescendants<T>
  • AkWaapiUtilities.GetWwiseObjectAndAncestors<T>
  • AkWaapiUtilities.Search<T>
  • AkWaapiUtilities.GetChildren<T>

이 호출은 리턴 옵션에서 지정된 속성이 담긴 오브젝트 목록을 리턴합니다. 리턴 옵션의 전체 목록은 WAAPI 설명서에서 찾을 수 있습니다.

Wwise Picker는 이러한 함수에 WwiseObjectInfoJsonObject를 템플릿 타입으로 사용합니다. 그런 다음 이 오브젝트는 AkWaapiUtilities.ParseObjectInfo에 의해 WwiseObjectInfo로 캐스트됩니다.

WwiseObjectInfo에 들어 있지 않은 오브젝트 속성을 페치하려면, 접근하고자 하는 속성에 대한 커스텀 클래스가 필요합니다. 예를 들어 Notes 입력란을 페치하려는 경우 다음과 같은 클래스를 생성할 수 있습니다:

public class WwiseObjectNotes
{
public string notes;
}

그런 다음 노트 입력란만 열거하는 ReturnOptions 오브젝트와 WwiseObjectNotes의 목록을 수락하는 콜백이 있는 AkWaapiUtilities.GetWwiseObject<T> (혹은 이전에 열거된 다른 모든 함수)를 호출할 수 있습니다.

{
var callback = ( List<WwiseObjectNotes> notes ) => {
// do something
};
var options = new ReturnOptions(new string[] { "notes" });
var objectGuid = System.Guid.Empty(); //Put an actual guid from your project here
AkWaapiUtilities.GetWwiseObject<WwiseObjectNotes>( objectGuid, options, callback);
}

AkWwiseTreeWAAPIDataSource 클래스는 WAAPI를 사용하여 Wwise 오브젝트를 페치하고 Wwise Picker를 구성하는 많은 예시를 담고 있습니다.

토픽 구독하기

AkWaapiUtilities.Subscribe 를 사용하여 WAAPI 토픽으로 구독하세요. URI은 구독하는 토픽을 식별합니다. 콜백 인자는 토픽이 발행되었을 때 호출할 JSON 문자열 인자를 수락하는 함수입니다. handshakeCallback은 구독이 성공적으로 등록되었을 때에 호출됩니다. 이 호출은 구독 식별자를 담은 AkWaapiUtilities.SubscriptionInfo 오브젝트를 받습니다. 구독을 요청한 클래스에 이 정보가 저장되어 있어야 합니다.

주의: AkWaapiUtilities.Subscribe를 호출하는 클래스는 수명이 다한 후에 해당 구독을 제거해야 합니다. 이 작업은 AkWaapiUtilities.Unsubscribe 를 호출함으로써 실행됩니다.

이 통합에서 사용된 구독의 예시는 AkWwiseTreeWAAPIDataSource 클래스를 참고해 주세요.

  • AkWwiseTreeWAAPIDataSource.SubscribeTopics
  • AkWwiseTreeWAAPIDataSource.UnsubscribeTopics

사용 가능한 토픽에 대한 정보는 >Wwise Authoring API 참조에서 찾을 수 있습니다.

  • 대부분의 토픽 URI는 Uri.cs 안에서 찾을 수 있습니다

연결 해제

WAAPI 연결이 닫힐 때가 되면 (혹은 갑자기 닫혔을 경우) AkWaapiUtilities.Disconnection 델리게이트가 호출됩니다. 델리게이트의 불리언 매개 변수는 이 연결이 여전히 살아있는지의 여부를 나타냅니다.

참고: WAAPI 토픽으로 구독하는 클래스는 이 델리게이트를 바인드하여 연결이 끊기기 전에 구독 해제할 수 있게 해주어야 합니다.

Other WAAPI 명령어

AkWaapiUtilities 클래스는 Unity 안에서 WAAPI 프로젝트와 상호작용할 수 있게 해주는 다음의 추가 함수를 담고 있습니다:

  • AkWaapiUtilities.SelectObjectInAuthoring
  • AkWaapiUtilities.OpenWorkUnitInExplorer
  • AkWaapiUtilities.OpenSoundBankInExplorer
  • AkWaapiUtilities.Rename
  • AkWaapiUtilities.Delete
  • AkWaapiUtilities.TogglePlayEvent
  • AkWaapiUtilities.StopAllTransports

이 명령어가 사용되는 예시는 AkWwisePicker와 AkWwiseTreeView에서 찾을 수 있습니다.

실행하려는 WAAPI 명령어가 이미 AkWaapiUtilities 안에 구현되어 있지 않을 경우 여전히 명령어를 직접 생성할 수 있습니다. WAAPI 호출을 만들고 응답을 수신하려면 반드시 JSON 인자를 생성하고 파싱해야 합니다.

이 응답에서 파싱할 것이 없는 명령어의 경우 AkWaapiUtilities.QueueCommand 를 사용하세요

이 응답에서 파싱해야 할 값이 있는 명령어의 경우 AkWaapiUtilities.QueueCommandWithReturnType<T> 를 사용하세요

Unity JsonUtility 클래스는 C# 클래스와 JSON 문자열을 쉽게 번역할 수 있게 해줍니다. 인자의 기본 클래스로 JsonSerializable을 사용하세요. 옵션은 반드시 JSON 문자열로 변환되어야 합니다.

public class JsonSerializable
{
public static implicit operator string(JsonSerializable o) => UnityEngine.JsonUtility.ToJson(o);
}

그런 다음 특정 WAPPI 스키마의 C# 래퍼를 제공하도록 이 클래스를 확장할 수 있습니다. 이 클래스 확장의 사용 예시를 확인하려면 저희가 WAAPI를 사용하여 Event를 재생하고 트랜스포트에 구독하기 위해 필요한 스키마 클래스를 생성한 방식을 살펴보세요.

인자와 옵션 스키마

  • ArgsPlay
  • ArgsObject
  • TransportOptions

리턴된 오브젝트 스키마

  • ReturnTransport
  • TransportState

이 스키마가 사용된 방식은 AkWaapiUtilities.TogglePlayWwiseEventAsync와 AkWaapiUtilities.CreateTransport에서 확인할 수 있습니다.

JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:27
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:150
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34


Wwise Unity Integration Documentation: 네임스페이스 목록

네임스페이스 목록
다음은 문서화된 모든 네임스페이스에 대한 목록입니다. (간략한 설명만을 보여줍니다) :
[상세 단계 12]
▼N AK
N Wwise


Wwise Unity Integration Documentation: AK 네임스페이스 참조

네임스페이스
AK 네임스페이스 참조


Wwise Unity Integration Documentation: AK.Wwise 네임스페이스 참조

  • AK
  • Wwise
클래스
AK.Wwise 네임스페이스 참조

클래스

class | AcousticTexture
This type represents an Acoustic Texture. 더 자세히 ...
class | AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy. 더 자세히 ...
class | Bank
This type can be used to load/unload SoundBanks. 더 자세히 ...
class | BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. 더 자세히 ...
class | BaseType
This type represents the base for all Wwise Types that require a GUID. 더 자세히 ...
class | CallbackFlags
This type represents the values of the flags used when posting an Event with a callback. 더 자세히 ...
class | Event
This type can be used to post Events to the sound engine. 더 자세히 ...
class | RTPC
This type can be used to set game parameter values to the sound engine. 더 자세히 ...
class | State
This type can be used to set Wwise States. 더 자세히 ...
class | Switch
This type can be used to set Switch values on gameobjects. 더 자세히 ...
class | Trigger
This type can be used to post triggers to the sound engine. 더 자세히 ...


Wwise Unity Integration Documentation: 클래스 목록

클래스 목록
다음은 클래스, 구조체, 공용체 그리고 인터페이스들입니다. (간략한 설명만을 보여줍니다) :
[상세 단계 123]
▼N AK |
▼N Wwise |
C AcousticTexture | This type represents an Acoustic Texture
C AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C Bank | This type can be used to load/unload SoundBanks
C BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C BaseType | This type represents the base for all Wwise Types that require a GUID
C CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C Event | This type can be used to post Events to the sound engine
C RTPC | This type can be used to set game parameter values to the sound engine
C State | This type can be used to set Wwise States
C Switch | This type can be used to set Switch values on gameobjects
C Trigger | This type can be used to post triggers to the sound engine
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
▼C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
C AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
▼C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
C EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkReverbZone | This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
▼C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
▼C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C GeometryData | The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwise 이벤트에 새로운 트리거 추가하기
▼C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C SubscriptionInfo | Class used to store information about a specific subscription
C WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
C AkWwiseTrigger | This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
▼C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C ErrorException | Exception thrown during WAMP operations
C TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WaqlArgs | WAAPI arguments containing a WAQL string
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic


Wwise Unity Integration Documentation: AK.Wwise.AcousticTexture 클래스 참조

  • AK
  • Wwise
  • AcousticTexture
모든 멤버 목록
AK.Wwise.AcousticTexture 클래스 참조

This type represents an Acoustic Texture. 더 자세히 ...

AK.Wwise.AcousticTexture에 대한 상속 다이어그램 :
AK.Wwise.BaseType

상세한 설명

This type represents an Acoustic Texture.


Wwise Unity Integration Documentation: AK.Wwise.AuxBus 클래스 참조

  • AK
  • Wwise
  • AuxBus
모든 멤버 목록
AK.Wwise.AuxBus 클래스 참조

This type represents an auxiliary send in the Master-Mixer Hierarchy. 더 자세히 ...

AK.Wwise.AuxBus에 대한 상속 다이어그램 :
AK.Wwise.BaseType

상세한 설명

This type represents an auxiliary send in the Master-Mixer Hierarchy.


Wwise Unity Integration Documentation: AK.Wwise.Bank 클래스 참조

  • AK
  • Wwise
  • Bank
모든 멤버 목록
AK.Wwise.Bank 클래스 참조

This type can be used to load/unload SoundBanks. 더 자세히 ...

AK.Wwise.Bank에 대한 상속 다이어그램 :
AK.Wwise.BaseType

상세한 설명

This type can be used to load/unload SoundBanks.


Wwise Unity Integration Documentation: AK.Wwise.BaseGroupType 클래스 참조

  • AK
  • Wwise
  • BaseGroupType
모든 멤버 목록
AK.Wwise.BaseGroupType 클래스 참조

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. 더 자세히 ...

AK.Wwise.BaseGroupType에 대한 상속 다이어그램 :
AK.Wwise.BaseType AK.Wwise.State AK.Wwise.Switch

상세한 설명

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch.


Wwise Unity Integration Documentation: AK.Wwise.BaseType 클래스 참조

  • AK
  • Wwise
  • BaseType
모든 멤버 목록
AK.Wwise.BaseType 클래스 참조

This type represents the base for all Wwise Types that require a GUID. 더 자세히 ...

AK.Wwise.BaseType에 대한 상속 다이어그램 :
AK.Wwise.AcousticTexture AK.Wwise.AuxBus AK.Wwise.Bank AK.Wwise.BaseGroupType AK.Wwise.Event AK.Wwise.RTPC AK.Wwise.Trigger AK.Wwise.State AK.Wwise.Switch

상세한 설명

This type represents the base for all Wwise Types that require a GUID.


Wwise Unity Integration Documentation: AK.Wwise.CallbackFlags 클래스 참조

  • AK
  • Wwise
  • CallbackFlags
모든 멤버 목록
AK.Wwise.CallbackFlags 클래스 참조

This type represents the values of the flags used when posting an Event with a callback. 더 자세히 ...

상세한 설명

This type represents the values of the flags used when posting an Event with a callback.


Wwise Unity Integration Documentation: AK.Wwise.Event 클래스 참조

  • AK
  • Wwise
  • Event
Public 멤버 함수 | 모든 멤버 목록
AK.Wwise.Event 클래스 참조

This type can be used to post Events to the sound engine. 더 자세히 ...

AK.Wwise.Event에 대한 상속 다이어그램 :
AK.Wwise.BaseType

Public 멤버 함수

uint | Post (UnityEngine.GameObject gameObject)
Posts this Event on a GameObject. 더 자세히 ...
uint | Post (UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. 더 자세히 ...
uint | Post (UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. 더 자세히 ...
uint | Post (ulong gameObjectId)
Posts this Event on a GameObject ID. 더 자세히 ...
void | ExecuteAction (UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject. 더 자세히 ...
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject. 더 자세히 ...
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject. 더 자세히 ...
void | StopMIDI (UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject. 더 자세히 ...
void | StopMIDI ()
Stops all MIDI Events on this Event. 더 자세히 ...

상세한 설명

This type can be used to post Events to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.Event.ExecuteAction

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ ExecuteAction()

void AK.Wwise.Event.ExecuteAction | ( | UnityEngine.GameObject | gameObject,
 |  | AkActionOnEventType | actionOnEventType,
 |  | int | transitionDuration,
 |  | AkCurveInterpolation | curveInterpolation
 | ) |  |
inline

Executes various actions on this event associated with a GameObject.

매개변수
gameObject The GameObject
actionOnEventType
transitionDuration
curveInterpolation


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [1/4]

uint AK.Wwise.Event.Post ( ulong gameObjectId )
inline

Posts this Event on a GameObject ID.

매개변수
gameObjectId The GameObject ID
반환값
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [2/4]

uint AK.Wwise.Event.Post ( UnityEngine.GameObject gameObject )
inline

Posts this Event on a GameObject.

매개변수
gameObject The GameObject
반환값
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [3/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | CallbackFlags | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

매개변수
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
반환값
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [4/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | uint | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

매개변수
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
반환값
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [1/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

매개변수
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [2/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array,
 |  | int | count
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

매개변수
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.
count | The number of elements from the array that will be posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [1/2]

void AK.Wwise.Event.StopMIDI ( )
inline

Stops all MIDI Events on this Event.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [2/2]

void AK.Wwise.Event.StopMIDI ( UnityEngine.GameObject gameObject )
inline

Stops MIDI Events on this Event associated with a GameObject.

매개변수
gameObject The GameObject


Wwise Unity Integration Documentation: AK.Wwise.RTPC 클래스 참조

  • AK
  • Wwise
  • RTPC
모든 멤버 목록
AK.Wwise.RTPC 클래스 참조

This type can be used to set game parameter values to the sound engine. 더 자세히 ...

AK.Wwise.RTPC에 대한 상속 다이어그램 :
AK.Wwise.BaseType

상세한 설명

This type can be used to set game parameter values to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.State 클래스 참조

  • AK
  • Wwise
  • State
모든 멤버 목록
AK.Wwise.State 클래스 참조

This type can be used to set Wwise States. 더 자세히 ...

AK.Wwise.State에 대한 상속 다이어그램 :
AK.Wwise.BaseGroupType AK.Wwise.BaseType

상세한 설명

This type can be used to set Wwise States.


Wwise Unity Integration Documentation: AK.Wwise.Switch 클래스 참조

  • AK
  • Wwise
  • Switch
모든 멤버 목록
AK.Wwise.Switch 클래스 참조

This type can be used to set Switch values on gameobjects. 더 자세히 ...

AK.Wwise.Switch에 대한 상속 다이어그램 :
AK.Wwise.BaseGroupType AK.Wwise.BaseType

상세한 설명

This type can be used to set Switch values on gameobjects.


Wwise Unity Integration Documentation: AK.Wwise.Trigger 클래스 참조

  • AK
  • Wwise
  • Trigger
모든 멤버 목록
AK.Wwise.Trigger 클래스 참조

This type can be used to post triggers to the sound engine. 더 자세히 ...

AK.Wwise.Trigger에 대한 상속 다이어그램 :
AK.Wwise.BaseType

상세한 설명

This type can be used to post triggers to the sound engine.


Wwise Unity Integration Documentation: ak 클래스 참조

ak 클래스 참조

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation. 더 자세히 ...

상세한 설명

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation.


Wwise Unity Integration Documentation: AkAmbient 클래스 참조

Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkAmbient 클래스 참조

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event. 더 자세히 ...

AkAmbient에 대한 상속 다이어그램 :
AkEvent

Public 속성

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. 더 자세히 ...
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. 더 자세히 ...
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event.

참고
  • 인스펙터에서 AkAmbient 사용하기
  • AkGameObj
  • AkEvent
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkAmbientLargeModePositioner 클래스 참조

모든 멤버 목록
AkAmbientLargeModePositioner 클래스 참조

Use this component to add a Large Mode position to any AkAmbient in a Scene. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

상세한 설명

Use this component to add a Large Mode position to any AkAmbient in a Scene.

참고
  • 인스펙터에서 AkAmbient 사용하기
  • AkAmbient


Wwise Unity Integration Documentation: AkAudioListener 클래스 참조

모든 멤버 목록
AkAudioListener 클래스 참조

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

상세한 설명

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

참고
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkBank 클래스 참조

Public 멤버 함수 | Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkBank 클래스 참조

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared. 더 자세히 ...

AkTriggerHandler, AK.Wwise.IMigratable를(을) 상속했습니다.

Public 멤버 함수

override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Loads the SoundBank 더 자세히 ...
void | UnloadBank (UnityEngine.GameObject in_gameObject)
Unloads a SoundBank 더 자세히 ...

Public 속성

bool | decodeBank = false
Decode this SoundBank upon load 더 자세히 ...
bool | loadAsynchronous = false
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors. 더 자세히 ...
bool | saveDecodedBank = false
Save the decoded SoundBank to disk for faster loads in the future 더 자세히 ...
System.Collections.Generic.List< int > | unloadTriggerList
Reserved. 더 자세히 ...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared.


Wwise Unity Integration Documentation: AkBank.HandleEvent

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ HandleEvent()

override void AkBank.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Loads the SoundBank

다음을 참조함 : decodeBank, loadAsynchronous, saveDecodedBank.


Wwise Unity Integration Documentation: AkBank.UnloadBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ UnloadBank()

void AkBank.UnloadBank ( UnityEngine.GameObject in_gameObject )
inline

Unloads a SoundBank


Wwise Unity Integration Documentation: AkBank.decodeBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ decodeBank

bool AkBank.decodeBank = false

Decode this SoundBank upon load

다음에 의해서 참조됨 : HandleEvent().


Wwise Unity Integration Documentation: AkBank.loadAsynchronous

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ loadAsynchronous

bool AkBank.loadAsynchronous = false

Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors.

다음에 의해서 참조됨 : HandleEvent().


Wwise Unity Integration Documentation: AkBank.saveDecodedBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ saveDecodedBank

bool AkBank.saveDecodedBank = false

Save the decoded SoundBank to disk for faster loads in the future

다음에 의해서 참조됨 : HandleEvent().


Wwise Unity Integration Documentation: AkBank.unloadTriggerList

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ unloadTriggerList

System.Collections.Generic.List<int> AkBank.unloadTriggerList

Reserved.


Wwise Unity Integration Documentation: AkEarlyReflections 클래스 참조

Public 속성 | 모든 멤버 목록
AkEarlyReflections 클래스 참조

Set an early reflections auxiliary bus and send volume for a particular game object. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 속성

AK.Wwise.AuxBus | reflectionsAuxBus = new AK.Wwise.AuxBus()
float | reflectionsVolume = 1

상세한 설명

Set an early reflections auxiliary bus and send volume for a particular game object.


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsAuxBus

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsAuxBus

AK.Wwise.AuxBus AkEarlyReflections.reflectionsAuxBus = new AK.Wwise.AuxBus()

The early reflections auxiliary bus for this particular game object. Geometrical reflection calculation inside spatial audio is enabled for a game object if any sound playing on the game object has a valid early reflections aux bus specified in the authoring tool, or if an aux bus is specified via this parameter. The early reflection auxiliary bus specified in the authoring tool has precedence. Users may apply this function to avoid duplicating sounds in the actor-mixer hierarchy solely for the sake of specifying a unique early reflection bus, or in any situation where the same sound should be played on different game objects with different early reflection aux buses (the early reflection bus must be left blank in the authoring tool if the user intends to specify it through the API).


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsVolume

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsVolume

float AkEarlyReflections.reflectionsVolume = 1

The early reflections send volume for this particular game object. This parameter is used to control the volume of the early reflections send. It is combined with the early reflections volume specified in the authoring tool, and is applied to all sounds playing on the game object. Setting to 0.f will disable all reflection processing for this game object. Valid range 0.f-1.f.


Wwise Unity Integration Documentation: AkEmitterObstructionOcclusion 클래스 참조

Public 속성 | 모든 멤버 목록
AkEmitterObstructionOcclusion 클래스 참조

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them. 더 자세히 ...

AkObstructionOcclusion를(을) 상속했습니다.

Public 속성

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. 더 자세히 ...
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. 더 자세히 ...
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. 더 자세히 ...
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. 더 자세히 ...

상세한 설명

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them.


Wwise Unity Integration Documentation: AkEnvironment 클래스 참조

클래스 | 모든 멤버 목록
AkEnvironment 클래스 참조

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기. 더 자세히 ...

MonoBehaviour, AK.Wwise.IMigratable를(을) 상속했습니다.

클래스

class | AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities. 더 자세히 ...
class | AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: 더 자세히 ...

상세한 설명

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기.

This component can be attached to any collider. You can specify a roll-off to fade-in/out of the reverb.
The reverb parameters will be defined in the Wwise project, by the sound designer. All AkGameObj that are "environment"-aware will receive a send value when entering the attached collider.

참고
  • 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
  • Integrating Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::SetGameObjectAuxSendValues (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareByPriority 클래스 참조

  • AkEnvironment
  • AkEnvironment_CompareByPriority
모든 멤버 목록
AkEnvironment.AkEnvironment_CompareByPriority 클래스 참조

Sorts AkEnvironments based on their priorities. 더 자세히 ...

AkEnvironment.AkEnvironment_CompareByPriority에 대한 상속 다이어그램 :
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm

상세한 설명

Sorts AkEnvironments based on their priorities.


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm 클래스 참조

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
모든 멤버 목록
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm 클래스 참조

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: 더 자세히 ...

AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm에 대한 상속 다이어그램 :
AkEnvironment.AkEnvironment_CompareByPriority

상세한 설명

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:

  1. Environments have priorities.
  2. Environments have a "Default" flag. This flag effectively says that this environment will be bumped out if any other is present.
  3. Environments have an "Exclude Other" flag. This flag will tell that this env is not overlappable with others. So, only one (the highest priority) should be selected.


Wwise Unity Integration Documentation: AkEnvironmentPortal 클래스 참조

클래스 | Public 속성 | 모든 멤버 목록
AkEnvironmentPortal 클래스 참조

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

클래스

class EnvListWrapper
This enables us to detect intersections between portals and environments in the editor 더 자세히 ...

Public 속성

UnityEngine.Vector3 | axis = UnityEngine.Vector3.right
The axis used to find the contribution of each environment 더 자세히 ...
AkEnvironment[] | environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class 더 자세히 ...

상세한 설명

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기


Wwise Unity Integration Documentation: AkEnvironmentPortal.EnvListWrapper 클래스 참조

  • AkEnvironmentPortal
  • EnvListWrapper
모든 멤버 목록
AkEnvironmentPortal.EnvListWrapper 클래스 참조

This enables us to detect intersections between portals and environments in the editor 더 자세히 ...

상세한 설명

This enables us to detect intersections between portals and environments in the editor


Wwise Unity Integration Documentation: AkEnvironmentPortal.axis

  • AkEnvironmentPortal
axis
environments
envList

◆ axis

UnityEngine.Vector3 AkEnvironmentPortal.axis = UnityEngine.Vector3.right

The axis used to find the contribution of each environment


Wwise Unity Integration Documentation: AkEnvironmentPortal.environments

  • AkEnvironmentPortal
axis
environments
envList

◆ environments

AkEnvironment [] AkEnvironmentPortal.environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]

The array is already sorted by position. The first environment is on the negative side of the portal(opposite to the direction of the chosen axis) The second environment is on the positive side of the portal


Wwise Unity Integration Documentation: AkEnvironmentPortal.envList

  • AkEnvironmentPortal
axis
environments
envList

◆ envList

EnvListWrapper [] AkEnvironmentPortal.envList

Unity can't serialize an array of list so we wrap the list in a serializable class


Wwise Unity Integration Documentation: AkEvent 클래스 참조

Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkEvent 클래스 참조

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object. 더 자세히 ...

AkEvent에 대한 상속 다이어그램 :
AkAmbient

Public 속성

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. 더 자세히 ...
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. 더 자세히 ...
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() 더 자세히 ...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object.

참고
  • Edit Mode Support
  • 인스펙터에서 AkAmbient 사용하기
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEvent.actionOnEventType

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ actionOnEventType

AkActionOnEventType AkEvent.actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop

Replacement action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.curveInterpolation

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ curveInterpolation

AkCurveInterpolation AkEvent.curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear

Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.enableActionOnEvent

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ enableActionOnEvent

bool AkEvent.enableActionOnEvent = false

Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project.


Wwise Unity Integration Documentation: AkEvent.soundEmitterObject

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ soundEmitterObject

UnityEngine.GameObject AkEvent.soundEmitterObject

Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added.


Wwise Unity Integration Documentation: AkEvent.transitionDuration

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ transitionDuration

float AkEvent.transitionDuration = 0.0f

Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEventCallbackMsg 클래스 참조

Public 속성 | 모든 멤버 목록
AkEventCallbackMsg 클래스 참조

Event callback information. Event callback functions can receive this structure as a parameter 더 자세히 ...

Public 속성

AkCallbackInfo | info
For more information about the event callback, see the classes derived from AkCallbackInfo. 더 자세히 ...
UnityEngine.GameObject | sender
GameObject from whom the callback function was called 더 자세히 ...
AkCallbackType | type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks 더 자세히 ...

상세한 설명

Event callback information. Event callback functions can receive this structure as a parameter


Wwise Unity Integration Documentation: AkEventCallbackMsg.info

  • AkEventCallbackMsg
info
sender
type

◆ info

AkCallbackInfo AkEventCallbackMsg.info

For more information about the event callback, see the classes derived from AkCallbackInfo.


Wwise Unity Integration Documentation: AkEventCallbackMsg.sender

  • AkEventCallbackMsg
info
sender
type

◆ sender

UnityEngine.GameObject AkEventCallbackMsg.sender

GameObject from whom the callback function was called


Wwise Unity Integration Documentation: AkEventCallbackMsg.type

  • AkEventCallbackMsg
info
sender
type

◆ type

AkCallbackType AkEventCallbackMsg.type

AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks


Wwise Unity Integration Documentation: AkGameObj 클래스 참조

Public 멤버 함수 | Public 속성 | 모든 멤버 목록
AkGameObj 클래스 참조

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 멤버 함수

virtual UnityEngine.Vector3 | GetPosition ()
virtual UnityEngine.Vector3 | GetForward ()
virtual UnityEngine.Vector3 | GetUpward ()

Public 속성

bool | isEnvironmentAware = true
Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true. 더 자세히 ...
AkGameObjPositionOffsetData | m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Position Offset 더 자세히 ...

상세한 설명

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise.

참고
  • Integration Details - Game Objects (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkGameObj.GetForward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetForward()

virtual UnityEngine.Vector3 AkGameObj.GetForward ( )
inlinevirtual

Gets the orientation forward vector. User can also override this method to calculate an arbitrary vector.

반환값
The forward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.GetPosition

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetPosition()

virtual UnityEngine.Vector3 AkGameObj.GetPosition ( )
inlinevirtual

Gets the position including the position offset, if applyPositionOffset is enabled. User can also override this method to calculate an arbitrary position.

반환값
The position.

다음을 참조함 : m_positionOffsetData.


Wwise Unity Integration Documentation: AkGameObj.GetUpward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetUpward()

virtual UnityEngine.Vector3 AkGameObj.GetUpward ( )
inlinevirtual

Gets the orientation upward vector. User can also override this method to calculate an arbitrary vector.

반환값
The upward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.isEnvironmentAware

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ isEnvironmentAware

bool AkGameObj.isEnvironmentAware = true

Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true.


Wwise Unity Integration Documentation: AkGameObj.m_positionOffsetData

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ m_positionOffsetData

AkGameObjPositionOffsetData AkGameObj.m_positionOffsetData

When not set to null, the position will be offset relative to the Game Object position by the Position Offset

다음에 의해서 참조됨 : GetPosition().


Wwise Unity Integration Documentation: AkInitializer 클래스 참조

모든 멤버 목록
AkInitializer 클래스 참조

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

상세한 설명

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings.

참고
  • Initialize the Different Modules of the Sound Engine (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Init() (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Term() (Note: This is described in the Wwise SDK documentation.)
  • Enter Play Mode Behaviors
  • AkCallbackManager


Wwise Unity Integration Documentation: AkListenerDistanceProbe 클래스 참조

모든 멤버 목록
AkListenerDistanceProbe 클래스 참조

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

상세한 설명

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera.


Wwise Unity Integration Documentation: AkMemBankLoader 클래스 참조

Public 멤버 함수 | Public 속성 | 모든 멤버 목록
AkMemBankLoader 클래스 참조

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 멤버 함수

void | LoadNonLocalizedBank (string in_bankFilename)
Load a SoundBank from WWW object 더 자세히 ...
void | LoadLocalizedBank (string in_bankFilename)
Load a language-specific bank from WWW object 더 자세히 ...

Public 속성

string | bankName = ""
Name of the bank to load 더 자세히 ...
bool | isLocalizedBank = false
Is the bank localized (situated in the language-specific folders) 더 자세히 ...

상세한 설명

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class


Wwise Unity Integration Documentation: AkMemBankLoader.LoadLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadLocalizedBank()

void AkMemBankLoader.LoadLocalizedBank ( string in_bankFilename )
inline

Load a language-specific bank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.LoadNonLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadNonLocalizedBank()

void AkMemBankLoader.LoadNonLocalizedBank ( string in_bankFilename )
inline

Load a SoundBank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.bankName

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ bankName

string AkMemBankLoader.bankName = ""

Name of the bank to load


Wwise Unity Integration Documentation: AkMemBankLoader.isLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ isLocalizedBank

bool AkMemBankLoader.isLocalizedBank = false

Is the bank localized (situated in the language-specific folders)


Wwise Unity Integration Documentation: AkRadialEmitter 클래스 참조

Public 속성 | 모든 멤버 목록
AkRadialEmitter 클래스 참조

A radial emitter is for sounds that are not point sources, but instead originate from a region of space. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 속성

float | outerRadius = 0.0f
float | innerRadius = 0.0f

상세한 설명

A radial emitter is for sounds that are not point sources, but instead originate from a region of space.

A radial emitter is described by an inner and outer radius. The radii are used in spread and distance calculations, simulating a radial sound source. Since all game objects have a position and orientation, the position (center) and local axes are defined by the AkGameObj component required by this component.


Wwise Unity Integration Documentation: AkRadialEmitter.innerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ innerRadius

float AkRadialEmitter.innerRadius = 0.0f

Define an inner radius around each sound position to simulate a radial sound source. If the listener is inside the inner radius, the spread is 100%. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkRadialEmitter.outerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ outerRadius

float AkRadialEmitter.outerRadius = 0.0f

Define an outer radius around each sound position to simulate a radial sound source. The distance used for applying attenuation curves is taken as the distance between the listener and the point on the sphere, defined by the sound position and the outer radius, that is closest to the listener. The spread for each sound position is calculated as follows:

  • If the listener is outside the outer radius, the spread is defined by the area that the sphere takes in the listener field of view. Specifically, this angle is calculated as 2.0*asinf( outerRadius / distance ), where distance is the distance between the listener and the sound position.
  • When the listener intersects the outer radius (the listener is exactly outerRadius units away from the sound position), the spread is exactly 50%.
  • When the listener is in between the inner and outer radius, the spread interpolates linearly from 50% to 100% as the listener transitions from the outer radius towards the inner radius. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkReverbZone 클래스 참조

Public 멤버 함수 | 정적 Public 멤버 함수 | Public 속성 | 모든 멤버 목록
AkReverbZone 클래스 참조

This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 멤버 함수

void | SetReverbZone ()
Calls AkReverbZone::SetReverbZone() with this component's properties 더 자세히 ...
void | RemoveReverbZone ()
Calls AkReverbZone::RemoveReverbZone() with this component's properties 더 자세히 ...

정적 Public 멤버 함수

static void | SetReverbZone (AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AkRoom::SetReverbZone() from the Reverb Zone AkRoom component with the Parent Room and transition Region Width parameters. 더 자세히 ...
static void | RemoveReverbZone (AkRoom reverbZone)
Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms, unless they are explicitly connected with a Portal. Calls AkRoom::RemoveReverbZone() from the Reverb Zone AkRoom component. 더 자세히 ...

Public 속성

AkRoom ReverbZone
AkRoom ParentRoom
float TransitionRegionWidth = 1.0f
Width of the transition region between the Reverb Zone and its parent. The transition zone is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0. 더 자세히 ...

상세한 설명

This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal.

Setting a Room as a Reverb Zone is useful in situations where two or more acoustic environments are not easily modeled as closed rooms connected by portals. Possible uses for Reverb Zones include: a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent.


Wwise Unity Integration Documentation: AkReverbZone.RemoveReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ RemoveReverbZone() [1/2]

void AkReverbZone.RemoveReverbZone ( )
inline

Calls AkReverbZone::RemoveReverbZone() with this component's properties

다음을 참조함 : ReverbZone.


Wwise Unity Integration Documentation: AkReverbZone.RemoveReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ RemoveReverbZone() [2/2]

static void AkReverbZone.RemoveReverbZone ( AkRoom reverbZone )
inlinestatic

Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms, unless they are explicitly connected with a Portal. Calls AkRoom::RemoveReverbZone() from the Reverb Zone AkRoom component.

매개변수
reverbZone The Reverb Zone AkRoom component.

다음을 참조함 : AkRoom.RemoveReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.SetReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ SetReverbZone() [1/2]

void AkReverbZone.SetReverbZone ( )
inline

Calls AkReverbZone::SetReverbZone() with this component's properties

다음을 참조함 : ParentRoom, ReverbZone, TransitionRegionWidth.


Wwise Unity Integration Documentation: AkReverbZone.SetReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ SetReverbZone() [2/2]

static void AkReverbZone.SetReverbZone | ( | AkRoom | reverbZone,
 |  | AkRoom | parentRoom,
 |  | float | transitionRegionWidth
 | ) |  |
inlinestatic

Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AkRoom::SetReverbZone() from the Reverb Zone AkRoom component with the Parent Room and transition Region Width parameters.

매개변수
reverbZone | The AkRoom component to set as a Reverb Zone.
parentRoom | The AkRoom component to set as the Reverb Zone's parent. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. Set to null to attach the Reverb Zone to the automatically created 'Outdoors' room.
transitionRegionWidth | The width of the transition region between the Reverb Zone and its parent. The transition region is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

다음을 참조함 : AkRoom.SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.ParentRoom

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ ParentRoom

AkRoom AkReverbZone.ParentRoom

Set this Room as the parent of the Reverb Zone. Sound propagates between the Reverb Zone and its parent Room as if it were the same Room without the need for a connecting Portal. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, because they often model open spaces. Leave this set to None to attach the Reverb Zone to 'Outdoors'.

다음에 의해서 참조됨 : SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.ReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ ReverbZone

AkRoom AkReverbZone.ReverbZone

Set this Room as a Reverb Zone. Sound propagates between the Reverb Zone and its parent Room as if it were the same Room without the need for a connecting Portal. Examples include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space.

다음에 의해서 참조됨 : RemoveReverbZone(), SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.TransitionRegionWidth

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ TransitionRegionWidth

float AkReverbZone.TransitionRegionWidth = 1.0f

Width of the transition region between the Reverb Zone and its parent. The transition zone is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

다음에 의해서 참조됨 : SetReverbZone().


Wwise Unity Integration Documentation: AkRoom 클래스 참조

Public 멤버 함수 | Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkRoom 클래스 참조

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals 더 자세히 ...

AkTriggerHandler를(을) 상속했습니다.

Public 멤버 함수

ulong | GetID ()
Access the room's ID 더 자세히 ...
void | SetReverbZone (AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AK::SpatialAudio::SetReverbZone() with the Parent Room and transition Region Width parameters. 더 자세히 ...
void | RemoveReverbZone ()
Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and its parent, unless they are explicitly connected with a Portal. Calls AK::SpatialAudio::RemoveReverbZone() with this Room's ID."/>. 더 자세히 ...

Public 속성

int | priority = 0
AK.Wwise.AuxBus | reverbAuxBus = new AK.Wwise.AuxBus()
The reverb auxiliary bus. 더 자세히 ...
float | reverbLevel = 1
The reverb control value for the send to the reverb aux bus. 더 자세히 ...
float | transmissionLoss = 1
Loss value modeling transmission through walls. 더 자세히 ...
AK.Wwise.Event | roomToneEvent = new AK.Wwise.Event()
Wwise Event to be posted on the room game object. 더 자세히 ...
float | roomToneAuxSend = 0
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send. 더 자세히 ...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals

The AkRoom component uses its required Collider component to determine when AkRoomAwareObjects enter and exit the room using the OnTriggerEnter and OnTriggerExit callbacks.


Wwise Unity Integration Documentation: AkRoom.GetID

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ GetID()

ulong AkRoom.GetID ( )
inline

Access the room's ID

다음에 의해서 참조됨 : RemoveReverbZone(), SetReverbZone().


Wwise Unity Integration Documentation: AkRoom.RemoveReverbZone

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ RemoveReverbZone()

void AkRoom.RemoveReverbZone ( )
inline

Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and its parent, unless they are explicitly connected with a Portal. Calls AK::SpatialAudio::RemoveReverbZone() with this Room's ID."/>.

다음을 참조함 : GetID().

다음에 의해서 참조됨 : AkReverbZone.RemoveReverbZone().


Wwise Unity Integration Documentation: AkRoom.SetReverbZone

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ SetReverbZone()

void AkRoom.SetReverbZone | ( | AkRoom | parentRoom,
 |  | float | transitionRegionWidth
 | ) |  |
inline

Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AK::SpatialAudio::SetReverbZone() with the Parent Room and transition Region Width parameters.

매개변수
parentRoom | The AkRoom component to set as the Reverb Zone's parent. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. Set to null to attach the Reverb Zone to the automatically created 'Outdoors' room.
transitionRegionWidth | The width of the transition region between the Reverb Zone and its parent. The transition region is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

다음을 참조함 : GetID().

다음에 의해서 참조됨 : AkReverbZone.SetReverbZone().


Wwise Unity Integration Documentation: AkRoom.priority

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ priority

int AkRoom.priority = 0

In cases where a game object is in an area with two rooms, the higher priority room will be chosen for AK::SpatialAudio::SetGameObjectInRoom() The higher the priority number, the higher the priority of a room.


Wwise Unity Integration Documentation: AkRoom.reverbAuxBus

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ reverbAuxBus

AK.Wwise.AuxBus AkRoom.reverbAuxBus = new AK.Wwise.AuxBus()

The reverb auxiliary bus.


Wwise Unity Integration Documentation: AkRoom.reverbLevel

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ reverbLevel

float AkRoom.reverbLevel = 1

The reverb control value for the send to the reverb aux bus.


Wwise Unity Integration Documentation: AkRoom.roomToneAuxSend

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ roomToneAuxSend

float AkRoom.roomToneAuxSend = 0

Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send.


Wwise Unity Integration Documentation: AkRoom.roomToneEvent

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ roomToneEvent

AK.Wwise.Event AkRoom.roomToneEvent = new AK.Wwise.Event()

Wwise Event to be posted on the room game object.


Wwise Unity Integration Documentation: AkRoom.transmissionLoss

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ transmissionLoss

float AkRoom.transmissionLoss = 1

Loss value modeling transmission through walls.


Wwise Unity Integration Documentation: AkRoomAwareManager 클래스 참조

모든 멤버 목록
AkRoomAwareManager 클래스 참조

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit. 더 자세히 ...

상세한 설명

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.

At the end of the frame, the AkRoomAwareObject is set in the highest priority AkRoom in Spatial Audio.


Wwise Unity Integration Documentation: AkRoomAwareObject 클래스 참조

Public 멤버 함수 | 모든 멤버 목록
AkRoomAwareObject 클래스 참조

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 멤버 함수

void | EnteredRoom (AkRoom room)
Called when entering a room. 더 자세히 ...
void | ExitedRoom (AkRoom room)
Called when exiting a room. 더 자세히 ...

상세한 설명

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component.


Wwise Unity Integration Documentation: AkRoomAwareObject.EnteredRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ EnteredRoom()

void AkRoomAwareObject.EnteredRoom ( AkRoom room )
inline

Called when entering a room.

매개변수
room The room.


Wwise Unity Integration Documentation: AkRoomAwareObject.ExitedRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ ExitedRoom()

void AkRoomAwareObject.ExitedRoom ( AkRoom room )
inline

Called when exiting a room.

매개변수
room The room.


Wwise Unity Integration Documentation: AkRoomManager 클래스 참조

모든 멤버 목록
AkRoomManager 클래스 참조

This manager tracks AkRoomPortals and the rooms that they connect (front and back room). 더 자세히 ...

상세한 설명

This manager tracks AkRoomPortals and the rooms that they connect (front and back room).

At the end of the frame, the AkRoomPortals which rooms might have changed are updated and sent to Spatial Audio.


Wwise Unity Integration Documentation: AkRoomPortal 클래스 참조

Public 멤버 함수 | Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkRoomPortal 클래스 참조

An AkRoomPortal can connect two AkRoom components together. 더 자세히 ...

AkTriggerHandler를(을) 상속했습니다.

Public 멤버 함수

ulong | GetID ()
Access the portal's ID 더 자세히 ...
override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event 더 자세히 ...
void | ClosePortal (UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event 더 자세히 ...

Public 속성

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_ROOMS_PER_PORTAL = 2
AkRoomPortals can only connect a maximum of 2 rooms. 더 자세히 ...
const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

An AkRoomPortal can connect two AkRoom components together.


Wwise Unity Integration Documentation: AkRoomPortal.ClosePortal

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ ClosePortal()

void AkRoomPortal.ClosePortal ( UnityEngine.GameObject in_gameObject )
inline

Closes the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.GetID

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ GetID()

ulong AkRoomPortal.GetID ( )
inline

Access the portal's ID


Wwise Unity Integration Documentation: AkRoomPortal.HandleEvent

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ HandleEvent()

override void AkRoomPortal.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Opens the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.MAX_ROOMS_PER_PORTAL

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ MAX_ROOMS_PER_PORTAL

const int AkRoomPortal.MAX_ROOMS_PER_PORTAL = 2
static

AkRoomPortals can only connect a maximum of 2 rooms.


Wwise Unity Integration Documentation: AkRoomPortalObstruction 클래스 참조

Public 속성 | 모든 멤버 목록
AkRoomPortalObstruction 클래스 참조

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them. 더 자세히 ...

AkObstructionOcclusion를(을) 상속했습니다.

Public 속성

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. 더 자세히 ...
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. 더 자세히 ...
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. 더 자세히 ...
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. 더 자세히 ...

상세한 설명

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them.

If no spatial audio listener has been registered, there will be no obstruction.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw 클래스 참조

Public 속성 | 모든 멤버 목록
AkSpatialAudioDebugDraw 클래스 참조

Add this script on a GameObject to print Spatial Audio paths. 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

Public 속성

bool | drawFirstOrderReflections = false
This allows you to visualize first order reflection sound paths. 더 자세히 ...
bool | drawSecondOrderReflections = false
This allows you to visualize second order reflection sound paths. 더 자세히 ...
bool | drawHigherOrderReflections = false
This allows you to visualize third or higher order reflection sound paths. 더 자세히 ...
bool | drawDiffractionPaths = false
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener. 더 자세히 ...

상세한 설명

Add this script on a GameObject to print Spatial Audio paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawDiffractionPaths

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawDiffractionPaths

bool AkSpatialAudioDebugDraw.drawDiffractionPaths = false

This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawFirstOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawFirstOrderReflections

bool AkSpatialAudioDebugDraw.drawFirstOrderReflections = false

This allows you to visualize first order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawHigherOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawHigherOrderReflections

bool AkSpatialAudioDebugDraw.drawHigherOrderReflections = false

This allows you to visualize third or higher order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawSecondOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawSecondOrderReflections

bool AkSpatialAudioDebugDraw.drawSecondOrderReflections = false

This allows you to visualize second order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter 클래스 참조

Public 속성 | 모든 멤버 목록
AkSpatialAudioEmitter 클래스 참조

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring. 더 자세히 ...

MonoBehaviour, AK.Wwise.IMigratable를(을) 상속했습니다.

Public 속성

AK.Wwise.AuxBus | reflectAuxBus = new AK.Wwise.AuxBus()
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component. 더 자세히 ...
float | reflectionMaxPathLength = 1000
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool. 더 자세히 ...
float | reflectionsAuxBusGain = 1
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component. 더 자세히 ...
uint | reflectionsOrder = 1
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings. 더 자세히 ...
float | roomReverbAuxBusGain = 1
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool. 더 자세히 ...
uint | diffractionMaxEdges = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 더 자세히 ...
uint | diffractionMaxPaths = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 더 자세히 ...
uint | diffractionMaxPathLength = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 더 자세히 ...
bool | drawFirstOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 더 자세히 ...
bool | drawSecondOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 더 자세히 ...
bool | drawHigherOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 더 자세히 ...
bool | drawDiffractionPaths = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 더 자세히 ...

상세한 설명

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring.

Some functionalities were moved to different components. See the AkEarlyReflections and AkSpatialAudioDebugDraw components for more details.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxEdges

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxEdges

uint AkSpatialAudioEmitter.diffractionMaxEdges = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPathLength

uint AkSpatialAudioEmitter.diffractionMaxPathLength = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPaths

uint AkSpatialAudioEmitter.diffractionMaxPaths = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawDiffractionPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawDiffractionPaths

bool AkSpatialAudioEmitter.drawDiffractionPaths = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawFirstOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawFirstOrderReflections

bool AkSpatialAudioEmitter.drawFirstOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawHigherOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawHigherOrderReflections

bool AkSpatialAudioEmitter.drawHigherOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawSecondOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawSecondOrderReflections

bool AkSpatialAudioEmitter.drawSecondOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectAuxBus

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectAuxBus

AK.Wwise.AuxBus AkSpatialAudioEmitter.reflectAuxBus = new AK.Wwise.AuxBus()

(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionMaxPathLength

float AkSpatialAudioEmitter.reflectionMaxPathLength = 1000

(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsAuxBusGain

float AkSpatialAudioEmitter.reflectionsAuxBusGain = 1

(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsOrder

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsOrder

uint AkSpatialAudioEmitter.reflectionsOrder = 1

(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.roomReverbAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ roomReverbAuxBusGain

float AkSpatialAudioEmitter.roomReverbAuxBusGain = 1

(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioListener 클래스 참조

클래스 | 속성 | 모든 멤버 목록
AkSpatialAudioListener 클래스 참조

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. 더 자세히 ...

MonoBehaviour, AK.Wwise.IMigratable를(을) 상속했습니다.

클래스

class SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. 더 자세히 ...

속성

static AkAudioListener? | TheSpatialAudioListener [get]
Returns the "single" spatial audio listener. 더 자세히 ...
static SpatialAudioListenerList | SpatialAudioListeners [get]
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners. 더 자세히 ...

상세한 설명

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

참고
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList 클래스 참조

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Public 멤버 함수 | 모든 멤버 목록
AkSpatialAudioListener.SpatialAudioListenerList 클래스 참조

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. 더 자세히 ...

Public 멤버 함수

bool | Add (AkSpatialAudioListener listener)
Uniquely adds listeners to the list 더 자세히 ...
bool | Remove (AkSpatialAudioListener listener)
Removes listeners from the list 더 자세히 ...

상세한 설명

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time.


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Add

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Add()

bool AkSpatialAudioListener.SpatialAudioListenerList.Add ( AkSpatialAudioListener listener )
inline

Uniquely adds listeners to the list

매개변수
listener
반환값


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Remove

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Remove()

bool AkSpatialAudioListener.SpatialAudioListenerList.Remove ( AkSpatialAudioListener listener )
inline

Removes listeners from the list

매개변수
listener
반환값


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListeners

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ SpatialAudioListeners

SpatialAudioListenerList AkSpatialAudioListener.SpatialAudioListeners
staticget

Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.


Wwise Unity Integration Documentation: AkSpatialAudioListener.TheSpatialAudioListener

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ TheSpatialAudioListener

AkAudioListener? AkSpatialAudioListener.TheSpatialAudioListener
staticget

Returns the "single" spatial audio listener.


Wwise Unity Integration Documentation: AkState 클래스 참조

Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkState 클래스 참조

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it. 더 자세히 ...

AkDragDropTriggerHandler, AK.Wwise.IMigratable를(을) 상속했습니다.

Public 속성

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it.

참고
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSurfaceReflector 클래스 참조

클래스 | Public 멤버 함수 | 정적 Public 멤버 함수 | Public 속성 | 모든 멤버 목록
AkSurfaceReflector 클래스 참조

This component converts the provided mesh into Spatial Audio Geometry. 더 자세히 ...

MonoBehaviour, AK.Wwise.IMigratable를(을) 상속했습니다.

클래스

struct GeometryData
The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry() 더 자세히 ...

Public 멤버 함수

void | SetGeometry ()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh. 더 자세히 ...
void | SetGeometryInstance ()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform. 더 자세히 ...
void | UpdateGeometry ()
Update this component's geometry instance 더 자세히 ...
void | RemoveGeometry ()
Remove this component's geometry and corresponding instance from Spatial Audio. 더 자세히 ...
void | RemoveGeometryInstance ()
Remove this component's geometry instance from Spatial Audio. 더 자세히 ...

정적 Public 멤버 함수

static void | SetGeometryFromMesh (UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance(). 더 자세히 ...
static void | GetGeometryDataFromMesh (UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkSoundEngine.SetGeometry() 더 자세히 ...
static void | SetGeometryInstance (ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction)
Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. 더 자세히 ...

Public 속성

UnityEngine.Mesh | Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh. 더 자세히 ...
AK.Wwise.AcousticTexture[] | AcousticTextures = new AK.Wwise.AcousticTexture[1]
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry. 더 자세히 ...
float[] | TransmissionLossValues = new[] { 1.0f }
The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0. 더 자세히 ...
bool | EnableDiffraction = true
Switch to enable or disable geometric diffraction for this mesh. 더 자세히 ...
bool | EnableDiffractionOnBoundaryEdges = false
Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle. 더 자세히 ...
AkRoom | AssociatedRoom = null

상세한 설명

This component converts the provided mesh into Spatial Audio Geometry.

This component takes a mesh as a parameter. The triangles of the mesh are sent to Spatial Audio by calling SpatialAudio::AddGeometrySet(). The triangles reflect sounds that have an associated early reflections bus. If diffraction is enabled on this component, spatial audio also finds edges on the provided mesh, which diffract sounds that are diffraction enabled.


Wwise Unity Integration Documentation: AkSurfaceReflector.GeometryData 구조체 참조

  • AkSurfaceReflector
  • GeometryData
모든 멤버 목록
AkSurfaceReflector.GeometryData 구조체 참조

The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry() 더 자세히 ...

상세한 설명

The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()


Wwise Unity Integration Documentation: AkSurfaceReflector.GetGeometryDataFromMesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ GetGeometryDataFromMesh()

static void AkSurfaceReflector.GetGeometryDataFromMesh | ( | UnityEngine.Mesh | mesh,
 |  | ref GeometryData | geometryData,
 |  | AK.Wwise.AcousticTexture[] | acousticTextures = null,
 |  | float[] | transmissionLossValues = null,
 |  | string | name = ""
 | ) |  |
inlinestatic

Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkSoundEngine.SetGeometry()

매개변수
mesh | The mesh representing the geometry to be sent to Spatial Audio.
geometryData | (Output)The Spatial Audio Geometry Data created from the mesh.
acousticTextures | The acoustic texture of each surface of the geometry. Acoustic textures describe the filtering when sound reflects on the surface.
transmissionLossValues | The transmission loss value of each surface of the geometry. Transmission loss is the filtering when the sound goes through the surface.
name | A name for the geometry.

다음에 의해서 참조됨 : SetGeometryFromMesh().


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometry()

void AkSurfaceReflector.RemoveGeometry ( )
inline

Remove this component's geometry and corresponding instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometryInstance()

void AkSurfaceReflector.RemoveGeometryInstance ( )
inline

Remove this component's geometry instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometry()

void AkSurfaceReflector.SetGeometry ( )
inline

Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.

다음을 참조함 : AcousticTextures, EnableDiffraction, EnableDiffractionOnBoundaryEdges, Mesh, SetGeometryFromMesh(), TransmissionLossValues.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryFromMesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryFromMesh()

static void AkSurfaceReflector.SetGeometryFromMesh | ( | UnityEngine.Mesh | mesh,
 |  | ulong | geometryID,
 |  | bool | enableDiffraction,
 |  | bool | enableDiffractionOnBoundaryEdges,
 |  | AK.Wwise.AcousticTexture[] | acousticTextures = null,
 |  | float[] | transmissionLossValues = null,
 |  | string | name = ""
 | ) |  |
inlinestatic

Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance().

매개변수
mesh | The mesh representing the geometry to be sent to Spatial Audio.
geometryID | A unique ID representing the geometry.
enableDiffraction | Enable the edges of this geometry to become diffraction edges.
enableDiffractionOnBoundaryEdges | Enable the boundary edges of this geometry to become diffraction edges. Boundary edges are edges that are connected to only one triangle.
acousticTextures | The acoustic texture of each surface of the geometry. Acoustic textures describe the filtering when sound reflects on the surface.
transmissionLossValues | The transmission loss value of each surface of the geometry. Transmission loss is the filtering when the sound goes through the surface.
name | A name for the geometry.

다음을 참조함 : GetGeometryDataFromMesh().

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [1/2]

void AkSurfaceReflector.SetGeometryInstance ( )
inline

Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.

다음을 참조함 : AssociatedRoom.

다음에 의해서 참조됨 : UpdateGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [2/2]

static void AkSurfaceReflector.SetGeometryInstance | ( | ulong | geometryInstanceID,
 |  | ulong | geometryID,
 |  | ulong | associatedRoomID,
 |  | UnityEngine.Transform | transform,
 |  | bool | useForReflectionAndDiffraction
 | ) |  |
inlinestatic

Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation.

매개변수
geometryInstanceID | A unique ID to for the geometry instance. It must be unique amongst all geometry instances, including geometry instances referencing different geometries.
geometryID | The ID of the geometry referenced by this instance.
associatedRoomID | The ID of the room this geometry is encompassed in, if any.
transform | The transform to be applied to the geometry to convert it in world positions.
useForReflectionAndDiffraction | When enabled, the geometry instance triangles are used to compute reflection and diffraction. Set to false when using a geometry instance only to describe a room, and not for reflection and diffraction calculation.


Wwise Unity Integration Documentation: AkSurfaceReflector.UpdateGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ UpdateGeometry()

void AkSurfaceReflector.UpdateGeometry ( )
inline

Update this component's geometry instance

다음을 참조함 : SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.AcousticTextures

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AcousticTextures

AK.Wwise.AcousticTexture [] AkSurfaceReflector.AcousticTextures = new AK.Wwise.AcousticTexture[1]

The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry.

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.AssociatedRoom

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AssociatedRoom

AkRoom AkSurfaceReflector.AssociatedRoom = null

(Deprecated) Associate this AkSurfaceReflector component with a Room. This property is deprecated and will be removed in a future version. We recommend not using it by leaving it set to None. Associating an AkSurfaceReflector with a particular Room limits the scope in which the geometry is accessible. Doing so reduces the search space for ray casting performed by reflection and diffraction calculations. When set to None, this geometry has a global scope. Note if one or more geometry sets are associated with a room, that room can no longer access geometry that is in the global scope.

다음에 의해서 참조됨 : SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffraction

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffraction

bool AkSurfaceReflector.EnableDiffraction = true

Switch to enable or disable geometric diffraction for this mesh.

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffractionOnBoundaryEdges

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffractionOnBoundaryEdges

bool AkSurfaceReflector.EnableDiffractionOnBoundaryEdges = false

Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle.

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.Mesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ Mesh

UnityEngine.Mesh AkSurfaceReflector.Mesh

The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.TransmissionLossValues

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ TransmissionLossValues

float [] AkSurfaceReflector.TransmissionLossValues = new[] { 1.0f }

The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0.

다음에 의해서 참조됨 : SetGeometry().


Wwise Unity Integration Documentation: AkSwitch 클래스 참조

Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkSwitch 클래스 참조

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it. 더 자세히 ...

AkDragDropTriggerHandler, AK.Wwise.IMigratable를(을) 상속했습니다.

Public 속성

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it.

참고
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkTriggerBase 클래스 참조

Public 멤버 함수 | Public 속성 | 모든 멤버 목록
AkTriggerBase 클래스 참조

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwise 이벤트에 새로운 트리거 추가하기 더 자세히 ...

MonoBehaviour를(을) 상속했습니다.

AkTriggerCollisionEnter, AkTriggerCollisionExit, AkTriggerDisable, AkTriggerEnable, AkTriggerEnter, AkTriggerExit, AkTriggerMouseDown, AkTriggerMouseEnter, AkTriggerMouseExit, AkTriggerMouseUp에 의해 상속되었습니다.

Public 멤버 함수

delegate void Trigger (UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers. 더 자세히 ...

Public 속성

Trigger triggerDelegate = null
All components reacting to the trigger will be registered in this delegate. 더 자세히 ...

상세한 설명

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwise 이벤트에 새로운 트리거 추가하기


Wwise Unity Integration Documentation: AkTriggerBase.Trigger

  • AkTriggerBase
Trigger
triggerDelegate

◆ Trigger()

delegate void AkTriggerBase.Trigger ( UnityEngine.GameObject in_gameObject )

Delegate declaration for all Wwise Triggers.

매개변수
in_gameObject in_gameObject is used to pass "Collidee" objects when Colliders are used. Some components have the option "Use other object", this is the object they'll use.


Wwise Unity Integration Documentation: AkTriggerBase.triggerDelegate

  • AkTriggerBase
Trigger
triggerDelegate

◆ triggerDelegate

Trigger AkTriggerBase.triggerDelegate = null

All components reacting to the trigger will be registered in this delegate.


Wwise Unity Integration Documentation: AkWaapiUtilities 클래스 참조

클래스 | Public 멤버 함수 | 정적 Public 멤버 함수 | 정적 Public 속성 | 모든 멤버 목록
AkWaapiUtilities 클래스 참조

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages. 더 자세히 ...

클래스

class | SubscriptionInfo
Class used to store information about a specific subscription. 더 자세히 ...
struct | WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by the command queue. 더 자세히 ...

Public 멤버 함수

delegate void | GetResultListDelegate< T > (List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request. 더 자세히 ...
delegate void | GetResultDelegate< T > (T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request. 더 자세히 ...

정적 Public 멤버 함수

static bool | IsConnected ()
Check whether the client is currently connected. 더 자세히 ...
static void | Disconnected ()
Invoked after the client has disconnected from Wwise authoring. 더 자세히 ...
static string | GetStatusString ()
Returns a rich text string representing the current WAAPI connection status. 더 자세히 ...
static void | QueueCommand (string uri, string args, string options)
Use this function to enqueue a command with no expected return object. 더 자세히 ...
static void | QueueCommandWithReturnType< T > (string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. /// 더 자세히 ...
static void | QueueCommandWithReturnWwiseObjects< T > (WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response. 더 자세히 ...
static void | GetWwiseObject< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options. 더 자세히 ...
static void | GetWwiseObjects< T > (List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options. 더 자세히 ...
static void | GetWwiseObjectAndAncestors< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback. 더 자세히 ...
static void | GetWwiseObjectAndDescendants< T > (System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback. 더 자세히 ...
static void | GetWwiseObjectAndDescendants< T > (string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback 더 자세히 ...
static void | Search< T > (string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback 더 자세히 ...
static void | GetChildren< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object. 더 자세히 ...
static void | GetProject< T > (GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project. 더 자세히 ...
static List< WwiseObjectInfo > | ParseObjectInfo (List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo. 더 자세히 ...
static void | SelectObjectInAuthoring (System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static void | OpenWorkUnitInExplorer (System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static void | OpenSoundBankInExplorer (System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue. 더 자세히 ...
static void | Rename (System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static void | Delete (System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static bool | IsPlayable (WwiseObjectType type)
Checks if Wwise object is playable. 더 자세히 ...
static void | TogglePlayEvent (WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

매개변수
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.
더 자세히 ...
static void | StopAllTransports ()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static void | Subscribe (string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static void | Unsubscribe (uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue. 더 자세히 ...
static List< WwiseObjectInfo > | ParseSelectedObjects (string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic. 더 자세히 ...
static WwiseRenameInfo | ParseRenameObject (string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic. 더 자세히 ...
static WwiseChildModifiedInfo | ParseChildAddedOrRemoved (string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic. 더 자세히 ...

정적 Public 속성

static System.Action< bool > | Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions). 더 자세히 ...
static System.Action | Connected
Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in. 더 자세히 ...
static System.Action | QueueConsumed
Fired when all commands in the queue have been executed. 더 자세히 ...

상세한 설명

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages.


Wwise Unity Integration Documentation: AkWaapiUtilities.SubscriptionInfo 클래스 참조

  • AkWaapiUtilities
  • SubscriptionInfo
모든 멤버 목록
AkWaapiUtilities.SubscriptionInfo 클래스 참조

Class used to store information about a specific subscription. 더 자세히 ...

상세한 설명

Class used to store information about a specific subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.WaapiCommand 구조체 참조

  • AkWaapiUtilities
  • WaapiCommand
모든 멤버 목록
AkWaapiUtilities.WaapiCommand 구조체 참조

A simple structure containing an async payload function that will be executed when it is consumed by the command queue. 더 자세히 ...

상세한 설명

A simple structure containing an async payload function that will be executed when it is consumed by the command queue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Delete

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Delete()

static void AkWaapiUtilities.Delete ( System.Guid guid )
inlinestatic

Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue.

매개변수
guid GUID of the object to be deleted.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnected()

static void AkWaapiUtilities.Disconnected ( )
inlinestatic

Invoked after the client has disconnected from Wwise authoring.

다음을 참조함 : Disconnecting.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetChildren< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetChildren< T >()

static void AkWaapiUtilities.GetChildren< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Get the children of a given object.

매개변수
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetProject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetProject< T >()

static void AkWaapiUtilities.GetProject< T > | ( | GetResultListDelegate< T > | callback,
 |  | ReturnOptions | options
 | ) |  |
inlinestatic

Get the WwiseObjectInfo for the project.

매개변수
callback | Function accepting a list of WwiseObjectInfo. The first element of the list will be the project info.
options | Specifies which object properties to include in the response


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultDelegate< T >()

delegate void AkWaapiUtilities.GetResultDelegate< T > ( T result )

Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request.

매개변수
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultListDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultListDelegate< T >()

delegate void AkWaapiUtilities.GetResultListDelegate< T > ( List< T > result )

Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request.

매개변수
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetStatusString

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetStatusString()

static string AkWaapiUtilities.GetStatusString ( )
inlinestatic

Returns a rich text string representing the current WAAPI connection status.

반환값


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObject< T >()

static void AkWaapiUtilities.GetWwiseObject< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a Wwise object with custom return options.

템플릿 파라메터
T Type of the object to be deserialized from the response.
매개변수
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndAncestors< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndAncestors< T >()

static void AkWaapiUtilities.GetWwiseObjectAndAncestors< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback.

매개변수
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [1/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | string | identifier,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback

매개변수
identifier | Can bethe target object GUID or path within the hierarchy.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [2/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback.

매개변수
guid | GUID of the target object.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjects< T >()

static void AkWaapiUtilities.GetWwiseObjects< T > | ( | List< System.Guid > | guids,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a list of Wwise objects with custom return options.

템플릿 파라메터
T Type of the object to be deserialized from the response.
매개변수
guids | GUIDs of the target objects.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.IsConnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsConnected()

static bool AkWaapiUtilities.IsConnected ( )
inlinestatic

Check whether the client is currently connected.

반환값


Wwise Unity Integration Documentation: AkWaapiUtilities.IsPlayable

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsPlayable()

static bool AkWaapiUtilities.IsPlayable ( WwiseObjectType type )
inlinestatic

Checks if Wwise object is playable.

매개변수
type WwiseObjectType of object to check.
반환값
True if playable

다음에 의해서 참조됨 : TogglePlayEvent().


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenSoundBankInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenSoundBankInExplorer()

static void AkWaapiUtilities.OpenSoundBankInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue.

매개변수
guid GUID of the SoundBank to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenWorkUnitInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenWorkUnitInExplorer()

static void AkWaapiUtilities.OpenWorkUnitInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue.

매개변수
guid GUID of the object to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseChildAddedOrRemoved

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseChildAddedOrRemoved()

static WwiseChildModifiedInfo AkWaapiUtilities.ParseChildAddedOrRemoved ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic.

매개변수
json Json string containing the message.
반환값
WwiseChildModifiedInfo containing parent and child object information.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseObjectInfo

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseObjectInfo()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseObjectInfo ( List< WwiseObjectInfoJsonObject > returnObjects )
inlinestatic

Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo.

매개변수
returnObjects
반환값


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseRenameObject

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseRenameObject()

static WwiseRenameInfo AkWaapiUtilities.ParseRenameObject ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.nameChanged topic.

매개변수
json Json string containing the message.
반환값
WwiseRenameInfo containing the object information and the new name.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseSelectedObjects

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseSelectedObjects()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseSelectedObjects ( string json )
inlinestatic

Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.

매개변수
json Json string containing the message.
반환값
List of WwiseObjectInfo objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommand

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommand()

static void AkWaapiUtilities.QueueCommand | ( | string | uri,
 |  | string | args,
 |  | string | options
 | ) |  |
inlinestatic

Use this function to enqueue a command with no expected return object.

매개변수
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnType< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnType< T >()

static void AkWaapiUtilities.QueueCommandWithReturnType< T > | ( | string | uri,
 |  | GetResultDelegate< T > | callback,
 |  | string | args = null,
 |  | string | options = null
 | ) |  |
inlinestatic

Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. ///

템플릿 파라메터
T Type of the expected return object
매개변수
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options
callback | Function accepting an argument of type T


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnWwiseObjects< T >()

static void AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T > | ( | WaqlArgs | args,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a command with a payload that desirializes the list of wwise objects from the response.

매개변수
args
options
callback


Wwise Unity Integration Documentation: AkWaapiUtilities.Rename

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Rename()

static void AkWaapiUtilities.Rename | ( | System.Guid | guid,
 |  | string | newName
 | ) |  |
inlinestatic

Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue.

매개변수
guid | GUID of the object to be renamed.
newName | New name for the wwise object.


Wwise Unity Integration Documentation: AkWaapiUtilities.Search< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Search< T >()

static void AkWaapiUtilities.Search< T > | ( | string | searchString,
 |  | WwiseObjectType | objectType,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback

매개변수
searchString | Characters to search for.
options | Specifies which object properties to include in the response
objectType | An optional object type used to filter search results.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.SelectObjectInAuthoring

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ SelectObjectInAuthoring()

static void AkWaapiUtilities.SelectObjectInAuthoring ( System.Guid guid )
inlinestatic

Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue.

매개변수
guid GUID of the object to be selected.


Wwise Unity Integration Documentation: AkWaapiUtilities.StopAllTransports

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ StopAllTransports()

static void AkWaapiUtilities.StopAllTransports ( )
inlinestatic

Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Subscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Subscribe()

static void AkWaapiUtilities.Subscribe | ( | string | topic,
 |  | Wamp.PublishHandler | subscriptionCallback,
 |  | System.Action< SubscriptionInfo > | handshakeCallback
 | ) |  |
inlinestatic

Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue.

매개변수
topic | The topic URI to subscribe to.
subscriptionCallback | Delegate function to call when the topic is published.
handshakeCallback | Action to be executed once the subscription has been made. This should store the subscription ID so that the subscription can be cleaned up when it is no longer needed.

다음에 의해서 참조됨 : AkWwiseTreeWAAPIDataSource.SubscribeTopics().


Wwise Unity Integration Documentation: AkWaapiUtilities.TogglePlayEvent

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ TogglePlayEvent()

static void AkWaapiUtilities.TogglePlayEvent | ( | WwiseObjectType | objectType,
 |  | System.Guid | guid
 | ) |  |
inlinestatic

Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

매개변수
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.

다음을 참조함 : IsPlayable().


Wwise Unity Integration Documentation: AkWaapiUtilities.Unsubscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Unsubscribe()

static void AkWaapiUtilities.Unsubscribe ( uint id )
inlinestatic

Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue.

매개변수
id The subscription ID received from the initial subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.Connected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Connected

System.Action AkWaapiUtilities.Connected
static

Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnecting

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnecting

System.Action<bool> AkWaapiUtilities.Disconnecting
static

Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions).

다음에 의해서 참조됨 : Disconnected().


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueConsumed

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueConsumed

System.Action AkWaapiUtilities.QueueConsumed
static

Fired when all commands in the queue have been executed.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource 클래스 참조

Public 멤버 함수 | 모든 멤버 목록
AkWwiseTreeWAAPIDataSource 클래스 참조

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions. 더 자세히 ...

AkWwiseTreeDataSource를(을) 상속했습니다.

Public 멤버 함수

void SubscribeTopics ()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer. 더 자세히 ...

상세한 설명

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource.SubscribeTopics

  • AkWwiseTreeWAAPIDataSource
SubscribeTopics

◆ SubscribeTopics()

void AkWwiseTreeWAAPIDataSource.SubscribeTopics ( )
inline

Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer.

다음을 참조함 : AkWaapiUtilities.Subscribe().


Wwise Unity Integration Documentation: AkWwiseTrigger 클래스 참조

Public 속성 | 정적 Public 속성 | 모든 멤버 목록
AkWwiseTrigger 클래스 참조

This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it. 더 자세히 ...

AkDragDropTriggerHandler, AK.Wwise.IMigratable를(을) 상속했습니다.

Public 속성

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 더 자세히 ...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 더 자세히 ...

정적 Public 속성

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 더 자세히 ...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 더 자세히 ...

상세한 설명

This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it.

참고
  • Working with Triggers > Overview (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: Args 클래스 참조

모든 멤버 목록
Args 클래스 참조

Abstract base class for WAAPI command arguments. 더 자세히 ...

Args에 대한 상속 다이어그램 :
JsonSerializable ArgsCommand ArgsDisplayName ArgsObject ArgsPlay ArgsRename ArgsTransport WaqlArgs

상세한 설명

Abstract base class for WAAPI command arguments.


Wwise Unity Integration Documentation: ArgsCommand 클래스 참조

모든 멤버 목록
ArgsCommand 클래스 참조

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync(). 더 자세히 ...

ArgsCommand에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync().


Wwise Unity Integration Documentation: ArgsDisplayName 클래스 참조

모든 멤버 목록
ArgsDisplayName 클래스 참조

WAAPI arguments containing an object identfier and name used when deleting an object. 더 자세히 ...

ArgsDisplayName에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing an object identfier and name used when deleting an object.


Wwise Unity Integration Documentation: ArgsObject 클래스 참조

모든 멤버 목록
ArgsObject 클래스 참조

WAAPI arguments containing an object identfier. 더 자세히 ...

ArgsObject에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing an object identfier.


Wwise Unity Integration Documentation: ArgsPlay 클래스 참조

모든 멤버 목록
ArgsPlay 클래스 참조

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback. 더 자세히 ...

ArgsPlay에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.


Wwise Unity Integration Documentation: ArgsRename 클래스 참조

모든 멤버 목록
ArgsRename 클래스 참조

WAAPI arguments containing an object identfier and new value used when renaming an object. 더 자세히 ...

ArgsRename에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing an object identfier and new value used when renaming an object.


Wwise Unity Integration Documentation: ArgsTransport 클래스 참조

모든 멤버 목록
ArgsTransport 클래스 참조

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands. 더 자세히 ...

ArgsTransport에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.


Wwise Unity Integration Documentation: ErrorDetails 클래스 참조

모든 멤버 목록
ErrorDetails 클래스 참조

Used to deserialize details in WAAPI error messages. 더 자세히 ...

ErrorDetails에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize details in WAAPI error messages.


Wwise Unity Integration Documentation: ErrorMessage 클래스 참조

모든 멤버 목록
ErrorMessage 클래스 참조

Used to deserialize WAAPI error messages. 더 자세히 ...

ErrorMessage에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize WAAPI error messages.


Wwise Unity Integration Documentation: JsonSerializable 클래스 참조

모든 멤버 목록
JsonSerializable 클래스 참조

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson. 더 자세히 ...

JsonSerializable에 대한 상속 다이어그램 :
Args ErrorDetails ErrorMessage Options ReturnTransport ReturnWwiseObjects< T > ReturnWwiseObjects< T > SelectedWwiseObjects TransportState WwiseChildModifiedInfo WwiseRenameInfo

상세한 설명

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson.


Wwise Unity Integration Documentation: Options 클래스 참조

모든 멤버 목록
Options 클래스 참조

Abstract base class for WAAPI command options. 더 자세히 ...

Options에 대한 상속 다이어그램 :
JsonSerializable ReturnOptions TransportOptions

상세한 설명

Abstract base class for WAAPI command options.


Wwise Unity Integration Documentation: ReturnOptions 클래스 참조

모든 멤버 목록
ReturnOptions 클래스 참조

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects. 더 자세히 ...

ReturnOptions에 대한 상속 다이어그램 :
Options JsonSerializable

상세한 설명

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.


Wwise Unity Integration Documentation: ReturnTransport 클래스 참조

모든 멤버 목록
ReturnTransport 클래스 참조

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID. 더 자세히 ...

ReturnTransport에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID.


Wwise Unity Integration Documentation: ReturnWwiseObjects 클래스 참조

ReturnWwiseObjects 클래스 참조

Class used to deserialize a WAAPI response containing Wwise objects. 더 자세히 ...

상세한 설명

Class used to deserialize a WAAPI response containing Wwise objects.


Wwise Unity Integration Documentation: SelectedWwiseObjects 클래스 참조

모든 멤버 목록
SelectedWwiseObjects 클래스 참조

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic. 더 자세히 ...

SelectedWwiseObjects에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.


Wwise Unity Integration Documentation: TransportOptions 클래스 참조

모든 멤버 목록
TransportOptions 클래스 참조

WAAPI options used to specify the transport ID when subscribing. 더 자세히 ...

TransportOptions에 대한 상속 다이어그램 :
Options JsonSerializable

상세한 설명

WAAPI options used to specify the transport ID when subscribing.


Wwise Unity Integration Documentation: TransportState 클래스 참조

모든 멤버 목록
TransportState 클래스 참조

Used to deserialize transport-state information receieved from the transport.stateChanged topic. 더 자세히 ...

TransportState에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize transport-state information receieved from the transport.stateChanged topic.


Wwise Unity Integration Documentation: WaapiHelper 클래스 참조

모든 멤버 목록
WaapiHelper 클래스 참조

Contains a helper function GetWwiseObjectTypeFromString. 더 자세히 ...

상세한 설명

Contains a helper function GetWwiseObjectTypeFromString.


Wwise Unity Integration Documentation: WaapiKeywords 클래스 참조

정적 Public 속성 | 모든 멤버 목록
WaapiKeywords 클래스 참조

Contains fields for specific WAAPI keywords. 더 자세히 ...

정적 Public 속성

static ReadOnlyDictionary< WwiseObjectType, string > | WwiseObjectTypeStrings
Maps WwiseObjectType to strings. 더 자세히 ...
static ReadOnlyDictionary< string, string > | FolderDisplaynames
Maps root folder names to displayed strings. 더 자세히 ...
static ReadOnlyDictionary< string, WwiseObjectType > | typeStringDict
Maps strings to WwiseObjectType. 더 자세히 ...

상세한 설명

Contains fields for specific WAAPI keywords.


Wwise Unity Integration Documentation: WaapiKeywords.FolderDisplaynames

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ FolderDisplaynames

ReadOnlyDictionary<string, string> WaapiKeywords.FolderDisplaynames
static

Maps root folder names to displayed strings.


Wwise Unity Integration Documentation: WaapiKeywords.typeStringDict

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ typeStringDict

ReadOnlyDictionary<string, WwiseObjectType> WaapiKeywords.typeStringDict
static

Maps strings to WwiseObjectType.


Wwise Unity Integration Documentation: WaapiKeywords.WwiseObjectTypeStrings

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ WwiseObjectTypeStrings

ReadOnlyDictionary<WwiseObjectType, string> WaapiKeywords.WwiseObjectTypeStrings
static

Maps WwiseObjectType to strings.


Wwise Unity Integration Documentation: Wamp 클래스 참조

클래스 | Public 멤버 함수 | 모든 멤버 목록
Wamp 클래스 참조

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise. 더 자세히 ...

클래스

class | ErrorException
Exception thrown during WAMP operations. 더 자세히 ...
class | TimeoutException
Exception thrown during WAMP operations when the timeout is reached. 더 자세히 ...

Public 멤버 함수

delegate void PublishHandler (string json)
Publish events are delegates registered with Subscribe. 더 자세히 ...

상세한 설명

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise.


Wwise Unity Integration Documentation: Wamp.ErrorException 클래스 참조

  • Wamp
  • ErrorException
모든 멤버 목록
Wamp.ErrorException 클래스 참조

Exception thrown during WAMP operations. 더 자세히 ...

Exception를(을) 상속했습니다.

상세한 설명

Exception thrown during WAMP operations.


Wwise Unity Integration Documentation: Wamp.TimeoutException 클래스 참조

  • Wamp
  • TimeoutException
모든 멤버 목록
Wamp.TimeoutException 클래스 참조

Exception thrown during WAMP operations when the timeout is reached. 더 자세히 ...

Exception를(을) 상속했습니다.

상세한 설명

Exception thrown during WAMP operations when the timeout is reached.


Wwise Unity Integration Documentation: Wamp.PublishHandler

  • Wamp
PublishHandler

◆ PublishHandler()

delegate void Wamp.PublishHandler ( string json )

Publish events are delegates registered with Subscribe.


Wwise Unity Integration Documentation: WaqlArgs 클래스 참조

모든 멤버 목록
WaqlArgs 클래스 참조

WAAPI arguments containing a WAQL string. 더 자세히 ...

WaqlArgs에 대한 상속 다이어그램 :
Args JsonSerializable

상세한 설명

WAAPI arguments containing a WAQL string.


Wwise Unity Integration Documentation: WwiseChildModifiedInfo 클래스 참조

모든 멤버 목록
WwiseChildModifiedInfo 클래스 참조

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics. 더 자세히 ...

WwiseChildModifiedInfo에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics.


Wwise Unity Integration Documentation: WwiseObjectInfo 구조체 참조

모든 멤버 목록
WwiseObjectInfo 구조체 참조

Class containing the information returned by a WAAPI request for an object. 더 자세히 ...

상세한 설명

Class containing the information returned by a WAAPI request for an object.


Wwise Unity Integration Documentation: WwiseObjectInfoJsonObject 클래스 참조

모든 멤버 목록
WwiseObjectInfoJsonObject 클래스 참조

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo. 더 자세히 ...

상세한 설명

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo.


Wwise Unity Integration Documentation: WwiseObjectInfoParent 클래스 참조

모든 멤버 목록
WwiseObjectInfoParent 클래스 참조

Contains the GUID of the returned object's parent. 더 자세히 ...

상세한 설명

Contains the GUID of the returned object's parent.


Wwise Unity Integration Documentation: WwiseRenameInfo 클래스 참조

모든 멤버 목록
WwiseRenameInfo 클래스 참조

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic. 더 자세히 ...

WwiseRenameInfo에 대한 상속 다이어그램 :
JsonSerializable

상세한 설명

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic.


Wwise Unity Integration Documentation: 클래스 색인

클래스 색인
a | b | c | e | g | j | o | r | s | t | w
a
AkRadialEmitter ArgsObject
j
TransportOptions
AkReverbZone ArgsPlay TransportState
ak AkRoom ArgsRename JsonSerializable Wamp.TimeoutException
AcousticTexture (AK.Wwise) AkRoomAwareManager ArgsTransport
o
w
AuxBus (AK.Wwise) AkRoomAwareObject
b
AkAmbient AkRoomManager Options AkWaapiUtilities.WaapiCommand
AkAmbientLargeModePositioner AkRoomPortal Bank (AK.Wwise)
r
WaapiHelper
AkAudioListener AkRoomPortalObstruction BaseGroupType (AK.Wwise) WaapiKeywords
AkBank AkSpatialAudioDebugDraw BaseType (AK.Wwise) RTPC (AK.Wwise) Wamp
AkEarlyReflections AkSpatialAudioEmitter
c
ReturnOptions WaqlArgs
AkEmitterObstructionOcclusion AkSpatialAudioListener ReturnTransport WwiseChildModifiedInfo
AkEnvironment AkState CallbackFlags (AK.Wwise) ReturnWwiseObjects WwiseObjectInfo
AkEnvironment.AkEnvironment_CompareByPriority AkSurfaceReflector
e
ReturnWwiseObjects WwiseObjectInfoJsonObject
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm AkSwitch
s
WwiseObjectInfoParent
AkEnvironmentPortal AkTriggerBase Event (AK.Wwise) WwiseRenameInfo
AkEvent AkWaapiUtilities AkEnvironmentPortal.EnvListWrapper State (AK.Wwise)
AkEventCallbackMsg AkWwiseTreeWAAPIDataSource ErrorDetails Switch (AK.Wwise)
AkGameObj AkWwiseTrigger ErrorMessage AkSpatialAudioListener.SpatialAudioListenerList
AkInitializer Args Wamp.ErrorException AkWaapiUtilities.SubscriptionInfo
AkListenerDistanceProbe ArgsCommand
g
SelectedWwiseObjects
AkMemBankLoader ArgsDisplayName
t
AkSurfaceReflector.GeometryData


Wwise Unity Integration Documentation: 클래스 계통도

클래스 계통도
이 상속 목록은 완전하진 않지만 알파벳순으로 대략적으로 정렬되어있습니다.:
[상세 단계 123]
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
▼C AK.Wwise.BaseType | This type represents the base for all Wwise Types that require a GUID
C AK.Wwise.AcousticTexture | This type represents an Acoustic Texture
C AK.Wwise.AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C AK.Wwise.Bank | This type can be used to load/unload SoundBanks
▼C AK.Wwise.BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C AK.Wwise.State | This type can be used to set Wwise States
C AK.Wwise.Switch | This type can be used to set Switch values on gameobjects
C AK.Wwise.Event | This type can be used to post Events to the sound engine
C AK.Wwise.RTPC | This type can be used to set game parameter values to the sound engine
C AK.Wwise.Trigger | This type can be used to post triggers to the sound engine
C AK.Wwise.CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
▼C AkEnvironment.AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 인스펙터에서 AkEnvironment와 AkEnvironmentPortal 사용하기
C AkEnvironmentPortal.EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
▼C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkReverbZone | This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkSpatialAudioListener.SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C AkSurfaceReflector.GeometryData | The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwise 이벤트에 새로운 트리거 추가하기
C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C AkWaapiUtilities.SubscriptionInfo | Class used to store information about a specific subscription
C AkWaapiUtilities.WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
C AkWwiseTrigger | This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
▼C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
▼C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C WaqlArgs | WAAPI arguments containing a WAQL string
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
▼C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C Wamp.ErrorException | Exception thrown during WAMP operations
C Wamp.TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent


Wwise Unity Integration Documentation: 클래스 멤버

다음은 문서화된 모든 클래스 멤버들의 목록입니다. 각 멤버들은 해당 멤버에 대한 클래스의 문서화 페이지의 링크를 가지고 있습니다. :

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • Add() : AkSpatialAudioListener.SpatialAudioListenerList
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • ClosePortal() : AkRoomPortal
  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • Delete() : AkWaapiUtilities
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnected() : AkWaapiUtilities
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • EnteredRoom() : AkRoomAwareObject
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- f -

  • FolderDisplaynames : WaapiKeywords

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetGeometryDataFromMesh() : AkSurfaceReflector
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • IsConnected() : AkWaapiUtilities
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader
  • IsPlayable() : AkWaapiUtilities

- l -

  • loadAsynchronous : AkBank
  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities
  • outerRadius : AkRadialEmitter

- p -

  • ParentRoom : AkReverbZone
  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • priority : AkRoom
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities
  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • RemoveReverbZone() : AkReverbZone , AkRoom
  • Rename() : AkWaapiUtilities
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • ReverbZone : AkReverbZone
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • sender : AkEventCallbackMsg
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • SetReverbZone() : AkReverbZone , AkRoom
  • soundEmitterObject : AkEvent
  • SpatialAudioListeners : AkSpatialAudioListener
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TheSpatialAudioListener : AkSpatialAudioListener
  • TogglePlayEvent() : AkWaapiUtilities
  • transitionDuration : AkEvent
  • TransitionRegionWidth : AkReverbZone
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • Trigger() : AkTriggerBase
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • UnloadBank() : AkBank
  • unloadTriggerList : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: 클래스 멤버 - 함수

- a -

  • Add() : AkSpatialAudioListener.SpatialAudioListenerList

- c -

  • ClosePortal() : AkRoomPortal

- d -

  • Delete() : AkWaapiUtilities
  • Disconnected() : AkWaapiUtilities

- e -

  • EnteredRoom() : AkRoomAwareObject
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetGeometryDataFromMesh() : AkSurfaceReflector
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • IsConnected() : AkWaapiUtilities
  • IsPlayable() : AkWaapiUtilities

- l -

  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities

- p -

  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities

- r -

  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • RemoveReverbZone() : AkReverbZone , AkRoom
  • Rename() : AkWaapiUtilities

- s -

  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • SetReverbZone() : AkReverbZone , AkRoom
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TogglePlayEvent() : AkWaapiUtilities
  • Trigger() : AkTriggerBase

- u -

  • UnloadBank() : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector


Wwise Unity Integration Documentation: 클래스 멤버 - 변수

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal

- f -

  • FolderDisplaynames : WaapiKeywords

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader

- l -

  • loadAsynchronous : AkBank

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • outerRadius : AkRadialEmitter

- p -

  • ParentRoom : AkReverbZone
  • priority : AkRoom

- q -

  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • ReverbZone : AkReverbZone
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • sender : AkEventCallbackMsg
  • soundEmitterObject : AkEvent

- t -

  • transitionDuration : AkEvent
  • TransitionRegionWidth : AkReverbZone
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • unloadTriggerList : AkBank

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: 클래스 멤버 - 속성

  • SpatialAudioListeners : AkSpatialAudioListener
  • TheSpatialAudioListener : AkSpatialAudioListener


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • AcousticTexture
AK.Wwise.AcousticTexture 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.AcousticTexture (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • AuxBus
AK.Wwise.AuxBus 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.AuxBus (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • Bank
AK.Wwise.Bank 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.Bank (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • BaseGroupType
AK.Wwise.BaseGroupType 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.BaseGroupType (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • BaseType
AK.Wwise.BaseType 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.BaseType (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • CallbackFlags
AK.Wwise.CallbackFlags 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.CallbackFlags (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • Event
AK.Wwise.Event 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.Event (모든 상속된 멤버들도 포함합니다.)

ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(ulong gameObjectId) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count) | AK.Wwise.Event | inline
StopMIDI(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
StopMIDI() | AK.Wwise.Event | inline


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • RTPC
AK.Wwise.RTPC 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.RTPC (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • State
AK.Wwise.State 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.State (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • Switch
AK.Wwise.Switch 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.Switch (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AK
  • Wwise
  • Trigger
AK.Wwise.Trigger 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AK.Wwise.Trigger (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkAmbient 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkAmbient (모든 상속된 멤버들도 포함합니다.)

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: 멤버 목록

AkAmbientLargeModePositioner 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkAmbientLargeModePositioner (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkAudioListener 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkAudioListener (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkBank 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkBank (모든 상속된 멤버들도 포함합니다.)

decodeBank AkBank
HandleEvent(UnityEngine.GameObject in_gameObject) | AkBank | inline
loadAsynchronous AkBank
saveDecodedBank AkBank
UnloadBank(UnityEngine.GameObject in_gameObject) | AkBank | inline


Wwise Unity Integration Documentation: 멤버 목록

AkEarlyReflections 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEarlyReflections (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkEmitterObstructionOcclusion 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEmitterObstructionOcclusion (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkEnvironment 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEnvironment (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AkEnvironment
  • AkEnvironment_CompareByPriority
AkEnvironment.AkEnvironment_CompareByPriority 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEnvironment.AkEnvironment_CompareByPriority (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkEnvironmentPortal 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEnvironmentPortal (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AkEnvironmentPortal
  • EnvListWrapper
AkEnvironmentPortal.EnvListWrapper 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEnvironmentPortal.EnvListWrapper (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkEvent 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEvent (모든 상속된 멤버들도 포함합니다.)

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: 멤버 목록

AkEventCallbackMsg 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkEventCallbackMsg (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkGameObj 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkGameObj (모든 상속된 멤버들도 포함합니다.)

GetForward() | AkGameObj | inlinevirtual
GetPosition() | AkGameObj | inlinevirtual
GetUpward() | AkGameObj | inlinevirtual


Wwise Unity Integration Documentation: 멤버 목록

AkInitializer 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkInitializer (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkListenerDistanceProbe 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkListenerDistanceProbe (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkMemBankLoader 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkMemBankLoader (모든 상속된 멤버들도 포함합니다.)

bankName | AkMemBankLoader |
isLocalizedBank | AkMemBankLoader |
LoadLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline
LoadNonLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline


Wwise Unity Integration Documentation: AkObstructionOcclusion.LayerMask

  • AkRoomPortalObstruction

◆ LayerMask

UnityEngine.LayerMask AkObstructionOcclusion.LayerMask = -1
inherited

Indicates which layers act as obstructers/occluders.


Wwise Unity Integration Documentation: AkObstructionOcclusion.maxDistance

  • AkRoomPortalObstruction

◆ maxDistance

float AkObstructionOcclusion.maxDistance = -1.0f
inherited

The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance.


Wwise Unity Integration Documentation: AkObstructionOcclusion.refreshInterval

  • AkRoomPortalObstruction

◆ refreshInterval

float AkObstructionOcclusion.refreshInterval = 1
inherited

The number of seconds between obstruction/occlusion checks.


Wwise Unity Integration Documentation: AkObstructionOcclusion.fadeTime

  • AkRoomPortalObstruction

◆ fadeTime

float AkObstructionOcclusion.fadeTime = 0.5f
inherited

The number of seconds for fade ins and fade outs.


Wwise Unity Integration Documentation: 멤버 목록

AkRadialEmitter 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRadialEmitter (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkReverbZone 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkReverbZone (모든 상속된 멤버들도 포함합니다.)

ParentRoom AkReverbZone
RemoveReverbZone(AkRoom reverbZone) | AkReverbZone | inlinestatic
RemoveReverbZone() | AkReverbZone | inline
ReverbZone AkReverbZone
SetReverbZone(AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth) | AkReverbZone | inlinestatic
SetReverbZone() | AkReverbZone | inline


Wwise Unity Integration Documentation: 멤버 목록

AkRoom 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoom (모든 상속된 멤버들도 포함합니다.)

GetID() | AkRoom | inline
priority AkRoom
RemoveReverbZone() | AkRoom | inline
reverbAuxBus AkRoom
reverbLevel AkRoom
roomToneAuxSend AkRoom
roomToneEvent AkRoom
SetReverbZone(AkRoom parentRoom, float transitionRegionWidth) | AkRoom | inline


Wwise Unity Integration Documentation: 멤버 목록

AkRoomAwareManager 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoomAwareManager (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkRoomAwareObject 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoomAwareObject (모든 상속된 멤버들도 포함합니다.)

EnteredRoom(AkRoom room) | AkRoomAwareObject | inline
ExitedRoom(AkRoom room) | AkRoomAwareObject | inline


Wwise Unity Integration Documentation: 멤버 목록

AkRoomManager 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoomManager (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkRoomPortal 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoomPortal (모든 상속된 멤버들도 포함합니다.)

ClosePortal(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
GetID() | AkRoomPortal | inline
HandleEvent(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
MAX_ROOMS_PER_PORTAL | AkRoomPortal | static


Wwise Unity Integration Documentation: 멤버 목록

AkRoomPortalObstruction 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkRoomPortalObstruction (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkSpatialAudioDebugDraw 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSpatialAudioDebugDraw (모든 상속된 멤버들도 포함합니다.)

drawDiffractionPaths | AkSpatialAudioDebugDraw
drawFirstOrderReflections | AkSpatialAudioDebugDraw
drawHigherOrderReflections | AkSpatialAudioDebugDraw
drawSecondOrderReflections | AkSpatialAudioDebugDraw


Wwise Unity Integration Documentation: 멤버 목록

AkSpatialAudioEmitter 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSpatialAudioEmitter (모든 상속된 멤버들도 포함합니다.)

diffractionMaxEdges | AkSpatialAudioEmitter
diffractionMaxPathLength | AkSpatialAudioEmitter
diffractionMaxPaths | AkSpatialAudioEmitter
drawDiffractionPaths | AkSpatialAudioEmitter
drawFirstOrderReflections | AkSpatialAudioEmitter
drawHigherOrderReflections | AkSpatialAudioEmitter
drawSecondOrderReflections | AkSpatialAudioEmitter
reflectAuxBus | AkSpatialAudioEmitter
reflectionMaxPathLength | AkSpatialAudioEmitter
reflectionsAuxBusGain | AkSpatialAudioEmitter
reflectionsOrder | AkSpatialAudioEmitter
roomReverbAuxBusGain | AkSpatialAudioEmitter


Wwise Unity Integration Documentation: 멤버 목록

AkSpatialAudioListener 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSpatialAudioListener (모든 상속된 멤버들도 포함합니다.)

SpatialAudioListeners | AkSpatialAudioListener | static
TheSpatialAudioListener | AkSpatialAudioListener | static


Wwise Unity Integration Documentation: 멤버 목록

  • AkSpatialAudioListener
  • SpatialAudioListenerList
AkSpatialAudioListener.SpatialAudioListenerList 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSpatialAudioListener.SpatialAudioListenerList (모든 상속된 멤버들도 포함합니다.)

Add(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline
Remove(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline


Wwise Unity Integration Documentation: 멤버 목록

AkState 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkState (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkSurfaceReflector 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSurfaceReflector (모든 상속된 멤버들도 포함합니다.)

AcousticTextures | AkSurfaceReflector |
AssociatedRoom | AkSurfaceReflector |
EnableDiffraction | AkSurfaceReflector |
EnableDiffractionOnBoundaryEdges | AkSurfaceReflector |
GetGeometryDataFromMesh(UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="") | AkSurfaceReflector | inlinestatic
Mesh | AkSurfaceReflector |
RemoveGeometry() | AkSurfaceReflector | inline
RemoveGeometryInstance() | AkSurfaceReflector | inline
SetGeometry() | AkSurfaceReflector | inline
SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="") | AkSurfaceReflector | inlinestatic
SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction) | AkSurfaceReflector | inlinestatic
SetGeometryInstance() | AkSurfaceReflector | inline
TransmissionLossValues | AkSurfaceReflector |
UpdateGeometry() | AkSurfaceReflector | inline


Wwise Unity Integration Documentation: 멤버 목록

AkSwitch 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSwitch (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkTriggerBase 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkTriggerBase (모든 상속된 멤버들도 포함합니다.)

Trigger(UnityEngine.GameObject in_gameObject) AkTriggerBase


Wwise Unity Integration Documentation: AkTriggerHandler.useOtherObject

  • AkWwiseTrigger

◆ useOtherObject

bool AkTriggerHandler.useOtherObject = false
inherited

This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object.


Wwise Unity Integration Documentation: AkTriggerHandler.triggerTypes

  • AkWwiseTrigger

◆ triggerTypes

System.Collections.Generic.Dictionary<uint, string> AkTriggerHandler.triggerTypes = AkTriggerBase.GetAllDerivedTypes()
staticinherited

Will contain the types of all the triggers derived from AkTriggerBase at runtime


Wwise Unity Integration Documentation: AkTriggerHandler.MAX_NB_TRIGGERS

  • AkWwiseTrigger

◆ MAX_NB_TRIGGERS

const int AkTriggerHandler.MAX_NB_TRIGGERS = 32
staticinherited

Since our mask is a 32 bits integer, we can't have more than 32 triggers


Wwise Unity Integration Documentation: AkTriggerHandler.triggerList

  • AkWwiseTrigger

◆ triggerList

System.Collections.Generic.List<int> AkTriggerHandler.triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
inherited

List containing the enabled triggers.


Wwise Unity Integration Documentation: 멤버 목록

AkWaapiUtilities 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkWaapiUtilities (모든 상속된 멤버들도 포함합니다.)

Connected | AkWaapiUtilities | static
Delete(System.Guid guid) | AkWaapiUtilities | inlinestatic
Disconnected() | AkWaapiUtilities | inlinestatic
Disconnecting | AkWaapiUtilities | static
GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options) | AkWaapiUtilities | inlinestatic
GetResultDelegate< T >(T result) | AkWaapiUtilities |
GetResultListDelegate< T >(List< T > result) | AkWaapiUtilities |
GetStatusString() | AkWaapiUtilities | inlinestatic
GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
IsConnected() | AkWaapiUtilities | inlinestatic
IsPlayable(WwiseObjectType type) | AkWaapiUtilities | inlinestatic
OpenSoundBankInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
OpenWorkUnitInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
ParseChildAddedOrRemoved(string json) | AkWaapiUtilities | inlinestatic
ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects) | AkWaapiUtilities | inlinestatic
ParseRenameObject(string json) | AkWaapiUtilities | inlinestatic
ParseSelectedObjects(string json) | AkWaapiUtilities | inlinestatic
QueueCommand(string uri, string args, string options) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
QueueConsumed | AkWaapiUtilities | static
Rename(System.Guid guid, string newName) | AkWaapiUtilities | inlinestatic
Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
SelectObjectInAuthoring(System.Guid guid) | AkWaapiUtilities | inlinestatic
StopAllTransports() | AkWaapiUtilities | inlinestatic
Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback) | AkWaapiUtilities | inlinestatic
TogglePlayEvent(WwiseObjectType objectType, System.Guid guid) | AkWaapiUtilities | inlinestatic
Unsubscribe(uint id) | AkWaapiUtilities | inlinestatic


Wwise Unity Integration Documentation: 멤버 목록

  • AkWaapiUtilities
  • SubscriptionInfo
AkWaapiUtilities.SubscriptionInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkWaapiUtilities.SubscriptionInfo (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

AkWwiseTreeWAAPIDataSource 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkWwiseTreeWAAPIDataSource (모든 상속된 멤버들도 포함합니다.)

SubscribeTopics() AkWwiseTreeWAAPIDataSource inline


Wwise Unity Integration Documentation: 멤버 목록

AkWwiseTrigger 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkWwiseTrigger (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

Args 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : Args (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsCommand 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsCommand (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsDisplayName 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsDisplayName (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsObject 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsObject (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsPlay 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsPlay (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsRename 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsRename (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ArgsTransport 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ArgsTransport (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ErrorDetails 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ErrorDetails (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ErrorMessage 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ErrorMessage (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

JsonSerializable 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : JsonSerializable (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

Options 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : Options (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ReturnOptions 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ReturnOptions (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ReturnTransport 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ReturnTransport (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

ReturnWwiseObjects< T > 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : ReturnWwiseObjects< T > (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

SelectedWwiseObjects 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : SelectedWwiseObjects (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

TransportOptions 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : TransportOptions (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

TransportState 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : TransportState (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WaapiHelper 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WaapiHelper (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WaapiKeywords 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WaapiKeywords (모든 상속된 멤버들도 포함합니다.)

FolderDisplaynames | WaapiKeywords | static
typeStringDict | WaapiKeywords | static
WwiseObjectTypeStrings | WaapiKeywords | static


Wwise Unity Integration Documentation: 멤버 목록

Wamp 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : Wamp (모든 상속된 멤버들도 포함합니다.)

PublishHandler(string json) Wamp


Wwise Unity Integration Documentation: 멤버 목록

  • Wamp
  • ErrorException
Wamp.ErrorException 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : Wamp.ErrorException (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • Wamp
  • TimeoutException
Wamp.TimeoutException 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : Wamp.TimeoutException (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WaqlArgs 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WaqlArgs (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WwiseChildModifiedInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WwiseChildModifiedInfo (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WwiseObjectInfoJsonObject 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WwiseObjectInfoJsonObject (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WwiseObjectInfoParent 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WwiseObjectInfoParent (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WwiseRenameInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WwiseRenameInfo (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ko/Android/ReleaseNotes 디렉토리 참조

  • Documentation
  • private
  • Doxygen_ko
  • Android
  • ReleaseNotes
ReleaseNotes 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten/WAAPI 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
  • WAAPI
WAAPI 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
Runtime 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise 디렉토리 참조

  • Integration
  • Assets
  • Wwise
Wwise 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor/WwiseWindows 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
  • WwiseWindows
WwiseWindows 디렉토리 참조


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ko/Android 디렉토리 참조

  • Documentation
  • private
  • Doxygen_ko
  • Android
Android 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
Editor 디렉토리 참조

디렉토리들


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
WwiseTypes 디렉토리 참조

디렉토리들


Wwise Unity Integration Documentation: Documentation/private 디렉토리 참조

  • Documentation
  • private
private 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour/Runtime 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
  • Runtime
Runtime 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes/WwiseTypes 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
  • WwiseTypes
WwiseTypes 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
API 디렉토리 참조


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ko/Common 디렉토리 참조

  • Documentation
  • private
  • Doxygen_ko
  • Common
Common 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
MonoBehaviour 디렉토리 참조

디렉토리들


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ko/Common/ReleaseNotes 디렉토리 참조

  • Documentation
  • private
  • Doxygen_ko
  • Common
  • ReleaseNotes
ReleaseNotes 디렉토리 참조


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ko 디렉토리 참조

  • Documentation
  • private
  • Doxygen_ko
Doxygen_ko 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten 디렉토리 참조

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
Handwritten 디렉토리 참조

디렉토리들


Wwise Unity Integration Documentation: Integration 디렉토리 참조

  • Integration
Integration 디렉토리 참조


Wwise Unity Integration Documentation: Documentation 디렉토리 참조

  • Documentation
Documentation 디렉토리 참조


Wwise Unity Integration Documentation: Integration/Assets 디렉토리 참조

  • Integration
  • Assets
Assets 디렉토리 참조


Wwise Unity Integration Documentation: 관련된 페이지

관련된 페이지
다음은 관련된 모든 문서화 페이지들의 목록입니다.:
WAAPI 유틸리티


Wwise Unity Integration Documentation: 멤버 목록

  • AkSurfaceReflector
  • GeometryData
AkSurfaceReflector.GeometryData 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkSurfaceReflector.GeometryData (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

  • AkWaapiUtilities
  • WaapiCommand
AkWaapiUtilities.WaapiCommand 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : AkWaapiUtilities.WaapiCommand (모든 상속된 멤버들도 포함합니다.)


Wwise Unity Integration Documentation: 멤버 목록

WwiseObjectInfo 멤버 목록

다음에 대한 모든 멤버의 목록입니다 : WwiseObjectInfo (모든 상속된 멤버들도 포함합니다.)