Wwise Unity Integration Documentation: Wwise Unityインテグレーション

Wwise Unity Integration Documentation
Wwise Unityインテグレーション

Wwise Unityインテグレーションは、UnityのゲームでWwise Sound Engineを使えるようにするリソースを取りまとめたものです。以下「インテグレーション」とします。インテグレーションには、Unityプラグインライブラリ、C::のWwise SDK APIバインディング、多数の便利なmultiple helpful コンポーネント、そしてEditorウィンドウが含まれます。Wwise SDKの全般的な機能については、オンラインまたはWwiseインストールに含まれるCHMとして提供されるSDKドキュメンテーションを参照してください。

本インテグレーションドキュメントは、Unity-WiseインテグレーションやWwise APIに関する情報を提供するものです。Wwiseオーサリングアプリケーションに関する情報（サウンドエンジニア向け）を知るには、オンラインまたはローカルインストール内（一般的な場所は、C:\Program Files(x86)\Audiokinetic\Wwise [version] \Authoring\Help）にあるヘルプファイルを参照してください。

  • リリースノート - Wwise Unityインテグレーション2023.1.1.8417.3007
  • 以前のリリースノート
  • Unityプロジェクトのインテグレーションの、インストールとアップグレード
  • Wwise Integration Packageをアンインストールする
  • Unity Editor Settingsを調整する
  • Wwise Initialization Settingsを調整する
  • サウンドバンクを管理する
  • Wwise Unityインテグレーションの使用
  • Wwise Picker
    • WAAPIユーティリティ
  • 特定プラットフォーム向けにUnityゲームをビルドする
  • WwiseとUnityでDLCをつくる
  • インテグレーションコードをビルドする
  • Enter Play Modeの動作
  • APIの変更と制約
  • 各プラットフォーム固有の情報
  • デモゲーム
  • Unityで、Spatial Audio
  • UnityのためのWwise Addressablesパッケージ
  • Wwise Unity Addressablesパッケージをインストールする
  • DLCをパッケージングするための基本チュートリアル
  • Wwise Addressablesサンプル
  • トラブルシューティング

お問い合わせ

本インテグレーションに関する質問は、弊社のQ&A community forumに出してください。サポートパッケージを購入されている場合はカスタマーサポートにお問い合わせください。

参照
  • Audiokinetic Launcher: Integrating Wwise into a Unity Project
  • Wwise-301: Wwise Unityインテグレーション


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション2023.1.1.8417.3007

リリースノート - Wwise Unityインテグレーション2023.1.1.8417.3007

このリリースはWwise 2023.1.1 向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2023.1.1
  • Unity: このインテグレーションはUnity 2023.2.3f1でテストされました。サポートされる最低バージョンは2020.3、最高バージョンは2023.2です。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、tvOS、およびvisionOS 2023.1.1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • パフォーマンスの変更
  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

パフォーマンスの変更

  • WG-69395 WG-68992で導入されたMemory Span Count設定のサポートが、Advanced Settingsに追加されました。これにより、コストを抑えながらCPUの総合的な性能を引き出し、Wwiseによって確保されるメモリ量を大幅に削減できます。

その他の変更

  • WG-68202 Reverb ZoneのTransition Regionのデフォルト値をゼロ以外の値に変更しました。

バグ修正

  • WG-68461 修正済み（Spatial Audio）Transition Regionを有効にするには、Reverb ZoneにAKSurfaceReflectorコンポーネントが必要です。
  • WG-68629 修正済み：サウンドエンジンエラーがUnityに出力される時にクラッシュします。
  • WG-68716 修正済み：（Spatial Audio）兄弟のReverb Zonesを接続するポータルが無効であるにもかかわらず赤色で表示されません。
  • WG-68980 修正済み：（Spatial Audio）同じフロントルームやバックルームを維持したままポータルを移動すると、ポータルは更新されません。

コミュニティで報告されたバグの修正

  • WG-69036 Fixed: InvalidOperationException in Unity when the debugger is attached.
  • WG-69340 修正済み：エディタの起動時にProjectDataの作成に失敗することがあります。
  • WG-69422 修正済み：（Spatial Audio）Unity Portalを初期ステートで閉じると、 開かなくなります。


Wwise Unity Integration Documentation: 以前のリリースノート

以前のリリースノート

以下のページに、以前のリリースで行われたインテグレーションへの変更点が記載されています。

  • リリースノート - Wwise Unityインテグレーション 2023.1.0.8367.2953
  • リリースノート - Wwise Unityインテグレーション 2022.1.9.8365.2941
  • リリースノート - Wwise Unityインテグレーション 2022.1.8.8316.2888
  • リリースノート - Wwise Unityインテグレーション 2022.1.7.8290.2858
  • リリースノート - Wwise Unityインテグレーション 2022.1.6.8263.2826
  • リリースノート - Wwise Unityインテグレーション 2022.1.5.8242.2798
  • リリースノート - Wwise Unityインテグレーション 2022.1.4.8200.2750
  • リリースノート - Wwise Unityインテグレーション 2022.1.3.8179.2728
  • リリースノート - Wwise Unityインテグレーション2022.1.2.8150.2694
  • リリースノート - Wwise Unityインテグレーション 2022.1.1.8100.2644
  • リリースノート - Wwise Unityインテグレーション 2022.1.0.8070.2611
  • リリースノート - Wwise Unityインテグレーション 2021.1.14.8108.2676
  • リリースノート - Wwise Unityインテグレーション 2021.1.13.8036.2602
  • リリースノート - Wwise Unityインテグレーション 2021.1.12.7973.2529
  • リリースノート - Wwise Unityインテグレーション 2021.1.11.7933.2488
  • リリースノート - Wwise Unity Integration 2021.1.10.7883.2429
  • リリースノート - Wwise Unityインテグレーション 2021.1.9.7847.2389
  • リリースノート - Wwise Unityインテグレーション 2021.1.8.7831.2373
  • リリースノート - Wwise Unityインテグレーション 2021.1.7.7796.2335
  • リリースノート - Wwise Unityインテグレーション 2021.1.6.7774.2308
  • リリースノート - Wwise Unityインテグレーション 2021.1.5.7749.2277
  • リリースノート - Wwise Unityインテグレーション 2021.1.4.7707.2232
  • リリースノート - Wwise Unityインテグレーション 2021.1.3.7665.2179
  • リリースノート - Wwise Unityインテグレーション 2021.1.2.7629.2141
  • リリースノート - Wwise Unityインテグレーション 2021.1.1.7601.2102
  • リリースノート - Wwise Unityインテグレーション 2021.1.0.7575.2069
  • リリースノート - Wwise Unityインテグレーション 2019.2.15.7667.2215
  • リリースノート - Wwise Unityインテグレーション 2019.2.14.7616.2152
  • リリースノート - Wwise Unityインテグレーション 2019.2.13.7577.2104
  • リリースノート - Wwise Unityインテグレーション 2019.2.12.7544.2058
  • リリースノート - Wwise Unityインテグレーション 2019.2.11.7512.2017
  • リリースノート - Wwise Unityインテグレーション 2019.2.10.7490.1989
  • リリースノート - Wwise Unityインテグレーション 2019.2.9.7459.1949
  • リリースノート - Wwise Unityインテグレーション 2019.2.8.7432.1919
  • リリースノート - Wwise Unityインテグレーション 2019.2.7.7402.1888
  • リリースノート - Wwise Unityインテグレーション 2019.2.6.7381.1867
  • リリースノート - Wwise Unityインテグレーション 2019.2.5.7349.1831
  • リリースノート - Wwise Unityインテグレーション 2019.2.4.7329.1806
  • リリースノート - Wwise Unityインテグレーション 2019.2.3.7304.1778
  • リリースノート - Wwise Unityインテグレーション 2019.2.2.7275.1749
  • リリースノート - Wwise Unityインテグレーション 2019.2.1.7250.1718
  • リリースノート - Wwise Unityインテグレーション 2019.2.0.7216.1681
  • リリースノート - Wwise Unityインテグレーション 2019.1.11.7296.1786
  • リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480
  • リリースノート - Wwise Unityインテグレーション 2019.1.9.7221.1704
  • リリースノート - Wwise Unityインテグレーション 2019.1.8.7173.1654
  • リリースノート - Wwise Unityインテグレーション 2019.1.7.7135.1611
  • リリースノート - Wwise Unityインテグレーション 2019.1.6.7110.1585
  • リリースノート - Wwise Unityインテグレーション 2019.1.5.7093.1568
  • リリースノート - Wwise Unityインテグレーション 2019.1.4.7065.1538
  • リリースノート - Wwise Unityインテグレーション 2019.1.3.7048.1516
  • リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1481
  • リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480
  • リリースノート - Wwise Unityインテグレーション 2019.1.1.6977.1430
  • リリースノート - Wwise Unityインテグレーション 2019.1.2.6947.1394
  • リリースノート - Wwise Unityインテグレーション 2018.1.6.6858.1313
  • リリースノート - Wwise Unityインテグレーション 2018.1.5.6835.1288
  • リリースノート - Wwise Unityインテグレーション 2018.1.4.6807.1258
  • リリースノート - Wwise Unityインテグレーション 2018.1.3.6784.1233
  • リリースノート - Wwise Unityインテグレーション 2018.1.2.6762.1211
  • リリースノート - Wwise Unityインテグレーション 2018.1.1.6727.1172
  • リリースノート - Wwise Unityインテグレーション 2018.1.0.6714.1154
    • 新機能2018.1
  • リリースノート - Wwise Unityインテグレーション 2017.2.9.6726.1210
  • リリースノート - Wwise Unityインテグレーション 2017.2.8.6698.1171
  • リリースノート - Wwise Unityインテグレーション 2017.2.7.6661.1133
  • リリースノート - Wwise Unityインテグレーション 2017.2.6.6636.1107
  • リリースノート - Wwise Unityインテグレーション 2017.2.5.6619.1090
  • リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1064
  • リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1054
  • リリースノート - Wwise Unityインテグレーション 2017.2.3.6575.1037
  • リリースノート - Wwise Unityインテグレーション 2017.2.2.6553.1015
  • リリースノート - Wwise Unityインテグレーション 2017.2.1.6524.980
  • リリースノート - Wwise Unityインテグレーション 2017.2.0.6500.947
    • 新機能2017.2
    • 重要な移行の注意 2017.2
  • リリースノート - Wwise Unityインテグレーション 2017.1.9.6501.947
  • リリースノート - Wwise Unityインテグレーション 2017.1.8.6488.933
  • リリースノート - Wwise Unityインテグレーション 2017.1.7.6467.910
  • リリースノート - Wwise Unityインテグレーション 2017.1.6.6446.890
  • リリースノート - Wwise Unityインテグレーション 2017.1.5.6429.870
  • リリースノート - Wwise Unityインテグレーション 2017.1.4.6407.845
  • リリースノート - Wwise Unityインテグレーション 2017.1.3.6377.812
  • リリースノート - Wwise Unityインテグレーション 2017.1.2.6361.791
  • リリースノート - Wwise Unityインテグレーション 2017.1.1.6340.770
  • リリースノート - Wwise Unityインテグレーション 2017.1.0.6302.726
    • 新機能2017.1
    • 重要な移行の注意 2017.1
  • リリースノート - Wwise Unityインテグレーション 2016.2.6.6153.595
  • リリースノート - Wwise Unityインテグレーション 2016.2.5.6121.560
  • リリースノート - Wwise Unityインテグレーション 2016.2.4.6098.531
  • リリースノート - Wwise Unityインテグレーション 2016.2.3.6077.504
  • リリースノート - Wwise Unityインテグレーション 2016.2.2.6022.430
  • リリースノート - Wwise Unityインテグレーション 2016.2.1.5995.409
  • リリースノート - Wwise Unityインテグレーション 2016.2.1
  • リリースノート - Wwise Unityインテグレーション 2016.2.0
  • リリースノート - Wwise Unityインテグレーション 2016.1.6
  • リリースノート - Wwise Unityインテグレーション 2016.1.5
  • リリースノート - Wwise Unityインテグレーション 2016.1.4
  • リリースノート - Wwise Unityインテグレーション 2016.1.3
  • リリースノート - Wwise Unityインテグレーション 2016.1.2
  • リリースノート - Wwise Unityインテグレーション 2016.1.1
  • リリースノート - Wwise Unityインテグレーション 2016.1
  • リリースノート - Wwise Unityインテグレーション 2015.1.9
  • リリースノート - Wwise Unityインテグレーション 2015.1.8
  • リリースノート - Wwise Unityインテグレーション 2015.1.7
  • リリースノート - Wwise Unityインテグレーション 2015.1.6
  • リリースノート - Wwise Unityインテグレーション 2015.1.5
  • リリースノート - Wwise Unityインテグレーション 2015.1.4
  • リリースノート - Wwise Unityインテグレーション 2015.1.3
  • リリースノート - Wwise Unityインテグレーション 2015.1.2
  • リリースノート - Wwise Unityインテグレーション 2015.1.1
  • リリースノート - Wwise Unityインテグレーション 2015.1
  • リリースノート - Wwise Unityインテグレーション 2014.1.6
  • リリースノート - Wwise Unityインテグレーション 2014.1.5
  • リリースノート - Wwise Unityインテグレーション 2014.1.4
  • リリースノート - Wwise Unityインテグレーション 2014.1.3
  • リリースノート - Wwise Unityインテグレーション 2014.1.2
  • リリースノート - Wwise Unityインテグレーション 2014.1.1
  • リリースノート - Wwise Unityインテグレーション 2014.1
  • リリースノート - Wwise Unityインテグレーション 2013.2.10
  • リリースノート - Wwise Unityインテグレーション 2013.2.9
  • リリースノート - Wwise Unityインテグレーション 2013.2.8
  • リリースノート - Wwise Unityインテグレーション 2013.2.5
  • リリースノート - Wwise Unityインテグレーション 2013.2.4
  • リリースノート - Wwise Unityインテグレーション 2013.2.1
  • リリースノート - Wwise Unityインテグレーション 2013.1.1
  • リリースノート - Wwise Unityインテグレーション 2013.1


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2023.1.0.8367.2953

リリースノート - Wwise Unityインテグレーション 2023.1.0.8367.2953

このリリースはWwise 2023.1向けWwise SDKアップデートを提供します。

  • 重要な移行の注意 2023.1

互換性：

  • Wwise SDK: 2023.1.0
  • Unity: このインテグレーションはUnity 2022.3.2f1でテストされました。サポートされる最低バージョンは2020.3、最高バージョンは2023.2です。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • APIの変更
  • 動作の変更
  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

新機能

  • WG-51085 Enter Play Modeのサポートを追加しました。
  • WG-53593 ゲームがフォーカスを失っている時にオーディオを一時停止するオプションを追加しました。
  • WG-65226 3Dビューアにトランジションゾーンを表示するオプションを追加しました。

APIの変更

  • WG-64048（Spatial Audio）1つのエミッターから発することができるゲーム定義AUXセンドの上限を設定できるように、AkSpatialAudioInitSettings::uMaxEmitterRoomAuxSendsを追加しました。
  • WG-65130（Spatial Audio）AkGeometryParams::EnableTrianglesを削除し、AkGeometryInstanceParams::UseForReflectionAndDiffractionに置き換えました。
  • WG-66244（Spatial Audio） AkGeometryInstanceParams::RoomIDの使用が非推奨になったため、今後のバージョンではこのパラメータが削除されます。RoomIDを使用せず、デフォルト値（-1）のままにすることを推奨します。

動作の変更

  • WG-65242 Wwise Initialization Settingsのユーザエクスペリエンスを改善しました。

その他の変更

  • WG-66693 Wwise UnityインテグレーションにはAudiokinetic Launcher 2023.1.1以降が必要です。

バグ修正

  • WG-66259 修正済み：「Edit ModeのLoad Sound Engine」を無効にしてPlay Sessionを停止すると、「Failed load Init.bnk with result: AK_Fail」エラーが表示されます。
  • WG-68085 修正済み：Playモードに入った後はWwise Pickerが空です。

コミュニティで報告されたバグの修正

  • WG-56018 修正済み：AkRoomが不必要な物理的インタラクションを引き起こします。
  • WG-61124 修正済み：サウンドでストリーミングが無効になっている場合、Addressables Groupが正しく更新されません。


Wwise Unity Integration Documentation: 重要な移行の注意 2023.1

重要な移行の注意 2023.1

Spatial Audio

継続的レイキャスティング

Spatial Audioは、レイトレーシングエンジンを使って効率的にリフレクションとディフラクションのパスを評価します。Wwiseの以前のバージョンでは、エミッターやリスナーの動作が事前に定義された閾値（Spatial Audio SettingのMovement Thresholdを参照）を超えると、多数のレイがキャストされて、リフレクションとディフラクションのパスが再計算されました。レイキャストと再計算が組み合わさることでフレームの負荷が増加し、CPU使用率がピークに達することがありました。Wwise 2023.1では、再計算がトリガーされるまで、フレームごとにレイキャスティングが継続的に実行されます。これにより、レイキャスティングの負荷が複数のフレーム間で分散されるため、CPU使用率がピークに達するのを回避できます。

このような理由から、Spatial Audio SettingのNumber Of Primary Raysのデフォルト値が100から35に下げられました。移行後にプロジェクトに応じてプライマリレイ数を好みの値に変更してください。

隙間のないGeometry

Wwise 23.1に導入したSpatial Audioの新機能では、コンテインメントやトランジションリージョンまでの距離を計算するために、RoomのGeometryを隙間のない状態にする必要があります。これは、Geometryにホールが全くなく、すべてのエッジが正確に2つの三角形に接することを意味します。RoomがSpatial Audioに送信されると、RoomのGeometryで境界エッジが探索されます。境界エッジが検出されない場合、Geometryに隙間があるためエラーメッセージが表示されます。

RoomがReverb Zoneの場合、Geometryは隙間のない状態にする必要があります。エラーメッセージが表示された場合は、ホールや境界エッジを探してGeometryを修正してください。どのホールもサーフェスでカバーしてTransmission Lossの値を0にできます。ホールが見つからない場合は、エッジやサーフェスが重なっている境界エッジを探します。

Spatial Audioを使用してルームコンテインメントを実行する場合にも、Geometryを隙間のない状態にする必要があります。ただし、Unityインテグレーションはデフォルトでこの機能を使用していません。ほかのシナリオについては、このエラーメッセージは無視しても構いません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.9.8365.2941

リリースノート - Wwise Unityインテグレーション 2022.1.9.8365.2941

このリリースはWwise 2022.1.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.9
  • Unity: このインテグレーションはUnity 2022.2.2f1および2022.3.2f1でテストされました。サポートされる最低バージョンは2020.3、最高バージョンは2023.2です。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • バグ修正

新機能

  • WG-53593 ゲームがフォーカスを失っている時にオーディオを一時停止するオプションを追加しました。

バグ修正

  • WG-68085 修正済み：Playモードに入った後はWwise Pickerが空です。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.8.8316.2888

リリースノート - Wwise Unityインテグレーション 2022.1.8.8316.2888

このリリースはWwise 2022.1.8向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.8
  • Unity: このインテグレーションはUnity 2022.2.2f1および2022.3.2f1でテストされました。サポートされる最低バージョンは2020.3、最高バージョンは2023.2です。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-67267 修正済み：XMLErrorTranslatorのs_readerが初期化されないことがあります。

コミュニティで報告されたバグの修正

  • WG-64307 修正済み：式またはファイル名が一定の文字数を超えると AkUnityAssertHook() が原因でアサートが発生しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.7.8290.2858

リリースノート - Wwise Unityインテグレーション 2022.1.7.8290.2858

このリリースはWwise 2022.1.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.7
  • Unity: このインテグレーションはUnity 2022.2.2f1および2022.3.2f1でテストされました。サポートされる最低バージョンは2020.3、最高バージョンは2023.2です。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • コミュニティで報告されたバグの修正
  • ドキュメントの改善点

コミュニティで報告されたバグの修正

  • WG-62495 修正済み：Wwise Unity Addressablesバンクマネージャは、AK_BankAlreadyLoadedの結果を適切に処理しません。
  • WG-63623 修正済み：AVAudioSession.Playbackはサポートされていません。
  • WG-66686 修正済み：Wwiseプロジェクトが見つからない場合、アセットのインポートに失敗します。

ドキュメントの改善点

  • WG-66192 DLCをパッケージングするための基本チュートリアル がアップデートされ、Addressablesパッケージの新しいユーザインターフェースと一致するようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.6.8263.2826

リリースノート - Wwise Unityインテグレーション 2022.1.6.8263.2826

このリリースはWwise 2012.1.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.6
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-66643 Unity WwiseインテグレーションにはAudiokinetic Launcher 2023.1.1以降が必要です。

バグ修正

  • WG-66276 修正済み：Waapi Pickerコンテキストメニューではステートおよびスイッチグループが開きません。

コミュニティで報告されたバグの修正

  • WG-56968 修正済み：ゲームシンクをトリガーしてもUnity Wwise Pickerに公開されません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.5.8242.2798

リリースノート - Wwise Unityインテグレーション 2022.1.5.8242.2798

このリリースはWwise 2022.1.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.5
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2022.1.5

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-63104 修正済み：CubeがAkRoomコンポーネントとのやり取り中に、予想外にスポーンしました。
  • WG-63120 修正済み：Unity EditorでSpatial Audioをトグルした後に、Geometry Set削除エラー。
  • WG-63187 修正済み： (Spatial Audio) ジオメトリが予想される時に更新されません。
  • WG-65420 修正済み：無効なポータル配置のメッセージが、警告ではなくエラーです。

コミュニティで報告されたバグの修正

  • WG-63156 修正済み：SoundbanksInfo.xmlはパースされることも、Unityキャッシュに入ることもありません。
  • WG-64381 修正済み：アクティブなステート遷移のあるスイッチコンテナを含むサウンドバンクをアンロードする時に、デバッグ構成で誤ったアサート。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.4.8200.2750

リリースノート - Wwise Unityインテグレーション 2022.1.4.8200.2750

このリリースはWwise 2022.1.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.4
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-64673 修正済み: デバグビルドにすべてのサウンドエンジンのデバグ記号が含まれていません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.3.8179.2728

リリースノート - Wwise Unityインテグレーション 2022.1.3.8179.2728

このリリースはWwise 2022.1.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.3
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-63931 欠落していたAudiokinetic著作権をインテグレーションのC::コードファイルに追加しました。

バグ修正

  • WG-63983 修正済み: RoomAwareObjectを有効にした後に、RoomAwareManagerでNullReferenceException。

コミュニティで報告されたバグの修正

  • WG-54630 修正済み: Wwise Unity Addressablesを使用するiOSプラットフォームにおいて SetBasePath を不要に呼び出した時に、エラーメッセージがログに記録されます。
  • WG-63727 修正済み: UnityのAkEmitterObstructionOcclusionコンポーネントが音をすぐにブロックしません。
  • WG-64433 修正済み: FileSystemWatcherが引き起こす過剰なIOコール。
  • WG-64493 修正済み: Wwise Component Pickerが誤ったスクリーン上の位置に描写されます。
  • WG-64498 修正済み: ドメインのリロード時に"Unable to load Wwise Data: UnityEngine.UnityException: LoadAssetAtPath can only be called from the main thread."のエラー。
  • WG-64499 修正済み: Asset Import処理におけるパフォーマンス問題。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション2022.1.2.8150.2694

リリースノート - Wwise Unityインテグレーション2022.1.2.8150.2694

このリリースはWwise 2022.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.2
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-63482 修正済み: InspectorでEventを再生した後に、サウンドが再生されるのはほかのシーンを開いた後です。

コミュニティで報告されたバグの修正

  • WG-63469 修正済み: prefabの Environment Aware プロパティへの AkGameObj コンポーネントの変更が保存されません。
  • WG-64036 Wwise 2019.1以降を使用するプロジェクトの移行時間を改善しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.1.8100.2644

リリースノート - Wwise Unityインテグレーション 2022.1.1.8100.2644

このリリースはWwise 2022.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.1
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1です。2021.3.16f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-62355 ベストプラクティスに従い、Unity Spatial Audioコードを改善しました。

バグ修正

  • WG-62061 修正済み: (Spatial Audio) 再生中にルームを移動した時に、Game Object 3D Viewerでルームの可視化が重複します。
  • WG-62388 修正済み: (Spatial Audio) 以前AkGeometryに関連していたルームが、正しく更新されません。
  • WG-62411 修正済み: (Spatial Audio) AkRoomは、親GameObjectを変換した後に正しく拡大縮小されません。
  • WG-62690 修正済み: 移行後に以下のエラーがUnityコンソールに表示されます:
    • WwiseUnity: The platform SoundBank subfolder within the Wwise project could not be found.
    • WwiseUnity: Could not find source folder for <Assets> platform. Did you remember to generate your banks?
    • NullReferenceException: Object reference not set to an instance of an object
    • Asset import failed, "Assets/WwiseData/Banks/iOS/Subtitles.bnk" > NullReferenceException: Object reference not set to an instance of an object
  • WG-63116 修正済み: (Spatial Audio) ポータルと重なるジオメトリセットを更新する際に発生するデッドロック。
  • WG-63119 修正済み: AkAmbientを停止した時にエラーが発生します。

コミュニティで報告されたバグの修正

  • WG-62051 修正済み: AkGameObjポジションのオフセットの変更が、prefabに適切に保存されません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2022.1.0.8070.2611

リリースノート - Wwise Unityインテグレーション 2022.1.0.8070.2611

このリリースはWwise 2022.1.0向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2022.1.0
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1です。2021.3.0f1および2022.1.8f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2022.1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • APIの変更
  • 動作の変更
  • その他の変更
  • コミュニティで報告されたバグの修正

新機能

  • WG-54310 自動定義サウンドバンクのオプションを追加しました。これを有効にすることで各イベントやAUXバス（補助バス）のサウンドバンクを可能な限りWwiseが自動的に定義します。詳細は Automatically Defining SoundBanks を参照してください。

Auto-defined SoundBanks（自動定義サウンドバンク）は SoundBank Settingsで有効にします。詳細は SoundBank Settings を参照してください。

  • WG-54685 サウンドエンジン処理タスクの同時実行をより柔軟に行うために、Task Scheduler APIを新しいJob Managerに置き換えました。
  • WG-59193 新しいエラーメッセージトランスレータに関連し、XMLとWAAPIのタイムアウト値を調整するためのWwise Editor Project Settingsを新たに2つ追加しました。これらはWwise Error Message Translatorという新しいセクションの下にあります。

APIの変更

  • WG-55811 Wwise Demo Gameで使用する、WwiseSimpleExternalSourceManagerという名前のWwiseExternalSourceManagerの最低限の実装を追加しました。
  • WG-56860 SetPositionとSetMultiplePositionsに新しいin_eFlagsパラメータを導入し、1つのゲームオブジェクトでエミッタとリスナーのポジションを別々に設定できるようにしました。

動作の変更

  • WG-60908 すべてのプラットフォームにおいて AkCommonUserSettings::m_SamplesPerFrame のデフォルト値を512に変更しました。これによりWwiseの初期CPU使用が増加する一方、サウンドエンジンのオーディオレイテンシ合計が大幅に減少します。引き続きゲームの総オーディオレイテンシと利用可能な演算リソースのバランスをとるために"Samples Per Frame"や"Number of Refills In Voice"の微調整を行うことが推奨されます。

その他の変更

  • WG-57028 すべてのプラットフォームにおいて数値型をstdint.hで提供するようになりました。

コミュニティで報告されたバグの修正

  • WG-61295 修正済み: Unityインテグレーションはサーバビルドでデフォルトで無効になっています。
  • WG-61373 修正済み: (Wwise Unity Addressables) 開いていないシーンにおけるInitバンクへのリファレンスは、Init WwiseAddressableSoundBankが削除され再生成されている場合は無効となります。
  • WG-62390 修正済み: WwiseAddressableSoundBank RefCountは、LoadCountが0より大きい時にシリアライズすることができます。 この値はシリアライズが不要となりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.14.8108.2676

リリースノート - Wwise Unityインテグレーション 2021.1.14.8108.2676

このリリースはWwise 2021.1.14向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.14
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、tvOS、およびvisionOS 2021.1.14

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • その他の変更
  • バグ修正

新機能

  • WG-53593 ゲームがフォーカスを失っている時にオーディオを一時停止するオプションを追加しました。

その他の変更

  • WG-66693 Wwise UnityインテグレーションにはAudiokinetic Launcher 2023.1.1以降が必要です。

バグ修正

  • WG-68085 修正済み：Playモードに入った後はWwise Pickerが空です。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.13.8036.2602

リリースノート - Wwise Unityインテグレーション 2021.1.13.8036.2602

このリリースはWwise 2021.1.13向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.13
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-63983 修正済み: RoomAwareObjectを有効にした後に、RoomAwareManagerでNullReferenceException。

コミュニティで報告されたバグの修正

  • WG-54630 修正済み: Wwise Unity Addressablesを使用するiOSプラットフォームにおいて SetBasePath を不要に呼び出した時に、エラーメッセージがログに記録されます。
  • WG-63727 修正済み: UnityのAkEmitterObstructionOcclusionコンポーネントが音をすぐにブロックしません。
  • WG-64036 修正済み: 長い移行時間。
  • WG-64493 修正済み: Wwise Component Pickerが誤ったスクリーン上の位置に描写されます。
  • WG-64498 修正済み: ドメインのリロード時に"Unable to load Wwise Data: UnityEngine.UnityException: LoadAssetAtPath can only be called from the main thread."のエラー。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.12.7973.2529

リリースノート - Wwise Unityインテグレーション 2021.1.12.7973.2529

このリリースはWwise 2021.1.12向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.12
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1、2022.2です。2022.2.2f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-63119 修正済み: AkAmbientを停止した時にエラーが発生します。

コミュニティで報告されたバグの修正

  • WG-62051 修正済み: AkGameObjポジションのオフセットの変更が、prefabに適切に保存されません。
  • WG-63469 修正済み: prefabの Environment Aware プロパティへの AkGameObj コンポーネントの変更が保存されません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.11.7933.2488

リリースノート - Wwise Unityインテグレーション 2021.1.11.7933.2488

このリリースはWwise 2021.1.11向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.11
  • Unity: このインテグレーションのコンパイル対象はUnity 2020.3、2021.3、2022.1です。2021.3.14f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-61295 修正済み: Unityインテグレーションはサーバビルドでデフォルトで無効になっています。
  • WG-61373 修正済み: (Wwise Unity Addressables) 開いていないシーンにおけるInitバンクへのリファレンスは、Init WwiseAddressableSoundBankが削除され再生成されている場合は無効となります。
  • WG-62390 修正済み: WwiseAddressableSoundBank RefCountは、LoadCountが0より大きい時にシリアライズすることができます。 この値はシリアライズが不要となりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unity Integration 2021.1.10.7883.2429

リリースノート - Wwise Unity Integration 2021.1.10.7883.2429

このリリースはWwise 2021.1.10向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.10
  • Unity: このインテグレーションのコンパイル対象はUnity 2019.4、2020.3、2021.3です。2021.3.8f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-60348 修正済み: SetGameObjectRadius APIの呼び出しでGame Object IDが返されませんでした。

コミュニティで報告されたバグの修正

  • WG-57736 修正済み: AkAmbient.csを必要とするアセットをコマンドラインを使用して移行すると、エラーが発生していました。
  • WG-61133 修正済み: Wwiseプロジェクトが見つからない場合にUnityインテグレーションでメモリリークが発生することがありました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.9.7847.2389

リリースノート - Wwise Unityインテグレーション 2021.1.9.7847.2389

このリリースはWwise 2021.1.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.9
  • Unity: このインテグレーションのコンパイル対象はUnity 2019.4、2020.3、2021.2です。2021.2.17f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2021.1.9

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-59609 修正済み: 特定のプラットフォームのGenerateApiBinding.pyをコールした時に、ほかのプラットフォームを求めるエラーメッセージ。
  • WG-60097 修正済み: Unity Editor内でプレイすると、SetGameObjectRadiusが毎フレームでコールされました。
  • WG-60099 修正済み: Spatial Audio Initialization Setting Movement Thresholdのデフォルトが、UnityやUnity Demo Gameで高すぎました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.8.7831.2373

リリースノート - Wwise Unityインテグレーション 2021.1.8.7831.2373

このリリースはWwise 2021.1.8向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.8
  • Unity: このインテグレーションのコンパイル対象はUnity 2019.4、2020.3、2021.2です。2021.2.17f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2021.1.8

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-53953 Wwiseの初期化エラーを、より早くローカル出力で報告します。

バグ修正

  • WG-59456 修正済み: Unity 2020で、デフォルトのルーム"Outdoors"内に設定されたゲームオブジェクトが間違ったIDを使っていました。
  • WG-59563 修正済み: Unity EditorでSoundBankが見つからない時に、サウンドエンジン初期化で警告が出力されませんでした。
  • WG-59812 修正済み: AkRoomトーンがOnDisable内で再生されると、Unity Editorがクラッシュしました。

コミュニティで報告されたバグの修正

  • WG-58413 修正済み: Unity内でプレイ中にルームを無効にすると、エラーメッセージ'Unknown game object ID'。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.7.7796.2335

リリースノート - Wwise Unityインテグレーション 2021.1.7.7796.2335

このリリースはWwise 2021.1.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.7
  • Unity：Unity 2019.4.22f1、2020.3.1f1 (PersonalまたはPro)｡
    注記： このインテグレーションはUnity4に対応していません。このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム: | Wwise Unityインテグレーションテストに使用:
Mac (エディタおよびランタイム) Windows (エディタおよびランタイム) Linux (ランタイムのみ) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • コミュニティで報告されたバグの修正

新機能

  • WG-58565 Addressablesパッケージに、WwiseアセットのAddressablesメタデータのシリアライズとリストアを実行するサンプルスクリプトを追加しました。

コミュニティで報告されたバグの修正

  • WG-54625 修正済み: Windows以外のプラットフォームで AkAddressableBankManager が AK.Wwise.Unity.API.WwiseTypes アセンブリのロードに失敗しました。
  • WG-54627 修正済み: Addressables Wwise Build スクリプトは、エディタプラットフォームのアセットバンドルだけをビルドし、 WwiseAddressableSoundBank は常に、ターゲットビルドのプラットフォームではなくEditorプラットフォームの AssetReferences をシリアライズしました。
  • WG-58396 修正済み: Wwise Work Unitパーシングのエッジケース中の質の悪いロギング。Auto-delete WwiseObjectReferences設定を追加し、Work Unitパーサが実行するアセット削除の操作をユーザーが無効にできるようにしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.6.7774.2308

リリースノート - Wwise Unityインテグレーション 2021.1.6.7774.2308

このリリースはWwise 2021.1.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.6
  • Unity：Unity 2019.4.22f1、2020.3.1f1 (PersonalまたはPro)｡
    注記： このインテグレーションはUnity4に対応していません。このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム: | Wwise Unityインテグレーションテストに使用:
Mac (エディタおよびランタイム) Windows (エディタおよびランタイム) Linux (ランタイムのみ) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更

その他の変更

  • WG-57492 2つの新しい初期化設定を公開しました: MemoryAllocationSizeLimit （メモリの使用制限）と、 MemoryDebugLevel （メモリ問題のデバグ用）です。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.5.7749.2277

リリースノート - Wwise Unityインテグレーション 2021.1.5.7749.2277

このリリースはWwise 2021.1.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.5
  • Unity：Unity 2019.4.22f1、2020.3.1f1 (PersonalまたはPro)｡
    注記： このインテグレーションはUnity4に対応していません。このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム: | Wwise Unityインテグレーションテストに使用:
Mac (エディタおよびランタイム) Windows (エディタおよびランタイム) Linux (ランタイムのみ) PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-56969 修正済み: オフラインレンダリングを、ゲームタイムの2フレーム目まで開始できませでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.4.7707.2232

リリースノート - Wwise Unityインテグレーション 2021.1.4.7707.2232

このリリースはWwise 2021.1.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.4
  • Unity：Unity 2019.4.22f1、2020.3.1f1 (PersonalまたはPro)｡
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2021.1.4

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • パフォーマンスの変更
  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

新機能

  • WG-29814 オフラインレンダリングへの対応を追加しました。

パフォーマンスの変更

  • WG-55340 大きいプロジェクト階層のパースやフェッチを行うときの、Wwise Pickerの2つのモードのパフォーマンスを改善しました。

その他の変更

  • WG-55912 Unity C# バインディングが、SWIG 4.0.2から生成されるようになりました。
  • WG-56370 コミュニティからの指摘 : 古いバージョンからWwise 2021.1.1以降に移行するには、JsonSerialize Unityパッケージが必要です。

バグ修正

  • WG-55639 修正済み: (Spatial Audio) ルームを無効にして再度有効にすると、ルームが失われました。

コミュニティで報告されたバグの修正

  • WG-55076 修正済み: ビルド後のゲームで、WwiseTypesのアセンブリのロードが、Windowsプラットフォームでしか行えませんでした。
  • WG-55077 修正済み: SoundBankのロードに失敗したときに、SoundBankのEventリストにアクセスしようとすると、 NullReferenceExceptions が発生しました。
  • WG-55078 修正済み: SoundBankのロードが非同期で完了する前に、SoundBankのアンロードを行うというエッジケースの扱い方が不適切でした。
  • WG-55704 修正済み: ファイルパスに"Runtime/Plugins"が含まれるプラグインを含むUnityプロジェクトに、Wwiseをインテグレートできませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.3.7665.2179

リリースノート - Wwise Unityインテグレーション 2021.1.3.7665.2179

このリリースはWwise 2021.1.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.3
  • Unity：Unity 2019.4.22f1、2020.3.1f1 (PersonalまたはPro)｡
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2021.1.3

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-47576 IntegrationスクリプトをPython 2からPython 3にアップグレードしました。

バグ修正

  • WG-55388 修正済み: Unity WwiseDemoSceneが、AkSpatialAudioListenerエラーを報告しました。

コミュニティで報告されたバグの修正

  • WG-54782 修正済み: AkWwiseProjectInfo における誤った定義のため、AssetDatabase V2を使ったときに、エディタを開いたときにAkWwiseProjectDataアセットを作成すると問題が発生しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.2.7629.2141

リリースノート - Wwise Unityインテグレーション 2021.1.2.7629.2141

このリリースはWwise 2021.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-52653 修正済み: AkRoomコンポーネントのWet Transmission警告メッセージは、ゲームオブジェクトに無効にした AkSurfaceReflector があると、表示されませんでした。
  • WG-53624 修正済み: Playableの Time プロパティを操作しているときに、オーディオがシークしませんでした。

コミュニティで報告されたバグの修正

  • WG-54127 修正済み: Wwise Scriptable Objectが、常にダーティ（dirty）とマークされました。
  • WG-54619 修正済み: ローカルコンピュータのロケールが、小数点にピリオドを使わないと、SoundbankInfo.xmlをパースできませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.1.7601.2102

リリースノート - Wwise Unityインテグレーション 2021.1.1.7601.2102

このリリースはWwise 2021.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2021.1.1
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2021.1.1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-53257 修正済み: IntegrationsのCPU Limit値が、クランプしていませんでした。

コミュニティで報告されたバグの修正

  • WG-50723 修正済み: AkTriggerEnableは、Awake()で一度トリガーするだけで、その後の再enableではトリガーしませんでした。
  • WG-53320 修正済み: すでにUnityインテグレーションの一部であるダイナミックライブラリは、DSPフォルダにコピーされました。
  • WG-53410 修正済み: AkAmbient は、初期化されていないAkSoundEngineとbatchmodeでやり取りしようとしました。
  • WG-53722 修正済み: Game Parametersが、'Wwise Authoring'モードでWwise Pickerに表示されませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2021.1.0.7575.2069

リリースノート - Wwise Unityインテグレーション 2021.1.0.7575.2069

このリリースはWwise 2021.1.0向けWwise SDKアップデートを提供します。

  • 重要な移行の注意 2021.1

互換性：

  • Wwise SDK：2021.1.0
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • APIの変更
  • 動作の変更
  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

新機能

  • WG-34342 Wwise PickerウィンドウでWAAPIを使える場合は、使うようになりました。
  • WG-43009 Wwise Addressablesパッケージを追加し、Unity AddressablesシステムでWwiseアセットをロードできるようにしました。
  • WG-48935 Editorビューに表示される減衰半球の色を、変更できるようにしました。
  • WG-49016 Unity TreeViewバックエンドを使えるように、Wwise Pickerを更新しました。

APIの変更

  • WG-48127 バスのMeteringコールバック関数の AkBusMeteringCallbackFunc の署名が新しくなり、ゲームが AK::SoundEngine::RegisterBusMeteringCallback 経由で渡せるようになったオプショナルクッキーを運ぶ、 AkBusMeteringCallbackInfo というストラクチャを、受け取ります。同様に、 AK::SoundEngine::RegisterBusVolumeCallback() が、 AkSpeakerVolumeMatrixCallbackInfo ストラクチャによって AkBusCallbackFunc に正しく渡されるクッキーを、受け入れるようになりました。
  • WG-50742 Spatial Audio で"occlusion"を含むパラメータの名前を変更し、"transmission loss"にしました。

動作の変更

  • WG-47929 ソースのレイアウトを変更し、将来のUnityパッケージにインテグレーションを分けやすくしました。
  • WG-48326 コールバックのデータストラクチャメモリを、Authoringツールでモニタリングできるようになりました。
  • WG-52040 プラットフォームにカスタム名を使うには、デリゲートに登録することが必要になりました。詳細は UnityでWwiseのカスタムプラットフォームを使う を参照してください。

その他の変更

  • WG-52025 AkGameObj コンポーネントで、ゲームオブジェクトにAkRoomAwareObjectコンポーネントを追加するためのボタンを追加しました。
  • WG-52182 Monitor Queueのデフォルトプールのサイズを、大きくしました。

バグ修正

  • WG-48587 修正済み: 空のWork Unitの階層が、Wwise Pickerで正しく表示されませんでした。
  • WG-48929 修正済み: 減衰半球が、Editorビューでは見えにくい表示でした。

コミュニティで報告されたバグの修正

  • WG-52936 修正済み: Timelinesでスクラブ再生したときの、再生の問題。


Wwise Unity Integration Documentation: 重要な移行の注意 2021.1

重要な移行の注意 2021.1

Spatial Audio

Spatial Audioでは、オブストラクションやオクルージョンではなく、回折（diffraction）や透過（transmission）に言及することに決めました。

  • AkRoom コンポーネントでは、 Wall Occlusion の名前を、 Transmission Loss に変更しました。
  • AkSurfaceReflector コンポーネントでは、 Occlusion Values の名前を Transmission Loss Values に変更しました。

Spatial Audio Initialization Settingsが更新され、改善されました。あなたのプロジェクトを2021.1に更新する場合は、必ずSpatial Audio Initialization Settingsを再確認し、全ての設定がまだ希望通りであることを確認してください。 AkSpatialAudioInitSettings Struct Reference を参照してください。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.15.7667.2215

リリースノート - Wwise Unityインテグレーション 2019.2.15.7667.2215

このリリースはWwise 2019.2.15向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.15
  • Unity: このインテグレーションのコンパイル対象はUnity 2019.4、2020.3、2021.2です。2021.2.17f1に対してテストしました。前述のバージョンより新しいバージョンのUnityには現在対応していませんが、今後のパッチリリースで対応します。

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2019.2.15

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-50265 修正済み: Unity SpatialAudioTutorialのMobile Main Cameraオブジェクトにはスペーシャルオーディオリスナーがありませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.14.7616.2152

リリースノート - Wwise Unityインテグレーション 2019.2.14.7616.2152

このリリースはWwise 2019.2.14向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.14
  • Unity：Unity 2018.4.31f1, 2019.4.21f1, 2020.3.0f1 (PersonalまたはPro)。
    注記： 重要: このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更

その他の変更

  • WG-55912 Unity C# バインディングが、SWIG 4.0.2から生成されるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.13.7577.2104

リリースノート - Wwise Unityインテグレーション 2019.2.13.7577.2104

このリリースはWwise 2019.2.13向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.13
  • Unity：Unity 2018.4.31f1, 2019.4.21f1, 2020.3.0f1 (PersonalまたはPro)。
    注記： 重要: このリストに含まれるのは、厳密な互換性テストが実行されたUnityのバージョンだけです。Unityのこれ以外のバージョンとの互換性は、合理的に期待できますが、保証されていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2019.2.13

以前のバージョンについては、 以前のリリースノート を参照してください。

  • APIの変更
  • バグ修正

APIの変更

  • WG-56084 AkUtilities.GetWwiseSoundBankDestinationFolder 関数シグニチャを更新しました。

バグ修正

  • WG-52943 修正済み: Unity Editorでプレイモードに入ると、Decode Compressed Dataパスがクリアされました。
  • WG-55388 修正済み: UnityのWwiseDemoSceneで、AkSpatialAudioListenerのエラーが報告されました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.12.7544.2058

リリースノート - Wwise Unityインテグレーション 2019.2.12.7544.2058

このリリースはWwise 2019.2.12向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK：2019.2.12
  • Unity：Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3 (Personal また Pro)。
    注記： 重要な注意点：上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • その他の変更
  • バグ修正
  • コミュニティで報告されたバグの修正

その他の変更

  • WG-47576 IntegrationスクリプトをPython 2からPython 3にアップグレードしました。

バグ修正

  • WG-53624 修正済み: Playableの Time プロパティを操作しているときに、オーディオがシークしませんでした。

コミュニティで報告されたバグの修正

  • WG-53980 修正済み: Unityインテグレーションコードで、.NET 3.5との非互換性。
  • WG-54619 修正済み: ローカルコンピュータのロケールが、小数点にピリオドを使わないと、SoundbankInfo.xmlをパースできませんでした。
  • WG-54782 修正済み: AkWwiseProjectInfo における誤った定義のため、AssetDatabase V2を使ったときに、エディタを開いたときにAkWwiseProjectDataアセットを作成すると問題が発生しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.11.7512.2017

リリースノート - Wwise Unityインテグレーション 2019.2.11.7512.2017

このリリースはWwise 2019.1.11向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.11
  • Unity: Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3 (Personal また Pro)。
    注記： 重要な注意点：上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

プラットフォーム固有の情報は、こちらにあります:

Mac、iOS、およびtvOS 2019.2.11

以前のバージョンについては、 以前のリリースノート を参照してください。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-53320 修正済み: 既にUnityインテグレーションの一部であるライブラリは、DSPフォルダにコピーされました。
  • WG-54308 修正済み: Playableのタイムをコードから直接変更すると、アクティブイベントをシークしませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.10.7490.1989

リリースノート - Wwise Unityインテグレーション 2019.2.10.7490.1989

このリリースはWwise 2019.2.10向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.10
  • Unity: Unity 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1, 2020.3 (Personal また Pro)。
    注記： 重要な注意点：上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-53615 修正済み: AkPluginActivatorが、プラグインのxmlファイルを、最初は間違ったパスで探していました。

コミュニティで報告されたバグの修正

  • WG-50723 修正済み: AkTriggerEnableは、Awake()で一度トリガーするだけで、その後の再enableではトリガーしませんでした。
  • WG-52936 修正済み: Timelinesでスクラブ再生したときの、再生の問題。
  • WG-53410 修正済み: AkAmbient は、初期化されていないAkSoundEngineとbatchmodeでやり取りしようとしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.9.7459.1949

リリースノート - Wwise Unityインテグレーション 2019.2.9.7459.1949

このリリースはWwise 2019.2.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-47326 修正済み: Spatial Audioチュートリアルで、ダイアログサウンドの距離減衰に設定したローパスフィルタが、強すぎました。
  • WG-51287 修正済み: Unityでプロジェクトを開くと、Wwise Pickerにデータが入るのに、時間が長くかかりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.8.7432.1919

リリースノート - Wwise Unityインテグレーション 2019.2.8.7432.1919

このリリースはWwise 2019.2.8向けWwise SDKアップデートを提供します。

  • 重要な移行の注意 2019.2.8

互換性：

  • Wwise SDK: 2019.2.8
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2019.4.0f1

以前のバージョンについては、 以前のリリースノート を参照してください。


Wwise Unity Integration Documentation: 重要な移行の注意 2019.2.8

重要な移行の注意 2019.2.8

BitcodeとiOSを使う

2019.2.8以降、iOS用のWwise SDKはXCode 12を使ってビルドしています。あなたがまだXCode 11を使っている場合は、生成されたXCodeプロジェクトで、必ずBitcodeを無効にしてください。Unityビルドプロセスが完了したら、生成されたXCodeプロジェクトを開きます。次にXcode ProjectのBuild Settingsを開き、"Build Options"セクションの"Enable Bitcode"を、"No"に設定します。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.7.7402.1888

リリースノート - Wwise Unityインテグレーション 2019.2.7.7402.1888

このリリースはWwise 2019.2.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.7
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2019.4.0f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-50610 修正済み: 許容範囲外でルームIDを使うと、予測できない動作をしました。Rooms and Portals Integrationのデモのため誤解されがちですが、 AkRoomID::OutdoorsGameObjID は有効なルームIDではありません。代わりに AK::SpatialAudio::kOutdoorRoomID (-1) を使ってください。

コミュニティで報告されたバグの修正

  • WG-51147 修正済み: Unity Editorでプレイモードに入るときの、 XmlWatcher.EnableRaisingEvents 関連の長い待ち時間。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.6.7381.1867

リリースノート - Wwise Unityインテグレーション 2019.2.6.7381.1867

このリリースはWwise 2019.2.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.6
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2019.4.0f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正

バグ修正

  • WG-47325 修正済み: Spatial Audioチュートリアルで使われるリバーブは、Early Reflectionsが有効でした。
  • WG-47374 修正済み: Spatial Audio Roomを削除すると、Room toneがオーファン（孤立）になりました。
  • WG-49936 修正済み: チュートリアルのSpatial AudioメッシュをSpatial Audio Geometryとして使うと、エラーが表示されました


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.5.7349.1831

リリースノート - Wwise Unityインテグレーション 2019.2.5.7349.1831

このリリースはWwise 2019.2.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.5
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal また Pro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2019.4.0f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • 新機能
  • バグ修正
  • コミュニティで報告されたバグの修正

新機能

  • WG-48674 シーン内でプレイ中に、ポータルを閉じると、ポータルのギズモが変わります。

バグ修正

  • WG-47470 修正済み: AkSpatialAudioListener が正しく移行されませんでした。
  • WG-48672 修正済み: AkRoomPortal で、depth(Z)を拡大縮小すると、誤ったフロントルームやバックルームの割り当てが行われました。

コミュニティで報告されたバグの修正

  • WG-49902 修正済み: ネスト化されたWork Unitに関連したWwise Pickerの問題。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.4.7329.1806

リリースノート - Wwise Unityインテグレーション 2019.2.4.7329.1806

このリリースはWwise 2019.2.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.4
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.4.0f1

バグ修正

  • WG-45583 修正済み: Wwise SDKフォルダが特定の場所にないと、Unityインテグレーションをビルドできませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.3.7304.1778

リリースノート - Wwise Unityインテグレーション 2019.2.3.7304.1778

このリリースはWwise 2019.2.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.3
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.10f1

コミュニティで報告されたバグの修正

  • WG-49370 修正済み: AkBankは、Awakeでロードするように設定すると、バンクをAwakeでアンロードしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.2.7275.1749

リリースノート - Wwise Unityインテグレーション 2019.2.2.7275.1749

このリリースはWwise 2019.2.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.2
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.10f1

解決済みの問題:

  • WG-46080 修正済み: AkTriggerEnable が最初のトリガーを検知できませんでした。
  • WG-47578 修正済み: Unityをコマンドラインからスタートさせると、ハングアップしました。
  • WG-48293 修正済み: Wwise Project ExplorerのHierarchyは、何も入っていないバーチャルフォルダがHierarchyに含まれていると、Wwise Pickerで正しく表示されませんでした。
  • WG-48525 修正済み: アップデートファンクションである AkWwiseXMLWatcher のパフォーマンス問題。
  • WG-48709 修正済み: Asset Pipelineバージョン2を使ってWwiseをUnityプロジェクトにインテグレートすると、ハングアップしました。
  • WG-48831 修正済み: Wwiseプラグインが、ビルドしたゲームに登録されていませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.1.7250.1718

リリースノート - Wwise Unityインテグレーション 2019.2.1.7250.1718

このリリースは Wwise 2019.2.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.2.1
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.0f6

解決済みの問題:

  • WG-47287 Nintendo SwitchとiOS向けに、UnityインテグレーションでKrotos Igniterに対応しました。
  • WG-47349 修正済み: Unity 2019.3のWwise Pickerの色を、Unity 2019.2と同じにしました。
  • WG-47491 修正済み: (Stadia) Unityで、ダイナミックプラグインをStadiaにロードできませんでした。
  • WG-47537 修正済み (Stadia): Integrationライブラリは、 std::atomic に依存しなくなりました。
  • WG-47621 .NET 3.5スクリプトバックエンドを使ったときのコンパイルを、修正しました。
  • WG-48108 修正済み: 多数のコールバックを生成したときの、デッドロックの可能性を回避しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.2.0.7216.1681

リリースノート - Wwise Unityインテグレーション 2019.2.0.7216.1681

このリリースは Wwise 2019.2.0向けWwise SDKアップデートを提供します。

  • 重要な移行の注意 2019.2

互換性：

  • Wwise SDK: 2019.2.0
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows | Unity 2019.3.0f6
Android iOS Linux Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

解決済みの問題:

  • WG-39507 AkVector と AkVertex の使用の代わりに、 UnityEngine.Vector3 を使いました。
  • WG-42160 Wwise Editor設定と、Wwise Initialization設定を、 SettingsProviders として登録しました。
  • WG-42486 修正済み: Spatial Audioで、Back RoomやFront Roomにポータルをアサインすると、それをUndo/Redoできませんでした。
  • WG-42487 修正済み: (Spatial Audio) AkRoom コンポーネントを無効にすると、リスナーやエミッターが正しいルームに配置されませんでした。
  • WG-43185 Mutexの代わりに C# lockを使い、ロックのパフォーマンスを改善しました。
  • WG-43252 Wwiseのデバイス列挙を公開しました。
  • WG-43255 "Wwise\Resources" フォルダの名前を、 "Wwise\ScriptableObjects" に変えました。
  • WG-43329 AK::SoundEngine::ResourceMonitor 機能をUnityに公開しました。
  • WG-44044 メモリオーバーロードからのLoadBankを、 LoadBankMemoryCopy と LoadBankMemoryView に名前を変更しました。
  • WG-44311 (Spatial Audio) AkEnvironmentPortal に undo/redo のサポートを追加しました。
  • WG-44366 修正済み: AkRoom コンポーネントの無効化は、予想通りに機能しませんでした。
  • WG-44450 AkArray 、 AkHashList 、 AkKeyArray のすべてのバリエーションが、自身の "成長ポリシー" なるルールを提供することを選択でき、各宣言が適用するルールを最適化できます。
  • WG-44742 UnrealとUnityにおける、Spatial Audio設定の範囲を更新しました。
  • WG-44768 プラットフォームが対応していれば UnityEngine.Application.persistentDataPath からバンクをロードできる機能を、追加しました。
  • WG-45089 UnityのTimeline内で AkEventPlayables に対応するときに表示されることがある警告を、削除しました。
  • WG-45586 Spatial Audioに bEnableDirectPathDiffraction パラメータを追加し、ディフラクションをグローバル（全体的）に有効化・無効化できるようにしました。
  • WG-45782 修正済み: (Spatial Audio) AkRoom を無効化したあとに、AkSurfaceReflector コンポーネントが無視されました。
  • WG-46045 次の移行手順を2019.2に追加しました: AkSpatialAudioEmitter を、 AkRoomAwareObject に置き換えました。
  • WG-46158 シーンの切り替えやアプリケーション終了のメニューを、 WwiseDemoSceneに追加しました。
  • WG-46919 修正済み: Libraryフォルダの削除後に、WAAPI Clientで DllNotFoundException が発生する可能性がありました。
  • WG-46991 修正済み: バックグランドにおけるバンクのアンロードは、もう発生しません。
  • WG-47182 AkRoomPortal のフロントルームとバックルームを変更できる可能性を、取り消しました。ルームは自動的に、 AkRoomPortal のフロントポジションとバックポジションに重なる、最もプライオリティの高い、アクティブで、有効なルームとなりました。その結果、 SpatialAudioTutorial Unity のシーンの AkRoomPortal Component Baker が削除されました。


Wwise Unity Integration Documentation: 重要な移行の注意 2019.2

重要な移行の注意 2019.2

Spatial Audio

AkSpatialAudioEmitter コンポーネントが非推奨になりました。2019.2では、Spatial audioのパラメータを、オーサリングツールで、サウンド別に適用できます。Spatial audioのエミッタとして、1つのエミッタをタグ付けする必要がなくなりました。

  • Early Reflection
    • Reflect Aux Bus: 2019.2からは、オーサリングツールでEarly reflections auxiliary busを選択することができ、それはSound SFX Property Editorの、General Settingsタブで行います。引き続き、 AK::SpatialAudio::SetEarlyReflectionsAuxSend() をコールしてER auxiliary busをゲームオブジェクトに関連付けることは可能ですが、オーサリングツールで指定したEarly reflection auxiliary busの方が優先されます。詳細は、新 AkEarlyReflections コンポーネントを参照してください。現在、このコンポーネントは、このパラメータでAux busを指定して、AK::SpatialAudio::SetEarlyReflectionsAuxSend() をコールします
    • Reflection Max Path Length: 2019.2からは、Reflection Max Path LengthはAuthoringツールで、サウンドのAttenuation Max Distance値によって設定されます。
    • Reflection Aux Bus Gain: 2019.2からは、オーサリングツールでEarly reflectionsのボリュームを選択できるようになり、それはSound SFX Property Editorの、General Settingsタブで行います。引き続き、Early reflectionsボリュームをゲームオブジェクトごとに、 AK:SpatialAudio::SetEarlyReflectionsVolume() をコールして設定できます。オーサリングツールで各サウンドに設定したボリュームに、追加で適用されます。詳細は、新 AkEarlyReflections コンポーネントを参照してください。現在、このコンポーネントは、このパラメータ経由でボリュームを指定して、 AK:SpatialAudio::SetEarlyReflectionsVolume() をコールします。
    • Reflections Order: 2019.2からは、Reflection OrderをSpatial Audio Initialization Settingsで設定します。
  • Rooms
    • Room Reverb Aux Bus Gain: 2019.2からは、Room Reverb Aux Bus Gainを、AuthoringツールのSound Property Editorの、Game-Defined Auxiliary Sends Volumeで設定します。
  • Geometric Diffraction
    • Diffraction Max Edges: 2019.2からは、ディフラクションをAuthoringツールのSound Property Editorで有効にします。
    • Diffraction Max Paths: 2019.2からは、ディフラクションをAuthoringツールのSound Property Editorで有効にします。
    • Diffraction Max Path Length: 2019.2からは、ディフラクションをAuthoringツールのSound Property Editorで有効にします。

  • Debug Draw: Debug描画を、新 AkSpatialAudioDebugDraw コンポーネントに移動しました。

    AkSurfaceReflector コンポーネントには、新しいパラメータがあります。

  • Mesh: AkSurfaceReflector コンポーネントで、 MeshFilter コンポーネントが不要になりました。その代わり、Spatial Audioに送る、サーフェスリフレクタを表すメッシュは、このパラメータで指定します。何も選択しないと、このコンポーネントが、UnityのGame ObjectにMesh Filterコンポーネントがないかをチェックし、そのメッシュを AkSurfaceReflector として使います。
  • Acoustic Textures: 旧 AkSurfaceReflector コンポーネントでは、サーフェスリフレクタのメッシュ全体に対して1つの AkAcousticTexture しか選択できませんでした。2019.2からは、前のパラメータで提供されるメッシュのサブメッシュごとに、異なる AkAcousticTexture を指定できます。Acoustic Textureパラメータ1つに送られていた古い設定値は、全サブメッシュに適用されます。

Spatial Audioに AkRoomAwareObject という新しいコンポーネントが追加されました。このコンポーネントが AK::SpatialAudio::SetGameObjectInRoom() をコールするので、ゲームオブジェクトがどのルームにいるのかをSpatial Audioが常に把握するのに、役立ちます。このコンポーネントを、Spatial Audioのすべてのエミッターやリスナーに追加する必要があります。

  • AkRoomAwareObject コンポーネントは、移行によって今までAkSpatialAudioEmitterのあったGameObjectに、自動的に追加されるはずです。移行しても、このコンポーネントは AkSpatialAudioListener ゲームオブジェクトに追加されないので、ユーザーが行う必要があります。
  • AkRoomAwareObject コンポーネントの詳細については、 AkRoomAwareObject をInspectorで使う を参照してください。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.11.7296.1786

リリースノート - Wwise Unityインテグレーション 2019.1.11.7296.1786

このリリースはWwise 2019.1.11向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.11
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (ユニバーサル Windows プラットフォーム) Stadia | Unity 2020.1.16f1

以前のバージョンについては、 以前のリリースノート を参照してください。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480

リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480

このリリースはWwise 2019.1.10向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.10
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.10f1

以前のバージョンについては、 以前のリリースノート を参照してください。

  • バグ修正
  • コミュニティで報告されたバグの修正

バグ修正

  • WG-45583 修正済み: Wwise SDKフォルダが特定の場所にないと、Unityインテグレーションをビルドできませんでした。

コミュニティで報告されたバグの修正

  • WG-48525 修正済み: アップデートファンクションである AkWwiseXMLWatcher のパフォーマンス問題。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.9.7221.1704

リリースノート - Wwise Unityインテグレーション 2019.1.9.7221.1704

このリリースはWwise 2019.1.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal また Pro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.0f10

解決済みの問題:

  • WG-47349 修正済み: Unity 2019.3のWwise Pickerの色が、Unity 2019.2と違いました。
  • WG-47578 修正済み: Unityをコマンドラインからスタートさせると、ハングアップしました。
  • WG-48108 修正済み: 多数のコールバックを生成したときに、ハングすることがありました。
  • WG-48709 修正済み: Asset Pipelineバージョン2を使ってWwiseをUnityプロジェクトにインテグレートすると、ハングアップしました。
  • WG-48831 修正済み: Wwiseプラグインが、ビルドしたゲームに登録されていませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.8.7173.1654

リリースノート - Wwise Unityインテグレーション 2019.1.8.7173.1654

このリリースはWwise 2019.1.8向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.8
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal また Pro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.3.0f6
Stadia | Unity 2019.3.0f5

解決済みの問題:

  • WG-46771 修正済み: (Android) ノティフィケーションやソフトウェアキーボードを表示すると、Sound Engineが一時停止しました。
  • WG-46919 修正済み: Libraryフォルダの削除後に、WAAPI Clientで DllNotFoundException が発生する可能性がありました。
  • WG-46984 よりドキュメンテーションの記載に合うように、UnityのTimeline Integrationを簡素化しました。
  • WG-47287 Nintendo SwitchとiOS向けに、UnityインテグレーションでKrotosに対応。
  • WG-47418 修正済み: Spatial Audioの定位置の屋外ゲームオブジェクトが、元の場所に配置されていました。
  • WG-47491 修正済み: (Stadia) Unityで、ダイナミックプラグインをStadiaにロードできませんでした。
  • WG-47687 修正済み: Wwise UnityインテグレーションソースPackageに、AkSoundEngineLumin.makeを追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.7.7135.1611

リリースノート - Wwise Unityインテグレーション 2019.1.7.7135.1611

このリリースは Wwise 2019.1.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.7
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal また Pro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

解決済みの問題:

  • WG-44250 レガシーのFinalizerをEventCallbackPackageから削除しました。
  • WG-46282 修正済み: ビルド後のゲームのパス名に "Deployment" が含まれる場合、"Plug-in not found" エラーが表示されました。
  • WG-46282修正済み: AkGameObj が動かない場合はポジションを一度設定するようになり、もしマルチポジションに設定されていてターゲットの UnityEngine.GameObjects が静的でない場合は、 AkAmbientInspector に警告が表示されます。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.6.7110.1585

リリースノート - Wwise Unityインテグレーション 2019.1.6.7110.1585

このリリースは Wwise 2019.1.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.6
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal また Pro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.2.10f1
Stadia | Unity 2019.3.0b8

解決済みの問題:

  • WG-45582 AkEnvironmentPortal が送信するaux send値を [0, 1] にクランプしました。
  • WG-45671 Wwise Advanced Settingsで、low-level I/OのAsync Openを公開しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.5.7093.1568

リリースノート - Wwise Unityインテグレーション 2019.1.5.7093.1568

このリリースは Wwise 2019.1.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.5
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal また Pro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.2.6f1
Stadia | Unity 2019.3.0b8

解決済みの問題:

  • WG-45084 スクラビングしたあとの AkEventPlayable の再生を修正しました。
  • WG-45708 (Switch) ストリーミングサウンドを使ったときのフリーズを修正しました。
  • WG-45806 Fixing clip durations of AkEventPlayablesというポップアップ表示の裏の処理を、最適化しました。
  • WG-45902 (Stadia) 初期化のときのクラッシュを修正しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.4.7065.1538

リリースノート - Wwise Unityインテグレーション 2019.1.4.7065.1538

このリリースは Wwise 2019.1.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.4
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

解決済みの問題:

  • WG-44854 Xbox One用に生成するSoundBankベースパス（base path）の誤字を修正しました。
  • WG-44905 WwiseGroupValueObjectReferences は、その GroupObjectReferences が変更されると、ダーティとマークされました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.3.7048.1516

リリースノート - Wwise Unityインテグレーション 2019.1.3.7048.1516

このリリースは Wwise 2019.1.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.3
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

解決済みの問題:

  • WG-43179 Stadiaの初歩的なサポートを追加しました。
  • WG-43705 Unityでオクルージョンを修正しました。
  • WG-43966 Google Resonance Mixerプラグインが、Mixerプラグインのデフォルトのアタッチメントパラメータでアウトプットしないのを、修正しました。
  • WG-44142 Wwiseのバージョン情報や著作権情報が、Editorやビルドしたゲームのログに表示されるようになりました。
  • WG-44205 {{WwiseObjectReference}} アセットファイルが変更されるのは、そのデータが変更されたときだけです。
  • WG-44393 ゲームをビルドしたときに発生する、コンパイル警告を排除しました。
  • WG-44581 (iOS, Switch) このプラットフォーム専用の "PluginInfo.xml" ファイルが見つからないときにスローされる {{KeyNotFoundException}} エラーから、ビルドを保護しました。
  • WG-44205 WwiseObjectReference アセットファイルが変更されるのは、そのデータが変更されたときだけです。
  • WG-44393 ゲームをビルドしたときに発生する、コンパイル警告を排除しました。
  • WG-44581 プラットフォーム固有のPluginInfo.xmlファイルがみつからないときに、 {{KeyNotFoundException}} からSwitchとiOSの保護されたビルドが、throwされました。
  • WG-44627 GetWindowsDeviceCount() を追加し、 GetWindowsDeviceName() を修正したので、 AkAudioDeviceState の引数を受け入れるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1481

リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1481

このリリースは Wwise 2019.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1と、ML SDK 0.21.0

解決済みの問題:

  • WG-44216 Bug Reporterで報告されました: .NET 3.5 スクリプトバックエンドを使ったときのコンパイルエラーを修正しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480

リリースノート - Wwise Unityインテグレーション 2019.1.2.7018.1480

このリリースは Wwise 2019.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1と、ML SDK 0.21.0

解決済みの問題:

  • WG-42831 Unityのコールバックから一時停止中に、サウンドエンジンがレンダリングするかどうかを決定する設定を、追加しました。
  • WG-43182 大量のシーンのあるUnityプロジェクトの移行を、開いたシーンをすべて閉じることで、修正しました。
  • WG-43292 Spatial Audioのポータルが正しく配置されているときのエラーを、修正しました。
  • WG-43347 (Switch) コミュニティプラグインを使った場合の実装の問題を、修正しました。
  • WG-43358 (iOS) コミュニティプラグインを使った場合の実装の問題を、修正しました。
  • WG-43676 UWP: VS 2017にアップデートし、ARM64のサポートを追加しました。
  • WG-44134 Launcher 2019.5.905を使ってWwiseとインテグレーションしたあとに、UnityプロジェクトのビルドがAkSoundEngine.aで失敗するのを、修正しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.1.6977.1430

リリースノート - Wwise Unityインテグレーション 2019.1.1.6977.1430

このリリースは Wwise 2019.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.1
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (PersonalまたはPro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 Switch tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2019.1.0f2
Magic Leap (Lumin OS) | Unity 2019.1.0f2 with ML SDK 0.19.0

解決済みの問題:

  • WG-40425 Timeline上のAkEventsが正確に更新されるように変更し、名前やタイミングの変更を反映させ、SoundBankが新しい情報で再生成されたときに、それを示すようにしました。
  • WG-41071 TimelineのAkEventのクリップが、総長さが分からない場合に適切な最小長さで作成されるようにしました。
  • WG-41383 AkEventPlayable オブジェクトが、それに関連するクリップの終わりで停止するのかどうかを指定できる機能を追加しました。
  • WG-41684 修正済み: Windows実行ファイルを、Macエディタでビルドできませんでした。
  • WG-41721 AkRoomPortal コンポーネントを変え、初期ステートを選択できるオプションを追加しました。
  • WG-42001 修正済み: AkExternalSourceInfo.szFile を設定するときにクラッシュしました。
  • WG-42612 (Switch) Sourceソリューションを、フォルダ位置の条件なしでビルドできるようにしました。
  • WG-42625 構造のアレイを受領できるように、APIを適切に公開しました。
  • WG-42841 AkAmbientの添付されたGameObjectを選択したときの、NullReferenceExceptionを修正しました。
  • WG-42870 Motion plug-in DLLを、Unityインテグレーションのパッケージに含めました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2019.1.2.6947.1394

リリースノート - Wwise Unityインテグレーション 2019.1.2.6947.1394

このリリースはWwise 2019.1.0向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2019.1.0
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (PersonalまたはPro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Mac PS4 Switch Windows Xbox One | Unity 2018.3.7f1
Linux tvOS UWP (Universal Windows Platform) | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 with ML SDK 0.16.0)

解決済みの問題:

  • WG-26971 Wwiseオブジェクトの名前変更が、Unityプロジェクト全体に確実に適用されるようにしました。
  • WG-36815 修正済み: Advanced ProfilerのListenersタブで、Game Object名やListener名がリフレッシュされませんでした。
  • WG-38842 更新されたSoundBanksを設定し、Unityエディタに正しくリロードされるようにしました。
  • WG-39769 AkSurfaceReflectorコンポーネントを変更し、AkRoomコンポーネントに関連付くようにしました。
  • WG-40552 AkAmbient が、 Large_Mode というポジショニングタイプのときに、変わったエディタを使わないようになりました。代わりに、 AkAmbientLargeModePositioner コンポーネントを含む子オブジェクトを、マルチポジショニングのポジションソースとして使います。
  • WG-41010 Acoustic TexturesやGame Parametersの正しいアイコンを、Wwise Pickerに追加しました。
  • WG-41282 AkSurfaceReflector を、Acoustic Texturesのドラッグ＆ドロップの対象として追加しました。
  • WG-42073 すべてのPythonビルドスクリプトを、Python 3と互換性のあるものにしました。
  • WG-42081 (Linux) 32-bitのサポートを排除しました。
  • WG-42133 (Switch) 提供中のすべてのプラグインを、このプラットフォームで使えるようにしました。
  • WG-42208 修正済み: (tvOS) DSPプラグインへの、誤ったパス。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.6.6858.1313

リリースノート - Wwise Unityインテグレーション 2018.1.6.6858.1313

このリリースはWwise 2018.1.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.6
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (PersonalまたはPro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Mac Xbox One | Unity 2018.2.16f1
Linux PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 2018.2.16f1用Unityと、NintendoSDK 6.4.0

解決済みの問題:

  • WG-36343 修正済み: Portal obstructionが無効のポータルに設定されているため、エラーログが大量に表示されました。
  • WG-37644 修正済み: 誤った "AkInitializer.cs Awake() was not executed yet" というレポートが複数、標準アウトプットに印刷されました。
  • WG-39629 修正済み: Wwise Unityインテグレーションをインテグレートするときに、一部のシーンで AkAudioListener がカメラに追加されませんでした。
  • WG-39793 エディタでゲームが一時停止しているときに、Wwise Profilerを接続できるようになりました。
  • WG-40103 修正済み: WwiseTypesを移行するときに、Prefabsは保存されませんでした。
  • WG-40988 修正済み: サウンドを再生中に、 AkAmbient Playボタンが正しくリフレッシュされませんでした。
  • WG-41012 修正済み: Wwise Pickerからアイテムをドラッグ＆ドロップしてGame Object Inspectorビューに入れたときに、これに該当するスクリプトが作成されないことがありました。
  • WG-41018 修正済み: ドラッグ＆ドロップの操作を元に戻す・やり直すという行為は、Componentの作成をWwise Pickerから始めると、失敗しました。 WG-41107 (iOS, Switch, tvOS) 修正済み: 欠如したプラグインを参照するゲームを構築しても、エラーが表示されませんでした。
  • WG-41185 修正済み: プレイモード中に、Wwise Pickerウィンドウに "Root Item" が表示されました。
  • WG-41248 (PS4) 修正済み: ATRAC9のデコーディングは、ACP Batchバッファがないため、失敗しました。
  • WG-41479 修正済み: Timeline Demo Eventと、RTPCトラックを、移行できませんでした。
  • WG-41514 修正済み: Wwise Pickerからドラッグ＆ドロップしたときに、Wwise Pickerが正しいアイテムを参照しないことがありました。
  • WG-41815 修正済み: Wwiseコンポーネントの移行が、Wwiseの2018.1.3版から、 2018.1.6版まで、正しく行われませんでした。
  • WG-41920 AkEvents のコールバックが、Prefabインスタンス上で使うときに、確実に保存されるようにしました。
  • WG-42016 (Switch) パッケージに AkMotionSourceSource を追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.5.6835.1288

リリースノート - Wwise Unityインテグレーション 2018.1.5.6835.1288

このリリースはWwise 2018.1.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.5
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (PersonalまたはPro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 2018.2.16f1用Unityと、NintendoSDK 6.4.0

解決済みの問題:

  • WG-36753 UnityインテグレーションのC++を生成するために、SDKのpremake5を使用することになりました。
  • WG-39264 修正済み: Wwiseコンポーネントを含むオブジェクトを元に戻した（undo）ときの、コンソールのスパム。
  • WG-39429 修正済み: UIで表示されるプラットフォーム別の詳細設定を見つけることができませんでした。
  • WG-39543 SoundBankを生成すると、Timeline上のSound Eventが新しい名前で表示されるようになりました。
  • WG-39990 Android ARM64のサポートを追加しました。
  • WG-40006 プラグインのコンフィギュレーション変更を確認するメッセージを追加しました。
  • WG-40565 修正済み: Wwise Unityの初期化設定で、Spatial AudioのDiffraction設定のデフォルト値が無効でした。デフォルト値を修正したので、今までのプロジェクトのデフォルト値は、この範囲内に収まるように検証されます。
  • WG-40674 修正済み: Unity 2017.3より前のバージョンの、コンパイルエラー。
  • WG-40992 UnityデータにあるWwise Project情報の複製が、適宜、保存されるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.4.6807.1258

リリースノート - Wwise Unityインテグレーション 2018.1.4.6807.1258

このリリースはWwise 2018.1.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.4
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 2018.2.16f1用Unityと、NintendoSDK 6.4.0

解決済みの問題:

  • WG-39412 AkAmbientツールバーが、HiDPIディスプレイで表示されない問題を解決しました。
  • WG-39444 AkExternalSourceInfoファイル名の文字列エンコードを解決しました。
  • WG-39639 AkEventPlayable Timelineクリップが、新しいSoundBank情報に反応しないのを解決しました。
  • WG-39849 AkSoundEngine.PrepareEvent()やAksoundEngine.PrepareGameSync()を、文字列の配列でコールするときの、ヒープコラプションを解決しました。
  • WG-40051 SwitchプラットフォームのDevelopment Build問題を解決しました。
  • WG-40095 アセットの変更中にプロジェクトを開いたときにハングするのを、解決しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.3.6784.1233

リリースノート - Wwise Unityインテグレーション 2018.1.3.6784.1233

このリリースはWwise 2018.1.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.3
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 4.1.0用Unity (Unity 2018.1.4f1と、NintendoSDK 5.4.0)

解決済みの問題:

  • WG-38413 修正済み: Editorを一時停止してから再生モードに入ると、Unityがフリーズしました。
  • WG-39235 サウンドエンジンが初期化済みのときの、ログメッセージを追加しました。
  • WG-39416 解決済み: Prepare Pool Sizeを0以外に設定すると、Unityがクラッシュしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.2.6762.1211

リリースノート - Wwise Unityインテグレーション 2018.1.2.6762.1211

このリリースはWwise 2018.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.2
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (PersonalまたはPro)。
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 4.1.0用Unity (Unity 2018.1.4f1と、NintendoSDK 5.4.0)

解決済みの問題:

  • WG-26971 Wwiseオブジェクトの名前変更が、Unityプロジェクト全体に適用されるようになりました。
  • WG-39195 修正済み: 値が一貫している場合の、エディターのリスナーポジションやオリエンテーションのスパミング。
  • WG-39235 サウンドエンジンが初期化済みのときの、ログメッセージを追加しました。
  • WG-39307 減衰半球の見え方を、透明度90にしました。
  • WG-39331 変更があったときに、 AkWwiseInitializationSettings {{ScriptableObject}} がプラットフォーム設定と共に、確実に保存されるようにしました。
  • WG-39362 UnityインテグレーションにOpusコーデックを追加しました。
  • WG-39577 修正済み: (Xbox One) 初期化問題。
  • WG-39608 パッケージに、WAAPI C# APIファイルを追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.1.6727.1172

リリースノート - Wwise Unityインテグレーション 2018.1.1.6727.1172

このリリースはWwise 2018.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2018.1.1
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (PersonalまたはPro)。
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2018.1.5
Mac Windows | Unity 2018.2.2f1
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.0f2-MLTP6と、ML SDK 0.16.0)
Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-35762: 修正済み: 複数のAkEventsを選択して再生しても、1つのEvent IDしか再生されませんでした。
  • WG-39012: AkWwisePostImportCallbackSetup.ClearConsole() を削除しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2018.1.0.6714.1154

リリースノート - Wwise Unityインテグレーション 2018.1.0.6714.1154

このリリースはWwise 2018.1.0向けWwise SDKアップデートを提供します。

  • 新機能2018.1

互換性：

  • Wwise SDK: 2018.1.0
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2 (PersonalまたはPro)。
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
Android iOS Linux Mac PS4 tvOS UWP (ユニバーサル Windows プラットフォーム) Windows Xbox One | Unity 2018.1.0f2
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity 2018.1.0b12-MLTP5と、ML SDK 0.14.0)
Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-30965: COMMのinit設定を、C::バインディングに公開しました。
  • WG-32316: Xbox OneのAPUメモリヒープサイズを公開しました。
  • WG-36375: すべての初期化設定をUnity UIに公開しました。
  • WG-36993: アレイ内のWwise Typesの設定をフィックスしました。
  • WG-37127: Roomトーン用の新Spatial Audio Room APIのサポートを追加しました。
  • WG-37514: UnityにWAAPIのサポートを追加しました。


Wwise Unity Integration Documentation: 新機能2018.1

新機能2018.1

Wwise 2018.1と、そのUnityインテグレーションには、いくつかの重要な新機能があります。ここで、その一部を紹介します：

  • Profilerで使うコミュニケーション設定が、Unity Editorに公開されました。
  • APUヒープサイズが、Unityインテグレーションから設定できるようになりました。
  • 新しく追加されたC# WAAPI Clientクラスのおかげで、Wwise AuthoringツールとWAAPI経由で通信するためのスクリプトを、ユーザー自身が書けます。
  • 様々なメモリプールサイズを定義するWwiseの初期化設定を、プラットフォームごとに、Unity Editorから定義できるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.9.6726.1210

リリースノート - Wwise Unityインテグレーション 2017.2.9.6726.1210

このリリースはWwise 2017.2.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK：2017.2.9
  • Unity: Unity 5.6, 2017.4, 2018.1, 2018.2, 2018.3 (PersonalまたはPro).
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
プラットフォーム： | Wwise Unityインテグレーションテストに使用：
iOS Mac tvOS Windows | Unity 2018.3.0f2
Android Linux PS4 UWP (ユニバーサル Windows プラットフォーム) Xbox One | Unity 2018.2.16f1
Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity-2018.1.9f1-MLTP9.6と、ML SDK 0.18.0)
Switch | Nintendo Switch 2018.2.16f1用Unityと、NintendoSDK 6.4.0

Resolved Issues:

  • WG-39412 AkAmbient ツールバーが、Hi DPIディスプレイで表示されない問題を解決しました。
  • WG-39444 AkExternalSourceInfo ファイル名の文字列エンコードを解決しました。
  • WG-39849 AkSoundEngine.PrepareEvent()やAksoundEngine.PrepareGameSync()を、文字列の配列でコールするときの、ヒープコラプションを解決しました。
  • WG-39990 Android ARM64のサポートを追加しました。
  • WG-40006 プラグインのコンフィギュレーション変更を確認するメッセージを追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.8.6698.1171

リリースノート - Wwise Unityインテグレーション 2017.2.8.6698.1171

このリリースはWwise 2017.2.8向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.8
  • Unity：Unity 5.6、2017.1、2017.2、2017.3、2017.4、2018.1、2018.2 (PersonalまたはPro)｡
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Xbox One
    Mac
    Windows     		Unity 2018.2.5f1
    Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity 2018.1.0b12-MLTP5と、ML SDK 0.14.0)
    Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-38413 修正済み: Editorを一時停止してから再生モードに入ると、Unityがフリーズしました。
  • WG-39195 修正済み: 値が一貫している場合の、エディターのリスナーポジションやオリエンテーションのスパミング。
  • WG-39201 Add ComponentボタンでAkBankコンポーネントを追加するときのエラーメッセージを削除しました。
  • WG-39235 サウンドエンジンが初期化済みのときの、ログメッセージを追加しました。
  • WG-39307 減衰半球の見え方を、透明度90にしました。
  • WG-39388 修正済み: Ak Initializerの設定がプロジェクトをリロードすると継続されませんでした


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.7.6661.1133

リリースノート - Wwise Unityインテグレーション 2017.2.7.6661.1133

このリリースはWwise 2017.2.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.7
  • Unity：Unity 5.6、2017.1、2017.2、2017.3、2017.4、2018.1、2018.2 (PersonalまたはPro)｡
    注記： 需要な注意点: このインテグレーションはUnity4に対応していません。上記以外のUnityのバージョンとの互換性は、保証されません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 2018.1.5
    Mac
    Windows     		Unity 2018.2.2f1
    Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity 2018.1.0b12-MLTP5と、ML SDK 0.14.0)
    Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-35762: 修正済み: 複数のAk Objectsを選択して再生しても、1つのEvent IDしか再生されませんでした。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.6.6636.1107

リリースノート - Wwise Unityインテグレーション 2017.2.6.6636.1107

このリリースはWwise 2017.2.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.6
  • Unity：Unity 5.6、2017.1、2017.2、2017.3、2017.4、2018.1 (PersonalまたはPro)｡
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity 2018.1.0b12-MLTP5と、ML SDK 0.14.0)
    Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-36351: 修正済み: SpatialAudioTutorial Unityシーンの AkRoomPortal コンポーネントのBakerウィンドウが、エラーを出します。
  • WG-38246: 修正済み: InspectorウィンドウにあるWwiseTypesのリストを使うと、リストの正しい項目が設定されます。
  • WG-38247: 修正済み: Inspector以外のウィンドウにWwiseTypeを表示しても、exception（例外）が出されなくなりました。
  • WG-38312: 修正済み: Save Decoded Bank機能が、元のSoundBankを上書きしなくなりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.5.6619.1090

リリースノート - Wwise Unityインテグレーション 2017.2.5.6619.1090

このリリースはWwise 2017.2.5向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.5
  • Unity：Unity 5.6、2017.1、2017.2、2017.3、2017.4、2018.1 (PersonalまたはPro)｡
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Magic Leapテクニカルプレビュー用Unity (Unity 2018.1.0b12-MLTP5と、ML SDK 0.14.0)
    Switch | Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-37187: EditorでWwiseGlobalオブジェクトを削除したときの、サウンドエンジンの再アクティベーションをフィックスしました。
  • WG-37767: ビルド後のゲームで、 OnApllicationPause() と OnApplicationFocus() のコールバック経由のサウンドエンジンのPause/Resumeステートをフィックスしました。
  • WG-37836: Xbox One PDBファイル名が、確実にDLLファイル名に対応するようにしました。
  • WG-38027: Unity 2018.1でWwiseのタイプやコンポーネントのインスペクタをフィックスしました。
  • WG-38191: Magic Leapプラットフォームのサポートを実験的に追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1064

リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1064

このリリースはUnity 2018.1との互換性を提供します。

互換性：

  • Wwise SDK: 2017.2.4
  • Unity：Unity 5.6、2017.1、2017.2、2017.3、2017.4、2018.1 (PersonalまたはPro)｡
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1054

リリースノート - Wwise Unityインテグレーション 2017.2.4.6590.1054

このリリースはWwise 2017.2.4向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.4
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3、2017.4 (PersonalまたはPro)｡
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.3.6575.1037

リリースノート - Wwise Unityインテグレーション 2017.2.3.6575.1037

このリリースはWwise 2017.2.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.3
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (ユニバーサル Windows プラットフォーム) | Unity 2017.3.0p3
    Switch | Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

解決済みの問題:

  • WG-36615: Editorに接続中にゲームオブジェクト名がIDとして表示されるのをフィックスしました。
  • WG-36636: Editorやゲームの AkInitializer 関連問題をフィックスしました。
  • WG-36817: Editorでシーンを再生・停止するときに、デフォルトのリスナーゲームオブジェクトの登録で発生する問題をフィックスしました。
  • WG-36829: AkWwisePostImportCallbackSetup.csでダーティーとしてマークされないシーンをフィックスしました。
  • WG-36867: AkGameObj と、 AkAudioListener 初期化の、循環依存をフィックスしました。
  • WG-36952: MSSpatialプラグインのアクティブ化をフィックスしました。
  • WG-37021: EditorのStreamingAssetsフォルダからの、サウンドバンクのロードをフィックスしました。
  • WG-37061: Switch、iOS、またはtvOSに向けて初めてデプロイするときの障害をフィックスしました。
  • WG-37065: ゲームをストップする際にUnity Editorのクラッシュを引き起こす可能性がある、WwiseのAK::SoundEngine::Termのクラッシュの可能性を、フィックスしました。
  • WG-37122: 1つのAkEnvironmentPortal内で移動する際の、Aux sendのアップデートをフィックスしました。
  • WG-37171: Unity 5.5のAkAmbientInspector.csの、コンパイルエラーをフィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.2.6553.1015

リリースノート - Wwise Unityインテグレーション 2017.2.2.6553.1015

このリリースはWwise 2017.2.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.2.2
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (ユニバーサル Windows プラットフォーム) | Unity 2017.3.0p3
    Switch | Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

解決済みの問題:

  • WG-26533: Wwiseピッカーで展開された項目を保存する際に、必要な場合に限りプロジェクトをダーティーに設定します。
  • WG-33976: UWPでWwiseのコミュニケーションを有効にするために、メニューアイテムを追加しました。詳細は pg_WindowsInfo を参照してください。
  • WG-36296: AkSoundEngine.AddListener と AkSoundEngine.AddDefaultListener の機能の使用。
  • WG-36434: インテグレーションで使用されるすべてのタイプ名を完全修飾名（fully qualified names）としました。
  • WG-36499: AkSoundEngine.dllロード前の、Unityインストールに関する問題をフィックスしました。
  • WG-36584: AkSoundEngine のドキュメントを追加して、API/Handwritten and Componentsフォルダの様々なクラスのドキュメントを修正しました。
  • WG-36827: AkInitializerの再初期化と、SoundBanksのアンロードを、フィックスしました。
  • WG-36848: AkRoomPortalsが、トリガーコライダー付きのAkRoomコンポーネントを検知しないことを、フィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.1.6524.980

リリースノート - Wwise Unityインテグレーション 2017.2.1.6524.980

このリリースはWwise 2017.2.1向けWwise SDKアップデートを提供します。Wwise Unityインテグレーションのドキュメンテーションが、中国語に翻訳されました。

互換性：

  • Wwise SDK: 2017.2.1
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (ユニバーサル Windows プラットフォーム) | Unity 2017.3.0p3
    Switch | Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

解決済みの問題:

  • WG-34267: Wwise_IDs.csのメンバーをAK名前空間に入れ、クラス名に"Ak"のプレフィックスをつけました。
  • WG-35301: Eventセレクタを変更して、Timelineトラックに AkEventSection が追加されたときに、自動的にインスペクタに表示されるようにしました。
  • WG-35609: AkRoomPortal インスペクタが、リアルタイムでフロントルームとバックルームをアップデートするようにしました。
  • WG-36086: AkRoomPortal に、フロントルームとバックルームをアップデートする公開ファンクションを追加しました。
  • WG-36099: 2016.2.4から移行するときの NullReferenceException を、フィックスしました。
  • WG-36125: Unity 5.5との互換性をフィックスしました。
  • WG-36144: Wwise C::スクリプトで System.IO.Path を完全に指定して、コンフリクトの可能性を回避しました。
  • WG-36219: Unity 2017.3のWwise Pickerからのドラッグ＆ドロップを、フィックスしました。
  • WG-36356: AkInitializerインスペクタで、モニタリングプールサイズとキューサイズを公開しました。
  • WG-36413: あるルームから別のルームへのポータルが、2つ以上ある場合のクラッシュをフィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.2.0.6500.947

リリースノート - Wwise Unityインテグレーション 2017.2.0.6500.947

このリリースはWwise 2017.2.0向けWwise SDKアップデートと、Unity 2017.3との互換性を提供します。

  • 新機能2017.2
  • 重要な移行の注意 2017.2

互換性：

  • Wwise SDK: 2017.2.0
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Mac
    Windows
            Unity 2017.3.0f3
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 2017.2.0f3
    Switch Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

新機能:

  • 新機能2017.2 のページに記載の通り、いくつかの新機能を追加しました。

移行ノート

  • 破壊的な変更（breaking changes）を行い、ほかのソフトウェアパッケージと名前の衝突が起きないようにしました。詳細は、 重要な移行の注意 2017.2 のページを参照してください。

解決済みの問題:

  • WG-25994: オーディオ入力プラグインが、C::スクリプト経由でアクセスできるようになりました。詳細は UnityでAudio Input Sourceプラグインを使う を参照。
  • WG-27337: サウンドエンジンに対してMIDIイベントをポストする機能を追加しました。詳細は MIDIをWwiseに送る を参照。
  • WG-28541: Akのプレフィックスがない列挙に、ネームスペースを追加しました。生成された全てのクラスに、Akプレフィックスを追加しました。
  • WG-33501: SoundBankの自動管理機能が追加されました。
  • WG-34446: AkCallbackManagerのメモリアロケーションを削減しました。


Wwise Unity Integration Documentation: 新機能2017.2

新機能2017.2

Wwise 2017.2と、そのUnityインテグレーションには、いくつかの重要な新機能があります。ここで、その一部を紹介します：

  • Edit Modeのサポート
    • Editモードでバンクをロード・アンロードする
  • WwiseGlobalゲームオブジェクトへの追加
  • Wwise Audio Inputプラグイン
  • MIDIイベント
  • Automatic SoundBank Management

Edit Modeのサポート

Wwiseサウンドエンジンが、UnityのEditモード中に初期化されるようになりました。これで、Playモードに入らずにエディタからWwiseイベントをトリガーできるようになりました。これをデモできるように、AkEvent (そして AkAmbient ) のインスペクタがアップデートされました。インスペクタに追加されたボタンで、エディタから直接イベントを再生したり停止したりできます。Play/Stopボタンで、個々のイベントを再生したり停止したりできます。AkEventsのあるオブジェクトを複数、選択中の場合は、Play MultipleボタンとStop Multipleボタンで、選択中の全てのイベントを再生したり停止したりできます。Stop Allボタンで、再生中の全てのイベントを停止できます。

Editモードでバンクをロード・アンロードする

Editモード機能が正しく作動するためには、対応する AkBank コンポーネントのLoad On:プロパティをAwakeに、Unload On:プロパティをNeverに設定します。

WwiseGlobalゲームオブジェクトへの追加

WwiseGlobalゲームオブジェクトに、AkEditorEventPlayerコンポーネントが追加されました。このコンポーネントはエディタの機能のみで、Editモードで AkEvent コンポーネントに関連するWwiseEventsを再生するために使います。また、WwiseGlobalオブジェクトに、 Rigidbody、 AkGameObj、 AkAudioListener の各コンポーネントも追加されました。これらは、Editモードで AkEnvironment、 AkGameObj、 AkRoom の各コンポーネント間のやり取りに使います。Unity Projectに対する変更 を参照してください。

Wwise Audio Inputプラグイン

Wwise Audio Inputソースプラグインが、C::スクリプト経由でアクセスできるようになりました。詳細は UnityでAudio Input Sourceプラグインを使う を参照。

MIDIイベント

WwiseにMIDIイベントを、C::スクリプト経由でポストできるようになりました。詳細は MIDIをWwiseに送る を参照。

Automatic SoundBank Management

SoundBankの自動管理機能が追加されました。詳細は 1つのプラットフォームのプロジェクトでSoundBankをデプロイする と マルチプラットフォームのプロジェクトでSoundBankをデプロイする を参照。

Spatial Audioインテグレーション

UnityインテグレーションにスペーシャルオーディオAPIを追加しました。チュートリアルは、 トラブルシューティング を参照してください。


Wwise Unity Integration Documentation: 重要な移行の注意 2017.2

重要な移行の注意 2017.2

以下の列挙の名前が変更されました:

Pre-2017.2: | New in 2017.2:
ErrorCode | AK.Monitor.ErrorCode
ErrorLevel | AK.Monitor.ErrorLevel
DynamicSequenceType | AK.SoundEngine.DynamicSequence.DynamicSequenceType
MultiPositionType | AK.SoundEngine.MultiPositionType
PreparationType | AK.SoundEngine.PreparationType
RTPCValue_type | AK.SoundEngine.Query.RTPCValue_type

以下のクラスで名前が変更されました:

Pre-2017.2: | New in 2017.2:
Iterator | AkIterator
Playlist | AkPlaylist
PlaylistItem | AkPlaylistItem


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.9.6501.947

リリースノート - Wwise Unityインテグレーション 2017.1.9.6501.947

このリリースはWwise 2017.1.9向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.1.9
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3、2017.4、2018.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.8.6488.933

リリースノート - Wwise Unityインテグレーション 2017.1.8.6488.933

このリリースはWwise 2017.1.8向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.1.8
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3、2017.4、2018.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)

解決済みの問題:

  • WG-37836: Xbox One PDBファイル名が、確実にDLLファイル名に対応するようにしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.7.6467.910

リリースノート - Wwise Unityインテグレーション 2017.1.7.6467.910

このリリースはWwise 2017.1.7向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.1.7
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3、2017.4 (PersonalまたはPro)｡
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Nintendo Switch 4.1.0用Unity (Unity 2017.4.0f1と、NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.6.6446.890

リリースノート - Wwise Unityインテグレーション 2017.1.6.6446.890

このリリースはWwise 2017.1.6向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.1.6
  • Unity：Unity 5.5、5.6、2017.1、2017.2、2017.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (ユニバーサル Windows プラットフォーム) | Unity 2017.3.0p3
    Switch | Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.5.6429.870

リリースノート - Wwise Unityインテグレーション 2017.1.5.6429.870

互換性：

  • Wwise SDK: 2017.1.5
  • Unity：Unity 5.5、5.6、2017.1、2017.2 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (ユニバーサル Windows プラットフォーム) | Unity 2017.3.0p3
    Switch | Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

解決済みの問題:

  • WG-33289: SWIGを3.0.12に更新。
  • WG-36079: AddSecondaryOutputを、復活させました。
  • WG-36219: Unity 2017.3のWwise Pickerからのドラッグ＆ドロップを、フィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.4.6407.845

リリースノート - Wwise Unityインテグレーション 2017.1.4.6407.845

互換性：

  • Wwise SDK: 2017.1.4
  • Unity：Unity 5.5、5.6、2017.1、2017.2 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 2017.2.0f3
    Switch Nintendo Switch 3.1.2用Unity (Unity 5.6.4と、NintendoSDK 3.5.2)

解決済みの問題:

  • WG-35168: Switchでサウンドバンクをロードする時に発生するクラッシュを、フィックスしました。
  • WG-35383: カスタマイズされたインスペクタ内でプロパティとして使うWwiseTypesの、関連するIDのアップデートを修正しました。
  • WG-35384: AkAudioListener、 AkInitializer、 AkTerminator が、 Awake() よりも OnEnable() を実装するので、Editorでチェックされていない場合は無効にします。
  • WG-35513: AkGameObjに、完全なカスタムポジショニングを追加しました。
  • WG-35958: Unity 2017.3のサポートを追加しました。なおこのインテグレーションは、Unity 2017.3で全てをテストしていませんが、互換性があると考えられます。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.3.6377.812

リリースノート - Wwise Unityインテグレーション 2017.1.3.6377.812

このリリースはWwise 2017.1.3向けWwise SDKアップデートと、Unity 2017.1との互換性を提供します。

互換性：

  • Wwise SDK: 2017.1.3
  • Unity：Unity 5.5、5.6、2017.1、2017.2 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity　2017.2.0f3
    Switch Switch 1.0.1 用Unity (Unity 5.5.0p1 with Nintendo SDK 1.4.0)

解決済みの問題:

  • WG-34855: AkSoundEngine.GetCurrentLanguage()を追加しました。
  • WG-35075: 修正済み: Unity 2017.2インテグレーションのサポートをAudiokinetic Launcherに追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.2.6361.791

リリースノート - Wwise Unityインテグレーション 2017.1.2.6361.791

このリリースはWwise 2017.1.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2017.1.2
  • Unity: Unity 2017.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Windows
    Xbox One     		Unity 5.6.1p1
    Switch Switch 1.0.1 用Unity (Unity 5.5.0p1と、Nintendo SDK 1.4.0)


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.1.6340.770

リリースノート - Wwise Unityインテグレーション 2017.1.1.6340.770

このリリースはWwise 2017.1.1向けWwise SDKアップデートと、Unity 2017.1との互換性を提供します。

互換性：

  • Wwise SDK: 2017.1.1
  • Unity: Unity 2017.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.6.1p1
    Switch Switch 1.0.1 用Unity (Unity 5.5.0p1と、Nintendo SDK 1.4.0)

解決済みの問題:

  • WG-33018: 修正済み: Decode Banks機能を使う時に、ローカリゼーションフォルダが作成されません。
  • WG-33818: iOSとAndroidで、バンクデコーディングを修正しました。
  • WG-34090：WSA Unity PluginへのTLS Allocator Errorスパミングを解決しました。
  • WG-34188: System.EventHandlerを完全修飾名（fully qualified name)として、同名による衝突を回避しました。
  • WG-34205: UnityEditor.Menuと、UnityEditor.MenuItemを、完全修飾名（fully qualified name)として、同名による衝突を回避しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2017.1.0.6302.726

リリースノート - Wwise Unityインテグレーション 2017.1.0.6302.726

このリリースはWwise 2017.1.0向けWwise SDKアップデートと、Unity 2017.1との互換性を提供します。

  • 新機能2017.1
  • 重要な移行の注意 2017.1

互換性：

  • Wwise SDK: 2017.1.0
  • Unity: Unity 2017.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.6.1p1
    Switch Switch 1.0.1 用Unity (Unity 5.5.0p1と、Nintendo SDK 1.4.0)

新機能:

  • 新機能2017.1 のページに記載の通り、いくつかの新機能を追加しました。

移行ノート

  • Wii Uプラットフォームのサポートを終了しました。
  • GameObjectの自動登録を含む機能が、UnityインテグレーションExtensionsに移動しました。この変更内容の詳細は、Wwise Installation and Migration Guideを参照してください。
  • AkCallbackManagerの破壊的変更が数件あり、詳細は 重要な移行の注意 2017.1 ページに記載されています。

解決済みの問題:

  • WG-27479: コールバックのバッファサイズがAkInitializerで設定できるようになりました。
  • WG-30791: WwiseTypesを追加しました。詳細は Wwise Types を参照。
  • WG-31155： AkMemSettings と AkChannelConfig をフィックスして、これらのメソッドがSoundEngineの初期化をチェックしないようにしました。
  • WG-31735： ユーザーが簡単にGameObjectの自動登録を拡張したり削除したりできるように、フックを追加しました。詳細は Unityインテグレーションの拡張 を参照。
  • WG-32348：SoundBanksInfoファイルのXMLパーシングをフィックスしました。
  • WG-32657：コールバッククラスを使用する時のメモリアロケーションを減らし、 foreach ステートメントを削除しました。
  • WG-33303：AK_MusicPlaylistSelectのサポートを追加しました。
  • WG-34003: インストール方法は、プロジェクト内の他のネイティブプラグインをもはや非アクティブ化しません。


Wwise Unity Integration Documentation: 新機能2017.1

新機能2017.1

Wwise 2017.1と、そのUnityインテグレーションには、いくつかの重要な新機能があります。ここで、その一部を紹介します：

  • 必須コンポーネント
  • WwiseTypes
  • Unityインテグレーション Extensions
  • 3Dバス

必須コンポーネント

[RequireComponent(typeof(AkGameObj))] が、AkEventに追加されました。

AkEnvironment と、 AkEnvironmentPortal は、必須コンポーネントとして Rigidbody を指定せず、 Rigidbody のメンバーは、もう修正されません。もし、 AkEnvironment や AkEnvironmentPortalno のゲームオブジェクトに Rigidbody が添付されていなければ、あるいは AkGameObj が"Environment aware"に設定されていて、ゲームオブジェクトに Rigidbody が添付されていなければ、Editorに次の警告が表示されます: AkGameObj-AkEnvironment interactions require a Rigidbody component on the object or the environment.（AkGameObj-AkEnvironmentのやり取りには、オブジェクトまたは環境のRigidbodyコンポーネントが必要）

上記警告の全てのインスタンスを削除するには、WwiseのSettingsウィンドウで、Show Warning for Missing RigidBodyオプションのチェックを外します。

WwiseTypes

新しい"WwiseTypes"が追加され、Wwiseオブジェクトが表すEvent、ゲームパラメータ、Switches、Statesなどの微調整が可能になりました。新しいクラスはそれぞれのプロパティがあり、クリックするとWwiseピッカーが表示されるので、ゲームのオーディオシステムを素早くプロトタイプ化できるようになりました。

以下は簡単なユースケースの例です:

public class Footsteps : MonoBehaviour
{
[Header("Wwise Types")]
public AK.Wwise.Event FootStepEvent = null;
public AK.Wwise.RTPC SpeedRTPC = null;
public AK.Wwise.Switch UnderFootMaterialSwitch = null;
public AK.Wwise.Bank FootStepBank = null;
void InitializeSound() { FootStepBank.Load(); }
void FinalizeSound() { FootStepBank.Unload(); }
void PlayFootStepSound(float speed)
{
SpeedRTPC.SetValue(gameObject, speed);
UnderFootMaterialSwitch.SetValue(gameObject);
FootStepEvent.Post(gameObject);
}
}

Unityインテグレーション Extensions

AkSoundEngine は、パーシャルクラスになりました。ユーザーがゲームオブジェクトの自動登録を拡張したり、この機能を完全に削除したりするための、フックが追加されました。拡張は推奨されますが WwiseをUnityプロジェクトにインテグレートする 時にこれらを除外することができます。

3Dバス

Wwiseに追加された3Dバス機能を補完する形で、以下の修正が行われました。リスナー数の制限がなくなり、また、全てのゲームオブジェクトに関して、作成当初に設定されていた様々なリスナーが分かるように、デフォルトリスナーという概念が追加されました。AkGameObj は、AkAudioListenerのリストを保持できるように修正されました。デフォルトで、 AkGameObj は音をデフォルトのリスナーに対して出し、 AkAudioListener はデフォルトのリスナーです。

AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29


Wwise Unity Integration Documentation: 重要な移行の注意 2017.1

重要な移行の注意 2017.1

以下の破壊的変更が、AkCallbackManagerで実施されました。

  • AkCallbackManager.AudioInterruptionCallback() の署名が新しくなりました：
    public delegate AKRESULT AudioInterruptionCallback(bool in_bEnterInterruption, object in_Cookie);
  • AkCallbackManager.BGMCallback() の署名が新しくなりました：
    public delegate AKRESULT BGMCallback(bool in_bOtherAudioPlaying, object in_Cookie);
  • AkCallbackManager.EventCallback() の署名が新しくなりました：
    public delegate void EventCallback(object in_cookie, AkCallbackType in_type, AkCallbackInfo in_info);
  • コールバッククラスは、 AkCallbackManager 内にネスト化されなくなり、その階層はAkCallbackInfoから多くを受け継いでいます。これらクラスの相互関係やクラスのメンバーは、C++の同等のものを、できるだけ模倣します。
  • コールバッククラスの gameObjID メンバーのタイプが ulong となり、IntPtrではなくなりました。
  • クラス AkCallbackManager.AkMidiEventCallbackInfo は、現在はAkMIDIEventCallbackInfoです。（"MIDI"の大文字記載に注目してください。）
  • クラスAkCallbackManager.AkMusicSyncCallbackInfoBaseは、削除されました。代わりに、 AkMusicSyncCallbackInfo を使ってください。
  • AkCallbackManager.AkMusicSyncCallbackInfo.segmentInfoの全てのメンバーが、AkMusicSyncCallbackInfo.segmentInfo_*のメンバーとして公開されました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.6.6153.595

リリースノート - Wwise Unityインテグレーション 2016.2.6.6153.595

このリリースはWwise 2016.2.6向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.2.6
  • Unity: Unity 2017.2 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 2017.2.0f3
    Switch | Switch 3.1.2用Unity (Unity 5.6.4p1と、NintendoSDK 3.5.2)
    Wii U | Unity 5.4.2f2
    解決済みの問題：
  • WG-35075: 修正済み: Unity 2017.2インテグレーションのサポートをAudiokinetic Launcherに追加しました。
  • WG-35168: Switchでサウンドバンクをロードする時に発生するクラッシュを、フィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.5.6121.560

リリースノート - Wwise Unityインテグレーション 2016.2.5.6121.560

このリリースはWwise 2016.2.5向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.2.5
  • Unity: Unity 2017.1 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 2017.1.0f3
    Switch | Switch 1.0.1用Unity (Unity 5.5.0p1と、NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    解決済みの問題：
  • WG-33687: Nintendo Switchの不足しているインターナルプラグインのヘッダーを追加しました。
  • WG-34003: インストール方法は、プロジェクト内の他のネイティブプラグインをもはや非アクティブ化しません。
  • WG-34090：WSA Unity PluginへのTLS Allocator Errorスパミングを解決しました。
  • WG-34216: Unity 2017.1へのアップデートに関連するコンパイルエラーを修正しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.4.6098.531

リリースノート - Wwise Unityインテグレーション 2016.2.4.6098.531

このリリースはWwise 2016.2.4向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.2.4
  • Unity: Unity 5.6 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.6.1p1
    Switch | Switch 1.0.1用Unity (Unity 5.5.0p1と、NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    解決済みの問題：
  • WG-33395: 競合の可能性のあるクラス名の周りに、ネームスペースを追加しました


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.3.6077.504

リリースノート - Wwise Unityインテグレーション 2016.2.3.6077.504

このリリースはWwise 2016.2.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.2.3
  • Unity: Unity 5.6 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.6.0f3
    Switch | Switch 0.6.1用Unity
    Wii U | Unity 5.4.2f2

解決済みの問題:

  • WG-32536: Nintendo Switchのサポートを追加しました。
  • WG-32623: Androidでミュージックのカスタムキューのクラッシュをフィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.2.6022.430

リリースノート - Wwise Unityインテグレーション 2016.2.2.6022.430

このリリースはWwise 2016.2.2向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.2.2
  • Unity: Unity 5.5 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.5.0p4
    Wii U Unity 5.4.2f2

解決済みの問題:

  • WG-31862: イベントコールバックに関連しないenum値をイベントコールバックリストから削除しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.1.5995.409

リリースノート - Wwise Unityインテグレーション 2016.2.1.5995.409

このリリースはWwise 2016.2.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

解決済みの問題:

  • WG-32006: GameObjectのポジションを設定する時のエラー"Unknown Game Object ID"をフィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.1

リリースノート - Wwise Unityインテグレーション 2016.2.1

このリリースはWwise 2016.2.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

解決済みの問題:

  • WG-27085: AuxSendsによるアロケーションを削減しました。
  • WG-31127: AK_MusicSyncUserCueの返信ユーザーキューネームをフィックスしました。
  • WG-31650: SoundEngineが初期化されていない時の、AkGameObjのFixed NullReferenceExceptionをフィックスしました。
  • WG-31651: SetObjectPositionをコールする時に、AkGameObjが自動的に作成されるのを回避しました。
  • WG-31862: イベントコールバックに関連しないenum値をイベントコールバックリストから削除しました。

既知の不具合

  • Unity case #861189: Unity Windows Storeプレイバックエンジンがインストールされていると、Launcherからのインストールが失敗します。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.2.0

リリースノート - Wwise Unityインテグレーション 2016.2.0

このリリースはWwise 2016.2.0向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.2.0
  • Unity: Unity 5.4 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (ユニバーサル Windows プラットフォーム)
    Xbox One     		Unity 5.4.1p2
    Wii U Unity 5.2.4f1

移行ノート

  • Windows Phone 8.1、Windows Store 8.0、同8.1の3つのプラットフォームのサポートを非推奨としました。これで、サポートされるWindows Storeプラットフォームは、ユニバーサル Windows プラットフォーム (UWP) のみとなりました。
  • Xbox 360 プラットフォームのサポートを終了しました。
  • PS3 プラットフォームのサポートを終了しました。

解決済みの問題:

  • WG-30571: Libraryフォルダを再ビルドしても、Wwise Unityインテグレーションがあるプラットフォーム用にインストールされていないというエラーメッセージが表示されなくなりました。
  • WG-30960: AkGameObjにポジションオフセットを適用すると、Unityのダーティシステムにも反映されるようになりました。
  • WG-31507: Duration（持続時間）コールバックに、MediaIDとbStreamingを追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.6

リリースノート - Wwise Unityインテグレーション 2016.1.6

このリリースはWwise 2016.1.6向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.1.6
  • Unity: Unity 5.5 (PersonalまたはPro)
    注記： 重要な注意: Integration Unity 4の公式なサポートはしていません。 まだ動作する可能性はありますが、Unity 4用のWwise Integration Unityのこのバージョン、または今後のバージョンのテストは行いません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0p4
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-32006: GameObjectのポジションを設定する時のエラー"Unknown Game Object ID"をフィックスしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.5

リリースノート - Wwise Unityインテグレーション 2016.1.5

このリリースはWwise 2016.1.5向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.1.5
  • Unity: Unity 5.5 (PersonalまたはPro)
    注記： 重要な注意: Integration Unity 4の公式なサポートはしていません。 まだ動作する可能性はありますが、Unity 4用のWwise Integration Unityのこのバージョン、または今後のバージョンのテストは行いません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0f3
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.4

リリースノート - Wwise Unityインテグレーション 2016.1.4

このリリースはWwise 2016.1.4向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.1.4
  • Unity: Unity 5.4 (PersonalまたはPro)
    注記： 重要な注意: Integration Unity 4の公式なサポートはしていません。 まだ動作する可能性はありますが、Unity 4用のWwise Integration Unityのこのバージョン、または今後のバージョンのテストは行いません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-31507: Duration（持続時間）コールバックに、 MediaID と bStreaming を追加しました。
  • WG-31650: サウンドエンジンを初期化していないときの、 AkGameObj のNullReferenceException を修正しました。
  • WG-31651: SetObjectPosition() をコールしたときに AkGameObj が自動的に作成されるのを、バイパスさせました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.3

リリースノート - Wwise Unityインテグレーション 2016.1.3

このリリースはWwise 2016.2.3向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2016.1.3
  • Unity: Unity 5.4 (PersonalまたはPro)
    注記： 重要な注意: Integration Unity 4の公式なサポートはしていません。 まだ動作する可能性はありますが、Unity 4用のWwise Integration Unityのこのバージョン、または今後のバージョンのテストは行いません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.2

リリースノート - Wwise Unityインテグレーション 2016.1.2

このリリースはWwise 2016.1.2向けWwise SDKアップデートを提供します。Wwise Unityインテグレーションのドキュメンテーションが、日本語に翻訳されました。

互換性：

  • Wwise SDK: 2016.1.2
  • Unity: Unity 5.4 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-30567 Fixed: 空ラベルのあるWAVマーカーを使うと発生するクラッシュ。

移行ノート

  • 今まで提供されていたSWIGソースが、ソースzipファイルに含まれません。提供されるzipソースにインテグレーションパッケージをビルドするための必要ファイルと事前生成されたSWIGインターフェースが含まれるため、SWIGは不要です。
  • Wwise 2014.1.4以前を使ったプロジェクトを、直接2016.1にアップグレードすることはできません。最初にプロジェクトを2015.1.6にアップグレードしてから、2016.1にアップグレードしてください。
  • UnityプロジェクトUnity 5.4にアップデートする場合には、まずWwiseを 2016.1.2へ移行してください。 Unity 5.4でのある変更が古い統合を壊していますが、まずWwise 2016.1.2インテグレーションへ更新することで、これらの問題が解決します。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1.1

リリースノート - Wwise Unityインテグレーション 2016.1.1

このリリースはWwise 2016.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.1.1
  • Unity: Unity 5.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-30021: デコードされたSoundBankの再デコードが必要かどうか判定するのに、そのSoundBankが最後に変更された日付を使う。
  • WG-30228: Linuxインテグレーションをソースから再ビルドすることが可能になりました。
  • WG-30231: tvOSインテグレーションをソースから再ビルドすることが可能になりました。
  • WG-30259: GC.Collectをコールする時の AkGameObj 登録動作をフィックス。

既知の問題点:

  • WG-30128: Vitaプラットフォームで、デコードしたSoundBankをディスクに保存できません。
  • WG-30139: Wii Uプラットフォームで、デコードしたSoundBankをディスクに保存できません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2016.1

リリースノート - Wwise Unityインテグレーション 2016.1

このリリースはWwise 2016.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2016.1
  • Unity: Unity 5.3 (PersonalまたはPro)
    注記： 重要な注意点: このインテグレーションはUnity 4でテストされていません。
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p3
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-25675 フィックス済み: Wwiseプロジェクトの全プラットフォーム用のSoundBankを生成するために、Wwise Pickerに"Generate SoundBanks"ボタンを追加しました。
  • WG-27583 Fixed: Unityアセット内にあるSoundBankフォルダが自動管理されるようになり、Unityの現在のターゲットプラットフォームの、正しいSoundBankが指定されます。
  • WG-28175 フィックス済み: 新シーン作成時に、WwiseGlobalが自動的に作成されないことがありました。
  • WG-26011 フィックス済み: 新Scene作成後にAk Audio Listnerを再び有効にしても、Default Unity Audio Listenerが正しく破壊されませんでした。

移行ノート

  • 今まで提供されていたSWIGソースが、ソースzipファイルに含まれません。提供されるzipソースにインテグレーションパッケージをビルドするための必要ファイルと事前生成されたSWIGインターフェースが含まれるため、SWIGは不要です。
  • Wwise 2014.1.4以前を使ったプロジェクトを、直接2016.1にアップグレードすることはできません。最初にプロジェクトを2015.1.6にアップグレードしてから、2016.1にアップグレードしてください。

既知の問題点:

  • WG-30021: Editorでシーンのプレビューを行うと、DecodeBanks機能が無効になります。
  • WG-30021: DecodeBanks機能は、デコードされたSoundBankを自動的に削除しません。SoundBankをアップデートした場合は、対象デバイスのDecodedBanksフォルダが削除されるべきです。
  • WG-30128: Vitaプラットフォームで、デコードしたSoundBankをディスクに保存できません。
  • WG-30139: WiiUプラットフォームで、デコードしたSoundBankをディスクに保存できません


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.9

リリースノート - Wwise Unityインテグレーション 2015.1.9

このリリースはWwise 2015.1.9向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.9
  • Unity: Unity 4.6 Pro、またはUnity 5.3 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.8

リリースノート - Wwise Unityインテグレーション 2015.1.8

このリリースはWwise 2015.1.8向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.8
  • Unity: Unity 4.6 Pro、またはUnity 5.3 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

解決済みの問題:

  • WG-30259 修正済み: GC.Collectをコールする時の AkGameObj 登録動作をフィックス
  • WG-30422 修正済み: iOSアプリをApple TVに接続したときに、オーディオが消えなくなりました。
  • WG-30567 修正済み: ラベルが空白のWAVマーカを使ったときのクラッシュを、修正しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.7

リリースノート - Wwise Unityインテグレーション 2015.1.7

このリリースはWwise 2015.1.7向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.7
  • Unity: Unity 4.6 Pro、またはUnity 5.3 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p5
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

解決済みの問題:

  • WG-29521 修正済み: (iOS) FaceTimeの不在着信から戻ったときに、デッドロックが発生しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.6

リリースノート - Wwise Unityインテグレーション 2015.1.6

このリリースはWwise 2015.1.6向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.6
  • Unity: Unity 4.6 Pro、またはUnity 5.3 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.3p1
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

新機能

  • WG-23513 (Android) Unityで使用するOBBファイルを読むことができる、ローレベルI/Oを追加しました。

解決済みの問題:

  • WG-29405 修正済み: AkEnvironment Effectが、スポーンゾーンの環境外で継続されないようにしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.5

リリースノート - Wwise Unityインテグレーション 2015.1.5

このリリースはWwise 2015.1.5向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.5
  • Unity: Unity 4.6 Pro、またはUnity 5.3 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.1p3
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.3p3と、Wii Uアドオン3.0.1
    Xbox 360 | Unity 5.2.1f1

新機能

  • Wii UインテグレーションとUnity 5.2.3p3の互換性を確保しました。

解決済みの問題:

  • WG-27300 修正済み: Prepare Poolを公開し、 PrepareEvent() と、 PrepareBank() の使用を可能にしました。
  • WG-28716 修正済み: ソースパッケージとPython 3.4+の互換性を確保しました。
  • WG-28917 修正済み: Main Camera以外のGameObjectにマニュアル操作で追加した AkAudioListener を自動的に削除する機能を、無効にしました。
  • WG-28957 修正済み: Wwiseプロジェクトデータを取得するときの NullReferenceExceptions の原因を、排除しました。
  • WG-28975 修正済み: LoadBank() と、 UnLoadBank() の間の競争状態（race condition）を解消しました。

既知の問題点:

  • ProfilerをWindows Store Appsプラットフォームのゲームに接続できません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.4

リリースノート - Wwise Unityインテグレーション 2015.1.4

このリリースはWwise 2016.1向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2015.1.4
  • Unity: Unity 4.6 Pro、またはUnity 5.2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1と、Wii Uアドオン2.2.5
    Xbox 360 | Unity 5.0.1f1

新機能

  • Windows 10 Universal Appsのサポートを追加しました
  • Windows Store Apps SDK 8.1のサポートを追加しました

移行ノート

  • Windows Phone 8.0のサポートを取消しました
  • Windows Store Apps SDK 8.0のサポートを取消しました

解決済みの問題:

  • WG-28412 フィックス済み: AkGameObj ポジションのオフセットをPrefabで保存できるようになりました。
  • WG-28723 フィックス済み: ゲームをPS4パッケージとしてビルドできるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.3

リリースノート - Wwise Unityインテグレーション 2015.1.3

このリリースでWwise 2015.1.3向けにWwise SDKアップデートと、ユニバーサル Windows プラットフォームを提供します。

互換性：

  • Wwise SDK: 2015.1.3
  • Unity: Unity 4.6 Pro、またはUnity 5.2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store Apps
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1と、Wii Uアドオン2.2.5
    Xbox 360 | Unity 5.0.1f1

新機能:

  • ユニバーサル Windows プラットフォームのサポートをWindows Store Appsパッケージ下に追加しました。
  • Windows Store Apps SDK 8.1のサポートを追加しました。
  • Windows Phone 8.0のサポートを取消しました。
  • Windows Store Apps SDK 8.0のサポートを取消しました。

解決済みの問題:

  • WG-25945 フィックス済み: Wwiseエラーが常にUnityコンソールにリダイレクトされていました。WwiseGlobal設定に、WwiseエンジンのアウトプットをUnityコンソールで有効・無効にすメニュー項目を追加しました。
  • WG-26011 フィックス済み: 新Scene作成後にAk Audio Listnerを再び有効にしても、Default Unity Audio Listenerが正しく破壊されませんでした。
  • WG-28108 フィックス済み: Editorを一時停止した時に、サウンドの再生が続きました。今はEditorで一時停止するとサウンドを停止して、一時停止を解除するとサウンドを再生するようになりました。ウィンドウを切り替える時に、サウンドの再生が続きます（以前と同様）。
  • WG-28175 フィックス済み: 新シーン作成時に、WwiseGlobalが自動的に作成されないことがありました。
  • WG-28479 フィックス済み: Setupでチェックを外したオプションを追加しようとしました。Main Camera無しのプロジェクトにインテグレーションをインストールする時に、Setupが成功するようになりました。
  • WG-28526 フィックス済み: Unity Editorクラッシュの可能性。GameObjectsの登録や登録解除の前にSoundEngineが必ず初期化されるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.2

リリースノート - Wwise Unityインテグレーション 2015.1.2

このリリースはWwise 2016.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2015.1.2
  • Unity: Unity 4.6.5 Pro、またはUnity 5.1.2p2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.2.0f3
    Wii U | Unity 4.3.7f1と、Wii Uアドオン2.2.5
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-27029 フィックス済み: ディアクティベートしたUnity GameObjectが原因で、関連する AkGameObj が登録解除になるという稀なケースをフィックスしました。
  • WG-28200 フィックス済み: デフォルトのアクティブリスナーをEverythingに設定すると、(0, 0, 0)近辺のGameObjectの3Dポジショニングに影響していました。デフォルトのリスナーマスクをL0に設定して解決しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1.1

リリースノート - Wwise Unityインテグレーション 2015.1.1

このリリースはWwise 2015.1.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2015.1.1
  • Unity: Unity 4.6.5 Pro、またはUnity 5.1.2p2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    Wii U | Unity 4.3.7f1と、Wii Uアドオン2.2.5
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-27977 フィックス済み: スクリプトの順番が誤っている場合に、終了時にUnityがクラッシュします。
  • WG-28030 フィックス済み: Wii U/Unity: Release RPLに、TRCで規定されているNDEBUGタグ付けがされていなません。
  • WG-28042 フィックス済み: Unity: Wwiseプロジェクトにアクセスできないと、ゲームを実行できません。
  • WG-28044 フィックス済み: Unity: パフォーマンス問題、Wwiseプロジェクトが無限に再パースされます。
  • WG-28046 フィックス済み: ある AkInitializer インスタンスへの必須の依存を排除。
  • WG-28048 フィックス済み: Wwise ProfilerでGameObject名を正しく表示。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2015.1

リリースノート - Wwise Unityインテグレーション 2015.1

このリリースはWwise 2015.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2015.1

既知の問題点:

  • WG-25669: Wwise PickerのAuto PopulateがMac Editorで機能しません。

解決済みの問題:

  • WG-27079 Fixed: 英語以外のロケーション用にWwiseSettings.xmlファイルのエンコーディングを正しく設定しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.6

リリースノート - Wwise Unityインテグレーション 2014.1.6

このリリースはWwise 2014.1.6向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2014.1.6
  • Unity: Unity 4.6.5 Pro、またはUnity 5.0.2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    WiiU | Unity 4.3.7f1と、WiiUアドオン2.2.5
    Xbox 360 | Unity 5.0.1f1

解決済みの問題:

  • WG-27585 Fixed: Wwise PickerウィンドウでWwiseプロジェクト階層を正しく表示します。
  • WG-27624 Fixed: (PS3) SetListenerPostionがPS3で正しく作動しません
  • WG-27749 修正済み: オブジェクトのdestroy中にWwise APIをコールすると、多数のエラーがプリントされます。
  • WG-27977 フィックス済み: スクリプトの順番が誤っている場合に、終了時にUnityがクラッシュします。
  • WG-28030 フィックス済み: WiiU/Unity: Release RPLに、TRCで規定されているNDEBUGタグ付けがされていなません

既知のUnity問題点:

  • Xbox One: Unityオーディオを無効にしてもSoundEngine初期化が失敗します。ワークアラウンドは、 トラブルシューティング を参照してください。
  • Unity 4のWindows Store Apps: ビルドしたゲームが DllNotFoundException を出します。ワークアラウンドは、 トラブルシューティング を参照してください。

解決済みの問題:

  • WG-27585 Fixed: Wwise PickerウィンドウでWwiseプロジェクト階層を正しく表示します。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.5

リリースノート - Wwise Unityインテグレーション 2014.1.5

このリリースはWwise 2014.1.5向けWwise SDKアップデートを提供します。 互換性：

  • Wwise SDK: 2014.1.5
  • Unity: Unity 4.6.5 Pro、またはUnity 5.0.2 (Personal または Pro)
    プラットフォーム： Wwise Unityインテグレーションテストに使用：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone     		Unity 5.0.2p3
    Xbox 360 | Unity 5.0.1f1
    Xbox One | Unity 5.0.2p4

既知の問題点:

  • WG-25669 修正済み: Wwise PickerのAuto Populateが、Mac Editorで機能するようになりました。

既知のUnity問題点:

  • Xbox One: Unityオーディオを無効にしてもSoundEngine初期化が失敗します。ワークアラウンドは、 トラブルシューティング を参照してください。
  • Unity 4のWindows Store Apps: ビルドしたゲームが DllNotFoundException を出します。ワークアラウンドは、 トラブルシューティング を参照してください。

新機能:

  • Android x86のサポートを追加しました。
  • Windows Store AppsプラットフォームでScripting Define Symbolsが不要になりました。

解決済みの問題:

  • WG-25733 Fixed: Windowsエディタを使ったiOS/Macゲームのビルドと、その逆が新たに可能になりました。
  • WG-26655 iOS: 修正済み: AmbientSoundカテゴリにおいて、iOS 8の電話による中断のあとに、オーディオが復元されるようになりました。
  • WG-26875 Fixed: AkMemBankLoaderコンポーネントがアラインされたメモリを配分できるようになり、一部プラットフォームでの障害を防止します。
  • WG-27108 修正済み: Destroyフェーズ中にイベントをポストしたときの、Unityのエラーメッセージがなくなりました。
  • WG-27461 修正済み: AkEnvironment と同じオブジェクトに設定された AkGameObj が、environmentを入手できるようになりました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.4

リリースノート - Wwise Unityインテグレーション 2014.1.4

このリリースはWwise 2017.1.1向けWwise SDKアップデートと、Unity 2017.1との互換性を提供します。

互換性：

  • Wwise SDK: 2014.1.4
  • Unity: Unity 4 Pro、またはUnity 5 （PersonalまたはPro）

解決済みの問題:

  • WG-26780 Fixed: マシン上にWwiseプロジェクトがなくても、Unityコンソールウィンドウでエラーは発生しません。
  • WG-26837 Fixed: AkBankManagerで行うサウンドバンクレファレンスカウントを修正して、準備完了前のアンロードを防止します。

既知の問題点:

  • WG-25669: Wwise PickerのAuto PopulateがMac Editorで機能しません。
  • WG-25733: Windowsエディタを使ったiOS/Macゲームのビルドや、その逆ができません。

新機能:

  • Windows Phone 8.1プラットフォームのサポートを追加しました（ビルド設定のMetroプラットフォームからアクセス可能）。
  • Unity 5との完全互換性を確保しました。Wwise Unityインテグレーションが新しいPlugin Importer APIを使ってプラグインをアクティブにするようになりました。今までのインテグレーションで使われた<UNITY_PROJECT_ROOT>/Assets/Pluginsフォルダは、もう使われません。

– マイグレーションについて: Unity 4のプロジェクトをUnity 5にアップデートするための、推奨される方法:

  1. プロジェクトを確実にバックアップする
  2. Unity 4プロジェクトをUnity 5で開く。Unityアップグレードアシスタントが表示される。 – -# Unity 5へのアップグレードが完了したら、2014.1.4 Unityインテグレーションをインポートする
  3. マイグレーションウィンドウが表示されるので"Start"をクリックする
  4. マイグレーションウィンドウが閉じれば、マイグレーションが終了する
  5. Unity 5でWwise Unityインテグレーションを使う準備完了！


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.3

リリースノート - Wwise Unityインテグレーション 2014.1.3

このリリースはWwise 2014.1.3向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2014.1.3

既知の問題点:

  • WG-25669: Wwise PickerのAuto PopulateがMac Editorで機能しません。
  • WG-25733: Windowsエディタを使ったiOS/Macゲームのビルドや、その逆ができません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.2

リリースノート - Wwise Unityインテグレーション 2014.1.2

このリリースはWwise 2014.1.2向けWwise SDKアップデート、バグフィックス、各種改善を提供します。

互換性：

  • Wwise SDK: 2014.1.2
  • Unity Editor (October XDK) とWwise SDK (November XDK) のXDKの互換性がないため、このバージョンはXbox Oneプラットフォーム用に提供されません。

解決済みの問題:

  • WG-26305 Fixed: Nullゲームオブジェクトを使うと、64-bitビルドで無登録ゲームオブジェクトのレポートが出ます。
  • WG-26337 Fixed: Mac 64-bitプラットフォームとの互換性を追加しました。
  • WG-26385 Fixed: Androidでバックグランドにある時、WwiseはUnity内のCPUを取ります。
  • WG-26395 Fixed: MSBUILDを使ってコマンドラインからWindows Phone 8プロジェクトをビルドする時のビルドフェイルをフィックスしました。
  • WG-26430 Fixed: iOSでSetBasePath()をコールした時のクラッシュをフィックスしました。

既知の問題点:

  • WG-25669: Wwise PickerのAuto PopulateがMac Editorで機能しません。
  • WG-25733: Windowsエディタを使ったiOS/Macゲームのビルドや、その逆ができません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1.1

リリースノート - Wwise Unityインテグレーション 2014.1.1

このリリースは Wwise 2014.1.1向けWwise SDKアップデート、最新ドキュメンテーション、バグフィックスを提供します。

互換性：

  • Wwise SDK: 2014.1.1
  • Unity: 4.x （5.0は未対応）

新機能:

  • Wii Uプラットフォームのサポートを追加しました。
  • Plug-in Registrationドキュメンテーションを追加しました。
  • Unity "Wwise Settings"ダイアログでWwiseサウンドエンジンのバージョンを露出しました。
  • ドキュメンテーションをアップデートして、より正確なGeneratedSoundBanksやPopulateボタンの情報を追加。

解決済みの問題:

  • WG-26201: C# Systemコールのスコープを具体的にコールします


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2014.1

リリースノート - Wwise Unityインテグレーション 2014.1

このリリースはWwise 2014.1向けWwise SDKアップデート、バグフィックス、新しいデモシーン、2013.2 Wwise Unityインテグレーションで作成したプロジェクトのマイグレーションプロセスを提供します。

– 特記すべき内容：

  • 安定性のフィックス
  • デモシーンを追加しました
  • 2013.2 Wwise Unityインテグレーションで作成したプロジェクトのマイグレーションプロセスを追加しました。

互換性：

  • Wwise SDK: 2014.1
  • Unity: 4.x

– サポートするプラットフォーム：

  • Android
  • iOS
  • Linux*
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 以上)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新機能:

  • デモシーンを追加して、別パッケージとして提供しました。詳細は Wwiseデモシーン を参照。
  • 2013.2 Wwise Unityインテグレーションで作成したプロジェクトのマイグレーションプロセスを追加しました。
  • Wwiseコンポーネンツは、Wwise Unityインテグレーション内でUUIDで参照されるようになりました。これにより、Wwiseプロジェクトで名前を変更しても、Unityプロジェクトのリンクが維持されます。
  • イベントのポストやバンクのロード用に、カスタム化できる複数のトリガーを追加しました。詳細は Wwiseイベントのトリガーを追加する を参照。
  • Wwiseイベント用に、カスタム化できる複数のコールバックを追加しました。詳細は AkAmbient をInspectorで使う を参照。
  • AkSoundEngineプラグインサイズを小さくしました。
  • WwiseGlobalオブジェクトや AkListener を作成（または破壊）するオプションを追加しました

解決済みの問題:

  • WG-25783: Callback Managerのメモリリークをフィックスしました
  • WG-25677: Macのパス問題をフィックスしました

既知の問題点:

  • WG-25669: Wwise PickerのAuto PopulateがMac Editorで機能しません。
  • WG-25733: Windowsエディタを使ったiOS/Macゲームのビルドや、その逆ができません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.10

リリースノート - Wwise Unityインテグレーション 2013.2.10

このリリースはWwise 2013.2.10向けWwise SDKアップデート、バグフィックス、各種改善を提供します。

– 特記すべき内容：

  • WG-25783 修正済み: コールバックをキャンセルしたときのメモリリークを修正しました

互換性：

  • Wwise SDK: 2013.2.10
  • Unity: 4.x

– サポートするプラットフォーム：

  • Android
  • iOS
  • Linux*
    • 32bit
    • 64bit
  • Mac OS X (10.6 以上)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32bit
    • 64bit
  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows Phone 8.0
  • Xbox360
  • Xbox One


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.9

リリースノート - Wwise Unityインテグレーション 2013.2.9

このリリースはWwise 2013.2.9向けWwise SDKアップデート、最新ドキュメンテーション、バグフィックスを提供します。

– 特記すべき内容： – 特記すべき内容:

  • 安定性のフィックス

互換性：

  • Wwise SDK: 2013.2.9
  • Unity: 4.x

– サポートするプラットフォーム：

  • Android
  • iOS
  • Linux*
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 以上)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新機能:

  • Windows Phone 8.0プラットフォームのサポートを追加しました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.8

リリースノート - Wwise Unityインテグレーション 2013.2.8

このリリースは Wwise 2013.2.8向けWwise SDKアップデート、Wwise-Unityインテグレーションの新規ツール、追加ドキュメンテーション、バグフィックスを提供します。

– 特記すべき内容：

  • 新規プロジェクトのセットアップフローの簡略化（ Unityプロジェクトのインテグレーションの、インストールとアップグレード 参照）
  • Wwise Pickerを使ってWwiseプロジェクトへ簡単にアクセス（ Wwise Picker 参照）
  • 共通オーディオタスクをラップするためのUnityコンポーネンツの新規導入と改善（ Wwise Unityインテグレーションの使用 参照） このリリースはWwise 2015.1向けWwise SDKアップデートを提供します。

互換性：

  • Wwise SDK: 2013.2.8
  • Unity: 4.x

– サポートするプラットフォーム：

  • Android
  • iOS
  • Linux*
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 以上)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新機能:

  • Xbox Oneプラットフォームのサポートを追加しました。
  • PS4プラットフォームのサポートを追加しました。
  • Linuxプラットフォーム対応を追加しました。
    * Unity Integration for LinuxはWwise 2013.2.8 Linux BETAでサポートされています。
  • Windows Phone 8.0プラットフォームのサポートを追加しました。

移行内容：

  • マルチアーキテクチャWindowsやMetroのプラグインが各々の専用フォルダにインストールされるようになり、UnityのScripting Define Symbol機能を使って切り替える必要がなくなりました。
  • Integrationを再構築する機能をUnity Editorメニューから除き、シンプルにしました。
  • すぐに使えるIntegrationをソースコードから分けました。
  • Windows IDEソリューションをVisual Studio 2008から2010にアップグレードしました。
  • WindowsとMetroの専用プラットフォームフォルダをアップデートしました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.5

リリースノート - Wwise Unityインテグレーション 2013.2.5

このリリースはWwise 2013.2.5向けWwise SDKアップデート、新しいプラットフォームのサポート、バグフィックスを提供します。

互換性：

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

– サポートするプラットフォーム：

  • Android
  • iOS
  • Mac OS X (10.6 以上)
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32-bit
    • 64-bit
  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Xbox 360
  • Xbox One

新機能:

  • サポートを追加した新プラットフォーム: PS4
  • サポートを追加した新プラットフォーム: PS Vita
  • サポートを追加した新プラットフォーム: Xbox One
  • Android: 新API AddBasePath()を追加して、I/OのPOSIXファイルシステムパスを指定できるようにしました。

解決済みの問題:

  • WG-24351: iOS: リモートコントロールの中断がハンドルされません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.4

リリースノート - Wwise Unityインテグレーション 2013.2.4

このリリースはWwise 2013.2.4向けWwise SDKアップデート、バグフィックス、各種改善を提供します。

互換性：

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

– サポートするプラットフォーム：

  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 以上)
  • iOS
  • Android
  • Xbox360
  • PS3

新機能:

  • Integrationドキュメンテーションを開くための新しいメニューアイテムWwise > Helpをデフォルトウェブブラウザに追加しました。
  • 基礎のWwise SDK情報を示すためのVersion.txtメタデータファイルを全種類の配信に追加しました。

解決済みの問題:

  • WG-24080: Windows APIとMac APIの両方が存在する状態でAndroidに切り替えた後のコンパイラエラー。

移行内容：

  • Android armeabiプラグインを除きました。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.2.1

リリースノート - Wwise Unityインテグレーション 2013.2.1

このリリースは Wwise 2013.2.1向けWwise SDKアップデート、配信・インストール・ビルドにおける刷新されたエクスペリエンス、その他のの新機能、バグフィックスを提供します。

互換性：

  • Wwise SDK: 2013.2, 2013.2.1
  • Unity: 4.x（3.xのサポート終了）

– サポートするプラットフォーム：

  • Windows 8 (Metro)
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows
    • 32-bit
    • 64-bit
  • Mac OS X (10.6 以上)
  • iOS
  • Android
  • Xbox360
  • PS3

新機能:

  • Unityインテグレーションがターゲットプラットフォーム用とデスクトップ用の両バージョンを含むUnityアセットバンドルとして提供されるようになりました。Unityプロジェクトに直接インポートでき、Editorとターゲットデバイスの両方で機能します。
  • 以下のタスクを行うための新しいWwiseメニューをUnity EditorのUIに追加しました:
    • プラグインのインストール。
    • インテグレーションの再構築。
    • SoundBank ID C++ ヘッダーをC::バージョンにコンバージョン。
  • Unity 4のScripting Define Symbols機能を使い、マルチアーキテクチャプラットフォーム（Windowsなど）のアプリケーションをビルドして実行します。
  • サポートされているプラットフォームのインテグレーションをコマンドラインから再ビルドするためのビルドスクリプト。
  • シンプルなポジショニングデモをIntegrationDemoに追加しました。
  • Android: SoundBankをAndroid Expansion Files (OBB)で保存してロードできるようになりました。

解決済みの問題:

  • WG-23781: Bankコールバックが実行されない。
  • WG-23734: WindowsプラットフォームのMarkerコールバックで文字化けストリングが受信される。
  • WG-23345: Unity Editorで未サポートプラットフォームに切り替えた時のコンパイラエラー。
  • WG-23436: Unity: 誤ったインデックスタイプをキャストした時に発生するリスナーポジショニングエラー。
  • WG-23423: コンポーネントアクセスに関係するUnityのGameObjectパフォーマンス問題。
  • WG-22533: Unity: 一部のAPIバインディング機能でエクセプションハンドラーがあってはならない。

改善点：

  • iOSプラグインのインストールとデプロイの簡素化。
  • ドキュメンテーションをアップデートして、より正確な前提条件などの説明を追加。

移行内容：

  • 新しい配信方法向けに、インストール済みファイル構造やフォルダ構造をアップデートしました。詳細は Unityプロジェクトのインテグレーションの、インストールとアップグレード を参照。
  • マルチアーキテクチャプラットフォームのプラグインの名前を変更。詳細は マルチアーキテクチャプラットフォーム向けにアプリケーションをビルドする を参照。
  • iOSでプラグインライブラリを見つけるために、Xcodeプロジェクトをコンフィギュアする必要がなくなる。ただし新しいネーティブAPIコールが必要。詳細は Mac/iOS/tvOSに固有の情報 を参照。
  • 以前のマルチアーキテクチャプラットフォームビルドのUIスクリプト例を削除。
  • Appleプラットフォーム用の旧ビルドスクリプトを削除。
  • SWIGを2.0.11に更新。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.1.1

リリースノート - Wwise Unityインテグレーション 2013.1.1

このリリースはWwise 2013.1.1向けWwise SDKアップデートを提供します。Integrationに他の変更点はありません。


Wwise Unity Integration Documentation: リリースノート - Wwise Unityインテグレーション 2013.1

リリースノート - Wwise Unityインテグレーション 2013.1

このリリースはWwise 2013.1向けWwise SDKアップデート、Android関連の新機能、全般的なバグフィックスを含みます。

互換性：

  • Wwise SDK: 2012.2.x, 2013.1
  • Unity: 3.4.x, 3.5.x, 4.x

– サポートするプラットフォーム：

  • Windows 8
    • デスクトップ
    • IntelデバイスやARMタブレットのWindows Store App
  • Windows (32bit)
  • Windows (64bit)
  • Mac OS X (10.6 以上)
  • iOS
  • Android
  • Xbox360
  • PS3

新機能:

  • Android: SoundBanksがAndroidアプリケーションパッケージ (apk) に保存できるようになり、LoadBank() APIを使ってトランスペアレントにアクセスできるようになりました。
  • Windows 64bitをサポートします。
  • Windows 8をサポートします。

解決済みの問題: WG-22948: PS3のリスナーインデックスアサインメントエラーによるポジショニングエラー。

  • WG-22938: Mac OSXでUnityインテグレーションがパスするポジショニングデータが無効である。
  • WG-22334: Unityに対して、Music userCue名が空ストリングであると誤って報告される。
  • WG-22329: Unityインテグレーションでグローバルスコープに対してPostEvent()ができない。
  • WG-22255: Unity Android: アプリをバックグランドに切り替えた後もサウンドが続く。
  • WG-22165: 3Dポジショニングが、iOSやAndroidで正しく機能しない。
  • WG-21933: AkCallbackManager.csが、floatのデシリアライズを正しく行わない。UserCue名が壊れている。
  • WG-21365: Unity iOS: iOSオーディオ中断イベントが発生して終わった後に、サウンドが聞こえない。
  • WG-22533: 一部のAPIバインディング機能で、例外処理があってはならない。

改善点：

  • 1つのUnityプロジェクトにWindowsとMacの配信を共存させることが可能。
  • 読みやすく正確な改善ドキュメンテーションや 各プラットフォーム固有の情報 セクションの追加で、対象プラットフォームに関する情報を簡単に入手可能。
  • ビルドログでquietモードとverboseモードに対応し、読みやすさを向上。
  • ビルドパイプラインがユーザのPythonバージョンを確認して、古い場合は警告する。
  • デプロイメントスクリプトを直接使ってIntegrationをUnityプロジェクトにコピーできるようになった。

移行内容：

  • Integration for PS3をビルドするにはVisual Studio 2010が必要となりました。
  • ビルドスクリプトはPython 2.6以前のバージョンをサポートしない。Python 2.7.xまたは3.xが必要。
  • 自分でIntegrationをビルドするのに、環境変数UNITY_PROJECT_ROOTが不要となった。デフォルトで、IntegrationがUNITY_PROJECT_ROOTで指定したフォルダに自動的にデプロイされななくなった。詳細は インテグレーションコードをビルドする を参照。
  • AndroidビルドスクリプトがPostprocessBuildPlayerスクリプトをUnityプロジェクトにデプロイしなくなった。
  • IntegrationDemoプロジェクトをUnity4フォーマットに更新。


Wwise Unity Integration Documentation: Unityプロジェクトのインテグレーションの、インストールとアップグレード

Unityプロジェクトのインテグレーションの、インストールとアップグレード

Wwise Unityインテグレーションに、UnityプロジェクトでWwiseを使うために必要なUnityコンポーネント、Editorツール、ドキュメンテーションなどが含まれます。

必要となるインストール手順やアップグレード手順の情報を、以下のページに示します。

  • 前提条件
  • Wwise Integration Packageを初めてインストールする
  • Unity Projectに対する変更
  • サウンドをゲームにインテグレートする
  • サウンドバンクの場所を設定する
  • プラグインの追加
  • 新しいWwiseバージョンを使用するためにインテグレーションをアップグレードする


Wwise Unity Integration Documentation: 前提条件

前提条件

Wwiseの各種プラットフォームの要件を確認してください: 各プラットフォーム固有の情報 。

注記： このインテグレーションは、Unity Cloud Buildサービスに対応していません。

Unityとのインテグレーションに必要なソフトウェアを、以下に示します:

プラットフォーム | 必要なコンポーネント
iOS | Xcode 7.2以上、互換性のあるiOS SDKと共に
Windows | DirectX End-Userランタイム x64 Visual Studio 2013 redistributable
Windows 32-bit Debug | x86 Visual Studio 2013 redistributable


Wwise Unity Integration Documentation: Wwise Integration Packageを初めてインストールする

Wwise Integration Packageを初めてインストールする

Audiokinetic Launcherを使用してWwise Integrationパッケージをインストールすることができます。詳細は WwiseをUnityプロジェクトにインテグレートする を参照してください。

警告： 始める前に確認すること：
  • Unityプロジェクトをバックアップします。バックアップのためにあなたのソース管理システムを活用することも、Audiokinetic Launcherを使用することもできます。Launcherを通してあなたのプロジェクトをバックアップする場合、プロジェクトのインテグレーションページにおいて必ずInstall files into a copy of the Unity project directory, then apply changes if successfulを選択してください。
  • Wwiseインテグレーションをインストールする前に、Unityプロジェクトがエラー無しで正常にコンパイルできる状態であることを確認すること。(Warning表示は許容範囲内。)
  • Unityプロジェクトをソースコントロールで管理している場合は、インテグレーションを始める前にUnityプロジェクトフォルダ全体をチェックアウトしてください。これを行わないと、対象のファイルを変更できないためインテグレーションが失敗します。
  • Unityプロジェクトに既存のWwiseプロジェクトを統合する予定がある場合、必ずWwise Project SettingsダイアログにおいてEnable Auto-Defined SoundBanksオプションの選択を解除してください。

Unityインテグレーションの拡張

部分的な方法としてユーザーフックは、ユーザーがゲームオブジェクトの自動登録を拡張したり、この機能を完全に削除したりできるように、追加されました。デフォルトの拡張は推奨されますが WwiseをUnityプロジェクトにインテグレートする 時にこれらを除外することができます。


Wwise Unity Integration Documentation: Unity Projectに対する変更

Unity Projectに対する変更

Wwise Integrationインストールプロセスで以下が行われ、あなたのUnityプロジェクトが変更されます:

  • Edit > Project Settings > Audio の Disable Audio オプションを有効にします。これにより、組み込みオーディオシステムが無効になります。
  • Create WwiseGlobal GameObject Wwise Settingを有効にした場合は、現在のシーンで"Wwise Global"という名前のゲームオブジェクトが作成されます。WwiseGlobalオブジェクトにAkEditorEventPlayer、AkAudioListener、AkGameObjのスクリプトも与えられ、これを使用して編集モードでAkEventオブジェクトをプレビューします。また、Rigidbodyコンポーネントが追加されるので、 AkEnvironment や、 AkRoom や、 AkGameObj の間のやり取りもプレビューできます。
注記： WwiseGlobalオブジェクトは、Wwise Sound EngineのInitializingスクリプトとTerminatingスクリプトを含むGameObjectです。各シーンをEditorで正しくプレビューできるように、Editorのワークフローにおいて、すべてのシーンに追加されます。ビルドにおいて、最初のシーンで1つのインスタンスが作成されゲームを通して存続します。初期化スクリプトに、いくつかのカスタム設定可能なオプションがあります。Wwise SDK ドキュメントの サウンドエンジンモジュールの初期化 を参照してください。
  • 重要なWwiseスクリプト（AkInitializer、AkGameObj、AkAudioListener、AkBank）の Script Execution Order （スクリプト実行順序設定）を有効にします。
  • Add Ak Listener to Main Camera チェックボックスを選択した場合はMain CameraオブジェクトからAudio Listenerコンポーネントを削除し、デフォルトのAkAudioListener.csスクリプトセットをMain Cameraオブジェクトに設定します。
  • Edit > Project Settings > Player > Resolution and Presentation の Run in Background オプションが有効になり、Wwise Profilerに接続できるようになります。


Wwise Unity Integration Documentation: サウンドをゲームにインテグレートする

サウンドをゲームにインテグレートする

これで、Wwiseのサウンドをゲームで再生する準備が整いました。あなたのWwiseプロジェクトに、まだサウンド、イベント、SoundBankなどが設定されていなければ、最初にWwiseを起動して以下を行います:

  1. WAVファイルをインポートする。File Explorerウィンドウでファイルを1つ選択し、Project ExplorerのAudioタブにドラッグ＆ドロップする。これでSoundが1つ作成される。
  2. Eventを作成する。サウンドを右クリックし、New Eventを選択する。適切な名前を付ける。
  3. SoundBankを作成する。SoundBanksレイアウト（F7）を開く。SoundBank Managerで、New…をクリックする。
  4. 作成したEventをこのSoundBankに入れる。Eventを入れるには、Project ExplorerからSoundBankにドラッグ＆ドロップする。
  5. Generate Selectedをクリックする。これで、再生するものが準備できる。
警告： UnityインテグレーションはAuto-Defined SoundBanksに対応していません。この機能がWwise Project Settingsで無効になっていることを確認してください。

次に、サウンドをUnityプロジェクトにインテグレートします：

  1. Wwise Picker ウィンドウ (Window > Wwise Picker)を開くと、プロジェクトのEventやSoundBankが表示される。
  2. SoundBankをシーン中のオブジェクトにドラッグ＆ドロップする。
  3. Eventをシーン中のオブジェクトにドラッグ＆ドロップする。
  4. ゲームプレイ！スタートするとサウンドが聞こえるはず。

何も聞こえない？詳しくは トラブルシューティング ページへ。

他のサウンドをインテグレートする

UnityとWwiseの現在のインテグレーションで、よくあるユースケースの一部をカバーするいくつかのUnityコンポーネントを提供します。

  • AkAmbient を使って、シーン専用のサウンドエミッタを配置する。
  • AkBank を使って、SoundBankをロードする。
  • AkEnvironment をColliderに添付して、特定ゾーンのリバーブを設定する。
  • その他のコンポーネントについて。

ただし、より複雑なゲーム内の動作を実現するには、スクリプトが書けるプログラマの協力が重要になります。– Wwise APIに関する情報は、以下の2つのセクションにあります：

  • WWISE 要素のゲームへの統合
  • ネームスペース AK::SOUNDENGINE


Wwise Unity Integration Documentation: サウンドバンクの場所を設定する

サウンドバンクの場所を設定する

Unity Editorでプロジェクトを実行する時はプロトタイプ化をはやくするために、サウンドバンクをWwiseプロジェクトのGeneratedSoundBanksフォルダから直接取得します。このフォルダのデフォルトの場所は…\<UnityProjectName>\Assets\StreamingAssets\Audio\GeneratedSoundBanksです。

サウンドバンクの場所を変更するためには、Edit > Project Settings > Wwise Editorを選択してSoundBanks Pathを必要に応じて更新します。

Unityであなたのプロジェクトをパッケージングする時、ターゲットプラットフォームに応じてアセットが選択的にパッケージングされることはありません。逆に指定されたサウンドバンクフォルダにある、すべてのサウンドバンクがパッケージングされます。必要なプラットフォームのサウンドバンクだけをUnityで構築してパッケージングするためには、Wwise EditorページのCopy SoundBanks at pre-Build stepを選択したままにします。

別の方法としてUnityデベロッパの上級者は、BuildPlayerPipelineスクリプトを使用することができます。

Unity Addressablesを使用する場合はサウンドバンクの選択肢が多少異なります。 生成されたサウンドバンクの場所をAddressables用に設定する を参照してください。

参照
  • 特定プラットフォーム向けにUnityゲームをビルドする

生成されたサウンドバンクの場所をAddressables用に設定する

あなたのプロジェクトでUnity Addressablesを使用する場合、生成したサウンドバンクを入れるフォルダにサウンドバンクが適切にインポートされるよう、このフォルダをプロジェクト内に置く必要があります。

生成されたサウンドバンクのパスを設定するためには、必要に応じてEdit > Project Settings > Wwise Editorを選択してGenerated SoundBanks Pathを変更します。必ずAssetsフォルダの下の場所とします。

参照
  • Wwise Unity Addressablesパッケージをインストールする


Wwise Unity Integration Documentation: プラグインの追加

プラグインの追加

すべての組み込みWwiseソースプラグインとエフェクトプラグインがデフォルトでこのインテグレーションで使用できます。

エフェクトプラグインはダイナミックライブラリとして提供されます。これらのライブラリはWwiseプロジェクトにおける利用状況に応じてUnityプロジェクトに自動的に含まれます。プロジェクトで使うエフェクトプラグインのリストは、SoundBank生成時に作成されます。

今まで使ったことがないプラグインをプロジェクトに追加するには、以下の手順に従います:

  1. Wwiseプロジェクトのエフェクトプラグインを使う。
  2. 作業中のプラットフォーム用のSoundBankを生成する。
  3. Unityプロジェクトに切り替える。
  4. 新しいSoundBankを期待されるStreamingAssetsフォルダにコピーする。（Editorで再生する場合は、コピー不要。）
  5. ゲームをコンパイルする（またはEditorで再生する）。

Launcherを使用してWwiseにインストールしてあるその他のプラグインは、UnityプロジェクトにWwiseをインテグレートした時点で自動的に利用できます。一方UnityプロジェクトにWwiseをインテグレートした 後に Wwiseプロジェクトにプラグインをインストールした場合、そのようなプラグインをインテグレーションで使用するためには UnityやUnrealインテグレーションにプラグインを追加する の手順に従う必要があります。

ライセンスを要するプラグインはWwiseのデフォルトライセンスに含まれません（McDSP、iZotope、Auro、SoundSeed、Crankcase REV、Convolution Reverb、Motion）。オーサリングアプリケーション内で試せますが、ゲーム内では使えません。有効なライセンスがない場合は ご連絡ください 。Evaluationライセンスは全て無料です。

新しいエフェクトプラグインをWwise用に（そして追ってUnity用に）作成するには 新しいプラグインを作成する のセクションをお読みください。iOS、tvOS、またはNintendo Switch向けに作成する場合は、プラグインを必ずスタティックライブラリとして提供してください。詳細はPlug-in 静的登録 を参照してください。インテグレーションに含まれるプラグインは、AkPluginActivator.StaticPluginRegistrationクラス内で生成される該当CPPファイルに、自動的に登録されます。あなたの新しいプラグインを登録するには、以下のようなCPPファイルを作成してください:

namespace AK { class PluginRegistration; };
#define AK_STATIC_LINK_PLUGIN(_pluginName_) extern AK::PluginRegistration _pluginName_##Registration; void *_pluginName_##_fp = (void*)&_pluginName_##Registration;
#include "MyNewPluginFactory.h"
AK
Definition: AkWwiseAcousticTexture.cs:21


Wwise Unity Integration Documentation: 新しいWwiseバージョンを使用するためにインテグレーションをアップグレードする

新しいWwiseバージョンを使用するためにインテグレーションをアップグレードする

新しくリリースされるWwiseのメジャーバージョンやマイナーバージョンに合わせ、Wwiseの新しいバージョンを使用できるようにIntegrationパッケージを更新したい場合があります。

後述のアップグレード手順は以下を前提とします:

  • 古いWwiseバージョンのWwise Integrationパッケージを含むUnityプロジェクトがすでにあること。
  • Wwiseの新しいバージョンをすでにインストールしてあり、そこにWwise SDKや、既存インテグレーションが対応するデプロイメントプラットフォームがすべて含まれていること。
警告： 注意点
  • アップグレード操作を元に戻すことはできません。アップグレードを進める前に必ずあなたのUnityプロジェクトをバックアップしてください。
  • Unityプロジェクトがソースコントロール下にある場合は、アップグレードを開始する前に、必ずUnityプロジェクトフォルダ全体をチェックアウトしてください。これを行わないとアップグレードでファイルを正しく修正できず失敗します。
  • Wwiseインテグレーションのアップグレードを開始する前に、Unityプロジェクトがエラーなしで正常にコンパイルできる状態であることを確認してください。(Warning表示は許容範囲内。)
  • C++ AkSoundEngine プラグインソースコードのC++ Wwise SDKを変更してある場合は、 プラグインのC++コードを更新した後に、Wwise Integration Packageを新しいバージョンにアップデート・アップグレードする の手順に従ってください。
  • UnityのためのWwise Addressablesパッケージ を使用している場合は Wwise Unity Addressablesパッケージを更新する を参照してください。

ほかのUnityプラグインと異なり、新しいバージョンにアップグレードするには、以前のWwise Integrationパッケージをインストールしたままにする必要があります。

警告： 新しいWwise Integrationにアップグレードする前に既存のものを削除しないでください。削除するとあなたのゲームのWwiseオーディオがすべて失われます。

アップグレードは2段階に分けて行います。まず最初にWwiseプロジェクトをこれから利用するバージョンにアップデートしてから、Unityプロジェクトも同様にアップデートする必要があります。

  1. Wwiseプロジェクトを更新します:
    1. Launcherで Wwise ページを選択します。
    2. 新しくインストールしたWwiseバージョンを起動します。
    3. 既存のWwiseプロジェクトを開きます。
    4. WwiseプロジェクトをWwiseの新しいバージョンに更新するようにプロンプトが表示されたら、 Update をクリックします。
    5. 更新が終了したらWwise SoundBankを生成します。
    6. Wwiseプロジェクトを保存します。
  2. Unityプロジェクトを更新します:
    1. Wwiseの新しいバージョンにUnityプロジェクトを更新するには、Launcherを使用します。詳細はLauncherドキュメントの Upgrading or Modifying an Integration Package を参照してください。

2021.1.1より前のバージョンのWwiseからアップグレードする

Wwise 2021.1.1以降のバージョンに、Wwise 2021.1.1より前のバージョンからアップグレードする場合は、UnityプロジェクトのJsonSerializeパッケージがアクティブであることを確認する必要があります。アクティブでないと、アップグレードが失敗します。方法は、以下の2つがあります:

  1. Unityのパッケージマネージャで、パッケージをアクティブにする方法。
    • パッケージは、 Built-in packages リストにあります。
  2. "com.unity.modules.jsonserialize": "1.0.0" を、 Packages/Manifest.json の、依存関係のリストに追加する方法。
    • パッケージが確実に正しくプロジェクトに追加されるように、この変更を行ったあとにUnityプロジェクトを開き、閉じてください。


Wwise Unity Integration Documentation: Wwise Integration Packageをアンインストールする

Wwise Integration Packageをアンインストールする

Wwise Integration Packageをアンインストールするには、Unityプロジェクトから、Assets/Wwiseフォルダをマニュアル操作で削除する必要があります。ゲームオブジェクトのWwiseコンポーネントやその他の設定は、一切削除されません。

Wwise Addressablesパッケージも使っていた場合は、UnityのPackage Managerを使ってパッケージを削除するか、 [Unity Project]/Packages/manifest.json からパッケージを削除する必要があります。


Wwise Unity Integration Documentation: Unity Editor Settingsを調整する

Unity Editor Settingsを調整する

Wwise Editor Settingsは、Project Settingsウィンドウ (Edit > Project Settings) の、Wwise Editor セクションにあります。

Wwise Sound Engineの初期化に使うプロジェクト設定については、 Wwise Initialization Settingsを調整する のページを参照してください。

Wwise Project Settings

Wwise Project Path: このゲームに関連付けられたWwiseプロジェクトの場所。これは、Unity Projectのルートフォルダ内の、Assetsフォルダの外に置くことを推奨します。

Wwise Application Path: Wwiseアプリケーションの場所。これは、Unity内からSoundBankを生成するために必要です。

Editorの動作設定

サウンドバンクの選択肢はUnity Addressablesの使用の有無で異なります。Addressablesの詳細については UnityのためのWwise Addressablesパッケージ を参照してください。

SoundBanks Path：StreamingAssetsフォルダに対する（かつその内部の）サウンドバンクの場所。ゲームをビルドするときに、生成したサウンドバンクをプロジェクトにコピーするときに、これを使います。Unity Addressablesパッケージがあなたのプロジェクトにインストールされている場合、この選択肢は表示されません。代わりにGenerated SoundBanks Pathを指定する必要があります。

Generated SoundBanks Path：あなたのプロジェクトで生成されたサウンドバンクの場所。あなたのプロジェクトにAddressablesパッケージがインストールされている場合に限り表示される選択肢です。サウンドバンクが適切にインポートされるよう、必ずプロジェクトのAssetsフォルダの下にあるパスとします。

Copy SoundBanks at pre-Build step：これを選択した場合はビルドおよび展開時に、SoundBanks Pathで指定した場所にサウンドバンクがコピーされます。この選択肢を選択することを推奨します。Unity Addressablesパッケージがあなたのプロジェクトにインストールされている場合、この選択肢は表示されません。

Generate SoundBanks at pre-Build step: Build前のステップとして、SoundBankをコピーする前に生成します。サウンドバンクを特定ビルドマシンにおいて生成する場合、この選択肢を選択しないことを推奨します。Unity Addressablesパッケージがあなたのプロジェクトにインストールされている場合、この選択肢は表示されません。

Create WwiseGlobal GameObject: WwiseGlobalオブジェクトは、Wwise Sound Engine用のInitializingスクリプトとTerminatingスクリプトを含むGameObjectです。各シーンをEditorで正しくプレビューできるように、Editorのワークフローにおいて、すべてのシーンに追加されます。ゲーム中は最初のシーンでインスタンスが1つだけ作成され、それがゲームの終わりまで存続します。このボックスはチェックしておくことを推奨します。

Add Listener to Main Camera: ポジショニング機能を使うには、すべてのシーンで、AkAudioListenerスクリプトをメインカメラに添付する必要があります。別のGameObjectにリスナーを添付したい場合は、このボックスのチェックを外してください。

Auto-delete WwiseObjectReferences: Event、Bank、BusなどのWwiseオブジェクトを参照するコンポーネントは、これら参照先をWwise/ScriptableObjectsフォルダ内で作成されるWwiseObjectReferenceアセットを使ってトラッキングします。 このオプションをチェックし、あるWwise ObjectをWwise Projectから削除すると、Wwiseプロジェクト構造をパースした時にWwise/ScriptableObjectsフォルダ内の該当アセットが削除されます。

Load Sound Engine in Edit Mode：Sound EngineをEdit Modeでロードします。Sound Engineがゲーム内で適切に初期化されていることを確認するには、この設定を無効にします。この設定を無効にすると、Inspector、Timelineなどのファンクションでサウンドは再生されません。サウンドを聞く唯一の方法は、EditorでPlayをクリックします。この設定は Enter Play Modeの動作 に影響します。

Show Spatial Audio Warnings: Spatial Audioが正しく機能するように設定されていないWwiseコンポーネントに、警告が表示されます。このボックスはチェックしておくことを推奨します。

WAAPIの設定

Connect to Wwise: これをチェックすると、エディタは、Wwise AuthoringのインスタンスとWAAPI接続を確立させようと定期的に試みます。

WAAPI Port: 接続先のポート。Wwise Authoringで、 (Project > User Settings) の下で確認できます。デフォルト値は8080です。

WAAPI IP address: Wwiseオーサリングを実行中のデバイスのIPアドレス。同じマシン上で実行中の場合は、127.0.0.1を使います。

Wwiseエラーメッセージトランスレータの設定

Error Translatorsの目的は情報が入手可能な範囲で、エラーメッセージの認識番号を人間に理解できる名前に変換することです。これにはSoundBanksInfo.xmlを通す方法とWAAPIを通す方法の2通りがあります。

SoundBanksInfo.xmlファイルがサウンドバンクファイルの横に存在する場合（任意）、XML方式を利用した方が速いです。

WAAPIは最新の情報を持つWwiseのインスタンスから直接読むことができるという利点があります。ただしネットワーク通信が非常に遅い場合もあります。このためデフォルトで無効となっています。

XML Translator Timeout XMLファイルリーダーでIDを検索するために割り当てる最長時間（ミリ秒単位）。無効にするためには0に設定します。

WAAPI Translator Timeout WAAPI接続を通してIDを検索するために許容される最大時間（ミリ秒）。無効にするためには0に設定します。


Wwise Unity Integration Documentation: Wwise Initialization Settingsを調整する

Wwise Initialization Settingsを調整する

Wwise Initialization Settingsは、WwiseサウンドエンジンのC/C++ SDK内の、以下の構造のメンバーに対応しています:

  • AkCommSettings
  • AkDeviceSettings
  • AkInitSettings
  • AkMemSettings
  • AkMusicSettings
  • AkPlatformInitSettings
  • AkSpatialAudioInitSettings
  • AkStreamMgrSettings

設定の対象範囲はパスやランゲージからはじまり、サンプルレート、キューサイズ、メモリ閾値、プールサイズなど広域に及ぶので、負担に感じるかもしれません。しかし、ほぼすべての場面で、デフォルト設定をそのまま使用できます。それでもプロジェクトによっては、Wwise Initialization Settingsを部分的にアクセスし調整したい状況が考えられます。

Wwise Initialization Settingsにアクセスする

Wwise Initialization Settingsが、Unity Editorに公開されました。これからは、変更を文字列で行う必要がありません。

これらの設定は、Project Settings Window (Edit > Project Settings...) の、 Wwise Initialization セクションの下にあります。

Wwise Initialization Settings

Project Settingsウィンドウが開くと、Wwise Initialization Settingsが、直感的に把握しやすい次の4つのグループに分かれて表示されます: Common User Settings、Common Advanced Settings、Wwise Communication Settings、 Platform Specific Advanced Settings（ Platform に、あなたが作業中のプラットフォームが入ります）。設定項目はすべて、フィールドでもチェックボックスでもスライダーでも、このインターフェースで直接編集できます。使いやすいように、全ての設定項目に関してヒントが表示されるので、そのパラメータの情報や、可能な設定値などが分かります。

便利なヒントも表示される、Common User Settings

プラットフォーム別の設定

Common User Settings、Common Advanced Settings、Wwise Communication Settingsには、各プラットフォーム向けのの設定項目があり、使いやすいようにグループにまとめられています。設定した値はチェックボックスをチェックしたプラットフォームすべてに適用され、チェックボックスにチェックしていないプラットフォームは、個別に設定値を決められます。

Platform Specific Advanced SettingsはWwiseのカスタムプラットフォーム毎に表示されるので、ユーザーはプラットフォーム別に設定できます。

プラットフォームによって設定値の異なる、Common Advanced Settings
注記： Initialization Settingsの変更は、あなたがサウンドエンジンを再生してから停止するまで、有効になりません。


Wwise Unity Integration Documentation: サウンドバンクを管理する

サウンドバンクを管理する

Wwise Unityインテグレーションは複数のサウンドバンク管理の方法を提供していますが、独自の要件が伴います。このインテグレーションを使用す際、以下の点にご注意ください。

  • 推奨されるサウンドバンクの場所は、Unity Addressablesの使用の有無によって変わります（ UnityのためのWwise Addressablesパッケージ ）。Addressablesを使用する場合はサウンドバンクが確実にインポートされるように、あなたのプロジェクトのAssetsフォルダ内の場所を指定する必要があります。Addressablesを使用しない場合はプロジェクト外の場所を指定することができます。詳細は サウンドバンクの場所を設定する および Wwise Unity Addressablesパッケージをインストールする を参照してください。
  • Wwise Pickerを通してUnityでサウンドバンクを生成することが可能です。詳細は Wwise Picker を参照してください。
  • UnityデベロッパはAkBankクラスを使用してサウンドバンクのロード、アンロード、デコードなどさまざまな操作を実行することができます。
  • Auto-defined SoundBanksに対応していないため、Wwiseプロジェクトで該当するオプションを必ず無効にしてください。Wwise AuthoringでProject > Project Settings > SoundBanksを選択し、Enable Audo Defined SoundBanksが解除されていることを確認します。詳細はSoundBanks Tabを参照してください。


Wwise Unity Integration Documentation: Wwise Unityインテグレーションの使用

Wwise Unityインテグレーションの使用

このインテグレーションは、Unity Scene GameObjectsでそのまま使えるWwise専用コンポーネントを提供します。これらのコンポーネントで、サウンドデザインの大体のシナリオに対応できます。コンポーネントはC::のカスタムスクリプトですが、その公開プロパティを編集するのに、プログラミングは必要ありません。

Wwiseコンポーネントの追加

Unity GameObjectsにWwiseコンポーネントを追加するには:

  • シーンで選択したGameObjectがロードされているUnity Inspectorウィンドウ（Ctrl+3）を開きます。
  • Add Component をクリックし、Componentリストを表示させます。
  • Wwise を選択してそのサブリストを開き、希望する Wwiseコンポーネント を選択します。
    TIP： コンポーネントのサーチフィールドに "ak" と入力すると、すべてのWwiseコンポーネントの入ったリストがすぐに表示されます。

Wwise PickerでWwiseコンポーネントを追加する

コンポーネントをゲームに追加するには、WwiseオブジェクトをWwise PickerからInspectorにドラッグするか、ロードしたシーンのHierarchyの中にあるゲームオブジェクトにドラッグします。

参照
  • Wwiseコンポーネント
  • Wwise Picker

WwiseGlobalオブジェクト

WwiseGlobalオブジェクトは、Wwise Sound EngineのInitializingスクリプトとTerminatingスクリプトを含むGameObjectです。各シーンをEditorで正しくプレビューできるように、Editorのワークフローにおいて、すべてのシーンに追加されます。ゲーム中は最初のシーンでインスタンスが1つだけ作成され、それがゲームの終わりまで存続します。初期化スクリプトに、いくつかのカスタム設定可能なオプションがあります。

この動作を解除するには、 Edit > Project Settings > Wwise Editor を使い、 Create WwiseGlobal GameObject を無効にします。その場合、ゲームを通して存在するオブジェクトに、initializerスクリプトを追加するのは、あなたの責任となります。

メインカメラのリスナー

ポジショニング機能を使うには、すべてのシーンで、Ak Audio Listenerスクリプトをメインカメラに添付する必要があります。デフォルトで、自動的にリスナーがメインカメラに追加されます。この動作を無効にするには、 Edit > Project Settings > Wwise Editor に進み、 Automatically add Listener to Main Camera を無効にします。

参照
  • 三人称視点のゲームにおけるDistance Probeの使用に関する詳細は、 Ak Listener Distance Probeコンポーネントを使い、サードパーソンゲームのリスナーをカスタマイズする を参照してください。

Wwise Types

またこのインテグレーションには、最小限のコードで、これ以外の利用シナリオの大部分に対応できるクラスが、いくつか提供されています:

  • AK.Wwise.AuxBus
    This type represents an auxiliary send in the Master-Mixer Hierarchy.
  • AK.Wwise.Bank
    This type can be used to load/unload SoundBanks.
  • AK.Wwise.CallbackFlags
    This type represents the values of the flags used when posting an Event with a callback.
  • AK.Wwise.Event
    This type can be used to post Events to the sound engine.
  • AK.Wwise.RTPC
    This type can be used to set game parameter values to the sound engine.
  • AK.Wwise.State
    This type can be used to set Wwise States.
  • AK.Wwise.Switch
    This type can be used to set Switch values on gameobjects.
  • AK.Wwise.Trigger
    This type can be used to post triggers to the sound engine.
  • AK.Wwise.AcousticTexture
    This type represents an Acoustic Texture.
参照
  • Wwise Types

Wwise Authoring API（WAAPI）クライアント

C# APIのあるネイティブWAAPIクライアントを使い、Unity内から WAAPI に接続できます。現在、WindowsとmacOS用に提供中です。Wwise Authoring APIが、JSONオブジェクト経由でメッセージを送信します。Unity側では、文字列を使いクライアントを実装しました。あなたの好きな方式で、有効なJSON文字列を構築してから、WAAPIクライアントに渡してください。

参照
  • WAAPIユーティリティ

ゲームオブジェクトにWwiseサウンドを追加する

サウンドをゲームに追加する方法は、3通りあります：

  • Wwise Picker を使う。 最も簡単にサウンドをオブジェクトに追加できます。EventをWwise PickerウィンドウからUnity ViewerまたはInspectorにあるオブジェクトまでドラッグします。これで自動的に AkAmbient コンポーネントが対象Game Objectに作成されます。
  • Add Componentメニューを使う。 AkAmbient コンポーネントや AkEvent コンポーネントを、どのUnity Game Objectにも追加できます。
  • Wwise Types を使う。 いつでも AK.Wwise.Event.Post() をC::スクリプトからコールできます。
  • スクリプトを使う。 いつでも AkSoundEngine.PostEvent() をC::スクリプトからコールできます。
参照
  • サウンドエンジンの制御にC::コードを使う

WwiseとUnity Timelineを使う

UnityのTimeline機能用に、Wwiseイベントをトリガーしたり、Wwise RTPC値を設定したりするための、カスタム設定のWwiseトラックがあります。

WwiseサウンドオブジェクトがUnityのオーディオタイムラインにある場合、これらのサウンドにInitial Delayを適用すると問題が発生することがあります。例えばシークを使用する場合、サウンドそのものではなくInitial Delayをつくり出すために生成される無音期間をシークするため、サウンドは指定のタイムスタンプの位置からではなくファイルの先頭から開始されます。ディレイ後にサウンドを開始させるためには、WwiseのInitial DelayではなくUnity Timelineを使います。Timelineでクリップを希望するタイムスタンプまで移動します。

参照
  • WwiseのTimelineインテグレーション


Wwise Unity Integration Documentation: Wwiseコンポーネント

Wwiseコンポーネント

一般的なコンポーネント

AkAmbient
このコンポーネントを使えば、シーンのどのオブジェクトにでも、Wwise Eventをアタッチすることができます。サウンドを様々なタイミングでスタートすることができ、タイミングは選択したUnityトリガーに依存します。このコンポーネントはアンビエントサウンド（シーンに紐づいているオブジェクトに関連したサウンド）に特に有効なコンポーネントですが、その他の目的で利用することもできます。 AkAmbient のベースクラスが AkEvent なので、再生・停止、複数再生、複数停止、全ボタンの停止といった機能が、関連するWwiseイベントのプレビューに使えます。
公開プロパティの概要については、 AkAmbient をInspectorで使う を参照してください。

AkAudioListener
リスナーを担うゲームオブジェクトに、このスクリプトを追加します。通常はCameraオブジェクトやPlayerオブジェクトに追加しますが、3Dバスを実装するときに、どのゲームオブジェクトにでも追加できます。isDefaultListener は、あるゲームオブジェクトをデフォルトのリスナーとするのかどうか、つまりAkGameObjListenerListにリスナーがアタッチしていないすべてのゲームオブジェクトを聞くようなリスナーにするのかどうかを、指定します。<br/ > その公開プロパティの概要については、 AkAudioListener をInspectorで使う を参照してください。

AkBank
特定のタイミングで、あるSoundBankをロードしたりアンロードしたりします。Vorbisのサウンドを指定するタイミングで解凍するには、Decode Compressed Dataという選択肢を使います。その場合、SoundBankが準備されます。
その公開プロパティの概要については、 AkBank をInspectorで使う を参照してください。

また、 SDKドキュメンテーション: バンクのロード も参照してください。

AkEmitterObstructionOcclusion
現在のゲームオブジェクトとそのリスナーの間に、1つ以上のオブジェクトがあったときは、そのゲームオブジェクトのエミッタを、完全にオブストラクションまたはオクルージョンします。
その公開プロパティの概要については、 AkEmitterObstructionOcclusion をInspectorで使う を参照してください。

AkEnvironment
リバーブの範囲を定義するために使うコンポーネントです。正しく動作するには、コライダーオブジェクトに追加する必要があります。
その公開プロパティの概要については、 AkEnvironmentやAkEnvironmentPortalをInspectorで使う を参照してください。

AkEnvironmentPortal
2つの異なる AkEnvironment ゾーンにかかるエリアを定義し、その2つのゾーンの間のミキシングを可能にするために使うコンポーネントです。
その公開プロパティの概要については、 AkEnvironmentやAkEnvironmentPortalをInspectorで使う を参照してください。

AkEvent
Wwise Eventのことや、それをいつUnityでトリガーするのかを知っているHelperクラス。
その公開プロパティの概要については、 AkEvent をInspectorで使う を参照してください。

AkGameObj
あなたのシーンにあるサウンドオブジェクトを表すコンポーネントであり、そのポジションをトラッキングしたり、Switch、RTPC、環境値など、その他のゲームシンクをトラッキングしたりします。音を発するすべてのオブジェクトに追加することができ、AkAudioListenerをアタッチしたオブジェクトであれば、追加されます。WwiseにパスされるUnity Game Objectで、これがない場合は、デフォルト値を使ってWwiseが自動的に追加します。
その公開プロパティの概要については、 AkGameObj をInspectorで使う を参照してください。

AkInitializer
Wwiseオーディオエンジンの初期化やフレームアップデートに対応するコンポーネントです。これは DontDestroyOnLoad とマークされているので、1つのシーンだけでなく、ゲームのライフサイクルの最後まで、アクティブ状態が維持されます。サウンドエンジンの初期化パラメータを変更する場合は、このスクリプトを編集します。プロパティインスペクタにすでに公開されているものもあります。オーディオを正しく初期化するためには、ゲームのはじまりに、これが1つのGame Object上に存在している必要があります。AkSoundEngineを利用するほかのMonoBehaviorよりも 前に 実行する必要があります。

参照
  • Wwise Initialization Settingsを調整する
  • Wwise SDK doc: サウンドエンジンの各種モジュールの初期化
  • AK::SoundEngine::Init()
  • AK::SoundEngine::Term()
  • AkCallbackInfo

AkListenerDistanceProbe
このコンポーネントはゲームオブジェクトを、指定のリスナーゲームオブジェクトのDistance Probeにアサインします。Distance Probeは主に三人称視点ゲームで使われ、リスナーとは異なる場所に基づく減衰をサウンドに適用します。
Distance Probeの公開プロパティの概要については、 Ak Listener Distance Probeコンポーネントを使い、サードパーソンゲームのリスナーをカスタマイズする を参照してください。

AkState
これは、選択中のUnityイベントがトリガーされると、必ず ak.soundengine.setState() をコールします。例えば、Unityコライダーにこのコンポーネントを設定し、そこにオブジェクトが入ってきた時にトリガーされるようにできます。
公開プロパティの概要については Using AkState をInspectorで使う を参照してください。

AkSwitch
これは、選択中のUnityイベントがトリガーされると、必ず ak.soundengine.setSwitch() をコールします。例えば、Unityコライダーにこのコンポーネントを設定し、そこにオブジェクトが入ってきた時にトリガーされるようにできます。
その公開プロパティの概要については、 AkSwitch をInspectorで使う を参照してください。

Spatial Audioのコンポーネント

AkEarlyReflections
リスナーを担うゲームオブジェクトに、このスクリプトを追加します。このゲームオブジェクトから出たサウンドは、付近の AkSurfaceReflector に、アーリーリフレクションを出すことになります。
公開プロパティの概要については、 Inspectorの AkEarlyReflections を参照してください。

AkRadialEmitter
エミッターを担うゲームオブジェクトに、このスクリプトを追加します。このゲームオブジェクトから出るサウンドには、ゲームオブジェクトのポジションを中心とする内半径と外半径に基づいたスプレッドが伴います。
その公開プロパティの概要については、 InspectorのAkRadialEmitter を参照してください。

AkReverbZone
2つのRoomをつなぐ（1つはReverb Zone、もう1つはその親として）ゲームオブジェクトに、このスクリプトを追加します。 RoomをReverb Zoneとして設定するためのAkRoomコンポーネントを持つゲームオブジェクトに、このスクリプトを追加します。
その公開プロパティの概要については、 AkReverbZoneをInspectorで使う を参照してください。

AkRoom
AkRoom は閉鎖された環境で、外部やほかのルームとやり取りするには、 AkRoomPortals が必要です。
その公開プロパティの概要については、 AkRoom をInspectorで使う を参照してください。

AkRoomAwareObject
AkRoom コンポーネントを認識できるゲームオブジェクト。Spatial Audio Listenerやスペーシャルオーディオ音を出すGameObjectに、これを追加します。
公開プロパティの概要については、 AkRoomAwareObject をInspectorで使う を参照してください。

AkRoomPortal
AkRoomPortalは2つのAkRoomコンポーネントをつなげ、ルーム間で音が伝搬できるようにします。
その公開プロパティの概要については、 AkRoomPortal と AkRoomPortalObstruction をInspectorで使う を参照してください。

AkRoomPortalObstruction
現在のゲームオブジェクトのSpatial Audioポータルと、Spatial Audioリスナーの間に、1つ以上のオブジェクトがある場合は、そのSpatial Audioポータルからくるサウンドを、完全に妨げます。
その公開プロパティの概要については、 AkRoomPortal と AkRoomPortalObstruction をInspectorで使う を参照してください。

AkSpatialAudioDebugDraw
Spatial audioを使って音を出すゲームオブジェクトに、このスクリプトを追加します。このスクリプトは、現在のゲームオブジェクトから、Spatial audioリスナーまでの、アーリーリフレクションやディフラクションのパスをデバグ目的で描写します。
公開プロパティの概要については、 AkSpatialAudioDebugDraw をInspectorで使う を参照してください。

AkSpatialAudioListener:
リスナーを担うゲームオブジェクトに、このスクリプトを追加します。
その公開プロパティの概要については、 AkSpatialAudioListener をInspectorで使う を参照してください。

AkSurfaceReflector
GameObjectのジオメトリの三角形を、音を反射する面に変換するコンポーネントです。
公開プロパティの概要については AkSurfaceReflector をInspectorで使う を参照してください。

参照
  • Wwiseイベントのトリガーを追加する

コンポーネントのコード

Wwiseコンポーネントのコードを学ぶには、コンポーネントの設定ボタンを使い、該当するC::スクリプトを開きます。

あなたのWwise Unityインテグレーションプロジェクトで、カスタムスクリプトを書きたい場合は、 Wwise Types を使うことを推奨します。

参照
  • Wwiseコンポーネントの追加


Wwise Unity Integration Documentation: AkAmbient をInspectorで使う

AkAmbient をInspectorで使う
注記： AkAmbientはマルチポジショニングを許可することで、AkEventをビルドします。
  • Trigger On: あなたのWwise Eventをトリガーすることができる、Unityイベントのリストです。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。これ以外のイベントでも可能です。いつでもコードのどこからでも、 AkSoundEngine.PostEvent をコールしてイベントをトリガーできます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
  • Action On Event: Wwiseで定義されたイベントパラメータの一部を、Unityで直接オーバーライドできるようにします。そうすることで、新しいイベントを作成せず既存のものを再利用できます。
    チェックしていなければ、あなたがイベントをポストすることを意味します。Action On Eventを有効にすると、Use Callbackを有効にすることができません。 SDKドキュメントのAK::SoundEngine::ExecuteActionOnEventに関する記載も、合わせて参照してください。
    • Action On Event Type: イベントのActionタイプをオーバーライドします。
    • Curve Interpolation: インターポレーション（補間）カーブをオーバーライドします。
    • Fade Time: サウンドのフェードタイムをオーバーライドします。
  • Use Callback: 簡単に、ゲームオブジェクトをイベントのコールバックに反応させることができます。Action On Eventを有効にすると、Use Callbackを有効にすることができません。
    • Game Object: コールバックを受けるゲームオブジェクト。ゲームオブジェクトを選択するには、階層からドラッグしてゲームオブジェクトフィールドにドロップします。
    • Callback Function: このファンクションが、コールバックが発生した時にGame Objectからコールされます。ファンクションを選択するには、ファンクション名をCallback Functionテキストフィールドに入力します。 これが機能するにはGame Objectのコンポーネントの1つでCallback Functionを定義する必要があります。 このファンクションが受信できる AkEventCallbackMsg 引数は、1つだけです。
    • Callback Flags: Callback Functionをいつコールするのかを指定するフラグを選択します。同時に複数のフラグを選択できます。各フラグの詳しい情報については、Wwise ドキュメンテーション の AkCallbackType 一覧表を参照してください。
    • Add: 新しいコールバックを作成します。
  • Play / Stop: Editモードの時に、Wwiseイベントをプレビューするのに使います。
  • Stop All: すべての再生中のWwise Eventを停止します。
  • Position Type: イベントのポジションがどのようにAudioEngineに送信されるかを定義します。
    • Simple_Mode: イベントのポジションは、それがアタッチしているゲームオブジェクトと同じになります。
    • Large_Mode: イベントは、複数のポイントで定義された、複数のポジションを持つことができます。ポイントを追加するには、InspectorのAdd Large Modeポジションオブジェクトをクリックします。AkAmbientゲームオブジェクトに対し、子ゲームオブジェクトが追加され、通常のトランスフォームツールを使ってこれを動かせます。また、既存のゲームオブジェクトを使うには、AkAmbientLargeModePositionerコンポーネントをマニュアル操作で追加し、InspectorでPick existing position objectをクリックします。このモードは、同時に複数のポジションから1つのサウンドがくるときなどに便利で、海の真ん中にいるときの潮の音などが良い例です。
    • MultiPosition_Mode: このモードでは、同じイベントを使う AkAmbient のすべてのインスタンスのサウンドを、1つのインスタンスにして、 メモリを節約 します。このモードを利用する AkAmbient でイベントが同じものは自動的に検出され、同一サウンドを別々に何回もロードするのではなく、全てに同じサウンドインスタンスが使われます。
      注記： このモードで、同じイベントをもつ AkAmbient インスタンスはすべて、同じトリガーになります（ Trigger On in AkEvent 参照）。つまり1つの AkAmbient のトリガーを変更すると、ほかもイベントが同じであれば全て、トリガーが自動的に変更されます。
  • Show Attenuation Sphere: イベントによって再生されるサウンドの聞こえる範囲を定義する球体が表示されます。ただし、Editorで再生しても、これは見えません。
    これを作動させるには、あなたのWwiseプロジェクトのSoundBank設定で、 Max Attenuation を有効にする必要があります (Project > Project Settings > Soundbanks > Max attenuation) 。
    • Dont_Show: 減衰半球が表示されません。
    • Current_Event_Only: 現在のモード中に AkSoundEngine.PostEvent へのコールの後に再生される全てのサウンドの減衰球体が表示されます。
      • Simple_Modeの場合は、ゲームオブジェクトからくるサウンドの減衰半球のみが表示されます。
      • Large_Modeの場合は、全てのポイントのそれぞれの減衰カーブが表示されます。
      • MultiPosition_Mode の場合、同じイベントをもつ MultiPosition_Mode のAkAmbientが、1つおきに、減衰半球で表示されます。
    • All_Events: シーン内の全てのAkAmbientの減衰半球が表示されます。
  • Name: WwiseProject > Events ですでに定義されているイベントを1つ、クリックして選択します。新しいイベントを追加するには、Wwise Project ExplorerのEventsタブにある、 Create new 'Event' ボタンをクリックします。
注記： Position Typeを Large_Mode または MultiPosition_Mode とする場合は、考慮すべき制約事項がいくつかあります。 AkSoundEngine.SetMultiplePositions へのコールはあとになるので、サウンドを Awake でトリガーしないようにしてください。マルチポジショニングのこの2つのモードは、静的なオブジェクトに適しています。対象の UnityEngine.GameObjects をstaticに設定しておくことが、強く推奨されます。
参照
  • Wwise SDKドキュメンテーション: 統合の詳細 - 3D ポジション
  • AK::SoundEngine::SetMultiplePositions
  • AK::SoundEngine::SetPosition
  • Wwise Help: イベントの管理


Wwise Unity Integration Documentation: AkAudioListener をInspectorで使う

AkAudioListener をInspectorで使う
  • Is Default Listener: 選択したGameObjectをほかのGameObjectのリスナーとして設定し、ほかのリスナーを設定するコールによってオーバーライドされるまで、リスナーとして作用する。Default Listenerは、カメラなどの中心的なオブジェクトに適用されるのが一般的です。
参照
  • Wwise SDK doc: Wwiseにおけるリスナーの統合
  • Wwise-301: Audio Listener


Wwise Unity Integration Documentation: AkBank をInspectorで使う

AkBank をInspectorで使う
  • Load On: ゲームがSoundBankをロードするタイミングを指します。クリックし、以下の選択肢を1つ以上選択してください。
    • Start: シーンがロードしたとき。これがデフォルト設定で、通常のSoundBankロード方法です。
    • Nothing: Unityのデフォルトの選択肢で、使用を避けるべきです。
    • Everything: Unityのデフォルトの選択肢で、使用を避けるべきです。
    • Awake: 現在のゲームオブジェクトがアクティブになったとき。
    • Destroy: シーンが終了したとき。どちらかというとSoundBankのロードより、アンロードを対象としています。
    • AkTrigger の選択肢: AkTrigger の選択肢は複数あります。例えば AkTriggerEnter を適用し、プレイヤーがルームに入ったときにSoundBankをロードするようにできます。ルーム音が必要なときにSoundBankがロードされていなければ、サウンドに遅延が生じるリスクがあることを、考慮してください。SoundBankのロードにトリガーを使うことについて、その詳細はWwise 301の Loading SoundBanks using Triggers を参照してください。
  • Unload On: ゲームがSoundBankをアンロードするタイミング。クリックし、以下の選択肢を1つ以上選択してください。
    • Start: シーンをロードするとき。SoundBankのアンロードより、ロードを対象としています。
    • Nothing: Unityのデフォルトの選択肢で、使用を避けるべきです。
    • Everything: Unityのデフォルトの選択肢で、使用を避けるべきです。
    • Awake: 現在のゲームオブジェクトがアクティブになったとき。SoundBankのアンロードより、ロードを対象としています。
    • Destroy: シーンが終了したとき。これがデフォルト設定で、通常のSoundBankアンロード方法です。
    • AkTrigger の選択肢: AkTrigger の選択肢は複数あります。例えば AkTriggerExit は、プレイヤーがルームを出るときにSoundBankをアンロードするために適用できます。
  • Override Load Setting：Wwise Initialization Settings（Edit > Project Settings > Wwise Initialization）のLoad Bank Asynchronously設定をオーバーライドします。有効にすると、Load Bank Asynchronouslyの設定が表示され、このバンクの非同期ロードを選択できます。
  • Load Bank Asynchronously：すぐに LoadBank ファンクションコールを返し、 ロードリクエストが無事キューに入ったかどうかを示します。また、バックグラウンドで実際にロードしながら、ほかの操作を実行できるようにします。同期型バージョンでは、ロード完了を待つメインの処理スレッドをブロックします。非同期のコールは、すぐにロードする必要のない、大きなSoundBankに向いています。
    参照
    • LoadBankの非同期バージョンに関するSDK参照ドキュメント。
  • Decode compressed data: SoundBankの、VorbisやOpusの圧縮ファイルをすべて解凍します。
    参照
    • Wwise Help: オーディオフォーマットについて
    • Wwise SDK doc: バンクの準備
    • AK::SoundEngine::PrepareBank
  • Save decoded bank: 圧縮されていないファイルをディスクに保存し、SoundBankをアンロードしたあとに、より早くロードできるように準備しておきます。
  • Name: WwiseProject > Banks ですでに定義されているSoundBankを1つ、クリックして選択します。新しいSoundBankを追加するには、Wwise Project ExplorerのSoundBanksタブで、 Create new 'SoundBank' のボタンをクリックします。
参照
  • Wwise Help: SoundBankの管理
    • SoundBankを作成する
  • Wwise-301: Managing SoundBanks in Unity


Wwise Unity Integration Documentation: AkEmitterObstructionOcclusion をInspectorで使う

AkEmitterObstructionOcclusion をInspectorで使う

ゲームオブジェクトとそのリスナーの間に、別のオブジェクトがある場合に、GameObjectにAkEmitterObstructionComponentを追加し、リスナーに対してオブストラクションやオクルージョンを適用します。

エミッターがオブストラクションまたはオクルージョンの影響を受ける場合、AkEmitterObstructionOcclusionコンポーネントがSetObjectObstructionAndOcclusion()を、値を1として呼び出します。エミッターがオブストラクションカーブ（Obstruction Volume、Obstruction LPF、Obstruction HPF）と、オクルージョンカーブ（Occlusion Volume、Occlusion LPF、Occlusion HPF）を、 Wwise Project Settings で定義します。

あなたのマップにスペーシャルオーディオが使われていない場合（つまり AkRoom コンポーネントがない場合）は、 AkEmitterObstructionOcclusion コンポーネントは、あなたがWwiseで定義したオクルージョンカーブだけを使います。逆に、あなたのマップでスペーシャルオーディオを使っているのであれば、GameObjectは、Wwiseで定義されたオブストラクションカーブしか使いません。

  • Fade Time: フェードインやフェードアウトの秒数。
  • Layer Mask: どのレイヤがオブストラクションやオクルージョンとして機能しているのかを表します。
  • Max Distance: オブストラクションチェックやオクルージョンチェックを実行する、最長の距離。負の数であれば、距離は無限だと解釈します。
  • Refresh Interval: オブストラクションまたはオクルージョンのチェックを行う間隔を、秒数で表したもの。0であれば、オブストラクションまたはオクルージョンのチェックを無限に続けます。
注記： AkEmitterObstructionOcclusion は、スペーシャルオーディオの diffraction を使うのであれば、使用しないこと。
参照
  • A. エミッターのオブストラクションとオクルージョン
  • AK::SoundEngine::SetObjectObstructionAndOcclusion


Wwise Unity Integration Documentation: AkEnvironmentやAkEnvironmentPortalをInspectorで使う

AkEnvironmentやAkEnvironmentPortalをInspectorで使う

Unityインテグレーションでは、AkEnvironmentやAkEnvironmentPortalコンポーネントをゲームオブジェクトに適用できます。次にこれらのコンポーネントをWwise Effectを持つAuxiliary Busと関連付けて、サウンドの環境エフェクトをシミュレートできます。ここでは、これらのコンポーネントを使用してリバーブエフェクトをシミュレートする方法について説明します。同じ原理をほかのタイプのエフェクトにも適用できます。

TIP： Spatial Audioを使用してするリバーブを実装するという方法もあります。詳細は次のトピックを参照。
  • AkRoom をInspectorで使う
  • AkReverbZone
  • Unityで、Spatial Audio

このトピックの例は Wwiseデモシーン に記載されており、Audiokinetic Launcherを使用してダウンロードできます（Unityを参照）。

前提条件

Unityシーンに環境コンポーネントや環境ポータルコンポーネントを追加する前に、Wwise AuthoringでAuxiliary Busを作成してエフェクトを適用し、SoundBankを生成する必要があります。

バスに関する詳細は、Adding Busses in the Master-Mixer HierarchyおよびApplying Effects to Bussesを参照してください。

リバーブエフェクトの場合、どのようなリバーブプラグインでもバスに適用できます。

  • Matrix Reverb
  • AK Convolution Reverb
  • RoomVerb

AkEnvironmentコンポーネントを追加する

AkEnvironmentコンポーネントは単純な環境ゾーンを表します。AkEnvironmentコンポーネントは、あらゆる種類のコライダーに添付できます。

AkEnvironmentコンポーネントをシーンに追加する方法は3通りあります。 Wwise Picker またはAdd Componentメニューから追加するか、C::スクリプトを使用します。

Wwise PickerからAkEnvironmentコンポーネントを追加するには、次の手順を実行します。

  1. 目的のリバーブエフェクトを持つAuxiliary BusをWwise Pickerで見つけます。
  2. Unityでシーン内のオブジェクトを選択します。Inspectorにオブジェクトプロパティが表示されます。

  3. AUXバスをWwise PickerからInspectorまでドラッグします。

    AUXバスの名前が付けられたAkEnvironmentコンポーネントがオブジェクトに追加されます。

Add ComponentメニューからAkEnvironmentコンポーネントを追加するには、次の手順を実行します。

  1. シーン内のオブジェクトを選択します。Inspectorにオブジェクトプロパティが表示されます。
  2. Inspectorの下部でAdd Component > Wwise > AkEnvironmentの順にクリックします。AkEnvironmentコンポーネントがオブジェクトに追加されます。
  3. 別のAuxiliary Busを選択するには、NameをクリックしてAuxiliary Busウィンドウを開きます。次にバスを選択してOKをクリックするか、該当するバスをダブルクリックします。あるいは、Auxiliary BusをWwise Pickerから現在のAuxiliary Bus名までドラックします。

C::スクリプトを使用してAkEnvironmentコンポーネントを追加するには、次を実行します。

  • AkSoundEngine.SetGameObjectAuxSendValues() を必要に応じてコールします。

AkEnvironmentコンポーネントのプロパティ

1つのシーンまたは1つのAkGameObjで同時にアクティブにできるAkEnvironmentコンポーネントの数は最大4つです。

AkEnvironmentコンポーネントには次のプロパティがあり、Inspectorから設定できます。

  • Priority: その環境のプライオリティを定義する。最も小さい数字（0）のプライオリティが最も高くなります。
    ゲームオブジェクトが5つ以上の環境の中にある場合は、最もプライオリティの高い4つの環境のみがアクティブになります（ DefaultフラグやExclude Othersフラグが設定されていなければ）。
  • Default：デフォルト環境は、そのゲームオブジェクトを含む環境がほかにない場合に限りアクティブになります。
    ゲームオブジェクトが2つ以上のデフォルト環境の中にある場合は、最もプライオリティの高い1つの環境のみがアクティブになります。
  • Exclude Others：このフラグの立っている環境は、他の環境に重複されることはありません。
    ゲームオブジェクトがExclude Othersフラグの立っている環境の中にある場合は、他の環境はすべて棄却されます。
    ゲームオブジェクトがExclude Othersフラグの立っている2つ以上の環境の中にある場合は、最もプライオリティの高い1つの環境のみがアクティブになります。
  • Name：関連付けられているAuxiliary Busの名前。

AkEnvironmentPortalコンポーネントを追加する

ポータルを使用して2つの環境のエフェクトを統合できます。両者の環境が貢献するレベルは、ゲームオブジェクトからそれぞれの環境への距離に応じます。 例えばゲームオブジェクトが2つの部屋の間に立っている場合や、2つの環境をつなぐトンネル内にいる時などに便利です。

プロジェクトに環境ポータルを追加するには、次の手順を実行します。

  1. UnityメニューバーでGameObject > Wwise > Environment Portalの順にクリックします。環境ポータルオブジェクトがプロジェクト階層に追加されます。

AkEnvironmentPortalコンポーネントのプロパティ

2つの環境の間に環境ポータルを設定して、ゲームオブジェクトがそのポータルの中にある間は両者のエフェクトを統合することができます。ポータルは両者の環境と交差する必要があります。それぞれの環境が貢献するレベルは、ゲームオブジェクトから環境への距離に応じます。ゲームオブジェクトが1つの環境に近ければ近いほど、その環境の最終的なエフェクトに対する影響が強くなります。

AkEnvironmentPortalコンポーネントには次のプロパティがあり、Inspectorから設定できます。

  • Environment #1：ポータルは、そのポータルに交差するすべての環境を自動的に検知します。ポータルの負の側に位置する環境（つまり選択された軸と反対方向にある環境）がドロップダウンメニューに表示されます。
  • Environment #2：ポータルの正の側に位置する環境（つまり選択された軸と同一方向にある環境）がドロップダウンメニューに表示されます。
  • Axis：環境ごとの貢献レベルを決定するための軸。例えばZ軸を選択すると、X軸方向の移動は環境の貢献レベルを左右しません。Z軸方向の移動のみが貢献レベルを左右します。
    注記： Axisは、オブジェクトスペース内にあります。このため、ポータルを回転させると、軸も回転します。

環境や環境ポータルを利用する

環境や環境ポータルを利用するには、環境を意識できる AkGameObj コンポーネントを有するゲームオブジェクトが必要です。 AkEnvironmentPortalオブジェクトは、重なっているAkEnvironmentオブジェクトを自動的に検知します。重複する環境はポータルのInspectorにある2つの選択リストに表示されます。

ポータルに重複する環境が多すぎる場合は、ポータルで統合する環境を選択できます。1つのゲームオブジェクトで同時にアクティブにできるAkEnvironmentの数は最大4つです。環境ポータルの場合、その4つのAkEnvironmentは以下のように選択されます。

  • ポータルに接続されている環境で最もプライオリティの高いものが順に4つまで、またはそれ以上にポータルに接続されている環境がなくなるまで、選択されます。
  • 接続されている環境が4つ未満の場合、次の基準に従ってシーン内で接続されていない環境の中から選択されます。
    • 最もプライオリティの高い環境が順に4つまで選択されます（DefaultフラグやExclude Othersフラグが設定されていなければ）。
    • Default環境は、他の環境が一切選択されていない場合に限り、選択されます。
    • ゲームオブジェクトがExclude Othersフラグの立っている環境の中にある場合はその環境が選択されて、他の環境はすべて棄却されます。
参照
  • Wwise SDK doc: 環境とゲーム定義Auxセンドの統合
  • AK::SoundEngine::SetGameObjectAuxSendValues


Wwise Unity Integration Documentation: AkEvent をInspectorで使う

AkEvent をInspectorで使う
注記： AkAmbientはマルチポジショニングを許可することで、AkEventをビルドします。
  • Trigger On: このWwise Eventを設定できるUnityイベントのリストが表示されます。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。これ以外のイベントでも可能です。いつでもコードのどこからでも、 AkSoundEngine.PostEvent をコールしてイベントを設定できます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
    • Action On Event: Wwiseで定義されたイベントパラメータの一部を、Unityで直接オーバーライドできるようにします。そうすることで、新しいイベントを作成せず既存のものを再利用できます。
      チェックしていなければ、あなたがイベントをポストすることを意味します。Action On Eventを有効にすると、Use Callbackを有効にすることができません。 SDKドキュメントのAK::SoundEngine::ExecuteActionOnEventに関する記載も、合わせて参照してください。
      • Action On Event Type: イベントのActionタイプをオーバーライドします。
      • Curve Interpolation: インターポレーション（補間）カーブをオーバーライドします。
      • Fade Time: サウンドのフェードタイムをオーバーライドします。
    • Use Callback: 簡単に、ゲームオブジェクトをイベントのコールバックに反応させることができます。Action On Eventを有効にすると、Use Callbackを有効にすることができません。
      • Game Object: コールバックを受けるゲームオブジェクト。ゲームオブジェクトを選択するには、階層からドラッグしてゲームオブジェクトフィールドにドロップします。
      • Callback Function: このファンクションが、コールバックが発生した時にGame Objectからコールされます。ファンクションを選択するには、ファンクション名をCallback Functionテキストフィールドに入力します。 これが機能するにはGame Objectのコンポーネントの1つでCallback Functionを定義する必要があります。 このファンクションが受信できる AkEventCallbackMsg 引数は、1つだけです。
      • Callback Flags: Callback Functionをいつコールするのかを指定するフラグを選択します。同時に複数のフラグを選択できます。各フラグの詳しい情報については、Wwise ドキュメンテーション の AkCallbackType 一覧表を参照してください。
      • Add: 新しいコールバックを作成します。
  • Play / Stop: Editモードの時に、Wwiseイベントをプレビューするのに使います。
  • Stop All: すべての再生中のWwise Eventを停止します。
  • Name: Wwise Picker の WwiseProject > States ですでに定義されているEventを1つ、クリックして選択します。新しいイベントを追加するには、Wwise Project ExplorerのEventsタブにある、 Create new 'Event' ボタンをクリックします。
参照
  • AK::SoundEngine::SetPosition
  • Wwise Help: イベントの管理


Wwise Unity Integration Documentation: AkGameObj をInspectorで使う

AkGameObj をInspectorで使う
  • Apply Position Offset: ゲームオブジェクトに2つ目のTransformを適用することで、ゲームオブジェクトの実際のポジションとは別に、オーディオ計算によるポジションを指定します。
    • Position Offset ゲームオブジェクトの2つ目のTransformのポジションを、X（左右）、Y（上下）、Z（前後）の各フィールドに入力したゲームユニット数に従い、移動させます。
    • Hide Main Transform もとのTransformをビューから消し、オフセット後のものだけが見えるようにします。
  • Envrionment Aware: このゲームオブジェクトのオーディオが、環境、ルーム、ポータルに左右されるように設定します。設定する場合は、 AkGameObj に Rigidbody が必要です。
    注記： この設定は、シーンをプレイする前にチェックを入れた場合のみ、効力があります。
    • Add Rigidbody GameObject上に、Rigidbodyコンポーネントを作成します。
  • Use Default Listeners: Default Listenerは、カメラなどの中心的なオブジェクトに適用されるのが一般的です。すべてを聞き取ります。
    • Add Listener 別のリスナーの登場を指定します。セレクタをクリックしてSelect AkAudioListenerダイアログを表示させ、AkAudioListener のあるゲームオブジェクトを選択します。
      注記： リスナーは、必ず必要です。デフォルトのリスナーを使わず、別のリスナーも指定していない場合は、通常はWwise Settingsダイアログ (Edit > Project Settings > Wwise Editor) が活躍し、デフォルトで "Automatically add Listener to Main Camera" というAsset Management設定が適用されます。
参照
  • AkEnvironmentやAkEnvironmentPortalをInspectorで使う
  • SDK doc: Wwiseでリスナーを統合する


Wwise Unity Integration Documentation: Ak Listener Distance Probeコンポーネントを使い、サードパーソンゲームのリスナーをカスタマイズする

Ak Listener Distance Probeコンポーネントを使い、サードパーソンゲームのリスナーをカスタマイズする
注記： 次の例に進む前に、WwiseにおけるDistance Probe使用の概要についてWorking with Listeners in Third-Person Perspective Gamesを参照してください。

以下の例は三人称視点のゲームとして設定されたUnityプロジェクトがお手元にあることを前提としています。リスナーに使用するカメラGameObjectと、Distance Probeにアサインするプレイヤーキャラクターまたはその他のGameObjectが必要です。デフォルトでAk Audio Listenerコンポーネントがメインカメラに追加されます。

  1. Distance ProbeをアサインするGameObjectに移動します。一般的にプレイヤーキャラクターGameObjectにアサインします。
    1. GameObjectにAk Game Objコンポーネントがアタッチされていることを確認します。このコンポーネントを追加するためには、InspectorでAdd ComponentをクリックしてAk Game Objを選択します。

  2. リスナーとして使用するカメラGameObjectに移動します。

    1. InspectorでAdd Componentをクリックします。Ak Listener Distance Probeを選択します。Ak Audio ListenerスクリプトやAk Game Objスクリプトがまだ存在しない場合、どちらも自動的にGameObjectに追加されます。
    2. InspectorでAk Listener Distance Probeコンポーネントに移動します。Distance Probeフィールドをクリックし、Distance Probeとして使用するAk Game Objをアサインします。
      • 希望するGameObjectが選択メニューに表示されない場合は、Ak Game Objコンポーネントをアサインしていないためです。手順1を参照してください。

Wwiseオーサリングツールを使用してゲームに接続し、Distance Probeが正しく設定されていることを確認します。詳細はProfiling the Distance Probeを参照してください。


Wwise Unity Integration Documentation: Using AkState をInspectorで使う

Using AkState をInspectorで使う
  • Trigger On: あなたのStateをトリガーすることができる、Unityイベントのリストです。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。これ以外のイベントでも可能です。いつでもコードのどこからでも、 AkSoundEngine.SetState をコールしてStateをトリガーできます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
  • Name: Wwise Picker の WwiseProject > States ですでに定義されているStateを1つ、クリックして選択します。新しいStateを追加するには、Wwise Project ExplorerのGame Syncsタブで、 Create new 'State' のボタンをクリックします。
参照
  • Wwise Help: Stateの活用
    • Stateの作成
  • Wwise SDK doc: 統合の詳細 - State（ステート）
  • AkSoundEngine.SetState()


Wwise Unity Integration Documentation: AkSwitch をInspectorで使う

AkSwitch をInspectorで使う
  • Trigger On: あなたのSwitchをトリガーすることができる、Unityイベントのリストです。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。これ以外のイベントでも可能です。いつでもコードのどこからでも、 AkSoundEngine.SetSwitch をコールしてSwitchをトリガーできます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
  • Use Other Object: このプロパティが役立つのは、コライダーと合わせて使う時だけです。これを有効にすると、Actionの対象が、衝突するもうひとつのオブジェクトになります。無効にすると、現在のオブジェクトが対象です。
  • Name: Wwise Picker の WwiseProject > Switches ですでに定義されているSwitchを1つ、クリックして選択します。新しいSwitchを追加するには、Wwise Project ExplorerのSoundBanksタブで、 Create new 'Switch' のボタンをクリックします。
参照
  • Footstepsデモ
  • Wwise Help: Switchの使い方
    • Switchの作成
  • Wwise SDK doc: 統合の詳細 - Switch（スイッチ）
  • AkSoundEngine.SetSwitch()


Wwise Unity Integration Documentation: Inspectorの AkEarlyReflections

Inspectorの AkEarlyReflections

AkEarlyReflections は、任意のコンポーネントです。ゲームオブジェクトが出す全てのサウンドの、アーリーリフレクション（Early reflection）を有効にするコンポーネントです。これが SetEarlyReflectionsAuxSend() と、 SetEarlyReflectionsVolume() をコールします。

アーリーリフレクションは、AuthoringアプリケーションのSound Property Editorで、サウンドごとに個別に有効にすることもできます。なお、Authoringアプリケーションでサウンドに設定したReflect Auxiliary Busの方が、 AkEarlyReflections コンポーネントで定義したアーリーリフレクションよりも、必ず優先されます。

  • Reflections Aux Bus 現在のゲームオブジェクトに、アーリーリフレクションのAuxバスを設定します。このコンポーネントは、選択されたAuxバスで AK::SpatialAudio::SetEarlyReflectionsAuxSend() をコールします。Auxバスのパラメータは、ゲームオブジェクトで再生中のサウンドのうち、オーサリングツールでアーリーリフレクションのAuxバスを指定していないサウンドに適用されます。サウンドに個別に指定したアーリーリフレクションのAuxバスのパラメータが、ここでパスされる値よりも優先されます。
  • Reflections Volume 現在のゲームオブジェクト用に、アーリーリフレクションのセンドボリュームを設定します。これは、アーリーリフレクションのセンドのボリュームを制御するために使います。このコンポーネントは、入力したボリューム値で AK:SpatialAudio::SetEarlyReflectionsVolume() をコールします。この値とオーサリングツールで指定したアーリーリフレクションのボリュームを合算し、ゲームオブジェクトで再生中のすべてのサウンドに適用します。有効値は、[0, 1]です。ボリュームを0に設定すると、このゲームオブジェクトのリフレクション処理が、すべて無効になります。

このコンポーネントには、反射面も必要です。詳細は、 AkSurfaceReflector と AkSurfaceReflector をInspectorで使う を参照してください。


Wwise Unity Integration Documentation: InspectorのAkRadialEmitter

InspectorのAkRadialEmitter

これは放射状のエミッターをシミュレーションするために、ゲームオブジェクトに内半径（Inner Radius）と外半径（Outer Radius）を追加するコンポーネントです。サウンドのスプレッドは、内半径と外半径や、エミッターとリスナーの間の距離に基づいて、自動的に計算されます。減衰カーブを適用するときに採用される距離は、リスナーから、内半径の球体面の最も近い点までの距離です。

このコンポーネントが、指定したOuter Radius値とInner Radius値のパラメータで AK:SpatialAudio::SetGameObjectRadius() をコールします。

注記： これはSpatial Audioだけで使う機能なので、シーン内に AkSpatialAudioListener がなければなりません。
  • Outer Radius: 希望する外半径をこのフィールドに設定します。設定した数字は変更されず、そのまま直接Spatial Audioコールに送られます。Gizmoを有効にした状態で現在のゲームオブジェクトを選択すると、ゲームオブジェクトのポジションの周りに黄色い球体が表示され、入力した大きさが可視化されます。
  • Inner Radius: 希望する内半径をこのフィールドに設定します。内半径は、必ず外半径より小さくします。設定した数字はほかに変更されず、そのまま直接Spatial Audioコールに送られます。Gizmoを有効にした状態で現在のゲームオブジェクトを選択すると、ゲームオブジェクトのポジションの周りに黄色い球体が表示され、入力した大きさが可視化されます。

AkRadialEmitter のあるゲームオブジェクトを、 AkAmbient コンポーネントのLarge_Modeポジションタイプで使う場合は、半径が全てのポジションに追加されます。AkRadialEmitterはマルチポジションにも対応しています。


Wwise Unity Integration Documentation: AkReverbZoneをInspectorで使う

AkReverbZoneをInspectorで使う

Reverb Zoneとその親のRoom間では、同じRoomのようにサウンドが伝播するため、Portalを接続する必要はありません。

  • Reverb Zone：Reverb Zoneとして設定するAkRoomコンポーネントをクリックして選択します。AkReverbZoneコンポーネントがAkRoomコンポーネントを持つゲームオブジェクトに追加されると、 このプロパティはそのAkRoomコンポーネントに基づき自動的に入力されます。
  • Parent Room：Reverb Zoneの親として設定するAkRoomコンポーネントをクリックして選択します。親Roomは複数のReverb Zoneを持つことができますが、Reverb Zoneが持つことができる親は1つだけです。Roomがそれ自身の親になることはできません。このプロパティの設定をNoneのままにすると、自動的に作成された「Outdoors」RoomにReverb Zoneがアタッチされます。
  • Transition Zone Width：Reverb Zoneとその親Room間のトランジションゾーン幅が該当する値になるようスライダを設定します。トランジションゾーンはReverb Zoneジオメトリを中心としてその周りにあります。これが適用されるのは、三角形透過損失が0に設定されている場合のみです。
参照
  • AkRoom
  • AkRoomPortal


Wwise Unity Integration Documentation: AkRoom をInspectorで使う

AkRoom をInspectorで使う

ルーム（Room）はSpatial Audioの基礎となるもので、あらゆる Spatial Audioのコンセプト において、重要な役割を担っています。

  • Reverb Aux Bus: Wwise Picker の WwiseProject > AuxiliaryBusses ですでに定義されているAuxiliary Busを1つ、クリックして選択します。新しいAuxiliary Busを追加するには、Master-Mixer HierarchyでAudio Busを選択してから、Wwise Project ExplorerのAudioタブで、 Create new 'Auxiliary Bus' ボタンをクリックします。
  • Reverb Level: スライダーを設定するかフィールドに直接入力し、Auxiliary Busの Auxliary SendsのVolumeに対する倍数として（Aux Sendなしの0から1まで、第7小数点まで）設定します。例えば大きいルームと小さいルームでAuxiliary Busをそれぞれ設定してあれば、小さいルームのリバーブの方は、相対的に聞こえないので、そのボリュームレベルを抑えることが多いでしょう。
  • Transmission Loss: スライダーを設定するかフィールドに直接入力（0～1）し、このルームの透過損失値を設定します。透過損失は、音が障害物を通るときのエネルギーの消散をシミュレーションするために使います。透過に、オクルージョンを使う場合（あなたの Spatial Audio Initialization Settings で確認できます）は、透過損失値に、あなたの Wwise Project Settings にある全てのOcclusionカーブ（Occlusion Volume、Occlusion LPF、Occlusion HPF）を使い、サウンドをフィルターします。例えば、Transmission Lossが0.75であれば、それはWwiseのOcclusionグラフで、Occlusion軸の75に相当するので、下図の場合は-12.0 dBとなります。
    一般的に、小さい透過損失は薄い壁向きで、大きい透過損失は厚くて空洞のない壁向きです。
  • Priority: 1つのゲームオブジェクトが2つ以上のルームにある時に、ルームがAK::SpatialAudio::SetGameObjectInRoom()に選択される優先順位を設定します。ここで、番号が大きい方がプライオリティが高くなります。例えば、Priorityが2のルームを、Priorityが1のルームよりも優先します。

RoomのTone

  • Trigger On: あなたのWwise Eventをトリガーすることができる、Unityイベントのリストです。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。これ以外のイベントでも可能です。いつでもコードのどこからでも、 AkSoundEngine.PostEvent をコールしてEventをトリガーできます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
  • Room Tone Event: Wwise Picker の WwiseProject > Events ですでに定義されているEventを1つ、クリックして選択します。新しいイベントを追加するには、Wwise Project ExplorerのEventsタブにある、 Create new 'Event' ボタンをクリックします。選択したEventが、ルームのゲームオブジェクトに適用されます。
  • Room Tone Aux Send: スライダーを設定するかフィールドに直接入力し、ルームのゲームオブジェクトにポストされたサウンドの音量を指定しますが、このとき、0はAux sendが無効になり、1は最大の値が設定されます。

ルームの境界線を決定するのは、AkRoomコンポーネントと同じゲームオブジェクトにつくコライダーです。このコライダーのあるトリガーはルーム内のほかのゲームオブジェクトにAK::SpatialAudio::SetGameObjectInRoom()を設定します。

ルームは、ウェットサウンドを壁を通して伝えることもできます。ルームの形状は、ポータル周りにつくられるバウンディングボックスによって定義されます。また、ルームにジオメトリを関連付けることで、ルームの形状を指定することもできます。Unityのルームのコライダーの形状や、同じゲームオブジェクトに存在するAkSurfaceReflectorコンポーネントによって、自動的にジオメトリをルームに関連付けることができます。

以下のような動作となります:

  • AkSurfaceReflectorコンポーネントがなく、コライダーがメッシュ、ボックス、スフィア、またはカプセルである場合は、AkRoomコンポーネントが、ルームの範囲を決めて可視化するためだけに、Spatial Audioに送るジオメトリをコライダー形状から作成します。カプセルの場合は、ボックス形状のメッシュを送ります。このジオメトリは、 Game Object 3D Viewer に表示されます。ほかのジオメトリと同じように表示されますが、ルームであることが分かるように色別されています。
  • 有効なAkSurfaceReflectorコンポーネントがある場合は、そのIDが、 AkRoomParams に直接追加され、ジオメトリがルームに関連付けられます。
    注記： AkSurfaceReflectorコンポーネントのメッシュは、ルームのコライダーと似ている方が好都合です。ルームのコライダーを使い、ルーム内のゲームオブジェクトを設定します。両者のボリュームが異なると、ルーム内にとどまるものと、ルームから透過するもので、矛盾が生じます。さらに、 Game Object 3D Viewer に表示されるルーム周りのジオメトリが、ルーム内にあるととらえられるゲームオブジェクトのボリュームと、異なってしまいます。
  • 2つの条件のどちらも該当しない場合は、Inspectorに警告が表示されます。

その結果、Wwiseでは、関連付けられたジオメトリの頂点を使ったバウンディングボックスが構築されます。このボリュームが、スプレッドに影響します。このボリュームの外側では、ルームのウェットサウンドの透過のスプレッドが、角度0度から180度までの範囲内となります。ボリューム内では、100に達します。このボリュームを、ルームのExtent（範囲）と呼びます。これを Game Object 3D Viewer に表示させるには、 Game Object 3D Viewer Settings でRoom Extentを有効にします。

参照
  • Unityで、Spatial Audio
    • ルームやポータルに関するチュートリアル
      • B. Room
  • AkRoom
  • AkRoomParams
  • Rooms and Portal Documentation
  • Wwise Help: プロジェクトのオブストラクションやオクルージョンの、カーブ設定
  • トランスミッション
  • Room Transmission


Wwise Unity Integration Documentation: AkRoomAwareObject をInspectorで使う

AkRoomAwareObject をInspectorで使う

Rigidbody

  • AkRoomAwareObject コンポーネントのあるGameObjectと、 AkRoom コンポーネントのあるGameObjectがやり取りするには、少なくともどちらか一方に、Rigidbodyコンポーネントが必要です。1つ追加するには、Add Rigidbodyボタンをクリックします。

Collider

  • AkRoomAwareObject コンポーネントのあるGameObjectsには、Colliderコンポーネントが必要です。GameObjectが入っているルームを特定し、AK::SpatialAudio::SetGameObjectInRoom()関数を呼び出し、Spatial Audioに対してこの情報を送信する必要があります。GameObjectのコライダーがAkRoomコンポーネントのコライダーと重なると、すぐにルームにGameObjectが設定されます（このルームがGameObjectが現在いるルームよりも優先順位が高い場合）。GameObjectのコライダーを適宜、拡大縮小します。0に拡大縮小することを推奨します。
参照
  • Unityで、Spatial Audio
    • ルームやポータルに関するチュートリアル


Wwise Unity Integration Documentation: AkRoomPortal と AkRoomPortalObstruction をInspectorで使う

AkRoomPortal と AkRoomPortalObstruction をInspectorで使う

ポータル（Portal）は Spatial Audio において、重要な役割を担っています。このIntegrationは、ポータルに関して、 AkRoomPortal とそれを補助する（ただし必須でない） AkRoomPortalObstruction の、2つのWwiseコンポーネントを提供します。

AkRoomPortal

  • Initial State: ポータルの最初の開閉状態を設定します。
    • Open On: ポータルを開くUnityイベントのリストが表示されます。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。
    • Close On: ポータルを閉じるUnityイベントのリストが表示されます。複数のUnityイベントを選択することが可能で、その場合はフィールドに "Mixed…" と表示されます。また、トリガーのコードを自分で書いて、同僚のリストにも表示されるようにできます。 Wwiseイベントのトリガーを追加する を参照してください。また、 SDK doc: ルームとポータルを使用する も参照してください。
  • Back Room AkRoomPortal が、2つの ルーム をつなぎます。Back Room はポータルの負の側（ローカルのZ軸方向の逆向き）にある、最もプライオリティの高い、アクティブで、有効なルームです。ルームを無効にすると、ランタイムに選択されません。
  • Front Room AkRoomPortal が、2つの ルーム をつなぎます。Front Room はポータルの正の側（ローカルのZ軸方向と同じ向き）にある、最もプライオリティの高い、アクティブで、有効なルームです。ルームを無効にすると、ランタイムに選択されません。

AkRoomPortalObstruction

これは、あるオブジェクトがポータルとリスナーの間のパスを妨げている場合に、ポータルからくるサウンドにオブストラクションを適用するための、任意のコンポーネントです。もし回折（Diffraction）を有効にしたAkSurfaceReflectorを、妨害するオブジェクトに追加することが可能かつ望ましければ、その方がより正確な回折フィルターを確立できます。 AkSurfaceReflector をInspectorで使う を参照してください。

現在のGameObjectとスペーシャルオーディオリスナーの間に、1つ以上のオブジェクトがある場合に、 SetPortalObstructionAndOcclusion() へのコールを通して、オブストラクション（障害物）となります。現在のGameObjectとスペーシャルオーディオリスナーとの間にオブジェクトが存在する場合、このスクリプトがSetObjectObstructionAndOcclusion()をオブストラクション値を1として呼び出します。

AkRoomPortalObstructionを追加できるのは、すでにAkRoomPortalコンポーネントのあるGameObjectだけです。また、スペーシャルオーディリスナーが登録されていなければ、オブストラクションは起きません。

  • Fade Time: フェードインやフェードアウトの秒数。
  • Layer Mask: どのレイヤが障害物として機能しているのかを表します。
  • Max Distance: オブストラクションを実行する、最長の距離。負の数であれば、距離は無限だと解釈します。
  • Refresh Interval: オブストラクションのチェックを行う間隔を、秒数で表したもの。0であれば、オブストラクションのチェックを無限に続けます。
注記： AkRoomPortalObstruction は、スペーシャルオーディオの diffraction を使うのであれば、使用しないこと。
参照
  • A. エミッターのオブストラクションとオクルージョン
  • Unityで、Spatial Audio
    • ルームやポータルに関するチュートリアル
      • C. Portal
  • Wwise Help: User-Defined Auxiliary Sendを使う
  • Wwise Help: Game-Defined Auxiliary Sendを使う
  • SDK doc: ObstructionとOcclusion v.s. PortalのTransmissionとDiffraction
  • AkPortalParams
  • SetPortalObstructionAndOcclusion()


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw をInspectorで使う

AkSpatialAudioDebugDraw をInspectorで使う
  • Draw First Order Reflections 1つの面に当たったときに発生する、リフレクションの線を描写します。
  • Draw Second Order Reflections 音がリスナーに到達するまでに2つの面に当たったことで起きた、リフレクションの線を描写します。
  • Draw Higher Order Reflections 音がリスナーに到達するまでに3面以上に当たったことで起きた、リフレクションの線を描写します。
    警告： 生成されるリフレクションの数は、次数が増えるにつれ、急激に増加します。
  • Draw Diffraction Paths ジオメトリの有効なディフラクションを、線で描きます。
参照
  • Geometry APIを使用した回折シミュレーション
  • AK::SpatialAudio::SetReflectionsOrder
  • AkSpatialAudioInitSettings


Wwise Unity Integration Documentation: AkSpatialAudioListener をInspectorで使う

AkSpatialAudioListener をInspectorで使う

Spatial Audioリスナーを追加し、あなたのゲームでSpatial Audioが使えるようにします。オブジェクトに AkAudioListener が設定されていなければ、 AkSpatialAudioListener に必要なので、インテグレーションによって自動的に追加されます。

通常はCameraオブジェクトやPlayerオブジェクトに追加しますが、どのゲームオブジェクトにも追加できます。

スクリーンショットの警告文にもある通り、 Spatial Audioは、1つのアクティブな AkSpatialAudioListener にしか対応しません。どこで適用するのか、注意してください。

参照
  • Unityで、Spatial Audio
    • 3. Unityプロジェクトの準備


Wwise Unity Integration Documentation: AkSurfaceReflector をInspectorで使う

AkSurfaceReflector をInspectorで使う

このコンポーネントは、 geometry を Spatial Audio に送ります。音の伝搬の回折や透過に利用でき、Wwise Reflectプラグインがあれば、アーリーリフレクションのシミュレーションにも利用できます。

  • Mesh Early reflection、Diffraction、Transmissionに使うメッシュ。Noneのままにすると、GameObjectのMeshFilterコンポーネントのメッシュが、適切であれば、使われます。
  • Acoustic Textures Wwise Picker で、 WwiseProject > VirtualAcoustics で定義済みのAcoustic Textureから、サブメッシュ用に1つずつ選択します。新しいAcoustic Textureを追加するには、 Virtual Acoustics内のWork Unitまたはフォルダを選択してから、Wwise Project ExplorerのShareSetsタブで、Create new 'Acoustic Texture' ボタンをクリックします。フィルタされていないEarly reflectionにしたい場合は、 Noneのままにします。
  • Transmission Loss Values 各サブメッシュの透過損失値を、0～1の範囲で選択します。一般的に、設定値が1.0であれば完全な損失を意味し、設定値が0.0であれば、その音がフィルターなしでジオメトリを透過することを意味します。
  • Enable Diffraction メッシュのエッジに、ジオメトリの回折を設定します。
  • Enable Diffraction On Boundary Edgesバウンダリーエッジに、ジオメトリの回折を設定します。バウンダリーエッジとは、1つの三角形だけに接するエッジです。
  • Associated Room（非推奨）このAkSurfaceReflectorコンポーネントをRoomと関連付けます。このプロパティは非推奨になったため、今後のバージョンで削除される予定です。このプロパティは使用せず、Noneのままにすることを推奨します。AkSurfaceReflectorを特定のRoomと関連付けると、ジオメトリの範囲が制限されます。このことにより、反射や回析の計算時に実行されるレイキャストのサーチ対象範囲を狭めることができます。Noneに設定すると、このジオメトリにはグローバルスコープが割り当てられます。1つ以上のジオメトリセットが1つのルームに関連付けられている場合、そのルームはグローバルスコープ内のジオメトリにアクセスできなくなるため注意してください。
参照
  • Unityで、Spatial Audio
    • Surface Reflectorチュートリアル
    • A. Surface Reflectorと、Portal
  • Wwise ヘルプ: Wwise Reflect - Acoustic Textures
  • Wwise ヘルプ: Wwise Reflect - Diffractionの使い方
  • Wwise SDK doc: Spatial Audio - Diffraction
  • AK::SpatialAudio::SetGeometry


Wwise Unity Integration Documentation: Wwiseイベントのトリガーを追加する

Wwiseイベントのトリガーを追加する

Unityで使うWwiseコンポーネントの大部分に"Trigger On"プロパティが設定されていて、そこからそのWwiseコンポーネント（Event、Switch、Stateなど）をトリガーするUnityのノティフィケーションやイベントを選択できます。このリストは、Unityで可能な内容の一部しか表示していません。ただしトリガーシステムは拡張可能で、Integrationコード自体を修正する必要もありません。

新しいトリガーを追加するには、 AkTriggerBase から派生するC::クラスを書くだけです。AkTriggerBaseから派生するクラスは全て、反射で見つけられ"Trigger On"ドロップリストに追加されます。このクラスにデリゲート（代理）であるtriggerDelegate(GameObject in_target)が含まれ、トリガー条件が発生した時にこれをコールする必要があります。"target"オブジェクトは必須ではなく、現在はColliderと使う時にコライドするオブジェクトを提供するために使用されます。これにより、WwiseコンポーネントがイベントをColliderに対してではなくコライドの対象にPostできます。

もちろん必須ではありませんが、このシステムを利用してゲームコードからオーディオコンポーネントをトリガーすることもできます。トリガーが発生するたびに（またはカスタムファンクションのたびに）、コードから GetComponent<YourTriggerClass>().triggerDelegate(GameObject in_target) をコールするだけです。

注記： 現在の AkTriggerBase の派生クラス数の上限は、32です。

これは、カスタムファンクションを使った例です:

public class TriggerOnGunHit : AkTriggerBase
{
void Hit()
{
if(triggerDelegate != null)
{
triggerDelegate(null);
}
}
}

ゲームコードから、このコードを得ることができます:

if (playerIsShot)
{
GetComponent<TriggerOnGunHit>().Hit();
}

これでTriggerOnGunHitトリガーにリンクされたWwiseコンポーネントは全て、自分の責任を果たせます。なお、これは単純な場面ではやりすぎの可能性が高く、別の方法として単純に AkSoundEngine.PostEvent("GunHit", gameObject) からベースWwise SDKをコールさえすれば、サウンドデザイナはこのイベントのエフェクトをWwiseで設定できます。

AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23


Wwise Unity Integration Documentation: Wwise Picker

Wwise Picker

Wwise Pickerウィンドウに、Wwiseプロジェクトの利用できるオブジェクト（EventやSwitchなど）が同じ構造で表示されます。 Wwise Pickerビューに表示されるプロジェクトは、Wwise Settingsウィンドウ（メニューの Edit > Project Settings > Wwise Editor ）で入力したプロジェクトと同じです。 一般的に、UnityにWwiseプラグインをインストールするときに、このプロジェクトを指定します。

  • 機能
    • Pickerで、シーンにオーディオを追加する
    • サーチと閲覧
    • SoundBankの生成
    • リファレンスをシーンで探す
    • 自動入力
    • Wwise Pickerで選択する
  • WAAPIの機能
    • 選択の同期
    • Eventの再生
    • Wwiseオブジェクトの名前変更
    • 入っているフォルダを開く
    • SoundBankフォルダを開く
    • プロジェクトをリフレッシュする
    • Connectionステータス

バージョン2021.1から、Wwise Pickerには、File SystemとWwise Authoringの2つのモードができました。モードを切り替えるには、Pickerウィンドウの左上にあるメニューを使ってください。

File Systemモードでは、Wwiseプロジェクトを保存すると、表示されたオブジェクトがWwise Pickerビューで更新されます。 作成したオブジェクトが表示されない場合は、おそらく、プロジェクトが保存されていないからです。 Wwise Pickerビューを強制的にリフレッシュするには、Refresh Projectをクリックします。 なお、この操作で全てのWwise関連データがリフレッシュされるので、SoundBankを生成するときに作成されるXMLメタデータファイルの中のデータもリフレッシュされます。

注記： AkWwiseProjectData.assetを、バージョンコントロール下に置かないでください！ これはWwiseプロジェクトデータ用の一時的なキャッシュファイルで、Wwise PickerがWork Unitファイルを繰り返しパースするのを回避するためにあります。これをバージョンコントロールに追加すると、 問題発生の可能性があります。
注記： Wwise SettingsダイアログでWwise Windows Installation Path （MacではWwise Application）を指定する必要があります。Unityで Generate SoundBanks をクリックしたときに、UnityはWwiseパスを使う必要があります。

Wwise Authoringモードでは、PickerはWAAPIを使ってWwiseで開いているプロジェクトとやり取りをします。このモードでは、File Systemモードと同じ機能が提供されるほか、以下の機能もあります:

  • 表示中のオブジェクトがWwise Authoringで変更されると、すぐに更新されます
  • Picker内から、サウンドEventを再生
  • UnityとWwiseの間で、選択の同期
  • Unity内で、Wwiseオブジェクトの名前変更や削除。
注意： このモードが正しく機能するには、Wwise AuthoringでWwiseプロジェクトを開き、WAAPIの設定を正しく設定しておく必要があります。 WAAPIをあなたのプロジェクト用に設定する詳細については、 WAAPIユーティリティ ページを参照してください。

機能

次の各セクションで説明する機能は、File SystemモードとWwise Authoringモードのどちらにもあります。

Pickerで、シーンにオーディオを追加する

Wwise Pickerからシーンにオブジェクトを追加するには、オブジェクトを既存Game Objectの上や、Inspectorウィンドウの中にドラッグします。 各コンポーネントの詳細は、それぞれのコンポーネントのドキュメンテーションを参照してください:

  • Eventをドラッグ＆ドロップして作成されるのは、 AkAmbient 。
  • SoundBankをドラッグ＆ドロップして作成されるのは、 AkBank 。
  • Switch Valueをドラッグ＆ドロップして作成されるのは、 AkSwitch 。
  • State Valueをドラッグ＆ドロップして作成されるのは、 AkState 。
  • Aux Busをドラッグ＆ドロップして作成されるのは、 AkEnvironment 。

サーチと閲覧

特定アイテムを探すには、Wwise Picker上部にあるフィルターボックスを使います。 探しているアイテムの名前を入力すると、Wwise Picker がサーチ条件に合わないアイテムを自動的にフィルターにかけます。

アイテムを展開・縮小するには、+／-ボタンをクリックするか、アイテム名をダブルクリックします。 キーボードの矢印キーを使って、アイテムを選択したり展開したりすることもできます。

探しているアイテムの親アイテムが閉じていれば、見つかるまでアイテムをいくつか展開する必要があります。

SoundBankの生成

全てのプラットフォームやランゲージの全てのSoundBankを生成するには、 Generate SoundBanks をクリックします。 生成されたSoundBankはWwise PickerのSoundBankフォルダに、Wwise内で生成した場合と同様に表示されます。 同時にUnityのステータスバーに、以下のいずれかのメッセージが表示されます:

  • WwiseUnity: SoundBanks generation successful これは、エラーや警告がない場合
  • WwiseUnity: SoundBanks generation has warning(s) これは、警告がある場合
  • WwiseUnity: SoundBanks generation error これは、エラーがある場合 メッセージをクリックするとフォーカスが Console タブに移り、SoundBank生成プロセスの情報を確認できます。

リファレンスをシーンで探す

PickerでWwiseオブジェクトを右クリックすると、シーン内にあるそのリファレンスを探すオプションが提示されます。 これを選択すると、Hierarchyウィンドウにカスタムサーチが追加され、このWwiseオブジェクトへのリファレンスを含むGameObjectが隔離されます。 また、このアイテムを選択してShift + Rを押せば、同じことができます。

自動入力

これはFile Systemモードでしか提供されないオプションです。有効にすると、PickerはWwiseプロジェクトファイルが変更されたのを検知するとすぐに、表示内容を更新します（プロジェクトを保存したときにトリガーされることが多い）。 このオプションを無効にすると、Pickerの内容を更新するには Refresh Project ボタンをクリックする必要があります。

Wwise Pickerで選択する

Wwise Objectをリファレンス先とするWwiseコンポーネントを右クリックすると、それをPickerで選択するオプションが、メニューに表示されます。これを選択すると、Pickerウィンドウで、リファレンス先のオブジェクトがハイライト表示されます。

WAAPIの機能

Wwise AuthoringモードでWwiseプロジェクトに変更を加えると、すぐにPickerウィンドウにも反映されます。 WwiseのProject Explorerでオブジェクトのコピー、名前変更、削除、または移動を行うと、Pickerウィンドウの表示内容は、必ずそれに一致します。 さらに、Pickerウィンドウのアイテムを右クリックすると、多くの追加機能が表示されます。

選択の同期

選択した内容をUnityとWwise Authoringで同期させるかどうかを、 Autosync selection オプションで決めることができます。 最後に選択した項目が、両プログラムで同じになるので、プログラム間の移動が楽になります。

Eventの再生

WAAPi Pickerでイベントを右クリックして、試聴を選択することができます。 同じオプションを使って、現在再生中のEventが始まってから、それを停止することもできます。

ショートカット: スペースバー、または速いダブルクリック。

また、どのイベントが再生中なのか分からなくなった場合は、Pickerにある任意のアイテムを右クリックして Stop All を選択できます。

Wwiseオブジェクトの名前変更

PickerウィンドウでWwiseオブジェクトの名前を変更するには、ショートカットメニューでそのオプションを選択します。

ショートカット: F2、または遅いダブルクリック。

注記： Work UnitやPhysical Folderの名前は、変更できません。

入っているフォルダを開く

ショートカットメニューのOpen Containing Folderオプションで、WwiseオブジェクトのWork Unitが入っているフォルダを、File explorerで開けます。

ショートカット: Ctrl + O

SoundBankフォルダを開く

選択したアイテムがSoundBankであれば、SoundBankフォルダを開くためのオプションも、追加で表示されます。これで、Wwise Authoringで現在アクティブなプラットフォームの、Generated SoundBanksフォルダを、File explorerで開けます。

注記： まだSoundBankが生成されていなければ、おそらくOSのルートディレクトリが開きます。

プロジェクトをリフレッシュする

Wwise Authoringモードで Refresh ボタンをクリックすると、Pickerウィンドウの表示内容が消去され、WAAPIを使ってプロジェクトの内容が再度フェッチされます。

Connectionステータス

コネクション（Connection）の状態や、失敗したWAAPIリクエストの結果として出たエラーメッセージは、Wwise Picker Windowの右上に表示されます。

あなたのプロジェクトのWAAPIの設定は、 WAAPIユーティリティ ページを参照してください。 WAAPIが有効なのに、Unityプロジェクトでウェブソケットコネクションを開くのに失敗した場合は、Wwise Pickerウィンドウに具体的なエラーメッセージが表示されます。

コネクションエラーのメッセージ:

  • Connection refused
    • プロジェクトが開いていないことが原因。
  • Unity設定、またはWwise WAAPI設定で、誤ったポートまたはIPアドレスを指定したことが原因。
  • WAAPIがWwise Authoring User Preferencesで無効になっていることが原因。
  • The wrong project is open in Wwise
    • 正しいプロジェクトが開いているかどうかを確認してください
  • No project is open in Wwise yet
    • プロジェクトが開いているかどうかを確認してください

その他のエラーメッセージ:

  • Cannot execute call because Wwise has an exclusive lock
    • モーダルまたは設定ウィンドウが、Wwise Authoringで開いていることが原因。

接続が失敗するたびに、接続失敗の回数をNとすると、Unityインテグレーションが2^N秒後に再接続を試みます。待機時間は、32秒を超えることはありません。


Wwise Unity Integration Documentation: Wwise Types

Wwise Types

Wwise Typesは、Wwise内のコアオブジェクトを示す様々なクラスの集合体で、例えばSoundBanks、Events、Game Parameters、States、Switches等です。各クラスに、関連するプロパティ集があり、ユーザーは簡単に必要なオブジェクトを選択できます。Wwise Typesには、Eventをポストするときにサウンドエンジンに送信できるコールバックフラグを表す、サポートクラスも含まれます。

いくつかのWwise Typesを使ったスクリプト例を、以下に示します:

public class WwiseTypesExample : UnityEngine.MonoBehaviour
{
public AK.Wwise.Bank MyBank = null;
public AK.Wwise.Event MyEvent = null;
public AK.Wwise.RTPC MyRTPC = null;
public void Awake()
{
MyBank.Load();
}
public void Start()
{
MyEvent.Post(gameObject);
}
private float CalculateMyValue()
{
return (float)System.Math.Sin(System.Math.PI * UnityEngine.Time.timeSinceLevelLoad);
}
public void Update()
{
MyRTPC.SetValue(gameObject, CalculateMyValue());
}
}

上記スクリプトは、自動的に以下のinspectorを生成します:

以下の変更をWwiseTypesExampleクラスに加えることで、marker callbacksを使うこともできます：

public AK.Wwise.CallbackFlags MyCallbackFlags = null;
public void Start()
{
MyEvent.Post(gameObject, MyCallbackFlags, EventCallback);
}
private void EventCallback(object cookie, AkCallbackType type, AkCallbackInfo info)
{
if (type == AkCallbackType.AK_Marker)
{
var markerInfo = info as AkMarkerCallbackInfo;
if (markerInfo != null)
{
// ...
}
}
}
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25


Wwise Unity Integration Documentation: サウンドエンジンの制御にC#コードを使う

サウンドエンジンの制御にC::コードを使う

Wwise SDKの大部分の機能を AkSoundEngine クラスからUnityで利用できます。C++ ネームスペースの AK::SoundEngine や AK::MusicEngine などの代わりとしてとらえることができます。元のSDKと比較してAPIバインディングにどのような変更があったかは、 APIの変更と制約 を参照してください。 複雑な状況の場合は、コードでWwiseファンクションをコールする必要があります。APIで、全てのファンクションの GameObjectID がGameObjectのUnityフレーバーに置き換えられます。AkGameObj コンポーネントを既にマニュアル操作で追加してない限り、ランタイムにこのGameObjectに自動的に追加されます。

EventやBankの文字列の代わりに数値IDを使う

ネーティブWwise APIで、文字列やIDを使ってWwiseプロジェクト内のイベントやその他の名前の付いたオブジェクトをトリガーできます。C::の世界でも、 Wwise_IDs.h ファイルを Wwise_IDs.cs に変換することで、同様にできます。Assets > Wwise > Convert Wwise SoundBank IDsをクリックする。これが機能するには、Pythonをインストールしておく必要があります。

MIDIをWwiseに送る

MIDIをWwiseに送るには、 AkMIDIPostArray クラスの AkMIDIPost メンバーをfillして、以下の方式のどれかをコールします:

  • AkMIDIPostArray.PostOnEvent()
  • AkSoundEngine.PostMIDIOnEvent()
  • AK.Wwise.Event.PostMIDI()

以下は、サウンドエンジンにMIDIメッセージを送るための基本的なスクリプトです。

public class MyMIDIBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event SynthEvent;
private void Start()
{
AkMIDIPostArray MIDIPostArrayBuffer = new AkMIDIPostArray(6);
AkMIDIPost midiEvent = new AkMIDIPost();
midiEvent.byType = AkMIDIEventTypes.NOTE_ON;
midiEvent.byChan = 0;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 127;
midiEvent.uOffset = 0;
MIDIPostArrayBuffer[0] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[1] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[2] = midiEvent;
midiEvent.byType = AkMIDIEventTypes.NOTE_OFF;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 0;
midiEvent.uOffset = 48000 * 8;
MIDIPostArrayBuffer[3] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[4] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[5] = midiEvent;
SynthEvent.PostMIDI(gameObject, MIDIPostArrayBuffer);
}
}

Unityのオフラインレンダリング

Unityインテグレーションで、 オフラインレンダリング機能が Wwise SDK内 で公開されるので、オーディオサンプルの取得方法が簡素化されます。

注意： オフラインレンダリングを有効にする場合は、非同期の AkSoundEngine.LoadBank と AkSoundEngine.UnloadBank のAPIだけがメインスレッドから使われるように、注意してください。詳細は Custom Scheduling of Audio Rendering を確認してください。

AkSoundEngine.StartDeviceCapture で、キャプチャする特定の出力オーディオデバイスをセットアップすることで、 AkSoundEngine.UpdateCaptureSampleCount をコールして利用可能なサンプル数を確認することができ、 AkSoundEngine.GetCaptureSamples をコールしてオーディオサンプルを取得できるようになります。

以下は、Unityインテグレーションを使い、Unityのスクリーンキャプチャ機能と合わせてオフラインオーディオレンダリングを実行する方法を示した例です。この機能を実装すれば、マルチプレックスのポストプロセスの処理を簡単に実行して、キャプチャしたオーディオサンプルと動画フレームを組み合わせてムービーにすることができます。

public abstract class WwiseOfflineRenderer : UnityEngine.MonoBehaviour
{
public bool IsOfflineRendering { get; set; }
public bool StartWithOfflineRenderingEnabled = false;
private bool IsCurrentlyOfflineRendering = false;
public float FrameRate = 25.0f;
protected ulong OutputDeviceId = 0;
public abstract string GetUniqueScreenshotFileName(int frameCount);
public abstract void ProcessAudioSamples(float[] buffer);
protected void Start()
{
OutputDeviceId = AkSoundEngine.GetOutputID(AkSoundEngine.AK_INVALID_UNIQUE_ID, 0);
if (StartWithOfflineRenderingEnabled)
{
IsOfflineRendering = true;
Update();
}
}
private void LogAudioFormatInfo()
{
var sampleRate = AkSoundEngine.GetSampleRate();
var channelConfig = new AkChannelConfig();
var audioSinkCapabilities = new Ak3DAudioSinkCapabilities();
AkSoundEngine.GetOutputDeviceConfiguration(OutputDeviceId, channelConfig, audioSinkCapabilities);
UnityEngine.Debug.LogFormat("Sample Rate: {0}, Channels: {1}", sampleRate, channelConfig.uNumChannels);
}
protected void Update()
{
if (IsOfflineRendering != IsCurrentlyOfflineRendering)
{
IsCurrentlyOfflineRendering = IsOfflineRendering;
if (IsOfflineRendering)
{
#if UNITY_EDITOR
// エディタのアップデートで AkSoundEngine.RenderAudio() がコールされないように注意する。
AkSoundEngineController.Instance.DisableEditorLateUpdate();
#endif
LogAudioFormatInfo();
AkSoundEngine.ClearCaptureData();
AkSoundEngine.StartDeviceCapture(OutputDeviceId);
}
else
{
AkSoundEngine.StopDeviceCapture(OutputDeviceId);
#if UNITY_EDITOR
// エディタのアップデートコールを AkSoundEngine.RenderAudio() に戻す。
AkSoundEngineController.Instance.EnableEditorLateUpdate();
#endif
}
}
var frameTime = IsOfflineRendering && FrameRate != 0.0f ?1.0f / FrameRate : 0.0f;
UnityEngine.Time.captureDeltaTime = frameTime;
AkSoundEngine.SetOfflineRenderingFrameTime(frameTime);
AkSoundEngine.SetOfflineRendering(IsOfflineRendering);
if (!IsOfflineRendering)
return;
UnityEngine.ScreenCapture.CaptureScreenshot(GetUniqueScreenshotFileName(UnityEngine.Time.frameCount));
var sampleCount = AkSoundEngine.UpdateCaptureSampleCount(OutputDeviceId);
if (sampleCount <= 0)
return;
var buffer = new float[sampleCount];
var count = AkSoundEngine.GetCaptureSamples(OutputDeviceId, buffer, (uint)buffer.Length);
if (count <= 0)
return;
ProcessAudioSamples(buffer);
}
}

UnityでAudio Input Sourceプラグインを使う

Audio Input Sourceプラグインを、C::スクリプト経由で使えます。Wwise SDKドキュメンテーションの、オーディオ入力ソースプラグインを参照してください。

以下は、Audio Input Sourceプラグインにテストトーンを送るための基本的なスクリプトです。

public class MyAudioInputBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event AudioInputEvent;
public uint SampleRate = 48000;
public uint NumberOfChannels = 1;
public uint SampleIndex = 0;
public uint Frequency = 880;
private bool IsPlaying = true;
// Callback that fills audio samples - This function is called each frame for every channel.
bool AudioSamplesDelegate(uint playingID, uint channelIndex, float[] samples)
{
for (uint i = 0; i < samples.Length; ++i)
samples[i] = UnityEngine.Mathf.Sin(Frequency * 2 * UnityEngine.Mathf.PI * (i + SampleIndex) / SampleRate);
if (channelIndex == NumberOfChannels - 1)
SampleIndex = (uint)(SampleIndex + samples.Length) % SampleRate;
// これ以上提供するデータがないことを示すために、return falseとします。これで、関連するイベントも停止されます。
return IsPlaying;
}
// Callback that sets the audio format - This function is called once before samples are requested.
void AudioFormatDelegate(uint playingID, AkAudioFormat audioFormat)
{
// Channel configuration and sample rate are the main parameters that need to be set.
audioFormat.channelConfig.uNumChannels = NumberOfChannels;
audioFormat.uSampleRate = SampleRate;
}
private void Start()
{
// The AudioInputEvent event, that is setup within Wwise to use the Audio Input plug-in, is posted on gameObject.
// AudioFormatDelegate is called once, and AudioSamplesDelegate is called once per frame until it returns false.
AkAudioInputManager.PostAudioInputEvent(AudioInputEvent, gameObject, AudioSamplesDelegate, AudioFormatDelegate);
}
// コールバックを停止するために、このメソッドをほかのスクリプトからコールできます
public void StopSound()
{
IsPlaying = false;
}
private void OnDestroy()
{
AudioInputEvent.Stop(gameObject);
}
}

ポジショニングのカスタム設定をUnityで適用する

デフォルトで、 AkGameObj コンポーネントは特定のUnity gameObject に添付されて、そのtransform（オフセットの設定も可）を使ってフルポジショニングを行います。ファーストパーソンシューティングゲームなど多くのゲームは、これで充分です。一方、オーディオリスナーを単純に1つのゲームオブジェクト、例えばUnityのメインカメラなどに添付するだけでは、多くのサードパーソンゲームなどにあるカスタム設定されたカメラ角度で、ポジショニングに対応するための2つの要素（距離減衰とスペーシャリゼーション）に対応するのが難しい場合があります。また、その他のカスタム設定ポジショニングをプレイヤーに提供するゲームも、考えられます。

このような使い方のために、 AkGameObj コンポーネントクラスで、Unityユーザーはポジショニングをオーバーライドできます。GetPosition()、 GetForward()、 GetUpward() という3つのバーチャル方式を使って、ユーザーは AkGameObj からサブクラスを取り、そのサブクラスコンポーネントでUnity gameObjects のポジショニングをいくつでもカスタマイズできます。

デフォルトの AkAudioListener 動作を、カスタムコンポーネントを使ってオーバーライドするシンプルな例を、ここに示します。Wwiseにサードパーソンのプロジェクトをインテグレートした状態で、既存の AkAudioListener と、それに関連付けられた AkGameObj を削除します。次に、以下のスクリプトをMainCameraオブジェクトに添付して、さらに AkAudioListener を添付して、最後にオーディオリスナーのポジションが追うターゲットとして、Unity gameObject （例えばプレイヤーのアバター）を指定します。これ以降、全てのエミッターの距離減衰を計算するのに、選択したターゲットのUnity gameObject のポジションをリスナーポジション（画面上の距離リスナー）としてとらえる一方、全てのエミッターのオリエンテーションを決めるには、引き続きメインカメラのオリエンテーションをリスナーのオリエンテーションとしてとらえます（画面外のオリエンテーションリスナー）。

#if !(UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
//
// Copyright (c) 2017 Audiokinetic Inc. / All Rights Reserved
//
using UnityEngine;
using System;
using System.Collections.Generic;
[AddComponentMenu ("Wwise/AkGameObj3rdPersonCam")]
[ExecuteInEditMode] //ExecuteInEditMode necessary to maintain proper state of isStaticObject.
public class AkGameObj3rdPersonCam : AkGameObj
{
public Transform target; // The position that this camera will be following. ユーザーはこれを、InspectorでプレイヤーキャラクターのUnity gameObjectに対して指定できます。
// 距離減衰に対応するために、カメラのポジションをプレイヤーポジションに設定します。
public override Vector3 GetPosition ()
{
return target.GetComponent<AkGameObj> ().GetPosition ();
}
}
#endif // #if !(UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:278


Wwise Unity Integration Documentation: WwiseのTimelineインテグレーション

WwiseのTimelineインテグレーション

Timelineは、Unityのシネマティック編集ツールです。ゲームプレイのシーケンスや、オーディオシーケンスや、その他のシネマティックコンテンツを作成できます。

Timelineについて、詳しくは UnityのTimelineドキュメンテーション を参照してください。

TimelineアセットやTimelineインスタンスの作成方法は、Timeline Usageを参照してください。

注記： Timelineは、Unity 2019.3からUnity Package Manager経由で提供されることになりました。Timelineパッケージをアンインストールしたい場合は、必ず AK_DISABLE_TIMELINE Scripting Define Symbolを、あなたのプラットフォームのすべてのPlayer Settingsに追加してください。

WwiseのTimelineトラック

Wwise Unityインテグレーションで、 AkTimelineEventTrack と AkTimelineRtpcTrack という2つの新しいTimelineトラックと、 AkEventTrack と AkRTPCTrack という2つの非推奨となったTimelineトラックが、追加されます。

AkTimelineEventTrack はWwise Eventをポストするのに使い、 AkTimelineRtpcTrack はGame Parameter値を設定するのに使います。どちらのタイプのトラックも、ドロップダウンボタンのAddを使うか、Timelineウィンドウのトラックのヘッダ部分を右クリックして、Timelineに追加できます。

Adding AK tracks to Timeline
注記： AkEventTrack 、 AkRTPCTrack の両トラックと、それに関連するPlayableは、後方互換性だけのために提供されているので、今後は使わないようにしてください。
AkEventTrackは非推奨となった

Akトラックオブジェクトのバインディング

AkTimelineEventTracks や AkTimelineRtpcTracks のオブジェクトバインディングは、どのGame Objectに対してでも設定できます。トラックバインディングを明示的に設定すると、ターゲットとなるGame Objectを指定できます。トラックバインディングを設定しない（Noneに設定する）と、このトラックはTimelineのオーナーであるGame Object（つまり、このTimelineをトリガーするのに使われるPlayableDirectorコンポーネントがあるGame Object）をターゲットとします。イベントがポストされ、RTPCがターゲットであるこのGameObjectを変更します。

注記： ランタイムのアロケーションを減らすには、イベントをポストしたり、そのRTPCが変更されるような GameObject には、必ず AkGameObj を追加してください。

Wwise Timelineの再生可能なクリップ

AkTimelineEventTrack 、 AkTimelineRtpcTrack のどちらのトラックにも、対応するクリップがあり、前者は AkTimelineEventPlayable クリップが、後者は AkTimelineRtpcPlayable クリップがこれに該当します。これらのクリップは、トラックのメニューを使うかトラックを右クリックして、トラックに追加できます。

AKトラックにAKクリップを追加する

Timelineのクリップのプロパティ

Timelineの全てのクリップにタイミングプロパティがあり、インスペクタの上部に表示されます。これらのプロパティの詳細は、Clip Propertiesを参照してください。

AkTimelineEventPlayable クリップのプロパティ

AkTimelineEventPlayable クリップのInspectorで、以下のプロパティにアクセスできます。

AkTimelineEventPlayable クリップのプロパティ
  • Event: このクリップによってトリガーされるWwise Event。
  • Blend In Curve: このEventをポストするときに使う AkCurveInterpolation 値。この値は、クリップの Ease In Duration が0より大きいときに限り効果があります。
  • Blend Out Curve: Eventを停止するときに使う AkCurveInterpolation 値。この値は、クリップの Ease Out Duration が0より大きいときに限り効果があります。
  • Use Wwise Event Duration: これにチェックを入れるとEventは最後までトリガーされ続け、APIコールによって明示的に停止されることはなく、また次の2つのパラメータが選択できなくなります。
  • Stop Event At End Of Clip: これにチェックを入れると、適切なタイミングでストップAPIファンクションがコールされ、クリップの終わりにEventが停止し、Blend Out Curveが効果を発揮します。チェックしないとBlend Out Curveの影響はなく、EventはDurationの終わりまで再生されます。
  • Loop: これにチェックを入れ、クリップの長さがEventの長さよりも長い場合は、クリップの終わりよりも先にEventの再生が終わるたびに、Eventが再度トリガーされます。

AkTimelineRtpcPlayable クリップのプロパティ

AkTimelineRtpcPlayable クリップのInspectorで、以下のプロパティにアクセスできます:

AkTimelineRtpcPlayable クリップのプロパティ
  • RTPC: このトラックに関連付けられたGameObjectに設定する、WwiseのGame Parameter。
  • Set Globally: これにチェックを入れると、このRTPCが全オブジェクトを対象とするグローバル設定になります。
  • Animated Value: Value このクリップによってアニメーションされる値。

AkTimelineRtpcPlayable クリップのカーブ

トラックのターゲットに送信するRTPCの値のアニメーションを開始するには、以下を行ってください:

  1. クリップを適切なタイミングに、適切な長さで作成します。
  2. レコーディング用に、トラックをarmの状態にします。
  3. TimelineのPlayheadを、クリップの領域内に配置します。
  4. クリップのInspectorでValueを右クリックするとコンテキストメニューが表示され、Keyの追加、削除、編集ができます。
  5. 最初のキーを追加してからクリップをダブルクリックすると、Animation Windowが開くので、より細かくカーブやキーの編集を行えます。
注記： Timelineで行うアニメーションカーブの編集について、詳しくは Recording basic animation with an Infinite clip を参照してください。
レコーディング用のArm、カーブ表示ボタン
AkTimelineRtpcPlayable のレコーディングがarm状態で、カーブを表示

既知の問題点と限界

現在、スクラビングに対応しているのは、Unity EditorのEditモードとPlayモードです。しかし再生は、アセンブリのリロードをまたいで使えません。

Wwise Project Setup

Eventの長さが AkTimelineEventTracks で正しく表現されるには、オーディオEventの長さを予想できるように、そしてXMLメタデータが生成されるように、Wwiseプロジェクトを設定する必要があります。プロジェクト全体で設定をするには、Project SettingsのSoundBanksタブを開きます。以下のとおり、 Metadata Options グループボックスの Estimated duration チェックボックスを有効にし、 SoundBank Settings グループボックスの Generate XML Metadata チェックボックスを有効にします。

AkTimelineEventTracksに必須のProject Settings


Wwise Unity Integration Documentation: 特定プラットフォーム向けにUnityゲームをビルドする

特定プラットフォーム向けにUnityゲームをビルドする

ターゲットプラットフォームのためにUnityゲームをビルドするのが、Unityの標準パイプラインやビルドスクリプトを使ってアプリケーションをビルドするのと同じくらいに、シンプルになりました。SoundBankの生成、コピー、削除に使うビルド前後のプロセス（pre-build steps、post-build steps）は、 Edit > Project Settings > Wwise Editorで有効・無効にできます。

Wwiseプラグインをデプロイする

Unityのビルドシステムによって、Wwiseプラグインが自動的にゲームにパッケージ化されます。デフォルトで、プラグインの Profile コンフィギュレーションが使われます。このコンフィギュレーションを使うとWwiseをゲームに接続してプロファイリングができるので、ゲーム開発には最も実用的なコンフィギュレーションです。ただし、ゲームをリリースする準備ができたら、 Assets > Wwise > Activate PluginsメニューでWwiseプラグインコンフィギュレーションを Release オプションに変更してください。

注記： Debug はサウンドエンジンの具体的な問題をデバグする場合にのみ使い、一般的にAudiokineticサポートのもとで行います。
参照
  • 各プラットフォーム固有の情報

StreamingAssetsフォルダ

Unityでは通常、以下の通り、Unityプロジェクトの Assets フォルダ内に StreamingAssets フォルダを作成します（このフォルダがUnityプロジェクトにない場合は、マニュアルで作成すること）: <UNITY_PROJECT_ROOT>\Assets\StreamingAssets. Unityは、このフォルダのコンテンツを自動的に対象デバイスにデプロイします。詳細はUnityのStreamingAssets機能を参照してください。

デフォルトのSoundBankパスはAudio\GeneratedSoundBanksであり、 StreamingAssets フォルダの下にあります。Unity がこのパスの最後に現在のプラットフォーム用のフォルダを、WwiseプロジェクトのPlatform Managerで付けた名前に従い追加します。最終的なフルパスは、 <UNITY_PROJECT_ROOT>\Assets\StreamingAssets\Audio\GeneratedSoundBanks\<YourPlatform>となります。

必要に応じて Common User Settings でBase Pathを変更できます。

Unity Editorで実行する時に、SoundBankのパスは常にWwiseのProject Settingsダイアログで設定したWwiseプロジェクトの、GeneratedSoundBankパスにポイントするように設定されます。これによって、WindowsやMacでサウンドをインテグレートする時に、バンクをデプロイする際の問題を回避できます。

1つのプラットフォームのプロジェクトでSoundBankをデプロイする

プラットフォームが1つだけのタイトルを作成する場合は、SoundBankファイルを物理的に StreamingAssets フォルダに移動する代わりに、WwiseプロジェクトのSoundBankアウトプットパスを StreamingAssetsフォルダ の下の希望するフォルダに設定すれば、希望する場所にSoundBankを直接生成できます。この方法を使う場合は、必ずサウンドバンクの生成やコピーに関連するビルド前のプロセス（pre-build steps）を、Wwise Settingsウィンドウの設定で無効にしてください。

マルチプラットフォームのプロジェクトでSoundBankをデプロイする

複数のプラットフォームでリリースされる作品では、ゲームをビルドする対象プラットフォームに限定してSoundBankやストリーミングサウンドをコピーするスクリプトを実行する必要があります。

さらに細かい管理が必要かどうかを判断した上で、ゲームデベロッパが最終的な実装を決定すべきです。

レファレンスプラットフォーム用に複数のカスタム化プラットフォームを扱う

もしWwiseプロジェクト内で同じレファレンスプラットフォームのバージョンを複数定義している場合（例えばiOSを対象とするiPadとiPhoneのプラットフォームの場合）は、追加のスクリプトが必要となります。詳細は UnityでWwiseのカスタムプラットフォームを使う を参照してください。

メタデータを除外する

WwiseがTXTやXMLなどのSoundBankメタデータファイルを生成します。これらのファイルのファイル名は常に SoundbanksInfo です。他のパイプラインツールで使えるようなSoundBank情報が入っていますが、ゲームには不要です。最終的な StreamingAssets フォルダにコピーする必要はありません。


Wwise Unity Integration Documentation: WwiseとUnityでDLCをつくる

WwiseとUnityでDLCをつくる

Wwiseのファイルパッケージの利用

DLCをWwiseでサポートするデフォルトの手段は、File Packageの利用です。 機能の説明は、Authoringに関するドキュメント: Wwise > Help > Finishing Your Project > Managing File Packages > Downloadable Content Overviewにあります。パッケージに入れるBNKやWEMの置換用ファイルや追加ファイルについて、またそれらを自由にロードしたりアンロードしたりすることでDLCを有効・無効にする方法などが、簡単に説明されています。このパッケージフォーマットの使用は必須ではありませんが、現在のWwise/Unityプラグインに組み込まれて提供されています。自分のパッケージフォーマットを書くには、新しいLow-Level IOを書いてデフォルトのものと置き換えてください。

Unityでパッケージに使うには、パッケージをAkInitializerのプロパティとしてBase Pathに設定したパスに置くだけです。次に、 AkSoundEngine.LoadFilePackage() をコールします。Wwiseはファイルをロードする時に、必ずファイルパッケージ経由で、逆順でロード（最後に追加したものを最初にサーチ）しようとします。

この方法は、ゲーム出荷後にBase Pathにディスク書き込みができる全てのプラットフォームで利用できます。残念ながら、iOSやAndroidはこれが行えません。

AndroidとiOSの場合は全てのデータをリードオンリーのファイルシステムにバンドル化するため、パッケージを別のディレクトリに入れる必要があります。これを行うには AkSoundEngine.LoadFilePackage() の前に、 AkSoundEngine.AddBasePath() をコールします。複数のパスを追加でき、最後に追加したものを最初にサーチします。制約事項については、該当するOperating Systemドキュメントを確認してください。以下のコードは、ファイルを保存する場所のパスを選択するためのコードの例です:

#if UNITY_IPHONE
string fileNameBase = Application.dataPath.Substring(0, Application.dataPath.LastIndexOf('/'));
fileName = fileNameBase.Substring(0, fileNameBase.LastIndexOf('/')) + "/Documents/" + FILE_NAME;
#elif UNITY_ANDROID
fileName = Application.persistentDataPath + "/" + FILE_NAME ;
#else
fileName = Application.dataPath + "/" + FILE_NAME;
#endif

なおAndroidでは、sdcardや同様のメモリデバイスなど他にも書き込み可能なパスがいくつかあります。

Addressablesを使う

UnityのAddressablesシステムを使い、SoundBankのパッケージングや配信と、メディアファイルのストリーミングができます。 詳細は UnityのためのWwise Addressablesパッケージ ページを参照してください。

UnityWebRequestを使ってバンクをストリーミングする

UnityのUnityWebRequestクラスを利用して、直接DLCオーディオファイルを取得してロードすることも可能です。 これはメモリ内にバンクをロードして行い、AkMemBankLoader.csで実現できる通りです。 Unityの古いバージョンでは、AkMemBankLoaderで、WWWクラス（すでに廃止）のあるバンクもロードできます。 既存のバンクを新しいバンクで置き換えたい場合は、まず以前のバンクをアンロードする必要がありますが、その理由は、Wwise IOシステムがそのコードについて認識していないので、同じバンクをあなたが誤ってもう一度ロードしようとしているのか、それとも置き換えようとしているのかを、判断できないからです。


Wwise Unity Integration Documentation: インテグレーションコードをビルドする

インテグレーションコードをビルドする

Wwise-UnityインテグレーションはC#の薄いレイヤで、ネーティブWwise APIをコールします。全プラットフォーム用にビルドされた状態で提供されます。多くの場合、Integrationプラグインの再ビルドは不要です。ただしソースコードがある場合はカスタム化して、ネーティブサウンドエンジンにカスタム変更を実装させたり、サウンドエンジンとのインターフェースとなるC++コードを修正したりすることもできます。これは、C++の知識がある程度あるプログラマが行うべき作業です。

手順

  1. Audiokinetic Launcherを使って、これからビルドする各プラットフォームのWwise SDKをインストールする。必ずログオフして、再びログオンすること。
  2. WwiseインテグレーションをUnityプロジェクトに追加すると、使用するOS（WindowsまたはMac）のソース（source）zipがLauncherによってUnityプロジェクトにインストールされるので、そのソースzipの場所を見つける（zipの名前の最後に_Src.zipと付く）。
  3. ビルドする対象プラットフォームがWindowsやMac以外の場合は、そのソースzipの場所を見つける。
  4. このIntegrationをビルドするための前提条件を確認する。詳細は 前提条件 を参照。
  5. 全てのソースzipを、同じフォルダに解凍する。詳細は Unityプロジェクトのインテグレーションの、インストールとアップグレード を参照。
  6. ビルドプロセスを、次の2種類のメソッドのいずれかで起動する: Consoleユーティリティを使ってビルドする または Integrated Development Environment (IDE)を使ってビルドする.
  7. ビルドが終了するまで待つ。ビルドが成功すると、 API/Runtime/Plugin フォルダの下のプラグインやAPIバインディングが更新されるか、なければ新しく作成される。

Notes

  • ビルド中に警告、エラー、重要なメッセージなどがあれば、 Build Log の詳細ログメッセージを確認してモニターできます。

Integrationを自分でビルドするための要件:

プラットフォーム | 必要なコンポーネント
全てのプラットフォーム
  • Unity. Unityの最新バージョンについては Unity QA - Long Term Support を参照してください。
  • 対象プラットフォーム用の互換性のあるWwise SDK。 リリースノート - Wwise Unityインテグレーション2023.1.1.8417.3007 を参照してください。
  • 対象プラットフォーム用の互換性のあるプラットフォームSDK。 Wwise SDKヘルプ（Reference Materials > Platform Requirementsのセクション）。
  • Python 3.9.x、そしてPython実行フォルダをあなたのシステム実行パスに入れる。
Android
  • Android SDK: 32bitはAPI 14以上、64bitはAPI 21以上。
  • Android NDK r17c.
  • Apache Ant 1.8.4.
  • Wwise SDKへのパスにホワイトスペースを含めてはならない。
  • Unityプロジェクトルートへのパスにホワイトスペースを含めてはならない。
  • 環境変数:
    • ANDROID_HOME は、Android SDKルートフォルダをポイントするべき。
    • ANDROID_NDK_HOME は、Android NDKルートフォルダをポイントするべき。
    • NDKROOT は、Android NDKルートフォルダをポイントするべき。
    • ANT_HOME は、Apache Antルートフォルダをポイントするべき。
iOS
  • Xcode 11以上。
  • iOS用のWwise SDKと、それをポイントする WWISESDK 環境変数
Linux
  • Build-essential (sudo apt-get install build-essential)
  • Linux用のWwise SDKと、それをポイントする WWISESDK 環境変数
Mac
  • Xcode 11以上。
  • Mac用のWwise SDKと、それを指す WWISESDK 環境変数
PS4 | Visual Studio 2017 以上。
Windows | Visual Studio 2017 以上。
Windows Store | Visual Studio 2017 以上。
Xbox One | Visual Studio 2017 以上。

ソースパッケージをインストールするには

ソースパッケージを解凍します。これによって、ソースパッケージと求めているプラットフォームのWwise SDKインストールだけを使って、Integrationパッケージのコンテンツを再ビルドして生成できます。あるいは、圧縮されていないWwiseフォルダ内のコンテンツと、UnityプロジェクトのAssetsフォルダにあるインポート済みIntegrationユニティパッケージをマージする方法もあります。ただし不必要な中間ファイルがAssetsフォルダに生成されてしまうことがあり、これはマニュアル操作で排除しなければなりません。

インストールしたインテグレーションパッケージのフォルダ構成

  • StreamingAssets: SoundBankの自動デプロイに使う 1つのプラットフォームのプロジェクトでSoundBankをデプロイする のフォルダ。
  • Wwise: 最上位フォルダ。
    • API: あなたのアプリケーションで使う、メインのIntegrationファイル。
      • Runtime: C++ から C# へのバインディングファイル。これがネーティブWwise SDKの変換である。
      • Editor: APIの、Editorだけの部分。
      • Plug-ins: 様々なコンフィギュレーションやデバグシンボルデータベースのUnityプラグインライブラリ。
        • Platform
          • Architecture: マルチアーキテクチャプラットフォームで複数のアーキテクチャにシェアされるファイル。
            • Debug: プラグインバイナリの Debug バージョン。Wwiseプラグインをデプロイする for detail を参照してください。
            • Profile: プラグインバイナリの Profile バージョン。Wwiseプラグインをデプロイする for detail を参照してください。
            • Release: プラグインバイナリの Release バージョン。Wwiseプラグインをデプロイする for detail を参照してください。
            • DSP: Wwiseプラグインエフェクト。
    • MonoBehaviour: 直接使えるUnityコンポーネントスクリプトで、カスタム設定コンポーネントの例として活用できる。
    • Documentation: Integrationに関する完全なドキュメント。

インストールしたソースパッケージのフォルダ構成

  • Wwise: 最上位フォルダ。
    • AkSoundEngine: Integrationをビルドするのに必要なソースコードとIDCプロジェクトを、プラットフォーム別に整理したもの。
      • Common: 全ての対応済みプラットフォームで使われるソースコードやビルドスクリプト。
      • Platform: 対象プラットフォームのIDEソリューションまたはプロジェクト、ソースコード、そしてそのプラットフォーム専用のビルドスクリプト。
    • Integration/Assets/Wwise/API: アプリケーションで使うメインのIntegrationファイル。
      • Runtime: APIバインディングのルートレベルのフォルダ。
        • Generated: SWIGバインディングの段階で生成されるAPIバインディングファイル。
        • Handwritten: 手書きのAPIバインディングファイル。
    • MonoBehaviour: 直接使えるファクトリ版Unityコンポーネントスクリプトで、カスタム設定コンポーネントの例として活用できる。

Consoleユーティリティを使ってビルドする

Integrationを、 Wwise\AkSoundEngine\Common\BuildWwiseUnityIntegration.py にあるビルドスクリプトを使ってコマンドからビルドできます。これは連続するインテグレーションに便利です。利用方法や例を見るには、現在のワーキングディレクトリがスクリプトの親フォルダであれば、コンピュータにコマンドコンソールを1つ入力します:

python BuildWwiseUnityIntegration.py -h

Integrated Development Environment (IDE)を使ってビルドする

以下の下にあるWwise Unityインテグレーションソースパッケージの中にあります:

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\YourPlatform

このソリューション（またはXcodeプロジェクト）で、対象プラットフォーム用のIntegrationをサポート済みIDEでビルドできます。

Mac または iOSプラットフォーム用にXcodeでビルドする

コマンドラインからインテグレーションをビルドする場合は、 $WWISESDK 変数で設定されるもの、または -w オプションを使ってビルドスクリプトに提供されるものに基づいて、自動的に WWISESDK パスがXcodeに対して提供されます。ただしXcode IDEを使う場合は、WWISESDKパスをマニュアル設定する必要があります。これをするにはXcodeプロジェクトをMacまたはiOSのプラットフォーム用に開き、プロジェクトナビゲータで AkSoundEngine{platform} プロジェクトを選択します。Build Settingsページを選択する。ページの最後のUser-Definedセクションに WWISESDK 設定キーがあります。WWISESDK のパスを設定値として入力して、(ex: /Users/myUser/Wwise/SDK )に対するインテグレーションをビルドします。

Linuxプラットフォーム用にビルドする

以前はpremake5で生成されたmakefileが含まれています。ソースからLinuxプラグインをビルドするには、以下のコマンドを端末に入力するだけです:

  • cd <Integration source location>/AkSoundEngine/Linux

  • make config=<config>

    <config> が debug_x64 、または profile_x64 、または release_x64 です。その結果のプラグインは<Integration source location>/API/Runtime/Plugins/Linuxにあります。

新ライブラリをデプロイする

その結果のバイナリはWwise\API\Runtime\Plugins\[Platform]にあります。Assets\Wwiseディレクトリのソースが解凍してなければ、そのフォルダの新バイナリをコピーして、プロジェクトのAssetsディレクトリにある該当フォルダに入れます。

Under the hood

インテグレーションコードをビルドするためのソースをパッケージングする前に、SWIGを使ってWwise SDK用のAPIバインディングをUnity内で生成します。多くのユーザは、WwiseでUnityを使う上でSWIGは必要ありません。上級ユーザが、インテグレーションコードをビルドするために、変換されたAPIを含むWwise for Unityソースにアクセスする場合でも、SWIGをインストールしたり使用したりする必要ありません。唯一の例外が、サウンドエンジンを変更する場合や、サウンドエンジンとのインターフェースとなるC++コードを修正したりする場合です。このような稀なケースでは、サポート担当に連絡してから進めることを推奨します。

ビルドプロセスで以下のタスクが実行されます:

  1. Wwise SDKライブラリはUnityプラグインとして、またはWindowsのダイナミックライブラリとして、またはMac OS Xのロード可能なバンドルとして(.bundle) 、またはiOSのスタティックライブラリとして (.a)、またはAndroidの共有ライブラリとして、1つのライブラリにラップされます。Deploymentフォルダに直接ビルドされます。フォルダ構造は、 Unityプロジェクトのインテグレーションの、インストールとアップグレード を参照してください。
参照
  • 各プラットフォーム固有の情報
  • Build Log
  • プラグインのC++コードを更新した後に、Wwise Integration Packageを新しいバージョンにアップデート・アップグレードする


Wwise Unity Integration Documentation: Build Log

Build Log

WarningやエラーメッセージがUnity EditorコンソールやBuild Logに表示されます。Build Logファイルには、Integrationのビルド中に作成された詳細メッセージが入っています。 Build Logは以下の場所に保存されます：

UNITY_PROJECT_ROOT\Assets\Wwise\Logs\BuildWwiseUnityIntegration.log

ログメッセージは以下のフォーマットで表示されます：

Time: Message type: Source Code File name (Module name): Line number: Message body

例：

2013-09-26 09:29:56,490: INFO: BuildWwiseUnityIntegration.py (WindowsBuilder): 91: Building: Windows (Win32, Debug) ...

ログファイルは蓄積され、1時間後に新ファイルにローテンションします。ローテーション動作を変えるには、Unityインテグレーションソースパッケージにある以下のファイルの BuildUtil.CreateLogger() ファンクションを設定します：

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\Common\AkSoundEngine\Common\BuildUtil.py

詳細はPython logging.handlers module参照。

プラットフォームによって追加ログファイルがIDEによって生成されることがあり、Visual Studioはその一例です。追加されたファイルはファイル名にキーワード IDE が入った形で同じフォルダに保存されます。


Wwise Unity Integration Documentation: プラグインのC++コードを更新した後に、Wwise Integration Packageを新しいバージョンにアップデート・アップグレードする

プラグインのC++コードを更新した後に、Wwise Integration Packageを新しいバージョンにアップデート・アップグレードする
警告： 注意点
  • Unity移行の操作は元に戻せません。始める前に、Unityプロジェクトのバックアップをすること。
  • Unityプロジェクトをソースコントロールで管理している場合は、移行を始める前にUnityプロジェクトフォルダ全体をチェックアウトすること。これを行わないと、対象のファイルを正しく変更できないため移行が失敗する。
  • Wwiseインテグレーションをインストールする前に、Unityプロジェクトがエラー無しで正常にコンパイルできる状態であることを確認すること。(Warning表示は許容範囲内。)

このインストール手順は、以前のWwise Integrationパッケージを含むUnityプロジェクトが既にあることを前提としています。新規インストールの場合は、 Wwise Integration Packageを初めてインストールする ページを参照してください。他のUnityプラグインと異なり、新しいバージョンにアップグレードするには以前のWwise Integrationパッケージをインストールしたまま残しておく必要があります。Launcherが新機能やバグフィックスをインストールしてから、以前のWwise Integrationを新規バージョンに移行させます。

警告： 新しいWwise Integrationをインストールする前に古いインテグレーションを削除してしまうと、今までゲームにインテグレートしたWwiseオーディオが全て失われてしまうので、避けてください。

アップグレードは3段階に分けて行われます。まず最初にWwiseプロジェクトをこれから利用するバージョンにアップデートしてから、Unityプロジェクトも同様にアップデートする必要があります。

Unityプロジェクトを新しいWwiseバージョンにアップデートする

Audiokinetic Launcherを使って、Unityプロジェクトを新しいWwiseバージョンにアップデートします。

Wwiseプロジェクトを新しいWwiseバージョンにアップデートする

  1. Unityで使用する新しいWwise Integrationパッケージと合うWwiseのバージョンを起動する。
  2. Wwise Projectを開く。
  3. Wwiseプロジェクトを最新バージョンにアップデートするよう促すプロンプトが表示されたら、'Yes'と答える。
  4. 完了したら、Wwise SoundBankを再生成して、Unityプロジェクトを新しいWwiseのバージョンにした後の作業を続けられるようにすること。
  5. 生成されたSoundBankをコピーしてUnityプロジェクトのStreamingAssetsフォルダに入れる。

C++コードの修正をアップデートする

  1. 希望するプラットフォーム全てを対象に、アップデートされたWwise SDKをマシンにインストールする。
  2. 希望する全てのプラットフォーム用にUnityプロジェクトにコピーした、Unity Integration Source Codeのzipの場所を見つける。
  3. ダウンロードした全てのUnity Integration Source Codeパッケージを同一ディレクトリに抽出する
  4. Unity Integration Source Codeに対して行った修正を、更新した場所にマージする
  5. アップデートしてマージしたインテグレーションソースコードをコンパイルする


Wwise Unity Integration Documentation: Enter Play Modeの動作

Enter Play Modeの動作

Enter Play Mode Settingsを使用する際のSound Engine初期化の動作が変更されました。これに関連する設定は、「Reload Domain」および Unity Editor Settingsを調整する 「Load Sound Engine in Edit Mode」です。

Sound Engineの初期化
 | Reload Domainオン | Reload Domainオフ
Load Sound Engine in Edit Mode オン | Edit ModeやPlay Modeに入るとSound Engineは初期化され、Edit ModeやPlay Modeから出ると終了されます | Edit ModeやPlay Modeに入るとSound Engineは初期化され、終了されることはありません。
Load Sound Engine in Edit Modeオフ | Play Modeに入るとSound Engineは初期化され、Play Modeから出ると終了されます。 | Play Modeに入るとSound Engineは初期化され、Play Modeから出ると終了されます。

Sound Engineが無効になると、すべてのAkGameObjが登録解除されますが、必要に応じて登録できます。

注記：
  • AuthoringでProfiling Sessionを継続しながらPlay Modeに何度も出入りするには、Reload Domainをオフにし、Load Sound Engine in Edit Modeをオンにする必要があります。
  • シーンのリロードを省略し、 AkTypeで「Awake」トリガーを使うと、エディタとビルドしたゲームの間で不整合が生じます。Reload Sceneがオフになっている時は、代わりに「Start」トリガーを使用することを推奨します。

詳細についてはConfigurable Enter Play Modeを参照してください。


Wwise Unity Integration Documentation: APIの変更と制約

APIの変更と制約

ネーティブWwise SDKの以下の機能やファンクションは、Integrationでサポートされていないか、動作が変更されています（最新の変更から順に記載）:

  • UnloadBank() 単一引数オーバーロードバージョンを採用しなくなった。2番目の引数としてメモリ場所を示すポインタを提供しなければならない。
  • GetGameObjectFromPlayingID() のWindowsバージョンが、GameObject IDを32bitでWindows 32bit用と64bit（トランケーション）の両用に返す。
  • PostEvent() と GameObject関連のAPIが、グローバルスコープに影響するGameObject入力引数として、 null も受け入れるようになった。
  • PostEvent() コールバックのシリアル化が行われ、オーディオスレッドからコールするのではなく、次のゲームフレームの最初に合わせて発生するようになった。このため、同期メカニズムが不要である。
  • AK::Monitoring::SetLocalOutput() を AkCallbackManager.SetMonitoringCallback() に置き換えた。
  • AK::SoundEngine::SetPosition() を AkSoundEngine.SetObjectPosition() に置き換えた。
  • サウンドのストリーミングは、レベルデータをディスクからロードするのと同時に行ってはならない。
  • いくつかの AK::SoundEngine::DynamicSequence APIファンクションの名前を、明確性を保つためにUnity APIバインディングで変更した。これは、SWIGによって起きるネームスペースのフラット化という副作用を補う解決策である。例えば AK::SoundEngine::DynamicSequence::Open() は本来、生成されたAPIで AkSoundEngine.Open() となるはずである。そこで、APIバインディングで AkSoundEngine.DynamicSequenceOpen() に名前を変更する。
  • C++オーバーロードオペレータの名前がUnityスクリプト言語でファンクションに変更され、例えば AkArray::operator[] が AkPlaylistArray.ItemAtIndex(uint uiIndex) となる。これは、SWIGがC++オーバーロードオペレータに対応する方式に基づいて行われる。
  • 非対応のAPIやコンポーネント:
    • iOSオーディオ入力コールバックAPI
    • AkSpeakerVolumeMatrixCallbackInfo
    • AkSpeakerVolumeMatrixBusCallbackInfo
    • AkBusCallbackFunc
    • AK::SoundEngine::RegisterBusVolumeCallback
    • AK::SoundEngine::RegisterCodec
    • AK::SoundEngine::RegisterGlobalCallback
    • AK::SoundEngine::RegisterPlugin
    • AK::SoundEngine::Query::AkGameObjectsList
    • AK::SoundEngine::Query::GetActiveGameObjects()
    • AK::SoundEngine::Query::GameObjDst
    • AK::SoundEngine::Query::AkRadiusList
    • AK::SoundEngine::Query::GetMaxRadius(AkRadiusList& io_RadiusList)
    • コールバックやEvent名を受け付ける、AK::SoundEngine::DynamicDialogue::ResolveDialogueEvent の全ての変種
参照
  • 各プラットフォーム固有の情報.


Wwise Unity Integration Documentation: 各プラットフォーム固有の情報

各プラットフォーム固有の情報

以下のページに、プラットフォーム固有の情報があります。

Mac, iOS and tvOS

  • Mac/iOS/tvOSに固有の情報

カスタムプラットフォーム構成

  • UnityでWwiseのカスタムプラットフォームを使う


Wwise Unity Integration Documentation: Mac/iOS/tvOSに固有の情報

Mac/iOS/tvOSに固有の情報

iOS用にビルドする

UnityアプリケーションをiOSデバイスでテストするためには、あなたのアプリをビルドしてこのデバイスに展開する必要があります。Build または Build and Run をUnity Editorで実行すると、UnityはXcodeプロジェクトをUnityスクリプトに基づいて生成します。

UNITY_PROJECT_ROOT/Assets/Plugins/iOS

UnityはまだThumb命令に対応していません。このためXcodeプロジェクトにおいてThumb命令は無効になっています。

リリース向けにビルドする

通常Wwise Integrationライブラリの libAkSoundEngine.a にすべてのデバッグシンボルが含まれるため、非常に大きなライブラリとなります。デバッグシンボルをストリップ（削減）するために、(iOS) Player SettingsのOther SettingsセクションにあるStripping Levelオプションを必ず選択するようにします。このインテグレーションであなたのゲームに一般的に1～2MBほどが追加されます。

iOSにおけるオーディオセッションの中断

Unityインテグレーションは3つのオーディオセッションカテゴリに対応しています。

  • Solo Ambient (AkAudioSessionCategorySoloAmbient) (Default) ：このカテゴリを使うと、他のアプリのオーディオが無音になります。あなたのアプリのオーディオは、スクリーンロックやSilentスイッチ（iPhoneではRing/Silentスイッチと呼ぶ）によっても、無音になります。
  • Ambient (AkAudioSessionCategoryAmbient) ： AmbientSound で、アプリのオーディオを他のアプリとミックスできます。電話の着信などのオーディオ中断や、遠隔操作による音楽アプリの音楽再生などが、デフォルトであなたのアプリのオーディオとミックスされます。ただし、サウンドやミュージックを特別なバスにルーティング指定して、ユーザのミュージック再生中にミュートして、ユーザのミュージックが停止した時点でミュートを解除することもできます。ミュートやミュート解除はサウンドエンジン内部で行います。BGM (BackGround Music) コールバックを定義して、その他の便利なタスク、例えばUIエレメントを更新してユーザのミュージック再生ステータスをユーザに通知するなど、ユーザのミュージック操作に反応させることもできます。このコールバックの登録には、 AkCallbackManager.SetBGMCallback() を使います。
  • Play and Record (AkAudioSessionCategoryPlayAndRecord): オーディオが重要な位置を占めるアプリ内で、再生と録音を可能にするために使い、例えばカラオケアプリ、オーディオストリーミングのアプリ、またはオーディオレコーディングのアプリなどで用いることができます。

遠隔操作でユーザミュージックを再生すると、中断がトリガーされる（SoloAmbientカテゴリ下で）か、BGMイベントがトリガーされます（Ambientカテゴリ下で）が、ユーザミュージックを遠隔操作で停止すると、全カテゴリ下でBGMイベントがトリガーされます。ここでも、このようなイベントによるオーディオパイプライン上のタスクはサウンドエンジンが全て担います。追加の動作が必要であれば、アプリでBGMコールバックを登録してこれらのイベントに反応することもできます。

注記： バックグランドとフォアグランドの切り替えはiOS内で管理するので、このプラットフォームではSuspendやWakeupFromSuspendをマニュアル操作でコールする必要はありません。

これらのオプションの詳細は、Wwise SDKドキュメンテーションの オーディオセッションを理解する のセクションを参照してください。

参照
  • WwiseとUnityでDLCをつくる
  • Mac、iOS、およびtvOSのリリースノート


Wwise Unity Integration Documentation: Mac、iOS、およびtvOSのリリースノート

Mac、iOS、およびtvOSのリリースノート

以下のページに、Mac、iOS、およびtvOS向けに行われたWwiseの変更点に関する情報があります。このリストにないWwiseのバージョンでは、Mac、iOSおよびtvOS向けの変更点がありませんでした。

Mac、iOS、tvOS、およびvisionOS 2023.1.1
Mac、iOS、およびtvOS 2022.1.5
Mac、iOS、およびtvOS 2022.1
Mac、iOS、tvOS、およびvisionOS 2021.1.14
Mac、iOS、およびtvOS 2021.1.9
Mac、iOS、およびtvOS 2021.1.8
Mac、iOS、およびtvOS 2021.1.4
Mac、iOS、およびtvOS 2021.1.3
Mac、iOS、およびtvOS 2021.1.1
Mac、iOS、およびtvOS 2019.2.15
Mac、iOS、およびtvOS 2019.2.13
Mac、iOS、およびtvOS 2019.2.11


Wwise Unity Integration Documentation: Mac、iOS、tvOS、およびvisionOS 2023.1.1

Mac、iOS、tvOS、およびvisionOS 2023.1.1

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2023.1.1の変更点を挙げ、説明します。

  • バグ修正

バグ修正

  • WG-69135 修正済み：Ak Channel Routerプラグインをパッケージ化できません。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2022.1.5

Mac、iOS、およびtvOS 2022.1.5

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2022.1.5の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-65586 修正済み：Bundle IdentifierがないとApp Storeにサブミットできません。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2022.1

Mac、iOS、およびtvOS 2022.1

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2022.1の変更点を挙げ、説明します。

  • 動作の変更

動作の変更

  • WG-52303 iOS割り込みハンドラの設計を見直し、Apple Human Interface Guidelinesに合わせました。詳細は、iOS/tvOSに固有の情報を確認してください。


Wwise Unity Integration Documentation: Mac、iOS、tvOS、およびvisionOS 2021.1.14

Mac、iOS、tvOS、およびvisionOS 2021.1.14

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.14の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-66479 修正済み：Bundle IdentifierがないとApp Storeにサブミットできません。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2021.1.9

Mac、iOS、およびtvOS 2021.1.9

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.9の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-59213 修正済み: M1 MacsのDllNotFoundExceptionがUnity 2021.2以降を使用していました。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2021.1.8

Mac、iOS、およびtvOS 2021.1.8

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.8の変更点を挙げ、説明します。

  • バグ修正

バグ修正

  • WG-55735 修正済み: Unity Demo GameのモバイルカメラにSpatial Audio Listenerがありませんでした。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2021.1.4

Mac、iOS、およびtvOS 2021.1.4

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.4の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-55799 修正済み: ロード操作の失敗がないかを、AsyncHandleステータスで確認しませんでした。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2021.1.3

Mac、iOS、およびtvOS 2021.1.3

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.3の変更点を挙げ、説明します。

  • バグ修正

バグ修正

  • WG-55646 修正済み: AkInitSettings::szPluginDLLPath に空の文字列が設定されていると、Sound Engineを初期化したときにクラッシュしました。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2021.1.1

Mac、iOS、およびtvOS 2021.1.1

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2021.1.1の変更点を挙げ、説明します。

  • バグ修正

バグ修正

  • WG-53337 Resonanceプラグインを、正しく登録しました。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2019.2.15

Mac、iOS、およびtvOS 2019.2.15

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2019.2.15の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-59213 修正済み: M1 MacsのDllNotFoundExceptionがUnity 2021.2以降を使用していました。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2019.2.13

Mac、iOS、およびtvOS 2019.2.13

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2019.2.13の変更点を挙げ、説明します。

  • バグ修正

バグ修正

  • WG-55646 修正済み: AkInitSettings::szPluginDLLPath に空の文字列が設定されていると、Sound Engineを初期化したときにクラッシュしました。


Wwise Unity Integration Documentation: Mac、iOS、およびtvOS 2019.2.11

Mac、iOS、およびtvOS 2019.2.11

以下のセクションで、Mac、iOS、およびtvOS向けに行われた、Wwiseのバージョン2019.2.11の変更点を挙げ、説明します。

  • コミュニティで報告されたバグの修正

コミュニティで報告されたバグの修正

  • WG-53337 修正済み: Resonanceプラグインが、正しく登録されませんでした。


Wwise Unity Integration Documentation: UnityでWwiseのカスタムプラットフォームを使う

UnityでWwiseのカスタムプラットフォームを使う

デフォルトで、Wwise Unityインテグレーションは対象Wwiseプロジェクトに設定された全てのプラットフォームにデフォルトの名前が付いているものとします。プラットフォームに別の名前を付ける場合や、ベースプラットフォーム用に複数のカスタムプラットフォームを設定する場合は、対応できるようにC::スクリプトを作成する必要があります。

注記： このページでは、SoundBankが生成されるサブフォルダの名前がプラットフォームと同じものとしています。なお、そうでない場合は GetPlatformName メソッドで返される文字列が実際はゲーム中のSoundBankサブフォルダ名として使用されています。

カスタムプラットフォームの定義

デフォルトのプラットフォーム解消スクリプトの入っているファイルの場所は <UNITY_PROJECT_ROOT>/Assets/Wwise/API/Runtime/Handwritten/Common/AkBasePathGetter.csです。GetPlatformName() メソッドに見られるように、全てのプラットフォームのデフォルト名がこのファンクションで返却されます。自分のプラットフォーム名を使いたければ、 GetCustomPlatformName デリゲートに、メソッドを登録する必要があります。デリゲートに登録するには、 RuntimeInitializeOnLoadMethod アトリビュートを通してコールする静的メソッドを使うことを推奨します。

例

この例では、iOSプラットフォームのユースケースだけを見ます。iOSのベースプラットフォーム用に3つの異なるカスタムプラットフォームを用意する場合を考えます: iPod用、iPhone用、iPad用にそれぞれ1つずつとします。

  1. まずWwiseプロジェクト内で、次の3つの異なるプラットフォームをPlatform Managerで追加します: "iPod", "iPhone", "iPad"。（WwiseのPlatform Managerについては、WwiseドキュメントのWwise Help > Setting Up Your Projects > Managing Platformsを参照。）
  2. 次にUnityで、GetCustomPlatformName デリゲートに登録するC::スクリプトを作成します。ファイルの中身は、以下のようになるべきです:
    public partial class MyCustomBasePathGetter
    {
    [UnityEngine.RuntimeInitializeOnLoadMethod(UnityEngine.RuntimeInitializeLoadType.BeforeSceneLoad)]
    static void RegisterCustomPlatformName()
    {
    AkBasePathGetter.GetCustomPlatformName = GetCustomPlatformName;
    }
    static partial void GetCustomPlatformName(ref string platformName)
    {
    #if UNTIY_IOS
    switch(UnityEngine.iOS.Device.generation)
    {
    case UnityEngine.iOS.DeviceGeneration.iPodTouch1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch5Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouchUnknown:
    platformName = "iPod";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPad1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir1:
    case UnityEngine.iOS.DeviceGeneration.iPadMini2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir2:
    case UnityEngine.iOS.DeviceGeneration.iPadUnknown:
    platformName = "iPad";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPhone:
    case UnityEngine.iOS.DeviceGeneration.iPhone3G:
    case UnityEngine.iOS.DeviceGeneration.iPhone3GS:
    case UnityEngine.iOS.DeviceGeneration.iPhone4:
    case UnityEngine.iOS.DeviceGeneration.iPhone4S:
    case UnityEngine.iOS.DeviceGeneration.iPhone5:
    case UnityEngine.iOS.DeviceGeneration.iPhone5C:
    case UnityEngine.iOS.DeviceGeneration.iPhone5S:
    case UnityEngine.iOS.DeviceGeneration.iPhone6:
    case UnityEngine.iOS.DeviceGeneration.iPhone6Plus:
    case UnityEngine.iOS.DeviceGeneration.iPhoneUnknown:
    default:
    platformName = "iPhone";
    break;
    }
    #endif
    }
    }
    注記： platformName が変更されずそのままの場合は、起動中のUnityプラットフォームのデフォルトプラットフォーム名が使われます。
  3. (a) AkBuildPreprocessorを拡張するC::を作成するか、(b) AkBuildPreprocessor内でこの機能を使うC::スクリプトを作成します。ファイルの中身は、以下のようにすることができます:
    public class WwiseIOSBuildPreprocessor : IPreprocessBuild, IPostprocessBuild
    {
    public int callbackOrder { get { return 0; } }
    string iPodDestinationSoundBankFolder = string.Empty;
    string iPadDestinationSoundBankFolder = string.Empty;
    string iPhoneDestinationSoundBankFolder = string.Empty;
    public void OnPreprocessBuild(BuildTarget target, string path)
    {
    if (target == BuildTarget.iOS)
    {
    AkBuildPreprocessor.CopySoundbanks(true, "iPod", iPodDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPad", iPadDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPhone", iPhoneDestinationSoundBankFolder);
    }
    }
    public void OnPostprocessBuild(BuildTarget target, string path)
    {
    DeleteSoundbanks(iPodDestinationSoundBankFolder);
    DeleteSoundbanks(iPadDestinationSoundBankFolder);
    DeleteSoundbanks(iPhoneDestinationSoundBankFolder);
    }
    }
  4. または、Wwiseで"iPhone"、"iPod"、"iPad"の3つのプラットフォーム全てのSoundBankを生成して、その結果できた3つのフォルダを、UNITY_PROJECT_ROOT/Assets/StreamingAssets/Audio/GeneratedSoundBanksにコピーします。
  5. Unityで、ゲームをiOSプラットフォーム用にビルドする。
  6. これ以降はデバイスの種類に応じて異なるSoundBankセットが採用されることになる。


Wwise Unity Integration Documentation: デモゲーム

デモゲーム

Wwise Unityインテグレーションの入ったデモシーンがAudiokinetic LauncherのUnityページでダウンロードでき、"Recent Unity Projects"タイトルのコンテキストメニュー内にあります。Unityの標準アセットのみを使って作成されたこのシンプルなシーンで、Integrationの基本機能の一部の使い方を紹介しています。

インストール

Wwise Demo Gameは独立したプロジェクトです。Audiokinetic Launcherでダウンロードできます。開発するゲームの基盤として利用しないでください。そのような目的には、Audiokinetic Launcherを使って新しいUnityプロジェクトにWwiseをインテグレーションしてください。

注記：
  • 生成したサウンドバンクがパッケージに含まれます。
  • このシーンに関連したWwise Projectは<DEMO_SCENE_ROOT>/WwiseProjectにあります。WwiseプロジェクトをゲームのAssetsフォルダに残すのは推奨されませんが、本Demoではパッケージングの際に必要でした。

デプロイ

WwiseデモゲームはWwise UnityインテグレーションをUnity Editorで使用する様子をプレビューして使い方を確認するためのものです。

Wwise Demo Gameをゲームコンソールや携帯デバイスにデプロイするには、以下の手順に従います:

  1. LauncherのUnityタブを開いて、Wwise Demo Game Unityプロジェクトの、Modify Wwise in Project...オプションを選択します。
    1. LauncherのUnityインテグレーションのページが開きます。
  2. 希望するDeployment Platformを追加して、Modifyをクリックします。
  3. プロジェクトの更新されたバージョンをUnityで開きます。
  4. このプラットフォームのSoundBankを生成する。
  5. Generated SoundBanksフォルダをコピーしてStreamingAssets/Audioフォルダに入れる。
  6. Unity内で、希望するプラットフォーム用にシーンをビルドして、デバイスにデプロイします。

Unity Demo Gameには、2つのチュートリアルが入っています:

  • Wwiseデモシーン
  • Unityで、Spatial Audio


Wwise Unity Integration Documentation: Wwiseデモシーン

Wwiseデモシーン

このファーストパーソン3Dマップには、道沿いにいくつかの"ステーション"があります。ステーション毎に、簡単な説明の書かれた看板が脇にあります。簡単に参照できるように、各ステーションのアセットがシーン階層に入れてあります。

Footstepsデモ

フットパスと最初のステーションを通して、スクリプトやトリガーボリュームを使ってフットステップシステムを作成する方法をデモします。

Wwise Projectでフットステップシステムの実装が推奨通りに行われ、地面タイプ別にRandomコンテナがあり、それらがSwitchコンテナに入っています。フットステップをポストするには Footstep イベントを使い、地面の材質は Footstep_material スイッチグループで制御します。

シーンの地形は、草、砂利、木板、土という4種類のテクスチャに分けてペイントしてあります。それぞれの地表面タイプを歩き回ると、フットステップサウンドも合わせて変化します。

これを達成するためにBox Colliderが各ゾーン上に配置されています。Footstep_Material スイッチの設定は単純で、Switch ValueをWwise Picker WindowからBox Colliderにドラッグするだけです。First Person ControllerがColliderに入った時にSwitchをオンにするには、 "AkTriggerEnter"トリガーのAk Switchスクリプトをトリガーして、"Use Other Object"チェックボックスがチェックされていることを確認する必要があります（Inspector Window表示の通り）。

非常に初歩的なフットステップのスクリプトが実装されていて、プレイヤの移動中は0.3秒ごとに Footstep イベントがポストされます。このスクリプトはFirst Person Controllerに添付してあります。これは、スクリプトを使ってイベントをWwise SoundEngineにポストする方法を表しています。

Subtitleデモ

このステーションでは、カスタム設定したイベントトリガーをUnityで作成する方法と、イベントコールバックの使い方を示します。

単純なボタンスクリプトに、プレイヤがボタンに十分近づいた時に実行されるDelegateの入った単純なボタンスクリプトを準備し、キーボードやコントローラのキーが押されるように設定します。別のスクリプトの AkTriggerButtonPress がこのDelegateに登録され、親クラスの AkTriggerBase から triggerDelegate を呼び出します。AkTriggerBase から継承することで、カスタム設定したトリガーがWwise Component Inspectorウィンドウの"trigger"リストに表示されるようになります（例えばボタンに添付されたAk Ambientなど）。カスタムトリガーについては Wwiseイベントのトリガーを追加する を参照してください。

このイベントが、WAVマーカを含むサウンドファイルの再生を始めます。イベントに関連するマーカコールバックを登録することで、パネルのサブタイトルの更新が可能になります。これを達成するには、Ak AmbientのInspectorで"Use Callback"オプションを選択します。次にスクリプト(SubtitleDemo.cs)が含まれたGameObject (SubtitleSign)が"Game Object"ボックスにドラッグ＆ドロップされました。コールバックがトリガーされた時に実行するCallback Function (MarkerCallback)の名前を入力して、Callback Flagsとして"Marker"が選ばれました。SubtitleDemo のコードを見ると、Callbackファンクションは事前定義された文字列アレイからサブタイトルを読み、インデックスとして MarkerCallback の uIdentifier フィールドを使っただけだということが分かります。コールバックの詳細は AkAmbient をInspectorで使う を参照してください。

Environmentデモ

シーンにあるゾーン内のサウンドに関して、どのようにエフェクトを提供できるのかを、このStationで見せることができます。EnvironmentZoneに含まれる2つの洞穴（ここでも1つのBox Colliderがトリガーを担っている）があり、AuxBusがそれに対して追加されている（Wwise Pickerウィンドウからドラッグ＆ドロップして追加）。

Wwiseで2つのAuxiliary Busを作成して、それぞれ異なるエフェクトを入れてあります。さらにフットステップやLittle Sequenceは"Use game-defined Auxiliary sends"にチェックが入っています。

EnvironmentZone内からWwiseイベントをポストすると、そのサウンドがゾーンと関連性のあるAuxBusにルーティングされます。

このステーションでEnvironment Portalコンポーネントのデモも確認できます。これは、2つの環境間の空間的な切り替わりを表します。デモの3つのボタンを使い、Environment PortalがAuxiliaryバスのミキシングにどう影響するかを確認できます。

まず環境ポータルを作成するには、グラフ軸のいずれかでAk Environemnts2つにタッチするBox Colliderを1つ作成します（このデモではポータルが'z'軸上でRedゾーンとBlueゾーンにタッチします。I次にAk Environment Portalコンポーネントを追加して、正しい軸を選択します。ミックスされるこの2つの環境は、自動的にフィルインされます。

EnvironmentやEnvironment Portalの詳細は AkEnvironmentやAkEnvironmentPortalをInspectorで使う を参照。

Timelineデモ

このステーションでは、UnityのTimelineでAkEventTrackとAkRTPCTrackを使う方法を示します。2つのCubeがあり、ボタンを押すと、アニメーションでお互いに向かって動き始め、インパクト（衝突）が起きると止まります。

Timelineを確認するには、Window->Timelineを選択します。次に階層でTimelineDemoオブジェクトを展開して、Timeline Demo Buttonオブジェクトを展開します。続いて、Buttonオブジェクトを選択します。CubeのアニメーションやWwiseイベントをコントロールするためのTimelineが、Timelineエディタに表示されます。Timelineは、ButtonオブジェクトのPlayable Directorコンポーネントでコントロールできます。

Timelineには、2つのCube用に、それぞれのアニメーショントラックが1つずつ、入っています。これらのトラックを使って、各Cubeのz座標を時間の経過とともにアニメーションするのに使います。また、TimelineにはAkEventTrackとAkRTPCTrackも含まれ、それぞれが白と赤のタブでマークされています。AkEventTrackに2つのAkEventPlayableクリップが含まれ、1つ目はPlayCubeMovementのWwiseイベントをトリガーするもの、2つ目はPlayImpactのWwiseイベントをトリガーするものです。これらのWwiseイベントの名前は、クリップに表示されています。名前を完全に表示させるには、Timelineエディタのビューの大きさを変えて、ズームインする必要があるかもしれません。PlayCubeMovementのWwiseイベントは、ピッチをRTPCで調整するサイン波ソースを再生します。このRTPCの名前は、CubeAccelerationです。Cubeがお互いに向かっていくにつれ、時間の経過とともにAkRTPCTrackがRTPCを増加させます。これによってサイン波のピッチが増大して、Cube同士がお互いに加速していく様子をシンプルなサウンドエフェクトで表現できます。

このステーションで、モーション機能のデモを見ることもできます。プレイヤー階層に"Motion listener"というゲームオブジェクトがあります。このゲームオブジェクトは、モーション対応のプラットフォームのモーションデバイスに送信するアウトプット用に設定されています。どのアウトプットも、データを受信する複数のリスナーが必要です。モーションリスナーにAKゲームオブジェクトやAkオーディオリスナーもあるのは、このためです。Cubeインパクトでモーションエフェクトを使うには、2つの重要な準備があります。まず、インパクト音を、Wwiseプロジェクト内のWwise Motionシェアセットを使うアウトプットバスに送る必要があります。次に、モーションアウトプットに使うリスナーを、インパクトイベントをポストするエミッターのリスナーに追加する必要があります。アウトプットを追加する方法について、AkMotionListenerスクリプトに例があるので参照してください。

注記： Androidでモーション機能をサポートするには、アプリケーションのマニフェストにバイブレーションのパーミッションを含める必要があります。Unityは、アプリケーションの内容に基づいて自動的にマニフェストを生成します。Handheld.Vibrate() へのコールを追加すれば、マニフェストに必要なパーミッションを追加できます。

Timelineインテグレーションの詳細は、 WwiseのTimelineインテグレーション を参照してください。


Wwise Unity Integration Documentation: Unityで、Spatial Audio

Unityで、Spatial Audio

本章は、UnityインテグレーションのSpatial Audio機能の使い方の概要を説明します。以下3つのテーマに分かれています:

  • チュートリアルに入る前に必要な、準備のページ:
    • Spatial Audioチュートリアルの事前準備
  • 独立した2つのチュートリアル:
    • Surface Reflectorチュートリアル
    • ルームやポータルに関するチュートリアル
  • その他のSpatial Audio機能に関する補足的なページ:
    • Spatial Audioのその他の機能
    • オブストラクションとオクルージョン
注記： Wwise Reflectプラグインを使うセクションを終了するには、該当ライセンスが必要です。
参照
  • Spatial Audioのコンポーネント
  • Spatial AudioのSDKドキュメンテーション


Wwise Unity Integration Documentation: Spatial Audioチュートリアルの事前準備

Spatial Audioチュートリアルの事前準備

Spatial Audioチュートリアルを成功させるには、事前に以下を行ってください:

  • 1. Unityプロジェクトを作成する
  • 2. Wwiseプロジェクトの準備
  • 3. Unityプロジェクトの準備
  • 4. 自分の設定を、検証する
注記： 新規プロジェクトをゼロから作成したくなければ、Audiokinetic Launcherで デモゲーム Unity Demo Gameをダウンロードしてください。SpatialAudioTutorialというシーンがあり、チュートリアルの手順が全て入っています。

1. Unityプロジェクトを作成する

WwiseとUnityの最新バージョンを使い、以下の手順に従い、自分の作業環境を準備します。

  1. Unityを起動して、新しいプロジェクトを作成します。
  2. Unityを閉じる
  3. Audiokinetic Launcherを起動して、あなたのUnityプロジェクトにWwiseをインテグレートします。

2. Wwiseプロジェクトの準備

チュートリアルを実施するのに必要なのは、サウンドSFXが1つ、それを再生するイベントが1つ、そしてSoundBankが1つです。

  1. Launcherで、あなたのプロジェクトをWwiseで開きます。
  2. Actor Mixer HierarchyのDefault Work Unitの下に、サウンドSFXを追加します。
    1. そこに音を1つ、インポートします。
    2. Sound Property Editorの
      1. General Settingsタブで、Use game-defined auxiliary sendsを有効にします。

        Sound Property EditorのGeneral Settingsタブ
      2. Positioningタブで、 Listener Relative Routing を有効にし、3D Spatializationの Position + Orientation を選択します。妥当なMax Distanceを設定したAttenuationを追加します。

        Sound Property EditorのPositioningタブ
  3. Actor-Mixer Hierarchy内のサウンドSFXを右クリックして、New Event > Play を選択します。

    Event Editor
  4. SoundBankレイアウトに移り（ショートカットはF7）、新しいSoundBankを追加します。イベントを新しいSoundBankにドラッグします。
  5. プロジェクトを保存する。

3. Unityプロジェクトの準備

このセクションで、ゲームエリアやその中のオブジェクトを、作成します。ここで必要なのは、リスナーが1つ、エミッターが1つ以上、そしてルームが2つです。

Launcherで、あなたのプロジェクトをUnityで開きます。Wwise Picker (Windows > Wwise Picker)、Refresh Project、Generate SoundBanksを開きます。

Wwise Picker
  1. 好きなメソッドを使って、キャラクターを作成します。
    1. Unity Audio Sourceを削除します。
    2. あなたがリスナーとして利用するGameObjectに、 AkSpatialAudioListener コンポーネントを追加します。
      AkSpatialAudioListener コンポーネント
    3. AkSpatialAudioListener コンポーネントを追加すると、自動的に、 AkAudioListener と、 AkRoomAwareObject と、 AkGameObj コンポーネントが作成されます。
      AkAudioListener コンポーネント
      AkGameObj コンポーネント
      AkRoomAwareObject コンポーネント
      1. AkGameObj コンポーネントで、以下を行います
        1. Environment Aware チェックボックスのチェックを外します。
        2. Use Default Listener オプションを有効にします。
      2. AkRoomAwareObject コンポーネントに、警告メッセージが最大2つ表示されることがあります。ここでは、まだ AkRoom コンポーネントを使わないので、とりあえず無視してください。これは、後ほど ルームやポータルに関するチュートリアル のときに確認します。あなたのゲームで AkRoom コンポーネントを全く使う予定がなければ、このコンポーネントを無効にできます。
  2. 好きなメソッドを使い、フロア（床面）、2部屋ある建物、そして屋外の障害物を1つ、作成します。
    SpatialAudioTutorialシーンでは、建物にはメッシュ、フロアと障害物にはキューブを使っています（ GameObject > 3D Object > Cube）。

    SpatialAudioTutorialシーン
  3. 好きなメソッドを使い、複数のエミッターを作成します。Wwise Unity Demo Sceneでは、シリンダーを使い、複数のボタンを作成しました（ GameObject > 3D Object > Cylinder ）。各ルームの外と中に、ボタンを1つずつ追加しました。

    全てのエミッターで、以下を行います:
    1. AkAmbient コンポーネントを追加します｡
      1. 音をスタートする好みの方法を、Trigger Onで選択します。
      2. Name でEventを選択します。
        AkAmbient コンポーネント
    2. AkGameObj コンポーネント（ AkAmbient コンポーネントを追加すると自動的に追加される）において、以下を行います:
      1. Use Default Listener オプションを有効にします。
        AkGameObj コンポーネント
    3. AkBank コンポーネントを追加します:
      1. 前のセクションで作成したSoundBankを、 Name に追加します。
        AkBank コンポーネント

4. 自分の設定を、検証する

  1. ゲームをスタートし、Wwiseに接続します。
    1. Profilerレイアウトを開きます（ショートカットはF6）。
      1. ボタンから音を再生してみます。あなたがWwiseプロジェクトにインポートした音が、聞こえるはずです。
      2. Voices Graphタブに、以下のグラフが表示されるはずです:
        Voice Graph外のボタン、Effectなし
      3. Advanced Profilerビューの右上の歯車アイコンで、Profiler Sttingsを開き、Spatial Audioが選択されていることを確認し、Game Object 3D ViewerでSpatial Audioの図が見えるようにします（次の手順）。
        Profiler Settings
    2. Game Object Profilerレイアウトを開きます（ショートカットは F12）
      1. Game Object 3D Viewerに、あなたのゲームオブジェクトが表示されます。まだ音を発していないゲームオブジェクトは、Viewerに表示されていないことに気づきます。
        Game Object 3D Viewer
  2. あなたのシーンを、都合のよい場所に保存します。


Wwise Unity Integration Documentation: Surface Reflectorチュートリアル

Surface Reflectorチュートリアル

このチュートリアルでは、UnityでReflectプラグインとSpatial Audioを使う方法を、手順を追いながら説明します。SoundBankを生成するのにReflectプラグインのライセンスが必要ですが、Wwise Authoringに接続した状態で試すことはできます。

  • A. Wwiseプロジェクト
  • B. Unity Project
  • C. 設定の検証
注記： このチュートリアルの前提として、 Spatial Audioチュートリアルの事前準備 を完了しておいてください。

A. Wwiseプロジェクト

Wwiseプロジェクトを更新して、Reflectプラグインとアコースティックテキスチャが入ったAuxバスを入れる必要があります。

  1. ファクトリアセットをインポートして、Auxiliary Busプリセットや、ファクトリAcoustic Textureにアクセスできるようにします。
    1. Project > Import Factory Assets... に移動します。
    2. Reflect と、 Acoustic Textures を選択し、OKを押します。
  2. Acoustic Texturesは、 Project Explorer ビューのShareSets タブにある、 Virtual Acoustics フォルダの中にあります。
    Project ExplorerのShareSetsタブにある、Factory Reflect Acoustic Textures
    1. （オプション）カスタム設定のアコースティックテキスチャは、Default Work UnitのVirtual Acousticsフォルダに追加できます。
  3. アーリーリフレクション用にAuxiliary Busを追加します。
    1. Master Audio Bus を右クリックし、 New Child > Presets へ移動し、Early Reflection Auxiliary Busを選択します。
  4. Spatial Audioチュートリアルの事前準備 に追加したSoundを編集します
    1. General Settingsタブで、新しく作成したReflect付きのAuxiliary Busを、 Early Reflections ボックスに追加します。
      Reflect Auxiliary Busを、Sound Property EditorのGeneral Settingsタブで指定
  5. プロジェクトを保存する。

B. Unity Project

AkSurfaceReflector コンポーネントを使い、面（サーフェス）のアーリーリフレクションをシミュレーションできます。サーフェスリフレクタコンポーネントを、ゲームの既存メッシュに追加するのが、1つの方法です。形状が複雑すぎると、Spatial Audio APIに大量の三角形を送り込むことになり、ゲームが遅くなってしまう可能性もあります。その場合 AkSurfaceReflector コンポーネント自体に、コリジョンメッシュなど、別のメッシュを追加することができます。反射面を追加するには、新GameObjectを作成するという方法もあります。Wwise Unity Demo Sceneの中のシーンでは、新しいオブジェクトをサーフェスリフレクタに設定しています。ルームは立方体（キューブ）なので、キューブを使い、メッシュレンダラは使用していません。

  1. キューブを作成します: GameObject > 3D Object > Cube
    1. Mesh Rendererコンポーネントを除きます
    2. Box Colliderコンポーネントの、Is Triggerにチェックを入れます
    3. AkSurfaceReflector コンポーネントを追加します。
      1. MeshFilterコンポーネントのメッシュを使う予定であれば、meshパラメータをNoneのままにすることもできます。そうでなければ、希望するメッシュをここで追加できます。
      2. Acoustic Textures アレイで、各サブメッシュのアコースティックテキスチャを選択するか（キューブにはサブメッシュが1つしかありません）、フィルタなしのリフレクションにするために None とします。
      3. Transmission Loss Values アレイで、各サブメッシュの面の透過損失値を設定できます。これは、メッシュを通るサウンドに適用するフィルタに使います。詳細は D. Transmission（透過） セクションを参照してください。
      4. Diffraction（回折）を有効にするには、 Enable Diffraction チェックボックスを使います。詳細は E. ルームをSurface Reflectorと関連付ける（非推奨） を参照してください。
      5. 最後に、Associated RoomはNoneのままにしてください。詳細は E. ルームをSurface Reflectorと関連付ける（非推奨） のセクションを参照してください。
        AkSurfaceReflectorコンポーネント
  2. リフレクションの次数は、Spatial Audio Settingsの下の AkWwiseInitializationSettings で設定します。
    1. デフォルトのリフレクションOrderは、1です。最大4まで設定できます。
      Spatial Audioの初期設定
  3. リフレクションパスをシーン内で描写させたい場合は、エミッタに AkSpatialAudioDebugDraw コンポーネントを追加します。
    1. 描写したいリフレクション次数に、チェックを入れます。
      AkSpatialAudioDebugDraw コンポーネント

C. 設定の検証

  1. Wwise Pickerで、 Windows > Wwise Picker と進みます
    1. サウンドバンクを生成します
      Wwise Picker
  2. ゲームをスタートし、エミッターの1つを再生します。
    1. Wwiseでゲームに接続して、Profilerレイアウトを開きます。下図と似たグラフが、表示されるはずです:
      ReflectエフェクトのあるVoice Graph
    2. グラフでAuxiliary Busノードの下にある、ハイライト表示されたWwise Reflectをダブルクリックし、リフレクトのEffect Editorを開きます。音が再生されると、進行中のリフレクションが、グラフとリストで確認できるはずです。Texture(s)列の下にテキスチャが2つ表示されている場合は、セカンドオーダーのリフレクションです。
      1. この画面で、リフレクションの減衰カーブを調整できます。
      2. リフレクションが全く表示されない場合は、エミッターとリスナーの間のリフレクションの距離に対し、Max Distanceが低すぎないかを確認してください。
        ReflectのEffect Editorビュー
    3. Game Object Profilerレイアウトに移動します（ショートカットはF12）
      1. すでに設定されていなければ、Game Object 3D Viewer Settingsで、Reflection Pathsと、Reflection Image Sourcesを、有効にします。
        Game Object 3D Viewer Settingsにある、リフレクションの設定
      2. Game Object 3D Viewerを見ると、サーフェスリフレクタや、再生中のエミッターからスペーシャルオーディオのリスナーへのリフレクションパスが、表示されるはずです。
        Game Object 3D Viewer
注記： もしGame Object 3Dビュアーにジオメトリが全く表示されなければ、Initialization SettingsでMonitor Queue Pool Sizeを増やす必要があるかもしれません。次ページ Wwise Initialization Settingsを調整する を参照してください。
注記： 立方体のサーフェスリフレクタが建物を覆っているので、エミッターを再生中でも、リスナーが屋外にいれば建物の中のエミッターから出るリフレクションパスを取得できず、その逆でも同じです。これは、建物の開口部も、反射面の一部となっているからです。これを直すには、ビルのメッシュだけをサーフェスリフレクタとして利用するか、開口部にポータルを配置します。Portalの詳細については、 ルームやポータルに関するチュートリアル を参照してください。
参照
  • Spatial Audioのコンポーネント
  • Reflect ドキュメンテーション
  • Using the Geometry API for Simulating Early Reflections


Wwise Unity Integration Documentation: ルームやポータルに関するチュートリアル

ルームやポータルに関するチュートリアル

このチュートリアルでは、Spatial Audioでルームやポータルを使う方法を説明します。チュートリアルの手順内容が、以下のセクションに詳しく書かれています。

  • A. Wwise Project
  • B. Room
  • C. Portal
  • D. 設定の検証
  • E. ポータルと、リバーブ
注記： このチュートリアルの前提として、 Spatial Audioチュートリアルの事前準備 を完了しておいてください。一方、 Surface Reflectorチュートリアル とは独立しているので、終了していなくても問題ありません。 Surface Reflectorチュートリアル を終了し、続けてこのチュートリアルを始める場合は、あなたのシーンをそのまま使えます。新たにスタートしたい場合に、すでに Surface Reflectorチュートリアル を実施してあれば、同じシーンを維持できます。

A. Wwise Project

このチュートリアルでは、エミッターの姿が見えなくなったときにポータルを通して回折の効果が聞こえるように、Reverb Effectsを追加し、Obstructionカーブを変更します。

  1. ルームプリセットを使い、Auxiliary Bussesを2つ追加します。
    1. Master Audio Bus を右クリックし、 New Child > Presets へ移動し、Room Auxiliary Busを選択します。
    2. Effects タブで、各ルームに異なるエフェクトを選択します。例えば、小さいルームにはRooms/Room_Mediumを、大きいルームにはCathedrals/Mediumを選択します。
      ルームの、Auxiliary Bus Property EditorのEffectsタブ
  2. Spatial Audioチュートリアルの事前準備 に追加したSoundを編集します
    1. Positioningタブで、Diffraction and Transmissionが有効になっていることを確認してください。
      Sound Property EditorのPositioningタブで、Diffraction and Transmissionを有効にする
  3. デフォルトで、回折はオブストラクションのフィルターがかかり、透過損失はオクルージョンのフィルターがかかります。Project > Project Settings > Obstruction/Occlusionに移動します
    1. Obstruction Volumeカーブと、Obstruction LPFカーブを、好きなように調整します。例えばWwise Unity Demo Sceneのプロジェクトでは、以下を用いています:
      Curve | Point 1 | Point 2 | Curve Type
      X | Y | X | Y
      Obstruction Volume | 0 | 0 | 100 | -3 | Linear
      Obstruction LPF | 0 | 0 | 100 | 60 | Linear
      Occlusion Volume | 0 | 0 | 100 | -12 | Sine (Constant Power Fade In)
      Occlusion LPF | 0 | 0 | 100 | 75 | Sine (Constant Power Fade Out)
    2. Obstruction Volumeカーブは、このように表示されます:
      Wwise Project SettingsのObstruction/Occlusionカーブ
  4. プロジェクトを保存する。
  5. Unityプロジェクトで、Wwise Picker: Windows > Wwise Picker でバンクをリフレッシュします
    1. サウンドバンクを生成します
      Wwise Picker

B. Room

シーンの中で、各ルームがどこにあるのかを指定します。これを行うには、 AkRoom コンポーネントを使います。

  1. Wwise Unity Demo Sceneのチュートリアルシーンでは、建物の中の各ルームの内側を表すために、キューブメッシュを追加しました。 Surface Reflectorチュートリアル を終えたばかりであれば、 AkSurfaceReflector コンポーネントのあるGameObjectsを使えます。
    1. GameObject > 3D Object > Cubeで、キューブを追加します。
    2. Mesh Rendererコンポーネントを除きます。
    3. Box Colliderコンポーネントの、Is Triggerにチェックを入れます。
    4. AkRoom コンポーネントを追加します｡
      1. Reverb Aux Bus に対応するAuxiliary Busをピックします。
      2. ルームに Rigidbody コンポーネントを追加するよう、警告メッセージが提案します。そうすると、 AkRoom コンポーネントと AkRoomAwareObject コンポーネントのやり取りが可能になります。次は、それらのコンポーネントを追加する手順です。
        AkRoom コンポーネント
  2. ルームを使用するので、すべてのリスナーやエミッタが "Room Aware" となるように、 AkRoomAwareObject コンポーネントを追加します。
    1. すでに、Spatial Audioのリスナーに AkRoomAwareObject コンポーネントが自動的に追加されていたので、そのコンポーネントが有効になっていることを確認してください。
      AkRoomAwareObject コンポーネント
    2. 上図のように2つの警告メッセージが表示されることがあります。
      1. 1つ目は、Rigidbody コンポーネントをルーム上、または現在のオブジェクト上に配置する必要性を示しています。まだルームに追加していなければ、 Add Rigidbody をクリックします。
      2. 2つ目の警告メッセージは、コライダーについてです。 AkRoomAwareObject が AkRoom コンポーネントとやり取りするには、コライダーが必要です。

C. Portal

リスナーがエミッターと違う部屋にいるときは、音がルームの「壁」によって妨げられます。壁に、透過損失値を設定することができます（ /ref pg_obs_occ を参照）。そうしない場合は、希望する開口部から音の伝搬を直接受け取るには、ポータルを追加する必要があります。SpatialAudioTutorialシーンには、ポータルを置ける開口部が2つあります。1つは屋外エリアと小ルームの間の開口部で、もう1つは2つのルームの間です。

  1. 2つの AkRoomPortal コンポーネントが必要なので、GameObject > Wwise > Room Portal の手順で作成し、それらを開口部周りに配置します。
  2. Sceneウィンドウで、ポータルの周りに黄色い帯が表示され、ポータルの大きさと配置する時の向きを示します。赤線が、ポータルの表と裏のエリアの境界線を示します。前は、ローカルのZ軸と同じ方向です。
    Sceneウィンドウの、AkRoomPortal
  3. AkRoomPortal コンポーネントで、以下を行います:
    1. Open On Start.
    2. Close On Nothing.
    3. Back RoomとFront Roomに表示された AkRoom コンポーネントが正しいことを確認してください。
  4. 以下は、小ルームと屋外の間のポータルの、 AkRoomPortal コンポーネントの設定です:
    AkRoomPortalコンポーネント

D. 設定の検証

  1. 音の伝搬パスをシーン内で描写させたい場合は、エミッタに AkSpatialAudioDebugDraw コンポーネントを追加します。
    1. Draw Diffraction Paths オプションにチェックを入れます。
      AkSpatialAudioDebugDraw コンポーネント
  2. ゲームをスタートし、Wwiseに接続します。
    1. 1つの部屋のボタンを押して、リバーブを聞きます。
      1. Voice Graphにこのように表示されます:
        Voice Graphに表示されたRoom
    2. ルームを出て、別のルームで再生中のエミッターが見えたり見えなかったりする位置に移動しながら、音に適用される回折を聞いてみます。リスナーとポータルの間の角度によって、ディフラクションが多く聞こえたり少なく聞こえたりします。
      1. Unityの Scene ウィンドウに、ポータルからくる音のパスが表示されます。音に適用されている回折率は、回折ポイントに表示されます。
        上から見た、ポータルを通る回折パス
    3. AuthoringのGame Object Profilerレイアウトを開きます（ショートカットはF12）
      1. すでに設定されていなければ、Game Object 3D Viewer Settingsで、Diffraction Pathsを有効にします。
        ポータルの回折パスの、Game Object 3D Viewer Settings
    4. Game Object 3D Viewerに、以下が表示されます:
      1. 可視化されたルームやポータル。
      2. エミッターからポータルを通り、リスナーまで進む回折パス。エッジに、その回折率が表示されます。緑色のバーチャルソースが出現し、音が実際にどこからくるのかを示しています。
      3. ルームの壁を通る透過パスと、その透過損失（）。
      4. 家アイコンとともに表示される、ルームのウェットサウンド。この図では、ポータルから出てくるものが1つと、ルームの壁を通る音を表しているものが1つあります。
      5. エミッターやリスナーの名前の下に、そのルームがあります。リスナーはルーム内にいないので、デフォルトで"Outdoors"ルームに入れられます。
        1. リスナーをルームに移動すると、Game Object 3D Viewerに表示中のリスナーゲームオブジェクトの下の、ルーム名（Room:）が変わるのが分かります。
          Game Object 3D Viewerで見る、ポータルを通る回折パス
注記： 屋外にリバーブを追加するには、エリア全体の周りにルームを追加します。ルームのプライオリティが、あなたのシーンにあるほかの AkRoom コンポーネントよりも、必ず低くなるようにしてください。

E. ポータルと、リバーブ

ポータル経由で発せられるサウンドに、リスナーがいるルームのリバーブを使うことができます。これをルームカップリングと呼びます。

  1. ルームのAuxiliary Bus Property Editorを開き、General Settingsタブの Use game-defined auxiliary sends がチェックされていることを確認します。そうすると、ルームのリバーブが、シーン内のほかのリバーブに送られます。
  2. 小部屋のエミッターを再生中に大部屋に入ると、小部屋のリバーブが、大部屋のリバーブに送られるのが分かります。
    Voice Graphのルームカップリング

注記： Wwise Unity Demo Sceneに Surface Reflectorチュートリアル と ルームやポータルに関するチュートリアル が実装されているほか、回折も実装されています。詳細は、 Spatial Audioのその他の機能 を参照してください。

参照
  • ルームカップリング

F. Room Tone

時々、ルームに空調の音など特定のアンビエント音があります。これを再現するには、Spatial Audio Roomゲームオブジェクトにイベントをポストします。リスナーがルームにいると、その音のポジションはリスナーの位置となります。ほかのルームに入ると、リスナーには、ルームトーンを出すルームと、リスナーをつなげるポータルから、そのルームトーンが聞こえてきます。

  1. Wwiseプロジェクトで、
    1. ルームトーン用に新しいSound SFXを作成します。
      1. Game-defined aux sendsを有効にし、ルームトーンをルームリバーブに送れるようにします。
    2. このルームトーンを使ったPlayイベントを作成するために、Sound SFXを右クリックしてから、 New Event > Play を選択します。
    3. プロジェクトを保存する。
  2. Unityで、
    1. このイベントを、1つのルームの AkRoom コンポーネントの、Room Tone Eventパラメータに追加します。
      1. Aux Send Levelを調整して、音の一部がルームのリバーブに送られるようにします。
      2. このイベントのトリガー方法は、自分で選べます。
        Roomを有効にしたSpatial Audio Volumeの、 AkEventのセクション。
  3. SoundBankを生成します。
  4. シーンをスタートし、Wwise Authoringに接続します。
  5. ルームトーンが聞こえることを確認します。
    1. Advanced Profilerビューに、再生中のイベントが表示されるはずです。
      ルームトーンのあるルームにリスナーがいるときの、Advanced Profilerビュー
    2. リスナーを動かしながら、3D Game Object Viewerでルームのゲームオブジェクトを観察します。
      1. もしリスナーがルーム内にいれば、ルームはリスナーの位置において音を出します。ルームのゲームオブジェクトが、リスナーのゲームオブジェクトのあとをついていくのが分かります。
      2. もしリスナーが別のルームにいれば、ルームのゲームオブジェクトはポータルの位置に配置され、そこからリスナーのゲームオブジェクトまでのパスが、描写されます。
        Game Object 3D Viewerでルームゲームオブジェクトを観察する
参照
  • Spatial Audioのコンポーネント
  • Spatial Audio Rooms and Portals Documentation


Wwise Unity Integration Documentation: Spatial Audioのその他の機能

Spatial Audioのその他の機能
  • A. Surface Reflectorと、Portal
  • B. Surface Reflectorと、Reverb
  • C. Diffraction（回折）
  • D. Transmission（透過）
  • E. ルームをSurface Reflectorと関連付ける（非推奨）
注記： このページの前提として、 Spatial Audioチュートリアルの事前準備 を完了し、さらに Surface Reflectorチュートリアル と、 ルームやポータルに関するチュートリアル の両方を完了しておいてください。

A. Surface Reflectorと、Portal

ポータル（Portal）はルーム（Room）の開口部であり、そこを通って音が伝播しますが、ポータルには反射面を開口する役割もあります。単純な立方体をサーフェスリフレクタとして使うと、メッシュの開口部分でもリフレクション（反射）が発生してしまうことを、私たちは Surface Reflectorチュートリアル の終わりに気づきました。この問題の対策として、Spatial Audioのポータルは、リフレクションパスも認識し、通過させることができます。リフレクションパスは、ポータルの境界線で回折することもできます。

  1. 設定は単純で、ルームとサーフェスリフレクタを貫通するポータルを配置するだけです。
    リフレクションパスがポータルを通過する様子を示す、Game Object 3D Viewer

B. Surface Reflectorと、Reverb

後期リバーブ（Late reverb）のあるルームでは、アーリーリフレクションをリバーブに送り込み、空間の形状をリバーブで意識できるようにすることが可能です。

  1. Wwiseプロジェクトで、Reflectエフェクトを適用したAuxiliary Busを開きます。
    1. General Settingsタブで、 Use game-defined auxiliary sends がチェックされていることを確認します。
      Auxiliary Bus Property EditorのGeneral Settingsタブで、ルームリバーブにアーリーリフレクションを送る
  2. シーンを再生して、小ルーム（Small Room）の中のボタンを押します。プレイヤーが小ルームにいると、Voices Graphには以下のように表示されます:
    Voices Graphで、Small Roomのアーリーリフレクションを、Small Roomのリバーブに送る

C. Diffraction（回折）

エミッターとリスナーの間にオブジェクトが出現するときに、Spatial Audioを使い、このオブジェクトの周りを回る回折パス（Diffraction path）を作成できます。エッジを回るパスの角度に基づいて、オブストラクションをシミュレーションし、音を減衰させます。回折（Diffraction）を、個別のサウンドや、個別のサーフェスリフレクタに対して設定できます。回折を有効にしたサウンドを出すエミッターは、回折を有効にした反射面でしか回折しません。

  1. サウンドの回折を有効にするには:
    1. Positioningタブで、Enable Diffractionチェックボックスがチェックされていることを確認します。
      サウンドにDiffractionを設定する
  2. AkSurfaceReflector コンポーネントの回折を有効にするには:
    1. Enable Diffractionをチェックします。これで、Wwise Spatial Audioに送られるジオメトリに、回折エッジが生じます。Wwiseがゲームに接続したときに、回折エッジをゲームオブジェクトビュアーで見ることができます。
    2. 場合によって、Enable Diffraction On Boundary Edgesもチェックします。前の手順のチェックボックスをチェックすると、このチェックボックスが表示されます。バウンダリーエッジとは、1つの三角形だけに接するエッジです。例えば、UnityのQuad 3D Objectを囲うエッジなどは、バウンダリーエッジとみなされます。
      Diffractionを有効にした AkSurfaceReflector
  3. Wwise Unity Demo Sceneでは、屋外のエミッター、バリア、そして建物の外壁で、回折を有効にしてあります。回折パスは、紫色です。それぞれのバーチャルソースが作成されて、音が出される場所に配置されます。
    Game Object 3D Viewerに表示された回折パス
    参照
    • Spatial Audio Diffraction
    • Geometry APIを使用した回折シミュレーション

D. Transmission（透過）

エミッターとリスナーの間にオブジェクトが出現すると、音はそのオブジェクトの中を通ることもできます。この現象をモデル化するために、Spatial Audioでは、音のダイレクトパスにフィルターをかけます。エミッターがルーム内にあれば、ルームの壁が音をブロックするオブジェクトのようなはたらきをします。この場合は、透過（Transmission）をモデル化するために、音のダイレクトパスとウェットパスにフィルターをかけます。AkSurfaceReflector コンポーネントや AkRoom コンポーネントに、0から1までの透過損失値を適用できます。デフォルトで、プロジェクトのオクルージョンボリューム、ローパス、そしてハイパスの各カーブが透過に使われます。通常は設定値が1.0であれば完全な損失を意味し、設定値が0.0であれば音がフィルターされずにジオメトリを透過することを意味します。

  1. Spatial Audio Settingsで、 Use Occlusion を有効にします。これで、透過損失値がWwiseプロジェクトのOcclusionカーブに関連付けられます。
    Spatial Audioの初期設定
  2. フィルターとして音に適用する最終的な透過損失値は、その音がエミッターからリスナーまでのダイレクトパスにおいて遭遇するAkSurfaceReflector コンポーネントや AkRoom コンポーネントから送られる、全てのサーフェスの透過損失値のうちの最大値です。
    1. AkSurfaceReflector コンポーネントで、 Surface Reflectorメッシュの各サブメッシュに透過損失値を関連付けるために、Transmission Loss Valuesアレイを設定します。
      AkSurfaceReflector コンポーネントのTransmission Loss Valuesアレイ
    2. AkRoom コンポーネントで、Transmission Lossパラメータの透過損失値を変更します。
      AkRoom コンポーネントのTransmission Lossパラメータ
  3. 透過にオクルージョンを使う場合は、Wwise AuthoringのProject Settingsで、Obstruction/OcclusionタブにあるOcclusionカーブを調節します。
    WwiseのProject SettingsのOcclusionカーブ
    参照
    • Spatial Audio Transmission
    • Rooms and Portal Transmission

E. ルームをSurface Reflectorと関連付ける（非推奨）

警告： AkSurfaceReflectorコンポーネントのAssociated Roomプロパティが非推奨になったため、今後のバージョンで削除される予定です。このプロパティは使用せず、Noneのままにすることを推奨します。

Spatial Audioにサーフェスリフレクタを追加すると、必ずその回折（Diffraction）エッジや、それが視界に入るかが、分析されます。この処理を最適化するために、各ルームに複数のサーフェスリフレクタをつなげるグループを設定できます。1つのルームに関連付けられたサーフェスリフレクタは、ほかのルームからは見えません。サーフェスリフレクタを、1つのルームに関連付けるのが適しているのは、サーフェスリフレクタがそのルームに完全に包囲されていて、そのルームに、ほかのルームと共有するサーフェスリフレクタがない場合です。ルームを、サーフェスリフレクタに関連付けるかどうかは、全く自由です。ルームを選択していないサーフェスリフレクタは、サーフェスリフレクタをまとめたグローバルグループに追加されます。サーフェスリフレクタをルームに関連付けることで、反射や回折の計算で実行する、レイキャストのサーチ対象範囲を削減できます。

  1. ルームとサーフェスリフレクタを関連付けるには、 AkSurfaceReflector コンポーネントのAssociated Roomの下にある、ルームを、1つ選択します。
    AkSurfaceReflectorにAssociated Roomを設定する
AkEvent
Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017....
Definition: AkEvent.cs:48
AkSurfaceReflector.RemoveGeometryInstance
void RemoveGeometryInstance()
Remove this component's geometry instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:401
AkEnvironmentPortal.axis
UnityEngine.Vector3 axis
The axis used to find the contribution of each environment
Definition: AkEnvironmentPortal.cs:27
TransportState
Used to deserialize transport-state information receieved from the transport.stateChanged topic.
Definition: AkWaapiHelper.cs:187
AkSpatialAudioEmitter
(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb c...
Definition: AkSpatialAudioEmitter.cs:26
AkWaapiUtilities.Disconnecting
static System.Action< bool > Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket conn...
Definition: AkWaapiUtilities.cs:42
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AkWwiseTreeWAAPIDataSource
This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object h...
Definition: AkWwiseTreeWAAPIDataSource.cs:31
AkListenerDistanceProbe
Add this script on a listener game object to assign another game object as a distance probe....
Definition: AkListenerDistanceProbe.cs:28
AkRadialEmitter
A radial emitter is for sounds that are not point sources, but instead originate from a region of spa...
Definition: AkRadialEmitter.cs:26
AK.Wwise.AcousticTexture
This type represents an Acoustic Texture.
Definition: AkWwiseAcousticTexture.cs:25
ak.wwise.core
Definition: Uri.cs:103
ArgsObject
WAAPI arguments containing an object identfier.
Definition: AkWaapiHelper.cs:57
AkBank.decodeBank
bool decodeBank
Decode this SoundBank upon load
Definition: AkBank.cs:31
AK
Definition: AkWwiseAcousticTexture.cs:21
AkSurfaceReflector.AcousticTextures
AK.Wwise.AcousticTexture[] AcousticTextures
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry....
Definition: AkSurfaceReflector.cs:36
AkSurfaceReflector.TransmissionLossValues
float[] TransmissionLossValues
The transmission loss value per submesh. The transmission loss value is a control value used to adjus...
Definition: AkSurfaceReflector.cs:41
AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >
static void QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response.
Definition: AkWaapiUtilities.cs:564
ak.wwise
Definition: Uri.cs:73
AkReverbZone.SetReverbZone
static void SetReverbZone(AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and it...
Definition: AkReverbZone.cs:60
AkBank.loadAsynchronous
bool loadAsynchronous
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the Sound...
Definition: AkBank.cs:36
AK.Wwise.Event.StopMIDI
void StopMIDI()
Stops all MIDI Events on this Event.
Definition: AkWwiseEvent.cs:232
AkWaapiUtilities.GetWwiseObject< T >
static void GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options.
Definition: AkWaapiUtilities.cs:582
ak.wwise.core.undo
Definition: Uri.cs:193
ak.wwise.error
Definition: Uri.cs:75
Wamp.ErrorException
Exception thrown during WAMP operations.
Definition: Wamp.cs:44
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:213
AkSpatialAudioDebugDraw.drawDiffractionPaths
bool drawDiffractionPaths
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the ...
Definition: AkSpatialAudioDebugDraw.cs:35
AkRoomPortal.ClosePortal
void ClosePortal(UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event
Definition: AkRoomPortal.cs:221
AkRoomPortal.GetID
ulong GetID()
Access the portal's ID
Definition: AkRoomPortal.cs:181
AkReverbZone.TransitionRegionWidth
float TransitionRegionWidth
Width of the transition region between the Reverb Zone and its parent. The transition zone is centere...
Definition: AkReverbZone.cs:43
AkRoom.reverbLevel
float reverbLevel
The reverb control value for the send to the reverb aux bus.
Definition: AkRoom.cs:47
AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
Definition: AkEnvironment.cs:86
AkWaapiUtilities.SelectObjectInAuthoring
static void SelectObjectInAuthoring(System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to Selec...
Definition: AkWaapiUtilities.cs:728
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:201
AkWaapiUtilities.Search< T >
static void Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command....
Definition: AkWaapiUtilities.cs:665
AkEnvironment.AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities.
Definition: AkEnvironment.cs:72
AkEvent.transitionDuration
float transitionDuration
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:84
AkSpatialAudioEmitter.reflectionsAuxBusGain
float reflectionsAuxBusGain
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:37
AkSurfaceReflector.GeometryData
The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
Definition: AkSurfaceReflector.cs:112
AkGameObj.GetUpward
virtual UnityEngine.Vector3 GetUpward()
Definition: AkGameObj.cs:298
AkSurfaceReflector.GetGeometryDataFromMesh
static void GetGeometryDataFromMesh(UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkS...
Definition: AkSurfaceReflector.cs:186
AkSurfaceReflector
This component converts the provided mesh into Spatial Audio Geometry.
Definition: AkSurfaceReflector.cs:27
JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:27
AkSpatialAudioEmitter.roomReverbAuxBusGain
float roomReverbAuxBusGain
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Vo...
Definition: AkSpatialAudioEmitter.cs:45
AkSpatialAudioEmitter.diffractionMaxPathLength
uint diffractionMaxPathLength
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:56
AkWaapiUtilities.GetChildren< T >
static void GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object.
Definition: AkWaapiUtilities.cs:686
AkSpatialAudioListener.SpatialAudioListeners
static SpatialAudioListenerList SpatialAudioListeners
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.
Definition: AkSpatialAudioListener.cs:47
AK.Wwise.BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and S...
Definition: AkWwiseBaseGroupType.cs:25
AkSpatialAudioEmitter.drawDiffractionPaths
bool drawDiffractionPaths
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:72
AkSpatialAudioListener.SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio l...
Definition: AkSpatialAudioListener.cs:71
AkMemBankLoader.isLocalizedBank
bool isLocalizedBank
Is the bank localized (situated in the language-specific folders)
Definition: AkMemBankLoader.cs:31
ArgsPlay
WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.
Definition: AkWaapiHelper.cs:119
AkSurfaceReflector.UpdateGeometry
void UpdateGeometry()
Update this component's geometry instance
Definition: AkSurfaceReflector.cs:382
ak.wwise.ui.commands
Definition: Uri.cs:297
AkWaapiUtilities.TogglePlayEvent
static void TogglePlayEvent(WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to...
Definition: AkWaapiUtilities.cs:876
AkSpatialAudioEmitter.drawSecondOrderReflections
bool drawSecondOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:66
ak.wwise.core.transport
Definition: Uri.cs:230
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkMemBankLoader.LoadNonLocalizedBank
void LoadNonLocalizedBank(string in_bankFilename)
Load a SoundBank from WWW object
Definition: AkMemBankLoader.cs:56
WwiseRenameInfo
Used to deserialize information published on the ak.wwise.core.@object.nameChanged topic.
Definition: AkWaapiHelper.cs:246
AkSpatialAudioEmitter.reflectAuxBus
AK.Wwise.AuxBus reflectAuxBus
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:30
AkWaapiUtilities.IsPlayable
static bool IsPlayable(WwiseObjectType type)
Checks if Wwise object is playable.
Definition: AkWaapiUtilities.cs:865
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:61
AkWaapiUtilities.GetWwiseObjects< T >
static void GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options.
Definition: AkWaapiUtilities.cs:594
AkRadialEmitter.outerRadius
float outerRadius
Definition: AkRadialEmitter.cs:38
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AkAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkAudioListener.cs:27
AkSurfaceReflector.EnableDiffractionOnBoundaryEdges
bool EnableDiffractionOnBoundaryEdges
Switch to enable or disable geometric diffraction on boundary edges for this mesh....
Definition: AkSurfaceReflector.cs:49
AkWaapiUtilities.WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by ...
Definition: AkWaapiUtilities.cs:102
AkWaapiUtilities.Unsubscribe
static void Unsubscribe(uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to ...
Definition: AkWaapiUtilities.cs:1041
AkSurfaceReflector.SetGeometry
void SetGeometry()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.
Definition: AkSurfaceReflector.cs:343
SelectedWwiseObjects
Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiHelper.cs:237
Wamp.WampNotConnectedException
Definition: Wamp.cs:35
AkSpatialAudioEmitter.diffractionMaxPaths
uint diffractionMaxPaths
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:53
AK.Wwise.TypeMigration
Definition: AkWwiseTypeMigration.cs:31
AkSpatialAudioEmitter.drawFirstOrderReflections
bool drawFirstOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:63
ErrorMessage
Used to deserialize WAAPI error messages.
Definition: AkWaapiHelper.cs:199
AkRoomAwareObject.ExitedRoom
void ExitedRoom(AkRoom room)
Called when exiting a room.
Definition: AkRoomAwareObject.cs:101
AK.Wwise.Event.StopMIDI
void StopMIDI(UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:223
AkBank.UnloadBank
void UnloadBank(UnityEngine.GameObject in_gameObject)
Unloads a SoundBank
Definition: AkBank.cs:124
AkTriggerBase.Trigger
delegate void Trigger(UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers.
Wamp.PublishHandler
delegate void PublishHandler(string json)
Publish events are delegates registered with Subscribe.
AkReverbZone.SetReverbZone
void SetReverbZone()
Calls AkReverbZone::SetReverbZone() with this component's properties
Definition: AkReverbZone.cs:94
AkEnvironmentPortal.EnvListWrapper
This enables us to detect intersections between portals and environments in the editor
Definition: AkEnvironmentPortal.cs:90
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkSpatialAudioListener.SpatialAudioListenerList.Remove
bool Remove(AkSpatialAudioListener listener)
Removes listeners from the list
Definition: AkSpatialAudioListener.cs:107
AkRoom.reverbAuxBus
AK.Wwise.AuxBus reverbAuxBus
The reverb auxiliary bus.
Definition: AkRoom.cs:43
AkWaapiUtilities.GetResultDelegate< T >
delegate void GetResultDelegate< T >(T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI...
AkMemBankLoader.LoadLocalizedBank
void LoadLocalizedBank(string in_bankFilename)
Load a language-specific bank from WWW object
Definition: AkMemBankLoader.cs:63
AkBank.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Loads the SoundBank
Definition: AkBank.cs:101
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
Wamp.TimeoutException
Exception thrown during WAMP operations when the timeout is reached.
Definition: Wamp.cs:27
AkSwitch
This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered....
Definition: AkSwitch.cs:29
AkSpatialAudioDebugDraw.drawSecondOrderReflections
bool drawSecondOrderReflections
This allows you to visualize second order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:29
AK.Wwise.Trigger
This type can be used to post triggers to the sound engine.
Definition: AkWwiseTrigger.cs:25
AkGameObj.m_positionOffsetData
AkGameObjPositionOffsetData m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Positio...
Definition: AkGameObj.cs:49
AkSurfaceReflector.SetGeometryInstance
void SetGeometryInstance()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.
Definition: AkSurfaceReflector.cs:369
AkWaapiUtilities.ParseRenameObject
static WwiseRenameInfo ParseRenameObject(string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic.
Definition: AkWaapiUtilities.cs:1078
AkGameObj.GetForward
virtual UnityEngine.Vector3 GetForward()
Definition: AkGameObj.cs:291
AkEventCallbackMsg.sender
UnityEngine.GameObject sender
GameObject from whom the callback function was called
Definition: AkEvent.cs:29
ArgsDisplayName
WAAPI arguments containing an object identfier and name used when deleting an object.
Definition: AkWaapiHelper.cs:88
ArgsRename
WAAPI arguments containing an object identfier and new value used when renaming an object.
Definition: AkWaapiHelper.cs:72
TransportOptions
WAAPI options used to specify the transport ID when subscribing.
Definition: AkWaapiHelper.cs:164
AkRoom
An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoom...
Definition: AkRoom.cs:25
AkWaapiUtilities.ParseObjectInfo
static List< WwiseObjectInfo > ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects...
Definition: AkWaapiUtilities.cs:713
AkSurfaceReflector.SetGeometryFromMesh
static void SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and t...
Definition: AkSurfaceReflector.cs:138
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AkWaapiUtilities.Disconnected
static void Disconnected()
Invoked after the client has disconnected from Wwise authoring.
Definition: AkWaapiUtilities.cs:442
ArgsTransport
WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.
Definition: AkWaapiHelper.cs:131
AkWaapiUtilities.QueueConsumed
static System.Action QueueConsumed
Fired when all commands in the queue have been executed.
Definition: AkWaapiUtilities.cs:52
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25
AkWaapiUtilities.ParseSelectedObjects
static List< WwiseObjectInfo > ParseSelectedObjects(string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiUtilities.cs:1062
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:278
AkEarlyReflections.reflectionsAuxBus
AK.Wwise.AuxBus reflectionsAuxBus
Definition: AkEarlyReflections.cs:32
AkSpatialAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkSpatialAudioListener.cs:30
ak.wwise.ui
Definition: Uri.cs:286
AkReverbZone
This component establishes a parent-child relationship between two Rooms and allows for sound propaga...
Definition: AkReverbZone.cs:27
AkRoomAwareObject.EnteredRoom
void EnteredRoom(AkRoom room)
Called when entering a room.
Definition: AkRoomAwareObject.cs:92
AkWaapiUtilities.OpenWorkUnitInExplorer
static void OpenWorkUnitInExplorer(System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:751
AK.Wwise.State
This type can be used to set Wwise States.
Definition: AkWwiseState.cs:25
AkWaapiUtilities.Delete
static void Delete(System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiComm...
Definition: AkWaapiUtilities.cs:838
AkBank.unloadTriggerList
System.Collections.Generic.List< int > unloadTriggerList
Reserved.
Definition: AkBank.cs:42
AkSpatialAudioEmitter.reflectionsOrder
uint reflectionsOrder
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.
Definition: AkSpatialAudioEmitter.cs:40
ReturnTransport
Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transpo...
Definition: AkWaapiHelper.cs:178
AkWwiseTreeWAAPIDataSource.SubscribeTopics
void SubscribeTopics()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to ke...
Definition: AkWwiseTreeWAAPIDataSource.cs:391
AkWaapiUtilities.QueueCommandWithReturnType< T >
static void QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will des...
Definition: AkWaapiUtilities.cs:548
WaapiKeywords.WwiseObjectTypeStrings
static ReadOnlyDictionary< WwiseObjectType, string > WwiseObjectTypeStrings
Maps WwiseObjectType to strings.
Definition: AkWaapiHelper.cs:464
AkRoomAwareManager
This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.
Definition: AkRoomAwareManager.cs:22
AkRoom.SetReverbZone
void SetReverbZone(AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a ...
Definition: AkRoom.cs:591
WwiseObjectInfoParent
Contains the GUID of the returned object's parent.
Definition: AkWaapiHelper.cs:328
AkEventCallbackMsg
Event callback information. Event callback functions can receive this structure as a parameter
Definition: AkEvent.cs:24
AkEventCallbackMsg.info
AkCallbackInfo info
For more information about the event callback, see the classes derived from AkCallbackInfo.
Definition: AkEvent.cs:26
AkState
This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered....
Definition: AkState.cs:29
AkRoom.PriorityList
Definition: AkRoom.cs:620
AkSurfaceReflector.Mesh
UnityEngine.Mesh Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.
Definition: AkSurfaceReflector.cs:32
AkMemBankLoader.bankName
string bankName
Name of the bank to load
Definition: AkMemBankLoader.cs:28
AkEnvironmentPortal.environments
AkEnvironment[] environments
Definition: AkEnvironmentPortal.cs:32
AkSpatialAudioDebugDraw.drawHigherOrderReflections
bool drawHigherOrderReflections
This allows you to visualize third or higher order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:32
WaapiHelper
Contains a helper function GetWwiseObjectTypeFromString.
Definition: AkWaapiHelper.cs:354
AkRoom.GetID
ulong GetID()
Access the room's ID
Definition: AkRoom.cs:195
AkSurfaceReflector.RemoveGeometry
void RemoveGeometry()
Remove this component's geometry and corresponding instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:390
AkSurfaceReflector.SetGeometryInstance
static void SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction)
Add or update an instance of the geometry by sending the transform of this component to Wwise....
Definition: AkSurfaceReflector.cs:297
AkRoomPortal.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event
Definition: AkRoomPortal.cs:215
AkSurfaceReflector.AssociatedRoom
AkRoom AssociatedRoom
Definition: AkSurfaceReflector.cs:57
AkRoom.roomToneEvent
AK.Wwise.Event roomToneEvent
Wwise Event to be posted on the room game object.
Definition: AkRoom.cs:54
AkMemBankLoader
This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory....
Definition: AkMemBankLoader.cs:22
AkRoom.transmissionLoss
float transmissionLoss
Loss value modeling transmission through walls.
Definition: AkRoom.cs:51
Args
Abstract base class for WAAPI command arguments.
Definition: AkWaapiHelper.cs:36
WaapiKeywords.FolderDisplaynames
static ReadOnlyDictionary< string, string > FolderDisplaynames
Maps root folder names to displayed strings.
Definition: AkWaapiHelper.cs:487
AkReverbZone.ReverbZone
AkRoom ReverbZone
Definition: AkReverbZone.cs:33
AkRoom.priority
int priority
Definition: AkRoom.cs:40
AkSpatialAudioDebugDraw.drawFirstOrderReflections
bool drawFirstOrderReflections
This allows you to visualize first order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:26
AkEnvironment
Use this component to define a reverb zone. This needs to be added to a collider object to work prope...
Definition: AkEnvironment.cs:34
Wamp
WAMP protocol implementation using only strings and regular expressions. This implements only a subse...
Definition: Wamp.cs:24
AkEventCallbackMsg.type
AkCallbackType type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callback...
Definition: AkEvent.cs:32
AkEvent.enableActionOnEvent
bool enableActionOnEvent
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop eve...
Definition: AkEvent.cs:56
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23
AkRoom.RemoveReverbZone
void RemoveReverbZone()
Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and...
Definition: AkRoom.cs:613
AkWaapiUtilities.Subscribe
static void Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their optio...
Definition: AkWaapiUtilities.cs:1015
AkEvent.curveInterpolation
AkCurveInterpolation curveInterpolation
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:53
AkWaapiUtilities.Rename
static void Rename(System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to Rename...
Definition: AkWaapiUtilities.cs:813
AkGameObj.isEnvironmentAware
bool isEnvironmentAware
Is this object affected by Environment changes? Set to false if not affected in order to save some us...
Definition: AkGameObj.cs:36
ReturnWwiseObjects
Generic class to deserialize a WAAPI response containing Wwise objects with custom return options.
Definition: AkWaapiHelper.cs:228
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:150
AkWaapiUtilities.Connected
static System.Action Connected
Fired when the connection is established, should be used by external classes to subscribe to topics t...
Definition: AkWaapiUtilities.cs:47
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34
AkSpatialAudioEmitter.reflectionMaxPathLength
float reflectionMaxPathLength
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Dista...
Definition: AkSpatialAudioEmitter.cs:33
AkInitializer
This script deals with initialization, and frame updates of the Wwise audio engine....
Definition: AkInitializer.cs:38
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:88
AkSpatialAudioListener.SpatialAudioListenerList.Add
bool Add(AkSpatialAudioListener listener)
Uniquely adds listeners to the list
Definition: AkSpatialAudioListener.cs:85
AkWwiseTrigger
This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered....
Definition: AkWwiseTrigger.cs:28
AkEmitterObstructionOcclusion
Completely obstructs/occludes the emitter of the current game object from its listeners if at least o...
Definition: AkEmitterObstructionOcclusion.cs:23
AkSpatialAudioEmitter.diffractionMaxEdges
uint diffractionMaxEdges
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:50
AkSpatialAudioEmitter.drawHigherOrderReflections
bool drawHigherOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:69
AkWaapiUtilities.GetWwiseObjectAndDescendants< T >
static void GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to ...
Definition: AkWaapiUtilities.cs:628
AkRoom.roomToneAuxSend
float roomToneAuxSend
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones...
Definition: AkRoom.cs:59
AkEvent.soundEmitterObject
UnityEngine.GameObject soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same obj...
Definition: AkEvent.cs:81
WwiseObjectInfo
Class containing the information returned by a WAAPI request for an object.
Definition: AkWaapiHelper.cs:338
AkEarlyReflections.reflectionsVolume
float reflectionsVolume
Definition: AkEarlyReflections.cs:39
AkRoomPortal.MAX_ROOMS_PER_PORTAL
const int MAX_ROOMS_PER_PORTAL
AkRoomPortals can only connect a maximum of 2 rooms.
Definition: AkRoomPortal.cs:26
AkAmbientLargeModePositioner
Use this component to add a Large Mode position to any AkAmbient in a Scene.
Definition: AkAmbientLargeModePositioner.cs:24
AkRoomManager
This manager tracks AkRoomPortals and the rooms that they connect (front and back room).
Definition: AkRoomManager.cs:22
AkReverbZone.RemoveReverbZone
static void RemoveReverbZone(AkRoom reverbZone)
Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms,...
Definition: AkReverbZone.cs:79
WaapiKeywords.typeStringDict
static ReadOnlyDictionary< string, WwiseObjectType > typeStringDict
Maps strings to WwiseObjectType.
Definition: AkWaapiHelper.cs:501
AkWaapiUtilities.IsConnected
static bool IsConnected()
Check whether the client is currently connected.
Definition: AkWaapiUtilities.cs:179
AkWaapiUtilities.GetProject< T >
static void GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project.
Definition: AkWaapiUtilities.cs:701
AkSpatialAudioDebugDraw
Add this script on a GameObject to print Spatial Audio paths.
Definition: AkSpatialAudioDebugDraw.cs:23
AkRoomPortalObstruction
Completely obstructs the spatial audio portal of the current game object from the spatial audio liste...
Definition: AkRoomPortalObstruction.cs:24
AkWaapiUtilities.QueueCommand
static void QueueCommand(string uri, string args, string options)
Use this function to enqueue a command with no expected return object.
Definition: AkWaapiUtilities.cs:533
AK.Wwise.IMigratable
Definition: AkWwiseTypeMigration.cs:25
AkWaapiUtilities.GetWwiseObjectAndAncestors< T >
static void GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy....
Definition: AkWaapiUtilities.cs:613
AkRoomPortal
An AkRoomPortal can connect two AkRoom components together.
Definition: AkRoomPortal.cs:24
AkReverbZone.ParentRoom
AkRoom ParentRoom
Definition: AkReverbZone.cs:39
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:117
Options
Abstract base class for WAAPI command options.
Definition: AkWaapiHelper.cs:141
AkEnvironmentPortal.envList
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class
Definition: AkEnvironmentPortal.cs:95
AkEnvironmentPortal
Use this component to define an area that straddles two different AkEnvironment's zones and allow mix...
Definition: AkEnvironmentPortal.cs:23
AK.Wwise.BaseType
This type represents the base for all Wwise Types that require a GUID.
Definition: AkWwiseBaseType.cs:25
AkReverbZone.RemoveReverbZone
void RemoveReverbZone()
Calls AkReverbZone::RemoveReverbZone() with this component's properties
Definition: AkReverbZone.cs:103
ErrorDetails
Used to deserialize details in WAAPI error messages.
Definition: AkWaapiHelper.cs:209
WaqlArgs
WAAPI arguments containing a WAQL string.
Definition: AkWaapiHelper.cs:44
AkRoomAwareObject
This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms,...
Definition: AkRoomAwareObject.cs:28
AkWaapiUtilities.StopAllTransports
static void StopAllTransports()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransp...
Definition: AkWaapiUtilities.cs:989
AkWaapiUtilities.SubscriptionInfo
Class used to store information about a specific subscription.
Definition: AkWaapiUtilities.cs:118
AkRadialEmitter.innerRadius
float innerRadius
Definition: AkRadialEmitter.cs:44
AkWaapiUtilities.GetResultListDelegate< T >
delegate void GetResultListDelegate< T >(List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAA...
ak
URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK docume...
Definition: Uri.cs:20
AK.Wwise.AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy.
Definition: AkWwiseAuxBus.cs:25
AK.Wwise.Event.Post
uint Post(ulong gameObjectId)
Posts this Event on a GameObject ID.
Definition: AkWwiseEvent.cs:143
AkSpatialAudioListener.TheSpatialAudioListener
static AkAudioListener? TheSpatialAudioListener
Returns the "single" spatial audio listener.
Definition: AkSpatialAudioListener.cs:39
WwiseChildModifiedInfo
Used to deserialize information published on the ak.wwise.core.@object.childAdded and ak....
Definition: AkWaapiHelper.cs:264
WaapiKeywords
Contains fields for specific WAAPI keywords.
Definition: AkWaapiHelper.cs:377
AkBank
Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified...
Definition: AkBank.cs:27
WwiseObjectInfoJsonObject
Used to deserialize information from a request for a Wwise object. Implements an implicit cast to Wwi...
Definition: AkWaapiHelper.cs:284
AkAmbient
Use this component to attach a Wwise Event to any object in a scene. The sound can be started at vari...
Definition: AkAmbient.cs:47
AkEarlyReflections
Set an early reflections auxiliary bus and send volume for a particular game object.
Definition: AkEarlyReflections.cs:25
AkWaapiUtilities.GetStatusString
static string GetStatusString()
Returns a rich text string representing the current WAAPI connection status.
Definition: AkWaapiUtilities.cs:481
AkBank.saveDecodedBank
bool saveDecodedBank
Save the decoded SoundBank to disk for faster loads in the future
Definition: AkBank.cs:39
AkWaapiUtilities.OpenSoundBankInExplorer
static void OpenSoundBankInExplorer(System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:762
ArgsCommand
WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities....
Definition: AkWaapiHelper.cs:103
AkEvent.actionOnEventType
AkActionOnEventType actionOnEventType
Replacement action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:50
AkWaapiUtilities.ParseChildAddedOrRemoved
static WwiseChildModifiedInfo ParseChildAddedOrRemoved(string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise....
Definition: AkWaapiUtilities.cs:1090
AkSurfaceReflector.EnableDiffraction
bool EnableDiffraction
Switch to enable or disable geometric diffraction for this mesh.
Definition: AkSurfaceReflector.cs:45
AK.Wwise.Event.ExecuteAction
void ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject.
Definition: AkWwiseEvent.cs:175


Wwise Unity Integration Documentation: オブストラクションとオクルージョン

オブストラクションとオクルージョン

Unityで、音にオブストラクションやオクルージョンを適用できます。以下の2つの方法があります:

  • スペーシャルオーディオにおける回折。
    • 詳しくは Spatial Audioのその他の機能 のセクション C. Diffraction（回折） を参照
  • 以下のセクションで説明する、オブストラクションやオクルージョンのシンプルなコンポーネント:
    • A. エミッターのオブストラクションとオクルージョン
    • B. ポータルのオブストラクション

A. エミッターのオブストラクションとオクルージョン

Unityで、エミッターのゲームオブジェクトに AkEmitterObstructionOcclusion コンポーネントを追加すると、そのエミッターにオブストラクションやオクルージョンを適用できます。エミッタとリスナーの間のバスで、オブジェクトが見つかると、このコンポーネントが SetObjectObstructionAndOcclusion() をコールし、そのときのobstruction/occlusion値は、1となります。あなたのマップにスペーシャルオーディオが使われていない場合、つまり AkRoom コンポーネントがない場合は、 AkEmitterObstructionOcclusion コンポーネントはオクルージョンを使います。スペーシャルオーディオのシーンでは、同じコンポーネントがオブストラクションを使うのは、スペーシャルオーディオリスナーに対してだけ、つまり AkSpatialAudioListener コンポーネントをもつGameObjectだけです。エミッターに対するオブストラクションは、スペーシャルオーディオのリスナーと同じ部屋にあるエミッターに適用されます。

AkEmitterObstructionOcclusionコンポーネント

オブストラクションやオクルージョンを、必ず正しいオブジェクトに適用できるように、レイヤーマスクを利用します。例えば、プレイヤーオブジェクトのレイヤを指定し、それを AkEmitterObstructionOcclusion コンポーネントから除外すれば、リスナーのボディが音を邪魔したり聞こえにくくしたりしてしまうのを防げます。

Ak Emitter Obstruction Occlusionコンポーネントの、Layer Maskの選択

B. ポータルのオブストラクション

ポータル経由で発せられた音にも、オブストラクションを適用できます。Spatial Audioの回折を使わない場合は、 AkRoomPortal にあるゲームオブジェクトに AkRoomPortalObstruction コンポーネントを使えます。Portalと、Spatial Audioのリスナーの間のパスで、オブジェクトが見つかると、このコンポーネントが SetObjectObstructionAndOcclusion() をコールし、そのときのobstruction値は、1となります。

AkRoomPortalObstructionコンポーネント

ポータルが接する各ルームの、様々なメッシュで、 AkRoomPortalObstruction コンポーネントでオブストラクションが発生します。サーフェスリフレクタが設定されていれば、それらによってポータルの開口が塞がれる可能性もあります。これらを別のレイヤに入れ、 AkRoomPortalObstruction コンポーネントのLayer Maskから除外できるようにしてください。

Ak Room Portal Obstructionコンポーネントの、Layer Maskの選択


Wwise Unity Integration Documentation: UnityのためのWwise Addressablesパッケージ

UnityのためのWwise Addressablesパッケージ

Unity Addressablesについて

Unity AddressablesはAssetBundlesをベースにつくられたシステムで、アセットをプレイヤーとは別にパッケージングするためのものです。 追加のアセットを外部サーバに格納することのできるDLCなどの用途には、特に便利です。

もし、まだAddressablesを使い始めたばかりで慣れていない場合は、 公式ドキュメンテーション や 学習リソース などを読むと良いでしょう。

Wwise Unity Addressablesパッケージを使い始めるには、ここからスタートすると良いでしょう:

  • Wwise Unity Addressablesパッケージをインストールする
  • DLCをパッケージングするための基本チュートリアル

以下のセクションで、Wwise Addressablesパッケージの機能を説明します:

  1. Addressablesシステムの特殊性
  2. 既知の問題点と限界
  3. Wwise Addressablesサンプル
  4. WwiseのAddressable Assetsの概要
    1. SoundBankと、AddressableSoundBank
    2. Addressable Bank Managerについて
    3. WwiseBankReference
    4. WwiseのAsset Importer
    5. ストリーミングメディア
注意： このパッケージは実験的な段階のものです。 Addressablesの対応はUnity integrationに導入された新機能で、変更される可能性があります。
注意： Unity 2018はサポートされていません。 Unity 2018で外部パッケージを使ったときに問題が起きやすいことを考慮すると、このパッケージがUnity 2019よりも前のバージョンで正しく作動することを、保証できません。

Addressablesシステムの特殊性

Addressablesシステムは、以下の特殊性があるので、注意してください:

  • Addressablesでアセットをロードすると、本質的に、非同期となります: SoundBankをロードすることと、イベントをポストすることが、同じトリガーにリンクしている場合は、問題が発生する可能性があります。そこで、イベントの正確なタイミングが特に重要なときは、SoundBankに関連付いているEventがトリガーされる前に、そのSoundBankをロードするようにしてください。なお、Init Soundbankは特別なケースで、シーンのどのSoundBankよりも先にロードする必要があります。Init SoundBankアセットをリモートでアップデートしている場合は、シーンの最初にSoundBankをロードする際に、わずかな追加のディレイが生じることが予測されますが、これは、まずAddressablesを使って新しいInit SoundBankをウェブサーバからフェッチする必要があるからです。
  • Addressableアセットを、シーンで、直接のリファレンスとしてはいけません: Addressablesのアセットは、Addressablesシステムを使ってシーンにダイナミックにロードすることになっています。シーンで直接参照先となっているアセットは、そのシーンのAssetBundleに作り込まれるため、Addressables経由でロードされることはありません。もし、シーンに直接置いたアセットを、Addressablesでもパッケージ化した場合は、ゲームデータに、このアセットの2つの別々のコピーが存在することになります。1つはシーンのAssetBundleにあり、もう1つはAddressableグループのAssetBundleにあります。

既知の問題点と限界

  • プロジェクトの全プラットフォームが、ルートとして同じ Generated SoundBanks Path を共有する必要があります。
  • Unityのプロジェクト設定で Generated SoundBank Path を設定しても、External Sourcesのアウトプットパスは自動的に変更されません。
  • Decoded SoundBanksの保存とロードに、まだ未対応です。
  • Prepared Eventsに、まだ未対応です。
  • External Sourcesに、まだ未対応です。

Wwise Addressablesサンプル

Wwise Addressablesサンプル でWwise Addressablesアセットの管理を助けるために設計されたコードサンプルの追加情報を提供します。

WwiseのAddressable Assetsの概要

WwiseのAsset Importer

作成された .bnk ファイルや .wem ファイルは、WwiseBankImporterクラスやWwiseStreamingAssetImporterクラスによって処理されます。 このスクリプトで、ファイルのバイナリデータの入ったアセットが作成されます。次に、独自のアセットポストプロセッサであるWwiseBankPostProcessが、新アセットをそれぞれのプラットフォームのAddressablesグループに追加します。 各プラットフォームのInit SoundBankは、そのプラットフォームのAddressablesグループに追加されます。ここでInit Bankを別に扱っているのは、リリース後にプロジェクトへの変更（新しいオーディオバスの追加など）があった場合に、それをアップデートする必要があるからです。 Init SoundBankを、Addressable対象の専用AssetBundleにパッケージすることで、ホスティングサービスから、このアセットの最新バージョンを短時間でフェッチできます。 どのAddressablesグループにアセットを追加するのかや、どのラベルをアセットに適用するのかをカスタマイズしたい場合は、 Wwise Addressablesサンプル を参照してください。

SoundBankと、AddressableSoundBank

アセットポストプロセッサは、プロジェクトの各SoundBankのWwiseAddressableSoundBankも作成してくれます。 このアセットには、プラットフォーム名を、そのSoundBankやストリーミングメディアアセットに対してマッピングするディクショナリが入っています。

  • WwiseAddressableSoundBankは、Generated SoundBanksフォルダのルートレベルにあります。
  • WwiseAddressableSoundBankクラスは、SoundBankやメディアファイルをポイントするのに、AssetReferenceTを使います。
  • プロジェクトをビルドするときに、WwiseAddressableSoundBankのCurrent Platfrom Assetsフィールドが、ターゲットとなるビルドプラットフォームに設定されます。
注意： WwiseAddressableSoundBankが参照するSoundBankやストリーミングメディアは、ソフトリファレンスです。Addressablesを使ってロードされるので、必ずAddressablesグループの中にパッケージしてください。
注意： 誤ってWwiseAddressableSoundBankを削除してしまった場合は、それに関連づけられているSoundBankを一度削除して再生成して、新しいものを作成してリファレンスを正しく設定しなおす必要があります。

Init Bank Holderについて

Init SoundBankのWwiseAddressableSoundBankが作成されると、InitBankHolderコンポーネントが、そのシーンのWwiseGlobalゲームオブジェクトに追加されます。 このコンポーネントは、AddressableBankManagerが見つけやすいように、単純にWwiseAddressableSoundBankを保存します。

Addressable Bank Managerについて

Wwise Addressablesを使うと、AkAddressableBankManagerが、メモリにサウンドバンクをロード・アンロードするのを担当します。このクラスに、ロード中やロード済みのAddressableSoundBankへのリファレンスが保存され、必ずInit SoundBankが最初にロードされるようにしてくれます。 もしAkEventが、そのSoundBankのロード終了前にトリガーされてしまった場合は、このクラスが、トリガーされたコールのパラメータを保存し、SoundBankのロードが済んでから、このイベントを再度トリガーします。

SoundBankがロードされたら、現在のプラットフォームに対応するSoundBankアセットが、Addressablesを使ってロードされます。ロードが済むと、SoundBankデータがピン付けされ、AkSoundEngine.LoadBankMemoryCopy()を使ってメモリのコピーがサウンドエンジンにロードされます。

Editorでプレイモードのときは、AddressablesではなくAssetDatabaseを使って、SounBanksが同期的にロードします。非同期のロードは、ビルドしたゲームでしかテストできません。

WwiseBankReference

WwiseBankReferenceクラスは、Ak.Wwise.Bankコンポーネントのために、カスタムInspectorで使います。 WwiseBankReference に、 WwiseAddressableSoundBank へのハードリファレンスが入っています。 このリファレンスはWwiseAddressableSoundBank Assetを AkAssetUtilities.AddressableBankUpdated デリゲート経由で作成した時に更新されます。 WwiseBankReference が WwiseAddressableSoundBank の後に作成された場合は、そのバンク名に一致するWwiseAddressableSoundBankアセットをSoundBanksフォルダ内で探します。 シリアル化されたWwiseBankReferencesは、 Assets\Wwise\ScriptableObjects\SoundBank に保存されます。

注記： ゲームオブジェクトによって直接参照されるアセットは、すべてそのゲームオブジェクトと共にパッケージされます。 AkBank Componentには、WwiseBankReferenceへのハードリファレンスが含まれ、WwiseBankReferenceには、それに対応するWwiseAddressableSoundBankへのハードリファレンスが含まれます。 AkBankコンポーネントのあるGameObjectをAddressablesグループに入れると、それと共にWwiseBankReferenceや、WwiseAddressableSoundBankも、パッケージされます（グループに意図的に追加しなくても）。

ストリーミングメディア

ストリーミングメディア（.wem ファイル）にも、WwiseBankImporterスクリプトが対応します。 WwiseAddressableSoundBankには、このバンクに関連するプラットフォーム別のストリーミングメディアアセットへのリファレンスのリストが、含まれます。 バンクをロードすると、メディアアセットがAddressables経由でロードされ、 Application.persistentDataPath フォルダにコピーされます。 同名のファイルがすでにフォルダ内にある場合は、両者のハッシュを比較します。異なるファイルであれば、そのファイルを、AssetBundleのファイルで上書きします。


Wwise Unity Integration Documentation: Wwise Unity Addressablesパッケージをインストールする

Wwise Unity Addressablesパッケージをインストールする

目次

  • Wwise Addressables Packageを、Unity Package ManagerとGitHubでインストールする
    • Wwise Unity Addressablesパッケージを更新する
    • Unity Addressablesパッケージとの互換性
    • Unity 2018で行う追加手順
  • Wwise Addressables Packageの設定とビルド
  • プロジェクトをビルドする
  • WwiseのAddressables Packageを削除する

Wwise Addressables Packageを、Unity Package ManagerとGitHubでインストールする

Wwise Addressables Package公式レポジトリは : https://github.com/audiokinetic/WwiseUnityAddressables です。

  • UnityのPackage Managerを開き、'+' アイコンをクリックし、 Add package from git URL... を選択します。
  • テキストフィールドに https://github.com/audiokinetic/WwiseUnityAddressables.git をペーストし、Addをクリックします。

Gitレポジトリでホスティングされるパッケージの使い方について、 Unity documentation に詳しい情報があります。

注記： エラーメッセージで "No 'git' executable was found" と表示された場合は、あなたのシステム環境に実行ファイルgit.exeを含むディレクトリを追加し、場合によっては変更を有効にするためにシステムを再起動してください。
注記： WwiseのAddressables機能を正しく使うには、プロジェクトにUnity Addressables Packageを追加する必要があります。このパッケージはWwise Addressables Packageのディペンデンシのリストに入っているので、自動的にインストールされるはずです。

Wwise Unity Addressablesパッケージを更新する

Wwiseの新しいバージョンに更新する時に、Wwise Unity Addressablesパッケージを更新する前にUnity Integrationを更新することを推奨します。

Wwise Unity Addressablesパッケージの更新はWwiseのマイナーまたはメジャーリリースと同じタイミングで公開されますが、頻度はより少ないです。各アップデートに、共にリリース（そしてテスト）したWwiseのバージョンがタグ付けされています。Unity Integrationの最新バージョンとWwise Unity Addressablesパッケージの古いバージョンの互換性を維持することを目指していますが、大掛かりな変更が必要となる場合はこの限りではありません。例えばWwise Unityインテグレーションのバージョン2021.1.7以降は、Wwise Unity Addressablesパッケージの21.1.7タグよりも古いバージョンと互換性がありません（その逆も同じです）。各GitHubタグに対応する項目が レポジトリのリリースページ にあり、ここに変更内容やバージョン互換性が記載されています。

Unity Addressablesパッケージとの互換性

Wwise Unity AddressablesパッケージはUnity Addressablesパッケージの最新版と互換性があります。それよりも古いバージョンとも互換性があるはずですが、1.16.0より古いバージョンではテストされていません。デフォルトでWwise Unity Addressablesパッケージには、Unity Integrationが対応する最小Unityバージョン用のAddressablesパッケージの最新の検証済みバージョンを使用します。対応するUnityバージョンの一覧が リリースノート - Wwise Unityインテグレーション2023.1.1.8417.3007 にあります。

Unity 2018で行う追加手順

Unity 2018.xを使う場合は、 Project Settings > Player > Other Settings の、 Scripting Define Symbols に、 AK_WWISE_ADDRESSABLES と UNITY_ADDRESSABLES を追加してください。

警告： このパッケージはUnity 2018に公式に対応していません。リスクがあることを理解した上で、ご利用ください。

Wwise Addressables Packageの設定とビルド

ステップ 1: 生成されるSoundBankのターゲットディレクトリを、 Project Settings > Wwise Editor > Generated SoundBanks Path で設定します。

注意： SoundBankを正しくインポートするには、このディレクトリが、あなたのAssetsフォルダ内にある必要があります。
  • 今回の例では、ターゲットディレクトリを Assets\WwiseData\Banks に設定します。
  • このパスを変更すると、Wwiseのアウトプットターゲットディレクトリが自動的に変更されます。
  • 変更時にWwise Authoringが開いていれば、プロジェクトのリロードを促すダイアログが表示されます。

ステップ 2: SoundBankを、Wwise Authoring内から生成、またはWwise Pickerを使って生成します。

  • この時点で、 .bnk ファイルや .wem ファイルのカスタムアセットインポーターが、生成されたSoundBankやストリーミングメディアファイルのために、Unityアセットを作成します。
  • メタデータファイルや、特定プラットフォーム用のグループは、AddressableAssetsDataディレクトリで自動的に生成されます。
  • Generated SoundBanks Pathのファイルを確認すれば、あなたのアセットが正しくインポートされたかどうかが分かります。
  • 詳細は WwiseのAddressable Assetsの概要 を参照してください。

ステップ 3: Window > Asset Management > Addressables > Groups をクリックします。WwiseのAddressables Groupsウィンドウが開きます。

デフォルトで、デプロイ予定のプラットフォームごとに、そのプラットフォーム用のSoundBankアセットの入ったグループが1つずつ、作成されます。 また、デプロイ予定のプラットフォームごとに、Init SoundBankだけが入ったグループが、別途作成されます。

シーン内のWwiseGlobalオブジェクトを確認すると、そこにInit Bank Holderコンポーネントが追加されたのが分かります。

ステップ 4: Addressables用にWwise Build Scriptを作成します。

  • これを、デフォルトのビルドスクリプトと一緒に AddressableAssetsData/DataBuilders に入れることを推奨します。
  • ブラウザ内の任意の場所を右クリックして、 Create > Addressables > Content Builders > Wwise Build Script を選択します。
  • これで、 BuildScriptWwisePacked というアセットが作成されます。

ステップ 5: Addressablesの設定を確認します。

  • デフォルトの場所は、 AddressableAssetsData/AddressableAssetSettings
  • Groupsウィンドウからは: Tools > Inspect System Settings
  • Editorからは: Window > AssetManagement > Addressables> Settings

ステップ 6: BuildScriptWwisePackedを、Addressablesビルドスクリプトに追加します。 AddressableAssetSettings のInspectorで、ステップ 4で作成した BuildScriptWwisePacked アセットを Build and Play Mode スクリプトに追加します。

プロジェクトをビルドする

Addressableアセットバンドルを、GroupsウィンドウでWwise Build Scriptを使ってビルドします。 これで、全ての一般アセットバンドル（Default Local Groupなど）や、プラットフォーム別のアセットバンドルが、 Library\com.unity.Addressables\StreamingAssetsCopy\aa\<Platform Name> に生成されます。

注意： Wwise Build Scriptは、WwiseDataグループスキーマの、 Include in Build プロパティに変更を加えます。 グループ名にWwiseDataとあれば、このグループが含まれるのは、グループ名にターゲットのビルドプラットフォーム名も入っている場合だけです。 この動作は、 BuildScriptWwisePacked.cs スクリプトで変更できます。 どのグループを含めるかを、 Include in Build プロパティを使って自分でコントロールしたい場合は、デフォルトのビルドスクリプトを使えばいいだけです。

Addressablesアセットをビルドしてしまえば、通常通りにプロジェクトをビルドできます。

注意： プロジェクトでSoundBankを変更したり新しいSoundBankを追加したりした場合は、Addressableグループを再度ビルドしてください。 また、プラットフォームを切り替えたときは、Addressableグループを再度ビルドするのを忘れないでください。

ビルドのディレクトリでは:

  • Addressableアセットバンドルは、 StreamingAssets\aa\ にコピーされます。

WwiseのAddressables Packageを削除する

パッケージを削除するにあたり、Wwiseインテグレーションが正しく機能するように、いくつかの手順を踏んでください。

  • 生成されたSoundBankの入ったフォルダを、Unityアセットフォルダから削除します。
  • パッケージをアンインストールするために、Unityパッケージマネージャでアンインストールするか、 <UnityProject>\Packages\manifest.json ファイルの該当する行を削除します。
  • WwiseのProject Settingsで、SoundBank PathsをAssetsフォルダ外のパスに設定します。
  • SoundBankを再生成します。
  • まだUnity Addressablesパッケージを使う場合は、Addressablesグループを整理してください。
注記： Unity 2018を使っている場合は、必ず AK_WWISE_ADDRESSABLES と UNITY_ADDRESSABLES Scripting Define Symbols を、 Project Settings > Player > Other Settings で削除してください。


Wwise Unity Integration Documentation: DLCをパッケージングするための基本チュートリアル

DLCをパッケージングするための基本チュートリアル

目次

  • Addressablesのデモシーンをインストールする
  • 始めてみよう
  • Addressablesを使ってアセットをロードする
  • Addressablesを使ってシーンをロードする
  • ランゲージを変える
  • Addressablesのホスティングを設定する
  • Addressablesアセットをアップデートする

この例では、一部のアセット（例えば新アイテムやキャラクターなど）をほかと分けて、それ専用のDLCアセットバンドルとしてAddressablesを使ってパッケージングしたい、という簡単な状況に対応します。

Addressablesのデモシーンをインストールする

まだプロジェクトにWwise Unity Addressablesパッケージを設定していない場合は、 Wwise Unity Addressablesパッケージをインストールする に従ってください。

このチュートリアルで使うAddressables Demo Sceneの公式レポジトリは、 https://github.com/audiokinetic/WwiseUnityAddressablesDemoScene です。 デモシーンでUnity Demo Game内にあるアセットを使うので、Audiokinetic Launcherを使って事前にインストールしておいてください。

手順:

  • 最新のUnity Demo Game（バージョン2021.1.0以降）を、Audiokinetic Launcherからインストールします。
  • Wwise Unity Addressablesデモシーンのクローンを、あなたのコンピュータに作成します。
  • Demo GameをUnityで開きます。
  • Unity Package Managerで、 Wwise Addressables Packageを、Unity Package ManagerとGitHubでインストールする のセクションに記載された方法で、プロジェクトにWwise Unity Addressablesパッケージを追加します。
  • 最後に、Wwise Unity Addressables Demo Sceneパッケージを、Package Managerの Add package from disk オプションで追加します。
注記： このパッケージを Add package from git URL を使って追加してしまうと、パッケージ内にあるシーンが開けなくなるので、このインストール方式は避けてください。

始めてみよう

このチュートリアル用に、Wwiseプロジェクトに2つのサウンドエフェクト、1つのイベント、そして1つのSoundBankを用意しました。

AkBankコンポーネントとAkEventコンポーネントのある、2つのGameObject prefabを作成しました: DlcAssetHighImpact、DlcAssetLowImpactです。 これらのprefabは、DLC SoundBankをロードして、インスタンス化されるとサウンドエフェクトを再生します。

また、AddressablesDemoScene、AddressablesSubSceneの2つのシーンを作成しました。 AddressablesDemoSceneはインタラクティブボタンがいくつかある簡単なUnityシーンで、Addressableアセットのロード・アンロードをテストするのに使います。 AddressablesSubSceneはDlcAssetLowImpact prefabだけが入ったシーンです。Addressablesで、Wwiseオブジェクトの入ったシーンをロードするのを、テストします。

注記： AddressablesDemoSceneには、ローカライズされたボイスを使い、Wwise Addressablesパッケージでランゲージを切り替える例も入っています。

これらのアセットや以下のセクションに記載のスクリプトはすべて WwiseUnityAddressablesDemoScene パッケージにあります。

以下の3つのアセットをAddressableで管理できるように、それぞれのInspectorでAddressableチェックボックスを有効にします。

  • AddressablesSubScene.unity
  • Prefabs/DlcAssetHighImpact.prefab
  • Prefabs/DlcAssetLowImpact.prefab
注意： あなたのプロジェクトでUnity Addressablesパッケージを削除すると、全アセットでこのAddressableフィールドが消え、このチェックボックスの状態は、パッケージを再インストールしても保存されていません。

これらのAddressableアセットは Addressables Groups ウィンドウを見ると、デフォルトでDefault Local Groupに入っています。

新しいグループを作成するためにはグループウィンドウを右クリックしてCreate New Groupを選択するか、メニューでNew > Packed Assetsを選択します。 DLCアセット用に、次の2つの新しいグループを作成します:

  • Prefabやサブシーン用に、DLC_Assets。
  • プラットフォーム専用のSoundbankアセット用に、DLC_WwiseData_Windows。
注記： 今回の例で追加で作成するのはWindowsプラットフォーム用のSoundBankグループを1つだけですが、一般的には、デプロイ予定の各プラットフォーム用に、それぞれ1つずつ、グループを作成してください。
  • DlcAssetHighImpact、DlcAssetLowImpact、AddressablesSubSceneを、Default Local GroupからDLC_Assetsグループに移します。
  • プラットフォーム専用のDLC SoundBankアセットを、WwiseData_WindowsからDLC_WwiseData_Windowsグループに移します。
注記： プラットフォーム専用のグループ名に、 WwiseData という文字列と、プラットフォーム名の Windows を必ず入れるように気を付けて、AddressablesをビルドするときにBuildWwiseDataスクリプトが正しく処理できるようにしています。

Groupsウィンドウで、 Play Mode Script を Use Existing Build に設定し、新しいAddressableパッケージをWwise Build Scriptでビルドします（ プロジェクトをビルドする で説明したとおり）。

次にAddressablesDemoSceneを開きます。

Addressablesを使ってアセットをロードする

このシーンには、2つのボタンがあります

  • 左側のボタンで、Addressablesを使ってDlcAssetHighImpact Prefabをロードし、インスタンス化できます。
  • 右側のボタンで、AddressableSubSceneをロードし、インスタンス化できます。
  • このシーンには、DlcAssetLowImpactアセットが入っています。

Loading DLC Assets Demo GameObjectを見ると、AssetLoaderオブジェクトが作成されていて、そこにAddressablePrefabLoaderコンポーネントが入っているのが確認できます。

using UnityEngine;
using UnityEngine.AddressableAssets;
using UnityEngine.ResourceManagement.AsyncOperations;
public class AddressablePrefabLoader : MonoBehaviour
{
public AssetReference reference;
public void Load()
{
Addressables.LoadAssetAsync<GameObject>(reference).Completed += asyncOp =>
{
if (asyncOp.Status == AsyncOperationStatus.Succeeded)
{
Instantiate(asyncOp.Result,this.transform);
}
};
}
}

このコンポーネントにはAssetReferenceが入っていて、ここではInspectorで、これをDlcAssetHighImpact Prefabに設定しました。

ゲームを実行して左ボタンを押すと、AddressablePrefabLoaderのLoadメソッドがコールされ、それがDLC_Assetsからロードされ、DlcAssetHighImpact Prefabがインスタンス化されます。 一旦インスタンス化されると、AkBankコンポーネントが、DLC_WwiseData_WindowsアセットパンドルからSoundBankをロードします。

Addressablesを使ってシーンをロードする

Loading DLC Scene Demo GameObjectを見ると、SceneLoaderオブジェクトが作成されていて、そこにAddressableSceneLoaderコンポーネントが入っているのが確認できます。

using UnityEngine;
using UnityEngine.AddressableAssets;
using UnityEngine.ResourceManagement.AsyncOperations;
using UnityEngine.ResourceManagement.ResourceProviders;
using UnityEngine.SceneManagement;
public class AddressableSceneLoader : MonoBehaviour
{
public AssetReference scene;
private AsyncOperationHandle<SceneInstance> sceneHandle;
public void Awake()
{
DontDestroyOnLoad(gameObject);
}
public void LoadScene()
{
if (!sceneHandle.IsValid() )
{
scene.LoadSceneAsync( LoadSceneMode.Additive).Completed += SceneLoadComplete;
}
else
{
UnloadScene();
}
}
public void UnloadScene()
{
Addressables.UnloadSceneAsync(sceneHandle).Completed += op =>
{
if (op.Status == AsyncOperationStatus.Succeeded)
{
Debug.Log("Successfully unloaded scene");
}
};
}
private void SceneLoadComplete(AsyncOperationHandle<SceneInstance> obj)
{
sceneHandle = obj;
if (obj.Status == AsyncOperationStatus.Succeeded)
{
Debug.Log(obj.Result.Scene.name + " successfully loaded");
}
}
}

このコンポーネントは、AssetReferenceを使って、私たちのAddressablesSubSceneへのレファレンスを保持しています。 このボタンを最初に押すとLoadSceneMethodがコールされ、シーンがLoadSceneAsyncメソッドを使ってロードされ、現在のシーンに追加されます。 もう一度このボタンを押すと、このシーンがアンロードされます。

AddressablesSubSceneにはDlcAssetLowImpact Prefabだけが入っていて、これをインスタンス化するとDLCサウンドバンクがロードされ、それに対応するイベントが再生されます。

ランゲージを変える

このシーンの3つ目のデモは、ランゲージを英語とフランス語で切り替えて、ローカライズされたボイスサンプルを再生するものです。 このデモにはAkWwiseSetLocalizationスクリプトが使われます。緑ボタンまたは青ボタンを押すと、AkAddressableBankManager.SetLanguageAndReloadLocalizedBanksファンクションがコールされ、ランゲージが英語、またはフランス語に変わります。

このファンクションで、以下の操作が実行されます:

  • すべてのローカライズされたバンクのアンロード
  • Initバンクのアンロード
  • AkSoundEngine.SetCurrentLanguageを使ったランゲージの設定
  • Initバンクのリロード
  • ローカライズされたバンクのリロード
using UnityEngine;
public class AkWwiseSetLocalization : MonoBehaviour
{
public string LanguageString;
public void SetLanguage()
{
Debug.Log($"Setting language to {LanguageString}");
AK.Wwise.Unity.WwiseAddressables.AkAddressableBankManager.Instance.SetLanguageAndReloadLocalizedBanks(LanguageString);
}
}

これで、AddressablesDemoSceneをビルドして、ボタンをテストしながら、ビルドされたゲームがこれらのアセットをロードしているかを確認できます。

Addressablesのホスティングを設定する

次に、Unityの組込みホスティングサービスを私たちのAddressable DLCアセットに利用できるように、Unityを設定します。これを使えば、プレイヤーをリビルドしなくても、Addressablesを使ったアセットのアップデートをテストできます。

まず最初に、AddressablesDemoSceneをビルドして、期待通りの動きをするかを確認します。 Buildウィンドウで、 Add open scenes ボタンを使ってAddressablesDemoSceneを追加して、ビルドするシーンとして選択します。

次に、Addressables Hostingを設定するために、Toolsメニューからアクセスします。

次にLocal Hostingサービスを作成して、Enableチェックボックスを選択してそれを有効にします。

Addressables Profilesウィンドウを開くために、メニューで選択し（Profile > Manage Profiles）、Editor Hostedという新プロファイルを作成します。

LocalとRemoteを設定します。次に、各Pathを以下のように設定します:

  • Local.BuildPath : HostedData/[BuildTarget]
  • Local.LoadPath : http://[PrivateIpAddress]:[HostingServicePort]
  • Remote.BuildPath : HostedData/[BuildTarget]
  • Remote.LoadPath : http://[PrivateIpAddress]:[HostingServicePort]

次に、このプロファイルを使えるように、 Editor Hosted を右クリックして Set Active を選択します。

注記： Addressablesホスティングサービスの詳細は、 公式ドキュメンテーション を参照してください。

DLC_WwiseData_Windowsグループアセットを確認し、そのBuild & Load Pathsが更新されていることを確認します。

Addressable Asset Settingsを開いてBuild Remote Catalogを有効にします。Build & Load PathsをLocalに設定します。

あなたのAddressableアセットを、Wwise Build Scriptを使ってリビルドします。新しいAdressable AssetBundleが、 <Unity Project Path>\HostedData 内に作成されるはずです。

次に、AddressablesDemoSceneをリビルドして、あなたのアセットに正しく対応することをテストします。

Addressables Hostingウィンドウを開き、ゲームを実行しながら、入ってくるリクエストを確認します。ボタンを最初に押したときに、ウィンドウの下にあるイベントログに、リクエストが表示されるはずです。

Addressablesアセットをアップデートする

今度は、Addressablesを使ってDlcAssetHighImpactサウンドをアップデートします。

まず最初に、Wwiseで、サウンドファイルimp_axe_stone_highのピッチ値を調整して、変化がはっきりと分かるようにします。次に、SoundBankを再生成します。

さらに、Addressables Groupsウィンドウで、 Build >Update a previous build を選択します。選択ウィンドウが開くので、AddressableAssetsData/Windows 内の、addressables_content_state.bin ファイルを選択します。

最後に、ビルドされたゲームをもう一度実行します（リビルドはしません）。開いたときに、Addressables Hostingウィンドウにアップデートカタログのリクエストが表示されるはずです。

そして、左ボタンを押すと、サウンドエフェクトが新しいピッチ高さで聞こえるはずです。

Addressablesカタログや、開発サイクルの予定について、さらに詳しく知るには、 公式ドキュメンテーション を確認してください。

注記： このチュートリアルで提供するスクリプトは、Addressablesを使ったアセットのロードをテストするための、最低限のものです。 実際にプロジェクトにアセットをロードする際は、よりロバストなソリューションが必要になると考えられます。 さらに質の高い例が、 Unity Addressables Sample レポジトリにいくつかあります。
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21


Wwise Unity Integration Documentation: Wwise Addressablesサンプル

Wwise Addressablesサンプル

目次

  • Wwise Addressablesアセットのメタデータの維持
    • 仕組み
    • サンプルコード

Wwise Addressablesアセットのメタデータの維持

Addressablesとして扱えるWwiseアセットで作業する時にWwiseAddressableBankアセットを最新状態にするには、生成されたサウンドバンクフォルダを削除してサウンドバンクを再生成するのが最も簡単な方法です。Addressablesアセットを削除するとアセットが削除されてAddressablesグループの中身が消えるので、再度インポートすると親グループやラベルが失われます。このサンプルスクリプトはWwise Unity Addressablesパッケージに含まれ、Addressableアセットのメタデータ、つまり親グループやラベルなどを維持（preserve）できる機能を提供します。

仕組み

失われたグループやラベルが復元しやすくなるオプション設定を追加しました。Unityプロジェクト設定の Wwise Addressables で設定できます。これを有効にするとメタデータのターゲットディレクトリを指定できます。ディレクトリは、Unityプロジェクトのアセットフォルダ内のものとします。

WwiseAssetMetadataPreserverスクリプトが、プロジェクトのすべてのWwise Addressablesアセットのメタデータを保存するメニュートリガーを Assets/Wwise/Addressables の下に追加します。これがトリガーされると、Addressable Wwiseアセットごとに AddressableMetadata アセットが作成され、親グループの名前やラベルがシリアライズされます。また、スクリプト自体が WwiseBankPostProcess.GetAssetMetadataDelegate 関数で登録されます。このデリゲートによって、アセットがWwiseBankPostProcessカスタムインポーター（Unityプロジェクトに追加された時に、.bnkファイルや.wemファイルをインポートするもの）によってインポートされた時に、アセットのフィールドを設定するために使うmetadata structを外部コードから入力することが可能になります。

この2つのメカニズムでクリーンアップ前にアセットメタデータをシリアライズすることができ、サウンドバンクを生成してからアセットを再度インポートする時にアセットに再び適用できます。

注記： このスクリプトは、手順を示した一例です。制作条件に合わせて独自のメタデータフィラーを作成して実装させた方が適切なこともあります。

サンプルコード

#if AK_WWISE_ADDRESSABLES && UNITY_ADDRESSABLES
using UnityEditor.AddressableAssets;
using UnityEditor.AddressableAssets.Settings;
using System.Collections.Generic;
using UnityEditor;
using UnityEngine;
using System.IO;
namespace AK.Wwise.Unity.WwiseAddressables
{
/*
このクラスはWwise Addressablesアセットグループやラベルのメタデータを維持してリストアする機能を提供します。
アセットを削除するとこの情報が失われ、Wwise Addressablesアセットフォルダをクリアするのが、壊れたWwiseAddressableSounbankを修復するには最も簡単な方法です。
このクラスは、この機能の実装方法を示す一例であり、完全なソリューションではありません。
*/
[InitializeOnLoad]
class WwiseAddressableAssetMetadataPreserver
{
static WwiseAddressableAssetMetadataPreserver()
{
if (AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver)
{
BindMetadataDelegate();
}
}
//WwiseBankPostProcess AssetPostProcessor（.bnkファイルや.wemファイルのインポートを担当）にGetAssetMetadataDelegateを設定。
public static void BindMetadataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate += GetMetadata;
}
//デリゲートの設定解除（この機能を無効にした時）
public static void UnbindMetaDataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate -= GetMetadata;
}
//WwiseのAddressablesアセットごとにAddressableMetadataアセットを作成し、グループやラベルを記録。
//Metadataアセットをwwise assetに合った階層内で専用フォルダ内に作成
//フォルダ階層とアセット名を使いインポート時にアセットをマッチさせます
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Serialize addressable asset metadata")]
public static void PreserveAllWwiseAssetMetadata()
{
AddressableAssetSettings addressableSettings = AddressableAssetSettingsDefaultObject.Settings;
foreach (AddressableAssetGroup group in addressableSettings.groups)
{
foreach (AddressableAssetEntry assetEntry in group.entries)
{
if (assetEntry.MainAsset)
{
if (assetEntry.MainAsset.GetType().IsSubclassOf(typeof(WwiseAsset)))
{
CreateMetadataAsset(assetEntry.AssetPath, assetEntry.labels, group.name);
}
}
}
}
}
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Preserve addressable asset metadata", true)]
public static bool ValidatePreserveAllWwiseAssetMetadata()
{
return AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver;
}
//必要なサブフォルダとメタデータアセットを作成
public static void CreateMetadataAsset(string assetPath, HashSet<string> assetLabels, string groupName)
{
string soundbankPath = assetPath.Replace(AkAssetUtilities.GetSoundbanksPath(), "");
var splitBankPath = soundbankPath.Split('/');
AddressableMetadata metaDataAsset = ScriptableObject.CreateInstance<AddressableMetadata>();
metaDataAsset.labels = new List<string>(assetLabels);
metaDataAsset.groupName = groupName;
var rootPath = AkAddressablesEditorSettings.Instance.MetadataPath;
if (!Directory.Exists(Path.Combine(Application.dataPath, rootPath)))
{
UnityEditor.AssetDatabase.CreateFolder("Assets", rootPath);
}
for (int i = 1; i < splitBankPath.Length - 1; i++)
{
if (!Directory.Exists(Path.Combine(Application.dataPath, Path.Combine(rootPath, splitBankPath[i]))))
{
AssetDatabase.CreateFolder(Path.Combine("Assets", rootPath), splitBankPath[i]);
}
rootPath = Path.Combine(rootPath, splitBankPath[i]);
}
string assetMetadataPath = Path.Combine("Assets", rootPath, Path.GetFileNameWithoutExtension(assetPath) + ".asset");
AddressableMetadata oldAsset = AssetDatabase.LoadAssetAtPath<AddressableMetadata>(assetMetadataPath);
if (oldAsset)
{
if (!metaDataAsset.IsDifferent(oldAsset))
{
return;
}
}
UnityEditor.AssetDatabase.CreateAsset(metaDataAsset, assetMetadataPath);
}
//メタデータアセットの場所はそのプラットフォームやランゲージに基づいて判断。
public static AddressableMetadata FindMetadataAsset(string assetName, string platformName, string languageName)
{
string MetadataAssetPath;
if (languageName !="SFX")
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, languageName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
else
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
return AssetDatabase.LoadAssetAtPath<AddressableMetadata>(MetadataAssetPath);
}
//.bnkファイルや.wemファイルのインポート時に呼び出し。プロジェクト内の既存メタデータオブジェクトを探してロードしようとします。
public static bool GetMetadata(string assetName, string platformName, string languageName, ref AddressableMetadata metaData )
{
AddressableMetadata asset = FindMetadataAsset(assetName, platformName, languageName);
if ( asset )
{
metaData = asset;
return true;
}
return false;
}
}
}
#endif


Wwise Unity Integration Documentation: トラブルシューティング

トラブルシューティング
  • Wwise Components/Typesに、staleデータや矛盾データが表示される
  • インストール後のエラーをコンパイルする
  • UnityコンソールでDllNotFoundExceptionが表示される
  • サウンドがない
  • Wwise Profilerを接続できない
  • Error during installation - Unityコンソールでパスへのアクセスを拒否された
  • Wwise for MacでSoundBank生成中にエラーが発生 - Wwise_IDs.hに書き込めない
  • Error: Pluginが登録されていない
  • MacのUnity Consoleで "Multiple plugins with the same name" と表示される
  • Wwiseを、Google Play Servicesを実装したプロジェクトに、インテグレートしたり移行したりできない

Wwise Components/Typesに、staleデータや矛盾データが表示される

AkAmbientや、AkStateなどのWwiseコンポーネントが、そのWwiseオブジェクトへの参照を失ってしまった場合は、あなたがバージョンコントロールにAkWwiseProjectData.assetを追加した可能性があります。バージョンコントロール下にあると、AkWwiseProjectData.assetがロックされることがよくありますが、この場合、新しいファイルはAkWwiseProjectData##.asset.の形式で作成されます。このような場合は、それらをすべて削除してから、 Wwise Picker で、Auto populateをクリックして、ファイルを再生成してください。

注記： AkWwiseProjectData.assetを、バージョンコントロール下に置かないでください！ これはWwiseプロジェクトデータ用の一時的なキャッシュファイルで、Wwise PickerがWork Unitファイルを繰り返しパースするのを回避するためにあります。

インストール後のエラーをコンパイルする

Wwiseを古いバージョンからアップグレードしたばかりであれば、重複するスクリプトがある場合があります。2013.2.8バージョンで、UNITY_PROJECT_ROOT\Assets\Wwise\Deployment\Examplesフォルダの名前が Components に変更されました。Examples フォルダのスクリプトを変更していなければ、単純に削除できます。

また複数プラットフォーム向けに開発している場合は、開発プラットフォーム毎にUnityPackageをインストールしてあることを確認してください。orms. プラットフォームによっては、専用スクリプトがあります。

UnityコンソールでDllNotFoundExceptionが表示される

WindowsでAkSoundEngineについてDllNotFoundExceptionメッセージがUnityコンソールに表示される場合は、2つの依存関係が不足しているかもしれません：

  • マシンにDirectXがインストールされていることを確認してください。
  • Wwise Unityインテグレーションの Debug コンフィギュレーションを使う場合は、Microsoft Visual Studio 2010 Debug Redistributablesもインストールする必要があります。通常はデフォルトで Profile コンフィギュレーションがインストールされるので、 Debug コンフィギュレーションをマニュアル操作でインストールしていない限り、問題が発生しないはずです。

サウンドがない

ゲームにサウンドがない場合は、以下を確認してください:

  • ゲームを単体で実行した時にサウンドがなければ、ゲームをWindowsまたはMacでEditorで実行してみてください。最初にEditorで問題を解決する方が、簡単です。
  • SoundBankが正しく生成されUnityから見つけられることを、確認してください。ゲームをEditorで実行する場合は、インテグレーションがWwiseプロジェクトからGenerated Soundbanksパスを見てSoundBankを探します。そこに1つもなければ、次にStreamingAssetsフォルダを探します。なおWwiseのプロジェクトSoundBankパスをオーバーライドする場合は、インテグレーションで自動的にロードできなくなります。この問題の詳細は 特定プラットフォーム向けにUnityゲームをビルドする を参照してください
  • 他のオーディオコールを実施する前に、Sound Engineが正しく初期化されていて、全てのエンジンコール完了後に終了されたかを確認してください。Script Execution Order (menu Edit > Project Settings > Script Execution Order)が、正しくAkInitializer用に設定されていることを確認してください。
  • 必ずWwise Project Settingsダイアログにおいて、Enable Auto-Defined SoundBanksオプションを解除してください。
  • Unityコンソールでエラーが報告されていないことを確認してください。
  • Wwise Profiler（WwiseではF7）をゲーム実行中に接続すると、Capture Logにエラーが表示されますか？
  • Wwise ProfilerのSoundBankタブに、バンクがロードされて表示されていますか？タブがない場合は、Profiling Settings (Alt-G)を開いてSoundBankを有効にします。ロードされていない場合は、いつ、どのようにロードしているのかを確認します。AkBankコンポーネントと AkSoundEngine.LoadBank コールを探してください。
  • Wwise ProfilerのCapture Logで、表示されるべきEventがポストされたと表示されていますか？表示されない場合は、それらのイベントが全てSoundBankに入っていること、そして正しくロードされたこと（前項を参照）を確認してください。バンクがロードされていれば、ゲームスクリプトのAkEvent, AkAmbientコンポーネントや AkSoundEngine.PostEvent コールを確認してください。

Wwise Profilerを接続できない

Windowsで稼働するゲームの場合は、以下を確認します：

  • Unityで Run in background の設定が有効になっていることを確認してください（メニューで File > Build Settings > Player Settings）。
  • マシンのファイヤーウォールがport 24024を許可することと、Wwiseが例外設定されていることを確認してください。ファイヤーウォールを無効にしてあれば、これは問題ではありません。
  • 実行中のWwise-Unity Plug-inのコンフィギュレーションは何ですか？コミュニケーションコードが有効になっているのは、 Debug と Profile だけです。
  • Task Managerを開き、"adb.exe"という名前の付いたプロセスを全てキルする。これがAndroidドライバであり、TCPポートをロックします。Androidで開発していなくても、Androidデバイスを接続していなくても、これは発生します。（Google側の問題が原因です。）

ゲームが他のコンピュータやコンソールで実行できる場合は、以下を確認してください：

  • Wwiseコンピュータとゲームコンソールは同じサブネット上にありますか？ない場合は、ゲームがRemote Connectionダイアログに表示されません。Connect To IP ボタンを使ってIPをマニュアル入力してください。
  • ネットワークでport 24024のトラフィックや、ダイナミックポート配分を許可していますか？

Error during installation - Unityコンソールでパスへのアクセスを拒否された

Wwise: Error during installation: Access to the path is deniedメッセージがUnityコンソールに表示された場合は、以下を確認してください:

  • 新しいPlug-inコンフィギュレーション (Debug, Profile, Release) をAssets > Wwise > Install Plugins メニューから、次の直後にインストールしようとしましたか：
    • 新Unityインテグレーションを Wwise Setup ウィンドウからインストール？
    • Unity EditorでSceneをプレビューしようとした？
  • Unityプロジェクトを開きなおして、新しいPlug-inコンフィギュレーション (Debug, Profile, Release) をすぐにインストールします。

Wwise for MacでSoundBank生成中にエラーが発生 - Wwise_IDs.hに書き込めない

もしWwise for Macを使用中に、SoundBank生成中のエラーとしてWwise_IDs.hに書き込めないとメッセージが表示されたら、以下を確認してください:

  • Wwise Projectを開く。
  • Project Settingsで、SoundBanksタブを開く。
  • Header file pathを、SoundBanksが生成される場所に設定する。

Error: Pluginが登録されていない

Wwiseプロジェクトで、まだAkSoundEngineダイナミックライブラリに含まれていないライセンス済みプラグインが使われています。プラグインの追加 を参照してください。

MacのUnity Consoleで "Multiple plugins with the same name" と表示される

Mac で Unity を使うと、Integrationをインポートした時にUnity Consoleに複数のエラーが表示され、以下が表示されるかもしれません

Multiple plug-ins with the same name 'aksoundengine' (found at 'Assets/Wwise/API/Runtime/Plugins/Mac/Release/AkSoundEngine.bundle' and 'Assets/Wwise/Deployment/Plugins/Mac/Debug/AkSoundEngine.bundle'). Editorで一度に1つのプラグインしか使用できません。これは、1つあるいは１つ以上のプラグインがEditorと互換性があるように設定されていることを意味します。

このようなエラーがあっても、インストールプロセスで正しいプラグインが正常に有効になるので、無視しても安全です

Wwiseを、Google Play Servicesを実装したプロジェクトに、インテグレートしたり移行したりできない

Google Play ServicesをインストールしたUnityプロジェクトで、ビルドのターゲットがAndroidに設定されていると、Audiokinetic LauncherでWwiseをこのプロジェクトにインテグレートしたり、プロジェクト内でWwiseを移行したりできません。この制限のワークアラウンドとして、Unityプロジェクトを開き、ビルドのターゲットをAndroiod以外のプラットフォームにしてからUnityを閉じ、再びLauncherでインテグレートまたは移行を始めてください。


Wwise Unity Integration Documentation: WAAPIユーティリティ

WAAPIユーティリティ

バージョン2018.1より、Wwise Authoring API (WAAPI) のサポートをUnityインテグレーションに組み込みました（詳しくは Using the Wwise Authoring API (WAAPI) を参照）。 バージョン2021.1でWwise Authoring API (WAAPI) のデザインを見直し、Wwise Pickerとのインテグレーションを改善して全体的に使いやすくしました。 WAAPIとWwise Pickerの関係や使い方について、詳しくはWwise Pickerのドキュメンテーションページをご覧ください: Wwise Picker .

  1. WAAPIの設定
    1. トラブルシューティング
  2. WAAPIをUnityで使う
    1. Waapiを使ってWwise Objectをフェッチする
    2. トピックにサブスクライブする
    3. Disconnection
    4. その他のWAAPIコマンド

WAAPIの設定

WAAPIの設定は、 Project Settings > Wwise Editor > Wwise Authoring API にあります。

ここで Connect to Wwise チェックボックスのチェックを外すと、WAAPI機能は無効になります。 デフォルトで、WAAPIクライアントはlocalhost (127.0.0.1)のPort 8080に接続します。 これらの設定をWAAPIに接続したまま変更すると、現在の接続が切れ、新しいターゲットアドレスに接続しようとします。

トラブルシューティング

プロジェクトにうまく接続できないときは、以下のソリューションを試してみてください:

  • Wwise Authoringで正しいプロジェクトが開いているかを、確認してください。
  • Project Settings > Wwise Editor > Wwise Project のWwise Project Pathが正しいかを、確認してください。
  • 複数のWwise Authoringインスタンスが開いた状態だと、そのうちの1つが、別のインスタンスのWAAPIポートをブロックしてしまうことがあります。
  • Wwise AuthoringでWAAPIが有効になっているか、そして許可された接続やポートが正しいかを、確認してください。
    • WAAPI設定は、User Preferencesにあります。

WAAPIをUnityで使う

AKWaapiClientクラスは、websocket接続を使ってWwise Authoringとメッセージを送受信します。WAAPIメッセージは、JSONオブジェクトです。 WAAPIコールは非同期的で、WAAPIに対するコールがGUIスレッドなどのスレッドからくることがあるので、返信を待つことはできません。 また、websocketの実装は一度に1レスポンスしか待ち受けることができないので、WAAPIクライアントはAkWaapiUtilitiesクラスにラップされています。 このクラスは、WAAPIリクエストを作成したりエンキュー（enqueue）したりする関数セットを提供し、アップデートループ中に順次、それらを呼び出します。 WAAPIリクエストは、非同期関数ポインタペイロードを含むたけのWaapiCommandにカプセル化されています。コマンドが消化されると、ペイロードが実行されます。

AkWaapiUtilitiesで提供される関数で、あなたのほとんどのニーズをカバーできるはずですが、作り込まれていない特別なWAAPIの使い方をしたければ、自分で実装することもできます。詳細は その他のWAAPIコマンド を参照してください。

注意： 提供されるWAAPIコールの大部分は、Wwise Authoring Query Language (WAQL) を使っています。 WAQLの詳細については、 WAQLの introduction ページや、 reference ページを参照してください。

Waapiを使ってWwise Objectをフェッチする

AkWaapiUtilitiesには、すでにWwiseオブジェクトをフェッチするためのWAAPIコールが入っています。

  • AkWaapiUtilities.GetWwiseObject<T>
  • AkWaapiUtilities.GetWwiseObjectAndDescendants<T>
  • AkWaapiUtilities.GetWwiseObjectAndAncestors<T>
  • AkWaapiUtilities.Search<T>
  • AkWaapiUtilities.GetChildren<T>

これらが、returnオプションで指定されたプロパティを含むオブジェクトのリストを返します。すべてのreturnオプションの一覧が、 WAAPI ドキュメンテーションにあります。

Wwise Pickerは、WwiseObjectInfoJsonObjectを、これらの関数のテンプレートタイプとして使います。これらのオブジェクトは、次にAkWaapiUtilities.ParseObjectInfo によって、WwiseObjectInfoにキャストされます。

WwiseObjectInfoに含まれていないオブジェクトプロパティをフェッチしたい場合は、アクセスしたいプロパティのためのカスタムクラスが必要です。 例えば、Notesフィールドだけが知りたい場合は、以下のようなクラスを作成します:

public class WwiseObjectNotes
{
public string notes;
}

次に、notesフィールドだけをリストしたReturnOptionsオブジェクトと、WwiseObjectNotesのリストを受け取るコールバックの、 AkWaapiUtilities.GetWwiseObject<T> （前述のほかの関数でも可）をコールします。

{
var callback = ( List<WwiseObjectNotes> notes ) => {
// do something
};
var options = new ReturnOptions(new string[] { "notes" });
var objectGuid = System.Guid.Empty(); //Put an actual guid from your project here
AkWaapiUtilities.GetWwiseObject<WwiseObjectNotes>( objectGuid, options, callback);
}

AkWwiseTreeWAAPIDataSource クラスには、Wwise Pickerで表示するために、WAAPIを使ってWwiseオブジェクトをフェッチする例が、多数入っています。

トピックにサブスクライブする

WAAPIトピックにサブスクライブするには、 AkWaapiUtilities.Subscribe を使います。 URIでサブスクライブするトピックを特定できます。コールバック引数は、トピックがパブリッシュされたときにコールするJSON文字列の引数を受け入れる関数です。 このサブスクリプションの登録が完了すると、handshakeCallbackをコールします。サブスクリプション識別子の入った AkWaapiUtilities.SubscriptionInfo オブジェクトを、受け取ります。 この情報は、サブスクリプションをリクエストしたクラスに保存します。

注意： ライフタイムの終わりにサブスクリプションをクリーンアップする責任は、AkWaapiUtilities.Subscribeをコールしたクラスにあります。 これは、AkWaapiUtilities.Unsubscribe をコールすることで行います。

このインテグレーションで使われているサブスクリプション例を見るには、 AkWwiseTreeWAAPIDataSource クラスを確認してください。

  • AkWwiseTreeWAAPIDataSource.SubscribeTopics
  • AkWwiseTreeWAAPIDataSource.UnsubscribeTopics

利用可能なトピックについてのさらなる情報は、 >Wwise Authoring API Reference にあります。

  • トピックURIの多くは、 Uri.cs にあります

Disconnection

WAAPI接続が終了する直前に（または急に終了したときに）、 AkWaapiUtilities.Disconnection デリゲートがコールされます。 デリゲートのブーリアンパラメータが、まだ接続が有効かどうかを示します。

注記： WAAPIトピックにサブスクライブしているクラスは、接続が切れる前にサブスクリプションを解除できるように、このデリゲートにバインドしておくべきです。

その他のWAAPIコマンド

AkWaapiUtilitiesクラスに含まれる以下の追加の関数を使い、Unity内からあなたのWAAPIプロジェクトとやり取りができます:

  • AkWaapiUtilities.SelectObjectInAuthoring
  • AkWaapiUtilities.OpenWorkUnitInExplorer
  • AkWaapiUtilities.OpenSoundBankInExplorer
  • AkWaapiUtilities.Rename
  • AkWaapiUtilities.Delete
  • AkWaapiUtilities.TogglePlayEvent
  • AkWaapiUtilities.StopAllTransports

これらのコマンドの使用例が、AkWwisePicker や、AkWwiseTreeView にあります。

あなたが実行したいWAAPIコマンドが、まだ AkWaapiUtilities に実装されていなくても、自分でコマンドを作成することができます。 WAAPIコールを出しレスポンスを受領するには、JSON引数を構築しパースする必要があります。

レスポンスをパースする必要がないコマンドには、 AkWaapiUtilities.QueueCommand を使います

レスポンスに、パースする値があるコマンドには、 AkWaapiUtilities.QueueCommandWithReturnType<T> を使います

Unity JsonUtility クラスで、C::クラスとJSON文字列の間の翻訳が簡単にできます。JSON文字列に変換する必要のある引数やオプションのベースクラスとして JsonSerializable を使います。

public class JsonSerializable
{
public static implicit operator string(JsonSerializable o) => UnityEngine.JsonUtility.ToJson(o);
}

次にこのクラスを拡張すれば、特定のWAAPIスキーマ用にC::ラッパーを提供できます。使用例については、Eventを再生してトランスポートにサブスクライブするのに必要なスキーマクラスを、WAAPIを使ってどのように作成したかを、参考にしてください:

引数やオプションのスキーマ

  • ArgsPlay
  • ArgsObject
  • TransportOptions

リターンされるオブジェクトのスキーマ

  • ReturnTransport
  • TransportState

AkWaapiUtilities.TogglePlayWwiseEventAsync や、 AkWaapiUtilities.CreateTransport で、これらがどのように使われているのかを見ることができます。

JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:27
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:150
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34


Wwise Unity Integration Documentation: 名前空間一覧

名前空間一覧
詳解が付いた名前空間の一覧です。
[表示階層 12]
▼N AK
N Wwise


Wwise Unity Integration Documentation: AK 名前空間

名前空間
AK 名前空間


Wwise Unity Integration Documentation: AK.Wwise 名前空間

  • AK
  • Wwise
クラス
AK.Wwise 名前空間

クラス

class | AcousticTexture
This type represents an Acoustic Texture. [詳解]
class | AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy. [詳解]
class | Bank
This type can be used to load/unload SoundBanks. [詳解]
class | BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. [詳解]
class | BaseType
This type represents the base for all Wwise Types that require a GUID. [詳解]
class | CallbackFlags
This type represents the values of the flags used when posting an Event with a callback. [詳解]
class | Event
This type can be used to post Events to the sound engine. [詳解]
class | RTPC
This type can be used to set game parameter values to the sound engine. [詳解]
class | State
This type can be used to set Wwise States. [詳解]
class | Switch
This type can be used to set Switch values on gameobjects. [詳解]
class | Trigger
This type can be used to post triggers to the sound engine. [詳解]


Wwise Unity Integration Documentation: クラス一覧

クラス一覧
クラス・構造体・共用体・インターフェースの一覧です。
[表示階層 123]
▼N AK |
▼N Wwise |
C AcousticTexture | This type represents an Acoustic Texture
C AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C Bank | This type can be used to load/unload SoundBanks
C BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C BaseType | This type represents the base for all Wwise Types that require a GUID
C CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C Event | This type can be used to post Events to the sound engine
C RTPC | This type can be used to set game parameter values to the sound engine
C State | This type can be used to set Wwise States
C Switch | This type can be used to set Switch values on gameobjects
C Trigger | This type can be used to post triggers to the sound engine
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
▼C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See AkEnvironmentやAkEnvironmentPortalをInspectorで使う
C AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
▼C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. AkEnvironmentやAkEnvironmentPortalをInspectorで使う
C EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkReverbZone | This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
▼C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
▼C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C GeometryData | The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwiseイベントのトリガーを追加する
▼C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C SubscriptionInfo | Class used to store information about a specific subscription
C WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
C AkWwiseTrigger | This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
▼C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C ErrorException | Exception thrown during WAMP operations
C TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WaqlArgs | WAAPI arguments containing a WAQL string
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic


Wwise Unity Integration Documentation: AK.Wwise.AcousticTexture クラス

  • AK
  • Wwise
  • AcousticTexture
全メンバ一覧
AK.Wwise.AcousticTexture クラス

This type represents an Acoustic Texture. [詳解]

AK.Wwise.AcousticTexture の継承関係図
AK.Wwise.BaseType

詳解

This type represents an Acoustic Texture.


Wwise Unity Integration Documentation: AK.Wwise.AuxBus クラス

  • AK
  • Wwise
  • AuxBus
全メンバ一覧
AK.Wwise.AuxBus クラス

This type represents an auxiliary send in the Master-Mixer Hierarchy. [詳解]

AK.Wwise.AuxBus の継承関係図
AK.Wwise.BaseType

詳解

This type represents an auxiliary send in the Master-Mixer Hierarchy.


Wwise Unity Integration Documentation: AK.Wwise.Bank クラス

  • AK
  • Wwise
  • Bank
全メンバ一覧
AK.Wwise.Bank クラス

This type can be used to load/unload SoundBanks. [詳解]

AK.Wwise.Bank の継承関係図
AK.Wwise.BaseType

詳解

This type can be used to load/unload SoundBanks.


Wwise Unity Integration Documentation: AK.Wwise.BaseGroupType クラス

  • AK
  • Wwise
  • BaseGroupType
全メンバ一覧
AK.Wwise.BaseGroupType クラス

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. [詳解]

AK.Wwise.BaseGroupType の継承関係図
AK.Wwise.BaseType AK.Wwise.State AK.Wwise.Switch

詳解

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch.


Wwise Unity Integration Documentation: AK.Wwise.BaseType クラス

  • AK
  • Wwise
  • BaseType
全メンバ一覧
AK.Wwise.BaseType クラス

This type represents the base for all Wwise Types that require a GUID. [詳解]

AK.Wwise.BaseType の継承関係図
AK.Wwise.AcousticTexture AK.Wwise.AuxBus AK.Wwise.Bank AK.Wwise.BaseGroupType AK.Wwise.Event AK.Wwise.RTPC AK.Wwise.Trigger AK.Wwise.State AK.Wwise.Switch

詳解

This type represents the base for all Wwise Types that require a GUID.


Wwise Unity Integration Documentation: AK.Wwise.CallbackFlags クラス

  • AK
  • Wwise
  • CallbackFlags
全メンバ一覧
AK.Wwise.CallbackFlags クラス

This type represents the values of the flags used when posting an Event with a callback. [詳解]

詳解

This type represents the values of the flags used when posting an Event with a callback.


Wwise Unity Integration Documentation: AK.Wwise.Event クラス

  • AK
  • Wwise
  • Event
公開メンバ関数 | 全メンバ一覧
AK.Wwise.Event クラス

This type can be used to post Events to the sound engine. [詳解]

AK.Wwise.Event の継承関係図
AK.Wwise.BaseType

公開メンバ関数

uint | Post (UnityEngine.GameObject gameObject)
Posts this Event on a GameObject. [詳解]
uint | Post (UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. [詳解]
uint | Post (UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. [詳解]
uint | Post (ulong gameObjectId)
Posts this Event on a GameObject ID. [詳解]
void | ExecuteAction (UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject. [詳解]
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject. [詳解]
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject. [詳解]
void | StopMIDI (UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject. [詳解]
void | StopMIDI ()
Stops all MIDI Events on this Event. [詳解]

詳解

This type can be used to post Events to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.Event.ExecuteAction

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ ExecuteAction()

void AK.Wwise.Event.ExecuteAction | ( | UnityEngine.GameObject | gameObject,
 |  | AkActionOnEventType | actionOnEventType,
 |  | int | transitionDuration,
 |  | AkCurveInterpolation | curveInterpolation
 | ) |  |
inline

Executes various actions on this event associated with a GameObject.

引数
gameObject The GameObject
actionOnEventType
transitionDuration
curveInterpolation


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [1/4]

uint AK.Wwise.Event.Post ( ulong gameObjectId )
inline

Posts this Event on a GameObject ID.

引数
gameObjectId The GameObject ID
戻り値
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [2/4]

uint AK.Wwise.Event.Post ( UnityEngine.GameObject gameObject )
inline

Posts this Event on a GameObject.

引数
gameObject The GameObject
戻り値
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [3/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | CallbackFlags | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

引数
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
戻り値
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [4/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | uint | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

引数
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
戻り値
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [1/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

引数
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [2/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array,
 |  | int | count
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

引数
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.
count | The number of elements from the array that will be posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [1/2]

void AK.Wwise.Event.StopMIDI ( )
inline

Stops all MIDI Events on this Event.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [2/2]

void AK.Wwise.Event.StopMIDI ( UnityEngine.GameObject gameObject )
inline

Stops MIDI Events on this Event associated with a GameObject.

引数
gameObject The GameObject


Wwise Unity Integration Documentation: AK.Wwise.RTPC クラス

  • AK
  • Wwise
  • RTPC
全メンバ一覧
AK.Wwise.RTPC クラス

This type can be used to set game parameter values to the sound engine. [詳解]

AK.Wwise.RTPC の継承関係図
AK.Wwise.BaseType

詳解

This type can be used to set game parameter values to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.State クラス

  • AK
  • Wwise
  • State
全メンバ一覧
AK.Wwise.State クラス

This type can be used to set Wwise States. [詳解]

AK.Wwise.State の継承関係図
AK.Wwise.BaseGroupType AK.Wwise.BaseType

詳解

This type can be used to set Wwise States.


Wwise Unity Integration Documentation: AK.Wwise.Switch クラス

  • AK
  • Wwise
  • Switch
全メンバ一覧
AK.Wwise.Switch クラス

This type can be used to set Switch values on gameobjects. [詳解]

AK.Wwise.Switch の継承関係図
AK.Wwise.BaseGroupType AK.Wwise.BaseType

詳解

This type can be used to set Switch values on gameobjects.


Wwise Unity Integration Documentation: AK.Wwise.Trigger クラス

  • AK
  • Wwise
  • Trigger
全メンバ一覧
AK.Wwise.Trigger クラス

This type can be used to post triggers to the sound engine. [詳解]

AK.Wwise.Trigger の継承関係図
AK.Wwise.BaseType

詳解

This type can be used to post triggers to the sound engine.


Wwise Unity Integration Documentation: ak クラス

ak クラス

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation. [詳解]

詳解

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation.


Wwise Unity Integration Documentation: AkAmbient クラス

公開変数類 | 静的公開変数類 | 全メンバ一覧
AkAmbient クラス

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event. [詳解]

AkAmbient の継承関係図
AkEvent

公開変数類

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. [詳解]
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. [詳解]
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event.

参照
  • AkAmbient をInspectorで使う
  • AkGameObj
  • AkEvent
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkAmbientLargeModePositioner クラス

全メンバ一覧
AkAmbientLargeModePositioner クラス

Use this component to add a Large Mode position to any AkAmbient in a Scene. [詳解]

MonoBehaviourを継承しています。

詳解

Use this component to add a Large Mode position to any AkAmbient in a Scene.

参照
  • AkAmbient をInspectorで使う
  • AkAmbient


Wwise Unity Integration Documentation: AkAudioListener クラス

全メンバ一覧
AkAudioListener クラス

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. [詳解]

MonoBehaviourを継承しています。

詳解

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

参照
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkBank クラス

公開メンバ関数 | 公開変数類 | 静的公開変数類 | 全メンバ一覧
AkBank クラス

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared. [詳解]

AkTriggerHandler, AK.Wwise.IMigratableを継承しています。

公開メンバ関数

override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Loads the SoundBank [詳解]
void | UnloadBank (UnityEngine.GameObject in_gameObject)
Unloads a SoundBank [詳解]

公開変数類

bool | decodeBank = false
Decode this SoundBank upon load [詳解]
bool | loadAsynchronous = false
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors. [詳解]
bool | saveDecodedBank = false
Save the decoded SoundBank to disk for faster loads in the future [詳解]
System.Collections.Generic.List< int > | unloadTriggerList
Reserved. [詳解]
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared.


Wwise Unity Integration Documentation: AkBank.HandleEvent

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ HandleEvent()

override void AkBank.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Loads the SoundBank

参照先 decodeBank, loadAsynchronous, saveDecodedBank.


Wwise Unity Integration Documentation: AkBank.UnloadBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ UnloadBank()

void AkBank.UnloadBank ( UnityEngine.GameObject in_gameObject )
inline

Unloads a SoundBank


Wwise Unity Integration Documentation: AkBank.decodeBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ decodeBank

bool AkBank.decodeBank = false

Decode this SoundBank upon load

参照元 HandleEvent().


Wwise Unity Integration Documentation: AkBank.loadAsynchronous

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ loadAsynchronous

bool AkBank.loadAsynchronous = false

Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors.

参照元 HandleEvent().


Wwise Unity Integration Documentation: AkBank.saveDecodedBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ saveDecodedBank

bool AkBank.saveDecodedBank = false

Save the decoded SoundBank to disk for faster loads in the future

参照元 HandleEvent().


Wwise Unity Integration Documentation: AkBank.unloadTriggerList

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ unloadTriggerList

System.Collections.Generic.List<int> AkBank.unloadTriggerList

Reserved.


Wwise Unity Integration Documentation: AkEarlyReflections クラス

公開変数類 | 全メンバ一覧
AkEarlyReflections クラス

Set an early reflections auxiliary bus and send volume for a particular game object. [詳解]

MonoBehaviourを継承しています。

公開変数類

AK.Wwise.AuxBus | reflectionsAuxBus = new AK.Wwise.AuxBus()
float | reflectionsVolume = 1

詳解

Set an early reflections auxiliary bus and send volume for a particular game object.


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsAuxBus

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsAuxBus

AK.Wwise.AuxBus AkEarlyReflections.reflectionsAuxBus = new AK.Wwise.AuxBus()

The early reflections auxiliary bus for this particular game object. Geometrical reflection calculation inside spatial audio is enabled for a game object if any sound playing on the game object has a valid early reflections aux bus specified in the authoring tool, or if an aux bus is specified via this parameter. The early reflection auxiliary bus specified in the authoring tool has precedence. Users may apply this function to avoid duplicating sounds in the actor-mixer hierarchy solely for the sake of specifying a unique early reflection bus, or in any situation where the same sound should be played on different game objects with different early reflection aux buses (the early reflection bus must be left blank in the authoring tool if the user intends to specify it through the API).


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsVolume

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsVolume

float AkEarlyReflections.reflectionsVolume = 1

The early reflections send volume for this particular game object. This parameter is used to control the volume of the early reflections send. It is combined with the early reflections volume specified in the authoring tool, and is applied to all sounds playing on the game object. Setting to 0.f will disable all reflection processing for this game object. Valid range 0.f-1.f.


Wwise Unity Integration Documentation: AkEmitterObstructionOcclusion クラス

公開変数類 | 全メンバ一覧
AkEmitterObstructionOcclusion クラス

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them. [詳解]

AkObstructionOcclusionを継承しています。

公開変数類

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. [詳解]
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. [詳解]
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. [詳解]
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. [詳解]

詳解

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them.


Wwise Unity Integration Documentation: AkEnvironment クラス

クラス | 全メンバ一覧
AkEnvironment クラス

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See AkEnvironmentやAkEnvironmentPortalをInspectorで使う. [詳解]

MonoBehaviour, AK.Wwise.IMigratableを継承しています。

クラス

class | AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities. [詳解]
class | AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: [詳解]

詳解

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See AkEnvironmentやAkEnvironmentPortalをInspectorで使う.

This component can be attached to any collider. You can specify a roll-off to fade-in/out of the reverb.
The reverb parameters will be defined in the Wwise project, by the sound designer. All AkGameObj that are "environment"-aware will receive a send value when entering the attached collider.

参照
  • AkEnvironmentやAkEnvironmentPortalをInspectorで使う
  • Integrating Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::SetGameObjectAuxSendValues (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareByPriority クラス

  • AkEnvironment
  • AkEnvironment_CompareByPriority
全メンバ一覧
AkEnvironment.AkEnvironment_CompareByPriority クラス

Sorts AkEnvironments based on their priorities. [詳解]

AkEnvironment.AkEnvironment_CompareByPriority の継承関係図
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm

詳解

Sorts AkEnvironments based on their priorities.


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm クラス

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
全メンバ一覧
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm クラス

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: [詳解]

AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm の継承関係図
AkEnvironment.AkEnvironment_CompareByPriority

詳解

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:

  1. Environments have priorities.
  2. Environments have a "Default" flag. This flag effectively says that this environment will be bumped out if any other is present.
  3. Environments have an "Exclude Other" flag. This flag will tell that this env is not overlappable with others. So, only one (the highest priority) should be selected.


Wwise Unity Integration Documentation: AkEnvironmentPortal クラス

クラス | 公開変数類 | 全メンバ一覧
AkEnvironmentPortal クラス

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. AkEnvironmentやAkEnvironmentPortalをInspectorで使う [詳解]

MonoBehaviourを継承しています。

クラス

class EnvListWrapper
This enables us to detect intersections between portals and environments in the editor [詳解]

公開変数類

UnityEngine.Vector3 | axis = UnityEngine.Vector3.right
The axis used to find the contribution of each environment [詳解]
AkEnvironment[] | environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class [詳解]

詳解

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. AkEnvironmentやAkEnvironmentPortalをInspectorで使う


Wwise Unity Integration Documentation: AkEnvironmentPortal.EnvListWrapper クラス

  • AkEnvironmentPortal
  • EnvListWrapper
全メンバ一覧
AkEnvironmentPortal.EnvListWrapper クラス

This enables us to detect intersections between portals and environments in the editor [詳解]

詳解

This enables us to detect intersections between portals and environments in the editor


Wwise Unity Integration Documentation: AkEnvironmentPortal.axis

  • AkEnvironmentPortal
axis
environments
envList

◆ axis

UnityEngine.Vector3 AkEnvironmentPortal.axis = UnityEngine.Vector3.right

The axis used to find the contribution of each environment


Wwise Unity Integration Documentation: AkEnvironmentPortal.environments

  • AkEnvironmentPortal
axis
environments
envList

◆ environments

AkEnvironment [] AkEnvironmentPortal.environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]

The array is already sorted by position. The first environment is on the negative side of the portal(opposite to the direction of the chosen axis) The second environment is on the positive side of the portal


Wwise Unity Integration Documentation: AkEnvironmentPortal.envList

  • AkEnvironmentPortal
axis
environments
envList

◆ envList

EnvListWrapper [] AkEnvironmentPortal.envList

Unity can't serialize an array of list so we wrap the list in a serializable class


Wwise Unity Integration Documentation: AkEvent クラス

公開変数類 | 静的公開変数類 | 全メンバ一覧
AkEvent クラス

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object. [詳解]

AkEvent の継承関係図
AkAmbient

公開変数類

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. [詳解]
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. [詳解]
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() [詳解]
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object.

参照
  • Edit Modeのサポート
  • AkAmbient をInspectorで使う
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEvent.actionOnEventType

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ actionOnEventType

AkActionOnEventType AkEvent.actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop

Replacement action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.curveInterpolation

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ curveInterpolation

AkCurveInterpolation AkEvent.curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear

Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.enableActionOnEvent

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ enableActionOnEvent

bool AkEvent.enableActionOnEvent = false

Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project.


Wwise Unity Integration Documentation: AkEvent.soundEmitterObject

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ soundEmitterObject

UnityEngine.GameObject AkEvent.soundEmitterObject

Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added.


Wwise Unity Integration Documentation: AkEvent.transitionDuration

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ transitionDuration

float AkEvent.transitionDuration = 0.0f

Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEventCallbackMsg クラス

公開変数類 | 全メンバ一覧
AkEventCallbackMsg クラス

Event callback information. Event callback functions can receive this structure as a parameter [詳解]

公開変数類

AkCallbackInfo | info
For more information about the event callback, see the classes derived from AkCallbackInfo. [詳解]
UnityEngine.GameObject | sender
GameObject from whom the callback function was called [詳解]
AkCallbackType | type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks [詳解]

詳解

Event callback information. Event callback functions can receive this structure as a parameter


Wwise Unity Integration Documentation: AkEventCallbackMsg.info

  • AkEventCallbackMsg
info
sender
type

◆ info

AkCallbackInfo AkEventCallbackMsg.info

For more information about the event callback, see the classes derived from AkCallbackInfo.


Wwise Unity Integration Documentation: AkEventCallbackMsg.sender

  • AkEventCallbackMsg
info
sender
type

◆ sender

UnityEngine.GameObject AkEventCallbackMsg.sender

GameObject from whom the callback function was called


Wwise Unity Integration Documentation: AkEventCallbackMsg.type

  • AkEventCallbackMsg
info
sender
type

◆ type

AkCallbackType AkEventCallbackMsg.type

AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks


Wwise Unity Integration Documentation: AkGameObj クラス

公開メンバ関数 | 公開変数類 | 全メンバ一覧
AkGameObj クラス

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise. [詳解]

MonoBehaviourを継承しています。

公開メンバ関数

virtual UnityEngine.Vector3 | GetPosition ()
virtual UnityEngine.Vector3 | GetForward ()
virtual UnityEngine.Vector3 | GetUpward ()

公開変数類

bool | isEnvironmentAware = true
Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true. [詳解]
AkGameObjPositionOffsetData | m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Position Offset [詳解]

詳解

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise.

参照
  • Integration Details - Game Objects (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkGameObj.GetForward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetForward()

virtual UnityEngine.Vector3 AkGameObj.GetForward ( )
inlinevirtual

Gets the orientation forward vector. User can also override this method to calculate an arbitrary vector.

戻り値
The forward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.GetPosition

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetPosition()

virtual UnityEngine.Vector3 AkGameObj.GetPosition ( )
inlinevirtual

Gets the position including the position offset, if applyPositionOffset is enabled. User can also override this method to calculate an arbitrary position.

戻り値
The position.

参照先 m_positionOffsetData.


Wwise Unity Integration Documentation: AkGameObj.GetUpward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetUpward()

virtual UnityEngine.Vector3 AkGameObj.GetUpward ( )
inlinevirtual

Gets the orientation upward vector. User can also override this method to calculate an arbitrary vector.

戻り値
The upward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.isEnvironmentAware

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ isEnvironmentAware

bool AkGameObj.isEnvironmentAware = true

Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true.


Wwise Unity Integration Documentation: AkGameObj.m_positionOffsetData

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ m_positionOffsetData

AkGameObjPositionOffsetData AkGameObj.m_positionOffsetData

When not set to null, the position will be offset relative to the Game Object position by the Position Offset

参照元 GetPosition().


Wwise Unity Integration Documentation: AkInitializer クラス

全メンバ一覧
AkInitializer クラス

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings. [詳解]

MonoBehaviourを継承しています。

詳解

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings.

参照
  • Initialize the Different Modules of the Sound Engine (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Init() (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Term() (Note: This is described in the Wwise SDK documentation.)
  • Enter Play Mode Behaviors
  • AkCallbackManager


Wwise Unity Integration Documentation: AkListenerDistanceProbe クラス

全メンバ一覧
AkListenerDistanceProbe クラス

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera. [詳解]

MonoBehaviourを継承しています。

詳解

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera.


Wwise Unity Integration Documentation: AkMemBankLoader クラス

公開メンバ関数 | 公開変数類 | 全メンバ一覧
AkMemBankLoader クラス

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class [詳解]

MonoBehaviourを継承しています。

公開メンバ関数

void | LoadNonLocalizedBank (string in_bankFilename)
Load a SoundBank from WWW object [詳解]
void | LoadLocalizedBank (string in_bankFilename)
Load a language-specific bank from WWW object [詳解]

公開変数類

string | bankName = ""
Name of the bank to load [詳解]
bool | isLocalizedBank = false
Is the bank localized (situated in the language-specific folders) [詳解]

詳解

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class


Wwise Unity Integration Documentation: AkMemBankLoader.LoadLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadLocalizedBank()

void AkMemBankLoader.LoadLocalizedBank ( string in_bankFilename )
inline

Load a language-specific bank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.LoadNonLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadNonLocalizedBank()

void AkMemBankLoader.LoadNonLocalizedBank ( string in_bankFilename )
inline

Load a SoundBank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.bankName

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ bankName

string AkMemBankLoader.bankName = ""

Name of the bank to load


Wwise Unity Integration Documentation: AkMemBankLoader.isLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ isLocalizedBank

bool AkMemBankLoader.isLocalizedBank = false

Is the bank localized (situated in the language-specific folders)


Wwise Unity Integration Documentation: AkRadialEmitter クラス

公開変数類 | 全メンバ一覧
AkRadialEmitter クラス

A radial emitter is for sounds that are not point sources, but instead originate from a region of space. [詳解]

MonoBehaviourを継承しています。

公開変数類

float | outerRadius = 0.0f
float | innerRadius = 0.0f

詳解

A radial emitter is for sounds that are not point sources, but instead originate from a region of space.

A radial emitter is described by an inner and outer radius. The radii are used in spread and distance calculations, simulating a radial sound source. Since all game objects have a position and orientation, the position (center) and local axes are defined by the AkGameObj component required by this component.


Wwise Unity Integration Documentation: AkRadialEmitter.innerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ innerRadius

float AkRadialEmitter.innerRadius = 0.0f

Define an inner radius around each sound position to simulate a radial sound source. If the listener is inside the inner radius, the spread is 100%. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkRadialEmitter.outerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ outerRadius

float AkRadialEmitter.outerRadius = 0.0f

Define an outer radius around each sound position to simulate a radial sound source. The distance used for applying attenuation curves is taken as the distance between the listener and the point on the sphere, defined by the sound position and the outer radius, that is closest to the listener. The spread for each sound position is calculated as follows:

  • If the listener is outside the outer radius, the spread is defined by the area that the sphere takes in the listener field of view. Specifically, this angle is calculated as 2.0*asinf( outerRadius / distance ), where distance is the distance between the listener and the sound position.
  • When the listener intersects the outer radius (the listener is exactly outerRadius units away from the sound position), the spread is exactly 50%.
  • When the listener is in between the inner and outer radius, the spread interpolates linearly from 50% to 100% as the listener transitions from the outer radius towards the inner radius. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkReverbZone クラス

公開メンバ関数 | 静的公開メンバ関数 | 公開変数類 | 全メンバ一覧
AkReverbZone クラス

This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal. [詳解]

MonoBehaviourを継承しています。

公開メンバ関数

void | SetReverbZone ()
Calls AkReverbZone::SetReverbZone() with this component's properties [詳解]
void | RemoveReverbZone ()
Calls AkReverbZone::RemoveReverbZone() with this component's properties [詳解]

静的公開メンバ関数

static void | SetReverbZone (AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AkRoom::SetReverbZone() from the Reverb Zone AkRoom component with the Parent Room and transition Region Width parameters. [詳解]
static void | RemoveReverbZone (AkRoom reverbZone)
Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms, unless they are explicitly connected with a Portal. Calls AkRoom::RemoveReverbZone() from the Reverb Zone AkRoom component. [詳解]

公開変数類

AkRoom ReverbZone
AkRoom ParentRoom
float TransitionRegionWidth = 1.0f
Width of the transition region between the Reverb Zone and its parent. The transition zone is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0. [詳解]

詳解

This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal.

Setting a Room as a Reverb Zone is useful in situations where two or more acoustic environments are not easily modeled as closed rooms connected by portals. Possible uses for Reverb Zones include: a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent.


Wwise Unity Integration Documentation: AkReverbZone.RemoveReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ RemoveReverbZone() [1/2]

void AkReverbZone.RemoveReverbZone ( )
inline

Calls AkReverbZone::RemoveReverbZone() with this component's properties

参照先 ReverbZone.


Wwise Unity Integration Documentation: AkReverbZone.RemoveReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ RemoveReverbZone() [2/2]

static void AkReverbZone.RemoveReverbZone ( AkRoom reverbZone )
inlinestatic

Remove a Reverb Zone from its parent. Sound can no longer propagate between the two Rooms, unless they are explicitly connected with a Portal. Calls AkRoom::RemoveReverbZone() from the Reverb Zone AkRoom component.

引数
reverbZone The Reverb Zone AkRoom component.

参照先 AkRoom.RemoveReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.SetReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ SetReverbZone() [1/2]

void AkReverbZone.SetReverbZone ( )
inline

Calls AkReverbZone::SetReverbZone() with this component's properties

参照先 ParentRoom, ReverbZone, TransitionRegionWidth.


Wwise Unity Integration Documentation: AkReverbZone.SetReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ SetReverbZone() [2/2]

static void AkReverbZone.SetReverbZone | ( | AkRoom | reverbZone,
 |  | AkRoom | parentRoom,
 |  | float | transitionRegionWidth
 | ) |  |
inlinestatic

Establish a parent-child relationship between two Rooms. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AkRoom::SetReverbZone() from the Reverb Zone AkRoom component with the Parent Room and transition Region Width parameters.

引数
reverbZone | The AkRoom component to set as a Reverb Zone.
parentRoom | The AkRoom component to set as the Reverb Zone's parent. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. Set to null to attach the Reverb Zone to the automatically created 'Outdoors' room.
transitionRegionWidth | The width of the transition region between the Reverb Zone and its parent. The transition region is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

参照先 AkRoom.SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.ParentRoom

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ ParentRoom

AkRoom AkReverbZone.ParentRoom

Set this Room as the parent of the Reverb Zone. Sound propagates between the Reverb Zone and its parent Room as if it were the same Room without the need for a connecting Portal. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, because they often model open spaces. Leave this set to None to attach the Reverb Zone to 'Outdoors'.

参照元 SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.ReverbZone

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ ReverbZone

AkRoom AkReverbZone.ReverbZone

Set this Room as a Reverb Zone. Sound propagates between the Reverb Zone and its parent Room as if it were the same Room without the need for a connecting Portal. Examples include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space.

参照元 RemoveReverbZone(), SetReverbZone().


Wwise Unity Integration Documentation: AkReverbZone.TransitionRegionWidth

  • AkReverbZone
ParentRoom
RemoveReverbZone
RemoveReverbZone
ReverbZone
SetReverbZone
SetReverbZone
TransitionRegionWidth

◆ TransitionRegionWidth

float AkReverbZone.TransitionRegionWidth = 1.0f

Width of the transition region between the Reverb Zone and its parent. The transition zone is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

参照元 SetReverbZone().


Wwise Unity Integration Documentation: AkRoom クラス

公開メンバ関数 | 公開変数類 | 静的公開変数類 | 全メンバ一覧
AkRoom クラス

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals [詳解]

AkTriggerHandlerを継承しています。

公開メンバ関数

ulong | GetID ()
Access the room's ID [詳解]
void | SetReverbZone (AkRoom parentRoom, float transitionRegionWidth)
Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AK::SpatialAudio::SetReverbZone() with the Parent Room and transition Region Width parameters. [詳解]
void | RemoveReverbZone ()
Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and its parent, unless they are explicitly connected with a Portal. Calls AK::SpatialAudio::RemoveReverbZone() with this Room's ID."/>. [詳解]

公開変数類

int | priority = 0
AK.Wwise.AuxBus | reverbAuxBus = new AK.Wwise.AuxBus()
The reverb auxiliary bus. [詳解]
float | reverbLevel = 1
The reverb control value for the send to the reverb aux bus. [詳解]
float | transmissionLoss = 1
Loss value modeling transmission through walls. [詳解]
AK.Wwise.Event | roomToneEvent = new AK.Wwise.Event()
Wwise Event to be posted on the room game object. [詳解]
float | roomToneAuxSend = 0
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send. [詳解]
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals

The AkRoom component uses its required Collider component to determine when AkRoomAwareObjects enter and exit the room using the OnTriggerEnter and OnTriggerExit callbacks.


Wwise Unity Integration Documentation: AkRoom.GetID

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ GetID()

ulong AkRoom.GetID ( )
inline

Access the room's ID

参照元 RemoveReverbZone(), SetReverbZone().


Wwise Unity Integration Documentation: AkRoom.RemoveReverbZone

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ RemoveReverbZone()

void AkRoom.RemoveReverbZone ( )
inline

Remove this Room, a Reverb Zone, from its parent. Sound can no longer propagate between this Room and its parent, unless they are explicitly connected with a Portal. Calls AK::SpatialAudio::RemoveReverbZone() with this Room's ID."/>.

参照先 GetID().

参照元 AkReverbZone.RemoveReverbZone().


Wwise Unity Integration Documentation: AkRoom.SetReverbZone

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ SetReverbZone()

void AkRoom.SetReverbZone | ( | AkRoom | parentRoom,
 |  | float | transitionRegionWidth
 | ) |  |
inline

Establish a parent-child relationship between this Room and a parent Room. Sound propagate between a Reverb Zone and its parent as if they were the same Room, without the need for a connecting Portal. Examples of Reverb Zones include a covered area with no walls, a forested area within an outdoor space, or any situation where multiple reverb effects are desired within a common space. Reverb Zones have many advantages compared to standard Game-Defined Auxiliary Sends. They are part of the wet path, and form reverb chains with other Rooms; they are spatialized according to their 3D extent; they are also subject to other acoustic phenomena simulated in Wwise Spatial Audio, such as diffraction and transmission. If a Room is already assigned to a parent Room, it is first be removed from the original parent (exactly as if RemoveReverbZone were called) before it is assigned to the new parent Room. The automatically created 'Outdoors' Room is commonly used as a parent Room for Reverb Zones, since they often model open spaces. Calls AK::SpatialAudio::SetReverbZone() with the Parent Room and transition Region Width parameters.

引数
parentRoom | The AkRoom component to set as the Reverb Zone's parent. A parent Room can have multiple Reverb Zones, but a Reverb Zone can only have a single Parent. A Room cannot be its own parent. Set to null to attach the Reverb Zone to the automatically created 'Outdoors' room.
transitionRegionWidth | The width of the transition region between the Reverb Zone and its parent. The transition region is centered around the Reverb Zone geometry. It only applies where triangle transmission loss is set to 0.

参照先 GetID().

参照元 AkReverbZone.SetReverbZone().


Wwise Unity Integration Documentation: AkRoom.priority

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ priority

int AkRoom.priority = 0

In cases where a game object is in an area with two rooms, the higher priority room will be chosen for AK::SpatialAudio::SetGameObjectInRoom() The higher the priority number, the higher the priority of a room.


Wwise Unity Integration Documentation: AkRoom.reverbAuxBus

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ reverbAuxBus

AK.Wwise.AuxBus AkRoom.reverbAuxBus = new AK.Wwise.AuxBus()

The reverb auxiliary bus.


Wwise Unity Integration Documentation: AkRoom.reverbLevel

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ reverbLevel

float AkRoom.reverbLevel = 1

The reverb control value for the send to the reverb aux bus.


Wwise Unity Integration Documentation: AkRoom.roomToneAuxSend

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ roomToneAuxSend

float AkRoom.roomToneAuxSend = 0

Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send.


Wwise Unity Integration Documentation: AkRoom.roomToneEvent

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ roomToneEvent

AK.Wwise.Event AkRoom.roomToneEvent = new AK.Wwise.Event()

Wwise Event to be posted on the room game object.


Wwise Unity Integration Documentation: AkRoom.transmissionLoss

  • AkRoom
GetID
priority
RemoveReverbZone
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
SetReverbZone
transmissionLoss

◆ transmissionLoss

float AkRoom.transmissionLoss = 1

Loss value modeling transmission through walls.


Wwise Unity Integration Documentation: AkRoomAwareManager クラス

全メンバ一覧
AkRoomAwareManager クラス

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit. [詳解]

詳解

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.

At the end of the frame, the AkRoomAwareObject is set in the highest priority AkRoom in Spatial Audio.


Wwise Unity Integration Documentation: AkRoomAwareObject クラス

公開メンバ関数 | 全メンバ一覧
AkRoomAwareObject クラス

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component. [詳解]

MonoBehaviourを継承しています。

公開メンバ関数

void | EnteredRoom (AkRoom room)
Called when entering a room. [詳解]
void | ExitedRoom (AkRoom room)
Called when exiting a room. [詳解]

詳解

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component.


Wwise Unity Integration Documentation: AkRoomAwareObject.EnteredRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ EnteredRoom()

void AkRoomAwareObject.EnteredRoom ( AkRoom room )
inline

Called when entering a room.

引数
room The room.


Wwise Unity Integration Documentation: AkRoomAwareObject.ExitedRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ ExitedRoom()

void AkRoomAwareObject.ExitedRoom ( AkRoom room )
inline

Called when exiting a room.

引数
room The room.


Wwise Unity Integration Documentation: AkRoomManager クラス

全メンバ一覧
AkRoomManager クラス

This manager tracks AkRoomPortals and the rooms that they connect (front and back room). [詳解]

詳解

This manager tracks AkRoomPortals and the rooms that they connect (front and back room).

At the end of the frame, the AkRoomPortals which rooms might have changed are updated and sent to Spatial Audio.


Wwise Unity Integration Documentation: AkRoomPortal クラス

公開メンバ関数 | 公開変数類 | 静的公開変数類 | 全メンバ一覧
AkRoomPortal クラス

An AkRoomPortal can connect two AkRoom components together. [詳解]

AkTriggerHandlerを継承しています。

公開メンバ関数

ulong | GetID ()
Access the portal's ID [詳解]
override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event [詳解]
void | ClosePortal (UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event [詳解]

公開変数類

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_ROOMS_PER_PORTAL = 2
AkRoomPortals can only connect a maximum of 2 rooms. [詳解]
const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

An AkRoomPortal can connect two AkRoom components together.


Wwise Unity Integration Documentation: AkRoomPortal.ClosePortal

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ ClosePortal()

void AkRoomPortal.ClosePortal ( UnityEngine.GameObject in_gameObject )
inline

Closes the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.GetID

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ GetID()

ulong AkRoomPortal.GetID ( )
inline

Access the portal's ID


Wwise Unity Integration Documentation: AkRoomPortal.HandleEvent

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ HandleEvent()

override void AkRoomPortal.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Opens the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.MAX_ROOMS_PER_PORTAL

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ MAX_ROOMS_PER_PORTAL

const int AkRoomPortal.MAX_ROOMS_PER_PORTAL = 2
static

AkRoomPortals can only connect a maximum of 2 rooms.


Wwise Unity Integration Documentation: AkRoomPortalObstruction クラス

公開変数類 | 全メンバ一覧
AkRoomPortalObstruction クラス

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them. [詳解]

AkObstructionOcclusionを継承しています。

公開変数類

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. [詳解]
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. [詳解]
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. [詳解]
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. [詳解]

詳解

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them.

If no spatial audio listener has been registered, there will be no obstruction.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw クラス

公開変数類 | 全メンバ一覧
AkSpatialAudioDebugDraw クラス

Add this script on a GameObject to print Spatial Audio paths. [詳解]

MonoBehaviourを継承しています。

公開変数類

bool | drawFirstOrderReflections = false
This allows you to visualize first order reflection sound paths. [詳解]
bool | drawSecondOrderReflections = false
This allows you to visualize second order reflection sound paths. [詳解]
bool | drawHigherOrderReflections = false
This allows you to visualize third or higher order reflection sound paths. [詳解]
bool | drawDiffractionPaths = false
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener. [詳解]

詳解

Add this script on a GameObject to print Spatial Audio paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawDiffractionPaths

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawDiffractionPaths

bool AkSpatialAudioDebugDraw.drawDiffractionPaths = false

This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawFirstOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawFirstOrderReflections

bool AkSpatialAudioDebugDraw.drawFirstOrderReflections = false

This allows you to visualize first order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawHigherOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawHigherOrderReflections

bool AkSpatialAudioDebugDraw.drawHigherOrderReflections = false

This allows you to visualize third or higher order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawSecondOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawSecondOrderReflections

bool AkSpatialAudioDebugDraw.drawSecondOrderReflections = false

This allows you to visualize second order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter クラス

公開変数類 | 全メンバ一覧
AkSpatialAudioEmitter クラス

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring. [詳解]

MonoBehaviour, AK.Wwise.IMigratableを継承しています。

公開変数類

AK.Wwise.AuxBus | reflectAuxBus = new AK.Wwise.AuxBus()
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component. [詳解]
float | reflectionMaxPathLength = 1000
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool. [詳解]
float | reflectionsAuxBusGain = 1
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component. [詳解]
uint | reflectionsOrder = 1
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings. [詳解]
float | roomReverbAuxBusGain = 1
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool. [詳解]
uint | diffractionMaxEdges = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. [詳解]
uint | diffractionMaxPaths = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. [詳解]
uint | diffractionMaxPathLength = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. [詳解]
bool | drawFirstOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. [詳解]
bool | drawSecondOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. [詳解]
bool | drawHigherOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. [詳解]
bool | drawDiffractionPaths = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. [詳解]

詳解

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring.

Some functionalities were moved to different components. See the AkEarlyReflections and AkSpatialAudioDebugDraw components for more details.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxEdges

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxEdges

uint AkSpatialAudioEmitter.diffractionMaxEdges = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPathLength

uint AkSpatialAudioEmitter.diffractionMaxPathLength = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPaths

uint AkSpatialAudioEmitter.diffractionMaxPaths = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawDiffractionPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawDiffractionPaths

bool AkSpatialAudioEmitter.drawDiffractionPaths = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawFirstOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawFirstOrderReflections

bool AkSpatialAudioEmitter.drawFirstOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawHigherOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawHigherOrderReflections

bool AkSpatialAudioEmitter.drawHigherOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawSecondOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawSecondOrderReflections

bool AkSpatialAudioEmitter.drawSecondOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectAuxBus

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectAuxBus

AK.Wwise.AuxBus AkSpatialAudioEmitter.reflectAuxBus = new AK.Wwise.AuxBus()

(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionMaxPathLength

float AkSpatialAudioEmitter.reflectionMaxPathLength = 1000

(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsAuxBusGain

float AkSpatialAudioEmitter.reflectionsAuxBusGain = 1

(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsOrder

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsOrder

uint AkSpatialAudioEmitter.reflectionsOrder = 1

(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.roomReverbAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ roomReverbAuxBusGain

float AkSpatialAudioEmitter.roomReverbAuxBusGain = 1

(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioListener クラス

クラス | プロパティ | 全メンバ一覧
AkSpatialAudioListener クラス

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. [詳解]

MonoBehaviour, AK.Wwise.IMigratableを継承しています。

クラス

class SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. [詳解]

プロパティ

static AkAudioListener? | TheSpatialAudioListener [get]
Returns the "single" spatial audio listener. [詳解]
static SpatialAudioListenerList | SpatialAudioListeners [get]
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners. [詳解]

詳解

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

参照
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList クラス

  • AkSpatialAudioListener
  • SpatialAudioListenerList
公開メンバ関数 | 全メンバ一覧
AkSpatialAudioListener.SpatialAudioListenerList クラス

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. [詳解]

公開メンバ関数

bool | Add (AkSpatialAudioListener listener)
Uniquely adds listeners to the list [詳解]
bool | Remove (AkSpatialAudioListener listener)
Removes listeners from the list [詳解]

詳解

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time.


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Add

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Add()

bool AkSpatialAudioListener.SpatialAudioListenerList.Add ( AkSpatialAudioListener listener )
inline

Uniquely adds listeners to the list

引数
listener
戻り値


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Remove

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Remove()

bool AkSpatialAudioListener.SpatialAudioListenerList.Remove ( AkSpatialAudioListener listener )
inline

Removes listeners from the list

引数
listener
戻り値


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListeners

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ SpatialAudioListeners

SpatialAudioListenerList AkSpatialAudioListener.SpatialAudioListeners
staticget

Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.


Wwise Unity Integration Documentation: AkSpatialAudioListener.TheSpatialAudioListener

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ TheSpatialAudioListener

AkAudioListener? AkSpatialAudioListener.TheSpatialAudioListener
staticget

Returns the "single" spatial audio listener.


Wwise Unity Integration Documentation: AkState クラス

公開変数類 | 静的公開変数類 | 全メンバ一覧
AkState クラス

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it. [詳解]

AkDragDropTriggerHandler, AK.Wwise.IMigratableを継承しています。

公開変数類

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it.

参照
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSurfaceReflector クラス

クラス | 公開メンバ関数 | 静的公開メンバ関数 | 公開変数類 | 全メンバ一覧
AkSurfaceReflector クラス

This component converts the provided mesh into Spatial Audio Geometry. [詳解]

MonoBehaviour, AK.Wwise.IMigratableを継承しています。

クラス

struct GeometryData
The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry() [詳解]

公開メンバ関数

void | SetGeometry ()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh. [詳解]
void | SetGeometryInstance ()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform. [詳解]
void | UpdateGeometry ()
Update this component's geometry instance [詳解]
void | RemoveGeometry ()
Remove this component's geometry and corresponding instance from Spatial Audio. [詳解]
void | RemoveGeometryInstance ()
Remove this component's geometry instance from Spatial Audio. [詳解]

静的公開メンバ関数

static void | SetGeometryFromMesh (UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance(). [詳解]
static void | GetGeometryDataFromMesh (UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkSoundEngine.SetGeometry() [詳解]
static void | SetGeometryInstance (ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction)
Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. [詳解]

公開変数類

UnityEngine.Mesh | Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh. [詳解]
AK.Wwise.AcousticTexture[] | AcousticTextures = new AK.Wwise.AcousticTexture[1]
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry. [詳解]
float[] | TransmissionLossValues = new[] { 1.0f }
The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0. [詳解]
bool | EnableDiffraction = true
Switch to enable or disable geometric diffraction for this mesh. [詳解]
bool | EnableDiffractionOnBoundaryEdges = false
Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle. [詳解]
AkRoom | AssociatedRoom = null

詳解

This component converts the provided mesh into Spatial Audio Geometry.

This component takes a mesh as a parameter. The triangles of the mesh are sent to Spatial Audio by calling SpatialAudio::AddGeometrySet(). The triangles reflect sounds that have an associated early reflections bus. If diffraction is enabled on this component, spatial audio also finds edges on the provided mesh, which diffract sounds that are diffraction enabled.


Wwise Unity Integration Documentation: AkSurfaceReflector.GeometryData 構造体

  • AkSurfaceReflector
  • GeometryData
全メンバ一覧
AkSurfaceReflector.GeometryData 構造体

The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry() [詳解]

詳解

The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()


Wwise Unity Integration Documentation: AkSurfaceReflector.GetGeometryDataFromMesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ GetGeometryDataFromMesh()

static void AkSurfaceReflector.GetGeometryDataFromMesh | ( | UnityEngine.Mesh | mesh,
 |  | ref GeometryData | geometryData,
 |  | AK.Wwise.AcousticTexture[] | acousticTextures = null,
 |  | float[] | transmissionLossValues = null,
 |  | string | name = ""
 | ) |  |
inlinestatic

Create Spatial Audio Geometry Data from a Unity mesh. The Geometry Data can be used later to call AkSoundEngine.SetGeometry()

引数
mesh | The mesh representing the geometry to be sent to Spatial Audio.
geometryData | (Output)The Spatial Audio Geometry Data created from the mesh.
acousticTextures | The acoustic texture of each surface of the geometry. Acoustic textures describe the filtering when sound reflects on the surface.
transmissionLossValues | The transmission loss value of each surface of the geometry. Transmission loss is the filtering when the sound goes through the surface.
name | A name for the geometry.

参照元 SetGeometryFromMesh().


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometry()

void AkSurfaceReflector.RemoveGeometry ( )
inline

Remove this component's geometry and corresponding instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometryInstance()

void AkSurfaceReflector.RemoveGeometryInstance ( )
inline

Remove this component's geometry instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometry()

void AkSurfaceReflector.SetGeometry ( )
inline

Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.

参照先 AcousticTextures, EnableDiffraction, EnableDiffractionOnBoundaryEdges, Mesh, SetGeometryFromMesh(), TransmissionLossValues.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryFromMesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryFromMesh()

static void AkSurfaceReflector.SetGeometryFromMesh | ( | UnityEngine.Mesh | mesh,
 |  | ulong | geometryID,
 |  | bool | enableDiffraction,
 |  | bool | enableDiffractionOnBoundaryEdges,
 |  | AK.Wwise.AcousticTexture[] | acousticTextures = null,
 |  | float[] | transmissionLossValues = null,
 |  | string | name = ""
 | ) |  |
inlinestatic

Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance().

引数
mesh | The mesh representing the geometry to be sent to Spatial Audio.
geometryID | A unique ID representing the geometry.
enableDiffraction | Enable the edges of this geometry to become diffraction edges.
enableDiffractionOnBoundaryEdges | Enable the boundary edges of this geometry to become diffraction edges. Boundary edges are edges that are connected to only one triangle.
acousticTextures | The acoustic texture of each surface of the geometry. Acoustic textures describe the filtering when sound reflects on the surface.
transmissionLossValues | The transmission loss value of each surface of the geometry. Transmission loss is the filtering when the sound goes through the surface.
name | A name for the geometry.

参照先 GetGeometryDataFromMesh().

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [1/2]

void AkSurfaceReflector.SetGeometryInstance ( )
inline

Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.

参照先 AssociatedRoom.

参照元 UpdateGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [2/2]

static void AkSurfaceReflector.SetGeometryInstance | ( | ulong | geometryInstanceID,
 |  | ulong | geometryID,
 |  | ulong | associatedRoomID,
 |  | UnityEngine.Transform | transform,
 |  | bool | useForReflectionAndDiffraction
 | ) |  |
inlinestatic

Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation.

引数
geometryInstanceID | A unique ID to for the geometry instance. It must be unique amongst all geometry instances, including geometry instances referencing different geometries.
geometryID | The ID of the geometry referenced by this instance.
associatedRoomID | The ID of the room this geometry is encompassed in, if any.
transform | The transform to be applied to the geometry to convert it in world positions.
useForReflectionAndDiffraction | When enabled, the geometry instance triangles are used to compute reflection and diffraction. Set to false when using a geometry instance only to describe a room, and not for reflection and diffraction calculation.


Wwise Unity Integration Documentation: AkSurfaceReflector.UpdateGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ UpdateGeometry()

void AkSurfaceReflector.UpdateGeometry ( )
inline

Update this component's geometry instance

参照先 SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.AcousticTextures

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AcousticTextures

AK.Wwise.AcousticTexture [] AkSurfaceReflector.AcousticTextures = new AK.Wwise.AcousticTexture[1]

The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry.

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.AssociatedRoom

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AssociatedRoom

AkRoom AkSurfaceReflector.AssociatedRoom = null

(Deprecated) Associate this AkSurfaceReflector component with a Room. This property is deprecated and will be removed in a future version. We recommend not using it by leaving it set to None. Associating an AkSurfaceReflector with a particular Room limits the scope in which the geometry is accessible. Doing so reduces the search space for ray casting performed by reflection and diffraction calculations. When set to None, this geometry has a global scope. Note if one or more geometry sets are associated with a room, that room can no longer access geometry that is in the global scope.

参照元 SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffraction

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffraction

bool AkSurfaceReflector.EnableDiffraction = true

Switch to enable or disable geometric diffraction for this mesh.

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffractionOnBoundaryEdges

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffractionOnBoundaryEdges

bool AkSurfaceReflector.EnableDiffractionOnBoundaryEdges = false

Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle.

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.Mesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ Mesh

UnityEngine.Mesh AkSurfaceReflector.Mesh

The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.TransmissionLossValues

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
GetGeometryDataFromMesh
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ TransmissionLossValues

float [] AkSurfaceReflector.TransmissionLossValues = new[] { 1.0f }

The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0.

参照元 SetGeometry().


Wwise Unity Integration Documentation: AkSwitch クラス

公開変数類 | 静的公開変数類 | 全メンバ一覧
AkSwitch クラス

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it. [詳解]

AkDragDropTriggerHandler, AK.Wwise.IMigratableを継承しています。

公開変数類

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it.

参照
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkTriggerBase クラス

公開メンバ関数 | 公開変数類 | 全メンバ一覧
AkTriggerBase クラス

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwiseイベントのトリガーを追加する [詳解]

MonoBehaviourを継承しています。

AkTriggerCollisionEnter, AkTriggerCollisionExit, AkTriggerDisable, AkTriggerEnable, AkTriggerEnter, AkTriggerExit, AkTriggerMouseDown, AkTriggerMouseEnter, AkTriggerMouseExit, AkTriggerMouseUpに継承されています。

公開メンバ関数

delegate void Trigger (UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers. [詳解]

公開変数類

Trigger triggerDelegate = null
All components reacting to the trigger will be registered in this delegate. [詳解]

詳解

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwiseイベントのトリガーを追加する


Wwise Unity Integration Documentation: AkTriggerBase.Trigger

  • AkTriggerBase
Trigger
triggerDelegate

◆ Trigger()

delegate void AkTriggerBase.Trigger ( UnityEngine.GameObject in_gameObject )

Delegate declaration for all Wwise Triggers.

引数
in_gameObject in_gameObject is used to pass "Collidee" objects when Colliders are used. Some components have the option "Use other object", this is the object they'll use.


Wwise Unity Integration Documentation: AkTriggerBase.triggerDelegate

  • AkTriggerBase
Trigger
triggerDelegate

◆ triggerDelegate

Trigger AkTriggerBase.triggerDelegate = null

All components reacting to the trigger will be registered in this delegate.


Wwise Unity Integration Documentation: AkWaapiUtilities クラス

クラス | 公開メンバ関数 | 静的公開メンバ関数 | 静的公開変数類 | 全メンバ一覧
AkWaapiUtilities クラス

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages. [詳解]

クラス

class | SubscriptionInfo
Class used to store information about a specific subscription. [詳解]
struct | WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by the command queue. [詳解]

公開メンバ関数

delegate void | GetResultListDelegate< T > (List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request. [詳解]
delegate void | GetResultDelegate< T > (T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request. [詳解]

静的公開メンバ関数

static bool | IsConnected ()
Check whether the client is currently connected. [詳解]
static void | Disconnected ()
Invoked after the client has disconnected from Wwise authoring. [詳解]
static string | GetStatusString ()
Returns a rich text string representing the current WAAPI connection status. [詳解]
static void | QueueCommand (string uri, string args, string options)
Use this function to enqueue a command with no expected return object. [詳解]
static void | QueueCommandWithReturnType< T > (string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. /// [詳解]
static void | QueueCommandWithReturnWwiseObjects< T > (WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response. [詳解]
static void | GetWwiseObject< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options. [詳解]
static void | GetWwiseObjects< T > (List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options. [詳解]
static void | GetWwiseObjectAndAncestors< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback. [詳解]
static void | GetWwiseObjectAndDescendants< T > (System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback. [詳解]
static void | GetWwiseObjectAndDescendants< T > (string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback [詳解]
static void | Search< T > (string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback [詳解]
static void | GetChildren< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object. [詳解]
static void | GetProject< T > (GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project. [詳解]
static List< WwiseObjectInfo > | ParseObjectInfo (List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo. [詳解]
static void | SelectObjectInAuthoring (System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue. [詳解]
static void | OpenWorkUnitInExplorer (System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue. [詳解]
static void | OpenSoundBankInExplorer (System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue. [詳解]
static void | Rename (System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue. [詳解]
static void | Delete (System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue. [詳解]
static bool | IsPlayable (WwiseObjectType type)
Checks if Wwise object is playable. [詳解]
static void | TogglePlayEvent (WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

引数
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.
[詳解]
static void | StopAllTransports ()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue. [詳解]
static void | Subscribe (string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue. [詳解]
static void | Unsubscribe (uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue. [詳解]
static List< WwiseObjectInfo > | ParseSelectedObjects (string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic. [詳解]
static WwiseRenameInfo | ParseRenameObject (string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic. [詳解]
static WwiseChildModifiedInfo | ParseChildAddedOrRemoved (string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic. [詳解]

静的公開変数類

static System.Action< bool > | Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions). [詳解]
static System.Action | Connected
Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in. [詳解]
static System.Action | QueueConsumed
Fired when all commands in the queue have been executed. [詳解]

詳解

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages.


Wwise Unity Integration Documentation: AkWaapiUtilities.SubscriptionInfo クラス

  • AkWaapiUtilities
  • SubscriptionInfo
全メンバ一覧
AkWaapiUtilities.SubscriptionInfo クラス

Class used to store information about a specific subscription. [詳解]

詳解

Class used to store information about a specific subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.WaapiCommand 構造体

  • AkWaapiUtilities
  • WaapiCommand
全メンバ一覧
AkWaapiUtilities.WaapiCommand 構造体

A simple structure containing an async payload function that will be executed when it is consumed by the command queue. [詳解]

詳解

A simple structure containing an async payload function that will be executed when it is consumed by the command queue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Delete

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Delete()

static void AkWaapiUtilities.Delete ( System.Guid guid )
inlinestatic

Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue.

引数
guid GUID of the object to be deleted.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnected()

static void AkWaapiUtilities.Disconnected ( )
inlinestatic

Invoked after the client has disconnected from Wwise authoring.

参照先 Disconnecting.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetChildren< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetChildren< T >()

static void AkWaapiUtilities.GetChildren< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Get the children of a given object.

引数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetProject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetProject< T >()

static void AkWaapiUtilities.GetProject< T > | ( | GetResultListDelegate< T > | callback,
 |  | ReturnOptions | options
 | ) |  |
inlinestatic

Get the WwiseObjectInfo for the project.

引数
callback | Function accepting a list of WwiseObjectInfo. The first element of the list will be the project info.
options | Specifies which object properties to include in the response


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultDelegate< T >()

delegate void AkWaapiUtilities.GetResultDelegate< T > ( T result )

Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request.

引数
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultListDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultListDelegate< T >()

delegate void AkWaapiUtilities.GetResultListDelegate< T > ( List< T > result )

Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request.

引数
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetStatusString

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetStatusString()

static string AkWaapiUtilities.GetStatusString ( )
inlinestatic

Returns a rich text string representing the current WAAPI connection status.

戻り値


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObject< T >()

static void AkWaapiUtilities.GetWwiseObject< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a Wwise object with custom return options.

テンプレート引数
T Type of the object to be deserialized from the response.
引数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndAncestors< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndAncestors< T >()

static void AkWaapiUtilities.GetWwiseObjectAndAncestors< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback.

引数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [1/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | string | identifier,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback

引数
identifier | Can bethe target object GUID or path within the hierarchy.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [2/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback.

引数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjects< T >()

static void AkWaapiUtilities.GetWwiseObjects< T > | ( | List< System.Guid > | guids,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a list of Wwise objects with custom return options.

テンプレート引数
T Type of the object to be deserialized from the response.
引数
guids | GUIDs of the target objects.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.IsConnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsConnected()

static bool AkWaapiUtilities.IsConnected ( )
inlinestatic

Check whether the client is currently connected.

戻り値


Wwise Unity Integration Documentation: AkWaapiUtilities.IsPlayable

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsPlayable()

static bool AkWaapiUtilities.IsPlayable ( WwiseObjectType type )
inlinestatic

Checks if Wwise object is playable.

引数
type WwiseObjectType of object to check.
戻り値
True if playable

参照元 TogglePlayEvent().


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenSoundBankInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenSoundBankInExplorer()

static void AkWaapiUtilities.OpenSoundBankInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue.

引数
guid GUID of the SoundBank to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenWorkUnitInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenWorkUnitInExplorer()

static void AkWaapiUtilities.OpenWorkUnitInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue.

引数
guid GUID of the object to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseChildAddedOrRemoved

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseChildAddedOrRemoved()

static WwiseChildModifiedInfo AkWaapiUtilities.ParseChildAddedOrRemoved ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic.

引数
json Json string containing the message.
戻り値
WwiseChildModifiedInfo containing parent and child object information.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseObjectInfo

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseObjectInfo()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseObjectInfo ( List< WwiseObjectInfoJsonObject > returnObjects )
inlinestatic

Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo.

引数
returnObjects
戻り値


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseRenameObject

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseRenameObject()

static WwiseRenameInfo AkWaapiUtilities.ParseRenameObject ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.nameChanged topic.

引数
json Json string containing the message.
戻り値
WwiseRenameInfo containing the object information and the new name.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseSelectedObjects

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseSelectedObjects()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseSelectedObjects ( string json )
inlinestatic

Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.

引数
json Json string containing the message.
戻り値
List of WwiseObjectInfo objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommand

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommand()

static void AkWaapiUtilities.QueueCommand | ( | string | uri,
 |  | string | args,
 |  | string | options
 | ) |  |
inlinestatic

Use this function to enqueue a command with no expected return object.

引数
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnType< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnType< T >()

static void AkWaapiUtilities.QueueCommandWithReturnType< T > | ( | string | uri,
 |  | GetResultDelegate< T > | callback,
 |  | string | args = null,
 |  | string | options = null
 | ) |  |
inlinestatic

Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. ///

テンプレート引数
T Type of the expected return object
引数
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options
callback | Function accepting an argument of type T


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnWwiseObjects< T >()

static void AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T > | ( | WaqlArgs | args,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a command with a payload that desirializes the list of wwise objects from the response.

引数
args
options
callback


Wwise Unity Integration Documentation: AkWaapiUtilities.Rename

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Rename()

static void AkWaapiUtilities.Rename | ( | System.Guid | guid,
 |  | string | newName
 | ) |  |
inlinestatic

Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue.

引数
guid | GUID of the object to be renamed.
newName | New name for the wwise object.


Wwise Unity Integration Documentation: AkWaapiUtilities.Search< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Search< T >()

static void AkWaapiUtilities.Search< T > | ( | string | searchString,
 |  | WwiseObjectType | objectType,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback

引数
searchString | Characters to search for.
options | Specifies which object properties to include in the response
objectType | An optional object type used to filter search results.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.SelectObjectInAuthoring

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ SelectObjectInAuthoring()

static void AkWaapiUtilities.SelectObjectInAuthoring ( System.Guid guid )
inlinestatic

Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue.

引数
guid GUID of the object to be selected.


Wwise Unity Integration Documentation: AkWaapiUtilities.StopAllTransports

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ StopAllTransports()

static void AkWaapiUtilities.StopAllTransports ( )
inlinestatic

Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Subscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Subscribe()

static void AkWaapiUtilities.Subscribe | ( | string | topic,
 |  | Wamp.PublishHandler | subscriptionCallback,
 |  | System.Action< SubscriptionInfo > | handshakeCallback
 | ) |  |
inlinestatic

Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue.

引数
topic | The topic URI to subscribe to.
subscriptionCallback | Delegate function to call when the topic is published.
handshakeCallback | Action to be executed once the subscription has been made. This should store the subscription ID so that the subscription can be cleaned up when it is no longer needed.

参照元 AkWwiseTreeWAAPIDataSource.SubscribeTopics().


Wwise Unity Integration Documentation: AkWaapiUtilities.TogglePlayEvent

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ TogglePlayEvent()

static void AkWaapiUtilities.TogglePlayEvent | ( | WwiseObjectType | objectType,
 |  | System.Guid | guid
 | ) |  |
inlinestatic

Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

引数
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.

参照先 IsPlayable().


Wwise Unity Integration Documentation: AkWaapiUtilities.Unsubscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Unsubscribe()

static void AkWaapiUtilities.Unsubscribe ( uint id )
inlinestatic

Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue.

引数
id The subscription ID received from the initial subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.Connected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Connected

System.Action AkWaapiUtilities.Connected
static

Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnecting

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnecting

System.Action<bool> AkWaapiUtilities.Disconnecting
static

Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions).

参照元 Disconnected().


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueConsumed

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueConsumed

System.Action AkWaapiUtilities.QueueConsumed
static

Fired when all commands in the queue have been executed.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource クラス

公開メンバ関数 | 全メンバ一覧
AkWwiseTreeWAAPIDataSource クラス

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions. [詳解]

AkWwiseTreeDataSourceを継承しています。

公開メンバ関数

void SubscribeTopics ()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer. [詳解]

詳解

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource.SubscribeTopics

  • AkWwiseTreeWAAPIDataSource
SubscribeTopics

◆ SubscribeTopics()

void AkWwiseTreeWAAPIDataSource.SubscribeTopics ( )
inline

Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer.

参照先 AkWaapiUtilities.Subscribe().


Wwise Unity Integration Documentation: AkWwiseTrigger クラス

公開変数類 | 静的公開変数類 | 全メンバ一覧
AkWwiseTrigger クラス

This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it. [詳解]

AkDragDropTriggerHandler, AK.Wwise.IMigratableを継承しています。

公開変数類

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. [詳解]
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. [詳解]

静的公開変数類

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers [詳解]
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime [詳解]

詳解

This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it.

参照
  • Working with Triggers > Overview (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: Args クラス

全メンバ一覧
Args クラス

Abstract base class for WAAPI command arguments. [詳解]

Args の継承関係図
JsonSerializable ArgsCommand ArgsDisplayName ArgsObject ArgsPlay ArgsRename ArgsTransport WaqlArgs

詳解

Abstract base class for WAAPI command arguments.


Wwise Unity Integration Documentation: ArgsCommand クラス

全メンバ一覧
ArgsCommand クラス

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync(). [詳解]

ArgsCommand の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync().


Wwise Unity Integration Documentation: ArgsDisplayName クラス

全メンバ一覧
ArgsDisplayName クラス

WAAPI arguments containing an object identfier and name used when deleting an object. [詳解]

ArgsDisplayName の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing an object identfier and name used when deleting an object.


Wwise Unity Integration Documentation: ArgsObject クラス

全メンバ一覧
ArgsObject クラス

WAAPI arguments containing an object identfier. [詳解]

ArgsObject の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing an object identfier.


Wwise Unity Integration Documentation: ArgsPlay クラス

全メンバ一覧
ArgsPlay クラス

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback. [詳解]

ArgsPlay の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.


Wwise Unity Integration Documentation: ArgsRename クラス

全メンバ一覧
ArgsRename クラス

WAAPI arguments containing an object identfier and new value used when renaming an object. [詳解]

ArgsRename の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing an object identfier and new value used when renaming an object.


Wwise Unity Integration Documentation: ArgsTransport クラス

全メンバ一覧
ArgsTransport クラス

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands. [詳解]

ArgsTransport の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.


Wwise Unity Integration Documentation: ErrorDetails クラス

全メンバ一覧
ErrorDetails クラス

Used to deserialize details in WAAPI error messages. [詳解]

ErrorDetails の継承関係図
JsonSerializable

詳解

Used to deserialize details in WAAPI error messages.


Wwise Unity Integration Documentation: ErrorMessage クラス

全メンバ一覧
ErrorMessage クラス

Used to deserialize WAAPI error messages. [詳解]

ErrorMessage の継承関係図
JsonSerializable

詳解

Used to deserialize WAAPI error messages.


Wwise Unity Integration Documentation: JsonSerializable クラス

全メンバ一覧
JsonSerializable クラス

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson. [詳解]

JsonSerializable の継承関係図
Args ErrorDetails ErrorMessage Options ReturnTransport ReturnWwiseObjects< T > ReturnWwiseObjects< T > SelectedWwiseObjects TransportState WwiseChildModifiedInfo WwiseRenameInfo

詳解

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson.


Wwise Unity Integration Documentation: Options クラス

全メンバ一覧
Options クラス

Abstract base class for WAAPI command options. [詳解]

Options の継承関係図
JsonSerializable ReturnOptions TransportOptions

詳解

Abstract base class for WAAPI command options.


Wwise Unity Integration Documentation: ReturnOptions クラス

全メンバ一覧
ReturnOptions クラス

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects. [詳解]

ReturnOptions の継承関係図
Options JsonSerializable

詳解

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.


Wwise Unity Integration Documentation: ReturnTransport クラス

全メンバ一覧
ReturnTransport クラス

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID. [詳解]

ReturnTransport の継承関係図
JsonSerializable

詳解

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID.


Wwise Unity Integration Documentation: ReturnWwiseObjects クラス

ReturnWwiseObjects クラス

Class used to deserialize a WAAPI response containing Wwise objects. [詳解]

詳解

Class used to deserialize a WAAPI response containing Wwise objects.


Wwise Unity Integration Documentation: SelectedWwiseObjects クラス

全メンバ一覧
SelectedWwiseObjects クラス

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic. [詳解]

SelectedWwiseObjects の継承関係図
JsonSerializable

詳解

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.


Wwise Unity Integration Documentation: TransportOptions クラス

全メンバ一覧
TransportOptions クラス

WAAPI options used to specify the transport ID when subscribing. [詳解]

TransportOptions の継承関係図
Options JsonSerializable

詳解

WAAPI options used to specify the transport ID when subscribing.


Wwise Unity Integration Documentation: TransportState クラス

全メンバ一覧
TransportState クラス

Used to deserialize transport-state information receieved from the transport.stateChanged topic. [詳解]

TransportState の継承関係図
JsonSerializable

詳解

Used to deserialize transport-state information receieved from the transport.stateChanged topic.


Wwise Unity Integration Documentation: WaapiHelper クラス

全メンバ一覧
WaapiHelper クラス

Contains a helper function GetWwiseObjectTypeFromString. [詳解]

詳解

Contains a helper function GetWwiseObjectTypeFromString.


Wwise Unity Integration Documentation: WaapiKeywords クラス

静的公開変数類 | 全メンバ一覧
WaapiKeywords クラス

Contains fields for specific WAAPI keywords. [詳解]

静的公開変数類

static ReadOnlyDictionary< WwiseObjectType, string > | WwiseObjectTypeStrings
Maps WwiseObjectType to strings. [詳解]
static ReadOnlyDictionary< string, string > | FolderDisplaynames
Maps root folder names to displayed strings. [詳解]
static ReadOnlyDictionary< string, WwiseObjectType > | typeStringDict
Maps strings to WwiseObjectType. [詳解]

詳解

Contains fields for specific WAAPI keywords.


Wwise Unity Integration Documentation: WaapiKeywords.FolderDisplaynames

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ FolderDisplaynames

ReadOnlyDictionary<string, string> WaapiKeywords.FolderDisplaynames
static

Maps root folder names to displayed strings.


Wwise Unity Integration Documentation: WaapiKeywords.typeStringDict

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ typeStringDict

ReadOnlyDictionary<string, WwiseObjectType> WaapiKeywords.typeStringDict
static

Maps strings to WwiseObjectType.


Wwise Unity Integration Documentation: WaapiKeywords.WwiseObjectTypeStrings

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ WwiseObjectTypeStrings

ReadOnlyDictionary<WwiseObjectType, string> WaapiKeywords.WwiseObjectTypeStrings
static

Maps WwiseObjectType to strings.


Wwise Unity Integration Documentation: Wamp クラス

クラス | 公開メンバ関数 | 全メンバ一覧
Wamp クラス

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise. [詳解]

クラス

class | ErrorException
Exception thrown during WAMP operations. [詳解]
class | TimeoutException
Exception thrown during WAMP operations when the timeout is reached. [詳解]

公開メンバ関数

delegate void PublishHandler (string json)
Publish events are delegates registered with Subscribe. [詳解]

詳解

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise.


Wwise Unity Integration Documentation: Wamp.ErrorException クラス

  • Wamp
  • ErrorException
全メンバ一覧
Wamp.ErrorException クラス

Exception thrown during WAMP operations. [詳解]

Exceptionを継承しています。

詳解

Exception thrown during WAMP operations.


Wwise Unity Integration Documentation: Wamp.TimeoutException クラス

  • Wamp
  • TimeoutException
全メンバ一覧
Wamp.TimeoutException クラス

Exception thrown during WAMP operations when the timeout is reached. [詳解]

Exceptionを継承しています。

詳解

Exception thrown during WAMP operations when the timeout is reached.


Wwise Unity Integration Documentation: Wamp.PublishHandler

  • Wamp
PublishHandler

◆ PublishHandler()

delegate void Wamp.PublishHandler ( string json )

Publish events are delegates registered with Subscribe.


Wwise Unity Integration Documentation: WaqlArgs クラス

全メンバ一覧
WaqlArgs クラス

WAAPI arguments containing a WAQL string. [詳解]

WaqlArgs の継承関係図
Args JsonSerializable

詳解

WAAPI arguments containing a WAQL string.


Wwise Unity Integration Documentation: WwiseChildModifiedInfo クラス

全メンバ一覧
WwiseChildModifiedInfo クラス

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics. [詳解]

WwiseChildModifiedInfo の継承関係図
JsonSerializable

詳解

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics.


Wwise Unity Integration Documentation: WwiseObjectInfo 構造体

全メンバ一覧
WwiseObjectInfo 構造体

Class containing the information returned by a WAAPI request for an object. [詳解]

詳解

Class containing the information returned by a WAAPI request for an object.


Wwise Unity Integration Documentation: WwiseObjectInfoJsonObject クラス

全メンバ一覧
WwiseObjectInfoJsonObject クラス

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo. [詳解]

詳解

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo.


Wwise Unity Integration Documentation: WwiseObjectInfoParent クラス

全メンバ一覧
WwiseObjectInfoParent クラス

Contains the GUID of the returned object's parent. [詳解]

詳解

Contains the GUID of the returned object's parent.


Wwise Unity Integration Documentation: WwiseRenameInfo クラス

全メンバ一覧
WwiseRenameInfo クラス

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic. [詳解]

WwiseRenameInfo の継承関係図
JsonSerializable

詳解

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic.


Wwise Unity Integration Documentation: クラス索引

クラス索引
a | b | c | e | g | j | o | r | s | t | w
a
AkRadialEmitter ArgsObject
j
TransportOptions
AkReverbZone ArgsPlay TransportState
ak AkRoom ArgsRename JsonSerializable Wamp.TimeoutException
AcousticTexture (AK.Wwise) AkRoomAwareManager ArgsTransport
o
w
AuxBus (AK.Wwise) AkRoomAwareObject
b
AkAmbient AkRoomManager Options AkWaapiUtilities.WaapiCommand
AkAmbientLargeModePositioner AkRoomPortal Bank (AK.Wwise)
r
WaapiHelper
AkAudioListener AkRoomPortalObstruction BaseGroupType (AK.Wwise) WaapiKeywords
AkBank AkSpatialAudioDebugDraw BaseType (AK.Wwise) RTPC (AK.Wwise) Wamp
AkEarlyReflections AkSpatialAudioEmitter
c
ReturnOptions WaqlArgs
AkEmitterObstructionOcclusion AkSpatialAudioListener ReturnTransport WwiseChildModifiedInfo
AkEnvironment AkState CallbackFlags (AK.Wwise) ReturnWwiseObjects WwiseObjectInfo
AkEnvironment.AkEnvironment_CompareByPriority AkSurfaceReflector
e
ReturnWwiseObjects WwiseObjectInfoJsonObject
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm AkSwitch
s
WwiseObjectInfoParent
AkEnvironmentPortal AkTriggerBase Event (AK.Wwise) WwiseRenameInfo
AkEvent AkWaapiUtilities AkEnvironmentPortal.EnvListWrapper State (AK.Wwise)
AkEventCallbackMsg AkWwiseTreeWAAPIDataSource ErrorDetails Switch (AK.Wwise)
AkGameObj AkWwiseTrigger ErrorMessage AkSpatialAudioListener.SpatialAudioListenerList
AkInitializer Args Wamp.ErrorException AkWaapiUtilities.SubscriptionInfo
AkListenerDistanceProbe ArgsCommand
g
SelectedWwiseObjects
AkMemBankLoader ArgsDisplayName
t
AkSurfaceReflector.GeometryData


Wwise Unity Integration Documentation: クラス階層

クラス階層
クラス階層一覧です。大雑把に文字符号順で並べられています。
[表示階層 123]
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
▼C AK.Wwise.BaseType | This type represents the base for all Wwise Types that require a GUID
C AK.Wwise.AcousticTexture | This type represents an Acoustic Texture
C AK.Wwise.AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C AK.Wwise.Bank | This type can be used to load/unload SoundBanks
▼C AK.Wwise.BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C AK.Wwise.State | This type can be used to set Wwise States
C AK.Wwise.Switch | This type can be used to set Switch values on gameobjects
C AK.Wwise.Event | This type can be used to post Events to the sound engine
C AK.Wwise.RTPC | This type can be used to set game parameter values to the sound engine
C AK.Wwise.Trigger | This type can be used to post triggers to the sound engine
C AK.Wwise.CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See AkEnvironmentやAkEnvironmentPortalをInspectorで使う
▼C AkEnvironment.AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. AkEnvironmentやAkEnvironmentPortalをInspectorで使う
C AkEnvironmentPortal.EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
▼C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkReverbZone | This component establishes a parent-child relationship between two Rooms and allows for sound propagation between them as if they were the same Room, without the need for a connecting Portal
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkSpatialAudioListener.SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C AkSurfaceReflector.GeometryData | The Spatial Audio Geometry Data. Can be used when calling AkSoundEngine.SetGeometry()
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in Wwiseイベントのトリガーを追加する
C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C AkWaapiUtilities.SubscriptionInfo | Class used to store information about a specific subscription
C AkWaapiUtilities.WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
C AkWwiseTrigger | This will call AkSoundEngine.PostTrigger() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
▼C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
▼C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C WaqlArgs | WAAPI arguments containing a WAQL string
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
▼C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C Wamp.ErrorException | Exception thrown during WAMP operations
C Wamp.TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent


Wwise Unity Integration Documentation: クラスメンバ

詳解ありクラスメンバの一覧です。各クラスメンバ詳解へのリンクがあります。

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • Add() : AkSpatialAudioListener.SpatialAudioListenerList
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • ClosePortal() : AkRoomPortal
  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • Delete() : AkWaapiUtilities
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnected() : AkWaapiUtilities
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • EnteredRoom() : AkRoomAwareObject
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- f -

  • FolderDisplaynames : WaapiKeywords

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetGeometryDataFromMesh() : AkSurfaceReflector
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • IsConnected() : AkWaapiUtilities
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader
  • IsPlayable() : AkWaapiUtilities

- l -

  • loadAsynchronous : AkBank
  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities
  • outerRadius : AkRadialEmitter

- p -

  • ParentRoom : AkReverbZone
  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • priority : AkRoom
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities
  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • RemoveReverbZone() : AkReverbZone , AkRoom
  • Rename() : AkWaapiUtilities
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • ReverbZone : AkReverbZone
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • sender : AkEventCallbackMsg
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • SetReverbZone() : AkReverbZone , AkRoom
  • soundEmitterObject : AkEvent
  • SpatialAudioListeners : AkSpatialAudioListener
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TheSpatialAudioListener : AkSpatialAudioListener
  • TogglePlayEvent() : AkWaapiUtilities
  • transitionDuration : AkEvent
  • TransitionRegionWidth : AkReverbZone
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • Trigger() : AkTriggerBase
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • UnloadBank() : AkBank
  • unloadTriggerList : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: クラスメンバ - 関数

- a -

  • Add() : AkSpatialAudioListener.SpatialAudioListenerList

- c -

  • ClosePortal() : AkRoomPortal

- d -

  • Delete() : AkWaapiUtilities
  • Disconnected() : AkWaapiUtilities

- e -

  • EnteredRoom() : AkRoomAwareObject
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetGeometryDataFromMesh() : AkSurfaceReflector
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • IsConnected() : AkWaapiUtilities
  • IsPlayable() : AkWaapiUtilities

- l -

  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities

- p -

  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities

- r -

  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • RemoveReverbZone() : AkReverbZone , AkRoom
  • Rename() : AkWaapiUtilities

- s -

  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • SetReverbZone() : AkReverbZone , AkRoom
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TogglePlayEvent() : AkWaapiUtilities
  • Trigger() : AkTriggerBase

- u -

  • UnloadBank() : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector


Wwise Unity Integration Documentation: クラスメンバ - 変数

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal

- f -

  • FolderDisplaynames : WaapiKeywords

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader

- l -

  • loadAsynchronous : AkBank

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • outerRadius : AkRadialEmitter

- p -

  • ParentRoom : AkReverbZone
  • priority : AkRoom

- q -

  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • ReverbZone : AkReverbZone
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • sender : AkEventCallbackMsg
  • soundEmitterObject : AkEvent

- t -

  • transitionDuration : AkEvent
  • TransitionRegionWidth : AkReverbZone
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • unloadTriggerList : AkBank

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: クラスメンバ - プロパティ

  • SpatialAudioListeners : AkSpatialAudioListener
  • TheSpatialAudioListener : AkSpatialAudioListener


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • AcousticTexture
AK.Wwise.AcousticTexture メンバ一覧

継承メンバを含む AK.Wwise.AcousticTexture の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • AuxBus
AK.Wwise.AuxBus メンバ一覧

継承メンバを含む AK.Wwise.AuxBus の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • Bank
AK.Wwise.Bank メンバ一覧

継承メンバを含む AK.Wwise.Bank の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • BaseGroupType
AK.Wwise.BaseGroupType メンバ一覧

継承メンバを含む AK.Wwise.BaseGroupType の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • BaseType
AK.Wwise.BaseType メンバ一覧

継承メンバを含む AK.Wwise.BaseType の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • CallbackFlags
AK.Wwise.CallbackFlags メンバ一覧

継承メンバを含む AK.Wwise.CallbackFlags の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • Event
AK.Wwise.Event メンバ一覧

継承メンバを含む AK.Wwise.Event の全メンバ一覧です。

ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(ulong gameObjectId) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count) | AK.Wwise.Event | inline
StopMIDI(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
StopMIDI() | AK.Wwise.Event | inline


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • RTPC
AK.Wwise.RTPC メンバ一覧

継承メンバを含む AK.Wwise.RTPC の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • State
AK.Wwise.State メンバ一覧

継承メンバを含む AK.Wwise.State の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • Switch
AK.Wwise.Switch メンバ一覧

継承メンバを含む AK.Wwise.Switch の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AK
  • Wwise
  • Trigger
AK.Wwise.Trigger メンバ一覧

継承メンバを含む AK.Wwise.Trigger の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkAmbient メンバ一覧

継承メンバを含む AkAmbient の全メンバ一覧です。

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: メンバ一覧

AkAmbientLargeModePositioner メンバ一覧

継承メンバを含む AkAmbientLargeModePositioner の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkAudioListener メンバ一覧

継承メンバを含む AkAudioListener の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkBank メンバ一覧

継承メンバを含む AkBank の全メンバ一覧です。

decodeBank AkBank
HandleEvent(UnityEngine.GameObject in_gameObject) | AkBank | inline
loadAsynchronous AkBank
saveDecodedBank AkBank
UnloadBank(UnityEngine.GameObject in_gameObject) | AkBank | inline


Wwise Unity Integration Documentation: メンバ一覧

AkEarlyReflections メンバ一覧

継承メンバを含む AkEarlyReflections の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkEmitterObstructionOcclusion メンバ一覧

継承メンバを含む AkEmitterObstructionOcclusion の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkEnvironment メンバ一覧

継承メンバを含む AkEnvironment の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AkEnvironment
  • AkEnvironment_CompareByPriority
AkEnvironment.AkEnvironment_CompareByPriority メンバ一覧

継承メンバを含む AkEnvironment.AkEnvironment_CompareByPriority の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm メンバ一覧

継承メンバを含む AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkEnvironmentPortal メンバ一覧

継承メンバを含む AkEnvironmentPortal の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AkEnvironmentPortal
  • EnvListWrapper
AkEnvironmentPortal.EnvListWrapper メンバ一覧

継承メンバを含む AkEnvironmentPortal.EnvListWrapper の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkEvent メンバ一覧

継承メンバを含む AkEvent の全メンバ一覧です。

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: メンバ一覧

AkEventCallbackMsg メンバ一覧

継承メンバを含む AkEventCallbackMsg の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkGameObj メンバ一覧

継承メンバを含む AkGameObj の全メンバ一覧です。

GetForward() | AkGameObj | inlinevirtual
GetPosition() | AkGameObj | inlinevirtual
GetUpward() | AkGameObj | inlinevirtual


Wwise Unity Integration Documentation: メンバ一覧

AkInitializer メンバ一覧

継承メンバを含む AkInitializer の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkListenerDistanceProbe メンバ一覧

継承メンバを含む AkListenerDistanceProbe の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkMemBankLoader メンバ一覧

継承メンバを含む AkMemBankLoader の全メンバ一覧です。

bankName | AkMemBankLoader |
isLocalizedBank | AkMemBankLoader |
LoadLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline
LoadNonLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline


Wwise Unity Integration Documentation: AkObstructionOcclusion.LayerMask

  • AkRoomPortalObstruction

◆ LayerMask

UnityEngine.LayerMask AkObstructionOcclusion.LayerMask = -1
inherited

Indicates which layers act as obstructers/occluders.


Wwise Unity Integration Documentation: AkObstructionOcclusion.maxDistance

  • AkRoomPortalObstruction

◆ maxDistance

float AkObstructionOcclusion.maxDistance = -1.0f
inherited

The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance.


Wwise Unity Integration Documentation: AkObstructionOcclusion.refreshInterval

  • AkRoomPortalObstruction

◆ refreshInterval

float AkObstructionOcclusion.refreshInterval = 1
inherited

The number of seconds between obstruction/occlusion checks.


Wwise Unity Integration Documentation: AkObstructionOcclusion.fadeTime

  • AkRoomPortalObstruction

◆ fadeTime

float AkObstructionOcclusion.fadeTime = 0.5f
inherited

The number of seconds for fade ins and fade outs.


Wwise Unity Integration Documentation: メンバ一覧

AkRadialEmitter メンバ一覧

継承メンバを含む AkRadialEmitter の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkReverbZone メンバ一覧

継承メンバを含む AkReverbZone の全メンバ一覧です。

ParentRoom AkReverbZone
RemoveReverbZone(AkRoom reverbZone) | AkReverbZone | inlinestatic
RemoveReverbZone() | AkReverbZone | inline
ReverbZone AkReverbZone
SetReverbZone(AkRoom reverbZone, AkRoom parentRoom, float transitionRegionWidth) | AkReverbZone | inlinestatic
SetReverbZone() | AkReverbZone | inline


Wwise Unity Integration Documentation: メンバ一覧

AkRoom メンバ一覧

継承メンバを含む AkRoom の全メンバ一覧です。

GetID() | AkRoom | inline
priority AkRoom
RemoveReverbZone() | AkRoom | inline
reverbAuxBus AkRoom
reverbLevel AkRoom
roomToneAuxSend AkRoom
roomToneEvent AkRoom
SetReverbZone(AkRoom parentRoom, float transitionRegionWidth) | AkRoom | inline


Wwise Unity Integration Documentation: メンバ一覧

AkRoomAwareManager メンバ一覧

継承メンバを含む AkRoomAwareManager の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkRoomAwareObject メンバ一覧

継承メンバを含む AkRoomAwareObject の全メンバ一覧です。

EnteredRoom(AkRoom room) | AkRoomAwareObject | inline
ExitedRoom(AkRoom room) | AkRoomAwareObject | inline


Wwise Unity Integration Documentation: メンバ一覧

AkRoomManager メンバ一覧

継承メンバを含む AkRoomManager の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkRoomPortal メンバ一覧

継承メンバを含む AkRoomPortal の全メンバ一覧です。

ClosePortal(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
GetID() | AkRoomPortal | inline
HandleEvent(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
MAX_ROOMS_PER_PORTAL | AkRoomPortal | static


Wwise Unity Integration Documentation: メンバ一覧

AkRoomPortalObstruction メンバ一覧

継承メンバを含む AkRoomPortalObstruction の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkSpatialAudioDebugDraw メンバ一覧

継承メンバを含む AkSpatialAudioDebugDraw の全メンバ一覧です。

drawDiffractionPaths | AkSpatialAudioDebugDraw
drawFirstOrderReflections | AkSpatialAudioDebugDraw
drawHigherOrderReflections | AkSpatialAudioDebugDraw
drawSecondOrderReflections | AkSpatialAudioDebugDraw


Wwise Unity Integration Documentation: メンバ一覧

AkSpatialAudioEmitter メンバ一覧

継承メンバを含む AkSpatialAudioEmitter の全メンバ一覧です。

diffractionMaxEdges | AkSpatialAudioEmitter
diffractionMaxPathLength | AkSpatialAudioEmitter
diffractionMaxPaths | AkSpatialAudioEmitter
drawDiffractionPaths | AkSpatialAudioEmitter
drawFirstOrderReflections | AkSpatialAudioEmitter
drawHigherOrderReflections | AkSpatialAudioEmitter
drawSecondOrderReflections | AkSpatialAudioEmitter
reflectAuxBus | AkSpatialAudioEmitter
reflectionMaxPathLength | AkSpatialAudioEmitter
reflectionsAuxBusGain | AkSpatialAudioEmitter
reflectionsOrder | AkSpatialAudioEmitter
roomReverbAuxBusGain | AkSpatialAudioEmitter


Wwise Unity Integration Documentation: メンバ一覧

AkSpatialAudioListener メンバ一覧

継承メンバを含む AkSpatialAudioListener の全メンバ一覧です。

SpatialAudioListeners | AkSpatialAudioListener | static
TheSpatialAudioListener | AkSpatialAudioListener | static


Wwise Unity Integration Documentation: メンバ一覧

  • AkSpatialAudioListener
  • SpatialAudioListenerList
AkSpatialAudioListener.SpatialAudioListenerList メンバ一覧

継承メンバを含む AkSpatialAudioListener.SpatialAudioListenerList の全メンバ一覧です。

Add(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline
Remove(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline


Wwise Unity Integration Documentation: メンバ一覧

AkState メンバ一覧

継承メンバを含む AkState の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkSurfaceReflector メンバ一覧

継承メンバを含む AkSurfaceReflector の全メンバ一覧です。

AcousticTextures | AkSurfaceReflector |
AssociatedRoom | AkSurfaceReflector |
EnableDiffraction | AkSurfaceReflector |
EnableDiffractionOnBoundaryEdges | AkSurfaceReflector |
GetGeometryDataFromMesh(UnityEngine.Mesh mesh, ref GeometryData geometryData, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="") | AkSurfaceReflector | inlinestatic
Mesh | AkSurfaceReflector |
RemoveGeometry() | AkSurfaceReflector | inline
RemoveGeometryInstance() | AkSurfaceReflector | inline
SetGeometry() | AkSurfaceReflector | inline
SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="") | AkSurfaceReflector | inlinestatic
SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform, bool useForReflectionAndDiffraction) | AkSurfaceReflector | inlinestatic
SetGeometryInstance() | AkSurfaceReflector | inline
TransmissionLossValues | AkSurfaceReflector |
UpdateGeometry() | AkSurfaceReflector | inline


Wwise Unity Integration Documentation: メンバ一覧

AkSwitch メンバ一覧

継承メンバを含む AkSwitch の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkTriggerBase メンバ一覧

継承メンバを含む AkTriggerBase の全メンバ一覧です。

Trigger(UnityEngine.GameObject in_gameObject) AkTriggerBase


Wwise Unity Integration Documentation: AkTriggerHandler.useOtherObject

  • AkWwiseTrigger

◆ useOtherObject

bool AkTriggerHandler.useOtherObject = false
inherited

This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object.


Wwise Unity Integration Documentation: AkTriggerHandler.triggerTypes

  • AkWwiseTrigger

◆ triggerTypes

System.Collections.Generic.Dictionary<uint, string> AkTriggerHandler.triggerTypes = AkTriggerBase.GetAllDerivedTypes()
staticinherited

Will contain the types of all the triggers derived from AkTriggerBase at runtime


Wwise Unity Integration Documentation: AkTriggerHandler.MAX_NB_TRIGGERS

  • AkWwiseTrigger

◆ MAX_NB_TRIGGERS

const int AkTriggerHandler.MAX_NB_TRIGGERS = 32
staticinherited

Since our mask is a 32 bits integer, we can't have more than 32 triggers


Wwise Unity Integration Documentation: AkTriggerHandler.triggerList

  • AkWwiseTrigger

◆ triggerList

System.Collections.Generic.List<int> AkTriggerHandler.triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
inherited

List containing the enabled triggers.


Wwise Unity Integration Documentation: メンバ一覧

AkWaapiUtilities メンバ一覧

継承メンバを含む AkWaapiUtilities の全メンバ一覧です。

Connected | AkWaapiUtilities | static
Delete(System.Guid guid) | AkWaapiUtilities | inlinestatic
Disconnected() | AkWaapiUtilities | inlinestatic
Disconnecting | AkWaapiUtilities | static
GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options) | AkWaapiUtilities | inlinestatic
GetResultDelegate< T >(T result) | AkWaapiUtilities |
GetResultListDelegate< T >(List< T > result) | AkWaapiUtilities |
GetStatusString() | AkWaapiUtilities | inlinestatic
GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
IsConnected() | AkWaapiUtilities | inlinestatic
IsPlayable(WwiseObjectType type) | AkWaapiUtilities | inlinestatic
OpenSoundBankInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
OpenWorkUnitInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
ParseChildAddedOrRemoved(string json) | AkWaapiUtilities | inlinestatic
ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects) | AkWaapiUtilities | inlinestatic
ParseRenameObject(string json) | AkWaapiUtilities | inlinestatic
ParseSelectedObjects(string json) | AkWaapiUtilities | inlinestatic
QueueCommand(string uri, string args, string options) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
QueueConsumed | AkWaapiUtilities | static
Rename(System.Guid guid, string newName) | AkWaapiUtilities | inlinestatic
Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
SelectObjectInAuthoring(System.Guid guid) | AkWaapiUtilities | inlinestatic
StopAllTransports() | AkWaapiUtilities | inlinestatic
Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback) | AkWaapiUtilities | inlinestatic
TogglePlayEvent(WwiseObjectType objectType, System.Guid guid) | AkWaapiUtilities | inlinestatic
Unsubscribe(uint id) | AkWaapiUtilities | inlinestatic


Wwise Unity Integration Documentation: メンバ一覧

  • AkWaapiUtilities
  • SubscriptionInfo
AkWaapiUtilities.SubscriptionInfo メンバ一覧

継承メンバを含む AkWaapiUtilities.SubscriptionInfo の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

AkWwiseTreeWAAPIDataSource メンバ一覧

継承メンバを含む AkWwiseTreeWAAPIDataSource の全メンバ一覧です。

SubscribeTopics() AkWwiseTreeWAAPIDataSource inline


Wwise Unity Integration Documentation: メンバ一覧

AkWwiseTrigger メンバ一覧

継承メンバを含む AkWwiseTrigger の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

Args メンバ一覧

継承メンバを含む Args の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsCommand メンバ一覧

継承メンバを含む ArgsCommand の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsDisplayName メンバ一覧

継承メンバを含む ArgsDisplayName の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsObject メンバ一覧

継承メンバを含む ArgsObject の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsPlay メンバ一覧

継承メンバを含む ArgsPlay の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsRename メンバ一覧

継承メンバを含む ArgsRename の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ArgsTransport メンバ一覧

継承メンバを含む ArgsTransport の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ErrorDetails メンバ一覧

継承メンバを含む ErrorDetails の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ErrorMessage メンバ一覧

継承メンバを含む ErrorMessage の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

JsonSerializable メンバ一覧

継承メンバを含む JsonSerializable の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

Options メンバ一覧

継承メンバを含む Options の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ReturnOptions メンバ一覧

継承メンバを含む ReturnOptions の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ReturnTransport メンバ一覧

継承メンバを含む ReturnTransport の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

ReturnWwiseObjects< T > メンバ一覧

継承メンバを含む ReturnWwiseObjects< T > の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

SelectedWwiseObjects メンバ一覧

継承メンバを含む SelectedWwiseObjects の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

TransportOptions メンバ一覧

継承メンバを含む TransportOptions の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

TransportState メンバ一覧

継承メンバを含む TransportState の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WaapiHelper メンバ一覧

継承メンバを含む WaapiHelper の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WaapiKeywords メンバ一覧

継承メンバを含む WaapiKeywords の全メンバ一覧です。

FolderDisplaynames | WaapiKeywords | static
typeStringDict | WaapiKeywords | static
WwiseObjectTypeStrings | WaapiKeywords | static


Wwise Unity Integration Documentation: メンバ一覧

Wamp メンバ一覧

継承メンバを含む Wamp の全メンバ一覧です。

PublishHandler(string json) Wamp


Wwise Unity Integration Documentation: メンバ一覧

  • Wamp
  • ErrorException
Wamp.ErrorException メンバ一覧

継承メンバを含む Wamp.ErrorException の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • Wamp
  • TimeoutException
Wamp.TimeoutException メンバ一覧

継承メンバを含む Wamp.TimeoutException の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WaqlArgs メンバ一覧

継承メンバを含む WaqlArgs の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WwiseChildModifiedInfo メンバ一覧

継承メンバを含む WwiseChildModifiedInfo の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WwiseObjectInfoJsonObject メンバ一覧

継承メンバを含む WwiseObjectInfoJsonObject の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WwiseObjectInfoParent メンバ一覧

継承メンバを含む WwiseObjectInfoParent の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WwiseRenameInfo メンバ一覧

継承メンバを含む WwiseRenameInfo の全メンバ一覧です。


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten/WAAPI ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
  • WAAPI
WAAPI ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
Runtime ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
Wwise ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor/WwiseWindows ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
  • WwiseWindows
WwiseWindows ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
Editor ディレクトリリファレンス

ディレクトリ


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
WwiseTypes ディレクトリリファレンス

ディレクトリ


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ja ディレクトリリファレンス

  • Documentation
  • private
  • Doxygen_ja
Doxygen_ja ディレクトリリファレンス


Wwise Unity Integration Documentation: Documentation/private ディレクトリリファレンス

  • Documentation
  • private
private ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour/Runtime ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
  • Runtime
Runtime ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes/WwiseTypes ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
  • WwiseTypes
WwiseTypes ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
API ディレクトリリファレンス


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ja/Common ディレクトリリファレンス

  • Documentation
  • private
  • Doxygen_ja
  • Common
Common ディレクトリリファレンス


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ja/AppleCommon/ReleaseNotes ディレクトリリファレンス

  • Documentation
  • private
  • Doxygen_ja
  • AppleCommon
  • ReleaseNotes
ReleaseNotes ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
MonoBehaviour ディレクトリリファレンス

ディレクトリ


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ja/Common/ReleaseNotes ディレクトリリファレンス

  • Documentation
  • private
  • Doxygen_ja
  • Common
  • ReleaseNotes
ReleaseNotes ディレクトリリファレンス


Wwise Unity Integration Documentation: Documentation/private/Doxygen_ja/AppleCommon ディレクトリリファレンス

  • Documentation
  • private
  • Doxygen_ja
  • AppleCommon
AppleCommon ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten ディレクトリリファレンス

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
Handwritten ディレクトリリファレンス

ディレクトリ


Wwise Unity Integration Documentation: Integration ディレクトリリファレンス

  • Integration
Integration ディレクトリリファレンス


Wwise Unity Integration Documentation: Documentation ディレクトリリファレンス

  • Documentation
Documentation ディレクトリリファレンス


Wwise Unity Integration Documentation: Integration/Assets ディレクトリリファレンス

  • Integration
  • Assets
Assets ディレクトリリファレンス


Wwise Unity Integration Documentation: 諸情報

諸情報
諸情報の一覧です。
WAAPIユーティリティ


Wwise Unity Integration Documentation: メンバ一覧

  • AkSurfaceReflector
  • GeometryData
AkSurfaceReflector.GeometryData メンバ一覧

継承メンバを含む AkSurfaceReflector.GeometryData の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

  • AkWaapiUtilities
  • WaapiCommand
AkWaapiUtilities.WaapiCommand メンバ一覧

継承メンバを含む AkWaapiUtilities.WaapiCommand の全メンバ一覧です。


Wwise Unity Integration Documentation: メンバ一覧

WwiseObjectInfo メンバ一覧

継承メンバを含む WwiseObjectInfo の全メンバ一覧です。